Page 1 sur 2

Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 04 juin 2018, 21:55
par TiTerm
Bonjour,

J'ai plusieurs modules zwave fibaro et aucun ne m'a posé de problème, mais avec celui là, rien à faire, je n'arrive pas à le faire reconnaitre.

Il s'agit donc du Fibaro FGFS-101 ZW5 v3.3

Voici les différents screenshots (si jamais il y a besoin d'autres informations, je les fournis sans aucun problème).
ScreenCapture1.png
ScreenCapture1.png (291.14 Kio) Consulté 1746 fois
ScreenCapture2.png
ScreenCapture2.png (296.39 Kio) Consulté 1746 fois
ScreenCapture3.png
ScreenCapture3.png (480.4 Kio) Consulté 1746 fois

Re: Fibaro FGFS-101 ZW5 v3.3 non reconnu

Publié : 04 juin 2018, 22:02
par TiTerm
Sreeenshot (suite)
ScreenCapture4.jpg
ScreenCapture4.jpg (126.24 Kio) Consulté 1744 fois
Il y a très peu de commande, et quand j'ai essayé de les régénérer, soit cela ne fait rien quand j'ai fait complété, soit cela débouche sur plus de commande du tout quand je fais regénérer la totale.

Voilà, j'espère que cela sera suffisant pour pouvoir ajouter ce device.

Merci d'avance,

Re: Fibaro FGFS-101 ZW5 v3.3 non reconnu

Publié : 06 juin 2018, 20:12
par TiTerm
Hello @nechry

Bon, ben j'ai fait la modif dans le code en me basant sur un modèle déjà géré mais dans une version plus ancienne.
Tout fonctionne correctement chez moi.
Du coup, j'ai fait un pull request avec les modifications.

A+

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 07 juin 2018, 16:35
par nechry
c'est parfait, sauf que c'est plus moi qui merge, j'ai de PR depuis mars toujours pas mergé...

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 07 juin 2018, 20:49
par TiTerm
Bon, je suppose que la personne qui a repris le flambeau regarde ce forum ou les PR de temps en temps.
c'est vrai que j'ai vu qu'il y avait 6 autres PR mais j'avais pas regardé leurs dates de soumission.

On dirait que c'est sarakha qui fait les merges, mais vu son activité sur les forums/blog, y a des chances qu'il sache plus où donner de la tête...

Merci de ta réponse et de ton article sur l'API z-wave :)

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 10 juin 2018, 22:16
par nechry
avec plaisir, j'ai corrigé, mes images qui ne loadaient pas toujours si tu avais eux le problème

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 23 juin 2018, 19:18
par yadert
hello @TiTerm

J'ai le même soucis que toi avec ce module.
J'en ai plusieurs fonctionnels sur mon installation zwave mais le dernier que j'ai acheté est une nouvelle version (v3.3). Malgré avoir recharger les configs depuis les paramètres du plugin...
Peux tu me dire comment as tu corrigé le problème ?
Comment demandé la prise en charge d'un module à l'équipe ?
Merci pour vos réponses
Yadert.

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 27 juin 2018, 13:43
par Chrissy2
Bonjour j'ai le même problème. La dernière version du module détecteur d’inondation Fibaro n'est pas reconnu.
@nechry on a besoin de ton aide, merci!

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 27 juin 2018, 14:46
par yadert
Re-bonjour,
on a tous acheté le même module en promo chez amazon ;-)
Par ailleurs, ce petit soucis soulève une question :
Quelqu'un sait-il comment remonter ce genre de problème à l'équipe ? doit-on passer par le forum ? ouvrir un ticket ?
Merci

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 30 juin 2018, 13:52
par mortyre
TICKET bien sur

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 30 juin 2018, 21:42
par kcofoni
Bonjour,

J'ai exactement le même problème que vous.
Le FGFS-101 ZW5 v3.2 que j'ai acheté il y a plusieurs semaines n'a posé aucun problème à l'inclusion. En revanche j'obtiens exactement les mêmes symptômes que ceux cités plus haut avec la version 3.3.

Est-il utile que je fasse également un ticket ?

Pourriez-vous m'indiquer la modif à faire dans le code pour que ça marche, ça me permettrait de partir en vacances tout en protégeant ma buanderie d'éventuelles fuites et en attendant d'appliquer le patch en attendant qu'il soit dispo.

Merci

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 02 juil. 2018, 21:16
par yadert

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 12 juil. 2018, 09:53
par TiTerm
Bonjour à tous,

Quand j'ai fait les modifications pour ajouter le support de cette version, J'ai fait un Pull Request auprès sur le github du plugin Z-Wave (un PR, c'est une demande d'intégration du code que j'ai fait dans le code du plugin, cela simplifie le travail puisqu'il ne fait qu'une intégration et une recette).

De mon côté, voilà comment j'ai procédé en attendant que le module soit officiellement supporté.

Il faut éditer un fichier et faire une copie de 2 autres (rien de bien méchant) mais il faudra le faire directement sur la boxjeedom en ssh/root, donc attention si vous n'êtes pas familier avec ce genre de manip.
  • Premier fichier: on duplique le fichier existant de la version précédente du module en modifiant le nom pour prendre l'id du nouveau module
    Source: core/config/devices/fibaro_271/271.2817.4098_fgfs101zw5.flood.sensor.json
    Copie : core/config/devices/fibaro_271/271.2817.4099_fgfs101zw5.flood.sensor.json
    /!\ Attention au propriétaire, groupe et droit du fichier, remettre les même que la source avec chown, chgrp et chmod
  • Second fichier: on duplique le fichier existant pour l'image du module dans le plugin en modifiant le nom pour prendre l'id du nouveau module
    Source: core/config/devices/fibaro_271/271.2817.4098_fgfs101zw5.flood.sensor.jpg
    Copie: core/config/devices/fibaro_271/271.2817.4099_fgfs101zw5.flood.sensor.jpg
    /!\ Attention au propriétaire, groupe et droit du fichier, remettre les même que la source avec chown, chgrp et chmod
  • Dernier fichier: Il faut éditer le fichier resources/openzwaved/config/manufacturer_specific.xml
    comme on le voit dans mon Pull Request sur gitHub : Source
    Il s'agit ici d'ajouter la nouvelle référence du module
    Après cette ligne la qui doit exister

    Code : Tout sélectionner

    <Product type="0b01" id="1002" name="FGFS101 Zwave+ Flood Sensor" config="fibaro/fgfs101zw5.xml" />
    On ajoute cette ligne la

    Code : Tout sélectionner

    <Product type="0b01" id="1003" name="FGFS101 Zwave+ Flood Sensor" config="fibaro/fgfs101zw5.xml" />
    Pour obtenir ca

    Code : Tout sélectionner

    <Product type="0b01" id="1002" name="FGFS101 Zwave+ Flood Sensor" config="fibaro/fgfs101zw5.xml" />
    <Product type="0b01" id="1003" name="FGFS101 Zwave+ Flood Sensor" config="fibaro/fgfs101zw5.xml" />
    <Product type="0b01" id="2002" name="FGFS101 Zwave+ Flood Sensor" config="fibaro/fgfs101zw5.xml" />
    

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 13 juil. 2018, 14:09
par yadert
Super !
Un grand merci pour ces infos.
En plus ça ne semble pas super complexe à faire. (quand c'est bien expliqué :D )
Je vais attaquer ça ce week end.

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 13 juil. 2018, 19:56
par nykiizz
Merci pour ton tuto TiTerm ça marche chez moi :)
Il me manque les paramètres dans la configuration du module mais je tenterai une exclusion/inclusion plus tard pour corriger le problème.

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 14 juil. 2018, 13:11
par TiTerm
Cool, Heureux d'avoir pu rendre service :)
Pour moi, les paramètres sont bien là, donc effectivement, refaire une inclusion devrait corriger le pb.

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 20 juil. 2018, 20:27
par kcofoni
Un grand merci TiTerm !! je viens d'appliquer ta procédure à la lettre et d'inclure un Flood Sensor v3.3 avec succès !

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 20 août 2018, 07:58
par Domsrx06
Bonjour
Pour un nouvel utilisateur Jeedom (2 semaines) la procedure ssh/root est complexe.
Quand la version v3.3 sera telle supportée nativement par inclusion standard dans la Jeedom Smart ?
Faut il que je fasse une demande de support (ticket) ou l'évolution est déjà en cours par l'équipe Jeedom ?
(vu le nombre de personnes qui rencontrent le pb)
Merci

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 06 oct. 2018, 12:08
par fredyl7
Bonjour à tous,

J'ai dans l'idée d'acheter un nouveau Fibaro Flood Sensor, mais je vois que les merges Github ne sont toujours pas pris en compte..
Il se passe quoi ?
Plus rien ne va évoluer ? :?
Y a quand même des Pull de Janvier :shock:

Parce que des nouveaux matériels ZWave il y en a régulièrement, ça parait pas hyper complexe de valider les Merges, si ?
Modifier manuellement les fichiers, c'est pas compliqué, mais pas cool de craindre ensuite les updates des Plugins..

Si quelqu'un a eu une réponse de la team sur le sujet, merci de partager. ;)

Bon weekend à tous.

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Publié : 06 oct. 2018, 13:03
par mortyre
Pour avoir une réponse de la société Jeedom, sur les PR, intégrations autres, il faut passer par le Support donc par un ticket. Vous pouvez ensuite partager la réponse ici pour la communauté