Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Fibaro Smart Implant FGBS222

Uniquement pour apporter des contributions aux configurations OpenZwave (corrections de configurations erronées ou compléments de configurations manquantes). Si vous avez un souci avec votre module, merci de poster dans Périphériques Z-Wave !

Modérateur : nechry

Répondre
arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Fibaro Smart Implant FGBS222

Message par arnog23 » 06 avr. 2019, 18:52

Bonjour,

Une intégration du Fibaro Smart Implant FGBS222 est-elle prévue ? Pour le moment il est seulement reconnu en tant que module générique.

En regardant dans les configs du plugin Zwave (Master ou Beta), je ne vois aucun fichier relatif à ce module.

Ci-joint ce que j'obtiens au niveau de la config.

S'il y a besoin de faire des tests pour son intégration, j'en ai un sous la main.

Merci.
FGBS222_Resume.png
FGBS222_Resume.png (48.6 Kio) Consulté 1622 fois
FGBS222_Valeurs.png
FGBS222_Valeurs.png (42.86 Kio) Consulté 1622 fois
FGBS222_Parametres.png
FGBS222_Parametres.png (10.54 Kio) Consulté 1622 fois

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 06 avr. 2019, 18:54

FGBS222_Associations.png
FGBS222_Associations.png (23.97 Kio) Consulté 1620 fois
FGBS222_Associations.png
FGBS222_Associations.png (23.97 Kio) Consulté 1620 fois
FGBS222_Commandes.png
FGBS222_Commandes.png (239.09 Kio) Consulté 1620 fois
Pièces jointes
FGBS222_Systemes.png
FGBS222_Systemes.png (48.27 Kio) Consulté 1620 fois

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 06 avr. 2019, 18:55

FGBS222_Arbre_Zwave.txt
(20.65 Kio) Téléchargé 118 fois

Avatar de l’utilisateur
akenad
Actif
Messages : 695
Inscription : 27 oct. 2017, 11:39

Re: Fibaro Smart Implant FGBS222

Message par akenad » 08 avr. 2019, 07:09

Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 13 avr. 2019, 22:51

Bonsoir,

Merci @akenad pour ton retour d'expérience.

J'ai ajouté le fichier "fgbs222.xml" dans le répertoire "/plugins/openzwave/resources/openzwaved/config/"
J'ai ajouté le fichier "271.1282.4096_fgbs222.smart.implant.json" dans le répertoire "/core/config/devices/fibaro_271"
J'ai ajouté le fichier "271.1282.4096_fgbs222.smart.implant.png" dans le répertoire "/core/config/devices/fibaro_271"

Mais cela n'a pas suffit pour que le module soit détecté correctement. Il a aussi fallu que j'ajoute la ligne suivante :

Code : Tout sélectionner

<Product type="0502" id="1000" name="FGBS222 Smart Implant" config="fibaro/fgbs222.xml" />
dans le fichier "/plugins/openzwave/resources/openzwaved/config/manufacturer_specific.xml" dans la balise :

Code : Tout sélectionner

<Manufacturer id="010f" name="FIBARO System">
Voici donc ce que j'obtiens maintenant :
Equipement.png
Equipement.png (34.31 Kio) Consulté 1543 fois
Résumé.png
Résumé.png (46.64 Kio) Consulté 1543 fois
Paramètres.png
Paramètres.png (192.06 Kio) Consulté 1543 fois

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 13 avr. 2019, 22:53

Et pour les commandes créés :
Commandes.png
Commandes.png (79.88 Kio) Consulté 1539 fois
La modification des paramètres (20 et 21) semblent bien fonctionner. Je les ai passé en normalement ouvert pour mes tests.

En revanche, l'état des switch ne remonte pas automatiquement. Il faut forcer leur mise à jour pour avoir le bon statut.

IN_OFF.png
IN_OFF.png (50 Kio) Consulté 1539 fois
IN_ON.png
IN_ON.png (51.44 Kio) Consulté 1539 fois

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 10 mai 2019, 00:13

Bonsoir,

J'appelle à l'aide, je commence à craquer. Je me suis inscrit sur Github et j'ai réussi à charger localement sur mon PC le fichier FGBS222.xml. Mais je ne parviens pas à le mettre dans la box Jeedom. Je vois bien tous les fichiers xml dans le répertoire openzwaved, mais impossible d'y glisser le nouveau fichier. Est-ce parce que je le fais sur une box? Ou j'ai un problème de droit?
Je cherche par la même occasion à remplacer le fichier "manufacturer_specific.xml" par sa mise à jour trouvée également sur Github et qui intègre déjà la bonne ligne de code. idem, impossible pour moi.
Et enfin, je ne sais même pas ou chercher le fichier de config JSON ni l'image en PNG.
J'accepte qu'on me dise que je suis nul, à condition qu'on m'explique comment faire :) :).
J'ai 4 modules qui trônent sur le buffet de cuisine, à force d'attendre ils vont rouiller...
Merci par avance aux âmes charitables qui auront pitié de mes nerfs.
François

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 10 mai 2019, 00:57

Je m'auto-questionne sur le JPG : puis-je le créer moi même? c'est un JPG tout bête, seul le nom est important? Ou pas??
Et pour le JSON, ne faut-il pas faire un copié collé du fichier proposé par Akenad ? Dans un fichier txt renommé?
Merci.

Francois

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 10 mai 2019, 15:45

Bonjour,
Je viens de supprimer mon post précédent parce que je crois que j'étais parti sur une piste juste délirante. Et donc maintenant ça fonctionne (avant paramétrage dans mon appli)

voici ce que j'ai fait:
1) utilisation du plugin Jeexplore. Très sympa :)
2) création JSON en copiant le fichier proposé par Akenad, en lui donnant le bon nom :"271.1282.4096_fgbs222.smart.implant.json" et en partant d'une copie d'un JSON existant que j'ai préalablement dupliqué sur place.
3) création du JPG en100x100 et en lui donnant le bon nom "271.1282.4096_fgbs222.smart.implant.jpg", en respectant la taille de l'image, j'ai maintenant une belle photo...
4) j'ai récupéré le fichier "FGBS22.xml" sur Github et j'ai fait comme pour le JSON, en partant d'une copie d'un XML existant pour être reconnu en XML dans la Jeedom Smart. Donc un simple copié collé du code.
5) J'ai enfin ajouté la ligne de code dans le fichier "manufacturer_specific.xml"
6) De retour sur l'équipement, je recharge la configuration, et rien ne se passe sauf l’apparition du JPG que j'ai créé.
7) Il faut exclure et inclure à nouveau le FGBS222 ... Et c'est bon...

François

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 12 mai 2019, 00:37

Je continue mon monologue... Ça semblait pourtant bon.
En fait ça ressemble à du bon, mais le fonctionnement laisse à désirer, faute de configuration correcte de ma part.
Je pilote bien la sortie 1 en zwave, mais pas de sortie 2, et les entrées et sorties sont reliées, impossible de les rendre indépendantes et de recevoir un état. Bref, je laisse tomber à contrecœur, je vais attendre l'intégration officielle.
Bon courage à ceux qui comme moi voudront essayer de profiter d'un module capteur qui parait juste parfait.

François

dams_raspberrypi
Timide
Messages : 7
Inscription : 24 mars 2019, 17:11

Re: Fibaro Smart Implant FGBS222

Message par dams_raspberrypi » 12 mai 2019, 14:05

bonjour,

merci @akenad, @arnog23 et @FrancoisM

les fichiers xml et jpg du FGBS-222 sont bien pris en compte (fgbs222.xml et 271.1282.4096_fgbs222.smart.implant.jpg).
par contre, le fichier JSON (271.1282.4096_fgbs222.smart.implant.json) n'est pas reconnu car je suis obligé de créer les commandes manuellement.
j'ai pourtant bien exclu le smart implant après avoir inclut ces 3 fichiers.

j'ai pris l'exemple donné par akenad, mais je ne sais pas quoi mettre pour le champs "comlink" ?
je suis preneur si vous avez un exemple de fichier JSON fonctionnel.

@FrancoisM: pour piloter la sortie 2, j'utilise l'instance 3 (je ne sais pas pourquoi mais chez moi, la sortie 1 est pilotable avec l'instance 1 ou 2):
Nom: Out1_ON / Type: Action / Instance: 2 / Classe: 37 / Index: 0 / Commande: type=setvalue&value=255
Nom: Out1_OFF / Type: Action / Instance: 2 / Classe: 37 / Index: 0 / Commande: type=setvalue&value=0
Nom: Out2_ON / Type: Action / Instance: 3 / Classe: 37 / Index: 0 / Commande: type=setvalue&value=255
Nom: Out2_OFF / Type: Action / Instance: 3 / Classe: 37 / Index: 0 / Commande: type=setvalue&value=0

merci

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 12 mai 2019, 16:29

Merci Dams pour le retour concernant les instances. J'ai essayé toutes les instances jusque 15, rien n'y fait. Je parviens à faire monter ma porte de garage, mais impossible de la faire descendre avec la sortie 2. En plus, je souhaite utiliser les entrées pour valider la position de la porte, mais pour cela il faut arriver à rendre les entrées et les sorties indépendantes, je n'y arrive pas non plus. Avec une Box Fibaro (celle du copain), ça marche en moins de 15 minutes m'a-t-il dit, le plus long étant de faire le câblage. Mais j'ai choisi Jeedom, je ne vais pas changer pour si peu, je reste motivé :)

Cordialement.

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 13 mai 2019, 10:22

Petite mise à jour,

En faisant une nouvelle exclusion puis une inclusion cette fois "non sécurisée", j'accède à 3 instances. Instance 1 et 2 redondantes puisqu'elles concernent IN1 et OUT1 et instance 3 pour IN2 et OUT2.
Mais je ne parviens toujours pas à désynchroniser IN1/OUT1 et IN2/OUT2, même en configurant le paramètre 20 et 21 en "Alarme normalement ouverte" quand l'alarme passe à fermé sur IN1, ça me ferme OUT1 et le statut d'alarme ne remplit pas sa fonction, impossible de récupérer le retour "fermé" sur l'entrée 1.

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 23 mai 2019, 16:48

Bonjour,

Depuis une semaine j'utilisais les FGBS 222 en contacts sec commandés et j'ai eu en une semaine 2 plantages, la box m'indiquant que les nœuds étaient présumés morts. Pas plus inquiet que ça, en rafraichissant, ça repartait parfaitement.
Ce matin, J'ai fait la MAJ du plugin openzwave. Et depuis mes 2 FGBS-22 ne fonctionnent plus du tout. Pour l'un des 2, les commandes ont été effacées, et pour les 2, la photo du FGBS a disparu.
La box fonctionne maintenant au ralenti, impossible de naviguer dans les menus, plantages à répétition. Bref, une galère.
Je peux refaire ce que j'avais fait pour intégrer les smart implant, mais je me demandais si vous aviez eu cette même expérience que moi, ce qui toutefois me paraitrait assez logique si le répertoire openzwave a été réitinitialisé.

Enfin, petite question, est-il préférable d'exclure ou de supprimer l'équipement dans ce cas précis?

Merci.

François

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 23 mai 2019, 22:49

Alors, pour réparer, dans l'ordre:
* exclusion des modules - du coup plus rien ne plante
* remise en place du fichier "271.1282.4096_fgbs222.smart.implant.json" dans le répertoire "/core/config/devices/fibaro_271"
* remise en place du fichier "271.1282.4096_fgbs222.smart.implant.png" dans le répertoire "/core/config/devices/fibaro_271"
* ajout de la fameuse ligne "<Product type="0502" id="1000" name="FGBS222 Smart Implant" config="fibaro/fgbs222.xml" />" dans le fichier "/plugins/openzwave/resources/openzwaved/config/manufacturer_specific.xml"
* nouvelle inclusion (non sécurisée)
* réglage de la configuration et des commandes.
... c'est reparti comme avant.
Bon, toujours pas de possibilité de désynchroniser les entrées des sorties, mais ça fonctionne au moins pour le basique.

Francois

dams_raspberrypi
Timide
Messages : 7
Inscription : 24 mars 2019, 17:11

Re: Fibaro Smart Implant FGBS222

Message par dams_raspberrypi » 23 mai 2019, 22:57

bonjour François,

pourrais-tu partager ton fichier "271.1282.4096_fgbs222.smart.implant.json" car le mien n'est pas pris en compte (commandes non reconnues) ?

merci
Damien

FrancoisM
Timide
Messages : 30
Inscription : 26 avr. 2019, 18:13

Re: Fibaro Smart Implant FGBS222

Message par FrancoisM » 23 mai 2019, 23:06

Bonsoir Damien,

J'ai fait un copié collé de celui suggéré par Akenad. Merci à lui, au moins ça évite de planter la box. Mais ça ne génère pas de commandes, je suis obligé de les créer manuellement en les ajoutant une par une. C'est assez rapide dans mon cas, je génère juste 2 impulsions, une sur chaque sortie.
J'ai lu et relu le json pour essayer de trouver le couac, mais je ne trouve pas, même en m'inspirant des json officiels des autres modules.
Désolé, j'aurais aimé pouvoir aider...

François

romanais
Actif
Messages : 1990
Inscription : 21 août 2014, 21:36
Localisation : Drôme

Re: Fibaro Smart Implant FGBS222

Message par romanais » 24 mai 2019, 06:31

FrancoisM a écrit :
23 mai 2019, 16:48
Bonjour,

Depuis une semaine j'utilisais les FGBS 222 en contacts sec commandés et j'ai eu en une semaine 2 plantages, la box m'indiquant que les nœuds étaient présumés morts. Pas plus inquiet que ça, en rafraichissant, ça repartait parfaitement.
Ce matin, J'ai fait la MAJ du plugin openzwave. Et depuis mes 2 FGBS-22 ne fonctionnent plus du tout. Pour l'un des 2, les commandes ont été effacées, et pour les 2, la photo du FGBS a disparu.
La box fonctionne maintenant au ralenti, impossible de naviguer dans les menus, plantages à répétition. Bref, une galère.
Je peux refaire ce que j'avais fait pour intégrer les smart implant, mais je me demandais si vous aviez eu cette même expérience que moi, ce qui toutefois me paraitrait assez logique si le répertoire openzwave a été réitinitialisé.

Enfin, petite question, est-il préférable d'exclure ou de supprimer l'équipement dans ce cas précis?

Merci.

François
Comme tu l'as suggéré, c'est la mise à jour qui avait viré tes modif' manuelles.

Vu sur un site de vente
Coté Jeedom, pas d’amélioration concernant l’intégration depuis que nous les avons contactés.
A priori ils attendent une mise à jour de la librairie openzwave (certainement des classes de commande non présentes dans la librairie) si mes informations sont bonnes pour pouvoir faire correctement l’implémentation de ce module.
Ça ne tardera peut-être plus :-)
Merci à toute l'équipe pour le taf

Mon matériel

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 24 mai 2019, 07:01

Il faut espérer que ça arrivera bientôt en effet et c'est d'autant plus frustrant de ne pas avoir de communication de la part la Team.

Je me doute qu'ils sont en manque de ressources mais au moins juste un retour pour nous dire ce qu'il en est (pas regarder, intégration en cours, bloquage à cause la librairie openzwave, pas de module pour faire les tests, ...) serait le bienvenu.

J'ai ouvert un ticket il y a presque un mois maintenant mais aucun retour ...

Bref ... il faut être patient :-)

arnog23
Timide
Messages : 398
Inscription : 02 mars 2016, 21:50

Re: Fibaro Smart Implant FGBS222

Message par arnog23 » 24 mai 2019, 10:34

Il semblerait qu'une nouvelle version 1.6 d'OpenZwave soit sortie début Mai. Peut être que celle-ci intègre de nouvelles fonctionnalités necéssaire au Smart Implant.

https://groups.google.com/forum/#!topic ... 26mAKMam58

Il va maintenant falloir patienter pour qu'elle soit prise en compte par Jeedom.

Répondre

Revenir vers « Configurations OpenZwave Manquantes »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités