Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Résolu] Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Uniquement pour apporter des contributions aux configurations OpenZwave (corrections de configurations erronées ou compléments de configurations manquantes). Si vous avez un souci avec votre module, merci de poster dans Périphériques Z-Wave !

Modérateur : nechry

Répondre
i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

[Résolu] Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 11 sept. 2019, 23:05

Bonjour

Ayant eu des problèmes d'inclusion du Walli Dimmer (Firmware V5.1), j'ai tenté une nouvelle installation après mise à jour du plugin Z-Wave en version 2019-09-10 02:15:19

- Exclusion du module
- Inclusion du module

Le modèle reste inconnu dans la page configuration

walli dimmer 4.PNG
walli dimmer 4.PNG (15.68 Kio) Consulté 177 fois

La page paramètres est toujours vide

walli dimmer 3.PNG
walli dimmer 3.PNG (18.25 Kio) Consulté 177 fois

Pour résoudre les problèmes de fonctionnement, j'ai ajouté le paramètre 159 avec valeur 2
J'ai patienté pour voir les leds clignoter en rouge, puis vert fixe, puis éteintes
Je suis sorti de la page paramètre et suis retourné : les paramètres 151 (valeur 46) - 159 - 160 et 171 ont été ajoutés automatiquement


J'ai regardé le fichier de configuration et il ne correspond pas à la document Fibaro
Ce fichier de configuration s'apparente à celui du Dimmer 2

Exemple, l'état de l’éclairage après une coupure de courant
Selon la documentation Fibaro :
- pour le Walli Dimmer, "Remember device state" est en paramètre 1 (le paramètre 9 ne figure pas dans les paramètres avancés de la doc)
- pour le Dimmer 2, "State of the device after a power failure" est en paramètre 9
Or, dans le fichier de configuration du Walli Dimmer de Jeedom, l'état de l'éclairage après une coupure de courant figure en paramètre 9.

A mon sens, il doit y a voir un autre problème pour que le modèle ne soit pas reconnu

J'ai déjà posté ce type d'informations ICI
Mais les informations sont dans un thème global au risque de ne pas être prises en compte

NB : Au delà du problème d'intégration du Walli Dimmer, il me semblerait intéressant de savoir s'il est utile de lancer la procédure "configs modules"
Pour se faire il faudrait deux informations :
- Obtenir un numéro de version (ou date) de la dernière configuration des modules Z-Wave disponible
- Afficher dans le panneau de configuration du plugin Z-Wave, le numéro de version (ou date) de la configuration des modules installée (peut-être au niveau du bouton "Config modules" ?)

Merci
Dernière édition par i-magin le 19 sept. 2019, 00:34, édité 1 fois.
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 14 sept. 2019, 20:09

Bonjour

Je suis allé voir le GitHub d'OpenZWave (*) et j'ai trouvé ce fichier de configuration des Walli Dimmer : ICl

Cette configuration correspond bien à la documentation Fibaro et on y trouve l'intégralité des paramètres

Ce qui me confirme que le fichier de configuration du Walli Dimmer dans le plugin Z-Wave de Jeedom n'est pas bon

(*) Si j'ai bien compris, le plugin Z-Wave de Jeedom utilise un fork d'OpenZWave lorsqu'il était en version 1.4 (Je ne peux pas en préciser la date) - OpenZWave est actuellement en V1.6
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par m.georgein » 14 sept. 2019, 20:35

En espérant que Loïc ou Sakhara verront ton message ...

As tu essayé d'intégrer ce fichier à jeedom ??
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 14 sept. 2019, 20:48

Je pense que Loïc a suffisamment à faire pour s'occuper en plus du plugin Zwave... on le voit très souvent sur le pont (forum) y compris le week-end et à des heures où l'on doit se reposer :)

Je n'ai pas essayé d'intégrer ce fichier.
Je n'en ai pas les compétences et je ne veux pas que mon Jeedom de prod explose en vol :D
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par m.georgein » 14 sept. 2019, 20:58

Tu sais qui est en charge de ce plugin ?
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 14 sept. 2019, 21:05

Oui... la team Jeedom ou Jeedom SAS :lol:
Je ne connais pas leur organisation, mais j'imagine qu'ils doivent avoir beaucoup de travail
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

deimosfr
Timide
Messages : 22
Inscription : 17 mars 2018, 09:33

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par deimosfr » 14 sept. 2019, 21:36

Hello,

Même problème pour moi, c'était pourtant reconnu il y a encore peu de temps.

La seule différence notable sur ce module que je vois c'est ce commit https://github.com/OpenZWave/open-zwave ... ef814fecb9

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 14 sept. 2019, 22:27

@deimosfr, ton lien renvoie sur le GitHub d'OpenZWave qui n'est plus utilisé par le plugin Jeedom.

Comme je l'ai mentionné, le plugin Z-Wave de Jeedom fonctionne avec sa propre librairie Zwave

La structure du fichier de configuration du Walli Dimmer d'OpenZwave est différente de celle du plugin Z-Wave Jeedom
On peut toutefois constater la différence des paramètres/index de configuration du module Walli Dimmer
Ce sont les paramètres de configuration d'OpenZwave qui sont conformes à la documentation Fibaro

- Le fichier configuration plugin de Jeedom : ICI

- Le fichier configuration OpenZwave : ICI
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

deimosfr
Timide
Messages : 22
Inscription : 17 mars 2018, 09:33

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par deimosfr » 17 sept. 2019, 17:53

Bonjour,

Ca y est, l'équipe Jeedom a corrigée hier \o/. Mettez à jour les modules dans la configuration zwave, regénérez la détection du noeud et synchronisez.

L'équipe Jeedom m'a conseillé de d'exclure et include de nouveau ces équipements, mais ça ne m'arrangeait pas. J'ai pu m'en sortir comme expliqué au dessus.

Bon courage à vous

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 17 sept. 2019, 18:21

Bonjour

Il me semblait que la correction n'était pas encore passée dans la liste de configuration stable du GitHub
J'ai toutefois fait la mise à jour

Si le nom de modèle est enfin correct, le fichier de configuration est faux
Il correspond à un FGD212 (voir les commentaires des paramètres)
Pourtant , le bon fichier de configuration a été injecté hier dans le GitHub.... il doit y avoir une validation à faire sur GitHub pour le prendre en compte
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 985
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: [Résolu] Fibaro Walli Dimmer FGWDEU-111 (configuration partielle/erronée)

Message par i-magin » 19 sept. 2019, 00:39

Bonjour

Les corrections ont été apportées par l’assistance Jeedom pour que la Walli Dimmer soit correctement configuré
Les bons paramètres sont par conséquent intégrés et apparaissent après inclusion
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Répondre

Revenir vers « Configurations OpenZwave Manquantes »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités