Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Jeedom smart se plante souvent

Venez discuter de la box JEEDOM SMART
Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 07 janv. 2018, 10:07

glenan a écrit :
07 janv. 2018, 03:01
Il ne reste plus qu'à ouvrir un ticket support et revenir ici fournir la solution éventuelle car visiblement, le cas n'est pas unique.
Maikiniki en a introduit 1 le 3 janvier.

Wait and see

Edit: Je vais tenter la manip indiquée ici https://www1.zonewebmaster.eu/serveur-d ... date-heure

Je découvre qu'il existe aussi 1 temps Bios. ( L'heure se conjugue à tous les temps :D )

La commande " hwclock --systohc "

Je vais d'abord m'imprégner de https://www.thegeekstuff.com/2013/08/hw ... ce=tuicool
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Maikinoki
Timide
Messages : 24
Inscription : 19 nov. 2014, 20:48

Re: Jeedom smart se plante souvent

Message par Maikinoki » 07 janv. 2018, 16:25

Hello,

De mon côté je confirme que j'ai ouvert un ticket. Pas de retour pour le moment mais sur la période des fêtes je suis compréhensif :)

J'avais vu la solution de la ligne de commande mais, sauf erreur de ma part, sur une Jeedom Smart la connexion ssh fait perdre le droit au support. Ma box étant toujours sous garantie (04/2017), je n'ai rien essayé d'autres que les solutions par l'interface web (pas de connexion ssh, pas d'ouverture de la box pour voir s'il y a une pile, pas de chalumeau, etc.). C'est juste super handicapant car tout est boiteux (même avec la majorité de plugins désactivés).

A noter: Pour moi le décalage n'est ni fixe ni progressif mais complètement aléatoire. Si je ne touche à rien, l'heure passe de 18h à 14h puis 9h30 en 30 minutes d'intervalle. La date change aussi (j'ai des logs en Avril 2017...). Je m'en suis rendu compte au bout d'un certain temps car mon allumage extérieur ne fonctionnait plus (conditionné dans une tranche d'heures).

J'ai eu un souci similaire sur un iPhone 5C qui venait d'un problème physique du quartz qui défini les cycles d'horloge (courant sur ce modèle). J'espère ne pas avoir de problème hardware sur ma box mais comme expliqué plus haut le problème est apparu "comme ça".

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 07 janv. 2018, 18:43

Ah oui, là c'est beaucoup plus grave que chez moi.
Il sera intéressant d'en connaitre la cause.
Si je peux régler mon problème je reviendrai sur ton fil dire comment j'ai fait.
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

beber49
Timide
Messages : 141
Inscription : 26 janv. 2017, 20:11

Re: Jeedom smart se plante souvent

Message par beber49 » 08 janv. 2018, 15:24

Interessé par la solution perso !

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 08 janv. 2018, 15:28

beber49 a écrit :
08 janv. 2018, 15:24
Interessé par la solution perso !
As-tu un problème similaire ?
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

beber49
Timide
Messages : 141
Inscription : 26 janv. 2017, 20:11

Re: Jeedom smart se plante souvent

Message par beber49 » 08 janv. 2018, 15:52

Non mais j'ai eu et tout est revenu dans l'ordre sans rien toucher.

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 08 janv. 2018, 16:15

beber49 a écrit :
08 janv. 2018, 15:52
Non mais j'ai eu et tout est revenu dans l'ordre sans rien toucher.
Ce genre de désagrément ± aléatoire pose question.
Chez moi, c'est récurrent et toutes les manip faites ne changent rien.

As-tu une Smart ?
Quelle version Jeedom ?
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

beber49
Timide
Messages : 141
Inscription : 26 janv. 2017, 20:11

Re: Jeedom smart se plante souvent

Message par beber49 » 08 janv. 2018, 18:00

Smart, en 3.17
Bon courage...

t-minik
Timide
Messages : 72
Inscription : 15 déc. 2017, 18:32

Re: Jeedom smart se plante souvent

Message par t-minik » 12 janv. 2018, 12:31

Bonjour à tous.

juste pour faire remonter l'info, je suis confronté au même problème de dérèglement de l'heure sur une install diy a base d'orange pi PC+ sous jeedom 3.1.7 le tout en lan sur ma livebox play.

lorsque cela arrive l'heure est déréglée mais aussi la date comme le prouve le sceen que vous pouvez trouver joint.
ceci est pris après un reboot manuel dont je parle plus bas.
Image

on peut voir en haut à gauche l'heure du dernier check de mise à jour.

l’accès http/https continue de fonctionner mais plus rien ne fonctionne, l’accès ssh est impossible à ce moment là et le redémarrage / arrêt ne semblent plus fonctionner à travers l'interface.
le seul moyen de revenir à la normale reste le débranchement/re-branchement manuel.
EDIT// après le reboot, la température processeur est beaucoup plus élevée que la normale (65° au lieu des 35° maxi en cemoment), comme si une tache avait tourné à fond.

je viens de changer le pool de serveurs NTP d'origine pour voir si cela se reproduit.
je vous tiendrai au jus.
Dernière édition par t-minik le 12 janv. 2018, 13:48, édité 1 fois.

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 12 janv. 2018, 13:41

Perso, j'ai 3 heures différentes.
L'heure PC
L'heure Jeedom + 40 sec sur 4h de fonctionnement
L'heure VM + 55 mn sur 4h aussi.

Mes scénarios se déclenchent à l'heure VM.

A quoi sert l'heure Jeedom et où est-elle prise ?
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 13 janv. 2018, 23:20

Je pense avoir réglé mon problème d'heure.

Ici, en fin de page, l'indication qui a fait TILT https://access.redhat.com/documentation ... me-hwclock

Donc, en installant l'image de Jeedom sur ma VM Virtualbox, il faut décocher " Horloge interne en UTC " puisqu'elle est cochée par défaut.
Mon PC étant réglé sur l'heure locale, cela crée un BINZZ avec la VM réglée sur UTC (+1)

Je croise les doigts pour que ça dure.

Capture 228  12-01-2018.jpg
Capture 228 12-01-2018.jpg (467.47 Kio) Consulté 815 fois
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

francoisceline
Timide
Messages : 63
Inscription : 29 juin 2016, 23:02

Re: Jeedom smart se plante souvent

Message par francoisceline » 18 janv. 2018, 07:40

Bonjour,

Cette nuit plantage total de ma jeedom smart nécessitant un redémarrage. Les derniers rapports d erreurs sont qu elle n arrivent plus à communiquer avec la livebox. Orange doit déployer une maj sur livebox, j imagine que c est peut être ça...

Quikdav
Timide
Messages : 109
Inscription : 09 févr. 2017, 23:15
Localisation : GIBEL - Haute Garonne

Re: Jeedom smart se plante souvent

Message par Quikdav » 20 janv. 2018, 09:37

Après une migration de la 3.1.5 à la 3.1.7 depuis 4 jours, j'ai droit à quasi un plantage par jour avec le message "SQLSTATE[08004] [1040] Too many connections". Les plugins sont les mêmes qu'avant, aucun changement dans ma config donc voilà, pas cool tout ca...
Je vais essayer d'aller voir d'aller voir dans les logs mysql sur la box au cas ou... mais si quelqu'un a des pistes pour savoir ou aller jeter un oeil, merci d'avance

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 22 janv. 2018, 14:21

t-minik a écrit :
12 janv. 2018, 12:31

je viens de changer le pool de serveurs NTP d'origine pour voir si cela se reproduit.
je vous tiendrai au jus.
J'ai une bonne piste pour toi.
Ce lien m'a permis de régler mes heures PC, Jeedom et VM qui sont juste à 5 secondes près maintenant.
Le lien donne l'explication et la méthode.
http://collab.debian.net/portal/planet- ... nd-systemd
Il y a un conflit entre NTP et systemd qui est la nouvelle façon de régler l'heure sur debian strecht.

Chez moi, je n'ai plus qu'à trouver pourquoi ma synchronisation NTP reste sur : NO
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

t-minik
Timide
Messages : 72
Inscription : 15 déc. 2017, 18:32

Re: Jeedom smart se plante souvent

Message par t-minik » 25 janv. 2018, 14:39

salut @Patdec.

merci de ta réponse, je teste ça de suite car j'ai encore eu une paire de déconvenues avec mon Opi pc+ depuis que j'ai posté plus haut.
du coup avec "timedatectl status" je peux voir que l'horloge RTC avance d'environ 1minute par rapport à l'heure synchronisée.

merci en tout cas pour l'investigation ;)

EDIT // si cela perdure j'essaierai de rajouter une horloge RTC externe sur ma bestiole.

Avatar de l’utilisateur
Patdec
Timide
Messages : 238
Inscription : 21 janv. 2015, 15:49

Re: Jeedom smart se plante souvent

Message par Patdec » 25 janv. 2018, 16:12

Il y aussi ce site renseigné par Bosquétia qui traite du sujet.

A lire aussi.

https://wiki.archlinux.org/index.php/systemd-timesyncd
Débutant Jeedom.
VirtualBox Debian 5.2.12 - Image debian 9 "https://jeedom.github.io/documentation/ ... r_FR/index"
Jeedom 3.2.6 - Contrôleur Aeon ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Antoinekl1
Actif
Messages : 2711
Inscription : 23 mai 2015, 08:14

Re: Jeedom smart se plante souvent

Message par Antoinekl1 » 25 janv. 2018, 16:14

Bonjour à tous

depuis 2 semaines, j'en suis a mon 3eme plante de la base mysql sur la smart

SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

la base semble arrêtée

Code : Tout sélectionner

jeedom@jeedom:/var/log/mysql$ more error.log
180125  9:02:20 [Warning] Using unique option prefix myisam-recover instead of m
yisam-recover-options is deprecated and will be removed in a future release. Ple
ase use the full name instead.
180125  9:02:20 [Note] Plugin 'FEDERATED' is disabled.
180125  9:02:20 InnoDB: The InnoDB memory heap is disabled
180125  9:02:20 InnoDB: Mutexes and rw_locks use GCC atomic builtins
180125  9:02:20 InnoDB: Compressed tables use zlib 1.2.8
180125  9:02:20 InnoDB: Using Linux native AIO
180125  9:02:20 InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(137363456 bytes) failed; errno 12
180125  9:02:20 InnoDB: Completed initialization of buffer pool

180125  9:02:20 InnoDB: Fatal error: cannot allocate memory for the buffer pool
180125  9:02:20 [ERROR] Plugin 'InnoDB' init function returned error.
180125  9:02:20 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
180125  9:02:20 [ERROR] Unknown/unsupported storage engine: InnoDB
180125  9:02:20 [ERROR] Aborting

180125  9:02:20 [Note] /usr/sbin/mysqld: Shutdown complete
j'ai ouvert un ticket, la réponse :

Le souci est identifié, nous sommes en train d'y remédier .
Ce souci est lié à la gestion du temps.
Désolé pour le désagrément.

est-ce bien lié à ce problème ? et aux échanges que vous avez sur le décalage de l'heure ?
JEEDOM Smart Ultimate + 34 modules zwave et 1BLEA
A vendre ; Jeedom mini+ et pack POWER viewtopic.php?f=73&t=28813 - Console Clazio sous Android 6

Avatar de l’utilisateur
Antoinekl1
Actif
Messages : 2711
Inscription : 23 mai 2015, 08:14

Re: Jeedom smart se plante souvent

Message par Antoinekl1 » 26 janv. 2018, 07:30

MySQL encore planté ce matin

Code : Tout sélectionner

180126  7:02:10 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
180126  7:02:10 [Note] Plugin 'FEDERATED' is disabled.
180126  7:02:10 InnoDB: The InnoDB memory heap is disabled
180126  7:02:10 InnoDB: Mutexes and rw_locks use GCC atomic builtins
180126  7:02:10 InnoDB: Compressed tables use zlib 1.2.8
180126  7:02:10 InnoDB: Using Linux native AIO
180126  7:02:10 InnoDB: Initializing buffer pool, size = 128.0M
180126  7:02:10 InnoDB: Completed initialization of buffer pool
180126  7:02:10 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
180126  7:02:10  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
180126  7:02:10  InnoDB: Waiting for the background threads to start
180126  7:02:11 InnoDB: 5.5.58 started; log sequence number 28273619494
180126  7:02:11 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
180126  7:02:11 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
180126  7:02:11 [Note] Server socket created on IP: '127.0.0.1'.
180126  7:02:11 [Note] Event Scheduler: Loaded 0 events
180126  7:02:11 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.58-0+deb8u1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Debian)
180126  7:02:14 [ERROR] /usr/sbin/mysqld: Table './jeedom/conso_jour' is marked as crashed and should be repaired
180126  7:02:14 [Warning] Checking table:   './jeedom/conso_jour'
180126  7:05:22 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
180126  7:05:22 [Note] Plugin 'FEDERATED' is disabled.
180126  7:05:22 InnoDB: The InnoDB memory heap is disabled
180126  7:05:22 InnoDB: Mutexes and rw_locks use GCC atomic builtins
180126  7:05:22 InnoDB: Compressed tables use zlib 1.2.8
180126  7:05:22 InnoDB: Using Linux native AIO
180126  7:05:23 InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(137363456 bytes) failed; errno 12
180126  7:05:23 InnoDB: Completed initialization of buffer pool
180126  7:05:23 InnoDB: Fatal error: cannot allocate memory for the buffer pool
180126  7:05:23 [ERROR] Plugin 'InnoDB' init function returned error.
180126  7:05:23 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
180126  7:05:23 [ERROR] Unknown/unsupported storage engine: InnoDB
180126  7:05:23 [ERROR] Aborting

180126  7:05:23 [Note] /usr/sbin/mysqld: Shutdown complete

jeedom@jeedom:/var/log/mysql$ sudo /etc/init.d/mysql stop
[sudo] password for jeedom:
[ ok ] Stopping mysql (via systemctl): mysql.service.
jeedom@jeedom:/var/log/mysql$ sudo /etc/init.d/mysql start
[ ok ] Starting mysql (via systemctl): mysql.service.
La table conso_jour vient du plugin conso, ce ne serait pas lui qui ferait planter jeedom ?
Ou c'est un dommage du précédent plantage ?
JEEDOM Smart Ultimate + 34 modules zwave et 1BLEA
A vendre ; Jeedom mini+ et pack POWER viewtopic.php?f=73&t=28813 - Console Clazio sous Android 6

Avatar de l’utilisateur
Antoinekl1
Actif
Messages : 2711
Inscription : 23 mai 2015, 08:14

Re: Jeedom smart se plante souvent

Message par Antoinekl1 » 26 janv. 2018, 08:40

Là c'est la merde, la base plante systématiquement

Code : Tout sélectionner

180126  7:44:31 [Warning] Using unique option prefix myisam-recover instead of m
yisam-recover-options is deprecated and will be removed in a future release. Ple
ase use the full name instead.
180126  7:44:31 [Note] Plugin 'FEDERATED' is disabled.
180126  7:44:31 InnoDB: The InnoDB memory heap is disabled
180126  7:44:31 InnoDB: Mutexes and rw_locks use GCC atomic builtins
180126  7:44:31 InnoDB: Compressed tables use zlib 1.2.8
180126  7:44:31 InnoDB: Using Linux native AIO
180126  7:44:31 InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(137363456 bytes) failed; errno 12
180126  7:44:31 InnoDB: Completed initialization of buffer pool
180126  7:44:31 InnoDB: Fatal error: cannot allocate memory for the buffer pool
180126  7:44:31 [ERROR] Plugin 'InnoDB' init function returned error.
180126  7:44:31 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
180126  7:44:31 [ERROR] Unknown/unsupported storage engine: InnoDB
180126  7:44:31 [ERROR] Aborting
180126  7:44:31 [Note] /usr/sbin/mysqld: Shutdown complete
il semblerait que ce soit une erreur de wap

Code : Tout sélectionner

Swap:       262140     261592       548
Le mien de 256Mo est saturé
dois-je l'augmenter ?

je ne peux même pas vider le swap

Code : Tout sélectionner

jeedom@jeedom:/etc/mysql$ sudo swapon -s
[sudo] password for jeedom:
Filename                                Type            Size    Used    Priority
/swapfile1                              file            262140  261592  -1
jeedom@jeedom:/etc/mysql$ sudo swapoff -a && swapon -a
swapoff: /swapfile1: swapoff failed: Cannot allocate memory

j'ai fait un reboot, le swap est propre

Code : Tout sélectionner

Fri Jan 26 09:10:05 CET 2018
jeedom@jeedom:/var/log/mysql$ free -m
             total       used       free     shared    buffers     cached
Mem:          1717        564       1152         74         27        208
-/+ buffers/cache:        328       1388
Swap:          255          0        255
cela semble tenir le coup, pas eu de plantage depuis 2H alors que j'en avais eu 4 a la suite
Dernière édition par Antoinekl1 le 26 janv. 2018, 10:58, édité 2 fois.
JEEDOM Smart Ultimate + 34 modules zwave et 1BLEA
A vendre ; Jeedom mini+ et pack POWER viewtopic.php?f=73&t=28813 - Console Clazio sous Android 6

christr
Timide
Messages : 121
Inscription : 18 oct. 2014, 17:49
Localisation : Calvados, Caen

Re: Jeedom smart se plante souvent

Message par christr » 26 janv. 2018, 09:10

moi aussi depuis plusieurs jours l'heure de mon jeedom n'est pas la bonne: il a 45 mn de retard.
Reboot, modif serveur de temps dans les paramètres jeedom, rien n'y fait...

J'ai cru voir plus haut que le support jeedom serait sur ce problème, j'espère que le correctif va arriver très vite...

Mais du coup je me demandais s'il n'était pas possible de déclencher un script régulièrement pour mettre à jour Jeedom depuis un serveur de temps internet. Avez-vous déjà vu cela quelque part ?

Cela pourrait aussi m'aider en cas de coupure électrique chez moi: jeedom démarre plus vite que la box internet, et du coup jeedom n'est pas à l'heure (RPI2 oblige...).

Merci.
PI2+Razberry+Rfxcom+Teleinfo+Volets roulants FGRM-222+Powernode+FGFS-101 Flood Sensor+FGMS-001 Motion Sensor+FGSD-002 Smoke Sensor+KFOB Secure 4 Button Key Chain Controller+Hue+Netatmo Thermostat et Météo

Répondre

Revenir vers « La box JEEDOM SMART »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité