Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Jeedouino

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 07 févr. 2016, 23:28

Bonsoir,

kraku, impeccable. Sinon, j'aurais voulu savoir avec quel navigateur vous avez eu le soucis ? Merci.

Bono2007, effectivement c'est étrange que L'ESP ne se connecte pas à ton wifi. Je suppose que tu as bien vérifié le SSID et le mot de passe ? Regardes dans le sketch si ils ont bien été reportés lors de la génération du fichier.
J'ai aussi une freebox et ça fonctionne bien, par contre elle est a proximité (2m), la portée du wifi pouvant être une cause du souci..
Alors, arduino+ESP+jeedouino ça ne marchera pas, ce n'est pas prévu pour, mais arduino (usb ou lan) + jeedouino, oui.
L'ESP as-t-il déjà servi avec d'autres sketch auparavant ?
Si non, alors essaye le sketch d’exemple ici : https://github.com/esp8266/Arduino/blob ... Client.ino et dis moi si il se connecte a ton wifi.

Bonne soirée.

Avatar de l’utilisateur
Dany21000
Timide
Messages : 271
Inscription : 01 déc. 2015, 10:56
Localisation : Dijon

Re: [Sujet officiel] : Jeedouino

Message par Dany21000 » 07 févr. 2016, 23:59

Hello,

Ça fait quelques semaines que je suis ce projet.
Habitué à jouer avec les esp8266, je viens seulement de comprendre le rôle de ce plug-in et surtout son fonctionnement.

Juste... Excellent et vraiment génial comme idée !

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 11:22

J'ai reflashé le firmware d'origine, voulant vérifier si mon esp était grillé
python esptool.py --port COM4 --baud 115200 write_flash 0x00000 ./at/noboot/eagle.flash.bin 0x40000 ./at/noboot/eagle.irom0text.bin 0x3e000 ./at/blank.bin 0x7e000 ./at/blank.bin 0x7c000 ./at/esp_init_data_default.bin

Il fonctionne, donc je pense à un pb de branchement/fil trop long/...
Je vais essayer un sketch classique déjà. Je reviens bientôt
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 12:11

script fonctionnel, je rejoins ma fbox.
Par contre j'ai remarqué qu'avec des branchements sur la breadboard + RX + TX, avec les câbles, j'ai très peu de connexion au wifi.
J'ai fait un branchement au FTD directement avec RX et TX, et j'ai quelques déco, il quitte le réseau souvent.
J'ai juste branché à une alim externe 3.3V le GND, le VCC et le CH_PD : hyper stable.
Donc je pense que mes pb sont dus aux câbles.
Je vais refaire le test avec jeedouino

J'ai remis un ancien sketch que j'avais, branché juste les 3 câbles et ça marche !
Par contre j'ai un fil qui génère les impulsions ( ampoule reed ), est-ce que je dois mettre une résistance de 10 kOhms entre l'ampoule et le GPIO2 ?
Voir montage :
cap2.JPG
cap2.JPG (59.82 Kio) Consulté 489 fois
Dernière édition par Bono2007 le 08 févr. 2016, 16:49, édité 3 fois.
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Ericd
Timide
Messages : 59
Inscription : 18 déc. 2014, 16:45
Localisation : Toulouse

Re: [Sujet officiel] : Jeedouino

Message par Ericd » 08 févr. 2016, 14:45

Pour le problème du programme de l'arduino, j'ai eu le même le problème, mais je me suis rendu compte qu'en sortant de la page et en y revenant le programme est arrivé....

Il doit y avoir un petit problème....

@+

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 15:03

J'avance un peu. J'ai le bon script, l'ESP est connecté, j'ai branché une résistance de 10 ko au cul d'un bouton poussoir comme cela :
GPIO2 --- 10 ko ----o bouton o---- GND mais ça ne donne rien.

J'ai toujours NOK sur l'ip:port

LOG nginx.error :

Code : Tout sélectionner

2016/02/08 15:20:53 [error] 2549#0: *3704793 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to a member function setConfiguration() on a non-object in /usr/share/nginx/www/jeedom/plugins/jeedouino/core/php/Callback.php on line 76" while reading response header from upstream, client: 192.168.0.7, server: , request: "GET /plugins/jeedouino/core/php/Callback.php?BoardEQ=&ipwifi=192.168.0.7 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.0.32"
2016/02/08 15:21:05 [error] 2549#0: *3704816 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to a member function setConfiguration() on a non-object in /usr/share/nginx/www/jeedom/plugins/jeedouino/core/php/Callback.php on line 76" while reading response header from upstream, client: 192.168.0.7, server: , request: "GET /plugins/jeedouino/core/php/Callback.php?BoardEQ=&ipwifi=192.168.0.7 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.0.32"
Pièces jointes
JeedouinoESP_8266.txt
(17.6 Kio) Téléchargé 10 fois
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 16:35

Bonjour à tous,

Dany21000 , Merci ;-)

Ericd, tu parles de la page équipement je suppose. Cela arrive suivant les navigateurs, un problème de rafraîchissement de la page. J'essaierai de trouver une solution.

Bono2007, après avoir remis le sketch généré par le plugin, as-tu re-sauver l’équipement afin qu'il envoi le paramétrage des pins a l'ESP ?
'sudo: pip: command not found", c'est normalement pour installer la gestion des GPIO du RPI. Pas utile pour l'ESP.

NB. sur la capture de ta page ESP, tu n'as pas caché ton mot de passe. Et ça me fait penser que j'ai oublié de mettre cette case en caché.

A+

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 16:48

salut, j'avais sauvé. J'ai posté le fichier que j'ai téléversé dans l'Esp.
capt3.JPG
capt3.JPG (68.26 Kio) Consulté 494 fois
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 17:01

Bono2007 , je viens de regarder vite fait le sketch, il a été généré par une ancienne version du plugin. As tu mis à jour le plugin,et récupéré le nouveau sketch généré ?

Dans le log nginx.error, la ligne /plugins/jeedouino/core/php/Callback.php?BoardEQ=&ipwifi=192.168.0.7 indique que tu n'as pas re-sauvegarder l’équipement après avoir flashé l'ESP, BoardEQ= devrait avoir comme valeur l'ID de l'équipement et là il n'y a rien, d'où l'erreur.

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 17:25

Oui donc j'ai tout recommencé ^^ Et j'ai des résultats . Le compteur augmente quand je mets en contact GPIO2 avec GND.
Edit : j'ai mis le câble de mon compteur à impulsion sans résistance, et en soufflant dans le compteur, j'ai l'impression que ça fonctionne.
Voir après pour le calcul ...

PS : comment remettre à zéro le compteur ?
Merci pour tout !
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 18:16

On progresse ;-)

Pour le comptage, c'est peut être dû au bouton poussoir (effet de rebond). Ou le compteur était déjà à 6 si tu avais fait des tests avant.
En effet, Jeedom renvoie la dernière valeur connue du compteur à l'ESP après un reboot de celui-ci.
Ou il y a un bug que je n'ai pas encore vu :(
NB L'info compteur n'est envoyée à Jeedom que toutes les 10s environ.

Pour remettre à zéro, ou une valeur choisie, tu vas dans l’équipement sur la commande compteur, il doit y avoir une case avec la valeur. Tu peux la changer, puis tu sauves l’équipement.

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 18:27

J'ai fait et ça n'a rien changé ( pour le compteur / valeur ). J'arrive à sauvegarder la valeur 0 mais le compteur reste à sa valeur précédente.
J'avais choisi "Sauvegarde sur Jeedom" dans le paramétrage.

Sinon je pense aussi à l'effet rebond, vu qu'en mettant le bon câble, ça a l'air bon
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 18:38

"Sauvegarde sur Jeedom" n'a d'incidence que sur les pins en sorties.
Les pins en entrées sont elles sauvegardées automatiquement par Jeedom

Sinon, pour la remise à zéro du compteur, je viens de voir qu'il y a un soucis. J'avais fait en sorte que quand Jeedom renvoie cette valeur à l'ESP (suite reboot), elle soit ajoutée au compteur interne de ce-dernier pour tenir compte du comptage que l'ESP aurait fait entre temps , histoire de minimiser les pertes de comptage. Mais du coup, ça empêche la fixation de cette valeur.
Je vais regarder pour régler cela, désolé. :(

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Sujet officiel] : Jeedouino

Message par Bono2007 » 08 févr. 2016, 18:41

Une mise à jour de l'ESP OTA est envisageable ? ^^
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 18:43

non, mais c'est une idée à creuser...

Une idée en attendant pour la RàZ de ton compteur : éteint l'ESP - Sauve l'équipement ( il va y avoir quelques erreurs ) - Démarre l'ESP - Sauve de nouveau l’équipement .
Dernière édition par revlys le 08 févr. 2016, 19:37, édité 1 fois.

PM17
Timide
Messages : 22
Inscription : 02 févr. 2016, 09:26

Re: [Sujet officiel] : Jeedouino

Message par PM17 » 08 févr. 2016, 19:06

Bonjour,
Je découvre Jeedouino pour controler le GPIO avec un raspi B, une entrée pin 12 (interrupteur au 0v), une sortie avec LED pin 16. Je n'arrive pas à allumer la LED, ni à avoir un retour de l'état des pins sur le dashboard. Je n'ai rien d'autre d'installé.
D'autre part je n'arrive pas à avoir OK sur le démon.
Voilà la dernière partie du log jeedouino :

08-02-2016 18:45:34 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:45:41 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

Un grand merci pour un peu d'aide.

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 08 févr. 2016, 19:17

Bonjour PM17,

Alors si le démon n'est pas démarré le reste ne marchera pas forcément ;-)
A priori, les 2 tentatives de démarrer le démon ont échouées. Est-il sur un pi esclave ?
"SSH-2.0-OpenSSH_6.7p1 Raspbian-5 Protocol mismatch." est clairement ce qui empêche le démon de démarrer.
Je vais regarder pourquoi. En attendant, je voudrais bien une partie des logs précédents.

PM17
Timide
Messages : 22
Inscription : 02 févr. 2016, 09:26

Re: [Sujet officiel] : Jeedouino

Message par PM17 » 08 févr. 2016, 20:22

Non, il est seul. J'en suis seulement à mes débuts avec jeedom. J'ai installé l'image de jeedom pour rpi, le plugin jeedouino et RPi.GPIO, c'est tout.

PM17
Timide
Messages : 22
Inscription : 02 févr. 2016, 09:26

Re: [Sujet officiel] : Jeedouino

Message par PM17 » 08 févr. 2016, 20:30

J'ai oublié les logs, voilà ce qui me reste :

08-02-2016 18:26:42 | jeedouino | >>>preSave
08-02-2016 18:26:42 | jeedouino | >>>preUpdate
08-02-2016 18:26:42 | jeedouino | >>>postUpdate
08-02-2016 18:26:42 | jeedouino | >>>postSave
08-02-2016 18:27:02 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:27:08 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:27:10 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

08-02-2016 18:30:17 | jeedouino | >>>preSave
08-02-2016 18:30:17 | jeedouino | >>>preUpdate
08-02-2016 18:30:17 | jeedouino | >>>postUpdate
08-02-2016 18:30:17 | jeedouino | >>>postSave
08-02-2016 18:30:31 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:30:38 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:30:40 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

08-02-2016 18:31:11 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:31:15 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:36:36 | jeedouino | >>>preSave
08-02-2016 18:36:36 | jeedouino | >>>preUpdate
08-02-2016 18:36:36 | jeedouino | >>>postUpdate
08-02-2016 18:36:36 | jeedouino | >>>postSave
08-02-2016 18:36:53 | jeedouino | >>>preSave
08-02-2016 18:36:53 | jeedouino | >>>preUpdate
08-02-2016 18:36:53 | jeedouino | >>>postUpdate
08-02-2016 18:36:53 | jeedouino | >>>postSave
08-02-2016 18:38:00 | jeedouino | >>>preSave
08-02-2016 18:38:00 | jeedouino | >>>preUpdate
08-02-2016 18:38:00 | jeedouino | >>>postUpdate
08-02-2016 18:38:00 | jeedouino | >>>postSave
08-02-2016 18:38:21 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:38:27 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:38:29 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:38:50 | jeedouino | >>>preSave
08-02-2016 18:38:50 | jeedouino | >>>preUpdate
08-02-2016 18:38:50 | jeedouino | >>>postUpdate
08-02-2016 18:38:50 | jeedouino | >>>postSave
08-02-2016 18:39:04 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:39:10 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:39:13 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

08-02-2016 18:39:52 | jeedouino | >>>preSave
08-02-2016 18:39:52 | jeedouino | >>>preUpdate
08-02-2016 18:39:52 | jeedouino | >>>postUpdate
08-02-2016 18:39:52 | jeedouino | >>>postSave
08-02-2016 18:40:06 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:40:13 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:40:15 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:40:35 | jeedouino | >>>preSave
08-02-2016 18:40:35 | jeedouino | >>>preUpdate
08-02-2016 18:40:36 | jeedouino | >>>postUpdate
08-02-2016 18:40:36 | jeedouino | >>>postSave
08-02-2016 18:40:50 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:40:56 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:40:58 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:41:21 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:41:23 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

08-02-2016 18:41:26 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:41:31 | error | ERREUR SETTING PIN VALUE eqID ( 1 )- Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:43:00 | jeedouino | >>>preSave
08-02-2016 18:43:00 | jeedouino | >>>preUpdate
08-02-2016 18:43:00 | jeedouino | >>>postUpdate
08-02-2016 18:43:00 | jeedouino | >>>postSave
08-02-2016 18:43:14 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:43:20 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:43:22 | error | ERREUR CONFIGURATION PinMode eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
08-02-2016 18:45:34 | error | ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Net:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()

File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 69, in run
s.bind(('', port)) # try again
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

08-02-2016 18:45:41 | error | ENCORE ERREUR CONFIGURATION PINS MODE eqID ( 1 ) - Réponse :SSH-2.0-OpenSSH_6.7p1 Raspbian-5
Protocol mismatch.
Exception in thread Tmp:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/share/nginx/www/jeedom/plugins/jeedouino/ressources/jeedouinoPiGpio.py", line 275, in run
if Status_pins=='c':
KeyError: 0

Avatar de l’utilisateur
revlys
Timide
Messages : 327
Inscription : 05 mai 2015, 17:10
Localisation : Gard

Re: [Sujet officiel] : Jeedouino

Message par revlys » 09 févr. 2016, 12:02

Bonjour PM17,

Il semblerait que ce problème vienne de ton système. Soit un souci d'install, soit beaucoup de tests (install de dépendances, manip en ssh ) sur plugins et autre, qui ont engendrés ce problème. D'ailleurs, tu as dû avoir, ou tu auras d'autres bugs a mon avis.

Malheureusement, mes connaissances linux ne me permettent pas de t'aider plus avant.:(

De mon coté, j'ai procédé à une nouvelle installation vierge de Jeedom pour tester, et ça fonctionne. Tu devrais peut être essayer de refaire une install à partir de l'image officielle pour voir.

Bonne journée.

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités