Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

[Plugin Tiers][Sujet Principal] ArduiDom

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Avatar de l’utilisateur
chevalir
Timide
Messages : 148
Inscription : 04 juin 2015, 20:39
Localisation : Ain
Contact :

Re: [Sujet officiel] Plugin ArduiDom

Message par chevalir » 24 mars 2016, 20:28

maitrje a écrit :Bonjour à tous,

Nouveau sur le forum même si je le parcours avec intérêt depuis plusieurs mois.
Je me suis équipé il y a environ 2 mois avec RPI 2 sur lequel j'ai installé Jeedom et tout se passe bien. Plusieurs détecteurs de fumée Fibaro connectés, des volets Somfy RTS avec un Rfxtrx433E, interfaçage avec un WES 2 pour récupérer la Téléinfo, la conso d'eau, les différentes temp de ma VMC double flux, etc, que du bonheur !

Je m'attaque maintenant à la récupération d'infos à partir d'un Arduino.
J'ai un montage à base d'Arduino Uno qui permet de récupérer la hauteur d'eau dans ma cuve de récupération grâce à un capteur à ultra-sons.
Tout fonctionne bien côté Arduino et j'affiche bien sur le LCD de l'Arduino la hauteur d'eau de ma cuve.
Forcément, je veux maintenant connecter l'Arduino à Jeedom pour récupérer cette info dans Jeedom et pouvoir m'en servir dans différents scénario.
J'ai donc installé le plugin Arduidom, chargé le sketch fournit avec et l'arduino est détecté.

Ma question porte sur la meilleure façon de parvenir à mes fins. En effet pour activer le capteur à ultrasons, j'ai besoin de 2 ports digitaux de l'arduino, le premier sur lequel j'envoie un signal trigger d'environ 10ms et le second sur lequel je lis la réponse sous la forme d'un signal dont la durée est proportionnelle au temps qu'a mis l'echo pour revenir (PWM), on en déduit la distance.

Peut-on faire directement ces actions à partir du plugin Arduidom ou faut-il mieux insérer le code qui pilote le capteur dans le sketch Arduidom et remonter le résultat à Jeedom à travers une CustomValue ?

Merci d'avance pour vos avis éclairés
Ma réponse arrive peut-être un peu tard mais bon. Je ne pense pas que cela soit possible sans modif. du sketch.
Dans Le Skeck tu peux mettre ton code dans la méthode : customHook() si tu as besoin de temp réel pour faire ta mesure c'est peut-être bien de stopper la réception radio le temps de ta mesure comme cela (si tu as de la radio :) ) : J'imagine que tu n'a pas besoin de faire la mesure en permanance, dans ce cas il faudra mettre un timer cas la customHook est appelée à chaque tour de loop.

Code : Tout sélectionner

void customHook () {
// stop radio 
mySwitch.disableReceive(); 

//// ton code 


// start radio
			if (RadioRXpin == 2) mySwitch.enableReceive(0);
			if (RadioRXpin  == 3) mySwitch.enableReceive(1);
                #if defined(__AVR_ATmega168__) ||defined(__AVR_ATmega168P__) ||defined(__AVR_ATmega328P__) ||defined(__AVR_ATmega32U4__)
                #else
			if (RadioRXpin == 21) mySwitch.enableReceive(2);
			if (RadioRXpin == 20) mySwitch.enableReceive(3);
			if (RadioRXpin == 19) mySwitch.enableReceive(4);
			if (RadioRXpin == 18) mySwitch.enableReceive(5);
                #endif

}

bonne soirée,
chevalir
chevalir

FrThib
Timide
Messages : 33
Inscription : 02 févr. 2016, 22:39

Re: [Sujet officiel] Plugin ArduiDom

Message par FrThib » 24 mars 2016, 22:11

Galen23 a écrit :
FrThib a écrit :Bonjour
Je viens d'installer Arduidom sur mon raspberry Pi équipé d'un arduino Nano. Configuration hyper simple pour l'instant .
Néanmoins je n'arrive pas à le démarrer malgré plusieurs relance et reboot du Rp.
Ci joint le log des dépendances
Launch install of arduidom dependancy
-------------------------------------
>>> Apt Clean
>>> Apt Update
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Reading package lists...
>>> Install Arduino
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
arduino-core avr-libc binutils-avr ca-certificates-java dbus-x11 default-jre
default-jre-headless extra-xdg-menus fontconfig fonts-dejavu-extra gcc-avr
gconf-service gconf2 gconf2-common gnome-mime-data hicolor-icon-theme
icedtea-7-jre-jamvm java-common libasyncns0 libatk-wrapper-java
libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libavahi-client3
libavahi-glib1 libbonobo2-0 libbonobo2-common libcairo2 libcanberra0
libcups2 libdatrie1 libdbus-glib-1-2 libdrm-amdgpu1 libdrm-freedreno1
libdrm-nouveau2 libdrm-radeon1 libflac8 libgconf-2-4 libgconf2-4
libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgif4 libgl1-mesa-dri
libgl1-mesa-glx libglapi-mesa libgnome-2-0 libgnome2-0 libgnome2-bin
libgnome2-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra
libgraphite2-3 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libharfbuzz0b
libice6 libjasper1 libjna-java libjna-jni libllvm3.7 libltdl7 libnspr4
libnss3 libogg0 liborbit-2-0 libpam-systemd libpango-1.0-0
libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libpolkit-agent-1-0
libpolkit-backend-1-0 libpolkit-gobject-1-0 libpulse0 librxtx-java libsctp1
libsm6 libsndfile1 libtdb1 libthai-data libthai0 libtxc-dxtn-s2tc0
libvorbis0a libvorbisenc2 libvorbisfile3 libx11-xcb1 libxcb-dri2-0
libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shm0
libxcb-sync1 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxi6
libxinerama1 libxrandr2 libxrender1 libxshmfence1 libxtst6 libxxf86vm1
lksctp-tools openjdk-7-jre openjdk-7-jre-headless policykit-1 tzdata-java
x11-common
Suggested packages:
arduino-mk task-c-devel gcc-doc gconf-defaults-service equivs libbonobo2-bin
libcanberra-gtk0 libcanberra-pulse cups-common desktop-base libgnomevfs2-bin
librsvg2-common gvfs libjasper-runtime libjna-java-doc pulseaudio
icedtea-7-plugin sun-java6-fonts fonts-ipafont-gothic fonts-ipafont-mincho
ttf-wqy-microhei ttf-wqy-zenhei fonts-indic
The following NEW packages will be installed:
arduino arduino-core avr-libc binutils-avr ca-certificates-java dbus-x11
default-jre default-jre-headless extra-xdg-menus fontconfig
fonts-dejavu-extra gcc-avr gconf-service gconf2 gconf2-common
gnome-mime-data hicolor-icon-theme icedtea-7-jre-jamvm java-common
libasyncns0 libatk-wrapper-java libatk-wrapper-java-jni libatk1.0-0
libatk1.0-data libavahi-client3 libavahi-glib1 libbonobo2-0
libbonobo2-common libcairo2 libcanberra0 libcups2 libdatrie1
libdbus-glib-1-2 libdrm-amdgpu1 libdrm-freedreno1 libdrm-nouveau2
libdrm-radeon1 libflac8 libgconf-2-4 libgconf2-4 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-common libgif4 libgl1-mesa-dri libgl1-mesa-glx
libglapi-mesa libgnome-2-0 libgnome2-0 libgnome2-bin libgnome2-common
libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgraphite2-3
libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libharfbuzz0b libice6 libjasper1
libjna-java libjna-jni libllvm3.7 libltdl7 libnspr4 libnss3 libogg0
liborbit-2-0 libpam-systemd libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libpixman-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0
libpolkit-gobject-1-0 libpulse0 librxtx-java libsctp1 libsm6 libsndfile1
libtdb1 libthai-data libthai0 libtxc-dxtn-s2tc0 libvorbis0a libvorbisenc2
libvorbisfile3 libx11-xcb1 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
libxcb-present0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcomposite1
libxcursor1 libxdamage1 libxfixes3 libxi6 libxinerama1 libxrandr2
libxrender1 libxshmfence1 libxtst6 libxxf86vm1 lksctp-tools openjdk-7-jre
openjdk-7-jre-headless policykit-1 tzdata-java x11-common
0 upgraded, 113 newly installed, 0 to remove and 28 not upgraded.
Need to get 87.8 MB of archives.
After this operation, 288 MB of additional disk space will be used.
Get:1 http://archive.raspberrypi.org/debian/ jessie/main libpixman-1-0 armhf 0.33.3+git20151011-7de61d8-rpi1 [156 kB]
Get:2 http://archive.raspberrypi.org/debian/ jessie/main libcairo2 armhf 1.14.0-2.1rpi1rpi1g [661 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main fontconfig armhf 2.11.0-6.3 [402 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ jessie/main libasyncns0 armhf 0.8-5 [11.4 kB]
E: The method driver /usr/lib/apt/methods/https could not be found.
>>> Install Python PIP
Reading package lists...
Building dependency tree...
Reading state information...
python-pip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 28 not upgraded.
>>> Install INOTOOLS
Requirement already satisfied (use --upgrade to upgrade): ino in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): jinja2 in /usr/lib/python2.7/dist-packages (from ino)
Requirement already satisfied (use --upgrade to upgrade): pyserial in /usr/local/lib/python2.7/dist-packages (from ino)
Requirement already satisfied (use --upgrade to upgrade): configobj in /usr/local/lib/python2.7/dist-packages (from ino)
Requirement already satisfied (use --upgrade to upgrade): ordereddict in /usr/local/lib/python2.7/dist-packages (from ino)
Requirement already satisfied (use --upgrade to upgrade): argparse in /usr/lib/python2.7 (from ino)
Requirement already satisfied (use --upgrade to upgrade): markupsafe in /usr/lib/python2.7/dist-packages (from jinja2->ino)
Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python2.7/dist-packages (from configobj->ino)
Cleaning up...
>>> Install INOTOOLS
Searching for ino
Best match: ino 0.3.6
Adding ino 0.3.6 to easy-install.pth file
Using /usr/local/lib/python2.7/dist-packages
Processing dependencies for ino
Finished processing dependencies for ino
>>> Install AVRDUDE
Reading package lists...
Building dependency tree...
Reading state information...
avrdude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 28 not upgraded.
----------------------------
| Everything is installed! |
----------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Avez vous une idée ? Evidemment le démon est en stop.

Merci de votre réponse
Salut,

est-ce que l'installation des dépendances est marquée OK ?

J'ai fait la mise à jour jeedom V2 hier et donc la mise à jour arduidom. Je n'arrivais pas à installer les dépendances même après redémarrage du PI, je n'avais pas les mêmes erreurs que toi (impossible de se connecter au mirroir)
J'ai réussi à m'en sortir en me connectant en ssh sur le PI et en tapant :

Code : Tout sélectionner

sudo apt-get update
apt-get upgrade
Et ensuite j'ai relancé l'installation des dépendances, ça s'est bien passé j'ai pu transférer le sketch sur l'arduino et tout est passé OK.

J'espère que ça te débloquera aussi.

Bonsoir
Bon j'ai réussi en réinstallant l'os de mon raspberry et en manipulant un peu comme toi en ssh . Et le système a fini par se mettre en service . J'ai pas d'explication pour ce point. Il fonctionne maintenant

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 25 mars 2016, 09:39

chevalir a écrit :
maitrje a écrit :Bonjour à tous,

Nouveau sur le forum même si je le parcours avec intérêt depuis plusieurs mois.
Je me suis équipé il y a environ 2 mois avec RPI 2 sur lequel j'ai installé Jeedom et tout se passe bien. Plusieurs détecteurs de fumée Fibaro connectés, des volets Somfy RTS avec un Rfxtrx433E, interfaçage avec un WES 2 pour récupérer la Téléinfo, la conso d'eau, les différentes temp de ma VMC double flux, etc, que du bonheur !

Je m'attaque maintenant à la récupération d'infos à partir d'un Arduino.
J'ai un montage à base d'Arduino Uno qui permet de récupérer la hauteur d'eau dans ma cuve de récupération grâce à un capteur à ultra-sons.
Tout fonctionne bien côté Arduino et j'affiche bien sur le LCD de l'Arduino la hauteur d'eau de ma cuve.
Forcément, je veux maintenant connecter l'Arduino à Jeedom pour récupérer cette info dans Jeedom et pouvoir m'en servir dans différents scénario.
J'ai donc installé le plugin Arduidom, chargé le sketch fournit avec et l'arduino est détecté.

Ma question porte sur la meilleure façon de parvenir à mes fins. En effet pour activer le capteur à ultrasons, j'ai besoin de 2 ports digitaux de l'arduino, le premier sur lequel j'envoie un signal trigger d'environ 10ms et le second sur lequel je lis la réponse sous la forme d'un signal dont la durée est proportionnelle au temps qu'a mis l'echo pour revenir (PWM), on en déduit la distance.

Peut-on faire directement ces actions à partir du plugin Arduidom ou faut-il mieux insérer le code qui pilote le capteur dans le sketch Arduidom et remonter le résultat à Jeedom à travers une CustomValue ?

Merci d'avance pour vos avis éclairés
Ma réponse arrive peut-être un peu tard mais bon. Je ne pense pas que cela soit possible sans modif. du sketch.
Dans Le Skeck tu peux mettre ton code dans la méthode : customHook() si tu as besoin de temp réel pour faire ta mesure c'est peut-être bien de stopper la réception radio le temps de ta mesure comme cela (si tu as de la radio :) ) : J'imagine que tu n'a pas besoin de faire la mesure en permanance, dans ce cas il faudra mettre un timer cas la customHook est appelée à chaque tour de loop.

Code : Tout sélectionner

void customHook () {
// stop radio 
mySwitch.disableReceive(); 

//// ton code 


// start radio
			if (RadioRXpin == 2) mySwitch.enableReceive(0);
			if (RadioRXpin  == 3) mySwitch.enableReceive(1);
                #if defined(__AVR_ATmega168__) ||defined(__AVR_ATmega168P__) ||defined(__AVR_ATmega328P__) ||defined(__AVR_ATmega32U4__)
                #else
			if (RadioRXpin == 21) mySwitch.enableReceive(2);
			if (RadioRXpin == 20) mySwitch.enableReceive(3);
			if (RadioRXpin == 19) mySwitch.enableReceive(4);
			if (RadioRXpin == 18) mySwitch.enableReceive(5);
                #endif

}

bonne soirée,
chevalir
Merci chevalir
Je n'ai effectivement pas besoin d'une remontée en temps réel, une mesure toutes les 10 mins me suffit largement.
Je teste actuellement une autre approche sans le plugin Arduidom qui consiste à coder un mini serveur web sur l'arduino pour répondre à une requête Jeedom. ça me parait finalement plus adapté à ce besoin là mais je garde ta solution sous le coude pour d'autres applis à base d'arduino.

bonne journée

maitrje

Avatar de l’utilisateur
chevalir
Timide
Messages : 148
Inscription : 04 juin 2015, 20:39
Localisation : Ain
Contact :

Re: [Sujet officiel] Plugin ArduiDom

Message par chevalir » 25 mars 2016, 16:16

maitrje a écrit :
chevalir a écrit :
maitrje a écrit :Bonjour à tous,

Nouveau sur le forum même si je le parcours avec intérêt depuis plusieurs mois.
Je me suis équipé il y a environ 2 mois avec RPI 2 sur lequel j'ai installé Jeedom et tout se passe bien. Plusieurs détecteurs de fumée Fibaro connectés, des volets Somfy RTS avec un Rfxtrx433E, interfaçage avec un WES 2 pour récupérer la Téléinfo, la conso d'eau, les différentes temp de ma VMC double flux, etc, que du bonheur !

Je m'attaque maintenant à la récupération d'infos à partir d'un Arduino.
J'ai un montage à base d'Arduino Uno qui permet de récupérer la hauteur d'eau dans ma cuve de récupération grâce à un capteur à ultra-sons.
Tout fonctionne bien côté Arduino et j'affiche bien sur le LCD de l'Arduino la hauteur d'eau de ma cuve.
Forcément, je veux maintenant connecter l'Arduino à Jeedom pour récupérer cette info dans Jeedom et pouvoir m'en servir dans différents scénario.
J'ai donc installé le plugin Arduidom, chargé le sketch fournit avec et l'arduino est détecté.

Ma question porte sur la meilleure façon de parvenir à mes fins. En effet pour activer le capteur à ultrasons, j'ai besoin de 2 ports digitaux de l'arduino, le premier sur lequel j'envoie un signal trigger d'environ 10ms et le second sur lequel je lis la réponse sous la forme d'un signal dont la durée est proportionnelle au temps qu'a mis l'echo pour revenir (PWM), on en déduit la distance.

Peut-on faire directement ces actions à partir du plugin Arduidom ou faut-il mieux insérer le code qui pilote le capteur dans le sketch Arduidom et remonter le résultat à Jeedom à travers une CustomValue ?

Merci d'avance pour vos avis éclairés
Ma réponse arrive peut-être un peu tard mais bon. Je ne pense pas que cela soit possible sans modif. du sketch.
Dans Le Skeck tu peux mettre ton code dans la méthode : customHook() si tu as besoin de temp réel pour faire ta mesure c'est peut-être bien de stopper la réception radio le temps de ta mesure comme cela (si tu as de la radio :) ) : J'imagine que tu n'a pas besoin de faire la mesure en permanance, dans ce cas il faudra mettre un timer cas la customHook est appelée à chaque tour de loop.

Code : Tout sélectionner

void customHook () {
// stop radio 
mySwitch.disableReceive(); 

//// ton code 


// start radio
			if (RadioRXpin == 2) mySwitch.enableReceive(0);
			if (RadioRXpin  == 3) mySwitch.enableReceive(1);
                #if defined(__AVR_ATmega168__) ||defined(__AVR_ATmega168P__) ||defined(__AVR_ATmega328P__) ||defined(__AVR_ATmega32U4__)
                #else
			if (RadioRXpin == 21) mySwitch.enableReceive(2);
			if (RadioRXpin == 20) mySwitch.enableReceive(3);
			if (RadioRXpin == 19) mySwitch.enableReceive(4);
			if (RadioRXpin == 18) mySwitch.enableReceive(5);
                #endif

}

bonne soirée,
chevalir
Merci chevalir
Je n'ai effectivement pas besoin d'une remontée en temps réel, une mesure toutes les 10 mins me suffit largement.
Je teste actuellement une autre approche sans le plugin Arduidom qui consiste à coder un mini serveur web sur l'arduino pour répondre à une requête Jeedom. ça me parait finalement plus adapté à ce besoin là mais je garde ta solution sous le coude pour d'autres applis à base d'arduino.

bonne journée

maitrje
Pour moi c'est le point fort d'arduidom ... tu pose une valeur dans une customValue et hop cela remonte dans Jeedom ... à toi de mettre la customValue à jour à la fréquence que tu veux c'est très simple ... c'est cela qui m'a fait utiliser arduidom ... mais toutes les solutions sont bonnes ;)
chevalir

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 26 mars 2016, 18:06

Ma réponse arrive peut-être un peu tard mais bon. Je ne pense pas que cela soit possible sans modif. du sketch.
Dans Le Skeck tu peux mettre ton code dans la méthode : customHook() si tu as besoin de temp réel pour faire ta mesure c'est peut-être bien de stopper la réception radio le temps de ta mesure comme cela (si tu as de la radio :) ) : J'imagine que tu n'a pas besoin de faire la mesure en permanance, dans ce cas il faudra mettre un timer cas la customHook est appelée à chaque tour de loop.

Code : Tout sélectionner

void customHook () {
// stop radio 
mySwitch.disableReceive(); 

//// ton code 


// start radio
			if (RadioRXpin == 2) mySwitch.enableReceive(0);
			if (RadioRXpin  == 3) mySwitch.enableReceive(1);
                #if defined(__AVR_ATmega168__) ||defined(__AVR_ATmega168P__) ||defined(__AVR_ATmega328P__) ||defined(__AVR_ATmega32U4__)
                #else
			if (RadioRXpin == 21) mySwitch.enableReceive(2);
			if (RadioRXpin == 20) mySwitch.enableReceive(3);
			if (RadioRXpin == 19) mySwitch.enableReceive(4);
			if (RadioRXpin == 18) mySwitch.enableReceive(5);
                #endif

}

bonne soirée,
chevalir[/quote]

Merci chevalir
Je n'ai effectivement pas besoin d'une remontée en temps réel, une mesure toutes les 10 mins me suffit largement.
Je teste actuellement une autre approche sans le plugin Arduidom qui consiste à coder un mini serveur web sur l'arduino pour répondre à une requête Jeedom. ça me parait finalement plus adapté à ce besoin là mais je garde ta solution sous le coude pour d'autres applis à base d'arduino.

bonne journée

maitrje[/quote]

Pour moi c'est le point fort d'arduidom ... tu pose une valeur dans une customValue et hop cela remonte dans Jeedom ... à toi de mettre la customValue à jour à la fréquence que tu veux c'est très simple ... c'est cela qui m'a fait utiliser arduidom ... mais toutes les solutions sont bonnes ;)[/quote]

Bonjour
Je me suis replongé dans Arduidom et effectivement ce plugin a l'air très pratique.
Je vais donc persister avec Arduidom mais pour l'instant j'ai des erreurs de compil du sketch Arduidom_unified_V24:

Arduidom_unified_v24.ino: In function 'void setup()':
Arduidom_unified_v24.ino:214:20: error: 'InitEEPROM' was not declared in this scope
Arduidom_unified_v24.ino:235:15: error: 'setupHook' was not declared in this scope
Arduidom_unified_v24.ino: In function 'void loop()':
Arduidom_unified_v24.ino:465:34: error: 'ReloadEEPROM' was not declared in this scope
Arduidom_unified_v24.ino:533:24: error: 'serialHook' was not declared in this scope
Arduidom_unified_v24.ino:759:37: error: 'rfReceptionHook' was not declared in this scope
Arduidom_unified_v24.ino:899:20: error: 'customHook' was not declared in this scope
Erreur lors de la compilation.

Qu'est-ce que j'ai raté ?

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 26 mars 2016, 18:13

En fait ça me fait cette erreur quand je désactive le shield Ethernet #define CNF_NETWORK 0

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 27 mars 2016, 12:57

Bonjour,

Bon finalement, j'ai configuré en ethernet et là il est bien reconnu par le plugin Arduidom.
Par contre les valeurs CustomValue[0], CustomValue[1] et CustomValue[2] dans lesquelles je mets des valeurs de type float, ne remontent pas dans le virtuel que j'ai créé, tout reste à 0...
Si vous avez des idées, je suis preneur

merci

Avatar de l’utilisateur
chevalir
Timide
Messages : 148
Inscription : 04 juin 2015, 20:39
Localisation : Ain
Contact :

Re: [Sujet officiel] Plugin ArduiDom

Message par chevalir » 27 mars 2016, 20:45

maitrje a écrit :Bonjour,

Bon finalement, j'ai configuré en ethernet et là il est bien reconnu par le plugin Arduidom.
Par contre les valeurs CustomValue[0], CustomValue[1] et CustomValue[2] dans lesquelles je mets des valeurs de type float, ne remontent pas dans le virtuel que j'ai créé, tout reste à 0...
Si vous avez des idées, je suis preneur

merci
je compile toujours avec
#define CNF_NETWORK 0
sans erreur car je n'est pas de shield ethernet ... par contre il faut IDE en 1.6.7 avec les versions précédentes j'avais des erreurs...
Sinon pour les customs il faut juste attendre ce n'est pas immédiat ... quelle valeur as-tu pour #define CUSTOM_DELAY ?
tu peux lancer le démon en débug et regarder dans les log /temp/arduidom_demon tu doit voir passer la mise à jour des customs >>valeur<<
chevalir

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 28 mars 2016, 20:04

bonjour,

pour l'arduino, j'ai l'IDE 1.7.8 et dans CUSTOM_DELAY j'ai mis 10000 (une mesure toutes les 10 s)
Rien à faire si je mets CNF_NETWORK 0, j'ai les erreurs de compile.

Sinon en ethernet, dans le plugin Arduidom j'ai configuré les pins avec CustomValue[0] à [3] en "entrée customisée".
J'ai créé un équipement Arduidom avec 3 commandes Info numérique une pour chaque CustomValue.
Ensuite j'ai crée un virtuel qui va récupérer les valeurs des 3 commande de l'équipement Arduidom.
Les valeurs ne remontent pas dans le virtuel. J'ai raté qq chose, mais quoi ?

Sur tes conseils je suis allé voir les logs dans /temp/aduidom_demo mais il n'y a rien qui ressemble à une mise à jour de valeur:

2016-03-28 18:59:07,100 | INFO | MainThread - arduidomx:622 - .
2016-03-28 18:59:07,100 | INFO | MainThread - arduidomx:651 - Verify Arduino Version [124] >> Arduino 1
2016-03-28 18:59:07,101 | INFO | MainThread - arduidomx:826 - Launch Main TCP Thread
2016-03-28 18:59:07,103 | INFO | MainThread - arduidomx:836 - .
2016-03-28 18:59:07,114 | INFO | MainThread - arduidomx:837 - .
2016-03-28 18:59:07,115 | INFO | MainThread - arduidomx:838 - Prepare to launch TCP Thread(s) on base port 58200...
2016-03-28 18:59:07,618 | INFO | MainThread - arduidomx:854 - Launch TCP Thread n°1
2016-03-28 18:59:07,620 | INFO | MainThread - arduidomx:863 - ALL TCP Threads Launched !
2016-03-28 18:59:07,621 | INFO | MainThread - arduidomx:865 - Tell to jeedom Arduinos are OK
2016-03-28 18:59:07,635 | INFO | MainThread - arduidomx:869 - Surveille le .kill ...

Avatar de l’utilisateur
chevalir
Timide
Messages : 148
Inscription : 04 juin 2015, 20:39
Localisation : Ain
Contact :

Re: [Sujet officiel] Plugin ArduiDom

Message par chevalir » 29 mars 2016, 21:59

maitrje a écrit :bonjour,

pour l'arduino, j'ai l'IDE 1.7.8 et dans CUSTOM_DELAY j'ai mis 10000 (une mesure toutes les 10 s)
Rien à faire si je mets CNF_NETWORK 0, j'ai les erreurs de compile.

Sinon en ethernet, dans le plugin Arduidom j'ai configuré les pins avec CustomValue[0] à [3] en "entrée customisée".
J'ai créé un équipement Arduidom avec 3 commandes Info numérique une pour chaque CustomValue.
Ensuite j'ai crée un virtuel qui va récupérer les valeurs des 3 commande de l'équipement Arduidom.
Les valeurs ne remontent pas dans le virtuel. J'ai raté qq chose, mais quoi ?

Sur tes conseils je suis allé voir les logs dans /temp/aduidom_demo mais il n'y a rien qui ressemble à une mise à jour de valeur:

2016-03-28 18:59:07,100 | INFO | MainThread - arduidomx:622 - .
2016-03-28 18:59:07,100 | INFO | MainThread - arduidomx:651 - Verify Arduino Version [124] >> Arduino 1
2016-03-28 18:59:07,101 | INFO | MainThread - arduidomx:826 - Launch Main TCP Thread
2016-03-28 18:59:07,103 | INFO | MainThread - arduidomx:836 - .
2016-03-28 18:59:07,114 | INFO | MainThread - arduidomx:837 - .
2016-03-28 18:59:07,115 | INFO | MainThread - arduidomx:838 - Prepare to launch TCP Thread(s) on base port 58200...
2016-03-28 18:59:07,618 | INFO | MainThread - arduidomx:854 - Launch TCP Thread n°1
2016-03-28 18:59:07,620 | INFO | MainThread - arduidomx:863 - ALL TCP Threads Launched !
2016-03-28 18:59:07,621 | INFO | MainThread - arduidomx:865 - Tell to jeedom Arduinos are OK
2016-03-28 18:59:07,635 | INFO | MainThread - arduidomx:869 - Surveille le .kill ...

Pour l'IDE c'est 1.6.8 non ... j'ai pas vu 1.7.x encore ? ou alors cela dépend de l'OS !!
j'ai revivifier j'ai bien tout mes sketch qui compile avec CNF_NETWORK 0 donc si tu pose ton sketch quelque part je veux bien essayer de le compiler.

Pour les log est-ce que tu as lancer le deamon en débug ?

Sinon il faudra attendre que bobox59 passe sur le forum car la je ne peux pas t'aider plus !! En plus la carte SD de mon RPi vient de lâcher ... :cry: ... donc plus de test possible pour moi avant un jour ou deux ... :(
chevalir
chevalir

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 30 mars 2016, 09:40

Bonjour chevalir,

Pour l'IDE Arduino, il s'agit bien de la version 1.7.8, pour Windows. J'ai même chargé hier soir la version 1.7.9.
En prenant le sketch livré avec le plugin, sans rien y changer, (juste CNF_NETWORK 0) ça ne compile pas.
C'est peut-être lié à la version de l'IDE ?
Je vais vérifier pour les logs debug du deamon, il me semblait les avoir activé.

Cela dit, le mode ethernet me convient aussi (il me faudra juste une alim en + pour l'arduino) mais les CustomValue ne remontent toujours pas et ça me bloque pour la suite.

Merci pour tes retours et bon courage pour remonter ton RPi

cinpou
Timide
Messages : 25
Inscription : 18 févr. 2016, 00:00

Re: [Sujet officiel] Plugin ArduiDom

Message par cinpou » 30 mars 2016, 13:52

Yo!

Ta clé api contient combien de caractères? J'ai eu un problème de remontée d'info, parce que j'utilise une V2 neuve avec une clé api plus longue que ceux en V1 ou en upgrade de V1. Bobox m'a créé une version modifiée pour ce cas qui fonctionne bien.

Bon courage

maitrje
Timide
Messages : 36
Inscription : 20 mars 2016, 12:44

Re: [Sujet officiel] Plugin ArduiDom

Message par maitrje » 30 mars 2016, 14:35

bonjour,

Ma clé API fait 20 caractères. j'ai fait un upgrade depuis une V1.
Tu penses que ça peut poser pb ? Faut la préciser qq part la clé api où c'est le plugin qui la récupère sur Jeedom ?

merci

cinpou
Timide
Messages : 25
Inscription : 18 févr. 2016, 00:00

Re: [Sujet officiel] Plugin ArduiDom

Message par cinpou » 30 mars 2016, 15:39

c'est le plugin qui la récupère automatiquement, mais il dispose d'une plage limitée en mémoire pour le faire. Dans ton cas, c'est bon. Je te liste les points de vérification de Bobox :

verifie ta configuration réseaux dans la partie config de jeedom
verifie bien tes IP dans jeedom ET dans le sketch
verifie l'option qui dit si tu utilise ou non le /jeedom pour acceder a l'interface
verifie que ta clé api de jeedom fait bien 20 caracteres aussi
verifie que tu n'a pas de pare-feu activé sur le serveur jeedom

Xiboard
Timide
Messages : 83
Inscription : 04 janv. 2016, 20:39

Re: [Sujet officiel] Plugin ArduiDom

Message par Xiboard » 30 mars 2016, 22:32

Salut à tous,

Je suis en train de tester ArduiDom en vue de basculer ma gestion actuelle de mes lumières et inter de la maison :
Actuellement solution maison sur arduinos et shield ethernet, communication avec commandes en http + json (imperihome)
12 télérupteurs commandé par carte 16 relais (impulsion de 50ms) > Commandent les plafonniers et éclairages.
Boutons poussoirs câblé en direct sur arduino (oui sur plus de 10m de 1.5² ça marche en pull-up !!!)

D'ailleurs, je fait une aparté par rapport au quelques pages que j'ai lu précédemment. Je n'ai pas de retour d'état sur les télérupteur. Je peux donc avoir une inversion de l'état réel du télé et de ce que crois mon programme. Dans la pratique ça arrive très rarement. (je doit avoir encore qq bug ou autres).
Mais j'ai développé aussi un détecteur de 220V que j'utilise pour savoir si le brûleur de la chaudière fonctionne (calcul exact de la conso). Moi aussi je ne voulais pas truc qui consomme en plus, j'ai aussi fait la technique opto coupleur direct sur le 220V par contre derrière opto, j'ai quasi rien. Mon montage est plus simple. (il faut que je retrouve mon schéma) Mon montage est en fonction depuis plus d'un an donc il marche bien.
J'hésite à faire une carte pour mesurer le 220V sur la sortie de chacun de mes télé pour être sûr.

Retour de mes premiers essais : j'pense que je vais pas avoir de pb avec les télérupteurs.
Par contre je bloque un peu sur les boutons poussoirs : Quand je fait un "clic", ça va tellement vite que par exemple dans un scénario ça ne fait rien.
J'ai raté quelque chose ? Vous avez une idée comment faire ?

Autre point aussi, j'avais développé/modifié une librairie pour faire des doubles clic et des appuis long et autres combinaisons. (j'ai des doubles poussoirs, si on appui sur les 2 simultanément, ça faisait autre chose). Bon en toute honnêteté, c'était fun et pratique mais ça ne fessai marrer que moi car assez compliqué à retenir. Pour refaire ça, je ne vois que du rajout de code et passer par des virtuels par exemple.

Evolution aussi : je voudrai que en mode alarme activée, l'action des BP n'allume pas les lumière mais agisse comme déclencheur de l'alarme. On peux faire clignoter toutes les lumières au déclenchement par contre... (A gérer avec des scénario ça, je pense)
Jeedom 3.2.11 / RPI 3+

Xiboard
Timide
Messages : 83
Inscription : 04 janv. 2016, 20:39

Re: [Sujet officiel] Plugin ArduiDom

Message par Xiboard » 01 avr. 2016, 11:23

J'ai finalement réussi à avoir une réaction (plus ou moins) rapide (~1-3s) en faisant de la sorte :
-Dans mon Équipement Arduidom de mon bouton poussoir
>Commande ETAT
>Paramètres Avancées
>Configuration Avancée
>Action sur la valeur
-Si égal à 1 plus de 0min lancement de scénario bascule lampe (scénario qui bascule l'état d'une lampe !)

Si vous avez mieux je suis preneur ?

A la rigueur ce qui pourrai être pas mal c'est de rajouter dans la config des pins, la possibilité d'un pilotage direct Etat d'une Entrée = Pilote Etat d'une Sortie. Mais à gérer tout ça, ça va être coton (cas des inversion, des pulses, etc....) Donc un peu à la façon des relais fibaro.

A+
Jeedom 3.2.11 / RPI 3+

cinpou
Timide
Messages : 25
Inscription : 18 févr. 2016, 00:00

Re: [Sujet officiel] Plugin ArduiDom

Message par cinpou » 01 avr. 2016, 11:56

Bonjour,

tu peux aussi modifier le sketch pour gérer l'action directement par l'arduino.
L'information d'allumage remontera via le demon.

bob755
Timide
Messages : 132
Inscription : 02 févr. 2016, 11:58

Re: [Sujet officiel] Plugin ArduiDom

Message par bob755 » 01 avr. 2016, 14:13

Bonjour,

Je compte utiliser le plugin ArduiDom avec un emetteur et recepteur 433MHz et je voudrais installer un module de suivi d’énergie OWL CM160.
L'idée sera de surveiller la consommation instantanée pour couper certains appareils si la consommation est trop élevée (délestage).

Est-il possible d'interfacer in CM160 via ArduiDom et utiliser les mesures pour commander les appareils. Si oui, comment faire?
Les appareils seront commandés via des modules on/off CHACON.

Merci d'avance

Avatar de l’utilisateur
chevalir
Timide
Messages : 148
Inscription : 04 juin 2015, 20:39
Localisation : Ain
Contact :

Re: [Sujet officiel] Plugin ArduiDom

Message par chevalir » 02 avr. 2016, 15:59

@Xiboard
Pour la solution du scénario activé par une "Action sur la valeur" me semble bonne. Pour le délais, j'ai fait le même constat, c'est un peu trop long. c'est peu normal il faut passé tous les étages , le sketch, le démon, les triggers de Jeedom et redéscendre par le même chemin. C'est une des raisons pour laquelle j'ai laissé mes poussoirs directement branchés sur le télérupteur en plus du relais. L'autre raison était de garder un mode 'manuel" totalement indépendant de la domotique en cas de panne Rpi/Arduino ;) .

Sinon si tu retrouve ton schéma 220V/5V je suis preneur surtout si il est fonction chez toi et qu'il est plus simple que celui que j'ai posté.
Autre question/info j'ai eu quelque probléme en pilotant le relais depuis l'Arduidom, j'avais des impulsions intenpestives sur le relais lors des redémarrage de l'arduino mais aussi lors du redémarrage du démon Arduidom ... est-ce que tu constate la même chose ? (du coup j'ai les relais connectés directement au Rpi par contre j'ai laissé la RF433 et les remontés d'états sur Arduidom)

Dernière chose, j'ai beaucoup aimer ton truc avec les deux poussoirs en simultanés :D j'image la réaction des autres utilisateurs ... tu n'a pas essayer de gérer le "double clic" sur poussoir ;). C'est vrai que la connexion direct des poussoirs sur l'Arduino permet plein chose ...
chevalir
chevalir

tetenfer
Timide
Messages : 20
Inscription : 09 nov. 2014, 21:17

Re: [Sujet officiel] Plugin ArduiDom

Message par tetenfer » 03 avr. 2016, 14:07

Bonjour a tous,

premièrement super boulot pour le plugin Arduidom, arduino recu avec shield ethernet sketch installer et 5 minute après je faisait coller mon relai. et encore 5 minute après je brancher un bouton poussoir et hop le widget me donne l'etat du bouton...au top.

premières question ;) , mon but et de pouvoir faire changer mon relai avec le bouton poussoir en mode bistable, exemple : un coup sur le bouton poussoir le relai colle, un autre coup et le relai décolle. j'ai pas mal chercher sur le forum mais j'ai rien trouver de concluant, si une âme charitable pouvez me donner un indice, un scenario ? un virtuel ? dans l'équipement ? j'ai tester avec un scenario mais j'ai des réactions bizarre, si j'appuis moins d'une seconde il colle le relai et 2sec apres il decole ou l'inverse suivant l'etat au depart. si j'appuis plus de 2 seconde sa fonctionne??.

Image

j'ai tester beaucoup de combinaison, mais rien n'est vraiment fiable si quelq'un a une idée.

et deuxièmes question mais pour pure culture personnel, j'ai donc un arduino mega brancher en usb sur mon pc pour l'alimentation et un shield ethernet pour la comunication, et de l'autre une carte 16 relais optocouplé brancher tout seul en 12v sur une alimentation ATX separer qui me sert d'alim 5v/12v pour mes teste. le truc que je trouve bizarre : j'ai qu'un fils qui donne l'ordre entre l'arduino et la carte relais, le Grd brancher ou pas sa fonctionne, comme si le retour se faisait par l'alim puis le 220v, circuit de la maison , alim du PC et l'usb et l'arduino. normale ??

Par avance Merci

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 4 invités