Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers] Zigate

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Avatar de l’utilisateur
fredlamour
Timide
Messages : 260
Inscription : 31 janv. 2016, 11:38
Localisation : Brissac Loire Aubance

Re: [Plugin Tiers] Zigate

Message par fredlamour » 19 juil. 2019, 08:14

Bonjour,
J'ai migrer tous mes modules Xiaomi, Hue et OSRAM vers Zigate et cela fonctionne très bien.
Cependant lors du redemarrage du jeedom ou du plugin, je me retrouve avec ce message dans les log :

Code : Tout sélectionner

	2019-07-19 08:07:18	zigate	L'IEEE de l'équipement ea1e est absent, vous devriez refaire l'association
J'ai fait le tour de tous mes modules et aucun n'a l'identifiant ea1e. Que faut il faire ?
Merci pour votre aide.

dragonslore
Timide
Messages : 39
Inscription : 20 mai 2017, 14:15

Re: [Plugin Tiers] Zigate

Message par dragonslore » 19 juil. 2019, 09:42

Bonjour à tous,

J'ai un NAS Synology 1812+ et un jeedom sous Docker, j'ai déjà en place une clé USB Zwave+ qui fonctionne très bien.
Je viens de recevoir ma Zigate USB, je l'ai mise à jour en firmware, elle est branché en direct (led rouge et bleu allumées), il est bien detecté par l'OS de mon Synology par contre je ne le retrouve pas dans Jeedom dockerisé.
2019-07-19_12h30_17.png
2019-07-19_12h30_17.png (23.69 Kio) Consulté 492 fois
2019-07-19_12h29_31.png
2019-07-19_12h29_31.png (16.63 Kio) Consulté 492 fois
Avez vous une idée ?
Merci pour votre aide.
Manu
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

vince84
Timide
Messages : 5
Inscription : 04 nov. 2018, 14:35

Re: [Plugin Tiers] Zigate

Message par vince84 » 19 juil. 2019, 19:32

Bonjour,

J'ai fait l’acquisition d'une zigate récemment. Je ne parviens pas inclure quoi que ce soit. J'ai essayé un ampoule Philips hue blanche que j'ai préalablement réinitialisée avec le dimmer Philips. J'ai essayé d'inclure une prise osram neuve et je ne vois rien remonter dans le plugin. Je dois surement faire quelque chose de mal, mais je ne sais pas quoi. Les dépendances se sont bien installées et le daemon est bien lancé.
Je suis en version 1.2.3 du plugin, version lib : 0.28.4 et jeedom : 3.3.27.

Merci pour votre aide
Vince

Blum95
Timide
Messages : 322
Inscription : 10 oct. 2014, 18:16

Re: [Plugin Tiers] Zigate

Message par Blum95 » 20 juil. 2019, 07:42

Pareil pour moi. J'arrive à rien inclure (aqara)

Envoyé de mon POCOPHONE F1 en utilisant Tapatalk

Jeedom sur ESXi SSD Debian 9.
ZWAVE, RFXCOM, BT, TéléInfo, WifiLight, Alexa
9 Sondes, 4 Detecteurs 6 Ouvertures en 433.
9 Modules Zwave
5 Cams IP

jerome6994
Timide
Messages : 360
Inscription : 04 juin 2019, 12:36
Localisation : Lyon

Re: [Plugin Tiers] Zigate

Message par jerome6994 » 20 juil. 2019, 07:49

Bonjour

Je viens de mettre à jour ce matin le plugin et ce que je craignais est encore arrivé !
A la fin de la mise à jour qui c'est super bien passée je suis retourné dans la config le démon était KO et du coup quand je suis allé dans le plugin voir mes équipements : il y avait plus rien !!!
Un lancement d'un synchronisation à remis tout le monde mais en perdant l'objet parent et les noms que j'avais mis moi.
Le pire c'est que dans mes scénarios les commandes ont donc sautée et je n'ai plus que les ID #1983# par exemple !
Je dois aussi refaire tous mes éléments dans le Design !!!

C'est pas compliqué de remettre les éléments mais est-ce qu'il y aurait pas un correctif à faire pour que cela ne se produise pas ou plus car c'est long à faire.

Ou bien c'est moi qui m'y prend mal et je veux bien la marche à suivre

Merci
RPI 3 B+ : Jeedom 3.3.32 - Z-Wave + : Z-Stick GEN5 - Aeon Labs - RFXCom - ZiGate USB-TTL ZigBee®
IOT : Station Météo, Thermostat, Vannes Netatmo, Volets Profalux, Prises DI-O, Somfy Home Alarm, Hue, Fibaro

jerome6994
Timide
Messages : 360
Inscription : 04 juin 2019, 12:36
Localisation : Lyon

Re: [Plugin Tiers] Zigate

Message par jerome6994 » 20 juil. 2019, 10:17

Je viens de terminer les visuels et les mises en forme.
Maintenant il faut que je passe à la modification des scéanii !!!

Il faut vraiment me dire s'il existe une astuce pour ne pas perdre les infos en cas de mise à jour de de coupure de courant
RPI 3 B+ : Jeedom 3.3.32 - Z-Wave + : Z-Stick GEN5 - Aeon Labs - RFXCom - ZiGate USB-TTL ZigBee®
IOT : Station Météo, Thermostat, Vannes Netatmo, Volets Profalux, Prises DI-O, Somfy Home Alarm, Hue, Fibaro

Avatar de l’utilisateur
Woualy
Timide
Messages : 144
Inscription : 09 déc. 2018, 15:24
Localisation : Le Havre
Contact :

Re: [Plugin Tiers] Zigate

Message par Woualy » 20 juil. 2019, 11:56

J'ai fait la mise à jour de ma clé Zigate (bleue) en 3.0.f. Pas de soucis, redémarrage de la Jeedom. Ce matin, mise à jour du plugin Ziagte.
Je fais la mise à jour, relance des dépendances : Ca monte jusqu'a 70% - 1 min et aprés plus rien, pas de bouton de démarrage de Démon, plus de clé (pourtant bien en USB), plus de périphérique, Bref PLUS RIEN !

J'ai même desinstallé, reinstallé le plug in ZIgate , pas mieux :(

A la fin du log Update , j'ai ça

Code : Tout sélectionner

building 'RPi._GPIO' extension
creating build/temp.linux-aarch64-3.5
creating build/temp.linux-aarch64-3.5/source
aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-kWxB2e/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.5m -c source/py_gpio.c -o build/temp.linux-aarch64-3.5/source/py_gpio.o
source/py_gpio.c:23:20: fatal error: Python.h: No such file or directory
#include "Python.h"
^
compilation terminated.
error: command 'aarch64-linux-gnu-gcc' failed with exit status 1
----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-db326ymp/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-_5etzvtl-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-db326ymp/RPi.GPIO/
Installation des dépendances terminé !
Jeedom Smart + 6 FGR-223 + 7 capteurs ouvertures Xiaomi + 1 capteur Sensor Xiaomi + Clé Zigate

mamiot
Timide
Messages : 24
Inscription : 12 déc. 2018, 10:39

Re: [Plugin Tiers] Zigate

Message par mamiot » 20 juil. 2019, 12:22

Bonjour,

Également intéressé pour une astuce (ou évolution) pour éviter de devoir refaire toutes les associations dès que la clé est débranchée/rebranchée.
Sans compter la perte de l'historique, ennuyeux pour tout ce qui est température. J'en suis venu à faire des virtuels qui font tampon entre la zigate et Jeedom pour ne pas perdre l'historique, les designs... Solution dégradée que je trouve loin d'être idéale même si ça dépanne bien !

Bonne journée !

delawich
Timide
Messages : 257
Inscription : 11 nov. 2015, 11:31

Re: [Plugin Tiers] Zigate

Message par delawich » 20 juil. 2019, 12:48

Bonjour a tous

j'ai ce matin fait la mise a jour du plugin, la MAJ passe ok, mais le demon ne veut plus passer en OK

j'ai également perdu toute mes association

voici le log en mode debug

Code : Tout sélectionner

[2019-07-20 12:45:12][INFO] : Lancement démon zigate : /usr/bin/python3 /var/www/html/plugins/zigate/core/class/../../resources/zigated/zigated.py  --device auto --gpio 1 --loglevel debug --apikey b2wkwn0lerM4VAc5EU7RNjZaW6FH2CAh --pid /tmp/jeedom/zigate/daemon.pid --socket /tmp/jeedom/zigate/daemon.sock --callback http://127.0.0.1:80/plugins/zigate/core/php/jeeZiGate.php --sharedata 0
[2019-07-20 12:45:14][INFO][root](MainThread) : Start zigated
[2019-07-20 12:45:14][INFO][root](MainThread) : Log level : debug
[2019-07-20 12:45:14][INFO][root](MainThread) : Socket : /tmp/jeedom/zigate/daemon.sock
[2019-07-20 12:45:14][INFO][root](MainThread) : PID file : /tmp/jeedom/zigate/daemon.pid
[2019-07-20 12:45:14][INFO][root](MainThread) : Apikey : b2wkwn0lerM4VAc5EU7RNjZaW6FH2CAh
[2019-07-20 12:45:14][INFO][root](MainThread) : Device : auto
[2019-07-20 12:45:14][INFO][root](MainThread) : Callback : http://127.0.0.1:80/plugins/zigate/core/php/jeeZiGate.php
[2019-07-20 12:45:14][INFO][root](MainThread) : Python version : 3.4.2 (default, Feb 10 2019, 17:23:02)
[GCC 4.9.2]
[2019-07-20 12:45:14][INFO][root](MainThread) : zigate version : 0.31.0
[2019-07-20 12:45:14][INFO][root](MainThread) : Plugin Abeille détecté, vérification de l'état
[2019-07-20 12:45:14][INFO][root](MainThread) : Ok, le plugin Abeille ne semble pas en fonctionnement.
[2019-07-20 12:45:14][DEBUG][root](MainThread) : Writing PID 14966 to /tmp/jeedom/zigate/daemon.pid
[2019-07-20 12:45:14][DEBUG][root](MainThread) : Send to test to jeedom
[2019-07-20 12:45:14][DEBUG][root](MainThread) : Send to jeedom :  {'action': 'test'}
[2019-07-20 12:45:14][DEBUG] : Array (     [action] => test )
[2019-07-20 12:45:14][DEBUG][root](MainThread) : Jeedom reply :  {'success': True}
[2019-07-20 12:45:14][INFO][root](MainThread) : Démarrage ZiGate auto
Traceback (most recent call last):
File "/var/www/html/plugins/zigate/core/class/../../resources/zigated/zigated.py", line 317, in <module>
z = zigate.ZiGateGPIO(args.device, persistent_file, auto_start=False)
File "/usr/local/lib/python3.4/dist-packages/zigate/core.py", line 2139, in __init__
GPIO.setup(27, GPIO.OUT)  # GPIO2
RuntimeError: No access to /dev/mem.  Try running as root!
[2019-07-20 12:45:15][INFO] : Démon zigate lancé
[2019-07-20 12:45:15][DEBUG] : Synchronisation des équipements entre le démon et jeedom
[2019-07-20 12:45:15][DEBUG] : callZiGate devices
[2019-07-20 12:45:15][DEBUG] : result callZiGate
[2019-07-20 12:45:15][DEBUG] : Désactivation des équipements manquants
[2019-07-20 12:45:15][DEBUG] : callZiGate get_missing
[2019-07-20 12:45:15][DEBUG] : result callZiGate
merci pour votre aide

Avatar de l’utilisateur
Woualy
Timide
Messages : 144
Inscription : 09 déc. 2018, 15:24
Localisation : Le Havre
Contact :

Re: [Plugin Tiers] Zigate

Message par Woualy » 20 juil. 2019, 13:17

Mise à jour du Firmware en 3.1a avec erase de l'eeprom, toujours le même problème

Plugin 1.3.0, clé en 3.1a , pas d'installation de dépendances.

Voila les logs de l'update :

Code : Tout sélectionner

Installation des dépendances
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://www.deb-multimedia.org stretch InRelease
Hit:4 http://repo.jeedom.com/odroid stable InRelease
Hit:5 http://ftp.debian.org/debian stretch-updates InRelease
Hit:6 http://ftp.debian.org/debian stretch-backports InRelease
Hit:7 http://ftp.debian.org/debian stretch-proposed-updates InRelease
Hit:8 http://ftp.debian.org/debian stretch Release
Hit:9 https://oph.mdrjr.net/meveric all InRelease
Hit:10 https://oph.mdrjr.net/meveric stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
python3 is already the newest version (3.5.3-1).
The following packages were automatically installed and are no longer required:
libmemcached11 libmemcachedutil2 libmysqlclient18 libonig2 libopts25
libpng12-0 libqdbm14 libvpx1 linux-image-3.14.29+
linux-image-arm64-odroid-c2 u-boot-tools
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version (9.0.1-2+deb9u1).
The following packages were automatically installed and are no longer required:
libmemcached11 libmemcachedutil2 libmysqlclient18 libonig2 libopts25
libpng12-0 libqdbm14 libvpx1 linux-image-3.14.29+
linux-image-arm64-odroid-c2 u-boot-tools
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python3-requests is already the newest version (2.12.4-1).
The following packages were automatically installed and are no longer required:
libmemcached11 libmemcachedutil2 libmysqlclient18 libonig2 libopts25
libpng12-0 libqdbm14 libvpx1 linux-image-3.14.29+
linux-image-arm64-odroid-c2 u-boot-tools
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python3-setuptools is already the newest version (33.1.1-1).
The following packages were automatically installed and are no longer required:
libmemcached11 libmemcachedutil2 libmysqlclient18 libonig2 libopts25
libpng12-0 libqdbm14 libvpx1 linux-image-3.14.29+
linux-image-arm64-odroid-c2 u-boot-tools
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 162 not upgraded.
Collecting zigate==0.31.0
Using cached https://files.pythonhosted.org/packages/08/59/11f5fa73c373cdc37cc8cad6bf08aa5041fa4dc345f7cc825f2c44a83a14/zigate-0.31.0-py3-none-any.whl
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Collecting RPi.GPIO (from zigate==0.31.0)
Using cached https://files.pythonhosted.org/packages/af/2f/407b6e4cc8a0bdf434825a160bba1807991886b63cce16a5f1a6e1f24cdf/RPi.GPIO-0.6.5.tar.gz
Requirement already satisfied: bottle in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Requirement already satisfied: pydispatcher in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Building wheels for collected packages: RPi.GPIO
Running setup.py bdist_wheel for RPi.GPIO: started
Running setup.py bdist_wheel for RPi.GPIO: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-lz0hiv0m/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmp9ulep_jzpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for RPi.GPIO
Running setup.py clean for RPi.GPIO
Failed to build RPi.GPIO
Installing collected packages: RPi.GPIO, zigate
Running setup.py install for RPi.GPIO: started
Running setup.py install for RPi.GPIO: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-lz0hiv0m/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ldlcs6lw-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-aarch64-3.5
creating build/lib.linux-aarch64-3.5/RPi
copying RPi/__init__.py -> build/lib.linux-aarch64-3.5/RPi
creating build/lib.linux-aarch64-3.5/RPi/GPIO
copying RPi/GPIO/__init__.py -> build/lib.linux-aarch64-3.5/RPi/GPIO
running build_ext
building 'RPi._GPIO' extension
creating build/temp.linux-aarch64-3.5
creating build/temp.linux-aarch64-3.5/source
aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-kWxB2e/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.5m -c source/py_gpio.c -o build/temp.linux-aarch64-3.5/source/py_gpio.o
source/py_gpio.c:23:20: fatal error: Python.h: No such file or directory
#include "Python.h"
^
compilation terminated.
error: command 'aarch64-linux-gnu-gcc' failed with exit status 1
----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-lz0hiv0m/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ldlcs6lw-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-lz0hiv0m/RPi.GPIO/
Installation des dépendances terminé !
Y'a 2 messages d'erreurs sur la fin, des erreurs de compile
Jeedom Smart + 6 FGR-223 + 7 capteurs ouvertures Xiaomi + 1 capteur Sensor Xiaomi + Clé Zigate

nirronico
Timide
Messages : 3
Inscription : 20 juil. 2019, 14:12

Re: [Plugin Tiers] Zigate

Message par nirronico » 20 juil. 2019, 14:20

Bonjour,

J'ai fait la mise à jour du plugin Zigate et ensuite relancé la mise à jour des dépendances qui n'a pas fonctionné (pb après 70% d'installation).

Après avoir redémarrer ma box Jeedom, la date de dernière installation est passée à "2022-04-04 07:05:36" alors que la date du système est correcte. Du coup, impossible de relancer l'installation des dépendances car j'ai le message Jeedom "Vous devez attendre au moins 60 secondes entre deux installations de dépendances".

Comment je peux faire pour relancer les dépendances du plugin en mode console SSH (en espérant que cela remette une valeur cohérente pour la date de dernière installation des dépendances) ?

Merci !

nirronico
Timide
Messages : 3
Inscription : 20 juil. 2019, 14:12

Re: [Plugin Tiers] Zigate

Message par nirronico » 20 juil. 2019, 17:15

Je me réponds à moi même :
Il faut aller dans le répertoire "/var/www/html/plugins/zigate/resources"
et lancer la commande "sudo sh install_apt.sh"

Mais ça ne règle pas la date de dernière installation des dépendances qui reste à "2022-04-04 07:05:36" et surtout, l'installation des dépendances tombe en erreur (je mets juste la fin de la log) :

Collecting zigate==0.31.0
Using cached https://files.pythonhosted.org/packages ... ne-any.whl
Requirement already satisfied: pydispatcher in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Requirement already satisfied: bottle in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Collecting RPi.GPIO (from zigate==0.31.0)
Using cached https://files.pythonhosted.org/packages ... 6.5.tar.gz
Building wheels for collected packages: RPi.GPIO
Running setup.py bdist_wheel for RPi.GPIO ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpo5uyhr0jpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for RPi.GPIO
Running setup.py clean for RPi.GPIO
Failed to build RPi.GPIO
Installing collected packages: RPi.GPIO, zigate
Running setup.py install for RPi.GPIO ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-7sjys_ew-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-aarch64-3.5
creating build/lib.linux-aarch64-3.5/RPi
copying RPi/__init__.py -> build/lib.linux-aarch64-3.5/RPi
creating build/lib.linux-aarch64-3.5/RPi/GPIO
copying RPi/GPIO/__init__.py -> build/lib.linux-aarch64-3.5/RPi/GPIO
running build_ext
building 'RPi._GPIO' extension
creating build/temp.linux-aarch64-3.5
creating build/temp.linux-aarch64-3.5/source
aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-kWxB2e/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.5m -c source/py_gpio.c -o build/temp.linux-aarch64-3.5/source/py_gpio.o
source/py_gpio.c:23:20: fatal error: Python.h: No such file or directory
#include "Python.h"
^
compilation terminated.
error: command 'aarch64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-7sjys_ew-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-icacvua2/RPi.GPIO/
Installation des dépendances terminé !

Merci pour votre aide...

Sinoples
Timide
Messages : 7
Inscription : 21 déc. 2018, 11:26

Re: [Plugin Tiers] Zigate

Message par Sinoples » 20 juil. 2019, 18:15

Bonjour,

Je possède un Jeedom Smart ZWave et j'ai acheté la clé et intégrer le pluggin Zigate. Et je suis très déçu sur la gestion des ampoules, j'ai intégrer une ampoule HUE (Une vrai galère, j'ai du acheté la télécommande) pour au final ne pas avoir le retour d'état. Du coup, je suis passé sur les modèle IKEA (Achat ampoule + télécommande) je l'intègre et cette fois pas de bouton action On/Off...

Je commence sérieusement à me demander si j'ai bien fait de faire l'achat de cette clé. Je m'y prends mal ou c'est réellement des bugs non résolus ?? Pouvez vous m'éclairer ?

Cordialement,
Fabrice

Patrice59
Timide
Messages : 11
Inscription : 24 mai 2017, 09:07

Re: [Plugin Tiers] Zigate

Message par Patrice59 » 20 juil. 2019, 21:34

nirronico a écrit :
20 juil. 2019, 17:15
Je me réponds à moi même :
Il faut aller dans le répertoire "/var/www/html/plugins/zigate/resources"
et lancer la commande "sudo sh install_apt.sh"

Mais ça ne règle pas la date de dernière installation des dépendances qui reste à "2022-04-04 07:05:36" et surtout, l'installation des dépendances tombe en erreur (je mets juste la fin de la log) :

Collecting zigate==0.31.0
Using cached https://files.pythonhosted.org/packages ... ne-any.whl
Requirement already satisfied: pydispatcher in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Requirement already satisfied: bottle in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages (from zigate==0.31.0)
Collecting RPi.GPIO (from zigate==0.31.0)
Using cached https://files.pythonhosted.org/packages ... 6.5.tar.gz
Building wheels for collected packages: RPi.GPIO
Running setup.py bdist_wheel for RPi.GPIO ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpo5uyhr0jpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for RPi.GPIO
Running setup.py clean for RPi.GPIO
Failed to build RPi.GPIO
Installing collected packages: RPi.GPIO, zigate
Running setup.py install for RPi.GPIO ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-7sjys_ew-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-aarch64-3.5
creating build/lib.linux-aarch64-3.5/RPi
copying RPi/__init__.py -> build/lib.linux-aarch64-3.5/RPi
creating build/lib.linux-aarch64-3.5/RPi/GPIO
copying RPi/GPIO/__init__.py -> build/lib.linux-aarch64-3.5/RPi/GPIO
running build_ext
building 'RPi._GPIO' extension
creating build/temp.linux-aarch64-3.5
creating build/temp.linux-aarch64-3.5/source
aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-kWxB2e/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.5m -c source/py_gpio.c -o build/temp.linux-aarch64-3.5/source/py_gpio.o
source/py_gpio.c:23:20: fatal error: Python.h: No such file or directory
#include "Python.h"
^
compilation terminated.
error: command 'aarch64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-icacvua2/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-7sjys_ew-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-icacvua2/RPi.GPIO/
Installation des dépendances terminé !

Merci pour votre aide...
Bonjour
Avez vous trouvé la solution ?
J'ai le même problème avec les dépendances depuis la mise a jour du plug in en 1.3.0

EgMaf
Timide
Messages : 24
Inscription : 06 avr. 2016, 22:09

Re: [Plugin Tiers] Zigate

Message par EgMaf » 20 juil. 2019, 22:05

Moi aussi....

jerome6994
Timide
Messages : 360
Inscription : 04 juin 2019, 12:36
Localisation : Lyon

Re: [Plugin Tiers] Zigate

Message par jerome6994 » 20 juil. 2019, 22:05

Erreur sur la fonction deamon_start du plugin : [MySQL] Error code : 23000 (1062). Duplicate entry '231-1_5_2' for key 'unique' : INSERT INTO `cmd` SET `id` = :id, `logicalId` = :logicalId, `generic_type` = :generic_type, `eqType` = :eqType, `name` = :name, `order` = : order, `type` = :type, `subType` = :subType, `eqLogic_id` = :eqLogic_id, `isHistorized` = :isHistorized, `unite` = :unite, `configuration` = :configuration, `template` = :template, `display` = :display, `value` = :value, `isVisible` = :isVisible, `alert` = :alert
Voici ce que j'ai eu en avertissement !
RPI 3 B+ : Jeedom 3.3.32 - Z-Wave + : Z-Stick GEN5 - Aeon Labs - RFXCom - ZiGate USB-TTL ZigBee®
IOT : Station Météo, Thermostat, Vannes Netatmo, Volets Profalux, Prises DI-O, Somfy Home Alarm, Hue, Fibaro

dragonslore
Timide
Messages : 39
Inscription : 20 mai 2017, 14:15

Re: [Plugin Tiers] Zigate

Message par dragonslore » 20 juil. 2019, 22:52

dragonslore a écrit :
19 juil. 2019, 09:42
Bonjour à tous,

J'ai un NAS Synology 1812+ et un jeedom sous Docker, j'ai déjà en place une clé USB Zwave+ qui fonctionne très bien.
Je viens de recevoir ma Zigate USB, je l'ai mise à jour en firmware, elle est branché en direct (led rouge et bleu allumées), il est bien detecté par l'OS de mon Synology par contre je ne le retrouve pas dans Jeedom dockerisé.

2019-07-19_12h30_17.png

2019-07-19_12h29_31.png

Avez vous une idée ?
Merci pour votre aide.
Manu
L'un d'entre vous a t'il une idée de comment détecter la clé Zigate dans mon conteneur Docker Jeedom ?

Merci pour le coup de pouce je m'en sors pas...
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

Avatar de l’utilisateur
LuluDom
Timide
Messages : 111
Inscription : 30 oct. 2017, 12:51

Re: [Plugin Tiers] Zigate

Message par LuluDom » 21 juil. 2019, 10:14

Un peu de feedback et de retour d'expérience.

Une semaine après avoir dû réinclure tous mes équipements, nouvelle mise à jour des dépendances et de la libraire du plugin ce week-end et boom, mes équipements sont visibles mais ne réagissent plus...

Version plugin 1.3.0 (beta)
Version lib 0.31.0
Version firmware 3.0f

- Dépendances et démon dans la configuration du plugin déjà OK
- Tentative de "synchroniser" dans la gestion du plugin NOK
- Tentative de "scan réseau" dans la gestion du plugin NOK
- Tentative d' "identifier l'équipement" dans la page de l'équipement NOK
- Tentative de' "découvrir l'équipement" dans la page de l'équipement en même temps que manipuler l'équipement de toutes les manières possibles NOK
- Redémarrage de la clé Zigate depuis la gestion du plugin NOK

De bout en bout, les données des équipements telle que la qualité de signal (LQI) sont strictement inchangées, ce qui montre que plus rien ne communique au plugin.

C'est exactement comme la semaine dernière où j'ai dû tout réinclure un à un.

Je n'ai pas envie de réinclure tous mes capteurs Xiaomi (les seuls équipements que je gère par la clé Zigate) à chaque mise à jour.

Est-ce que ceux qui sont en version stable du plugin sont épargnés ? Je pense à passer en version stable si ça peut éviter ce fonctionnement trop peu 'fonctionnel".

jerome6994
Timide
Messages : 360
Inscription : 04 juin 2019, 12:36
Localisation : Lyon

Re: [Plugin Tiers] Zigate

Message par jerome6994 » 21 juil. 2019, 12:46

Sur la mise à jour d’hier soir je n’ai pas eu de problème.
Rien n’a disparu



Envoyé de mon iPhone en utilisant Tapatalk
RPI 3 B+ : Jeedom 3.3.32 - Z-Wave + : Z-Stick GEN5 - Aeon Labs - RFXCom - ZiGate USB-TTL ZigBee®
IOT : Station Météo, Thermostat, Vannes Netatmo, Volets Profalux, Prises DI-O, Somfy Home Alarm, Hue, Fibaro

nirronico
Timide
Messages : 3
Inscription : 20 juil. 2019, 14:12

Re: [Plugin Tiers] Zigate

Message par nirronico » 21 juil. 2019, 14:31

@Patrice59 et EgMaf

J'ai installé la version 1.3.1 du plugin (via le parket)
J'ai toujours le pb de date de dernière installation des dépendances (2022-04-04...) : J'ai ouvert un ticket JEEDOM
J'ai lancé l'installation des dépendances en SSH (aller dans le répertoire "/var/www/html/plugins/zigate/resources"
et lancer la commande "sudo sh install_apt.sh")
L'installation semble se terminer normalement malgré l'erreur ci-dessous :

Building wheels for collected packages: RPi.GPIO
Running setup.py bdist_wheel for RPi.GPIO ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-3pw6r5ho/RPi.GPIO/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmp97yneviapip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help

error: invalid command 'bdist_wheel'

----------------------------------------
Failed building wheel for RPi.GPIO
Running setup.py clean for RPi.GPIO
Failed to build RPi.GPIO
Installing collected packages: RPi.GPIO, zigate
Running setup.py install for RPi.GPIO ... done
Found existing installation: zigate 0.28.4
Uninstalling zigate-0.28.4:
Successfully uninstalled zigate-0.28.4
Successfully installed RPi.GPIO-0.6.5 zigate-0.31.0
Installation des dépendances terminé !

J'ai réussi à relancer le daemon après avoir désactiver la gestion automatique, et ça à l'ai de fonctionner, même si j'ai perdu le détecteur de fumée Xiaomi...

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : alexzen et 2 invités