Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

problème de commande des relais IPX800 V3

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Juju31
Timide
Messages : 149
Inscription : 09 févr. 2016, 21:07
Localisation : Banlieue Toulousaine

Re: problème de commande des relais IPX800 V3

Message par Juju31 » 22 oct. 2019, 13:36

Tu veux dire dans la config des équipements ?
J'ai eu le cas. En fait c'est le layout de la page de config équipement qui est pourri sous v4. Mais si tu scrolles vers le bas, tout apparaît ...

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 22 oct. 2019, 14:15

Arf ce n'est pas lié à jeedom V4 car je viens de faire une sauvegarde de jeedom et j'ai appliqué une restauration de cette sauvegarde sur une VM de test et la j'ai le même problème avec le message:
[2019-10-22 14:11:01][ERROR] : Erreur sur ipx800::pull() : [MySQL] Error code : 42S02 (1146). Table 'jeedom.object' doesn't exist : SELECT `el`.`id`, `el`.`name`, `el`.`logicalId`, `el`.`generic_type`, `el`.`object_id`, `el`.`eqType_name`, `el`.`eqReal_id`, `el`.`isVisible`, `el`.`isEnable`, `el`.`configuration`, `el`.`timeout`, `el`.`category`, `el`.`display`, `el`.`order`, `el`.`comment`, `el`.`tags` FROM eqLogic el LEFT JOIN object ob ON el.object_id=ob.id WHERE eqType_name=:eqType_name ORDER BY ob.name,el.name

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 22 oct. 2019, 14:19

Juju31 a écrit :
22 oct. 2019, 13:36
Tu veux dire dans la config des équipements ?
J'ai eu le cas. En fait c'est le layout de la page de config équipement qui est pourri sous v4. Mais si tu scrolles vers le bas, tout apparaît ...
Effectivement j'ai deja eu le tour mais hélas ce n'est pas le cas ici. je suis allé voir dans le résumé domotique mais dés que je clique pour acceder au parametres d'un élement de l'ipx , j'ai ce type de message :
[MySQL] Error code : 23000 (1452). Cannot add or update a child row: a foreign key constraint fails (`jeedom`.`eqLogic`, CONSTRAINT `fk_eqLogic_object1` FOREIGN KEY (`object_id`) REFERENCES `object` (`id`) ON DELETE SET NULL ON UPDATE CASCADE) : UPDATE `eqLogic` SET `id` = :id, `name` = :name, `logicalId` = :logicalId, `generic_type` = :generic_type, `object_id` = :object_id, `eqType_name` = :eqType_name, `eqReal_id` = :eqReal_id, `isVisible` = :isVisible, `isEnable` = :isEnable, `configuration` = :configuration, `timeout` = :timeout, `category` = :category, `display` = :display, `order` = :order, `comment` = :comment, `tags` = :tags WHERE id = :id

J'ai peur que la sauvegarde ou la restauration du plugin comporte un bug car en fonctionnement de production , tout vas bien.

edit: Par contre ma VM de test est en débian 10 , faudrait que j'essais sur débian 9 (comme sur ma prod) pour voir si ce n'est pas ca le soucis.
edit: Par contre les commandes continuent à bien fonctionner , c'est que la partie configuration de l'ipx qui ne fonctionne pas (s'affiche pas)

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 22 oct. 2019, 15:04

Bon je ne cherche pas plus loin , c'est le plugin IPX800 V3 qui n'est pas compatible avec débian 10 . J'ai vu ca sur ce post : viewtopic.php?f=50&t=32599&start=20#p756242
et lorsque je rafraichi la page vide , j'ai effectivement tout mes équipements qui s'affichent mais avec des accolages partout :(
J'espère que l'équipe va le rendre compatible , je croise les doigts.

dvb
Actif
Messages : 1440
Inscription : 15 févr. 2015, 22:50

Re: problème de commande des relais IPX800 V3

Message par dvb » 22 oct. 2019, 21:17

thebest28 a écrit :
22 oct. 2019, 15:04
Bon je ne cherche pas plus loin , c'est le plugin IPX800 V3 qui n'est pas compatible avec débian 10 . J'ai vu ca sur ce post : viewtopic.php?f=50&t=32599&start=20#p756242
et lorsque je rafraichi la page vide , j'ai effectivement tout mes équipements qui s'affichent mais avec des accolages partout :(
J'espère que l'équipe va le rendre compatible , je croise les doigts.
Bonsoir,
Tu as moyen de tester sous Jeedom v4 et Debian 9.x ?
DIY 4*2GHz - 4Go RAM - SSD
- ctrl 1-wire Dallas + IPX800 + X880
- ctrl RFXcom + Oregon (température) + Anémomètre
- ctrl Gen5 + Wallplug + fgrm-222 + Benext + Everspring AN157-6 + Aeon Key Fob+ ...

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 22 oct. 2019, 21:33

dvb a écrit :
22 oct. 2019, 21:17
thebest28 a écrit :
22 oct. 2019, 15:04
Bon je ne cherche pas plus loin , c'est le plugin IPX800 V3 qui n'est pas compatible avec débian 10 . J'ai vu ca sur ce post : viewtopic.php?f=50&t=32599&start=20#p756242
et lorsque je rafraichi la page vide , j'ai effectivement tout mes équipements qui s'affichent mais avec des accolages partout :(
J'espère que l'équipe va le rendre compatible , je croise les doigts.
Bonsoir,
Tu as moyen de tester sous Jeedom v4 et Debian 9.x ?
Oui pas de soucis , j'essais de faire ca demain ;)

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 22 oct. 2019, 22:29

Bon je l'ai déjà fait et aucun soucis du plugin ipx sous Jeedom v4 et debian 9 ;)

dvb
Actif
Messages : 1440
Inscription : 15 févr. 2015, 22:50

Re: problème de commande des relais IPX800 V3

Message par dvb » 23 oct. 2019, 07:27

Excellente nouvelle. Merci !
DIY 4*2GHz - 4Go RAM - SSD
- ctrl 1-wire Dallas + IPX800 + X880
- ctrl RFXcom + Oregon (température) + Anémomètre
- ctrl Gen5 + Wallplug + fgrm-222 + Benext + Everspring AN157-6 + Aeon Key Fob+ ...

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 23 oct. 2019, 09:55

J'ai modifié les fichiers php du plugin pour rendre compatible le plugin avec debian 10 si jamais cela interresse quelqu'un ;)

dvb
Actif
Messages : 1440
Inscription : 15 févr. 2015, 22:50

Re: problème de commande des relais IPX800 V3

Message par dvb » 23 oct. 2019, 19:03

thebest28 a écrit :
23 oct. 2019, 09:55
J'ai modifié les fichiers php du plugin pour rendre compatible le plugin avec debian 10 si jamais cela interresse quelqu'un ;)
Merci, mais je suis encore sous Debian 9.x.

Par contre, je suggère que tu pousses ton correctif à Loïc.
S'il est OK cela permettra d'actualiser le plugin et d'en faire profiter tout le monde.
DIY 4*2GHz - 4Go RAM - SSD
- ctrl 1-wire Dallas + IPX800 + X880
- ctrl RFXcom + Oregon (température) + Anémomètre
- ctrl Gen5 + Wallplug + fgrm-222 + Benext + Everspring AN157-6 + Aeon Key Fob+ ...

thebest28
Timide
Messages : 238
Inscription : 22 déc. 2015, 21:43

Re: problème de commande des relais IPX800 V3

Message par thebest28 » 23 oct. 2019, 19:13

dvb a écrit :
23 oct. 2019, 19:03
thebest28 a écrit :
23 oct. 2019, 09:55
J'ai modifié les fichiers php du plugin pour rendre compatible le plugin avec debian 10 si jamais cela interresse quelqu'un ;)
Merci, mais je suis encore sous Debian 9.x.

Par contre, je suggère que tu pousses ton correctif à Loïc.
S'il est OK cela permettra d'actualiser le plugin et d'en faire profiter tout le monde.
Je veux bien mais comment faut-il s'y prendre?

dvb
Actif
Messages : 1440
Inscription : 15 févr. 2015, 22:50

Re: problème de commande des relais IPX800 V3

Message par dvb » 23 oct. 2019, 20:34

Le mieux est de lui demander la procédure via mp par exemple.
Ou de poster sur le nouveau forum community, il y passe sans doute plus souvent.
DIY 4*2GHz - 4Go RAM - SSD
- ctrl 1-wire Dallas + IPX800 + X880
- ctrl RFXcom + Oregon (température) + Anémomètre
- ctrl Gen5 + Wallplug + fgrm-222 + Benext + Everspring AN157-6 + Aeon Key Fob+ ...

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : chtikers et 1 invité