Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Plugin Arlo

Pour échanger sur les plugins classés en catégorie "Sécurité"
jojo1309
Timide
Messages : 5
Inscription : 13 sept. 2016, 16:37

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par jojo1309 » 01 oct. 2019, 21:32

Bonjour à tous,
J'utilise ce plugin, et j'avoue qu'il me rend pas mal service. Je l'utilise au quotidien pour gérer l'activation ou la désactivation de mes caméras Arlo en fonction de l'activation/désactivation de mon alarme intérieure.
Par contre, j'aurai souhaiter activer le mode géolocalisation lorsque je quitte mon domicile, et non pas le mode "Activé".
En effet, cela me laisse le temps de sortir de chez moi sans que les caméras m'envoie une alerte. Ca, à la limite, je peux le gérer avec un
timer avant d'activer le mode total.
Par contre, quand je rentre chez moi, j'aimerai que le mode Géolocalisation soit actif car cela permettrai de désactiver la centrale avant que je
rentre dans le périmètre de mes caméras. Cela m'éviterai des alertes pour rien.
Par contre, je ne peux pas me baser uniquement sur le mode geoloc de la base, car j'ai souvent des gens de passage à la maison, et je ne veux pas leur demander a tous d'installer l'appli le temps de leur passage.
Est-ce qu'il y a un moyen de faire ça?
Merci d'avance

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 01 oct. 2019, 21:58

Bonsoir,

Je n'avais pas exclus de pouvoir activer ce mode depuis le jeedom via le plugin mais ce n'était pas dans les priorités car en fait il est possible de faire de la gestion de présence de façon plus général dans jeedom et que donc en fonction de la présence détectée ou non dans jeedom, on peut faire plusieurs actions comme activer le mode arlo (mais aussi activer le plugin alarm, éteindre les lumières... )

Donc l'idée à la base c'était de gérer la géolocalisation par Jeedom et de lui faire contrôler le mode des caméras en fonction.
L'avantage de gérer la présence via Jeedom est de pouvoir utiliser toute sorte de moyen et pas que l'app arlo; ca peut être une combinaison de:
- une app sur un téléphone qui géolocalise (app mobile officielle ou une autre, je n'ai pas testé toutes les solutions)
- un ping ou arp via le wifi sur un telephone
- un tracker bluetooth, etc

ca libère aussi la contrainte que chaque habitant doit avoir l'app arlo pour que cela fonctionne etc.

Pour conclure, je peux mettre ça dans ma todo list, je le ferai probablement un jour mais ma question est pourquoi cela ne va pas pour vous de gérer la présence/geoloc par jeedom (par exemple avec le plugin geoloc https://jeedom.github.io/plugin-geoloc/fr_FR/) et d'utiliser cette info pour activer le mode voulu?
Il me semble que cela permettra de centraliser et de réutiliser cette info pour d'autres actions que arlo,
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

jojo1309
Timide
Messages : 5
Inscription : 13 sept. 2016, 16:37

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par jojo1309 » 01 oct. 2019, 22:18

C'est une solution en effet, mais les quelques tests que j'avais fait sur la gestion de la géolocalisation ne m'avaient pas convaincu.
Mais c'était il y a quelques années, ça a sûrement changé.
Et puis, j'ai déjà un état présence ou absence dans jeedom, sur lequel se base plusieurs scénarios, qui se base sur l'état de mon alarme et qui est infaillible. Si ce n'est que l'état ne se change que lorsque je suis a l'intérieur de chez moi. Le gros avantage, c'est que c'est valable même lorsqu'on a des invités, ce qui évite d'avoir à installer quoique ce soit sur leur téléphones.
Pour les caméras exterieues, et uniquement pour ça, j'aurai besoin d'avoir la désactivation avant de rentrer dans mon jardin.
Je pourrai rajouter une variable "proximité" qui se baserai sur la présence à proximité des portables de ceux qui habitent en continu à la maison, mais ça reste moins simple que de juste activer le mode géolocalisation sur arlo

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 01 oct. 2019, 22:31

Ok, et bien je rajouterai cette possibilité mais je ne peux pas garantir un délai car j'ai une liste trop longue déjà (sur d'autres plugins aussi) pour le temps que j'ai.
Entre temps si vous avez l'occasion de re-tester la géoloc sous Jeedom ca permettrait peut-être d'avoir une solution au moins le temps que je l'intègre?
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

jojo1309
Timide
Messages : 5
Inscription : 13 sept. 2016, 16:37

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par jojo1309 » 01 oct. 2019, 22:37

Ok merci, pas de soucis pour le délai, ça marche déjà très bien.
Je vais réessayer la géolocalisation jeedom

PoloTechno
Timide
Messages : 13
Inscription : 03 mai 2019, 15:50

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par PoloTechno » 02 oct. 2019, 21:25

@Mips2648 Tu as vu juste ! Une de mes deux bases (la pro avec sirène) déco alors qu'elle avait bien les 3 LEDS vertes actives (donc celle du réseau) !! Complètement perdue de mon compte, obligé de la reset et de refaire un paramétrage de zero pour la retrouver. Rien à voir avec ton plugin, donc. Ce serait juste cool si dans les logs ou lors du NOK du démon tu pouvais avoir un message genre : "vérifiez si votre ou vos bases sont en ligne". Merci encore pour ton super Plugin ! tout est opérationnel désormais. je viens d'envoyer 20 e sur ton paypal, c'est le minimum pour ce super boulot

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 04 oct. 2019, 16:31

Merci à toi !

Et tu as raison, je devrais travailler sur ce problème, je dois commencer par le reproduire chez moi pour cela.
Il faudrait que 1/ le démon démarre et fonctionne pour le reste et 2/ effectivement prévenir de l'équipement qui à l'air "mort".
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
mobby38
Timide
Messages : 32
Inscription : 27 janv. 2015, 17:21
Localisation : 38

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par mobby38 » 04 oct. 2019, 23:10

Bonjour,

J'ai changé de caméra ARLO GO sur mon compte ARLO, et j'ai l'erreur suivante dans le plugin :

Code : Tout sélectionner

[2019-10-04 21:07:28][INFO] : MainThread : Start daemon
[2019-10-04 21:07:28][INFO] : MainThread : Log level : info
[2019-10-04 21:07:29][ERROR] : ConnectionThread : HTTP error:401 Client Error: Unauthorized for url: https://my.arlo.com/hmsweb/login/v2
[2019-10-04 21:08:16][INFO] : MainThread : Start daemon
[2019-10-04 21:08:16][INFO] : MainThread : Log level : info
[2019-10-04 21:08:18][ERROR] : EventHandler_51D29175A036A : Fatal error: Request (POST https://my.arlo.com/hmsweb/users/devices/notify/51D29175A036A) failed: {u'data': {u'message': u'The device does not exist.', u'reason': u'No such device.', u'error': u'2217'}, u'success': False}
[2019-10-04 21:08:18][ERROR] : ConnectionThread : HTTP error:Request (POST https://my.arlo.com/hmsweb/users/devices/notify/51D29175A036A) failed: {u'data': {u'message': u'The device does not exist.', u'reason': u'No such device.', u'error': u'2217'}, u'success': False}
Ce sont les références de l'ancienne caméra, comment je peux "cleaner" ces infos?

Merci beaucoup!

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 04 oct. 2019, 23:13

Bonjour,

Vous pouvez simplement supprimer la caméra dans jeedom et redémarrer le démon.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
mobby38
Timide
Messages : 32
Inscription : 27 janv. 2015, 17:21
Localisation : 38

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par mobby38 » 05 oct. 2019, 08:41

Mips2648 a écrit :
04 oct. 2019, 23:13
Bonjour,

Vous pouvez simplement supprimer la caméra dans jeedom et redémarrer le démon.
Elle est déjà supprimée :cry:
Je ne trouve aucune référence a cette objet "51D29175A036A" après avoir rapidement chercher dans la base MariaDb et les fichiers php.

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 05 oct. 2019, 09:06

Et dans ton appli arlo, la caméra est supprimée aussi ou pas?
peux-tu aussi vérifier les partages fait avec le "user jeedom" ? et retirer l'ancienne caméra de la liste des partages si elle y est toujours?

as-tu encore ton ancienne caméra? comment as-tu procéder pour la remplacer?

et enfin, peux-tu passer le log en debug, redémarrer le démon et me l'envoyer?
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
mobby38
Timide
Messages : 32
Inscription : 27 janv. 2015, 17:21
Localisation : 38

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par mobby38 » 06 oct. 2019, 07:59

Hello,

La caméra est supprimé de l'appli Arlo aussi.

Où-ce que l'on voit les "partages" ? je n'ai aucune caméra partagé dans l'appli arlo (onglet "Shared Device").

Je n'ai malheureusement plus l'ancienne caméra.
Pour l'enlever, je me suis connecté à l'interface d'admin Arlo puis j'ai fait "Remove Device".

Voici les logs en debug:

Code : Tout sélectionner

[2019-10-06 05:56:01][INFO] : MainThread : Start daemon
[2019-10-06 05:56:01][INFO] : MainThread : Log level : debug
[2019-10-06 05:56:01][DEBUG] : MainThread : Socket port : 55064
[2019-10-06 05:56:01][DEBUG] : MainThread : Socket host : localhost
[2019-10-06 05:56:01][DEBUG] : MainThread : PID file : /tmp/jeedom/arlo/deamon.pid
[2019-10-06 05:56:01][DEBUG] : MainThread : Apikey : XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
[2019-10-06 05:56:01][DEBUG] : MainThread : Writing PID 1195 to /tmp/jeedom/arlo/deamon.pid
[2019-10-06 05:56:01][DEBUG] : MainThread : Init request module v2.12.4
[2019-10-06 05:56:01][DEBUG] : MainThread : Starting new HTTP connection (1): 127.0.0.1:80
[2019-10-06 05:56:01][DEBUG] : MainThread : http://127.0.0.1:80 "GET /plugins/arlo/core/php/jeeArlo.php?test=1&apikey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX HTTP/1.1" 200 2
[2019-10-06 05:56:01][DEBUG] : MainThread : Start listening
[2019-10-06 05:56:01][DEBUG] : MainThread : Socket interface started
[2019-10-06 05:56:01][DEBUG] : Thread-2  : LoopNetServer Thread started
[2019-10-06 05:56:01][DEBUG] : Thread-2  : Listening on: [localhost:55064]
[2019-10-06 05:56:01][DEBUG] : ConnectionThread : Starting new HTTPS connection (1): my.arlo.com:443
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : https://my.arlo.com:443 "POST /hmsweb/login/v2 HTTP/1.1" 200 None
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : https://my.arlo.com:443 "GET /hmsweb/users/devices HTTP/1.1" 200 None
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : Send to jeedom :  {'devices': [{u'deviceName': u'Revel', u'permissionsSchemaVer': u'i008', u'migrateActivityZone': False, u'userId': u'YUPE-100-50026263', u'mediaObjectCount': 0, u'arloMobilePlan': False, u'owner': {u'lastName': u'Alvaro', u'firstName': u'Xavier', u'ownerId': u'YUPE-100-50026263'}, u'presignedLastImageUrl': u'https://arlolastimage-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/lastImage.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%2BsrcM%3D', u'displayOrder': 0, u'mobileTrialUsed': False, u'permissionsFilePath': u'https://vzs3-prod-common.s3.amazonaws.com/static/resources/permissions/VML4030/VML4030_i008_permissions.json', u'state': u'deactivated', u'deviceType': u'camera', u'firmwareVersion': u'1.096.3.0_1.8.55.0_19', u'uniqueId': u'YUPE-100-50026263_51D29175A036A', u'parentId': u'51D29175A036A', u'presignedSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/snapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=7e6zPdIZ2qnyb0kXuvdxtnzdOP4%3D', u'modelId': u'VML4030', u'userRole': u'OWNER', u'cvrEnabled': False, u'interfaceSchemaVer': u'2', u'dateCreated': 1563642175227, u'connectivity': {u'signalStrength': u'1', u'rfBand': 3, u'networkMode': u'auto', u'roamingAllowed': True, u'msisdn': u'', u'networkName': u'SFR', u'carrierFw': u'Generic', u'fwVersion': u'ARLO.FX.0.6.5.19.GC.002', u'wwanIpAddr': u'100.124.192.9', u'connected': True, u'iccid': u'89331010183209228456', u'imei': u'358417071379279', u'apn': u'sl2sfr', u'roaming': False, u'type': u'lte', u'mepStatus': u'notLocked', u'activeNetwork': u'lte'}, u'permissionsVerison': u'002', u'deviceId': u'51D29175A036A', u'properties': {u'olsonTimeZone': u'Europe/Belgrade', u'hwVersion': u'H6', u'modelId': u'VML4030'}, u'interfaceVersion': u'i002', u'mobileCarrier': u'GC', u'lastImageUploaded': u'true', u'lastModified': 1570341362393, u'xCloudId': u'QT54-1700-176-111578067', u'criticalBatteryState': False, u'permissionsVersion': u'002', u'presignedFullFrameSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/fullFrameSnapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=hNKLIoIxJ9Kqod%2BOkp3ZB%2BV4ij4%3D'}, {u'deviceName': u'RevelExt', u'permissionsSchemaVer': u'i008', u'migrateActivityZone': False, u'userId': u'YUPE-100-50026263', u'mediaObjectCount': 0, u'arloMobilePlan': False, u'owner': {u'lastName': u'Alvaro', u'firstName': u'Xavier', u'ownerId': u'YUPE-100-50026263'}, u'presignedLastImageUrl': u'https://arlolastimage-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/lastImage.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=e8GhiMJNSEt9VTyhDbIIZdyLqDM%3D', u'displayOrder': 7, u'permissionsFilePath': u'https://vzs3-prod-common.s3.amazonaws.com/static/resources/permissions/VML4030/VML4030_i008_permissions.json', u'state': u'provisioned', u'deviceType': u'camera', u'firmwareVersion': u'1.096.3.0_1.8.57.0_18', u'uniqueId': u'YUPE-100-50026263_51F1747LA289C', u'parentId': u'51F1747LA289C', u'presignedSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/snapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=ojDW9nBFsvvj8e3OvRT8f5ofLHw%3D', u'modelId': u'VML4030', u'userRole': u'OWNER', u'cvrEnabled': False, u'interfaceSchemaVer': u'2', u'dateCreated': 1570167522915, u'connectivity': {u'signalStrength': u'4', u'rfBand': 7, u'networkMode': u'auto', u'roamingAllowed': False, u'msisdn': u'', u'networkName': u'Arlo Mobile', u'carrierFw': u'ArloMobile', u'fwVersion': u'ARLO.FX.0.6.5.18.AM.001', u'wwanIpAddr': u'10.148.224.137', u'connected': True, u'iccid': u'89330119310809589750', u'imei': u'358417070554591', u'apn': u'orange', u'roaming': False, u'type': u'lte', u'mepStatus': u'notLocked', u'activeNetwork': u'lte'}, u'permissionsVerison': u'002', u'deviceId': u'51F1747LA289C', u'properties': {u'olsonTimeZone': u'Europe/Belgrade', u'hwVersion': u'H6', u'modelId': u'VML4030'}, u'interfaceVersion': u'i002', u'lastImageUploaded': u'true', u'lastModified': 1570341362393, u'xCloudId': u'UVKYCX-1700-176-109366593', u'criticalBatteryState': False, u'permissionsVersion': u'002', u'presignedFullFrameSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/fullFrameSnapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=eMzPJlwMXTQ05QyGh%2FB8G3DNgr4%3D'}]}
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : Starting new HTTP connection (1): 127.0.0.1:80
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : http://127.0.0.1:80 "POST /plugins/arlo/core/php/jeeArlo.php?apikey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX HTTP/1.1" 200 2
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : https://my.arlo.com:443 "GET /hmsweb/users/automation/definitions?uniqueIds=all HTTP/1.1" 200 None
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : Send to jeedom :  {'modes': {}}
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : Starting new HTTP connection (1): 127.0.0.1:80
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : http://127.0.0.1:80 "POST /plugins/arlo/core/php/jeeArlo.php?apikey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX HTTP/1.1" 200 2
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : https://my.arlo.com:443 "GET /hmsweb/users/devices/automation/active HTTP/1.1" 200 None
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : basestations: []
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arlobridges: []
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arloQ: []
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arloGo: [{u'deviceName': u'Revel', u'permissionsSchemaVer': u'i008', u'migrateActivityZone': False, u'userId': u'YUPE-100-50026263', u'mediaObjectCount': 0, u'arloMobilePlan': False, u'owner': {u'lastName': u'Alvaro', u'firstName': u'Xavier', u'ownerId': u'YUPE-100-50026263'}, u'presignedLastImageUrl': u'https://arlolastimage-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/lastImage.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%2BsrcM%3D', u'displayOrder': 0, u'mobileTrialUsed': False, u'permissionsFilePath': u'https://vzs3-prod-common.s3.amazonaws.com/static/resources/permissions/VML4030/VML4030_i008_permissions.json', u'state': u'deactivated', u'deviceType': u'camera', u'firmwareVersion': u'1.096.3.0_1.8.55.0_19', u'uniqueId': u'YUPE-100-50026263_51D29175A036A', u'parentId': u'51D29175A036A', u'presignedSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/snapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=7e6zPdIZ2qnyb0kXuvdxtnzdOP4%3D', u'modelId': u'VML4030', u'userRole': u'OWNER', u'cvrEnabled': False, u'interfaceSchemaVer': u'2', u'dateCreated': 1563642175227, u'connectivity': {u'signalStrength': u'1', u'rfBand': 3, u'networkMode': u'auto', u'roamingAllowed': True, u'msisdn': u'', u'networkName': u'SFR', u'carrierFw': u'Generic', u'fwVersion': u'ARLO.FX.0.6.5.19.GC.002', u'wwanIpAddr': u'100.124.192.9', u'connected': True, u'iccid': u'89331010183209228456', u'imei': u'358417071379279', u'apn': u'sl2sfr', u'roaming': False, u'type': u'lte', u'mepStatus': u'notLocked', u'activeNetwork': u'lte'}, u'permissionsVerison': u'002', u'deviceId': u'51D29175A036A', u'properties': {u'olsonTimeZone': u'Europe/Belgrade', u'hwVersion': u'H6', u'modelId': u'VML4030'}, u'interfaceVersion': u'i002', u'mobileCarrier': u'GC', u'lastImageUploaded': u'true', u'lastModified': 1570341362393, u'xCloudId': u'QT54-1700-176-111578067', u'criticalBatteryState': False, u'permissionsVersion': u'002', u'presignedFullFrameSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51D29175A036A/fullFrameSnapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=hNKLIoIxJ9Kqod%2BOkp3ZB%2BV4ij4%3D'}, {u'deviceName': u'RevelExt', u'permissionsSchemaVer': u'i008', u'migrateActivityZone': False, u'userId': u'YUPE-100-50026263', u'mediaObjectCount': 0, u'arloMobilePlan': False, u'owner': {u'lastName': u'Alvaro', u'firstName': u'Xavier', u'ownerId': u'YUPE-100-50026263'}, u'presignedLastImageUrl': u'https://arlolastimage-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/lastImage.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=e8GhiMJNSEt9VTyhDbIIZdyLqDM%3D', u'displayOrder': 7, u'permissionsFilePath': u'https://vzs3-prod-common.s3.amazonaws.com/static/resources/permissions/VML4030/VML4030_i008_permissions.json', u'state': u'provisioned', u'deviceType': u'camera', u'firmwareVersion': u'1.096.3.0_1.8.57.0_18', u'uniqueId': u'YUPE-100-50026263_51F1747LA289C', u'parentId': u'51F1747LA289C', u'presignedSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/snapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=ojDW9nBFsvvj8e3OvRT8f5ofLHw%3D', u'modelId': u'VML4030', u'userRole': u'OWNER', u'cvrEnabled': False, u'interfaceSchemaVer': u'2', u'dateCreated': 1570167522915, u'connectivity': {u'signalStrength': u'4', u'rfBand': 7, u'networkMode': u'auto', u'roamingAllowed': False, u'msisdn': u'', u'networkName': u'Arlo Mobile', u'carrierFw': u'ArloMobile', u'fwVersion': u'ARLO.FX.0.6.5.18.AM.001', u'wwanIpAddr': u'10.148.224.137', u'connected': True, u'iccid': u'89330119310809589750', u'imei': u'358417070554591', u'apn': u'orange', u'roaming': False, u'type': u'lte', u'mepStatus': u'notLocked', u'activeNetwork': u'lte'}, u'permissionsVerison': u'002', u'deviceId': u'51F1747LA289C', u'properties': {u'olsonTimeZone': u'Europe/Belgrade', u'hwVersion': u'H6', u'modelId': u'VML4030'}, u'interfaceVersion': u'i002', u'lastImageUploaded': u'true', u'lastModified': 1570341362393, u'xCloudId': u'UVKYCX-1700-176-109366593', u'criticalBatteryState': False, u'permissionsVersion': u'002', u'presignedFullFrameSnapshotUrl': u'https://arlos3-prod-z1.s3.amazonaws.com/1fd4e406728a479a844c3324dbbb7d6a/YUPE-100-50026263/51F1747LA289C/fullFrameSnapshot.jpg?AWSAccessKeyId=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&Expires=1570427762&Signature=eMzPJlwMXTQ05QyGh%2FB8G3DNgr4%3D'}]
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arlodoorbells: []
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arlochimes: []
[2019-10-06 05:56:02][DEBUG] : ConnectionThread : arloSirens: []
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : ### Start handle ###
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : https://my.arlo.com:443 "GET /hmsweb/client/subscribe?token=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX HTTP/1.1" 200 None
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : Starting new HTTPS connection (2): my.arlo.com:443
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : https://my.arlo.com:443 "POST /hmsweb/users/devices/notify/51D29175A036A HTTP/1.1" 200 None
[2019-10-06 05:56:02][ERROR] : EventHandler_51D29175A036A : Fatal error: Request (POST https://my.arlo.com/hmsweb/users/devices/notify/51D29175A036A) failed: {u'data': {u'message': u'The device does not exist.', u'reason': u'No such device.', u'error': u'2217'}, u'success': False}
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : Shutdown
[2019-10-06 05:56:02][DEBUG] : EventHandler_51D29175A036A : Removing PID file /tmp/jeedom/arlo/deamon.pid
[2019-10-06 05:56:03][DEBUG] : Thread-2  : LoopNetServer Thread stopped
[2019-10-06 05:56:03][DEBUG] : EventHandler_51D29175A036A : Exit 0

Merci de ton aide

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 06 oct. 2019, 09:42

1) Combien es-tu sensé avoir de caméra?
Dans le log, j'en vois deux: une "revel" avec id "51D29175A036A" (c'est celle sur laquelle le plugin a du mal) et la "revelext" avec id "51F1747LA289C"
2) laquelle a été changée? la première?
est-ce la nouvelle?
Où-ce que l'on voit les "partages" ? je n'ai aucune caméra partagé dans l'appli arlo (onglet "Shared Device").
Là ou tu as créé le user pour arlo et partagé tes caméras la première fois comme expliqué dans la doc

d'ailleurs, j'y pense, as-tu partagé ta nouvelle caméra? le problème n'est peut-être pas la caméra qui n'existe plus mais la nouvelle qui n'a pas été partagée avec jeedom?

Sinon tu peux aussi essayer de supprimer ton "user jeedom" dans arlo et d'en faire un nouveau
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
mobby38
Timide
Messages : 32
Inscription : 27 janv. 2015, 17:21
Localisation : 38

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par mobby38 » 06 oct. 2019, 13:22

Hello,

J'ai suivi la procédure de la documentation (création d'un nouvel utilisateur et partage), et cela marche maintenant, avant, je me connectais avec mon utilisateur principal.
Bizarre, ca a marché jusqu’à ce que je change de caméra.

Merci pour l'aide!

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

[Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 06 oct. 2019, 13:29

Super.

En passant n'hésitez pas à donner votre avis sur le market, les notes ont été réinitialisées avec le nouveau forum "communauté"
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

diroid
Timide
Messages : 21
Inscription : 25 févr. 2019, 14:33

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par diroid » 08 oct. 2019, 14:49

Salut,
J'adore le live stream, c'est top. Je vais noter le plugin pour "récompenser" ton travail.
Par contre, sur une Pro, j'ai pas de son en live stream. Ca te parle?

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 08 oct. 2019, 18:51

Merci pour le retour :-)

Concernant le son, j'ai des arlo pro moi et pas de soucis à ce niveau.
Y aurait il le son à activer ou une histoire de volume à régler dans l'app arlo ? (Perso j'ai probablement laisse les réglages de base)

Je vais un peu chercher de mon côté mais je voulais lancer la piste au cas où tu te souviendrais avoir fait quelque chose
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

diroid
Timide
Messages : 21
Inscription : 25 févr. 2019, 14:33

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par diroid » 09 oct. 2019, 14:13

Alors, j'avais pas de son ce matin non plus (le son du PC est à 100% et sur la vidéo on est à 100% et non muté).
J'ai lancé le live stream. Pas de son. J'ai coupé le live.
J'ai lancé sur l'iPhone. Tout est ok. J'ai coupé l'appli.
J'ai relancé le live stream. J'ai du son, mais je trouve le volume moins fort que sur le tel.

Cet après-midi j'ai re-testé directement le live stream et j'ai bien du son.
Quelle est ton ressenti sur le volume ? Sur l'iPhone 8 j'entends les voitures passer au loin, alors que je ne les entends pas du tout sur Jeedom.

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Plugin Arlo

Message par Mips2648 » 09 oct. 2019, 21:52

Très curieux, perso je n'entend pas de différence de volume.
Et d'ailleurs le plugin n'intervient absolument pas sur le volume.

Quel navigateur utilises-tu? cela vient peut-être de là?
je teste sous firefox et chrome, les 2 à jours dernières version, sous windows.
et la version mobile, je test sur iphone 8 (mais sans objet pour le streaming puisque pas encore supporté sur mobile)
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

889laurent
Timide
Messages : 43
Inscription : 29 mars 2017, 20:29

Plugin Arlo

Message par 889laurent » 21 oct. 2019, 21:11

j'ai un problème avec un arlo pro et une camera VMC5040 .
le demon se lance correctement et stoppe au bout de 5 s.
je met la fin du log ou il y de erreurs
[2019-10-21 19:05:14][DEBUG] : ConnectionThread : Starting new HTTP connection (1): 127.0.0.1:80
[2019-10-21 19:05:14][DEBUG] : ConnectionThread : http://127.0.0.1:80 "POST /plugins/arlo/core/php/jeeArlo.php?apikey=*******5grSiZeVmbVkkYNIhYLcdnSZX HTTP/1.1" 200 0
[2019-10-21 19:05:14][ERROR] : ConnectionThread : HTTP error:Request (POST https://my.arlo.com/hmsweb/users/device ... 29478A0B60) failed: {u'data': {u'message': u'The device does not exist.', u'reason': u'No such device.', u'error': u'2217'}, u'success': False}
[2019-10-21 19:05:14][DEBUG] : ConnectionThread : Shutdown
[2019-10-21 19:05:14][DEBUG] : ConnectionThread : Removing PID file /tmp/jeedom/arlo/deamon.pid
[2019-10-21 19:05:14][DEBUG] : Thread-2 : LoopNetServer Thread stopped
[2019-10-21 19:05:14][DEBUG] : EventHandler_51D29478A0B60 : Exit 0

Merci pour ton aide

Répondre

Revenir vers « [Catégorie] Sécurité »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité