Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

gab696
Timide
Messages : 142
Inscription : 19 mars 2015, 22:59

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par gab696 » 23 mars 2019, 07:24

j'ai aussi essayé d'installer aiohttp manuellement.

pour ça j'ai du préalablement mettre à jour setuptools avec la commande pip3 install --upgrade setuptools

puis la commande pip3 install aiotttp à pu se réaliser jusqu'au bout

mais je ne peux toujours pas lancer le deamon :

Code : Tout sélectionner

[2019-03-23 07:19:56][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
Traceback (most recent call last):
File "/var/www/html/plugins/fakeroku/resources/fakerokud.py", line 7, in <module>
import emulated_roku
File "/var/www/html/plugins/fakeroku/resources/emulated_roku/__init__.py", line 12, in <module>
from aiohttp import web
ImportError: No module named 'aiohttp'

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Bosquetia » 23 mars 2019, 07:53

Hello

Si lors de l'installation des dépendances la date ne change pas essayer cela :

- Ré-appliquer les droits Jeedom (voir sections tutos y a un tuto)
- Réinstaller les dépendances et voir si la date change de statut de inconnu à une date !

Je dis cela, car vu ce genre de souci sur un autre plugin...

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1373
Inscription : 20 oct. 2015, 17:32

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Jeandhom » 24 mars 2019, 13:59

Soucis de connexion client/serveur :

Client : app Roku Version 6.0.5 de Roku Inc sur iPad
Serveur : Fake Roku 2019-01-25 03:46:50 stable
Daemon : Ok
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:38 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:38 +0000] "GET /ecp-session HTTP/1.1" 404 172 "-" "-"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
WARNING:emulated_roku:Rejected non-advertised access by host monjeedom.mondomaine.fr
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.0" 403 172 "-" "-"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET /device-image.png HTTP/1.1" 404 172 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:40 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:41 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:43 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1373
Inscription : 20 oct. 2015, 17:32

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Jeandhom » 03 avr. 2019, 18:12

Jeandhom a écrit :
24 mars 2019, 13:59
Soucis de connexion client/serveur :

Client : app Roku Version 6.0.5 de Roku Inc sur iPad
Serveur : Fake Roku 2019-01-25 03:46:50 stable
Daemon : Ok
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:38 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:38 +0000] "GET /ecp-session HTTP/1.1" 404 172 "-" "-"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
WARNING:emulated_roku:Rejected non-advertised access by host monjeedom.mondomaine.fr
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET / HTTP/1.0" 403 172 "-" "-"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:39 +0000] "GET /device-image.png HTTP/1.1" 404 172 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:40 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:41 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
INFO:aiohttp.access:192.168.1.12 [24/Mar/2019:12:23:43 +0000] "GET / HTTP/1.1" 200 811 "-" "Roku/3 CFNetwork/976 Darwin/18.2.0"
Up, pour savoir si c'est un problème du plugin ou un problème de config sur mon installation.

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par nordix » 04 avr. 2019, 14:21

Si ton plugin fonctionne alors c'est ok. Ce n'est pas une erreur mais un warning!

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1373
Inscription : 20 oct. 2015, 17:32

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Jeandhom » 04 avr. 2019, 19:21

Justement non, le client voit bien le serveur mais il n'arrive pas à s'y connecter.
Pièces jointes
Roku_Client.jpg
Roku_Client.jpg (40.35 Kio) Consulté 735 fois

Dgak10
Timide
Messages : 35
Inscription : 20 nov. 2017, 23:28

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Dgak10 » 19 avr. 2019, 14:16

Je teste le plugin sur une Ultimate et un hub.
Ca fonctionne, j'arrive à créer une activité Roku et utiliser les boutons du LCD ou physiques quand l'activité est activée. Merci Lunarok ! :geek:

Maintenant je tente d'associer un bouton physique de la télécommande à une commande du fakeroku (via la configuration Harmony) mais pour le coup ca ne fonctionne pas. (jai bien synchronisé). Pas de réaction si l'activité n'est pas lancée.

Est ce un problème identifié ou suis une bille ?

Autre point est il envisageable de renommer les commandes ROKU visibles dans la télécommande via ce plugin ?
*edit* j'ai trouvé pour ce point ; cest une fonction de base de harmony, on y accède via le logiciel sous windows

merci

cairve
Timide
Messages : 62
Inscription : 18 déc. 2017, 11:39

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par cairve » 05 mai 2019, 08:32

Salut Lunarok,

suite au chargement d'une ancienne sauvegarde sur mon jeedom, ton plugin fakeroku ne veut plus installer les dépendances :

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Hit:2 http://ftp.debian.org/debian stretch-backports InRelease
Ign:3 http://ftp.fr.debian.org/debian stretch InRelease
Ign:4 http://ftp.de.debian.org/debian stretch InRelease
Hit:5 http://ftp.fr.debian.org/debian stretch-updates InRelease
Hit:6 http://ftp.fr.debian.org/debian stretch Release
Hit:7 http://ftp.de.debian.org/debian stretch Release
Hit:8 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Installation des dépendances apt
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version (9.0.1-2+deb9u1).
python3-dev is already the newest version (3.5.3-1).
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Installation du module aiohttp pour python
sudo: pip3: command not found
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Installation du module asyncio  pour python
sudo: pip3: command not found
********************************************************
*             Installation terminée                    *
********************************************************
Tu aurais une idée ?

Merci d'avance
Jeedom Z83 Debian 9
clé zigate 3.0f (40), clé zwave (25), clé 3G, 2 xiaomi Mi Home (30), Philips Hue (2), espeasy wifi (12), wifilight2 (2), blea (local + 1 déporté sur RPI2) + 3 Dafang custom
Awtrix 2.0, Logitech Harmony Elite
70 scénarios

agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par agasi34 » 08 mai 2019, 15:42

Tout d'abord merci encore pour ce super plugin ! c'est exactement ce que je cherchais :)
Par contre effectivement j'ai le meme problème que cairve sur l'installation des dépendances, j'ai l'impression qu'il y a un problème avec une version de python. J'ai essayé de mettre à jour python, aiohttp comme précisé plus haut dans les posts ... en vain.
J'ai par contre réussi à l'installer sur mon deuxieme jeedom sans aucun problème c'est assez dingue car j'ai la meme version de jeedom, meme version de python mais aucune erreur lors de l'installation des dépendances. Vraiment curieux.

Sur mon autre jeedom, le plugin est donc pleinement utilisable, par contre je me demandais pourquoi je ne retrouve pas toutes les commandes entre mon harmony et le plugin ? Sur harmony je dois avoir au moins une 30ène de bouton paramétrable, sur le plugin j'en ai 13. Savez vous pourquoi il y a cette différence ?

Merci en tout cas, je peux maintenant baisser mes volets avec ma telecommande et ça, c'est la classe :)

Dgak10
Timide
Messages : 35
Inscription : 20 nov. 2017, 23:28

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par Dgak10 » 10 mai 2019, 22:41

"sur le plugin j'en ai 13. Savez vous pourquoi il y a cette différence ?"

intéressé par ce point egalement

Avatar de l’utilisateur
chanchan
Timide
Messages : 16
Inscription : 24 janv. 2018, 11:17

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par chanchan » 28 mai 2019, 21:39

Bjr @ tous.
J'utilise depuis maintenant plus d'un an Jeedom sur Rpi 3B avec PiDrive sous Raspian Jessy (je sais qu'il faut que je le mette à jour et passer à Stretch mais j'ai peur que la restauration ne passe pas et pas trop le temps en ce moment, surtout que tout fonctionne parfaitement).

Comme certains, j'ai un problème avec l'installation des dépendances du Plugin "Fake ROKU", malgré plusieurs tentatives, la date reste sur "inconnue".
J'ai essayé les indications données par Bosquetia mais rien n'y fait.

Si je me connecte en SSH sur le Rpi et que j'essaie de lancer manuellement le script d'installation des dépendances (dependencies.sh) :

Code : Tout sélectionner

* Installation des dépendances *
Réception de : 1 http://mirrordirector.raspbian.org jessie InRelease [15,0 kB]
Réception de : 2 http://archive.raspberrypi.org jessie InRelease [22,9 kB]
Atteint https://deb.nodesource.com jessie InRelease
Réception de : 3 http://mirrordirector.raspbian.org jessie/main armhf Packages [9 539 kB]
Réception de : 4 http://archive.raspberrypi.org jessie/main armhf Packages [170 kB]
Atteint https://deb.nodesource.com jessie/main Sources
Atteint https://deb.nodesource.com jessie/main armhf Packages
Réception de : 5 https://deb.nodesource.com jessie/main Translation-fr_FR [162 B]
Réception de : 6 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Réception de : 7 https://deb.nodesource.com jessie/main Translation-en [162 B]
Réception de : 8 http://archive.raspberrypi.org jessie/ui armhf Packages [58,9 kB]
Réception de : 9 https://deb.nodesource.com jessie/main Translation-fr_FR [162 B]
Réception de : 10 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Réception de : 11 https://deb.nodesource.com jessie/main Translation-en [162 B]
Réception de : 12 https://deb.nodesource.com jessie/main Translation-fr_FR [162 B]
Réception de : 13 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Réception de : 14 https://deb.nodesource.com jessie/main Translation-en [162 B]
Réception de : 15 https://deb.nodesource.com jessie/main Translation-fr_FR [162 B]
Réception de : 16 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Réception de : 17 https://deb.nodesource.com jessie/main Translation-en [162 B]
Réception de : 18 https://deb.nodesource.com jessie/main Translation-fr_FR [162 B]
Ign https://deb.nodesource.com jessie/main Translation-fr_FR
Réception de : 19 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Ign https://deb.nodesource.com jessie/main Translation-fr
Réception de : 20 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/main Translation-fr_FR
Ign http://archive.raspberrypi.org jessie/main Translation-fr
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-fr_FR
Ign http://archive.raspberrypi.org jessie/ui Translation-fr
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Atteint http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Atteint http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Atteint http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-fr_FR
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-fr
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-fr_FR
Ign http://mirrordirector.raspbian.org jessie/main Translation-fr
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-fr_FR
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-fr
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-fr_FR
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-fr
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
9 806 ko réceptionnés en 22s (431 ko/s)
Lecture des listes de paquets... Fait
Installation des dépendances apt
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
python3-dev est déjà la plus récente version disponible.
python3-pip est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Installation du module aiohttp pour python
Requirement already satisfied: aiohttp in /usr/local/lib/python3.6/site-packages (3.5.1)
Requirement already satisfied: attrs>=17.3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (18.2.0)
Requirement already satisfied: chardet<4.0,>=2.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (3.0.4)
Requirement already satisfied: multidict<5.0,>=4.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (4.5.2)
Requirement already satisfied: async_timeout<4.0,>=3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (3.0.1)
Requirement already satisfied: yarl<2.0,>=1.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (1.3.0)
Requirement already satisfied: idna-ssl>=1.0 in /usr/local/lib/python3.6/site-packages (from aiohttp) (1.1.0)
Requirement already satisfied: typing_extensions>=3.6.5 in /usr/local/lib/python3.6/site-packages (from aiohttp) (3.6.6)
Requirement already satisfied: idna>=2.0 in /usr/local/lib/python3.6/site-packages (from yarl<2.0,>=1.0->aiohttp) (2.8)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Installation du module asyncio pour python
Requirement already satisfied: asyncio in /usr/local/lib/python3.6/site-packages (3.4.3)

* Installation terminée *
Je pense que c'est ça qui coince (mais pas sûr) :
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.

Si je fait :

Code : Tout sélectionner

compgen -ac | grep -E '^pip'
Il me répond :
@_screenshot_28.jpg
@_screenshot_28.jpg (18.74 Kio) Consulté 550 fois
Quand je veux installer les dépendances via l'interface de Jeedom, la roue crantée tourne pendant 10 secondes et rien, aucune date et toutes les "fonctionnalités" restent sur "Non" :
@_screenshot_26.jpg
@_screenshot_26.jpg (177.95 Kio) Consulté 550 fois
@_screenshot_25.jpg
@_screenshot_25.jpg (232.13 Kio) Consulté 550 fois
J'ai demandé de l'aide à Lunarok sur sa page Facebook et attends sa réponse.

Si quelqu’un peut m'aider ça serait bien car j'ai vraiment besoin de ce plugin pour l'utiliser avec ma Harmony Elite et ainsi pouvoir lancer des scénario rien qu'en appuyant sur une touche.

Merci d'avance.

arnox
Timide
Messages : 90
Inscription : 09 sept. 2018, 00:10

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par arnox » 31 mai 2019, 14:12

Bonjour a tous,
Ce plugin m'interesse mais je voudrai en savoir un tout petit peu plus: y-a-til du lag entre la pression sur le bouton de la teleco et le traitement par Jeedom? Leplugin Harmony est affreusement long et je ne voudrai pas avoir le meme effet...
Merci pour vos retours

totoonline
Timide
Messages : 55
Inscription : 11 janv. 2016, 18:46
Localisation : Le long de la Loire (44)

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par totoonline » 01 juin 2019, 07:00

Bonjour,
Pour ma part la réactivité est très bonne. A vu de nez, environ 500 ms sur un rpi3/ssd.

arnox
Timide
Messages : 90
Inscription : 09 sept. 2018, 00:10

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par arnox » 01 juin 2019, 13:54

totoonline a écrit :
01 juin 2019, 07:00
Bonjour,
Pour ma part la réactivité est très bonne. A vu de nez, environ 500 ms sur un rpi3/ssd.
Parfait, je vais essayer ça, merci !

Avatar de l’utilisateur
noodom
Actif
Messages : 980
Inscription : 13 juil. 2014, 17:25
Contact :

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par noodom » 15 juin 2019, 04:14

chanchan a écrit :
28 mai 2019, 21:39
Bjr @ tous.
J'utilise depuis maintenant plus d'un an Jeedom sur Rpi 3B avec PiDrive sous Raspian Jessy (je sais qu'il faut que je le mette à jour et passer à Stretch mais j'ai peur que la restauration ne passe pas et pas trop le temps en ce moment, surtout que tout fonctionne parfaitement).

Comme certains, j'ai un problème avec l'installation des dépendances du Plugin "Fake ROKU", malgré plusieurs tentatives, la date reste sur "inconnue".

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Installation du module asyncio pour python
Requirement already satisfied: asyncio in /usr/local/lib/python3.6/site-packages (3.4.3)


Je pense que c'est ça qui coince (mais pas sûr) :
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.



Si quelqu’un peut m'aider ça serait bien car j'ai vraiment besoin de ce plugin pour l'utiliser avec ma Harmony Elite et ainsi pouvoir lancer des scénario rien qu'en appuyant sur une touche.

Merci d'avance.
Salut,

J'ai eu le même message et avec les commandes suivantes, j'ai pu installer les dépendances et utiliser le plugin :

Code : Tout sélectionner

sudo apt-get remove python3-pip
sudo apt-get -y install python3-pip

Avatar de l’utilisateur
chanchan
Timide
Messages : 16
Inscription : 24 janv. 2018, 11:17

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par chanchan » 15 juin 2019, 09:42

Merci noodom pour ton aide, je viens d'essayer les lignes de commande que tu viens de me donner mais sans succès, lorsque je clique sur le bouton pour installer les dépendances, la roue crantée tourne 10 secondes (sans aucune notification de jeedom qu'il est en train de les installer) et toujours pas de date d'installation.

De même, aucune réponse de la part du développeur ni sur ce forum, ni sur son compte Facebook.

J'ai essayé de trouver un autre moyen pour commander Jeedom sans utiliser mon Smartphone et j'ai trouvé une solution qui me convient par défaut. J'ai programmé un Addon de Kodi qui me permet d'exécuter une commande ou un scénario de Jeedom directement dans Kodi (viewtopic.php?f=142&t=45855)

knorkies63
Timide
Messages : 17
Inscription : 30 juin 2014, 11:45

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par knorkies63 » 29 août 2019, 10:13

Bonjour,

j'ai installé le plugin, c'est juste parfait pour pouvoir commander ma domotique depuis mon harmony.

Pour ma part, après un premier test sur des commandes d'éclairage, je n'ai aucun temps de latence perceptible!

agasi34 a écrit :
08 mai 2019, 15:42

Sur mon autre jeedom, le plugin est donc pleinement utilisable, par contre je me demandais pourquoi je ne retrouve pas toutes les commandes entre mon harmony et le plugin ? Sur harmony je dois avoir au moins une 30ène de bouton paramétrable, sur le plugin j'en ai 13. Savez vous pourquoi il y a cette différence ?

Je suis également intéressé par ce point. Les commandes correspondant aux apps type Netflix et autres ne sont par exemple pas proposés via le plugin.

Est il possible d'intégrer toutes ces commandes, via une mise à jour du plugin ou manuellement, ou alors s'agit t'il d'une limitation de l'api Emulated_Roku?

13 commandes, c'est déjà une très bonne base, mais ce serait encore plus confortable de pouvoir utiliser d'autres commandes.

kerm'j
Timide
Messages : 199
Inscription : 18 sept. 2015, 16:29

Re: Idée pour le dev d'un nouveau plugin - Emulateur de ROKU

Message par kerm'j » 30 sept. 2019, 15:37

Bonjour,

j'ai également installé ce plugin qui fonctionne très bien (merci @Lunarok) avec les commandes de base (bouton haut, bas, gauche, etc...). Même si j'ai du testé car certaines commandes ne sont pas intuitives (correspondances boutons de la télécommande et commandes du plugin).

Par contre comme demandé dans le post précédent, comment ajouter de nouvelles commandes au plugin ? Le développeur a-t-il prévu de faire évoluer ce plugin ? Et à quoi servent les commandes créées par le hub lors de la création du dispositif (Netflix, Amazon, etc...)

Aussi, est-il possible d'utiliser les boutons domotiques (faire reconnaître le plugin par le Hub Harmony) ? J'ai cru lire sur d'autres posts que c'était possible ?!

Merci d'avance pour vos réponses.

Edit au 17/10 : j'ai finalement réussi à trouver comment utiliser les boutons domotiques de la télécommande mais pas de retour sur les évolutions potentiels du plugin (je reste un peu déçu car à 4€ je pensais qu'il y aurait plus de suivi :(
Raspberry PI3+ / z-stick aeon gen5 / Jeedom v3.3.33 / 50+ modules zwave

*** Un grand merci à toute l'équipe Jeedom et aux membres actifs du forum pour leur aide ! ***

Répondre

Revenir vers « Suggestions de Plugins »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité