Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Dash Button Amazon

Pour échanger sur les plugins classés en catégorie "Objets connectés"
Titom59
Timide
Messages : 92
Inscription : 25 mars 2018, 15:09

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Titom59 » 04 sept. 2019, 11:36

Personne n'a de solution ?

Envoyé de mon ONEPLUS A5010 en utilisant Tapatalk


philbil
Timide
Messages : 2
Inscription : 18 déc. 2018, 18:31

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par philbil » 09 sept. 2019, 10:29

Bonjour,

J'ai fait un upgrade hier de mon jeedom et depuis j'ai le même problème au niveau des dépendances.
Comment faire pour installer une version inférieur de nodejs. Je n'ai pas trouvé le node-install pour x86.

D'avance merci pour les retours

corv45
Timide
Messages : 4
Inscription : 29 mai 2018, 10:08

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par corv45 » 09 sept. 2019, 21:51

bonjour tout le monde une mise a jour est prévu pour le plugin? avec la mise a jour nodejs sa ma foutu la merde

phiphila
Timide
Messages : 49
Inscription : 05 avr. 2017, 07:10

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par phiphila » 12 sept. 2019, 06:01

bonjour,
suite au passage a linux strech sur ma smart, impossible de faire fonctionner mes dash button

voici l'erreur a l’install des dépendance, perso je m'y pers, pas assez de connaissance en la matière, si quelqu'un peu me renseigné avant que je jette l’éponge et désinstalle ce plugin ...

Code : Tout sélectionner

Début de l'installation
Reading package lists...
Building dependency tree...
Reading state information...
libpcap-dev is already the newest version (1.8.1-3).
0 upgraded, 0 newly installed, 0 to remove and 173 not upgraded.
--2019-09-12 03:44:59--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.128.133, 151.101.192.133, 151.101.0.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.128.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1491 (1.5K) [text/plain]
Saving to: 'dependencies.sh'

     0K .                                                     100% 16.0M=0s

2019-09-12 03:44:59 (16.0 MB/s) - 'dependencies.sh' saved [1491/1491]

dependencies.sh: 3: [: dashbutton: unexpected operator
Version actuelle : 12
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://www.deb-multimedia.org stretch InRelease
Hit:4 http://ftp.debian.org/debian stretch-updates InRelease
Hit:5 http://ftp.debian.org/debian stretch-backports InRelease
Hit:6 https://deb.nodesource.com/node_12.x stretch InRelease
Hit:7 http://ftp.debian.org/debian stretch-proposed-updates InRelease
Hit:8 http://ftp.debian.org/debian stretch Release
Hit:9 http://repo.jeedom.com/odroid stable InRelease
Hit:10 https://oph.mdrjr.net/meveric all InRelease
Hit:11 https://oph.mdrjr.net/meveric stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125).
0 upgraded, 0 newly installed, 0 to remove and 173 not upgraded.
Ok, version suffisante

> socketwatcher@0.3.0 install /var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher
> node-gyp rebuild

make: Entering directory '/var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher/build'
  CXX(target) Release/obj.target/socketwatcher/socket_watcher.o
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Initialize(v8::Local<v8::Object>)':
../socket_watcher.cpp:29:36: error: no matching function for call to 'v8::FunctionTemplate::GetFunction()'
   constructor.Reset(t->GetFunction());
                                    ^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
                 from ../../nan/nan.h:54,
                 from ../socket_watcher.hpp:8,
                 from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note: candidate: v8::MaybeLocal<v8::Function> v8::FunctionTemplate::GetFunction(v8::Local<v8::Context>)
   V8_WARN_UNUSED_RESULT MaybeLocal<Function> GetFunction(
                                              ^~~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note:   candidate expects 1 argument, 0 provided
../socket_watcher.cpp:30:75: error: no matching function for call to 'v8::FunctionTemplate::GetFunction()'
   exports->Set(Nan::New("SocketWatcher").ToLocalChecked(), t->GetFunction());
                                                                           ^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
                 from ../../nan/nan.h:54,
                 from ../socket_watcher.hpp:8,
                 from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note: candidate: v8::MaybeLocal<v8::Function> v8::FunctionTemplate::GetFunction(v8::Local<v8::Context>)
   V8_WARN_UNUSED_RESULT MaybeLocal<Function> GetFunction(
                                              ^~~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note:   candidate expects 1 argument, 0 provided
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Callback(uv_poll_t*, int, int)':
../socket_watcher.cpp:77:60: warning: 'v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)' is deprecated [-Wdeprecated-declarations]
   Nan::MakeCallback(watcher->handle(), callback, argc, argv);
                                                            ^
In file included from ../socket_watcher.hpp:8:0,
                 from ../socket_watcher.cpp:5:
../../nan/nan.h:1024:46: note: declared here
   NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                              ^~~~~~~~~~~~
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Set(const Nan::FunctionCallbackInfo<v8::Value>&)':
../socket_watcher.cpp:116:32: error: no matching function for call to 'v8::Value::Int32Value()'
   int fd = info[0]->Int32Value();
                                ^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
                 from ../../nan/nan.h:54,
                 from ../socket_watcher.hpp:8,
                 from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:2582:40: note: candidate: v8::Maybe<int> v8::Value::Int32Value(v8::Local<v8::Context>) const
   V8_WARN_UNUSED_RESULT Maybe<int32_t> Int32Value(Local<Context> context) const;
                                        ^~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:2582:40: note:   candidate expects 1 argument, 0 provided
socketwatcher.target.mk:109: recipe for target 'Release/obj.target/socketwatcher/socket_watcher.o' failed
make: *** [Release/obj.target/socketwatcher/socket_watcher.o] Error 1
make: Leaving directory '/var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:196:23)
gyp ERR! stack     at ChildProcess.emit (events.js:209:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
gyp ERR! System Linux 3.14.79-94
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher
gyp ERR! node -v v12.10.0
gyp ERR! node-gyp -v v5.0.3
gyp ERR! not ok 
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! socketwatcher@0.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the socketwatcher@0.3.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /var/www/.npm/_logs/2019-09-12T03_45_57_328Z-debug.log
Fin de l'installation
Merci

arsach
Timide
Messages : 2
Inscription : 20 juin 2019, 11:01

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par arsach » 12 sept. 2019, 14:10

Hello,

Petit up, je rencontre le même soucis à l'exécution du Deamon:

Code : Tout sélectionner

Error: The module '/var/www/html/plugins/dashbutton/resources/node_modules/pcap/build/Release/pcap_binding.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 64. This version of Node.js requires
NODE_MODULE_VERSION 72. Please try re-compiling or re-installing
J'espérais continuer à utiliser ces Dashbuttons bien qu'Amazon ait décidé de les enterrer.

Quelqu'un a-t-il une solution pour que le plugin puisse toujours tourner ? Recompiler qque chose ?

Merci

Titom59
Timide
Messages : 92
Inscription : 25 mars 2018, 15:09

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Titom59 » 12 sept. 2019, 20:39

Ça reste sans réponse depuis un moment c'est dommage j'avais quelques boutons que j'utilisais au quotidien.

Envoyé de mon ONEPLUS A5010 en utilisant Tapatalk


thomious
Timide
Messages : 201
Inscription : 15 sept. 2014, 22:53

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par thomious » 13 sept. 2019, 20:17

Titom59 a écrit :
12 sept. 2019, 20:39
Ça reste sans réponse depuis un moment c'est dommage j'avais quelques boutons que j'utilisais au quotidien.

Envoyé de mon ONEPLUS A5010 en utilisant Tapatalk

idem bien pratique les dash!

BetyOops
Timide
Messages : 107
Inscription : 13 avr. 2016, 14:35

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par BetyOops » 21 sept. 2019, 13:05

Si vous avez un vieux snapshot de jeedom sous une vm où dashbutton tournait, il reste la solution de monter un second petit jeedom en esclave avec juste dashbutton et jeedom link pour remonter les dash à votre jeedom principal.

J'avais un vieux snapshot qui trainait de 2018 en 3.1.16, çà fait parfaitement l'affaire, le plugin tourne, les dash sont remontés à jeedom.
Lenovo M720 Tiny - VMWare Debian 9 Jeedom DIY
Zwave - Bluetooth
Alexa Echo - Harmony Elite

phiphila
Timide
Messages : 49
Inscription : 05 avr. 2017, 07:10

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par phiphila » 22 sept. 2019, 10:05

Deja que le fonctionnement des dash étaient limite contraignant, la ca va devenir une vraie usine a gaz... ;)

Avatar de l’utilisateur
HollyFredD
Timide
Messages : 92
Inscription : 14 janv. 2018, 12:54

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par HollyFredD » 22 sept. 2019, 10:28

J'utilise le plugin "Dash Button" et ça fonctionne très bien.

Il suffit juste de récupérer l'@MAC et en avant !

Envoyé de mon OnePlus 6 en utilisant mes petits doigts


Fouy
Timide
Messages : 53
Inscription : 23 juil. 2015, 15:56

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Fouy » 23 sept. 2019, 13:01

HollyFredD a écrit :
22 sept. 2019, 10:28
J'utilise le plugin "Dash Button" et ça fonctionne très bien.
Ben tu as de la chance : la discussion du moment vient du fait que ce plugin n'a plus évolué et que les mises à jour de node.js pour les autres plugin rendent le plugin Dash inopérant me semble-t-il...

flodus
Timide
Messages : 33
Inscription : 13 mars 2015, 18:48

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par flodus » 23 sept. 2019, 17:37

Bonjour,

J'avais acheté un amazon dash button dès que j'avais vu qu'il était hackable, mais je ne m'en étais pas encore servit.
J'ai enfin trouvé à quoi ça pourrait me servir, donc j'installe le plugin et pouf ça marche pas dès l'install à cause de nodejs.
Moi je suis pas développeur alors je peux donner que mon avis d'utilisateur mais node.js franchement c'est relou, y a rien de retrocompatible et souvent ça marche pas et trouvé pourquoi c'est coton.... même Ryan Dahl, le développeur de node.js le dit ;)
https://www.programmez.com/actualites/d ... dejs-29342.

Par contre j'aime bien bidouiller et j'ai trouvé deux trucs pour mes dash.
Mon Jeedom est installé sur un intel nuc où tourne debian.
En cherchant un peu j'ai trouvé 2 projets github :
https://github.com/maxisme/amazon-bash ; http://so-domotic.fr/2017/11/20/hack-si ... sh-button/
https://github.com/Nekmo/amazon-dash ; https://docs.nekmo.org/amazon-dash/index.html

Moi je suis parti du 1er projet:
donc sur ma debian :

Code : Tout sélectionner

sudo apt-get install tcpdump arp-scan aircrack-ng
cd ~
git clone https://github.com/maxisme/amazon-bash.git
cd amazon-bash
Pour trouver la MAC de mon button :

Code : Tout sélectionner

sudo -i
cd /home/<user>/amazon-bash
while :; do arp-scan --localnet -O ieee-oui.txt | grep 'Amazon'; done

on clique sur notre bouton amazon est normalement on a la mac qui s'affiche

Code : Tout sélectionner

192.168.1.133    ac:63:be:2f:23     Amazon Technologies Inc.
on copie la mac,
on edite amazon-bash.sh ou amazon-bash-wifi.sh depuis le dossier /amazon-bash/

Code : Tout sélectionner

nano amazon-bash.sh
nano amazon-bash-wifi
et dans ce fichier à la deuxième ligne on indique notre @mac:

Code : Tout sélectionner

MAC="ac:63:be:2f:23"
et pour la fonction onclick j'ai indiqué par api que je voulais que soit lancé un scénario, info trouvé depuis la doc https://jeedom.github.io/core/fr_FR/api_http:

Code : Tout sélectionner

function onClick {
 #code to be ran on click
  curl -s "http://#IP_JEEDOM#/core/api/jeeApi.php?apikey=#APIKEY#&type=scenario&id=#ID#&action=#ACTION#"
 }
avec "start" pour #ACTION#

Dernière chose mettre amazon-bash en service

Code : Tout sélectionner

nano amazonbash.service

[Unit]
Description=Amazon Bash service
After=network.target multi-user.target

[Service]
Type=simple
User=root
ExecStart=<CHEMIN ABSOLU VERS VOTRE SCRIPT AMAZON BASH>/amazon-bash.sh &

[Install]
WantedBy=multi-user.target

Code : Tout sélectionner

sudo cp amazonbash.service /etc/systemd/system/ 
sudo systemctl daemon-reload
sudo systemctl enable amazonbash.service
Bon c'est peut être pas le plus simple, mais ça fonctionne bien.
J'ai pas encore essayer le deuxième projet c'est du python... à voir ...
[EDIT] J'ai l'impression que le 2ème projet permet de gérer plusieurs boutons !!! [/EDIT]

Comme je le disais je ne suis pas développeur donc je suis incapable de faire un plugin mais si ça peut débloquer ou donner des idées .... voire à @lunarok s'il veut reprendre son plugin ;)

UnixDave
Timide
Messages : 8
Inscription : 10 déc. 2016, 05:57

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par UnixDave » 27 sept. 2019, 03:37

Idem, depuis la dernière MàJ à Debian 9.11 et Node 12.10 impossible d'installer les dépendances et de plugin dashbutton est inutilisable.

Code : Tout sélectionner

Début de l'installation
Reading package lists...
Building dependency tree...
Reading state information...
libpcap-dev is already the newest version (1.8.1-3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--2019-09-26 21:04:50--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.136.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.136.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1491 (1.5K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 31.5M=0s
2019-09-26 21:04:50 (31.5 MB/s) - 'dependencies.sh' saved [1491/1491]
dependencies.sh: 3: [: dashbutton: unexpected operator
dependencies.sh: 8: dependencies.sh: cannot create /tmp/${2}_dep: Permission denied
dependencies.sh: 15: dependencies.sh: cannot create /tmp/${2}_dep: Permission denied
Version actuelle : 12
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://mirror.csclub.uwaterloo.ca/debian stretch InRelease
Hit:3 http://mirror.csclub.uwaterloo.ca/debian stretch-updates InRelease
Hit:4 http://mirror.csclub.uwaterloo.ca/debian stretch Release
Hit:5 https://deb.nodesource.com/node_12.x stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Ok, version suffisante
dependencies.sh: 54: dependencies.sh: cannot create /tmp/${2}_dep: Permission denied
dependencies.sh: 58: dependencies.sh: cannot create /tmp/${2}_dep: Permission denied
> socketwatcher@0.3.0 install /var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher
> node-gyp rebuild
make: Entering directory '/var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher/build'
CXX(target) Release/obj.target/socketwatcher/socket_watcher.o
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Initialize(v8::Local<v8::Object>)':
../socket_watcher.cpp:29:36: error: no matching function for call to 'v8::FunctionTemplate::GetFunction()'
constructor.Reset(t->GetFunction());
^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
from ../../nan/nan.h:54,
from ../socket_watcher.hpp:8,
from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note: candidate: v8::MaybeLocal<v8::Function> v8::FunctionTemplate::GetFunction(v8::Local<v8::Context>)
V8_WARN_UNUSED_RESULT MaybeLocal<Function> GetFunction(
^~~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note:   candidate expects 1 argument, 0 provided
../socket_watcher.cpp:30:75: error: no matching function for call to 'v8::FunctionTemplate::GetFunction()'
exports->Set(Nan::New("SocketWatcher").ToLocalChecked(), t->GetFunction());
^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
from ../../nan/nan.h:54,
from ../socket_watcher.hpp:8,
from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note: candidate: v8::MaybeLocal<v8::Function> v8::FunctionTemplate::GetFunction(v8::Local<v8::Context>)
V8_WARN_UNUSED_RESULT MaybeLocal<Function> GetFunction(
^~~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:5961:46: note:   candidate expects 1 argument, 0 provided
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Callback(uv_poll_t*, int, int)':
../socket_watcher.cpp:77:60: warning: 'v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)' is deprecated [-Wdeprecated-declarations]
Nan::MakeCallback(watcher->handle(), callback, argc, argv);
^
In file included from ../socket_watcher.hpp:8:0,
from ../socket_watcher.cpp:5:
../../nan/nan.h:1024:46: note: declared here
NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
^~~~~~~~~~~~
../socket_watcher.cpp: In static member function 'static void SocketWatcher::Set(const Nan::FunctionCallbackInfo<v8::Value>&)':
../socket_watcher.cpp:116:32: error: no matching function for call to 'v8::Value::Int32Value()'
int fd = info[0]->Int32Value();
^
In file included from /var/www/.cache/node-gyp/12.10.0/include/node/node.h:63:0,
from ../../nan/nan.h:54,
from ../socket_watcher.hpp:8,
from ../socket_watcher.cpp:5:
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:2582:40: note: candidate: v8::Maybe<int> v8::Value::Int32Value(v8::Local<v8::Context>) const
V8_WARN_UNUSED_RESULT Maybe<int32_t> Int32Value(Local<Context> context) const;
^~~~~~~~~~
/var/www/.cache/node-gyp/12.10.0/include/node/v8.h:2582:40: note:   candidate expects 1 argument, 0 provided
socketwatcher.target.mk:109: recipe for target 'Release/obj.target/socketwatcher/socket_watcher.o' failed
make: *** [Release/obj.target/socketwatcher/socket_watcher.o] Error 1
make: Leaving directory '/var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:196:23)
gyp ERR! stack     at ChildProcess.emit (events.js:209:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
gyp ERR! System Linux 4.9.0-11-amd64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /var/www/html/plugins/dashbutton/resources/node_modules/socketwatcher
gyp ERR! node -v v12.10.0
gyp ERR! node-gyp -v v5.0.3
gyp ERR! not ok
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! socketwatcher@0.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the socketwatcher@0.3.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /var/www/.npm/_logs/2019-09-27T01_05_00_416Z-debug.log
Fin de l'installation

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1286
Inscription : 02 avr. 2015, 08:37

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Darkeyes » 01 oct. 2019, 10:47

Salut,
Si @lunarok, pouvait nous faire signe, histoire de savoir s’il prévoit de mettre a jour le plugin pour le rendre compatible ce serait sympa
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

Avatar de l’utilisateur
Neokamikaze
Timide
Messages : 65
Inscription : 20 août 2014, 13:26
Localisation : Paris

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Neokamikaze » 10 oct. 2019, 14:36

Salut,

Idem pour moi @lunarok.

Merci d'avance
Ciao

TeHeR
Timide
Messages : 181
Inscription : 17 nov. 2015, 09:58
Localisation : Grenoble

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par TeHeR » 16 oct. 2019, 10:20

Hello,

J'ai dû changer les piles de l'un de mes boutons. Malheureusement, impossible de le ré-activer. Il clignote (sur appui long) ou reste toujours bleu (appui court)...

Je ne peux donc pas aller plus loin... (j'avais bien l'adresse MAC sauvegardée ou suivre l'une des méthodes proposées par @flodus).

Quelqu'un a passé cette étape ?

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1286
Inscription : 02 avr. 2015, 08:37

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Darkeyes » 17 oct. 2019, 22:31

TeHeR a écrit :Hello,

J'ai dû changer les piles de l'un de mes boutons. Malheureusement, impossible de le ré-activer. Il clignote (sur appui long) ou reste toujours bleu (appui court)...

Je ne peux donc pas aller plus loin... (j'avais bien l'adresse MAC sauvegardée ou suivre l'une des méthodes proposées par @flodus).

Quelqu'un a passé cette étape ?
Salut,
Je pense que ton bouton n’a plus la conf wifi. Il ne doit pas stocker ses paramètres.
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1286
Inscription : 02 avr. 2015, 08:37

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Darkeyes » 21 oct. 2019, 12:36

Bonjour à vous,

J'ai une 10ène de boutons en stock.

Question peut-on au jour d'aujourd'hui, toujours intégrer des nouveaux boutons via l'appli Amazon?
Car je n'ai qu'un Iphone et avec la version de app amazon que j'ai ce n'est plus possible.
Peut être avec une ancienne version, car si on ne peut plus les connecter au réseau wifi, ils sont bon pour le recyclage.

Merci pour vos retours.
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

TeHeR
Timide
Messages : 181
Inscription : 17 nov. 2015, 09:58
Localisation : Grenoble

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par TeHeR » 21 oct. 2019, 17:03

Hello,

A mon avis ils sont comme celui dont je viens de changer les piles... Ca ne se présente pas très bien... (J'imagine que l'app est dépendante de nombreux appels à la plateforme Amazon).

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3415
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [Plugin Tiers][Sujet Principal] Dash Button Amazon

Message par Fabrice » 21 oct. 2019, 19:29

Bonjour.

Non, ce n'est pas utile de les appeler, Amazon ayant mis fin à l'utilisation de ses boutons Dash.
Et est donc logique de ne plus pouvoir les associer à notre réseau.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités