Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Plugin Tiers][Sujet Principal] JPI Plugin

Pour échanger sur les plugins classés en catégorie "Objets connectés"
Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 12 avr. 2018, 17:45

marmoul a écrit :
12 avr. 2018, 17:22
Bonjour,

Je viens car j'ai un problème avec les ask.
J'ai fais la dernière maj du pluging et depuis les réponses ne sont jamais reçu dans jeedom.
Je précise que sa marchait bien avant :)

Y'a t'il une modif à faire dans les scénarios?
J'ai essayer de refaire la commande dans JPI et jeedom mais toujours pas.
Sa fonctionne bien avec les interactions mais pas les réponses.
Je vois bien les SMS dans JPI.


Si quelqu'un a une idee.

Merci
Hello,
bizarre, je n'ai pas fait de modification sur la partie ask et donc non pas de modification à faire de ton côté.
Je regarderai ce soir.

il faut que tu édites tes logs car il y a tes logs car il y a ton numéro de tél.
[EDIT] dans tes logs tu as l'erreur :
[2018-04-12 16:44:54][ERROR] : Vous n'etes pas autorisé à effectuer cette action (JPI)
[2018-04-12 16:52:02][ERROR] : Vous n'etes pas autorisé à effectuer cette action (JPI)

Cela correspond normalement à une erreur d'API. As-tu checké la clé dans l'APK ?
A+
Dernière édition par Jerome84 le 12 avr. 2018, 17:53, édité 1 fois.

Avatar de l’utilisateur
marmoul
Actif
Messages : 832
Inscription : 01 sept. 2015, 15:50
Localisation : Haute-Saône (70)

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par marmoul » 12 avr. 2018, 17:49

Merci je viens de le faire :)

aubioine
Timide
Messages : 46
Inscription : 23 janv. 2016, 22:02
Localisation : Proche de Nantes

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par aubioine » 12 avr. 2018, 18:22

Jerome84 a écrit :
11 avr. 2018, 18:31
aubioine a écrit :
11 avr. 2018, 18:11
Je cherche à faire fonctionner la fonctionnalité MMS... Après plusieurs tentatives, je sèche un peu..... Quelqu'un a un mini tuto ? (Paramètres, action de scénarios,...)

Envoyé de mon Redmi Note 3 en utilisant Tapatalk
pas de tuto dispo pour le moment de dispo pour le moment.
montre-moi ta configuration ( commande scénario et aussi tes logs) je te dirais ce qui ne va pas.
Voici les logs (API et numéro masqué)

Je pense que je n'arrive pas à renseigner correctement les paramètre et option de la commande MMS JPI
J'était parti sur un scénario qui fait capture plus commande envoi mms
Dans les paramètres, j'ai mis : pathfile='/var/www/html/plugins/camera/data/records/24'

Code : Tout sélectionner

[2018-04-12 18:15:44][INFO] : Execution de la commande : 
[2018-04-12 18:15:45][DEBUG] : Requete lancée pour la commande  : http://192.168.1.11:8080/?action=download&url=http%3A%2F%2F192.168.1.19%3A80%2Fcore%2Fphp%2FdownloadFile.php%3Fapikey%xxxxxxxxxpathfile%3D&__JPIPLUG=1 - Résultat : ERREUR! Impossible de télécharger le fichier à partir de http://192.168.1.19:80/core/php/downloadFile.php?apikey=xxxxxxxxxxx&pathfile=
[2018-04-12 18:15:45][ERROR] : La requete pour la commande  n'a pas été exécutée
[2018-04-12 18:15:45][INFO] : Execution de la commande : MMS Antoine
[2018-04-12 18:15:45][DEBUG] : Requete lancée pour la commande MMS Antoine : http://192.168.1.11:8080/?action=sendMms&number=00000000000&message=&imagePath=&__JPIPLUG=1 - Résultat : ERREUR!
[2018-04-12 18:15:45][ERROR] : La requete pour la commande MMS Antoine n'a pas été exécutée
[2018-04-12 18:15:45][INFO] : Execution de la commande : 
[2018-04-12 18:15:46][DEBUG] : Requete lancée pour la commande  : http://192.168.1.11:8080/?action=delete&filePath=&__JPIPLUG=1 - Résultat : ERREUR : Le fichier  n’existe pas !
[2018-04-12 18:15:46][ERROR] : La requete pour la commande  n'a pas été exécutée

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 12 avr. 2018, 20:51

marmoul a écrit :
12 avr. 2018, 17:49
Merci je viens de le faire :)
Ok, il y a eu une régression sur l'API, je viens de publier le fix

Avatar de l’utilisateur
marmoul
Actif
Messages : 832
Inscription : 01 sept. 2015, 15:50
Localisation : Haute-Saône (70)

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par marmoul » 12 avr. 2018, 21:07

Ah cool merci :)
J'attend l'update bonne soirée ;)

edit:
c'est corrigé merci!!!!!

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 12 avr. 2018, 21:45

marmoul a écrit :
12 avr. 2018, 21:07
Ah cool merci :)
J'attend l'update bonne soirée ;)

edit:
c'est corrigé merci!!!!!
Cool

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 12 avr. 2018, 21:53

aubioine a écrit :
12 avr. 2018, 18:22
Plutôt qu'un long discours, voici un exemple.
La commande MMS a créer :
2018-04-12_21h41_22.png
2018-04-12_21h41_22.png (55.75 Kio) Consulté 1008 fois
Le scénario type avec le plugin caméra.
2018-04-12_21h39_52.png
2018-04-12_21h39_52.png (14.76 Kio) Consulté 1008 fois
Comme tu le vois, pas de fichier spécifié. Le plugin caméra pousse automatiquement le nom et le chemin complet de l'image, le plugin JPI le récupère, l'upload sur le téléphone, expédie le MMS et supprime le fichier.
Du coup, ça marche super bien pour les scénarios de sécurité.

PS : j'ai vu que la partie MMS génére des petites erreurs dans les logs, rien d'alarmant. Je corrigerai cela ce week-end.

aubioine
Timide
Messages : 46
Inscription : 23 janv. 2016, 22:02
Localisation : Proche de Nantes

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par aubioine » 12 avr. 2018, 22:08

Ah bah oui, merci ! C'est top.
Je passait via capture.... j'avais oublié cette commande.
Et ça m'a également fait remarquer que j'avais oublié de config le MMS en action/message, il était resté en défaut.

Merci encore :)

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 12 avr. 2018, 22:10

aubioine a écrit :
12 avr. 2018, 22:08
Ah bah oui, merci ! C'est top.
Je passait via capture.... j'avais oublié cette commande.
Et ça m'a également fait remarquer que j'avais oublié de config le MMS en action/message, il était resté en défaut.

Merci encore :)
;)

Jeff92
Timide
Messages : 63
Inscription : 18 févr. 2017, 12:11

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jeff92 » 13 avr. 2018, 16:14

Bonjour à tous

Je suis en train de mettre en place la fonction ask de JPI et j'ai qqs soucis.
- la question arrive bien sur mon tél
- je réponds
- le sms de réponse arrive bien sur JPI apk
Mais rien ne remonte dans jeedom. la variable contient le texte "aucune réponse " !
J'étais avec l'ancienne version du plugiin. J'ai donc fait la maj mais c'est pareil ; à une différence près c'est que les temps de réponse sont devenus considérables par moment et surtout lorsque l'on est dans les commandes du plugin avec la saisie manuelle des cdes ou avec l'assistant. L'assistant ne réagit jamais de la même façon ( lignes action, options ou pas de ligne action permettant la saisie...). Il doit y avoir un pb d'instabilité quelque part. Je n'avais pas ça avec l'ancienne version du plugin.

Au niveau JPI apk je suis à la dernière version ainsi que jeedom.
La fonction sms fonctionne très bien
j'ai suivi le tuto de guillaume Braillon qui est très clair pour la fonction ask.
il y a certainement un point qui m'échappe. La réponse venant de JPI apk doit se trouver dans quelle variable ?
jeedomJPI ou celle que l'on indique dans le scénario ?
Au niveau des logs aucune erreur.
La clé api jeedom est ok ( je commande la prise d'alimentation du tél et c'est ok )

Si quelqu'un a une idée
Merci d'avance

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 13 avr. 2018, 18:48

Jeff92 a écrit :
13 avr. 2018, 16:14
Bonjour à tous

Je suis en train de mettre en place la fonction ask de JPI et j'ai qqs soucis.
- la question arrive bien sur mon tél
- je réponds
- le sms de réponse arrive bien sur JPI apk
Mais rien ne remonte dans jeedom. la variable contient le texte "aucune réponse " !
J'étais avec l'ancienne version du plugiin. J'ai donc fait la maj mais c'est pareil ; à une différence près c'est que les temps de réponse sont devenus considérables par moment et surtout lorsque l'on est dans les commandes du plugin avec la saisie manuelle des cdes ou avec l'assistant. L'assistant ne réagit jamais de la même façon ( lignes action, options ou pas de ligne action permettant la saisie...). Il doit y avoir un pb d'instabilité quelque part. Je n'avais pas ça avec l'ancienne version du plugin.

Au niveau JPI apk je suis à la dernière version ainsi que jeedom.
La fonction sms fonctionne très bien
j'ai suivi le tuto de guillaume Braillon qui est très clair pour la fonction ask.
il y a certainement un point qui m'échappe. La réponse venant de JPI apk doit se trouver dans quelle variable ?
jeedomJPI ou celle que l'on indique dans le scénario ?
Au niveau des logs aucune erreur.
La clé api jeedom est ok ( je commande la prise d'alimentation du tél et c'est ok )

Si quelqu'un a une idée
Merci d'avance

Je viens de refaire un test avec la dernière version stable du plugin et je ne vois aucun pb avec l'ask.
Peux-tu passer tes logs de l'apk au niveau 3 et poster le déroulement d'un test ASK (log événement de tete) ?

Jeff92
Timide
Messages : 63
Inscription : 18 févr. 2017, 12:11

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jeff92 » 13 avr. 2018, 22:39

Jerome84 a écrit :
13 avr. 2018, 18:48
Jeff92 a écrit :
13 avr. 2018, 16:14
Bonjour à tous

Je suis en train de mettre en place la fonction ask de JPI et j'ai qqs soucis.
- la question arrive bien sur mon tél
- je réponds
- le sms de réponse arrive bien sur JPI apk
Mais rien ne remonte dans jeedom. la variable contient le texte "aucune réponse " !
J'étais avec l'ancienne version du plugiin. J'ai donc fait la maj mais c'est pareil ; à une différence près c'est que les temps de réponse sont devenus considérables par moment et surtout lorsque l'on est dans les commandes du plugin avec la saisie manuelle des cdes ou avec l'assistant. L'assistant ne réagit jamais de la même façon ( lignes action, options ou pas de ligne action permettant la saisie...). Il doit y avoir un pb d'instabilité quelque part. Je n'avais pas ça avec l'ancienne version du plugin.

Au niveau JPI apk je suis à la dernière version ainsi que jeedom.
La fonction sms fonctionne très bien
j'ai suivi le tuto de guillaume Braillon qui est très clair pour la fonction ask.
il y a certainement un point qui m'échappe. La réponse venant de JPI apk doit se trouver dans quelle variable ?
jeedomJPI ou celle que l'on indique dans le scénario ?
Au niveau des logs aucune erreur.
La clé api jeedom est ok ( je commande la prise d'alimentation du tél et c'est ok )

Si quelqu'un a une idée
Merci d'avance


Je viens de refaire un test avec la dernière version stable du plugin et je ne vois aucun pb avec l'ask.
Peux-tu passer tes logs de l'apk au niveau 3 et poster le déroulement d'un test ASK (log événement de tete) ?

Ci-joint les logs d'un test cde ask du plugin jpi
===================
Log du scénario jeedom

[2018-04-13 21:53:29][SCENARIO] Start : 'Scenario lance manuellement'.
[2018-04-13 21:53:29][SCENARIO] Exécution du sous-élément de type [action] : action
[2018-04-13 21:53:30][SCENARIO] Demande Array
(
[title] => Femeture volets ?
[message] => Femeture volets ?
[answer] => Array
(
[0] => OUI
[1] => NON
)
[timeout] => 300
[variable] => Rep_ASK
)
[2018-04-13 21:58:52][SCENARIO] Réponse Aucune réponse => ( pour info j'ai répondu OUI avant le timeout et le sms est bien arrivé dans apk JPI)
[2018-04-13 21:58:52][SCENARIO] Fin correcte du scénario

===================
log de la cde ask du plugin JPI :

[2018-04-13 21:53:30] JPI.INFO: Execution de la commande : ask [] []
[2018-04-13 21:53:35] JPI.DEBUG: Requete lancée pour la commande ask : http://192.x.x.x:yy/?action=sendSms&number={MY_NUMBER}&message=Femeture+volets+%3F+%28OUI%3BNON%29&askData=jeedomJPI&askTimeout=600&__JPIPLUG=1 - Résultat : OK - 06xxxxxxxx [] []
[2018-04-13 21:53:37] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVolume&__JPIPLUG=1 : 13 [] []
[2018-04-13 21:53:39] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getBattLevel&__JPIPLUG=1 : 86 [] []
[2018-04-13 21:53:42] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getSmsCounter&__JPIPLUG=1 : 12 [] []
[2018-04-13 21:53:44] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getWifiStrength&__JPIPLUG=1 : 96 [] []
[2018-04-13 21:53:46] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVersion&__JPIPLUG=1 : 0.9684 [] []

===================
log évènement APK niv. 3 sur test ask de jeedom

- 13/04/18 21:53:30 - HTTP_EVENT déclenché - http action: sendSms - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:30 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:34 - http_event - action: sendSms => 1
- 13/04/18 21:53:34 - http_event - action: httpReturn => 1
- 13/04/18 21:53:34 - HTTP_EVENT terminé
- 13/04/18 21:53:35 - HTTP_EVENT déclenché - http action: getVolume - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:35 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:35 - http_event - action: getVolume => 2
- 13/04/18 21:53:35 - http_event - action: httpReturn => 1
- 13/04/18 21:53:36 - HTTP_EVENT terminé
- 13/04/18 21:53:38 - HTTP_EVENT déclenché - http action: getBattLevel - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:38 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:38 - http_event - action: getBattLevel => 2
- 13/04/18 21:53:38 - http_event - action: httpReturn => 1
- 13/04/18 21:53:38 - HTTP_EVENT terminé
- 13/04/18 21:53:40 - HTTP_EVENT déclenché - http action: getSmsCounter - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:40 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:40 - http_event - action: getSmsCounter => 2
- 13/04/18 21:53:41 - http_event - action: httpReturn => 1
- 13/04/18 21:53:41 - HTTP_EVENT terminé
- 13/04/18 21:53:42 - HTTP_EVENT déclenché - http action: getWifiStrength - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:43 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:43 - http_event - action: getWifiStrength => 2
- 13/04/18 21:53:43 - http_event - action: httpReturn => 1
- 13/04/18 21:53:43 - HTTP_EVENT terminé
- 13/04/18 21:53:44 - HTTP_EVENT déclenché - http action: getVersion - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:44 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:45 - http_event - action: getVersion => 2
- 13/04/18 21:53:45 - http_event - action: httpReturn => 1
- 13/04/18 21:53:45 - HTTP_EVENT terminé
===================

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 14 avr. 2018, 08:51

Jeff92 a écrit :
13 avr. 2018, 22:39
Jerome84 a écrit :
13 avr. 2018, 18:48
Jeff92 a écrit :
13 avr. 2018, 16:14
Bonjour à tous

Je suis en train de mettre en place la fonction ask de JPI et j'ai qqs soucis.
- la question arrive bien sur mon tél
- je réponds
- le sms de réponse arrive bien sur JPI apk
Mais rien ne remonte dans jeedom. la variable contient le texte "aucune réponse " !
J'étais avec l'ancienne version du plugiin. J'ai donc fait la maj mais c'est pareil ; à une différence près c'est que les temps de réponse sont devenus considérables par moment et surtout lorsque l'on est dans les commandes du plugin avec la saisie manuelle des cdes ou avec l'assistant. L'assistant ne réagit jamais de la même façon ( lignes action, options ou pas de ligne action permettant la saisie...). Il doit y avoir un pb d'instabilité quelque part. Je n'avais pas ça avec l'ancienne version du plugin.

Au niveau JPI apk je suis à la dernière version ainsi que jeedom.
La fonction sms fonctionne très bien
j'ai suivi le tuto de guillaume Braillon qui est très clair pour la fonction ask.
il y a certainement un point qui m'échappe. La réponse venant de JPI apk doit se trouver dans quelle variable ?
jeedomJPI ou celle que l'on indique dans le scénario ?
Au niveau des logs aucune erreur.
La clé api jeedom est ok ( je commande la prise d'alimentation du tél et c'est ok )

Si quelqu'un a une idée
Merci d'avance


Je viens de refaire un test avec la dernière version stable du plugin et je ne vois aucun pb avec l'ask.
Peux-tu passer tes logs de l'apk au niveau 3 et poster le déroulement d'un test ASK (log événement de tete) ?

Ci-joint les logs d'un test cde ask du plugin jpi
===================
Log du scénario jeedom

[2018-04-13 21:53:29][SCENARIO] Start : 'Scenario lance manuellement'.
[2018-04-13 21:53:29][SCENARIO] Exécution du sous-élément de type [action] : action
[2018-04-13 21:53:30][SCENARIO] Demande Array
(
[title] => Femeture volets ?
[message] => Femeture volets ?
[answer] => Array
(
[0] => OUI
[1] => NON
)
[timeout] => 300
[variable] => Rep_ASK
)
[2018-04-13 21:58:52][SCENARIO] Réponse Aucune réponse => ( pour info j'ai répondu OUI avant le timeout et le sms est bien arrivé dans apk JPI)
[2018-04-13 21:58:52][SCENARIO] Fin correcte du scénario

===================
log de la cde ask du plugin JPI :

[2018-04-13 21:53:30] JPI.INFO: Execution de la commande : ask [] []
[2018-04-13 21:53:35] JPI.DEBUG: Requete lancée pour la commande ask : http://192.x.x.x:yy/?action=sendSms&number={MY_NUMBER}&message=Femeture+volets+%3F+%28OUI%3BNON%29&askData=jeedomJPI&askTimeout=600&__JPIPLUG=1 - Résultat : OK - 06xxxxxxxx [] []
[2018-04-13 21:53:37] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVolume&__JPIPLUG=1 : 13 [] []
[2018-04-13 21:53:39] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getBattLevel&__JPIPLUG=1 : 86 [] []
[2018-04-13 21:53:42] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getSmsCounter&__JPIPLUG=1 : 12 [] []
[2018-04-13 21:53:44] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getWifiStrength&__JPIPLUG=1 : 96 [] []
[2018-04-13 21:53:46] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVersion&__JPIPLUG=1 : 0.9684 [] []

===================
log évènement APK niv. 3 sur test ask de jeedom

- 13/04/18 21:53:30 - HTTP_EVENT déclenché - http action: sendSms - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:30 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:34 - http_event - action: sendSms => 1
- 13/04/18 21:53:34 - http_event - action: httpReturn => 1
- 13/04/18 21:53:34 - HTTP_EVENT terminé
- 13/04/18 21:53:35 - HTTP_EVENT déclenché - http action: getVolume - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:35 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:35 - http_event - action: getVolume => 2
- 13/04/18 21:53:35 - http_event - action: httpReturn => 1
- 13/04/18 21:53:36 - HTTP_EVENT terminé
- 13/04/18 21:53:38 - HTTP_EVENT déclenché - http action: getBattLevel - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:38 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:38 - http_event - action: getBattLevel => 2
- 13/04/18 21:53:38 - http_event - action: httpReturn => 1
- 13/04/18 21:53:38 - HTTP_EVENT terminé
- 13/04/18 21:53:40 - HTTP_EVENT déclenché - http action: getSmsCounter - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:40 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:40 - http_event - action: getSmsCounter => 2
- 13/04/18 21:53:41 - http_event - action: httpReturn => 1
- 13/04/18 21:53:41 - HTTP_EVENT terminé
- 13/04/18 21:53:42 - HTTP_EVENT déclenché - http action: getWifiStrength - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:43 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:43 - http_event - action: getWifiStrength => 2
- 13/04/18 21:53:43 - http_event - action: httpReturn => 1
- 13/04/18 21:53:43 - HTTP_EVENT terminé
- 13/04/18 21:53:44 - HTTP_EVENT déclenché - http action: getVersion - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:44 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:45 - http_event - action: getVersion => 2
- 13/04/18 21:53:45 - http_event - action: httpReturn => 1
- 13/04/18 21:53:45 - HTTP_EVENT terminé
===================
A mon avis, tu as un pb coté APK, je ne vois pas d'event sur réception du mail.
Tu devrais avoir un log de ce type

Code : Tout sélectionner

 - 12/04/18 20:23:15 - http_event - action: httpReturn => 1
 - 12/04/18 20:23:15 - HTTP_EVENT terminé
 - 12/04/18 20:23:19 - INCOMINGSMS_EVENT déclenché - Numéro: +336XXXXXXXXX
 - 12/04/18 20:23:19 - incomingsms_event - scenario: __ASK__
 - 12/04/18 20:23:19 - incomingsms_event - évaluer: SI ( "jeedomJPI" match /^Framework SC_[0-9a-f]{13}$/gi ) => FAUX
 - 12/04/18 20:23:19 - incomingsms_event - évaluer: SINON SI ( "jeedomJPI" == "jeedomJPI" ) => VRAI
 - 12/04/18 20:23:19 - incomingsms_event - FIN du bloc CONDITION
 - 12/04/18 20:23:19 - INCOMINGSMS_EVENT terminé
Peux-tu nous un imprime écran des scénario SMS de l'APK ?

Jeff92
Timide
Messages : 63
Inscription : 18 févr. 2017, 12:11

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jeff92 » 14 avr. 2018, 13:19

Jerome84 a écrit :
14 avr. 2018, 08:51
Jeff92 a écrit :
13 avr. 2018, 22:39
Jerome84 a écrit :
13 avr. 2018, 18:48




Je viens de refaire un test avec la dernière version stable du plugin et je ne vois aucun pb avec l'ask.
Peux-tu passer tes logs de l'apk au niveau 3 et poster le déroulement d'un test ASK (log événement de tete) ?

Ci-joint les logs d'un test cde ask du plugin jpi
===================
Log du scénario jeedom

[2018-04-13 21:53:29][SCENARIO] Start : 'Scenario lance manuellement'.
[2018-04-13 21:53:29][SCENARIO] Exécution du sous-élément de type [action] : action
[2018-04-13 21:53:30][SCENARIO] Demande Array
(
[title] => Femeture volets ?
[message] => Femeture volets ?
[answer] => Array
(
[0] => OUI
[1] => NON
)
[timeout] => 300
[variable] => Rep_ASK
)
[2018-04-13 21:58:52][SCENARIO] Réponse Aucune réponse => ( pour info j'ai répondu OUI avant le timeout et le sms est bien arrivé dans apk JPI)
[2018-04-13 21:58:52][SCENARIO] Fin correcte du scénario

===================
log de la cde ask du plugin JPI :

[2018-04-13 21:53:30] JPI.INFO: Execution de la commande : ask [] []
[2018-04-13 21:53:35] JPI.DEBUG: Requete lancée pour la commande ask : http://192.x.x.x:yy/?action=sendSms&number={MY_NUMBER}&message=Femeture+volets+%3F+%28OUI%3BNON%29&askData=jeedomJPI&askTimeout=600&__JPIPLUG=1 - Résultat : OK - 06xxxxxxxx [] []
[2018-04-13 21:53:37] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVolume&__JPIPLUG=1 : 13 [] []
[2018-04-13 21:53:39] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getBattLevel&__JPIPLUG=1 : 86 [] []
[2018-04-13 21:53:42] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getSmsCounter&__JPIPLUG=1 : 12 [] []
[2018-04-13 21:53:44] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getWifiStrength&__JPIPLUG=1 : 96 [] []
[2018-04-13 21:53:46] JPI.DEBUG: Valeur de la requête http://192.x.x.x:yy/?action=getVersion&__JPIPLUG=1 : 0.9684 [] []

===================
log évènement APK niv. 3 sur test ask de jeedom

- 13/04/18 21:53:30 - HTTP_EVENT déclenché - http action: sendSms - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:30 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:34 - http_event - action: sendSms => 1
- 13/04/18 21:53:34 - http_event - action: httpReturn => 1
- 13/04/18 21:53:34 - HTTP_EVENT terminé
- 13/04/18 21:53:35 - HTTP_EVENT déclenché - http action: getVolume - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:35 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:35 - http_event - action: getVolume => 2
- 13/04/18 21:53:35 - http_event - action: httpReturn => 1
- 13/04/18 21:53:36 - HTTP_EVENT terminé
- 13/04/18 21:53:38 - HTTP_EVENT déclenché - http action: getBattLevel - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:38 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:38 - http_event - action: getBattLevel => 2
- 13/04/18 21:53:38 - http_event - action: httpReturn => 1
- 13/04/18 21:53:38 - HTTP_EVENT terminé
- 13/04/18 21:53:40 - HTTP_EVENT déclenché - http action: getSmsCounter - CLIENT: 192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:40 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:40 - http_event - action: getSmsCounter => 2
- 13/04/18 21:53:41 - http_event - action: httpReturn => 1
- 13/04/18 21:53:41 - HTTP_EVENT terminé
- 13/04/18 21:53:42 - HTTP_EVENT déclenché - http action: getWifiStrength - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:43 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:43 - http_event - action: getWifiStrength => 2
- 13/04/18 21:53:43 - http_event - action: httpReturn => 1
- 13/04/18 21:53:43 - HTTP_EVENT terminé
- 13/04/18 21:53:44 - HTTP_EVENT déclenché - http action: getVersion - CLIENT:192.x.x.x (Plugin Jeedom JPI)
- 13/04/18 21:53:44 - http_event - scénario: __DEFAULT__
- 13/04/18 21:53:45 - http_event - action: getVersion => 2
- 13/04/18 21:53:45 - http_event - action: httpReturn => 1
- 13/04/18 21:53:45 - HTTP_EVENT terminé
===================
A mon avis, tu as un pb coté APK, je ne vois pas d'event sur réception du mail.
Tu devrais avoir un log de ce type

Code : Tout sélectionner

 - 12/04/18 20:23:15 - http_event - action: httpReturn => 1
 - 12/04/18 20:23:15 - HTTP_EVENT terminé
 - 12/04/18 20:23:19 - INCOMINGSMS_EVENT déclenché - Numéro: +336XXXXXXXXX
 - 12/04/18 20:23:19 - incomingsms_event - scenario: __ASK__
 - 12/04/18 20:23:19 - incomingsms_event - évaluer: SI ( "jeedomJPI" match /^Framework SC_[0-9a-f]{13}$/gi ) => FAUX
 - 12/04/18 20:23:19 - incomingsms_event - évaluer: SINON SI ( "jeedomJPI" == "jeedomJPI" ) => VRAI
 - 12/04/18 20:23:19 - incomingsms_event - FIN du bloc CONDITION
 - 12/04/18 20:23:19 - INCOMINGSMS_EVENT terminé
Peux-tu nous un imprime écran des scénario SMS de l'APK ?
Question bête : comment fait on pour insérer une copie écran dans une réponse sur le forum. J'ai essayé avec insérer une image mais rien !

sinon j'ai déclenché manuellement le scénario et j'ai le log suivant :

- 14/04/18 13:17:16 - INCOMINGSMS_EVENT (TEST) déclenché
- 14/04/18 13:17:16 - incomingsms_event (TEST) - __ASK__
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SI ( "jeedomJPI" match /^Framework SC_[0-9a-f]{13}$/gi ) => FAUX
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SINON SI ( "jeedomJPI" == "jeedomJPI" ) => VRAI
- 14/04/18 13:17:17 - incomingsms_event (TEST) - action: askJeedomPlug => -2
- 14/04/18 13:17:17 - incomingsms_event (TEST) - FIN du bloc CONDITION
- 14/04/18 13:17:17 - INCOMINGSMS_EVENT (TEST) terminé

donc à priori pb de déclenchement de scénario !!

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 14 avr. 2018, 14:41

Jeff92 a écrit :
14 avr. 2018, 13:19

Question bête : comment fait on pour insérer une copie écran dans une réponse sur le forum. J'ai essayé avec insérer une image mais rien !

sinon j'ai déclenché manuellement le scénario et j'ai le log suivant :

- 14/04/18 13:17:16 - INCOMINGSMS_EVENT (TEST) déclenché
- 14/04/18 13:17:16 - incomingsms_event (TEST) - __ASK__
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SI ( "jeedomJPI" match /^Framework SC_[0-9a-f]{13}$/gi ) => FAUX
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SINON SI ( "jeedomJPI" == "jeedomJPI" ) => VRAI
- 14/04/18 13:17:17 - incomingsms_event (TEST) - action: askJeedomPlug => -2
- 14/04/18 13:17:17 - incomingsms_event (TEST) - FIN du bloc CONDITION
- 14/04/18 13:17:17 - INCOMINGSMS_EVENT (TEST) terminé

donc à priori pb de déclenchement de scénario !!
Tu es sur quelle branche et quelle version du plugin ?
Si tu lances la requete suivante dans ton navigateur, tu obtiens quoi comme résultat ?
http://IPJEEDOM/plugins/JPI/core/php/jeeJPI.php?apikey=TONAPI&test=?

Jeff92
Timide
Messages : 63
Inscription : 18 févr. 2017, 12:11

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jeff92 » 14 avr. 2018, 15:43

Jerome84 a écrit :
14 avr. 2018, 14:41
Jeff92 a écrit :
14 avr. 2018, 13:19

Question bête : comment fait on pour insérer une copie écran dans une réponse sur le forum. J'ai essayé avec insérer une image mais rien !

sinon j'ai déclenché manuellement le scénario et j'ai le log suivant :

- 14/04/18 13:17:16 - INCOMINGSMS_EVENT (TEST) déclenché
- 14/04/18 13:17:16 - incomingsms_event (TEST) - __ASK__
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SI ( "jeedomJPI" match /^Framework SC_[0-9a-f]{13}$/gi ) => FAUX
- 14/04/18 13:17:16 - incomingsms_event (TEST) - évaluer: SINON SI ( "jeedomJPI" == "jeedomJPI" ) => VRAI
- 14/04/18 13:17:17 - incomingsms_event (TEST) - action: askJeedomPlug => -2
- 14/04/18 13:17:17 - incomingsms_event (TEST) - FIN du bloc CONDITION
- 14/04/18 13:17:17 - INCOMINGSMS_EVENT (TEST) terminé

donc à priori pb de déclenchement de scénario !!
Tu es sur quelle branche et quelle version du plugin ?
Si tu lances la requete suivante dans ton navigateur, tu obtiens quoi comme résultat ?
http://IPJEEDOM/plugins/JPI/core/php/jeeJPI.php?apikey=TONAPI&test=?
Version plugin JPI : V3.0 - Stable
Version Jeedom : V3.1.7
Version APK JPI : V0.9684
Marériel : Odroid C2

Réponse à la requête : OK

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 14 avr. 2018, 16:35

Si la réponse de la requête est OK, c'est que l'API fonctionne. Tu as la date et lheure du plugin ?

Jeff92
Timide
Messages : 63
Inscription : 18 févr. 2017, 12:11

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jeff92 » 14 avr. 2018, 17:06

Jerome84 a écrit :
14 avr. 2018, 16:35
Si la réponse de la requête est OK, c'est que l'API fonctionne. Tu as la date et lheure du plugin ?
voilà l'info : 2018-04-12 20:47:46

Avatar de l’utilisateur
Jerome84
Actif
Messages : 545
Inscription : 09 mai 2015, 18:46
Localisation : Le Thor

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par Jerome84 » 14 avr. 2018, 17:48

Oui tu as bien la derniere version.
Je ne comprend pas PK chez toi ça ne fonction ne pas. Faut que je regarde cela a tête reposée

antec
Timide
Messages : 15
Inscription : 08 déc. 2016, 11:28

Re: [Plugin Tiers][Sujet Principal] JPI Plugin

Message par antec » 17 avr. 2018, 13:12

bonjour, j'ai installé le plugin JPI du market mais dans la fenêtre assistant de commande jpi je n'ai qu'une case pour le nom et rien pour action et paramètres de même pour ajout de commande pas de liste déroulante pour les actions ? et il en crée 2 à la fois que l'on ne peut pas supprimé. Ai je loupé quelque chose merci de votre aide (jeedom sur rpi3b+)
Sur le mobile tout est ok et je me connecte sans pb

bien cordialement

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités