Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Officiel][Sujet Principal] Ikea Light

Pour échanger sur les plugins classés en catégorie "Objets connectés"
Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 10:39

Bon excuse moi, j'ai entre temps du redémarrer la box ikea qui avait planté, il s'avère que ça a résolu le problème pour le moment, les nouvelles commandes fonctionnent. Hier soir ça plantait malgré le fait que la box fonctionnait, va savoir pourquoi. Je reste en debug quand même, au cas ou.
C'est encore assez instable malheureusement, cette box ikea est pas top :/
Merci pour ton aide.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 10:42

Je pense que lors du passage au nouveau demon (qui stress moins la box) il faut la redemarrer histoire de repartir d'une base solide.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 10:50

Désolé de te redéranger loic, mais j'ai un nouveau problème, certaines ampoules ne sont plus reconnues par le plugin:


[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65552 [name] => Plafonnier Couloir 1 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65552
[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65553 [name] => Plafonnier Couloir 2 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65553

bluebird101eu3
Timide
Messages : 61
Inscription : 08 oct. 2015, 15:49

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par bluebird101eu3 » 11 oct. 2019, 11:02

loic a écrit :
11 oct. 2019, 08:56
@Harapeko : il faut passer sur les nouvelle commande, malheureusement la transition est pas simple faut bien voir qu'on a tout refait, on avait pas le choix malheureusement

@bluebird101eu3 : il me faudrait la log d'installation des dépendances
Bonjour,

Voila mon log d'instalation des dépendances, merci pour ton aide.



Get:45 http://httpredir.debian.org jessie/non-free armhf Packages [62.5 kB]
Get:46 http://httpredir.debian.org jessie/contrib Translation-en [38.3 kB]
Get:47 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Get:48 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:49 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:50 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Get:51 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]
Get:52 http://apt.armbian.com jessie/utils Translation-en [178 B]
Err http://httpredir.debian.org jessie-backports/main armhf Packages
Get:53 http://apt.armbian.com jessie/main armhf Packages [178 B]
Get:54 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:55 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:56 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop Translation-en
Get:57 http://apt.armbian.com jessie/main Translation-en [178 B]
Ign http://httpredir.debian.org jessie-backports/contrib Translation-en
Ign http://httpredir.debian.org jessie-backports/main Translation-en
Ign http://httpredir.debian.org jessie-backports/non-free Translation-en
Ign http://apt.armbian.com jessie/main Translation-en
Err http://httpredir.debian.org jessie-backports/main armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:58 http://apt.armbian.com jessie/utils Translation-en [178 B]
Ign http://apt.armbian.com jessie/utils Translation-en
Err http://httpredir.debian.org jessie-backports/contrib armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:59 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
HttpError404
Get:60 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
HttpError404
Err http://httpredir.debian.org jessie-backports/non-free armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:61 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
HttpError404
Fetched 1732 B in 14s (116 B/s)
W: Failed to fetch http://apt.armbian.com/dists/jessie/mai ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/uti ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/jes ... f/Packages HttpError404
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 281 not upgraded.
Version actuelle : 5
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
nodejs* rlwrap*
0 upgraded, 0 newly installed, 2 to remove and 281 not upgraded.
After this operation, 38.8 MB disk space will be freed.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 64659 files and directories currently installed.)
Removing nodejs (5.12.0-1nodesource1~jessie1) ...
Purging configuration files for nodejs (5.12.0-1nodesource1~jessie1) ...
Removing rlwrap (0.41-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
/var/www/html/plugins/ikealight/core/class/../../resources/install_apt.sh: line 30: $LOG: ambiguous redirect
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Ign http://httpredir.debian.org jessie InRelease
Ign http://http.us.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit https://deb.nodesource.com jessie InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://httpredir.debian.org jessie-backports InRelease
Hit http://http.us.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release.gpg
Ign http://httpredir.debian.org jessie-backports Release.gpg
Hit http://httpredir.debian.org jessie Release
Hit http://http.us.debian.org jessie Release
Get:1 https://deb.nodesource.com jessie/main Sources [764 B]
Get:2 http://httpredir.debian.org jessie-updates/main armhf Packages [20 B]
Get:3 http://httpredir.debian.org jessie-updates/contrib armhf Packages [20 B]
Get:4 https://deb.nodesource.com jessie/main armhf Packages [968 B]
Get:5 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:6 http://httpredir.debian.org jessie-updates/non-free armhf Packages [20 B]
Get:7 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:8 http://httpredir.debian.org jessie-updates/contrib Translation-en [14 B]
Get:9 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:10 http://httpredir.debian.org jessie-updates/main Translation-en [14 B]
Get:11 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:12 http://httpredir.debian.org jessie-updates/non-free Translation-en [14 B]
Get:13 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:14 http://apt.armbian.com jessie InRelease [178 B]
Ign http://apt.armbian.com jessie InRelease
Ign http://httpredir.debian.org jessie-backports Release
Ign http://httpredir.debian.org jessie-backports/main armhf Packages/DiffIndex
Ign http://httpredir.debian.org jessie-backports/contrib armhf Packages/DiffIndex
Get:15 http://security.debian.org jessie/updates/main armhf Packages [689 kB]
Ign http://httpredir.debian.org jessie-backports/non-free armhf Packages/DiffIndex
Get:16 http://security.debian.org jessie/updates/contrib armhf Packages [1138 B]
Get:17 http://security.debian.org jessie/updates/non-free armhf Packages [4243 B]
Get:18 http://apt.armbian.com jessie Release.gpg [178 B]
Ign http://apt.armbian.com jessie Release.gpg
Get:19 http://security.debian.org jessie/updates/contrib Translation-en [1211 B]
Get:20 http://apt.armbian.com jessie Release [178 B]
Hit http://http.us.debian.org jessie/non-free armhf Packages
Get:21 http://security.debian.org jessie/updates/main Translation-en [359 kB]
Ign http://apt.armbian.com jessie Release
Get:22 http://security.debian.org jessie/updates/non-free Translation-en [11.8 kB]
Hit http://http.us.debian.org jessie/non-free Translation-en
Get:23 http://apt.armbian.com jessie/main armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/main armhf Packages/DiffIndex
Get:24 http://apt.armbian.com jessie/utils armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/utils armhf Packages/DiffIndex
Get:25 http://apt.armbian.com jessie/jessie-desktop armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop armhf Packages/DiffIndex
Get:26 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:27 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:28 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:29 http://httpredir.debian.org jessie/contrib armhf Packages [37.8 kB]
Get:30 http://httpredir.debian.org jessie/non-free armhf Packages [62.5 kB]
Get:31 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:32 http://httpredir.debian.org jessie/contrib Translation-en [38.3 kB]
Get:33 http://apt.armbian.com jessie/main armhf Packages [178 B]
Get:34 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Err http://apt.armbian.com jessie/main armhf Packages
Get:35 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Get:36 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]
Err http://httpredir.debian.org jessie-backports/main armhf Packages
Err http://apt.armbian.com jessie/utils armhf Packages
Get:37 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Ign http://httpredir.debian.org jessie-backports/contrib Translation-en
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Ign http://httpredir.debian.org jessie-backports/main Translation-en
Ign http://httpredir.debian.org jessie-backports/non-free Translation-en
Err http://httpredir.debian.org jessie-backports/main armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Err http://httpredir.debian.org jessie-backports/contrib armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Err http://httpredir.debian.org jessie-backports/non-free armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:38 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:39 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:40 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:41 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:42 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:43 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Get:44 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:45 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:46 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:47 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:48 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:49 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:50 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:51 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:52 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:53 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:54 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:55 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:56 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop Translation-en
Get:57 http://apt.armbian.com jessie/main Translation-en [178 B]
Ign http://apt.armbian.com jessie/main Translation-en
Get:58 http://apt.armbian.com jessie/utils Translation-en [178 B]
Ign http://apt.armbian.com jessie/utils Translation-en
Get:59 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
HttpError404
Get:60 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
HttpError404
Get:61 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
HttpError404
Fetched 1732 B in 24s (69 B/s)
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://apt.armbian.com/dists/jessie/mai ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/uti ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/jes ... f/Packages HttpError404
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
rlwrap
The following NEW packages will be installed:
nodejs rlwrap
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 2 newly installed, 0 to remove and 281 not upgraded.
Need to get 0 B/8130 kB of archives.
After this operation, 38.8 MB of additional disk space will be used.
Selecting previously unselected package rlwrap.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 61213 files and directories currently installed.)
Preparing to unpack .../rlwrap_0.41-1_armhf.deb ...
Unpacking rlwrap (0.41-1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_5.12.0-1nodesource1~jessie1_armhf.deb ...
Unpacking nodejs (5.12.0-1nodesource1~jessie1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up rlwrap (0.41-1) ...
update-alternatives: using /usr/bin/rlwrap to provide /usr/bin/readline-editor (readline-editor) in auto mode
Setting up nodejs (5.12.0-1nodesource1~jessie1) ...
Version actuelle : v5.12.0
> node-aead-crypto@2.1.4 install /var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto
> node lib/install.js
running default installation script
> node-aead-crypto@2.1.4 install:default /var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto
> prebuild-install || node-gyp rebuild
/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/simple-get/index.js:18
const { hostname, port, protocol, auth, path } = url.parse(opts.url) // eslint-disable-line node/no-deprecated-api
^
SyntaxError: Unexpected token {
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/prebuild-install/download.js:3:11)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
make: Entering directory '/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto/build'
CXX(target) Release/obj.target/node-aead-crypto/src/node-aes-ccm.o
CXX(target) Release/obj.target/node-aead-crypto/src/node-aes-gcm.o
CXX(target) Release/obj.target/node-aead-crypto/src/addon.o
SOLINK_MODULE(target) Release/obj.target/node-aead-crypto.node
COPY Release/node-aead-crypto.node
make: Leaving directory '/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto/build'
/var/www/html/plugins/ikealight/resources/ikealightd
`-- node-tradfri-client@2.0.1
+-- alcalzone-shared@2.0.0
+-- debug@4.1.1
| `-- ms@2.1.2
+-- mdns-server@1.0.8
| `-- dns-packet@1.3.1
| +-- ip@1.1.5
| `-- safe-buffer@5.2.0
+-- node-coap-client@1.0.2
| +-- debug@3.2.6
| `-- node-dtls-client@0.5.6
| +-- debug@3.2.6
| +-- node-aead-crypto@2.1.4
| | +-- bindings@1.5.0
| | | `-- file-uri-to-path@1.0.0
| | +-- nan@2.11.1
| | `-- prebuild-install@5.3.2
| | +-- detect-libc@1.0.3
| | +-- expand-template@2.0.3
| | +-- github-from-package@0.0.0
| | +-- minimist@1.2.0
| | +-- mkdirp@0.5.1
| | | `-- minimist@0.0.8
| | +-- napi-build-utils@1.0.1
| | +-- node-abi@2.11.0
| | +-- noop-logger@0.1.1
| | +-- npmlog@4.1.2
| | | +-- are-we-there-yet@1.1.5
| | | | +-- delegates@1.0.0
| | | | `-- readable-stream@2.3.6
| | | | +-- core-util-is@1.0.2
| | | | +-- isarray@1.0.0
| | | | +-- process-nextick-args@2.0.1
| | | | +-- safe-buffer@5.1.2
| | | | +-- string_decoder@1.1.1
| | | | | `-- safe-buffer@5.1.2
| | | | `-- util-deprecate@1.0.2
| | | +-- console-control-strings@1.1.0
| | | +-- gauge@2.7.4
| | | | +-- aproba@1.2.0
| | | | +-- has-unicode@2.0.1
| | | | +-- object-assign@4.1.1
| | | | +-- signal-exit@3.0.2
| | | | +-- string-width@1.0.2
| | | | | +-- code-point-at@1.1.0
| | | | | `-- is-fullwidth-code-point@1.0.0
| | | | | `-- number-is-nan@1.0.1
| | | | +-- strip-ansi@3.0.1
| | | | | `-- ansi-regex@2.1.1
| | | | `-- wide-align@1.1.3
| | | `-- set-blocking@2.0.0
| | +-- pump@3.0.0
| | | +-- end-of-stream@1.4.4
| | | `-- once@1.4.0
| | | `-- wrappy@1.0.2
| | +-- rc@1.2.8
| | | +-- deep-extend@0.6.0
| | | +-- ini@1.3.5
| | | `-- strip-json-comments@2.0.1
| | +-- simple-get@3.1.0
| | | +-- decompress-response@4.2.1
| | | | `-- mimic-response@2.0.0
| | | `-- simple-concat@1.0.0
| | +-- tar-fs@2.0.0
| | | +-- chownr@1.1.3
| | | `-- tar-stream@2.1.0
| | | +-- bl@3.0.0
| | | | `-- readable-stream@3.4.0
| | | +-- fs-constants@1.0.0
| | | +-- inherits@2.0.4
| | | `-- readable-stream@3.4.0
| | +-- tunnel-agent@0.6.0
| | `-- which-pm-runs@1.0.0
| `-- semver@5.7.1
`-- reflect-metadata@0.1.13
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- fs@0.0.1-security
`-- node-tradfri-client@2.0.1
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- fs@0.0.1-security
+-- node-tradfri-client@2.0.1
`-- request@2.88.0
+-- aws-sign2@0.7.0
+-- aws4@1.8.0
+-- caseless@0.12.0
+-- combined-stream@1.0.8
| `-- delayed-stream@1.0.0
+-- extend@3.0.2
+-- forever-agent@0.6.1
+-- form-data@2.3.3
| `-- asynckit@0.4.0
+-- har-validator@5.1.3
| +-- ajv@6.10.2
| | +-- fast-deep-equal@2.0.1
| | +-- fast-json-stable-stringify@2.0.0
| | +-- json-schema-traverse@0.4.1
| | `-- uri-js@4.2.2
| | `-- punycode@2.1.1
| `-- har-schema@2.0.0
+-- http-signature@1.2.0
| +-- assert-plus@1.0.0
| +-- jsprim@1.4.1
| | +-- extsprintf@1.3.0
| | +-- json-schema@0.2.3
| | `-- verror@1.10.0
| `-- sshpk@1.16.1
| +-- asn1@0.2.4
| +-- bcrypt-pbkdf@1.0.2
| +-- dashdash@1.14.1
| +-- ecc-jsbn@0.1.2
| +-- getpass@0.1.7
| +-- jsbn@0.1.1
| +-- safer-buffer@2.1.2
| `-- tweetnacl@0.14.5
+-- is-typedarray@1.0.0
+-- isstream@0.1.2
+-- json-stringify-safe@5.0.1
+-- mime-types@2.1.24
| `-- mime-db@1.40.0
+-- oauth-sign@0.9.0
+-- performance-now@2.1.0
+-- qs@6.5.2
+-- tough-cookie@2.4.3
| +-- psl@1.4.0
| `-- punycode@1.4.1
`-- uuid@3.3.3
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- express@4.17.1
| +-- accepts@1.3.7
| | `-- negotiator@0.6.2
| +-- array-flatten@1.1.1
| +-- body-parser@1.19.0
| | +-- bytes@3.1.0
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | +-- http-errors@1.7.2
| | | +-- inherits@2.0.3
| | | `-- toidentifier@1.0.0
| | +-- iconv-lite@0.4.24
| | +-- qs@6.7.0
| | `-- raw-body@2.4.0
| +-- content-disposition@0.5.3
| | `-- safe-buffer@5.1.2
| +-- content-type@1.0.4
| +-- cookie@0.4.0
| +-- cookie-signature@1.0.6
| +-- debug@2.6.9
| | `-- ms@2.0.0
| +-- depd@1.1.2
| +-- encodeurl@1.0.2
| +-- escape-html@1.0.3
| +-- etag@1.8.1
| +-- finalhandler@1.1.2
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | `-- unpipe@1.0.0
| +-- fresh@0.5.2
| +-- merge-descriptors@1.0.1
| +-- methods@1.1.2
| +-- on-finished@2.3.0
| | `-- ee-first@1.1.1
| +-- parseurl@1.3.3
| +-- path-to-regexp@0.1.7
| +-- proxy-addr@2.0.5
| | +-- forwarded@0.1.2
| | `-- ipaddr.js@1.9.0
| +-- qs@6.7.0
| +-- range-parser@1.2.1
| +-- safe-buffer@5.1.2
| +-- send@0.17.1
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | +-- destroy@1.0.4
| | +-- mime@1.6.0
| | `-- ms@2.1.1
| +-- serve-static@1.14.1
| +-- setprototypeof@1.1.1
| +-- statuses@1.5.0
| +-- type-is@1.6.18
| | `-- media-typer@0.3.0
| +-- utils-merge@1.0.1
| `-- vary@1.1.2
+-- fs@0.0.1-security
+-- node-tradfri-client@2.0.1
`-- request@2.88.0
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
********************************************************
* Installation terminée *
********************************************************

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 11:04

Harapeko a écrit :
11 oct. 2019, 10:50
Désolé de te redéranger loic, mais j'ai un nouveau problème, certaines ampoules ne sont plus reconnues par le plugin:


[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65552 [name] => Plafonnier Couloir 1 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65552
[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65553 [name] => Plafonnier Couloir 2 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65553
J'ai poussé la correction en stable
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 11:06

bluebird101eu3 a écrit :
11 oct. 2019, 11:02
loic a écrit :
11 oct. 2019, 08:56
@Harapeko : il faut passer sur les nouvelle commande, malheureusement la transition est pas simple faut bien voir qu'on a tout refait, on avait pas le choix malheureusement

@bluebird101eu3 : il me faudrait la log d'installation des dépendances
Bonjour,

Voila mon log d'instalation des dépendances, merci pour ton aide.



Get:45 http://httpredir.debian.org jessie/non-free armhf Packages [62.5 kB]
Get:46 http://httpredir.debian.org jessie/contrib Translation-en [38.3 kB]
Get:47 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Get:48 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:49 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:50 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Get:51 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]
Get:52 http://apt.armbian.com jessie/utils Translation-en [178 B]
Err http://httpredir.debian.org jessie-backports/main armhf Packages
Get:53 http://apt.armbian.com jessie/main armhf Packages [178 B]
Get:54 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:55 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:56 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop Translation-en
Get:57 http://apt.armbian.com jessie/main Translation-en [178 B]
Ign http://httpredir.debian.org jessie-backports/contrib Translation-en
Ign http://httpredir.debian.org jessie-backports/main Translation-en
Ign http://httpredir.debian.org jessie-backports/non-free Translation-en
Ign http://apt.armbian.com jessie/main Translation-en
Err http://httpredir.debian.org jessie-backports/main armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:58 http://apt.armbian.com jessie/utils Translation-en [178 B]
Ign http://apt.armbian.com jessie/utils Translation-en
Err http://httpredir.debian.org jessie-backports/contrib armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:59 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
HttpError404
Get:60 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
HttpError404
Err http://httpredir.debian.org jessie-backports/non-free armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:61 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
HttpError404
Fetched 1732 B in 14s (116 B/s)
W: Failed to fetch http://apt.armbian.com/dists/jessie/mai ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/uti ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/jes ... f/Packages HttpError404
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 281 not upgraded.
Version actuelle : 5
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
nodejs* rlwrap*
0 upgraded, 0 newly installed, 2 to remove and 281 not upgraded.
After this operation, 38.8 MB disk space will be freed.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 64659 files and directories currently installed.)
Removing nodejs (5.12.0-1nodesource1~jessie1) ...
Purging configuration files for nodejs (5.12.0-1nodesource1~jessie1) ...
Removing rlwrap (0.41-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
/var/www/html/plugins/ikealight/core/class/../../resources/install_apt.sh: line 30: $LOG: ambiguous redirect
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Ign http://httpredir.debian.org jessie InRelease
Ign http://http.us.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit https://deb.nodesource.com jessie InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://httpredir.debian.org jessie-backports InRelease
Hit http://http.us.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release.gpg
Ign http://httpredir.debian.org jessie-backports Release.gpg
Hit http://httpredir.debian.org jessie Release
Hit http://http.us.debian.org jessie Release
Get:1 https://deb.nodesource.com jessie/main Sources [764 B]
Get:2 http://httpredir.debian.org jessie-updates/main armhf Packages [20 B]
Get:3 http://httpredir.debian.org jessie-updates/contrib armhf Packages [20 B]
Get:4 https://deb.nodesource.com jessie/main armhf Packages [968 B]
Get:5 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:6 http://httpredir.debian.org jessie-updates/non-free armhf Packages [20 B]
Get:7 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:8 http://httpredir.debian.org jessie-updates/contrib Translation-en [14 B]
Get:9 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:10 http://httpredir.debian.org jessie-updates/main Translation-en [14 B]
Get:11 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:12 http://httpredir.debian.org jessie-updates/non-free Translation-en [14 B]
Get:13 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:14 http://apt.armbian.com jessie InRelease [178 B]
Ign http://apt.armbian.com jessie InRelease
Ign http://httpredir.debian.org jessie-backports Release
Ign http://httpredir.debian.org jessie-backports/main armhf Packages/DiffIndex
Ign http://httpredir.debian.org jessie-backports/contrib armhf Packages/DiffIndex
Get:15 http://security.debian.org jessie/updates/main armhf Packages [689 kB]
Ign http://httpredir.debian.org jessie-backports/non-free armhf Packages/DiffIndex
Get:16 http://security.debian.org jessie/updates/contrib armhf Packages [1138 B]
Get:17 http://security.debian.org jessie/updates/non-free armhf Packages [4243 B]
Get:18 http://apt.armbian.com jessie Release.gpg [178 B]
Ign http://apt.armbian.com jessie Release.gpg
Get:19 http://security.debian.org jessie/updates/contrib Translation-en [1211 B]
Get:20 http://apt.armbian.com jessie Release [178 B]
Hit http://http.us.debian.org jessie/non-free armhf Packages
Get:21 http://security.debian.org jessie/updates/main Translation-en [359 kB]
Ign http://apt.armbian.com jessie Release
Get:22 http://security.debian.org jessie/updates/non-free Translation-en [11.8 kB]
Hit http://http.us.debian.org jessie/non-free Translation-en
Get:23 http://apt.armbian.com jessie/main armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/main armhf Packages/DiffIndex
Get:24 http://apt.armbian.com jessie/utils armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/utils armhf Packages/DiffIndex
Get:25 http://apt.armbian.com jessie/jessie-desktop armhf Packages/DiffIndex [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop armhf Packages/DiffIndex
Get:26 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:27 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:28 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:29 http://httpredir.debian.org jessie/contrib armhf Packages [37.8 kB]
Get:30 http://httpredir.debian.org jessie/non-free armhf Packages [62.5 kB]
Get:31 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:32 http://httpredir.debian.org jessie/contrib Translation-en [38.3 kB]
Get:33 http://apt.armbian.com jessie/main armhf Packages [178 B]
Get:34 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Err http://apt.armbian.com jessie/main armhf Packages
Get:35 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Get:36 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]
Err http://httpredir.debian.org jessie-backports/main armhf Packages
Err http://apt.armbian.com jessie/utils armhf Packages
Get:37 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Ign http://httpredir.debian.org jessie-backports/contrib Translation-en
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Ign http://httpredir.debian.org jessie-backports/main Translation-en
Ign http://httpredir.debian.org jessie-backports/non-free Translation-en
Err http://httpredir.debian.org jessie-backports/main armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Err http://httpredir.debian.org jessie-backports/contrib armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Err http://httpredir.debian.org jessie-backports/non-free armhf Packages
404 Not Found [IP: 2a04:4e42:1d::204 80]
Get:38 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:39 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:40 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:41 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:42 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:43 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Get:44 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:45 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:46 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:47 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:48 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:49 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:50 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Get:51 http://apt.armbian.com jessie/main Translation-en [178 B]
Get:52 http://apt.armbian.com jessie/utils Translation-en [178 B]
Get:53 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
Get:54 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
Get:55 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
Get:56 http://apt.armbian.com jessie/jessie-desktop Translation-en [178 B]
Ign http://apt.armbian.com jessie/jessie-desktop Translation-en
Get:57 http://apt.armbian.com jessie/main Translation-en [178 B]
Ign http://apt.armbian.com jessie/main Translation-en
Get:58 http://apt.armbian.com jessie/utils Translation-en [178 B]
Ign http://apt.armbian.com jessie/utils Translation-en
Get:59 http://apt.armbian.com jessie/main armhf Packages [178 B]
Err http://apt.armbian.com jessie/main armhf Packages
HttpError404
Get:60 http://apt.armbian.com jessie/utils armhf Packages [178 B]
Err http://apt.armbian.com jessie/utils armhf Packages
HttpError404
Get:61 http://apt.armbian.com jessie/jessie-desktop armhf Packages [178 B]
Err http://apt.armbian.com jessie/jessie-desktop armhf Packages
HttpError404
Fetched 1732 B in 24s (69 B/s)
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://httpredir.debian.org/debian/dist ... f/Packages 404 Not Found [IP: 2a04:4e42:1d::204 80]
W: Failed to fetch http://apt.armbian.com/dists/jessie/mai ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/uti ... f/Packages HttpError404
W: Failed to fetch http://apt.armbian.com/dists/jessie/jes ... f/Packages HttpError404
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
rlwrap
The following NEW packages will be installed:
nodejs rlwrap
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 2 newly installed, 0 to remove and 281 not upgraded.
Need to get 0 B/8130 kB of archives.
After this operation, 38.8 MB of additional disk space will be used.
Selecting previously unselected package rlwrap.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 61213 files and directories currently installed.)
Preparing to unpack .../rlwrap_0.41-1_armhf.deb ...
Unpacking rlwrap (0.41-1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_5.12.0-1nodesource1~jessie1_armhf.deb ...
Unpacking nodejs (5.12.0-1nodesource1~jessie1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up rlwrap (0.41-1) ...
update-alternatives: using /usr/bin/rlwrap to provide /usr/bin/readline-editor (readline-editor) in auto mode
Setting up nodejs (5.12.0-1nodesource1~jessie1) ...
Version actuelle : v5.12.0
> node-aead-crypto@2.1.4 install /var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto
> node lib/install.js
running default installation script
> node-aead-crypto@2.1.4 install:default /var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto
> prebuild-install || node-gyp rebuild
/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/simple-get/index.js:18
const { hostname, port, protocol, auth, path } = url.parse(opts.url) // eslint-disable-line node/no-deprecated-api
^
SyntaxError: Unexpected token {
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/prebuild-install/download.js:3:11)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
make: Entering directory '/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto/build'
CXX(target) Release/obj.target/node-aead-crypto/src/node-aes-ccm.o
CXX(target) Release/obj.target/node-aead-crypto/src/node-aes-gcm.o
CXX(target) Release/obj.target/node-aead-crypto/src/addon.o
SOLINK_MODULE(target) Release/obj.target/node-aead-crypto.node
COPY Release/node-aead-crypto.node
make: Leaving directory '/var/www/html/plugins/ikealight/resources/ikealightd/node_modules/node-aead-crypto/build'
/var/www/html/plugins/ikealight/resources/ikealightd
`-- node-tradfri-client@2.0.1
+-- alcalzone-shared@2.0.0
+-- debug@4.1.1
| `-- ms@2.1.2
+-- mdns-server@1.0.8
| `-- dns-packet@1.3.1
| +-- ip@1.1.5
| `-- safe-buffer@5.2.0
+-- node-coap-client@1.0.2
| +-- debug@3.2.6
| `-- node-dtls-client@0.5.6
| +-- debug@3.2.6
| +-- node-aead-crypto@2.1.4
| | +-- bindings@1.5.0
| | | `-- file-uri-to-path@1.0.0
| | +-- nan@2.11.1
| | `-- prebuild-install@5.3.2
| | +-- detect-libc@1.0.3
| | +-- expand-template@2.0.3
| | +-- github-from-package@0.0.0
| | +-- minimist@1.2.0
| | +-- mkdirp@0.5.1
| | | `-- minimist@0.0.8
| | +-- napi-build-utils@1.0.1
| | +-- node-abi@2.11.0
| | +-- noop-logger@0.1.1
| | +-- npmlog@4.1.2
| | | +-- are-we-there-yet@1.1.5
| | | | +-- delegates@1.0.0
| | | | `-- readable-stream@2.3.6
| | | | +-- core-util-is@1.0.2
| | | | +-- isarray@1.0.0
| | | | +-- process-nextick-args@2.0.1
| | | | +-- safe-buffer@5.1.2
| | | | +-- string_decoder@1.1.1
| | | | | `-- safe-buffer@5.1.2
| | | | `-- util-deprecate@1.0.2
| | | +-- console-control-strings@1.1.0
| | | +-- gauge@2.7.4
| | | | +-- aproba@1.2.0
| | | | +-- has-unicode@2.0.1
| | | | +-- object-assign@4.1.1
| | | | +-- signal-exit@3.0.2
| | | | +-- string-width@1.0.2
| | | | | +-- code-point-at@1.1.0
| | | | | `-- is-fullwidth-code-point@1.0.0
| | | | | `-- number-is-nan@1.0.1
| | | | +-- strip-ansi@3.0.1
| | | | | `-- ansi-regex@2.1.1
| | | | `-- wide-align@1.1.3
| | | `-- set-blocking@2.0.0
| | +-- pump@3.0.0
| | | +-- end-of-stream@1.4.4
| | | `-- once@1.4.0
| | | `-- wrappy@1.0.2
| | +-- rc@1.2.8
| | | +-- deep-extend@0.6.0
| | | +-- ini@1.3.5
| | | `-- strip-json-comments@2.0.1
| | +-- simple-get@3.1.0
| | | +-- decompress-response@4.2.1
| | | | `-- mimic-response@2.0.0
| | | `-- simple-concat@1.0.0
| | +-- tar-fs@2.0.0
| | | +-- chownr@1.1.3
| | | `-- tar-stream@2.1.0
| | | +-- bl@3.0.0
| | | | `-- readable-stream@3.4.0
| | | +-- fs-constants@1.0.0
| | | +-- inherits@2.0.4
| | | `-- readable-stream@3.4.0
| | +-- tunnel-agent@0.6.0
| | `-- which-pm-runs@1.0.0
| `-- semver@5.7.1
`-- reflect-metadata@0.1.13
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- fs@0.0.1-security
`-- node-tradfri-client@2.0.1
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- fs@0.0.1-security
+-- node-tradfri-client@2.0.1
`-- request@2.88.0
+-- aws-sign2@0.7.0
+-- aws4@1.8.0
+-- caseless@0.12.0
+-- combined-stream@1.0.8
| `-- delayed-stream@1.0.0
+-- extend@3.0.2
+-- forever-agent@0.6.1
+-- form-data@2.3.3
| `-- asynckit@0.4.0
+-- har-validator@5.1.3
| +-- ajv@6.10.2
| | +-- fast-deep-equal@2.0.1
| | +-- fast-json-stable-stringify@2.0.0
| | +-- json-schema-traverse@0.4.1
| | `-- uri-js@4.2.2
| | `-- punycode@2.1.1
| `-- har-schema@2.0.0
+-- http-signature@1.2.0
| +-- assert-plus@1.0.0
| +-- jsprim@1.4.1
| | +-- extsprintf@1.3.0
| | +-- json-schema@0.2.3
| | `-- verror@1.10.0
| `-- sshpk@1.16.1
| +-- asn1@0.2.4
| +-- bcrypt-pbkdf@1.0.2
| +-- dashdash@1.14.1
| +-- ecc-jsbn@0.1.2
| +-- getpass@0.1.7
| +-- jsbn@0.1.1
| +-- safer-buffer@2.1.2
| `-- tweetnacl@0.14.5
+-- is-typedarray@1.0.0
+-- isstream@0.1.2
+-- json-stringify-safe@5.0.1
+-- mime-types@2.1.24
| `-- mime-db@1.40.0
+-- oauth-sign@0.9.0
+-- performance-now@2.1.0
+-- qs@6.5.2
+-- tough-cookie@2.4.3
| +-- psl@1.4.0
| `-- punycode@1.4.1
`-- uuid@3.3.3
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
/var/www/html/plugins/ikealight/resources/ikealightd
+-- express@4.17.1
| +-- accepts@1.3.7
| | `-- negotiator@0.6.2
| +-- array-flatten@1.1.1
| +-- body-parser@1.19.0
| | +-- bytes@3.1.0
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | +-- http-errors@1.7.2
| | | +-- inherits@2.0.3
| | | `-- toidentifier@1.0.0
| | +-- iconv-lite@0.4.24
| | +-- qs@6.7.0
| | `-- raw-body@2.4.0
| +-- content-disposition@0.5.3
| | `-- safe-buffer@5.1.2
| +-- content-type@1.0.4
| +-- cookie@0.4.0
| +-- cookie-signature@1.0.6
| +-- debug@2.6.9
| | `-- ms@2.0.0
| +-- depd@1.1.2
| +-- encodeurl@1.0.2
| +-- escape-html@1.0.3
| +-- etag@1.8.1
| +-- finalhandler@1.1.2
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | `-- unpipe@1.0.0
| +-- fresh@0.5.2
| +-- merge-descriptors@1.0.1
| +-- methods@1.1.2
| +-- on-finished@2.3.0
| | `-- ee-first@1.1.1
| +-- parseurl@1.3.3
| +-- path-to-regexp@0.1.7
| +-- proxy-addr@2.0.5
| | +-- forwarded@0.1.2
| | `-- ipaddr.js@1.9.0
| +-- qs@6.7.0
| +-- range-parser@1.2.1
| +-- safe-buffer@5.1.2
| +-- send@0.17.1
| | +-- debug@2.6.9
| | | `-- ms@2.0.0
| | +-- destroy@1.0.4
| | +-- mime@1.6.0
| | `-- ms@2.1.1
| +-- serve-static@1.14.1
| +-- setprototypeof@1.1.1
| +-- statuses@1.5.0
| +-- type-is@1.6.18
| | `-- media-typer@0.3.0
| +-- utils-merge@1.0.1
| `-- vary@1.1.2
+-- fs@0.0.1-security
+-- node-tradfri-client@2.0.1
`-- request@2.88.0
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/ikealight/resources/ikealightd/package.json'
npm WARN ikealightd No description
npm WARN ikealightd No repository field.
npm WARN ikealightd No README data
npm WARN ikealightd No license field.
********************************************************
* Installation terminée *
********************************************************
Tu es en jessie c'est ca le soucis il faut monter la version du systeme en stretch, si tu es sur une smart il suffit de bien recuperer un backup de jeedom et dans la roue cranté en haut a droite de faire restoration d'image et de suivre les instructions
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

bluebird101eu3
Timide
Messages : 61
Inscription : 08 oct. 2015, 15:49

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par bluebird101eu3 » 11 oct. 2019, 11:19

Merci pour les infos, je suis sous un Orange Pi sous Armbian Jessie, cela risque d'être un peut plus compliqué ?

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 11:39

A oui la je peux pas aider désolé, tout soucis vient du faite que debian a supprimé les sources jessie arm et n'a laissé que les stretch donc faut absolument monter en stretch par contre sous orange pi la je sais pas.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 12:18

loic a écrit :
11 oct. 2019, 11:04
Harapeko a écrit :
11 oct. 2019, 10:50
Désolé de te redéranger loic, mais j'ai un nouveau problème, certaines ampoules ne sont plus reconnues par le plugin:


[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65552 [name] => Plafonnier Couloir 1 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65552
[2019-10-11 10:46:32][DEBUG] : Impossible d'ajouter l'équipement : tradfri_bulb_e27_ws_opal_1000lm => Array ( [id] => 65553 [name] => Plafonnier Couloir 2 [firmwareVersion] => 2.0.022 [model] => TRADFRI bulb E27 WS opal 1000lm [alive] => 1 [type] => light [color] => f5faf6 [onOff] => [dimmer] => 100 [colorTemperature] => 0 )
[2019-10-11 10:46:32][DEBUG] : Merci de mettre le plugin en DEBUG est transmettre les infos demandées dans la doc pour avoir une intégration
[2019-10-11 10:46:32][DEBUG] : Aucun équipement trouvé pour : 65553
J'ai poussé la correction en stable
Hello Loic,

J'ai installé la dernière stable (2019-10-11 11:03:56) mais j'ai toujours le même soucis :s

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 12:24

Tu peux refaire la mise à jour et la decouverte en relancant le démon ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

bluebird101eu3
Timide
Messages : 61
Inscription : 08 oct. 2015, 15:49

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par bluebird101eu3 » 11 oct. 2019, 13:07

loic a écrit :
11 oct. 2019, 11:39
A oui la je peux pas aider désolé, tout soucis vient du faite que debian a supprimé les sources jessie arm et n'a laissé que les stretch donc faut absolument monter en stretch par contre sous orange pi la je sais pas.
Merci en tout cas, je sais ce qu'il me reste a faire.
Dernière édition par bluebird101eu3 le 11 oct. 2019, 14:40, édité 1 fois.

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 13:17

loic a écrit :
11 oct. 2019, 12:24
Tu peux refaire la mise à jour et la decouverte en relancant le démon ?
C'est fait, toujours la même erreur :/ je précise que j'arrive bien à piloter les ampoules en question sur l'appli tradfri

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 13:28

Ouvre un ticket alors la, c'est un truc tout con mais vu que j'ai pas le matériel j'arrive pas a corriger.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 14:38

loic a écrit :
11 oct. 2019, 13:28
Ouvre un ticket alors la, c'est un truc tout con mais vu que j'ai pas le matériel j'arrive pas a corriger.
Question bête, c'est de quel support dont tu parles?
Sinon tu n'as pas un repo pour le plugin que je puisse aussi regarder? Je maîtrise pas trop mal nodejs, je fais surtout du react en front end ces temps ci, mais j'ai pas mal utilisé nodejs il y a quelques temps pour faire des webservices, je devrais pouvoir peut être me debuguer comme un grand :)

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 14:47

Le repo est privé car le plugin est payant. Le support c'est le support de jeedom (soit l'icone ! soit dans le menu demande de support).

La le soucis c'est pas nodejs c'est au niveau de la recherche du template dans php
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 15:15

loic a écrit :
11 oct. 2019, 14:47
Le repo est privé car le plugin est payant. Le support c'est le support de jeedom (soit l'icone ! soit dans le menu demande de support).

La le soucis c'est pas nodejs c'est au niveau de la recherche du template dans php
J'ai ouvert un ticket :) Merci pour ton aide.

Harapeko
Timide
Messages : 26
Inscription : 22 août 2019, 17:30

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Harapeko » 11 oct. 2019, 15:45

Harapeko a écrit :
11 oct. 2019, 15:15
loic a écrit :
11 oct. 2019, 14:47
Le repo est privé car le plugin est payant. Le support c'est le support de jeedom (soit l'icone ! soit dans le menu demande de support).

La le soucis c'est pas nodejs c'est au niveau de la recherche du template dans php
J'ai ouvert un ticket :) Merci pour ton aide.
C'est bon merci pour la correction! Par contre j'ai un soucis avec les virtuels: avec l'ancienne version du plugin, j'importais les commande d'une ampoule puis je rajoutais d'autres ampoules pour en commander plusieurs en même temps. Maintenant, quand je le fais, je n'ai pas de retour d’état sur le widget (la petite ampoule reste éteinte), et quand je reclique dessus, ça n'envoie pas la commande d'eteignage (je suppose car il doit envoyer celle pour allumer). Y a-t-il un workaround, ou alors il faut continuer d'utiliser les virtuel à la façon des anciens widget, cad avec un bouton on et un bouton off?

Edit: C'est bon je n'avais pas alimenté le champs d’état avec le retour d’état, maintenant ça fonctionne bien.

Tof_24
Timide
Messages : 13
Inscription : 09 oct. 2017, 13:48

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Tof_24 » 11 oct. 2019, 17:54

Bonjour,
J'ai fait la mise à jour proposé mais depuis le démon n'arrive pas à se lancer,
Je suis en version béta du plug-in

Ci joint le log :
[2019-10-11 17:48:01][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
module.js:549
throw err;
^
Error: Cannot find module 'request'
at Function.Module._resolveFilename (module.js:547:15)
at Function.Module._load (module.js:474:25)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/var/www/html/plugins/ikealight/resources/ikealightd/jeedom/jeedom.js:17:17)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
[2019-10-11 17:48:32][ERROR] : Impossible de lancer le démon ikealightd, vérifiez le log
[2019-10-11 17:50:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
module.js:549
throw err;
^
Error: Cannot find module 'request'
at Function.Module._resolveFilename (module.js:547:15)
at Function.Module._load (module.js:474:25)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/var/www/html/plugins/ikealight/resources/ikealightd/jeedom/jeedom.js:17:17)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
[2019-10-11 17:50:34][ERROR] : Impossible de lancer le démon ikealightd, vérifiez le log
Merci de votre aide

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par loic » 11 oct. 2019, 17:56

As tu bien relancé l'installé les dépendances ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Tof_24
Timide
Messages : 13
Inscription : 09 oct. 2017, 13:48

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Tof_24 » 11 oct. 2019, 18:30

Oui mais je viens de voir, je sais pas si je suis en jessie ou strech
********************************************************
* Installation des dépendances *
********************************************************
Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Ign:3 https://dev2day.de/pms jessie InRelease
Err:4 https://dev2day.de/pms jessie Release
404 Not Found
Reading package lists...
E: The repository 'https://dev2day.de/pms jessie Release' does no longer have a Release file.
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
0 upgraded, 0 newly installed, 0 to remove and 371 not upgraded.
Version actuelle : 8
Ok, version suffisante
sudo: npm: command not found
sudo: npm: command not found
sudo: npm: command not found
sudo: npm: command not found
********************************************************
* Installation terminée *
********************************************************

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités