Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

[Plugin Officiel][Sujet Principal] Ikea Light

Pour échanger sur les plugins classés en catégorie "Objets connectés"
Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 27 mai 2019, 20:50

Erutnova a écrit :
Nebz a écrit :
27 mai 2019, 20:42
Erutnova a écrit :(
sudo devant


Envoyé de mon iPhone en utilisant Tapatalk
Ça marche toujours pas...
Par contre je vois Python 2.7

faut passer à 3.5 / 3.6 si je comprends bien ?
Si oui, une petite explication pour procéder?
Un risque important pour ma config ?
Aucune idée à ce niveau sorry... tu es en Stretch ?


Envoyé de mon iPhone en utilisant Tapatalk
[/quote]

Aucune idée :(
Trop compliqué pour moi.
On va attendre la version stable du coup. Merci quand même Nebz ;)[/quote]
Tu as quoi comme système ?


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Erutnova
Timide
Messages : 35
Inscription : 21 mai 2015, 15:25

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Erutnova » 27 mai 2019, 20:53

jeedom mini+
Droits sudo OK
Version Jeedom 3.3.24
Version PHP 5.6.33-0+deb8u1
Version OS Linux jeedom 3.14.53-fslc-imx6-sr #1 SMP Thu Oct 15 20:42:12 UTC 2015 armv7l GNU/Linux [8.3]
Version database 5.5.47-0+deb8u1
Jeedom Mini+ / Z-wave / Rfxcom / Service Pack Power
Moteurs RTS / Dimmer FIBARO / Prise Z-wave EVERSPRING / Prise Di-O
Karotz / Freebox Revolution (serveur/player) / Nvidia Shield / GoogleHome / Ikea Trafri

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 27 mai 2019, 20:59

Erutnova a écrit :jeedom mini+
Droits sudo OK
Version Jeedom 3.3.24
Version PHP 5.6.33-0+deb8u1
Version OS Linux jeedom 3.14.53-fslc-imx6-sr #1 SMP Thu Oct 15 20:42:12 UTC 2015 armv7l GNU/Linux [8.3]
Version database 5.5.47-0+deb8u1
Ok tu es donc en jessie...




Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Erutnova
Timide
Messages : 35
Inscription : 21 mai 2015, 15:25

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Erutnova » 27 mai 2019, 21:01

Nebz a écrit :
27 mai 2019, 20:59
Erutnova a écrit :jeedom mini+
Droits sudo OK
Version Jeedom 3.3.24
Version PHP 5.6.33-0+deb8u1
Version OS Linux jeedom 3.14.53-fslc-imx6-sr #1 SMP Thu Oct 15 20:42:12 UTC 2015 armv7l GNU/Linux [8.3]
Version database 5.5.47-0+deb8u1
Ok tu es donc en jessie...




Envoyé de mon iPhone en utilisant Tapatalk
Du coup ? Jdois modifier quelque chose pour que ça fonctionne ? 🙄
Jeedom Mini+ / Z-wave / Rfxcom / Service Pack Power
Moteurs RTS / Dimmer FIBARO / Prise Z-wave EVERSPRING / Prise Di-O
Karotz / Freebox Revolution (serveur/player) / Nvidia Shield / GoogleHome / Ikea Trafri

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 27 mai 2019, 21:04

Erutnova a écrit :
Nebz a écrit :
27 mai 2019, 20:59
Erutnova a écrit :jeedom mini+
Droits sudo OK
Version Jeedom 3.3.24
Version PHP 5.6.33-0+deb8u1
Version OS Linux jeedom 3.14.53-fslc-imx6-sr #1 SMP Thu Oct 15 20:42:12 UTC 2015 armv7l GNU/Linux [8.3]
Version database 5.5.47-0+deb8u1
Ok tu es donc en jessie...




Envoyé de mon iPhone en utilisant Tapatalk
Du coup ? Jdois modifier quelque chose pour que ça fonctionne ?
Je pense qu'il faut migrer en Stretch... mais je ne sais pas ce qu'il faut faire que un vieux modèle comme celui la désolé...


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

EIen
Timide
Messages : 18
Inscription : 10 mai 2019, 17:00

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par EIen » 28 mai 2019, 13:41

Bon bah moi j'ai mis à jour ce matin mon plugin et depuis plus rien ...

Installation à 8h03
Dernière communication à 2019-05-28 08:03:23

Plugin en beta. J'avais des soucis avec pip3. J'ai relancé l'installation de python3-pip + dépendances de Ikealight et je me retrouve dans les logs avec des erreurs du type :

Code : Tout sélectionner

[2019-05-28 13:35:11][ERROR] : Exception on socket : Error executing request: Command '['coap-client', '-u', '7ef8310edc5f427bb5167e06ebf141f4', '-k', 'jMuisghdN3hO5vrn', '-v', '0', '-m', 'get', 'coaps://192.168.1.16:5684/15001/65596']' returned non-zero exit status -15
coap-client: aucun processus trouvé
Les logs de l'installation des dépendances :

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Installation des dépendances apt
Reading package lists...
Building dependency tree...
Reading state information...
python3-setuptools is already the newest version (33.1.1-1).
python3-pip is already the newest version (9.0.1-2+rpt2).
The following packages were automatically installed and are no longer required:
  docutils-common mypy pylint3 python3-astroid python3-asttokens
  python3-docutils python3-isort python3-jedi python3-lazy-object-proxy
  python3-pygments python3-pyperclip python3-roman python3-thonny-pi
  python3-typed-ast python3-wrapt xclip xsel
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python3/dist-packages
Requirement already satisfied: pyudev in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pyudev)
rm: cannot remove 'libcoap': No such file or directory
Cloning into 'libcoap'...
Submodule 'ext/tinydtls' (https://git.eclipse.org/r/tinydtls/org.eclipse.tinydtls) registered for path 'ext/tinydtls'
Cloning into '/var/www/html/plugins/ikealight/resources/ikealightd/libcoap/ext/tinydtls'...
Submodule path 'ext/tinydtls': checked out 'cc5863fa0e438ba1fa46c05f2a27cd8dd3d85b96'

[HINT] You can run 'autogen.sh --clean' to remove all generated files by the autotools.

Found 'autoconf'.
Found 'aclocal'.

Couldn't find 'libtool'!
Found 'libtoolize'.

  --->  Found all needed tools! That's fine.

Generating needed autotools files for libcoap by running autoreconf ...
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force ${ACLOCAL_FLAGS} -I m4
autoreconf: configure.ac: tracing
autoreconf: configure.ac: adding subdirectory ext/tinydtls to autoreconf
autoreconf: Entering directory `ext/tinydtls'
autoreconf: running: aclocal --force 
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: configure.ac: not using Automake
autoreconf: Leaving directory `ext/tinydtls'
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in '../..'.
libtoolize: copying file '../../ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
autoreconf: running: automake --add-missing --copy --force-missing
configure.ac:29: installing './ar-lib'
configure.ac:25: installing './compile'
configure.ac:33: installing './config.guess'
configure.ac:33: installing './config.sub'
configure.ac:18: installing './install-sh'
configure.ac:33: error: required file './ltmain.sh' not found
configure.ac:18: installing './missing'
Makefile.am: installing './INSTALL'
Makefile.am: installing './depcomp'
autoreconf: automake failed with exit status: 1
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... 
yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ar... ar
checking the archiver (ar) interface... ar
checking build system type... armv7l-unknown-linux-gnueabihf
checking host system type... armv7l-unknown-linux-gnueabihf
checking how to print strings... 
printf
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert armv7l-unknown-linux-gnueabihf file names to armv7l-unknown-linux-gnueabihf format... func_convert_file_noop
checking how to convert armv7l-unknown-linux-gnueabihf file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s

checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... 
yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... 
yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking whether C compiler accepts -Wlogical-op... yes
checking whether C compiler accepts -fdiagnostics-color... yes
checking whether the linker accepts -Wl,--version-script=./libcoap-1.map... 
yes
checking for ctags... no
configure: ==> Note: 'ctags' command not found!
configure: WARNING: ==> Without ctags you will be unable to run the target 'update-map-file'!
configure: WARNING: ==> This is no problem if you just want to build the library libcoap.
configure: ==> Note: your ctags does not support '--c-kinds'!
configure: ==> Most likely, you are using the GNU Emacs ctag and not exuberant ctag
configure: WARNING: ==> This option is required for target 'update-map-file'
configure: WARNING: ==> which is not a problem if you just want to build the library libcoap.
checking assert.h usability... yes
checking assert.h presence... yes
checking for assert.h... yes
checking arpa/inet.h usability... yes
checking arpa/inet.h presence... yes
checking for arpa/inet.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking netdb.h usability... yes
checking netdb.h presence... yes
checking for netdb.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking for unistd.h... (cached) yes
checking sys/unistd.h usability... yes
checking sys/unistd.h presence... yes
checking for sys/unistd.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking for size_t... yes
checking for ssize_t... 
yes
checking for memset... yes
checking for select... yes
checking for socket... 
yes
checking for strcasecmp... yes
checking for strrchr... yes
checking for getaddrinfo... yes
checking for strnlen... yes
checking for malloc... yes
checking for library containing socket... none required
checking for library containing inet_ntop... none required
checking for library containing clock_gettime... none required
checking operating system... Linux
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: error: cannot find input file: `Makefile.in'
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
********************************************************
*             Installation terminée                    *
********************************************************

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 28 mai 2019, 15:22

Aucun problème pour moi avec cette nouvelle version... la mise à jour s'est passée parfaitement et tout fonctionne. et ce sur 2 systèmes (une jeedom beta et un jeedom stable, tous les deux avec le plugin beta)
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

EIen
Timide
Messages : 18
Inscription : 10 mai 2019, 17:00

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par EIen » 28 mai 2019, 15:40

Au final un petit reboot du HUB Ikea a permis de retrouver les connexions. Etrange mais bon ça marche now

TiTiLeGrand
Timide
Messages : 10
Inscription : 13 janv. 2018, 19:38

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par TiTiLeGrand » 28 mai 2019, 19:20

Nebz a écrit :
27 mai 2019, 12:09

Heu, où as-tu vu que la stable contenait la mise à jour nécessaire, d'après ton Log ce n'est pas le cas ? Continue à utiliser la bêta.


Envoyé de mon iPhone en utilisant Tapatalk
Le change log le dis ;)

TiTiLeGrand
Timide
Messages : 10
Inscription : 13 janv. 2018, 19:38

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par TiTiLeGrand » 28 mai 2019, 19:40

EIen a écrit :
28 mai 2019, 15:40
Au final un petit reboot du HUB Ikea a permis de retrouver les connexions. Etrange mais bon ça marche now
Tu n'a fait que couper le courant et remis ? Je te demande car j'ai exactement le meme log des deP.

VincentW
Timide
Messages : 15
Inscription : 12 oct. 2017, 16:52

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par VincentW » 29 mai 2019, 00:27

Nebz a écrit :
27 mai 2019, 21:04
Erutnova a écrit :
Nebz a écrit :
27 mai 2019, 20:59

Ok tu es donc en jessie...




Envoyé de mon iPhone en utilisant Tapatalk
Du coup ? Jdois modifier quelque chose pour que ça fonctionne ?
Je pense qu'il faut migrer en Stretch... mais je ne sais pas ce qu'il faut faire que un vieux modèle comme celui la désolé...


Envoyé de mon iPhone en utilisant Tapatalk
Bonsoir,

Des nouvelles de mon côté : j'étais également bloqué sur le même message d'erreur au lancement du plugin à propos du module "typing" manquant dans les librairies pythons.

J'ai donc lancé de plus grandes manœuvres pour résoudre le problème en suivant vos conseils :
En premier : sudo pip install typing mais le problème est resté identique.
puis sudo pip3 install typing a résolu le problème.

Le plugin refonctionne de nouveau !

Pour rappel, j'ai une jeedom smart pour ma part et je doute un peu que cette manip soit très conventionnelle pour les plus néophytes et d'autant plus pour une box normalement tout intégré?. Ne faudrait -il pas intégrer cela de façon à éviter cette manip ? La gestion des dépendances n'est-elle pas faite pour cela ?

Bref merci en tout cas pour tout ce travail !

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 29 mai 2019, 06:32

VincentW a écrit :
Nebz a écrit :
27 mai 2019, 21:04
Erutnova a écrit : Du coup ? Jdois modifier quelque chose pour que ça fonctionne ?
Je pense qu'il faut migrer en Stretch... mais je ne sais pas ce qu'il faut faire que un vieux modèle comme celui la désolé...


Envoyé de mon iPhone en utilisant Tapatalk
Bonsoir,

Des nouvelles de mon côté : j'étais également bloqué sur le même message d'erreur au lancement du plugin à propos du module "typing" manquant dans les librairies pythons.

J'ai donc lancé de plus grandes manœuvres pour résoudre le problème en suivant vos conseils :
En premier : sudo pip install typing mais le problème est resté identique.
puis sudo pip3 install typing a résolu le problème.

Le plugin refonctionne de nouveau !

Pour rappel, j'ai une jeedom smart pour ma part et je doute un peu que cette manip soit très conventionnelle pour les plus néophytes et d'autant plus pour une box normalement tout intégré?. Ne faudrait -il pas intégrer cela de façon à éviter cette manip ? La gestion des dépendances n'est-elle pas faite pour cela ?

Bref merci en tout cas pour tout ce travail !
Sisi... j'en ai fait part au dev il y a plusieurs semaines... mais il est très occupé pour l'instant...


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

EIen
Timide
Messages : 18
Inscription : 10 mai 2019, 17:00

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par EIen » 29 mai 2019, 14:00

TiTiLeGrand a écrit :
28 mai 2019, 19:40
EIen a écrit :
28 mai 2019, 15:40
Au final un petit reboot du HUB Ikea a permis de retrouver les connexions. Etrange mais bon ça marche now
Tu n'a fait que couper le courant et remis ? Je te demande car j'ai exactement le meme log des deP.
Alors en fait j'ai un peu galérer car je n'étais pas chez moi. Du coup j'ai lancé plusieurs fois l'installation des dépendances et toujours des erreurs.

J'ai ensuite fait un remove / install de python3-pip et redémarrage du Jeedom. Toujours des erreurs.

Je suis rentré chez moi et j'ai juste débrancher électriquement la GW IKEA et rebranchée celle-ci.

Honnêtement je ne peux pas te dire ce qui a résolu le problème. Vérifie bien la version de ta gateway. Redémarre la ainsi que le Jeedom.
Si tu es sur un Raspberry PI le remove puis install de pip3 n'a pas causé d'effet de bord.

Sartog
Timide
Messages : 494
Inscription : 27 août 2015, 14:54

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Sartog » 29 mai 2019, 15:05

Bonjour,

Je viens d'affiner mon problème de perte de contrôle et d'état de mes lumières sur Jeedom.
Cela a recommencé hier soir. En regardant de plus prêt, la passerelle est également inaccessible depuis le téléphone ... par contre Alexa arrive à piloter sans problème mes lumières.

Le seul moyen pour que tout re-fonctionne parfaitement est un reboot de la GW IKEA ... tous les jours !

Est-ce que le plugin "noyerait" la passerelle ... étrange vu que ça ne le fasse pas chez tout le monde !?!

A ce jour, je suis contraint de désactiver ce plugin et dire au revoir aux scénarios qui gérer la lumière, le temps de trouver le problème et la solution.
Box : smart, mini+, pi 2 et 3, ipbx800 v4
Protocole : Z-Wave (Fibaro & Qubino), Ikea, Bluetooth
Méteo : Netatmo
Audio : Sonos (Play 1 et 5)

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 29 mai 2019, 15:08

Sartog a écrit :Bonjour,

Je viens d'affiner mon problème de perte de contrôle et d'état de mes lumières sur Jeedom.
Cela a recommencé hier soir. En regardant de plus prêt, la passerelle est également inaccessible depuis le téléphone ... par contre Alexa arrive à piloter sans problème mes lumières.

Le seul moyen pour que tout re-fonctionne parfaitement est un reboot de la GW IKEA ... tous les jours !

Est-ce que le plugin "noyerait" la passerelle ... étrange vu que ça ne le fasse pas chez tout le monde !?!

A ce jour, je suis contraint de désactiver ce plugin et dire au revoir aux scénarios qui gérer la lumière, le temps de trouver le problème et la solution.
Oui ça m'est arrivé 3x... j'ai expliqué le phénomène plus haut


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

TiTiLeGrand
Timide
Messages : 10
Inscription : 13 janv. 2018, 19:38

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par TiTiLeGrand » 29 mai 2019, 15:25

EIen a écrit :
29 mai 2019, 14:00
TiTiLeGrand a écrit :
28 mai 2019, 19:40
EIen a écrit :
28 mai 2019, 15:40
Au final un petit reboot du HUB Ikea a permis de retrouver les connexions. Etrange mais bon ça marche now
Tu n'a fait que couper le courant et remis ? Je te demande car j'ai exactement le meme log des deP.
Alors en fait j'ai un peu galérer car je n'étais pas chez moi. Du coup j'ai lancé plusieurs fois l'installation des dépendances et toujours des erreurs.

J'ai ensuite fait un remove / install de python3-pip et redémarrage du Jeedom. Toujours des erreurs.

Je suis rentré chez moi et j'ai juste débrancher électriquement la GW IKEA et rebranchée celle-ci.

Honnêtement je ne peux pas te dire ce qui a résolu le problème. Vérifie bien la version de ta gateway. Redémarre la ainsi que le Jeedom.
Si tu es sur un Raspberry PI le remove puis install de pip3 n'a pas causé d'effet de bord.
Bon bah a force d'installation des dep, il est de nouveau OK(meme avec les erreurs dans les logs sur le cofig.status) bref ca refonctionne.

EIen
Timide
Messages : 18
Inscription : 10 mai 2019, 17:00

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par EIen » 29 mai 2019, 17:27

TiTiLeGrand a écrit :
29 mai 2019, 15:25
EIen a écrit :
29 mai 2019, 14:00
TiTiLeGrand a écrit :
28 mai 2019, 19:40


Tu n'a fait que couper le courant et remis ? Je te demande car j'ai exactement le meme log des deP.
Alors en fait j'ai un peu galérer car je n'étais pas chez moi. Du coup j'ai lancé plusieurs fois l'installation des dépendances et toujours des erreurs.

J'ai ensuite fait un remove / install de python3-pip et redémarrage du Jeedom. Toujours des erreurs.

Je suis rentré chez moi et j'ai juste débrancher électriquement la GW IKEA et rebranchée celle-ci.

Honnêtement je ne peux pas te dire ce qui a résolu le problème. Vérifie bien la version de ta gateway. Redémarre la ainsi que le Jeedom.
Si tu es sur un Raspberry PI le remove puis install de pip3 n'a pas causé d'effet de bord.
Bon bah a force d'installation des dep, il est de nouveau OK(meme avec les erreurs dans les logs sur le cofig.status) bref ca refonctionne.
Étrange n'est ce pas? In fine tant que ça remarche... :)

ovardon
Timide
Messages : 21
Inscription : 11 nov. 2014, 12:25

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par ovardon » 31 mai 2019, 10:39

Sartog a écrit :
29 mai 2019, 15:05
Bonjour,

Je viens d'affiner mon problème de perte de contrôle et d'état de mes lumières sur Jeedom.
Cela a recommencé hier soir. En regardant de plus prêt, la passerelle est également inaccessible depuis le téléphone ... par contre Alexa arrive à piloter sans problème mes lumières.

Le seul moyen pour que tout re-fonctionne parfaitement est un reboot de la GW IKEA ... tous les jours !

Est-ce que le plugin "noyerait" la passerelle ... étrange vu que ça ne le fasse pas chez tout le monde !?!

A ce jour, je suis contraint de désactiver ce plugin et dire au revoir aux scénarios qui gérer la lumière, le temps de trouver le problème et la solution.
J'ai aussi ce problème, perso j'y suis allé en mode barbare il me restait une prise commandé , je l'ai mise sur la GW et je la reboot toutes les nuits !
Pas propre mais la passerelle tient la journée....

J'ai vu une mise a jour de la béta du plugin ... je sais pas si je dois la passer .... arf dilemme

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 5974
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

[Plugin Officiel][Sujet Principal] Ikea Light

Message par Nebz » 31 mai 2019, 11:23

ovardon a écrit :
Sartog a écrit :
29 mai 2019, 15:05
Bonjour,

Je viens d'affiner mon problème de perte de contrôle et d'état de mes lumières sur Jeedom.
Cela a recommencé hier soir. En regardant de plus prêt, la passerelle est également inaccessible depuis le téléphone ... par contre Alexa arrive à piloter sans problème mes lumières.

Le seul moyen pour que tout re-fonctionne parfaitement est un reboot de la GW IKEA ... tous les jours !

Est-ce que le plugin "noyerait" la passerelle ... étrange vu que ça ne le fasse pas chez tout le monde !?!

A ce jour, je suis contraint de désactiver ce plugin et dire au revoir aux scénarios qui gérer la lumière, le temps de trouver le problème et la solution.
J'ai aussi ce problème, perso j'y suis allé en mode barbare il me restait une prise commandé , je l'ai mise sur la GW et je la reboot toutes les nuits !
Pas propre mais la passerelle tient la journée....

J'ai vu une mise a jour de la béta du plugin ... je sais pas si je dois la passer .... arf dilemme
Oui le dev a poussé la bêta en stable.

La bêta va (ou est) bientôt être mise à jour pour la v4 aussi

Je lui ai parlé du typing a ajouter dans les dépendances et il va voir pour le faire.


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

iklo
Timide
Messages : 4
Inscription : 31 mai 2019, 13:25

Re: [Plugin Officiel][Sujet Principal] Ikea Light

Message par iklo » 31 mai 2019, 13:35

Bonjour à tous,

J'utilise Jeedom depuis ... 7 jours, il est installé sur mon pi3B+ acheté pour l'occasion.
J'ai lu et relu ce post et donc installé la beta du plugins, cependant impossible de me connecter la gateway ikea ..

J'ai vérifié l'ip de la GW
J'ai vérifié et revérifier la security code

Mais j'obtiens toujours un "JSON file not found" et un "Key Error"

Que dois je faire de plus pour du debug ou de l'utilisation ?

J'ai oublié les séances de désintall/install du plugins, reboot de la GW

Voici les logs

Code : Tout sélectionner

[2019-05-31 13:30:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-05-31 13:30:05][INFO] : Lancement démon ikealight : sudo /usr/bin/python3 /var/www/html/plugins/ikealight/resources/ikealightd/ikealightd.py --loglevel debug --socketport 55025 --callback http://127.0.0.1:80/plugins/ikealight/core/php/jeeIkealight.php --apikey impkrGeg6B08vrLVgUR0fA3pFvMYPcTI --cycle 0.1 --pid /tmp/jeedom/ikealight/deamon.pid --gatewayip 192.168.15.86 --gatewaycode 2yPDNDmJpTR2dunz
[2019-05-31 13:30:08][INFO] : Start ikeatradfrid
[2019-05-31 13:30:08][INFO] : Log level : debug
[2019-05-31 13:30:08][INFO] : Socket port : 55025
[2019-05-31 13:30:08][INFO] : Socket host : 127.0.0.1
[2019-05-31 13:30:08][INFO] : PID file : /tmp/jeedom/ikealight/deamon.pid
[2019-05-31 13:30:08][INFO] : Apikey : impkrGeg6B08vrLVgUR0fA3pFvMYPcTI
[2019-05-31 13:30:08][INFO] : Callback : http://127.0.0.1:80/plugins/ikealight/core/php/jeeIkealight.php
[2019-05-31 13:30:08][INFO] : Cycle : 0.1
[2019-05-31 13:30:08][INFO] : Gateway Ip : 192.168.15.86
[2019-05-31 13:30:08][INFO] : Gateway Code : 2yPDNDmJpTR2dunz
[2019-05-31 13:30:08][DEBUG] : JSON file not found: tradfri_jeedom_psk.conf
[2019-05-31 13:30:08][DEBUG] : Executing 192.168.15.86 post ['15011', '9063']: {'9090': '37133e33d83248458883408bea98fe2e'}
Traceback (most recent call last):
File "/var/www/html/plugins/ikealight/resources/ikealightd/ikealightd.py", line 283, in <module>
identity = conf[args.gatewayip].get('identity')
KeyError: '192.168.15.86'
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File "/var/www/html/plugins/ikealight/resources/ikealightd/ikealightd.py", line 290, in <module>
psk = api_factory.generate_psk(args.gatewaycode)
File "/var/www/html/plugins/ikealight/resources/ikealightd/pytradfri/api/libcoap_api.py", line 164, in generate_psk
self._psk = self.request(Gateway().generate_psk(existing_psk_id))
File "/var/www/html/plugins/ikealight/resources/ikealightd/pytradfri/api/libcoap_api.py", line 96, in request
return self._execute(api_commands, timeout=timeout)
File "/var/www/html/plugins/ikealight/resources/ikealightd/pytradfri/api/libcoap_api.py", line 83, in _execute
return_value = subprocess.check_output(command, **kwargs)
File "/usr/lib/python3.5/subprocess.py", line 316, in check_output
**kwargs).stdout
File "/usr/lib/python3.5/subprocess.py", line 383, in run
with Popen(*popenargs, **kwargs) as process:
File "/usr/lib/python3.5/subprocess.py", line 676, in __init__
restore_signals, start_new_session)
File "/usr/lib/python3.5/subprocess.py", line 1282, in _execute_child
raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: 'coap-client'
[2019-05-31 13:30:35][ERROR] : Impossible de lancer le démon ikealightd, vérifiez le log

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : foxclan et 2 invités