Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

worxLandroidS

Pour échanger sur les plugins classés en catégorie "Objets connectés"
prophet_master
Timide
Messages : 61
Inscription : 05 août 2015, 22:38

Re: worxLandroidS

Message par prophet_master » 01 juin 2018, 12:31

pour moi sur android ça marche mais pas le plugin même en faisant la manipe de ré initialisé les données clou, j'ai vu que ton plugin ce fais passer pour un android ;-)

prophet_master
Timide
Messages : 61
Inscription : 05 août 2015, 22:38

Re: worxLandroidS

Message par prophet_master » 01 juin 2018, 12:50

jvais essayer de le désactiver un jour pour voir si c'est les requêtes max qui embête...

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 01 juin 2018, 13:39

Si ça marche sur android c'est qu'il y a autre chose.
Mais tu me confirmes que l'équipement a été créé, autrement dit que ça fonctionnait.
Est-ce que tu as moyen de voir si tu n'as pas déjà client mosquitto qui tourne?

En te connectant par SSH : sudo lsof -i :8883

(Pour voir s'il y a qqchose sur le port 8883 et qui n'est pas fermé correctement)
Si c'est le cas tu peux éventuellement tenter un kill -9 avec le numéro de la tâche. (avec sudo si besoin)

J'essaye de comprendre...

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 01 juin 2018, 15:06

une réinitialisation du code wifi sur la tondeuse fait que ça fonctionne de nouveau chez moi.

appli android - bouton + sur le premier écran
appuyer 3 secondes sur le bouton ok de la tondeuse
et mettre le code wifi sur l'appli android

Mais comme tu n'as pas exactement le même problème je ne sais pas si ça va résoudre le tien.
Je ferai des tests ce week end quand j'ai un moment.

prophet_master
Timide
Messages : 61
Inscription : 05 août 2015, 22:38

Re: worxLandroidS

Message par prophet_master » 01 juin 2018, 20:28

alors je précise que c'est chez mon papa, donc j'essayerai de voir dès que je peux...

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 02 juin 2018, 15:24

Bonjour,
J'ai du réinitialiser le code WiFi aussi.
Ça fonctionne de nouveau
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

prophet_master
Timide
Messages : 61
Inscription : 05 août 2015, 22:38

Re: worxLandroidS

Message par prophet_master » 04 juin 2018, 20:08

alors, j'ai pu tester c'étais bien un problème de nombre de requête sur le serveur.

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 04 juin 2018, 20:51

Merci pour ton retour.
Mais juste pour être sûr que je comprends bien: tu veux dire qu'au bout d'un nombre important de requêtes il déconnecte?
Pour moi le fonctionnement n'est pas très clair ( ce n'est pas documenté bien entendu..)

J'ai remarqué que si j'installe le plugin sur 2 jeedoms et qu'en plus j'ai un smartphone en parallèle j'ai une déconnexion du plugin avec un code 7 au bout de 30 secondes.
Ensuite la déconnexion revient tout le temps même si je n'ai plus qu'1 jeedom...
Et j'ai l'impression que réinitialiser les données de connexion permet de remédier à ce problème.

J'ai fait quelques modifications aujourd'hui:
on ne redémarre pas la connexion tout de suite mais uniquement au bout de 2 minutes en cas de soucis de connexion et j'ai aussi mis une taille par défaut sur le widget.

Je vais surveiller de mon côté mais si je vois qu'on a une déconnexion systématique au bout de 30 secondes en permanence je reverrai la solution avec une connexion / souscription / publication / déconnexion toutes les x minutes ou une reconnexion en cas de demande (si action sur le widget ou par scénario) .
On n'aura plus de temps de réel pour les infos...

En tout cas si vous avez des remarques ou si vous voyez des erreurs n'hésitez pas à m'en faire part.

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 05 juin 2018, 20:19

Bonsoir,
Hier j'étais déconnecté!
J'ai touché a rien et le plugin s'est reconnecté tout seul au démarrage de la tonte du jour!
Par contre avec les applis pas moyen : off line
J'attend encore quelques jours pour voir l'évolution
A+
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 05 juin 2018, 20:41

Bonsoir,

Merci pour le retour.
En théorie on se connecte au serveur cloud, on souscrit à un topic et en temps réel on a les différents messages/mises à jour qui arrivent.
Ça marche très bien pendant un temps mais au bout d'un certain temps je suis déconnecté. Le plugin se reconnecte automatiquement toutes les 2 minutes mais le serveur mosquitto me déconnecte assez rapidement.

D'après moi les appli smartphone ne font pas de notifications
en push pour la même raison. ( Worx ne veut pas laisser les connexions ouvertes en permanence)

Je vais donc travailler sur une mise à jour pour faire une réactualisation toutes les 2 minutes pendant la période de tonte et toutes les heures en dehors.
Je pense que ça sera suffisant.

+ une réactualisation manuelle sur demande ou en cas de mise à jour des horaires par exemple.

UnMaster
Timide
Messages : 182
Inscription : 17 juil. 2014, 21:12
Localisation : Anjou

Re: worxLandroidS

Message par UnMaster » 07 juin 2018, 00:36

Salut a tous, et tout d'abord, merci a toi ssc de ton développement.
J'avais mis en place précédemment le contournement que tu avais proposé.
Je viens donc d'installer ton plugin afin de le tester.
Pas de soucis a l'installation et pas de soucis a priori pour les dépendances.
Par contre, le démon ne démarre pas.
J'ai ce message dans les logs:
[2018-06-07 00:33:32][ERROR] : Erreur sur worxLandroidS::daemon() : Invalid function arguments provided.
Il est possible que j'ai des restes de l'installation précédente.
HP Microserver G7 WHS2011 - VM Jeedom 3.1.6 - ZWave 20 nodes - RFXcom + 11 sondes - Bluetooth - IPX800 +X880 -Téléinfo - Xiaomi Home - 20 nodes
Multimédia - 2 Kodi + 3 Squeezebox + Orvibo AllOne + Broadlink RM3 Mini - MP1

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 07 juin 2018, 07:58

Salut,
Tu peux essayer de cocher initialiser les données ?

mystoupistou
Timide
Messages : 2
Inscription : 07 juin 2018, 11:12

Re: worxLandroidS

Message par mystoupistou » 07 juin 2018, 11:15

Bonjour,

Tout d'abord, merci pour ce pluging qui est très bien réalisé.
Par contre, je ne peux pas modifier la couleur de fond du widget sur le dashbord, ni sur le design.
Pourrait tu m'indiquer dans quelle partie je peux modifier la couleur et mettre le fond en "transparent"

Merci par avance

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 07 juin 2018, 13:55

Ce n'était pas possible, c'est désormais le cas :-)

mystoupistou
Timide
Messages : 2
Inscription : 07 juin 2018, 11:12

Re: worxLandroidS

Message par mystoupistou » 07 juin 2018, 14:02

Quelle rapidité !!!
Merci beaucoup !!

UnMaster
Timide
Messages : 182
Inscription : 17 juil. 2014, 21:12
Localisation : Anjou

Re: worxLandroidS

Message par UnMaster » 07 juin 2018, 22:03

Et hop, initialisation des données et tout est OK.
Bravo ssc, super plugin.
HP Microserver G7 WHS2011 - VM Jeedom 3.1.6 - ZWave 20 nodes - RFXcom + 11 sondes - Bluetooth - IPX800 +X880 -Téléinfo - Xiaomi Home - 20 nodes
Multimédia - 2 Kodi + 3 Squeezebox + Orvibo AllOne + Broadlink RM3 Mini - MP1

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 08 juin 2018, 11:01

Bonjour,
J'ai un soucis avec les cycles de charges!!!
Ils augmentent très rapidement en ce moment, sans rapport avec la réalité des charges.
Possesseurs de Landroid vérifiez voir.
@SSC le plugin ne lis que la machine? Il ne peut pas influencer ce chiffre?
Merci d'avance
Bonne journée
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 08 juin 2018, 16:18

Bonjour,.

Le nombre de cycles semble énorme chez moi également mais je pense que c'est la réalité et je ne fais que récupérer ce qu'envoie le cloud.

D'après moi, Il ne s'agit pas de cycles complets de charge.
Je me suis rendu compte que pendant les périodes de veille elle lance plusieurs cycles de charge et même assez souvent pour toujours maintenir un minimum de charge. (même en "veille" la batterie se vide "beaucoup" - je ne parle pas de veille totale pour hivernage)

Pour ma part j'en suis à 2243 et je possède la machine depuis environ 1 an. Et sur cette année elle n'a pas tourné pendant environ 5-6 mois et elle ne tourne pas tous les jours et pas toute la journée...
Estimation à la louche : 20 jours par mois * 6 mois * 4 cycles de tonte/jour ça fait environ 500 cycles de charge théorique.
On est loin des 2243.

Bref faut-il vraiment s'en préoccuper?

La seule chose intéressante serait de comparer l'évolution pour un cycle de tonte, la diminution du niveau de batterie.
Avec toutes les possibilités qu'offre jeedom ça me semble jouable.

Il faudrait historiser ces valeurs: (et sûrement passer les valeurs en numérique - je verrai pour une prochaine mise à jour)
batteryCharging / batteryChargeCycle / totalTime / statusCode

Donc si ça tente qq1 de faire des stats :)

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 08 juin 2018, 23:02

Bonsoir SSC effectivement je pense aussi qu'il y a des cycles de charges pendant l'attente, la nuit, etc.
Mais avant le plugin ce n'étais pas évident a voir ;-)
La mienne est a 2044 cycles et elle se porte très bien.
La gestion de la (petite) batterie semble très bien faite.
Par contre si quelqu’un pouvais nous faire un scipt pour sortir des logs les stats de charges de la batterie je prend.
Il y a un lien vers un Allemand mais ça ne marche pas chez moi. (http://landroid.lg71.de/)
Bonne soirée
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

ssc
Timide
Messages : 337
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 09 juin 2018, 17:01

Bonjour,
Le lien sert à quoi?

Sinon j'ai poussé une grosse mise à jour aujourd'hui et j'ai aussi mis à jour la doc .
Gestion du "délai pluie" et affichage de la prochaine zone et vous choisir (en partie) ce que vous voulez afficher ou non.
J'ai aussi mis les zones en numérique pour pouvoir faire des stats mais si vous voulez être sûr d'avoir toutes les infos modifiées il faudrait supprimer l'équipement actuel.
Sinon vous pouvez toujours changer les types d'infos en numérique manuellement.

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 10 invités