Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

worxLandroidS

Pour échanger sur les plugins classés en catégorie "Objets connectés"
cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 09 juin 2018, 22:34

Bonsoir,

Récemment acquéreur d'une Worx Landroid WR106SI (techniquement lors de la validation du numéro de série j'ai du sélectionner WR106SI.1)

Pas de problème pour l'installation dans le jardin, ni même la configuration en Wifi ou l'application mobile. tout est nominal.
Screenshot_20180609-222944.jpg
Screenshot_20180609-222944.jpg (38.28 Kio) Consulté 388 fois
J'ai l'impression d'avoir bien configuré le plugin (avec le mdp reçu et saisi dans l'appli)
Capture d’écran 2018-06-09 à 22.27.58.png
Capture d’écran 2018-06-09 à 22.27.58.png (53.27 Kio) Consulté 388 fois
Par contre aucune tondeuse n'apparait sur mon dashboard.
Capture d’écran 2018-06-09 à 22.27.35.png
Capture d’écran 2018-06-09 à 22.27.35.png (133.27 Kio) Consulté 388 fois
Je veux bien un peu d'aide, et participer au débuggage si débuggage il est besoin :-)

Avatar de l’utilisateur
zep57
Timide
Messages : 276
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 09 juin 2018, 23:21

bonsoir,
dans la configuration du plugin essaie : Initialiser/réactualiser données cloud worx : cocher et enregistrer
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 09 juin 2018, 23:28

Oui c'est bien ça il faut cocher initialiser les données. Il me semble que dans la dernière version je la coche automatiquement à l'installation.
Sinon Les dépendances sont ok et le démon démarre ?
Si vraiment ça ne fonctionne pas tu peux m'envoyer la log "débug" en message privé du tu veux.
Et une réactualisation de la fenêtre au final.

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 08:44

Yes j'ai déjà essayé de cocher la case plusieurs fois mais ça ne change rien.

J'ai l'impression que tout démarre bien et que les dépendances sont OK.
J'envoie le log de debug

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 08:48

Je suis emmerdé mon log de debug est vide...
Celui des dépendances est OK. Je tente de réinstaller les dépendances....

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 11:05

Je viens de t'envoyer un message privé.
Le problème se situe au niveau du certificat :

OpenSSL Error: error:14090086
error Mosquitto 14

Peut-être qu'il faut faire une mise à jour openssl?

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 11:23

OK je vais regarder ça, merci 👌

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 13:04

Bon manifestement ça n'aide pas beaucoup.
J'avais déjà la dernière version.

Quand je regarde le détail du debug, j'ai l'impression que c'est un problème SSL en effet, mais côté serveur

Code : Tout sélectionner

[2018-06-10 13:00:32][INFO] : mac_address F0FE6B413472
[2018-06-10 13:00:32][DEBUG] : 16 : Client android-uuid/v1beb8ab9f sending CONNECT
[2018-06-10 13:00:32][DEBUG] : 16 : Client android-uuid/v1beb8ab9f sending SUBSCRIBE (Mid: 1, Topic: DB510/F0FE6B413472/commandOut, QoS: 0)
[2018-06-10 13:00:32][DEBUG] : Subscribe to mqtt a1optpg91s0ydf-2.iot.eu-west-1.amazonaws.com msg {}
[2018-06-10 13:00:32][DEBUG] : 16 : Client android-uuid/v1beb8ab9f sending PUBLISH (d0, q0, r0, m2, 'DB510/F0FE6B413472/commandIn', ... (2 bytes))
[2018-06-10 13:00:32][DEBUG] : 8 : OpenSSL Error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
[2018-06-10 13:00:32][DEBUG] : Déconnexion de Mosquitto avec code 14
Une idée?

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 19:21

Est ce que /var/www/html/plugins/worxLandroidS/resources
Contient les fichiers cert.pem pkey.pem?

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 19:34

yes.
non vides et avec un format qui ressemble à ce qu'on doit attendre.
Capture d’écran 2018-06-10 à 19.29.22.png
Capture d’écran 2018-06-10 à 19.29.22.png (56.64 Kio) Consulté 361 fois
Capture d’écran 2018-06-10 à 19.29.07.png
Capture d’écran 2018-06-10 à 19.29.07.png (57.83 Kio) Consulté 361 fois
Je ne sais pas si ça peut aider mais mon modèle est un modèle que l'on ne trouve pas en France mais seulement en Allemagne (d'après le site de Worx)

La fiche produit existe en français mais le menu ne contient le produit que si l'on passe le site en international ou allemand :
https://www.worxlandroid.com/fr-FR/prod ... 50-wr106si (et ensuite j'ai remplacé en /en/ par un /fr-FR/

ça n'a peut-être rien à voir.

en même temps dans les codes retours du debug ça a l'air nominal au départ...

Code : Tout sélectionner

[2018-06-10 13:00:32][INFO] : Connexion result :[{"id":37231,"product_id":38,"user_id":67436,"serial_number »: "MON »-SERIAL-NUMBER, »mac_address":"F0FE6B413472","name":"Gaston","purchase_date":null,"warranty_expiration_date":null,"purchase_info":null,"setup_location":null,"locked":false,"created_at":"2017-04-19 15:05:45","updated_at":"2018-06-10 07:24:24","firmware_version":3.45,"registration_date":"2018-06-09 13:58:16","firmware_auto_upgrade":true,"distance_covered":4794,"mower_work_time":285,"blade_work_time":254,"battery_charge_cycles":33,"messages_in":22,"messages_out":105,"push_notifications":true,"city_id":null,"push_notifications_level":"warning","lawn_size":null,"raw_messages_in":33,"raw_messages_out":105,"test":0,"city":null}]

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 20:09

Ce n'est pas lié à la machine. J'ai la même.
Je pense plutôt que c'est lié à ton installation mais je ne sais pas trop ce qui coince.
Le port sur le routeur ?

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 20:46

le 443 est redirigé convenablement (mon jeedom est exposé en https) et se porte plutôt bien.
Ce qui est étonnant c'est qu'il arrive à récupérer quelques infos donc il y a une bribe d'information qui passe quand même.

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 21:10

C'est le port 8883 qui est utilisé pour la connexion mqtts
C'est pour ça qu'il y a besoin des certificats.
Mais pourquoi ça ne passe pas chez toi? Pour l'instant je n'ai pas d'idées.

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 21:15

ah bah je peux le rediriger :-) #DontMove

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 21:32

J'ai redirigé les 2 ports en du mqtts mais ça ne change rien.
Capture d’écran 2018-06-10 à 21.21.24.png
Capture d’écran 2018-06-10 à 21.21.24.png (20.19 Kio) Consulté 353 fois
étonnamment, je ne suis pas sûr que ça soit lié...

La connexion est OK, c'est + un sujet de validité de certificat...

Code : Tout sélectionner

[2018-06-10 21:19:29][INFO] : Paramètres utilisés, Host : 127.0.0.1, Port : 1883, ID : Jeedom
[2018-06-10 21:19:29][INFO] : Connexion result :{"id":67436,"name":"Tamboise","email":"MON EMAIL","created_at":"2018-06-09 12:30:05","updated_at":"2018-06-09 12:30:05","city":null,"address":null,"zipcode":null,"country_id":250,"phone":null,"birth_date":null,"gender":null,"newsletter_subscription":null,"user_type":"customer","active":true,"locale":"en","push_notifications":true,"location":null,"terms_of_use_agreed":true,"api_token":"nkePhcSBfE7xpNf9hfWFTrklkS12AzNU","token_expiration":"2068-05-27 12:30:34","mqtt_client_id":"android-uuid\/v1","mqtt_endpoint":"data.iot.eu-west-1.amazonaws.com"}
[2018-06-10 21:19:29][INFO] : Connexion result :{"pkcs12":"ICI MA CLE"}
[2018-06-10 21:19:30][INFO] : Connexion result :[{"id":37231,"product_id":38,"user_id":67436,"serial_number":"MON NUMERO DE SERIE","mac_address":"F0FE6B413472","name":"Gaston","purchase_date":null,"warranty_expiration_date":null,"purchase_info":null,"setup_location":null,"locked":false,"created_at":"2017-04-19 15:05:45","updated_at":"2018-06-10 07:24:24","firmware_version":3.45,"registration_date":"2018-06-09 13:58:16","firmware_auto_upgrade":true,"distance_covered":4794,"mower_work_time":285,"blade_work_time":254,"battery_charge_cycles":33,"messages_in":22,"messages_out":105,"push_notifications":true,"city_id":null,"push_notifications_level":"warning","lawn_size":null,"raw_messages_in":33,"raw_messages_out":105,"test":0,"city":null}]
[2018-06-10 21:19:30][INFO] : mac_address F0FE6B413472
[2018-06-10 21:19:30][DEBUG] : 16 : Client android-uuid/v13ee1d1ae sending CONNECT
[2018-06-10 21:19:30][DEBUG] : 16 : Client android-uuid/v13ee1d1ae sending SUBSCRIBE (Mid: 1, Topic: DB510/F0FE6B413472/commandOut, QoS: 0)
[2018-06-10 21:19:30][DEBUG] : Subscribe to mqtt data.iot.eu-west-1.amazonaws.com msg {}
[2018-06-10 21:19:30][DEBUG] : 16 : Client android-uuid/v13ee1d1ae sending PUBLISH (d0, q0, r0, m2, 'DB510/F0FE6B413472/commandIn', ... (2 bytes))
[2018-06-10 21:19:30][DEBUG] : 8 : OpenSSL Error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
[2018-06-10 21:19:30][DEBUG] : Déconnexion de Mosquitto avec code 14
J'ai regardé si les heures/dates pouvaient merder mais tout semble cohérent. Rien qui justifierait un certificat refusé en tout cas...

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 22:01

A la fin de l'installation des dépendances, il y a le message suivant peut être il faudrait essayer.

Run 'systemctl daemon-reload'

Sinon pour expliquer le fonctionnement :

Il y a 3 appels successifs vers les serveurs pour récupérer tous les paramètres de connexion, données utilisateurs, données machines et enfin les certificats.

D'après ce que je vois, ces 3 étapes fonctionnement correctement.

Donc ce qui ne fonctionne pas est la connexion mosquitto sécurisée (donc avec certificats) vers les serveurs Amazon aws.

En ssh, tu peux faire  sudo lsof -i :8883 et  sudo lsof -i :1883

Est ce que ça te retourne quelque chose ?

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 22:12

Avec

Code : Tout sélectionner

systemctl daemon-reload
=> Rien ne change

Et sur les deux commandes, la première ne répond rien, la seconde ci-dessous :
Capture d’écran 2018-06-10 à 22.11.49.png
Capture d’écran 2018-06-10 à 22.11.49.png (17.92 Kio) Consulté 350 fois

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 10 juin 2018, 22:47

il faut creuser l'erreur OpenSSL Error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Je dirais que c'est un config openssl
je vais poser la question aux autres développeurs, peut-etre que ca parlera à qq1

cedsib
Timide
Messages : 43
Inscription : 13 déc. 2016, 15:16

Re: worxLandroidS

Message par cedsib » 10 juin 2018, 22:53

Je vois une piste ici : https://www.davidlangin.fr/articles/err ... ify-failed
mais je suis pas sous Windows ;-)

ssc
Timide
Messages : 299
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 11 juin 2018, 09:05

Oui j'avais vu ce lien.
On finira sûrement par trouver et probablement avec un coup de main de quelqu'un qui maîtrise mieux le sujet des certificats que moi.
Le truc, c'est que c'est un peu compliqué de vérifier puisque seul toi a accès à ton système.

Je te dirai si j'ai un retour des autres développeurs.

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités