Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

worxLandroidS

Pour échanger sur les plugins classés en catégorie "Objets connectés"
ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 15 juin 2018, 19:39

Est ce que dans les dossiers /var/www/html/plugins/worxLandroidS/resources tu as les fichiers:

cert.pem
pkey.pem
et vs-ca.pem

jeewawa
Timide
Messages : 321
Inscription : 24 oct. 2014, 23:41

Re: worxLandroidS

Message par jeewawa » 15 juin 2018, 21:56

ssc a écrit :
15 juin 2018, 19:39
Est ce que dans les dossiers /var/www/html/plugins/worxLandroidS/resources tu as les fichiers:

cert.pem
pkey.pem
et vs-ca.pem
Oui, ils y sont bien.
Smart Zwave avec RFXCom, RfPlayer et Teleinfo GCE ELECTRONICS

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 16 juin 2018, 07:56

Tu avais bien un problème de version de mosquitto.

Je ne sais pas à partir de quelle version ça fonctionne. Je pense au moins 1.4 et 1.4.1 pour être sûr puisque c'est la version que j'utilise.
Tu es en 1.4.2 maintenant.
Tu étais en 1.3.4

J'ai un problème avec les messages privés les réponses ne partent pas souvent... Donc je t'avais répondu mais ce n'est jamais parti..

Samuel14
Timide
Messages : 405
Inscription : 27 août 2014, 17:39
Localisation : Caen

Re: worxLandroidS

Message par Samuel14 » 20 juin 2018, 17:11

Je viens de voir que tu as sorti le plugin, félicitations :-)
Mini+ Ultimate (jeeboard dual) -> Z83II + zstick Aeotec sw090
47 noeuds Z-Wave + Clé 3G Huawei E172 + Karotz + Station météo Netatmo + Xiaomi (Gateway 24 noeuds + Aspi v1 + lampe de chevet v1 et v2) + nut

Avatar de l’utilisateur
zep57
Timide
Messages : 240
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 20 juin 2018, 21:42

Salut
ça fait deux jours que j'ai la même erreur;

2018-06-20 14:00:05 worxLandroidS Erreur sur la fonction cron30 du plugin : Call to a member function disconnect() on null

Si ça peut t'aider
Bonne soirée
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 21 juin 2018, 00:01

Salut,
Je pense connaitre la cause, c'est un problème de tests sur les horaires. Je corrigerais dès que possible.
En revanche j'ai un soucis de mon côté et je n'arrive pas à identifier la cause.
Impossible de communiquer avec la tondeuse et je n'ai aucun message d'erreur.
Pas de problème chez vous?

[Maj] C'est revenu tout seul ce matin

Avatar de l’utilisateur
zep57
Timide
Messages : 240
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 21 juin 2018, 09:31

Pareil
ça fait trois jours que je remarque ça.
ça revient tout seul le elendemain
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Avatar de l’utilisateur
zep57
Timide
Messages : 240
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: worxLandroidS

Message par zep57 » 21 juin 2018, 20:24

zep57 a écrit :
20 juin 2018, 21:42
Salut
ça fait deux jours que j'ai la même erreur;

2018-06-20 14:00:05 worxLandroidS Erreur sur la fonction cron30 du plugin : Call to a member function disconnect() on null

Si ça peut t'aider
Bonne soirée
Même erreur a la même heure!
Je précise que c'est l'heure de départ de la tonte
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

jeewawa
Timide
Messages : 321
Inscription : 24 oct. 2014, 23:41

Re: worxLandroidS

Message par jeewawa » 21 juin 2018, 22:34

Bonjour,
Je lis dans la doc que lorsque la tondeuse est active, l'actualisation se fait toutes les 2 minutes, ou 30 mn dans le cas contraire.
La mienne s'actualise toutes les 30 mn tout le temps.

Êtes-vous aussi concernés ?
Smart Zwave avec RFXCom, RfPlayer et Teleinfo GCE ELECTRONICS

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 21 juin 2018, 23:42

Bonjour,
Chez moi ça fonctionne mais je vais regarder ça de plus près.
Pour essayer de comprendre, Tu as mis quoi comme horaires ?
Pour le moment je compare les horaires comme des chaînes de caractères. et en PHP, je crois que ce n'est pas la bonne méthode.
Il y a une autre chose qui me gène c'est les remontée des statuts que je gère dans un scénario. Ça arrive régulièrement que la tondeuse remonte le statut bloquée alors qu'au final elle se débloque toute seule. Même si effectivement elle était légèrement bloquée pendant une courte période.
Sinon pour information j'ai abandonné le temps réel parce que le serveur mosquitto me déconnecte automatiquement au bout d'une heure et après j'ai des déconnexions bien plus rapide.

Avrel
Timide
Messages : 8
Inscription : 22 juin 2018, 10:31

Re: worxLandroidS

Message par Avrel » 22 juin 2018, 10:51

Bonjour ssc,

Tout d‘abord merci beaucoup pour ce plugin. Il avance à grande vitesse et s’améliore de jour en jour.

J’avais remarqué que les commandes de démarrage et retour à la base ne fonctionnaient pas. C’est fonctionnel dans la dernière mise à jour.
Par contre lorsque je commande un retour à la base, le robot retourne bien á la base, marque un court arrêt puis repart.

Cela ne se produit pas via l’app officielle.

Suis-je le seul dans ce cas? Puis-je fournir des informations supplémentaires pour aider à voir ce qui se passe ?

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 22 juin 2018, 12:16

Bonjour,
Je n'utilise pas cette fonction donc je ne connais pas le comportement. J'envoie simplement la commande stop.
Il me semblait avoir lu que ça envoyait une commande de retour à la base mais ce n'est pas un arrêt total jusqu'à nouvel ordre.
D'après ce que j'ai constaté lors de mon dernier essai, ça l'envoie à la base. Et dès que la tondeuse est chargée, elle repart si sa besogne quotidienne n'est pas terminée.
Sinon tu peux toujours mettre à "off" quand tu le souhaites en mettant le planning du jour à 0. Bien entendu il faudra le remettre à "on" (récupération des dernières heures connues) quand tu souhaites la faire repartir.
Et si tu souhaites le faire par scénario, tu peux utiliser les fonctions off_today / on_today.

jeewawa
Timide
Messages : 321
Inscription : 24 oct. 2014, 23:41

Re: worxLandroidS

Message par jeewawa » 29 juin 2018, 21:24

jeewawa a écrit :
21 juin 2018, 22:34
Bonjour,
Je lis dans la doc que lorsque la tondeuse est active, l'actualisation se fait toutes les 2 minutes, ou 30 mn dans le cas contraire.
La mienne s'actualise toutes les 30 mn tout le temps.

Êtes-vous aussi concernés ?
Bonjour à tous,
ça donne quoi chez vous ?
Merci.
Smart Zwave avec RFXCom, RfPlayer et Teleinfo GCE ELECTRONICS

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 29 juin 2018, 23:06

bonjour,
Bizarre chez moi ça marche bien, j'avais fait quelques mises à jour parce qu'il y avait un petit soucis lors du redémarrage.

donc première question: Est-ce que tu as appliqué les dernières mises à jour?

Est-ce que tu pourrais me donner tes horaires de tonte et est-ce que les horaires remontent bien sur le widget?
Et je suis aussi intéressé pour savoir si d'autres personnes sont concernées.

jeewawa
Timide
Messages : 321
Inscription : 24 oct. 2014, 23:41

Re: worxLandroidS

Message par jeewawa » 30 juin 2018, 10:41

Bonjour,
Oui, je fais bien les mises à jour à chaque fois. Mais pour la dernière je ne saurais pas te dire si le problème était toujours bien présent car la MAJ a été faite hier et je n'ai pas vérifié ensuite.
Sinon, oui, les horaires de tonte (tous les jours de 19 à 23h) remontent bien.
Smart Zwave avec RFXCom, RfPlayer et Teleinfo GCE ELECTRONICS

alex7614
Timide
Messages : 4
Inscription : 24 mars 2018, 10:06

Re: worxLandroidS

Message par alex7614 » 01 juil. 2018, 10:46

Bonjour

Pour ma part la tondeuse ne s'affiche pas dans Jeedom. J'ai tenté de réinstaller, forcer la réinitialisation des données etc... Mais rien n'y fait.

Pourtant dans le log, il détecte bien la tondeuse car il ressort toutes ses informations, son adresse MAC etc... Mais elle n’apparaît pas ensuite dans le plugin.

Fin du fichier log :
[2018-07-01 10:37:25][INFO] : Connexion result :[{"id":44179,"product_id":25,"user_id":2................................
[2018-07-01 10:37:25][INFO] : mac_address F0FE6.............................................

Modèle WR106SI

Des idées ? Merci par avance

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 01 juil. 2018, 13:51

Bonjour,
Jusqu'à maintenant quand ça ne fonctionnait pas, c'était la version mosquitto qui posait problème.
Il faut au moins la 1.4 (ou peut être 1.4.1)
Est ce que tu peux vérifier ta version en ssh en tapant mosquitto -h?

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 01 juil. 2018, 13:55

jeewawa a écrit :
30 juin 2018, 10:41
Bonjour,
Oui, je fais bien les mises à jour à chaque fois. Mais pour la dernière je ne saurais pas te dire si le problème était toujours bien présent car la MAJ a été faite hier et je n'ai pas vérifié ensuite.
Sinon, oui, les horaires de tonte (tous les jours de 19 à 23h) remontent bien.
J'essaierai demain avec ces horaires.
Mais sinon en attendant tu peux aussi gérer ça par scénario en utilisant la fonction refreshValue.

jeewawa
Timide
Messages : 321
Inscription : 24 oct. 2014, 23:41

Re: worxLandroidS

Message par jeewawa » 01 juil. 2018, 14:47

ssc a écrit :
01 juil. 2018, 13:55
jeewawa a écrit :
30 juin 2018, 10:41
Bonjour,
Oui, je fais bien les mises à jour à chaque fois. Mais pour la dernière je ne saurais pas te dire si le problème était toujours bien présent car la MAJ a été faite hier et je n'ai pas vérifié ensuite.
Sinon, oui, les horaires de tonte (tous les jours de 19 à 23h) remontent bien.
J'essaierai demain avec ces horaires.
Mais sinon en attendant tu peux aussi gérer ça par scénario en utilisant la fonction refreshValue.
Ok j'essaie ça.
Merci.
Smart Zwave avec RFXCom, RfPlayer et Teleinfo GCE ELECTRONICS

ssc
Timide
Messages : 171
Inscription : 28 juin 2017, 16:51

Re: worxLandroidS

Message par ssc » 01 juil. 2018, 19:41

jeewawa a écrit :
01 juil. 2018, 14:47
ssc a écrit :
01 juil. 2018, 13:55
jeewawa a écrit :
30 juin 2018, 10:41
Bonjour,
Oui, je fais bien les mises à jour à chaque fois. Mais pour la dernière je ne saurais pas te dire si le problème était toujours bien présent car la MAJ a été faite hier et je n'ai pas vérifié ensuite.
Sinon, oui, les horaires de tonte (tous les jours de 19 à 23h) remontent bien.
J'essaierai demain avec ces horaires.
Mais sinon en attendant tu peux aussi gérer ça par scénario en utilisant la fonction refreshValue.
Ok j'essaie ça.
Merci.
Je viens d'essayer 19h-23h ça fonctionne bien.
Si tu actives la log débug ça indique une réactualisation toutes les 30 minutes ?

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités