Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] synoaudio

Pour échanger sur les plugins classés en catégorie "Multimédia"
Répondre
Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

[Plugin Tiers][Sujet Principal] synoaudio

Message par nexus79000 » 28 déc. 2015, 14:19

Bonjour,

Suite au sujet viewtopic.php?f=28&t=11366&p=253772&hil ... on#p253772, je me suis lancé dans le développement de mon premier plugin.

Il n'est pas parfait mais c'est un début qui doit évoluer.

Pour les fonctionnalités actuelles:
- Fonction de base : play, pause, stop, suivant, précédent, shuffle et repeat
- Volume, muet
- Affichage du nom de l'artiste, du titre de la chanson et de la cover.
- Ajout d'une playlist a la liste de lecture
- Ajout d'une radio (User) à la liste de lecture
- Management de la liste de lecture
- Découverte des players (via un bouton)
- Activation et désactivation des players ( toutes les 15 minutes)
- Version mobile

Les fonctionnalités et/ou améliorations à venir :
- Prise en charge du HTTPS
- Gestion des lecteurs Airplay pour le Multiroom (Basculer de lecteur et gestion du volume)
- Panel de navigation dans l'arborescence d'Audio Station.
- TTS (A voir car pas embarquer dans Audio Station, solution tiers)


Je me suis basé sur le plugin Sonos de Loic et j'ai repris la mécanique de pulling pour avoir du temps réel. C'est consommateur du coté de jeedom et du coté du nas, je ferais des ajustement en fonction des retours.
synoaudio_icon.png
Icone synoaudio
synoaudio_icon.png (8.21 Kio) Consulté 3577 fois
Dernière édition par nexus79000 le 25 janv. 2016, 17:46, édité 6 fois.
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] Plugin synoaudio

Message par Anonyme » 28 déc. 2015, 14:20

Contenu supprimé à la demande de son auteur

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 28 déc. 2015, 14:28

magicgg91 a écrit :Cool, je test ça ce soir sur ma V2 et mon Syno

Pareil
Jeedom Version Dev sur Vm Debian


configuration, voir profil

yaz.oudj
Timide
Messages : 87
Inscription : 11 nov. 2014, 12:15
Contact :

Re: [Sujet officiel] Plugin synoaudio

Message par yaz.oudj » 28 déc. 2015, 14:43

Et de 3 pour tester ce soir ;)


Envoyé de mon iPhone à l'aide de Tapatalk

rosty
Actif
Messages : 2343
Inscription : 26 juin 2014, 08:14

Re: [Sujet officiel] Plugin synoaudio

Message par rosty » 28 déc. 2015, 15:59

Idem, des demain je peux tester

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 15:59

J'ai un problème pour uploader le plugin....

Je le mettrais à disposition ce soir dès que possible!
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] Plugin synoaudio

Message par Anonyme » 28 déc. 2015, 17:31

Contenu supprimé à la demande de son auteur

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 20:40

Première version uploadée... Enfin!

Mon serveur de dev était quelque peu récalcitrant...

J'attends vos commentaires et critiques ;-)
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 28 déc. 2015, 20:55

tu met quoi pour le port ?
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 20:57

Le port de ton synology.

Par defaut, c'est le 5000.
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 28 déc. 2015, 21:03

nexus79000 a écrit :Le port de ton synology.

Par defaut, c'est le 5000.

le port du DSM ?
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 21:04

Oui c'est ça. Pour le moment le HTTPS ne fonctionne pas donc le port HTTP.
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 28 déc. 2015, 21:11

erreur lors d'une recherche de lecteurs

Image
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 21:24

Peux tu m'envoyer les logs en débug?
Et as tu bien sauvegardé avant la découverte?
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 28 déc. 2015, 21:30

oui sauvegarde avant

Code : Tout sélectionner

[2015-12-28 21:10:56][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer - Début
[2015-12-28 21:10:56][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer URL crée : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid=
[2015-12-28 21:10:56][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer en erreur, url : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid= code : 
[2015-12-28 21:15:03][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer - Début
[2015-12-28 21:15:03][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer URL crée : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid=
[2015-12-28 21:15:03][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer en erreur, url : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid= code : 
[2015-12-28 21:16:43][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer - Début
[2015-12-28 21:16:43][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer URL crée : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid=
[2015-12-28 21:16:43][synoaudio][DEBUG] :  Appel de l'API : SYNO.AudioStation.RemotePlayer en erreur, url : /webapi/?api=SYNO.AudioStation.RemotePlayer&version=&method=list&_sid= code : 
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 21:36

Il y a bien un problème... Il n'y a pas le début de l'URL dans la log.
J'ai testé sur une 1.212.
J'ajoute les données dans la config, je ne sais pas si c'est géré de la même manière en 2.0...
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 28 déc. 2015, 23:35

Le problème ne venait pas de jeedom mais bien de mon code....

J'ai publié le correctif.
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 29 déc. 2015, 10:21

la recherche d'équipement fonctionne

Image

je test la suite plus tard
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Avatar de l’utilisateur
nexus79000
Actif
Messages : 597
Inscription : 28 nov. 2015, 17:52
Localisation : Peut-être un peu trop à l'ouest!

Re: [Sujet officiel] Plugin synoaudio

Message par nexus79000 » 29 déc. 2015, 10:45

C'est déja un bon début! ;-)
Jeedom en RPI3 (RFXCOM - Zwave - Teleinfo )
Nas DS415Play - DS411(Sauvegarde)
Mes Plugin : SynoAudio, SynoDownload, SynoVideo

beber53
Actif
Messages : 1238
Inscription : 17 juil. 2014, 14:28

Re: [Sujet officiel] Plugin synoaudio

Message par beber53 » 29 déc. 2015, 11:29

par contre je pense il y a un soucis sur le deamon

Image
Jeedom Version Dev sur Vm Debian


configuration, voir profil

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités