Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Google Cast

Pour échanger sur les plugins classés en catégorie "Multimédia"
herve0297
Timide
Messages : 61
Inscription : 25 sept. 2016, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par herve0297 » 02 déc. 2018, 17:01

Pour info pour ceux qui galère sous jeedom smart avec ce plugin. Je viens d'avancer un peu dans la résolution de mes problèmes.
Je suis passé sous jeedom strech : viewtopic.php?t=38469
Et j'ai tapé les lignes de commande ci-dessous, redémarré le tout et enfin le plugin fonctionne. J'arrive à faire parler ma home mini, ça fait une semaine que je suis dessus, ça fait plaisir d'avoir trouver la solution. Je n'ai pas tout compris mais le résultat est là.
ligne de commande 1 :

Code : Tout sélectionner

mkdir -p /root/tmp/
cd /root/tmp
wget https://github.com/jeedom/core/archive/master.zip
unzip master.zip
cp -R /root/tmp/core-master/* /var/www/html
rm -rf /root/tmp/core-master
ligne de commande 2 :

Code : Tout sélectionner

php /var/www/html/install/update.php mode=force
chmod 775 -R /var/www/html
chown www-data:www-data -R /var/www/html

tomtom43
Timide
Messages : 94
Inscription : 27 juil. 2015, 13:53

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par tomtom43 » 02 déc. 2018, 17:11

Bonjour,
Je suis dans le même cas impossible d'installer les dépendances :

Code : Tout sélectionner

Launch install of googlecast dependancies

-- Updating repo...
Ign http://ftp.fr.debian.org jessie InRelease
Hit http://ftp.fr.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates InRelease
Hit https://deb.nodesource.com jessie InRelease
Hit http://ftp.fr.debian.org jessie Release.gpg
Hit http://ftp.fr.debian.org jessie Release
Hit http://ftp.fr.debian.org jessie-updates/main Sources
Hit http://ftp.fr.debian.org jessie-updates/contrib Sources
Hit http://ftp.fr.debian.org jessie-updates/non-free Sources
Hit http://security.debian.org jessie/updates/main Sources
Get:1 http://ftp.fr.debian.org jessie-updates/main amd64 Packages/DiffIndex [11.8 kB]
Hit http://security.debian.org jessie/updates/contrib Sources
Hit http://ftp.fr.debian.org jessie-updates/contrib amd64 Packages
Hit https://deb.nodesource.com jessie/main Sources
Hit http://security.debian.org jessie/updates/non-free Sources
Hit https://deb.nodesource.com jessie/main amd64 Packages
Get:2 http://ftp.fr.debian.org jessie-updates/non-free amd64 Packages/DiffIndex [736 B]
Get:3 https://deb.nodesource.com jessie/main Translation-en [162 B]
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://ftp.fr.debian.org jessie-updates/contrib Translation-en
Get:4 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Get:5 https://deb.nodesource.com jessie/main Translation-en [162 B]
Hit http://security.debian.org jessie/updates/contrib amd64 Packages
Get:6 http://ftp.fr.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Get:7 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Hit http://security.debian.org jessie/updates/non-free amd64 Packages
Get:8 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:9 http://ftp.fr.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Get:10 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://ftp.fr.debian.org jessie/main Sources
Get:11 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:12 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://ftp.fr.debian.org jessie/non-free Sources
Get:13 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:14 https://deb.nodesource.com jessie/main Translation-fr [162 B]
Hit http://ftp.fr.debian.org jessie/contrib Sources
Ign https://deb.nodesource.com jessie/main Translation-fr
Hit http://security.debian.org jessie/updates/non-free Translation-en
Hit http://ftp.fr.debian.org jessie/main amd64 Packages
Hit http://ftp.fr.debian.org jessie/non-free amd64 Packages
Hit http://ftp.fr.debian.org jessie/contrib amd64 Packages
Hit http://ftp.fr.debian.org jessie/contrib Translation-en
Hit http://ftp.fr.debian.org jessie/main Translation-en
Hit http://ftp.fr.debian.org jessie/main Translation-fr
Hit http://ftp.fr.debian.org jessie/non-free Translation-en
Fetched 17.0 kB in 16s (1014 B/s)
Reading package lists...

-- Installation of python3 and dependancies
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
python-dev is already the newest version.
python3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

-- Installed version of Python :
Python 3.4.2

-- Installation of pip for python3 and necessary libraries
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version.
python3-dev is already the newest version.
python-requests is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

-- Installation of TTS libraries
Reading package lists...
Building dependency tree...
Reading state information...
libav-tools is already the newest version.
libavcodec-extra is already the newest version.
sox is already the newest version.
libttspico-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

-- Installed version of pip :
pip 1.5.6 from /usr/lib/python3/dist-packages (python 3.4)

-- Installation of python library 'netifaces' with command pip3
Requirement already satisfied (use --upgrade to upgrade): netifaces in /usr/local/lib/python3.4/dist-packages
Cleaning up...

-- Installation of python library 'requests' with command pip3
Requirement already satisfied (use --upgrade to upgrade): requests in /usr/lib/python3/dist-packages
Cleaning up...

-- Installation of python library 'protobuf' with command pip3
Requirement already satisfied (use --upgrade to upgrade): protobuf in /usr/local/lib/python3.4/dist-packages
Cleaning up...

-- Installation of python library 'zeroconf' with command pip3
Downloading/unpacking zeroconf
  Downloading zeroconf-0.21.3-py2.py3-none-any.whl
Downloading/unpacking ifaddr (from zeroconf)
  Downloading ifaddr-0.1.5.tar.gz
  Running setup.py (path:/tmp/pip-build-timp37am/ifaddr/setup.py) egg_info for package ifaddr
    error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
    Complete output from command python setup.py egg_info:
    error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-timp37am/ifaddr
Storing debug log for failure in /root/.pip/pip.log

-- Installation of python library 'click, bs4 and six' for TTS with command pip3
Requirement already satisfied (use --upgrade to upgrade): click in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): bs4 in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): beautifulsoup4 in /usr/local/lib/python3.4/dist-packages (from bs4)
Cleaning up...

-- Installation of python library 'tqdm, websocket-client' for plex with command pip3
Requirement already satisfied (use --upgrade to upgrade): tqdm in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): websocket-client in /usr/local/lib/python3.4/dist-packages
Cleaning up...

-- Installation of dependencies is done !

Je ne vois pas ou ça bloque ?

Avatar de l’utilisateur
blusy38
Timide
Messages : 471
Inscription : 31 mars 2016, 21:10
Localisation : Lyon
Contact :

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par blusy38 » 02 déc. 2018, 19:12

Bonjour,
J'ai un mi TV box et j'aimerais avoir l'état veille ou allumé, je n'ai pas trouvé dans les custom cmd est-ce que l'un d'entre vous aurait trouvé ? Merci d'avance.

guirem
Timide
Messages : 272
Inscription : 31 août 2017, 00:41

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par guirem » 03 déc. 2018, 20:31

Bonsoir,

@tomtom43 , @madwall83
Vous pouvez tenter cette ligne de code avant de relancer l'installation des dépendance pour voir si ça règle le problème?

Code : Tout sélectionner

sudo pip3 install setuptools --upgrade

tomtom43
Timide
Messages : 94
Inscription : 27 juil. 2015, 13:53

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par tomtom43 » 03 déc. 2018, 20:38

Salut Guirem,
J'ai tenté la commande et rien ... ce qui coince :

Code : Tout sélectionner

-- Installation of python library 'zeroconf' with command pip3.4
Downloading/unpacking zeroconf
  Downloading zeroconf-0.21.3-py2.py3-none-any.whl
Downloading/unpacking typing (from zeroconf)
  Downloading typing-3.6.6-py3-none-any.whl
Downloading/unpacking ifaddr (from zeroconf)
  Downloading ifaddr-0.1.5.tar.gz
  Running setup.py (path:/tmp/pip-build-8uh5x0uv/ifaddr/setup.py) egg_info for package ifaddr
    error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
    Complete output from command python setup.py egg_info:
    error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-8uh5x0uv/ifaddr
Storing debug log for failure in /root/.pip/pip.log

tomtom43
Timide
Messages : 94
Inscription : 27 juil. 2015, 13:53

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par tomtom43 » 03 déc. 2018, 20:58

Je m'en suis sortis et cela peut servir aux autres :

Code : Tout sélectionner

sudo aptitude install python3-setuptools
sudo easy_install3 pip
sudo aptitude install python3-dev

sudo pip3 install netifaces
Puis j'ai lancé depuis le shell : /var/www/html/plugins/googlecast/resources

Code : Tout sélectionner

./install.sh 

herve0297
Timide
Messages : 61
Inscription : 25 sept. 2016, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par herve0297 » 04 déc. 2018, 16:51

Bonjour,

Est ce que sur jeedom smart on peut lire un fichier mp3 en local ? Et si oui est ce que le répertoire est bien le suivant : /plugins/googlecast /localmedia/ ?

Merci.

Avatar de l’utilisateur
mael501
Timide
Messages : 118
Inscription : 27 mai 2017, 16:19

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par mael501 » 05 déc. 2018, 18:17

Bonjour,

Je viens tout juste d'installer le plugin, les dépendances ne s'installent pas... L'occasion de constater que je ne suis pas le seul :/.
Je suis sur Smart aussi, si pas de nouveau d'ici quelques jours j'essayerais d'ouvrir un ticket Jeedom.
1 Jeedom Smart stretch 3.3.30, zwave - rfxcom - zigbee - blea
1 Jeedom Smart stretch 3.3.30, zwave

herve0297
Timide
Messages : 61
Inscription : 25 sept. 2016, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par herve0297 » 08 déc. 2018, 10:37

Bonjour,

Est ce que sur jeedom smart on peut lire un fichier mp3 en local ? Et si oui est ce que le répertoire est bien le suivant : /plugins/googlecast /localmedia/ ?

Merci.
Personne n'a d'info pour moi ?
Merci.

sebforum29
Timide
Messages : 349
Inscription : 04 janv. 2018, 20:17

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par sebforum29 » 08 déc. 2018, 10:57

oui c'est possible, regarde dans la doc il y a des exemples (il faut envoyer une commande)

herve0297
Timide
Messages : 61
Inscription : 25 sept. 2016, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par herve0297 » 08 déc. 2018, 11:47

sebforum29, Je viens de réussir même si ce n 'est pas la technique que je voulais utiliser au départ. Lorsque ma porte d'entrée s'ouvre je fais jouer un petit carillon. J'ai utilisé la fonction notif et j'ai changé le mp3 dans local média.
A la base je voulais lancer une url, mais je n'ai pas trouvé comment la faire fonctionner, malgré la doc.

sebforum29
Timide
Messages : 349
Inscription : 04 janv. 2018, 20:17

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par sebforum29 » 08 déc. 2018, 12:31

je ne connais que ça :

Code : Tout sélectionner

cmd=notif|value=tornado_siren.mp3|vol=100|duration=11

herve0297
Timide
Messages : 61
Inscription : 25 sept. 2016, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par herve0297 » 08 déc. 2018, 12:36

Merci, je vais essayer.

raphael_malin
Timide
Messages : 484
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par raphael_malin » 09 déc. 2018, 13:02

Hello,
J'ai plusieurs soucis:
Le 1er: j'ai eu un plantage de ma jeedom il y a quelques jours et depuis la voix de la GH est celle du robot! (pico)
Je n'arrive pas à la faire revenir en normal. La config est pourtant bien en Google Translate API qui a tjs bien fonctionné jusque là.
Les commandes sont bonnes puisqu'elle parle.
La jeedom est bien connecté à internet, je récup les infos météo, trafic et autres sur d'autres plugins, et je reçois mes messages sur messenger.
je pige pas...

le second, les radios:
J'ai effectué la config du fichier, mais certaines fonctionnent dans la liste d'origine et pas d'autres... et les miennes que j'ai ajouté, ca ne fonctionne pas CMD unknown. Les liens sont bons (testé en direct)

Code : Tout sélectionner

{
	"Alouette": {
        "location": "http://broadcast.infomaniak.net/alouette-high.mp3",
        "title": "Alouette",
        "image": "https://upload.wikimedia.org/wikipedia/fr/a/a4/Logo_station_Alouette.jpeg"
    },
	"M_radio": {
        "location": "http://broadcast.infomaniak.net/mfm-128.mp3",
        "title": "M radio",
        "image": "https://upload.wikimedia.org/wikipedia/commons/1/15/Logo_Mradio.png"
    },
 	"RFM": {
        "location": "http://rfm-live-mp3-128.scdn.arkena.com/rfm.mp3",
        "title": "RFM",
        "image": "https://fr.wikipedia.org/wiki/RFM#/media/File:RFM_logo_2011.png"
    },
     "europe_1": {
        "location": "http://e1-live-mp3-128.scdn.arkena.com/europe1.mp3",
        "title": "Europe 1",
        "image": "http://cdn1-europe1.new2.ladmedia.fr/bundles/europe1front/images/logo_europe1.png"
    },
    "france_bleue": {
        "location": "http://direct.francebleu.fr/live/fb1071-midfi.mp3",
        "title": "France-Bleue-107.1",
        "image": "https://www.francebleu.fr/img/logo_francebleu.png"
    },
     "jazz": {
        "location": "http://jazzradio.ice.infomaniak.ch/jazzradio-high.mp3",
        "title": "Jazz",
        "image": "http://www.jazzradio.fr/media/pochette.jpg"
    },
Le 3eme: le volume qui n'est pas stable pour le TTS, malgré que cela soit imposé dans la commande, un coup c'est fort, des fois pas...

Merci
Jeedom smart avec en général toutes les mises à jour faites (système et plugin)

guirem
Timide
Messages : 272
Inscription : 31 août 2017, 00:41

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par guirem » 09 déc. 2018, 19:33

Bonsoir,

@raphael_malin :
pour 1 : sans logs peux rien faire
pour 2 : ton fichier json est-il valide (https://jsonlint.com) ? Si oui logs
pour 3 : Faut voir dans le logs également s'il est pris en compte à chaque fois. Le volume si lancé via un group cast ou individuellement ne sera pas le même.

xcell
Timide
Messages : 18
Inscription : 16 juil. 2017, 20:34

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par xcell » 09 déc. 2018, 21:20

bonjour pouvais j'ai essayer d'installer le plugin gcast mais impossible de d'installer la dependance

j'ai effectuer une redémarrage de ma smartbox jeedom mais rien

fait supprimer refait l'installe pareil

voila le résultat du log :

W: Failed to fetch http://security.debian.org/dists/jessie ... /InRelease Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
E: Some index files failed to download. They have been ignored, or old ones used instead.
-- Installation of python3 and dependancies
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
python-dev is already the newest version.
python3 is already the newest version.
The following package was automatically installed and is no longer required:
linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 138 not upgraded.
-- Installed version of Python :
Python 3.4.2
-- Installation of pip for python3 and necessary libraries
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version.
python3-dev is already the newest version.
python-requests is already the newest version.
The following package was automatically installed and is no longer required:
linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 138 not upgraded.
-- Installation of TTS libraries
Reading package lists...
Building dependency tree...
Reading state information...
libav-tools is already the newest version.
libavcodec-extra is already the newest version.
sox is already the newest version.
libttspico-utils is already the newest version.
The following package was automatically installed and is no longer required:
linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 138 not upgraded.
-- Installed version of pip :
pip 1.5.6 from /usr/lib/python3/dist-packages (python 3.4)
-- Installation of python library 'netifaces' with command pip3
Requirement already satisfied (use --upgrade to upgrade): netifaces in /usr/local/lib/python3.4/dist-packages
Cleaning up...
-- Installation of python library 'requests' with command pip3
Requirement already satisfied (use --upgrade to upgrade): requests in /usr/lib/python3/dist-packages
Cleaning up...
-- Installation of python library 'protobuf' with command pip3
Requirement already satisfied (use --upgrade to upgrade): protobuf in /usr/local/lib/python3.4/dist-packages
Cleaning up...
-- Installation of python library 'zeroconf' with command pip3
Downloading/unpacking zeroconf
Downloading zeroconf-0.21.3-py2.py3-none-any.whl
Downloading/unpacking typing (from zeroconf)
Downloading typing-3.6.6-py3-none-any.whl
Downloading/unpacking ifaddr (from zeroconf)
Downloading ifaddr-0.1.5.tar.gz
Running setup.py (path:/tmp/pip-build-d9uwi8tt/ifaddr/setup.py) egg_info for package ifaddr
error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
Complete output from command python setup.py egg_info:
error in ifaddr setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-d9uwi8tt/ifaddr
Storing debug log for failure in /root/.pip/pip.log
-- Installation of python library 'click, bs4 and six' for TTS with command pip3
Requirement already satisfied (use --upgrade to upgrade): click in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): bs4 in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): beautifulsoup4 in /usr/local/lib/python3.4/dist-packages (from bs4)
Cleaning up...
-- Installation of python library 'tqdm, websocket-client' for plex with command pip3
Requirement already satisfied (use --upgrade to upgrade): tqdm in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): websocket-client in /usr/local/lib/python3.4/dist-packages
Cleaning up...
-- Installation of dependencies is done !

je comprend pas

Idefix69
Timide
Messages : 301
Inscription : 12 janv. 2015, 23:57

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Idefix69 » 10 déc. 2018, 17:39

Bonjour guirem
Un grand merci pour ton travail
Je viens de l'installer et marche du premier coup
Ma config est un peut particulière et j'utilise mon propre moteur d'interaction
Je récupère sur mon système via ifttt la phrase dictée avec "un instant", je traite la phrase, fait les actions et éventuellement envoi via un scénario une réponse à la Google Home
Le scénario permettant de faire parler la GH marche nickel
Un grand bonheur
Encore merci

Avatar de l’utilisateur
Mardup
Timide
Messages : 188
Inscription : 16 mars 2015, 15:05

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Mardup » 11 déc. 2018, 11:25

raphael_malin a écrit :
09 déc. 2018, 13:02
Hello,
J'ai plusieurs soucis:
Le 1er: j'ai eu un plantage de ma jeedom il y a quelques jours et depuis la voix de la GH est celle du robot! (pico)
Je n'arrive pas à la faire revenir en normal. La config est pourtant bien en Google Translate API qui a tjs bien fonctionné jusque là.
Les commandes sont bonnes puisqu'elle parle.
La jeedom est bien connecté à internet, je récup les infos météo, trafic et autres sur d'autres plugins, et je reçois mes messages sur messenger.
je pige pas...
Bonjour, il m'arrive exactement la même chose, à part le plantage que je n'ai pas eu.
Chez moi après des mois de fonctionnement sans pb, tout d'un coup, l'autre jour, GH s'est mis à parler avec cette voix , alors que les réglages sont bons, que j'ai bien internet, etc ...
Coté log : rien. Je les ai mis sur "debug", mais rien, a part :

[2018-12-10 19:51:52][DEBUG] : Envoi de la commande [speak] depuis Jeedom

Si qqun à une idée ...

Avatar de l’utilisateur
breizh22
Actif
Messages : 1318
Inscription : 10 oct. 2015, 17:35

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par breizh22 » 11 déc. 2018, 13:20

Juste pour comparer, chez moi tout fonctionne sous firmware 1.36.139856 des GH.
HP Gen 8 / OMV4 sur SSD / Jeedom 3.3.37 VM Debian 9
RFLink - Sondes Oregon THN 132 N / THGR 122 NX / THGR 810 / THC238 - Prises DIO/Dedra/IDK.
Orvibo AllOne et S20 - Onduleur APC Back-UPS ES 700VA
Écosystème xiaomi - Dash buttons - GHome et mini.

bwoufy
Timide
Messages : 22
Inscription : 14 avr. 2017, 16:59

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par bwoufy » 11 déc. 2018, 13:59

Bonjour,

depuis quelques jours, je constate aussi la même problématique dès que je fais parler la googleHome. La voix est différente et cela ne fonctionne pas tout le temps via les sénarios mais semble bien fonctionner via la tuile du plugin. De plus la nouvelle voix m'a obligé à modifier mes phrases : elle ne sait pas prononcer les mots avec les accents. Pour avoir le son "é" dans garage fermé j'ai du ecrire garage fermer .

j'ai ré-installer les dépendances et tout et tout. La GH est bien connecté sur internet. Je peux ouvrir ma porte de garage, mais j'ai pas le retour d'état oral comme quoi elle est ouverte :(

je suis bien sur le paramétrage de base, mais J'ai cependant des erreurs dans les logs de la GoogleHome :

Code : Tout sélectionner

[b][2018-12-10 21:41:54][ERROR] : CMD-TTS------Exception while generating tts file : Decoding failed. ffmpeg returned error code: 1[/b]
Output from ffmpeg/avlib:
b"ffmpeg version 3.2.10-1~deb9u1+rpt2 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.3.0 (Raspbian 6.3.0-18+rpi1+deb9u1) 20170516
configuration: --prefix=/usr --extra-version='1~deb9u1+rpt2' --toolchain=hardened --libdir=/usr/lib/arm-linux-gnueabihf --incdir=/usr/include/arm-linux-gnueabihf --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx-rpi --enable-mmal --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --arch=armhf --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
[b]WARNING: library configuration mismatch[/b]
avcodec     configuration: --prefix=/usr --extra-version='1~deb9u1+rpt2' --toolchain=hardened --libdir=/usr/lib/arm-linux-gnueabihf --incdir=/usr/include/arm-linux-gnueabihf --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx-rpi --enable-mmal --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --arch=armhf --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared --enable-version3 --disable-doc --disable-programs --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libtesseract --enable-libvo_amrwbenc --enable-netcdf
libavutil      55. 34.101 / 55. 34.101
libavcodec     57. 64.101 / 57. 64.101
libavformat    57. 56.101 / 57. 56.101
libavdevice    57.  1.100 / 57.  1.100
libavfilter     6. 65.100 /  6. 65.100
libavresample   3.  1.  0 /  3.  1.  0
libswscale      4.  2.100 /  4.  2.100
libswresample   2.  3.100 /  2.  3.100
libpostproc    54.  1.100 / 54.  1.100
[b][mp3 @ 0x21325c0] Failed to read frame size: Could not seek to 1026.
/var/www/html/plugins/googlecast/tmp/e870d500702b864d28732e02226d1c6e.mp3: Invalid argument[/b]
RAS niveau des dépendances.

Code : Tout sélectionner

Launch install of googlecast dependancies
-- Updating repo...
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Reading package lists...
-- Installation of python3 and dependancies
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
python-dev is already the newest version (2.7.13-2).
python3 is already the newest version (3.5.3-1).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installed version of Python :
Python 3.5.3
-- Installation of pip for python3 and necessary libraries
Reading package lists...
Building dependency tree...
Reading state information...
python-requests is already the newest version (2.12.4-1).
python3-dev is already the newest version (3.5.3-1).
python3-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installation of TTS libraries
Reading package lists...
Building dependency tree...
Reading state information...
sox is already the newest version (14.4.1-5).
libav-tools is already the newest version (7:3.2.10-1~deb9u1+rpt2).
libavcodec-extra is already the newest version (7:3.2.10-1~deb9u1+rpt2).
libttspico-utils is already the newest version (1.0+git20130326-5).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installed version of pip :
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)
-- Installation of python library 'netifaces' with command python3 -m pip
Requirement already satisfied: netifaces in /usr/local/lib/python3.5/dist-packages
-- Installation of python library 'requests' with command python3 -m pip
Requirement already satisfied: requests in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: idna<2.8,>=2.5 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: urllib3<1.24,>=1.21.1 in /usr/local/lib/python3.5/dist-packages (from requests)
-- Installation of python library 'protobuf' with command python3 -m pip
Requirement already satisfied: protobuf in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from protobuf)
-- Installation of python library 'zeroconf' with command python3 -m pip
Requirement already satisfied: zeroconf in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: netifaces!=0.10.5 in /usr/local/lib/python3.5/dist-packages (from zeroconf)
-- Installation of python library 'click, bs4 and six' for TTS with command python3 -m pip
Requirement already satisfied: click in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: bs4 in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python3.5/dist-packages (from bs4)
-- Installation of python library 'tqdm, websocket-client' for plex with command python3 -m pip
Requirement already satisfied: tqdm in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: websocket-client in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from websocket-client)
-- Installation of dependencies is done !
Je ne me souviens pas d'avoir mis à jour le plugin google Cast ces derniers jours. J'ai cependant acheter une chrome Cast et j'ai aussi redemarré plusieurs fois mon Raspi.

Avez vous une idée sur la raison de ce changement ?
Merci :)

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités