Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Pour échanger sur les plugins classés en catégorie "Multimédia"
Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 19 sept. 2018, 14:22

non attend je vais voir pour que ca marche dans tous les cas
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 19 sept. 2018, 14:29

mise a jour ;) essaye
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tristan35
Timide
Messages : 345
Inscription : 09 juin 2017, 21:53
Localisation : Rennes

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Tristan35 » 19 sept. 2018, 14:34

Youpi c’est bon, merci !

BLRPERES
Actif
Messages : 658
Inscription : 31 août 2016, 10:51
Localisation : Bourg-La-Reine

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par BLRPERES » 19 sept. 2018, 16:06

Tristan35 a écrit :php -v

Code : Tout sélectionner

PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
J'ai mis à jour le plugin mais le soucis persiste. C'est bizarre parce que je n'avais pas ce comportement avant ce matin :(
Maj tvOs 12?


Envoyé de mon iPhone en utilisant Tapatalk

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 19 sept. 2018, 16:14

non ca marche, c'était coté pip3 qui avait un comportement différent sur sa machine, j'ai retiré la partie de code non nécessaire (que j'avais mise pour éviter un message de notification obsolète)
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
ArthurH
Timide
Messages : 113
Inscription : 27 nov. 2014, 09:05
Localisation : Charente

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par ArthurH » 21 sept. 2018, 09:39

Bonjour,
j'ai installé ce plugin sur un odroidc2 Armbian Strech 9.5 et j'ai des erreurs dans les logs :
--0%
********************************************************
* Installation des dépendances *
********************************************************
Atteint:1 http://security.debian.org stretch/updates InRelease
Atteint:3 http://apt.armbian.com stretch InRelease
Ign:2 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Atteint:4 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
Atteint:5 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
Atteint:6 http://cdn-fastly.deb.debian.org/debian stretch Release
Atteint:7 https://deb.nodesource.com/node_8.x stretch InRelease
Lecture des listes de paquets…
--10%
Installation des dépendances apt
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0f-3+deb9u2).
python3-pip is already the newest version (9.0.1-2).
python3-setuptools is already the newest version (33.1.1-1).
python3 is already the newest version (3.5.3-1).
python3-dev is already the newest version (3.5.3-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
--50%
Collecting git+https://github.com/NebzHB/pyatv@fix_bugs
Cloning https://github.com/NebzHB/pyatv (to fix_bugs) to /tmp/pip-pcx29xxb-build
Collecting aiohttp>=3.0.1 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 4.4.tar.gz (822kB)
Collecting cryptography>=1.8.1 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 3.1.tar.gz (449kB)
Collecting curve25519-donna>=1.3 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 1.3.tar.gz
Collecting ed25519>=1.4 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 1.4.tar.gz (866kB)
Collecting srptools>=0.2.0 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Collecting zeroconf>=0.17.7 (from pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Collecting async_timeout<4.0,>=3.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Collecting attrs>=17.3.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Collecting chardet<4.0,>=2.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Cache entry deserialization failed, entry ignored
Cache entry deserialization failed, entry ignored
Downloading https://files.pythonhosted.org/packages ... ne-any.whl (133kB)
Collecting idna-ssl>=1.0; python_version < "3.7" (from aiohttp>=3.0.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 1.0.tar.gz
Collecting multidict<5.0,>=4.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 4.2.tar.gz (118kB)
Collecting yarl<2.0,>=1.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 2.6.tar.gz (159kB)
Collecting asn1crypto>=0.21.0 (from cryptography>=1.8.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl (101kB)
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=1.8.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... 1.5.tar.gz (438kB)
Collecting idna>=2.1 (from cryptography>=1.8.1->pyatv==0.3.11)
Cache entry deserialization failed, entry ignored
Cache entry deserialization failed, entry ignored
Downloading https://files.pythonhosted.org/packages ... ne-any.whl (58kB)
Collecting six>=1.4.1 (from cryptography>=1.8.1->pyatv==0.3.11)
Cache entry deserialization failed, entry ignored
Cache entry deserialization failed, entry ignored
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Collecting ifaddr (from zeroconf>=0.17.7->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... -0.1.4.zip
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=1.8.1->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... .19.tar.gz (158kB)
Collecting ipaddress (from ifaddr->zeroconf>=0.17.7->pyatv==0.3.11)
Downloading https://files.pythonhosted.org/packages ... ne-any.whl
Building wheels for collected packages: aiohttp, cryptography, curve25519-donna, ed25519, idna-ssl, multidict, yarl, cffi, ifaddr, pycparser
Running setup.py bdist_wheel for aiohttp: started
Running setup.py bdist_wheel for aiohttp: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/aiohttp/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmp3ve44n4xpip-wheel- --python-tag cp35:
/usr/lib/python3.5/distutils/dist.py:261: UserWarning: Unknown distribution option: 'project_urls'
warnings.warn(msg)
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for aiohttp
Running setup.py clean for aiohttp
Running setup.py bdist_wheel for cryptography: started
Running setup.py bdist_wheel for cryptography: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/cryptography/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpukeyi_4rpip-wheel- --python-tag cp35:
Installed /tmp/pip-build-_ri04wbd/cryptography/.eggs/cffi-1.11.5-py3.5-linux-aarch64.egg
Searching for pycparser
Reading https://pypi.python.org/simple/pycparser/
Downloading https://files.pythonhosted.org/packages ... 93246b25b3
Best match: pycparser 2.19
Processing pycparser-2.19.tar.gz
Writing /tmp/easy_install-qsi5e0rs/pycparser-2.19/setup.cfg
Running pycparser-2.19/setup.py -q bdist_egg --dist-dir /tmp/easy_install-qsi5e0rs/pycparser-2.19/egg-dist-tmp-zy_5vn3r
warning: no previously-included files found matching 'setup.pyc'
warning: no previously-included files matching 'yacctab.*' found under directory 'tests'
warning: no previously-included files matching 'lextab.*' found under directory 'tests'
warning: no previously-included files matching 'yacctab.*' found under directory 'examples'
warning: no previously-included files matching 'lextab.*' found under directory 'examples'
zip_safe flag not set; analyzing archive contents...
pycparser.ply.__pycache__.yacc.cpython-35: module references __file__
pycparser.ply.__pycache__.yacc.cpython-35: module MAY be using inspect.getsourcefile
pycparser.ply.__pycache__.yacc.cpython-35: module MAY be using inspect.stack
pycparser.ply.__pycache__.ygen.cpython-35: module references __file__
pycparser.ply.__pycache__.lex.cpython-35: module references __file__
pycparser.ply.__pycache__.lex.cpython-35: module MAY be using inspect.getsourcefile
creating /tmp/pip-build-_ri04wbd/cryptography/.eggs/pycparser-2.19-py3.5.egg
Extracting pycparser-2.19-py3.5.egg to /tmp/pip-build-_ri04wbd/cryptography/.eggs
Installed /tmp/pip-build-_ri04wbd/cryptography/.eggs/pycparser-2.19-py3.5.egg
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for cryptography
Running setup.py clean for cryptography
Running setup.py bdist_wheel for curve25519-donna: started
Running setup.py bdist_wheel for curve25519-donna: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/curve25519-donna/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpv2rc3abnpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for curve25519-donna
Running setup.py clean for curve25519-donna
Running setup.py bdist_wheel for ed25519: started
Running setup.py bdist_wheel for ed25519: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/ed25519/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmp_d1xs14ppip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for ed25519
Running setup.py clean for ed25519
Running setup.py bdist_wheel for idna-ssl: started
Running setup.py bdist_wheel for idna-ssl: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/idna-ssl/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpc3l4keiqpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for idna-ssl
Running setup.py clean for idna-ssl
Running setup.py bdist_wheel for multidict: started
Running setup.py bdist_wheel for multidict: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/multidict/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmplxhz7tzqpip-wheel- --python-tag cp35:
/usr/lib/python3.5/distutils/dist.py:261: UserWarning: Unknown distribution option: 'project_urls'
warnings.warn(msg)
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for multidict
Running setup.py clean for multidict
Running setup.py bdist_wheel for yarl: started
Running setup.py bdist_wheel for yarl: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/yarl/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpq93jfa29pip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for yarl
Running setup.py clean for yarl
Running setup.py bdist_wheel for cffi: started
Running setup.py bdist_wheel for cffi: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/cffi/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmptdk1k5ilpip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for cffi
Running setup.py clean for cffi
Running setup.py bdist_wheel for ifaddr: started
Running setup.py bdist_wheel for ifaddr: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/ifaddr/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpxytepgy5pip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for ifaddr
Running setup.py clean for ifaddr
Running setup.py bdist_wheel for pycparser: started
Running setup.py bdist_wheel for pycparser: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-_ri04wbd/pycparser/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmppewc81q_pip-wheel- --python-tag cp35:
usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: -c --help [cmd1 cmd2 ...]
or: -c --help-commands
or: -c cmd --help
error: invalid command 'bdist_wheel'
----------------------------------------
Failed building wheel for pycparser
Running setup.py clean for pycparser
Failed to build aiohttp cryptography curve25519-donna ed25519 idna-ssl multidict yarl cffi ifaddr pycparser
Installing collected packages: async-timeout, attrs, chardet, idna, idna-ssl, multidict, yarl, aiohttp, asn1crypto, pycparser, cffi, six, cryptography, curve25519-donna, ed25519, srptools, ipaddress, ifaddr, zeroconf, pyatv
Running setup.py install for idna-ssl: started
Running setup.py install for idna-ssl: finished with status 'done'
Running setup.py install for multidict: started
Running setup.py install for multidict: finished with status 'done'
Running setup.py install for yarl: started
Running setup.py install for yarl: finished with status 'done'
Running setup.py install for aiohttp: started
Running setup.py install for aiohttp: still running...
Running setup.py install for aiohttp: finished with status 'done'
Running setup.py install for pycparser: started
Running setup.py install for pycparser: finished with status 'done'
Running setup.py install for cffi: started
Running setup.py install for cffi: finished with status 'done'
Running setup.py install for cryptography: started
Running setup.py install for cryptography: still running...
Running setup.py install for cryptography: finished with status 'done'
Running setup.py install for curve25519-donna: started
Running setup.py install for curve25519-donna: finished with status 'done'
Running setup.py install for ed25519: started
Running setup.py install for ed25519: finished with status 'done'
Running setup.py install for ifaddr: started
Running setup.py install for ifaddr: finished with status 'done'
Running setup.py install for pyatv: started
Running setup.py install for pyatv: finished with status 'done'
Successfully installed aiohttp-3.4.4 asn1crypto-0.24.0 async-timeout-3.0.0 attrs-18.2.0 cffi-1.11.5 chardet-3.0.4 cryptography-2.3.1 curve25519-donna-1.3 ed25519-1.4 idna-2.7 idna-ssl-1.1.0 ifaddr-0.1.4 ipaddress-1.0.22 multidict-4.4.2 pyatv-0.3.11 pycparser-2.19 six-1.11.0 srptools-0.2.0 yarl-1.2.6 zeroconf-0.21.2
--100%
********************************************************
* Installation terminée *
********************************************************
Par avance merci de me dire si je dois configurer autre chose ou bien si ce n'est pas compatible avec odroidc2.

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 21 sept. 2018, 10:46

Hello,

j'ai poussé une mise à jour, tu peux la faire et relancer tes dépendances stp ?
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
ArthurH
Timide
Messages : 113
Inscription : 27 nov. 2014, 09:05
Localisation : Charente

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par ArthurH » 21 sept. 2018, 11:55

Nebz a écrit :
21 sept. 2018, 10:46
Hello,

j'ai poussé une mise à jour, tu peux la faire et relancer tes dépendances stp ?
Mise à jour du Plugin et des dépendances effectuées, j'ai bien maintenant mon aTV qui est apparue. Bravo et Merci.

Je ferais des essais d'utilisation ce soir...

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 21 sept. 2018, 11:57

comme prévenu, il y a 3-4 secondes entre la commande et l'action, c'est normal...
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
ArthurH
Timide
Messages : 113
Inscription : 27 nov. 2014, 09:05
Localisation : Charente

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par ArthurH » 21 sept. 2018, 13:44

Nebz a écrit :
21 sept. 2018, 11:57
comme prévenu, il y a 3-4 secondes entre la commande et l'action, c'est normal...
J'ai tester plutôt que prévu ;) Le plugin marche très bien et les quelques seconde de décalage ne sont pas un problème :)

Encore bravo et merci.

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 21 sept. 2018, 13:45

Parfait alors :)
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 01 oct. 2018, 13:22

Vous pensez qu'il est bon pour passer en stable ?
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tristan35
Timide
Messages : 345
Inscription : 09 juin 2017, 21:53
Localisation : Rennes

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Tristan35 » 01 oct. 2018, 13:38

Jamais eu aucun soucis chez moi en tous cas :)

noodlesft
Timide
Messages : 1
Inscription : 11 nov. 2018, 22:23

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par noodlesft » 11 nov. 2018, 22:30

Bonjour,

Merci beaucoup pour ce plugin très prometteur.
Je suis tout nouveau sur Jeedom et les possibilités offertes sont vraiment impressionnantes !

J'ai un soucis lors de l'installation des dépendances de ce plugin, pourriez-vous m'aider ?

J'ai le log suivant lors de l'installation :

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
--10%
Installation des dépendances apt
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0f-3+deb9u2).
python3 is already the newest version (3.5.3-1).
python3-dev is already the newest version (3.5.3-1).
python3-setuptools is already the newest version (33.1.1-1).
python3-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--50%
Collecting wheel
  Using cached https://files.pythonhosted.org/packages/5a/9b/6aebe9e2636d35d1a93772fa644c828303e1d5d124e8a88f156f42ac4b87/wheel-0.32.2-py2.py3-none-any.whl
Collecting netifaces
  Using cached https://www.piwheels.org/simple/netifaces/netifaces-0.10.7-cp35-cp35m-linux_armv7l.whl
Installing collected packages: wheel, netifaces
Successfully installed netifaces-0.10.7 wheel-0.32.2
Collecting git+https://github.com/NebzHB/pyatv@fix_bugs
  Cloning https://github.com/NebzHB/pyatv (to fix_bugs) to /tmp/pip-4vx2ofjv-build
Collecting aiohttp>=3.0.1 (from pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/aiohttp/aiohttp-3.4.4-cp35-cp35m-linux_armv7l.whl
Collecting cryptography>=1.8.1 (from pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/cryptography/cryptography-2.3.1-cp35-cp35m-linux_armv7l.whl
Collecting curve25519-donna>=1.3 (from pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/curve25519-donna/curve25519_donna-1.3-cp35-cp35m-linux_armv7l.whl
Collecting ed25519>=1.4 (from pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/ed25519/ed25519-1.4-cp35-cp35m-linux_armv7l.whl
Collecting srptools>=0.2.0 (from pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/d0/fe/f5cf417857404c3b797cb3a8fc43967145686a921e491980cdd4ff505408/srptools-0.2.0-py2.py3-none-any.whl
Collecting zeroconf>=0.17.7 (from pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/d2/4e/3e751bc1f33d0368bdba509a140cb9f2e54cd1cfb8ebcf4ebd8a5eef794b/zeroconf-0.21.3-py2.py3-none-any.whl
Collecting idna-ssl>=1.0; python_version < "3.7" (from aiohttp>=3.0.1->pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/idna-ssl/idna_ssl-1.1.0-py3-none-any.whl
Collecting chardet<4.0,>=2.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting multidict<5.0,>=4.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/multidict/multidict-4.4.2-cp35-cp35m-linux_armv7l.whl
Collecting async-timeout<4.0,>=3.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/e1/1e/5a4441be21b0726c4464f3f23c8b19628372f606755a9d2e46c187e65ec4/async_timeout-3.0.1-py3-none-any.whl
Collecting yarl<2.0,>=1.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
Collecting attrs>=17.3.0 (from aiohttp>=3.0.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/3a/e1/5f9023cc983f1a628a8c2fd051ad19e76ff7b142a0faf329336f9a62a514/attrs-18.2.0-py2.py3-none-any.whl
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=1.8.1->pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/cffi/cffi-1.11.5-cp35-cp35m-linux_armv7l.whl
Collecting six>=1.4.1 (from cryptography>=1.8.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=1.8.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting idna>=2.1 (from cryptography>=1.8.1->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl
Collecting ifaddr (from zeroconf>=0.17.7->pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/ifaddr/ifaddr-0.1.4-py3-none-any.whl
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=1.8.1->pyatv==0.3.11)
  Using cached https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl
Collecting ipaddress (from ifaddr->zeroconf>=0.17.7->pyatv==0.3.11)
  Using cached https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
Installing collected packages: idna, idna-ssl, chardet, multidict, async-timeout, yarl, attrs, aiohttp, pycparser, cffi, six, asn1crypto, cryptography, curve25519-donna, ed25519, srptools, ipaddress, ifaddr, zeroconf, pyatv
  Running setup.py install for pyatv: started
    Running setup.py install for pyatv: finished with status 'error'
    Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-4vx2ofjv-build/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-9sxlt_dn-record/install-record.txt --single-version-externally-managed --compile:
    
    ----------------------------------------
/var/www/html/plugins/aTVremote/core/class/../../resources/install_apt.sh: line 30:  2898 Segmentation fault      sudo pip3 install -I git+https://github.com/NebzHB/pyatv@fix_bugs
--100%
********************************************************
*             Installation terminée                    *
********************************************************


Du coup j'ai fouillé un long moment, je suis allé voir le GitHub du projet et j'ai fait une installation directement en ligne de commande sur mon raspberry :

Code : Tout sélectionner

$ pip install pyatv
. Dans ce cas tout fonctionne, mon aTV est découverte et je peux interagir avec.
Mais sur Jeedom, elle est introuvable et j'ai toujours cette erreur sur les dépendance.

Merci d'avance

Avatar de l’utilisateur
Nebz
Actif
Messages : 4055
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] aTVremote - Télécommande AppleTV

Message par Nebz » 12 nov. 2018, 09:15

Hello,

le problème c'est que dans ton cas, tu as installé une autre version, la master qui ne corrige pas d'autres problèmes et qui peut avoir un format différent de sortie...

par contre je ne comprends pas ton problème de dépendances, je n'ai pas ce problème, j'aurais tendance à dire que ca vient de ton système puisque ca marche autre part... mais impossible de te guider...
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Titanium31 et 1 invité