Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Pour échanger sur les plugins classés en catégorie "Multimédia"
Thibaw
Timide
Messages : 17
Inscription : 01 déc. 2018, 02:48
Localisation : Nord

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Thibaw » 11 oct. 2019, 21:32

Je bloque mes gateway avec la fonction sur mon routeur Asus Bluecave.

C'est comme ça depuis près de 6 mois, aucun soucis de remontée d'infos.
Dernière édition par Thibaw le 11 oct. 2019, 21:33, édité 1 fois.


Thibaw
Timide
Messages : 17
Inscription : 01 déc. 2018, 02:48
Localisation : Nord

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Thibaw » 11 oct. 2019, 21:41

Je suppose que oui.

Il faudrait se renseigner sur cette fonction mais son but est d'isoler complètement les équipements d'internet pour ne les rendre dispo qu'en local.

oon
Timide
Messages : 282
Inscription : 23 févr. 2015, 12:12

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par oon » 27 oct. 2019, 18:19

Avec le plugin Xiaomi j'arrive a jouer des sons sur mes 2 gateaways, si j'active l'alarme j'entends bien du son mais je n'arrive plus a les faire parler (ca marchais au début) si vous avez une idée ?

------------------------------------
[2019-10-27 17:59:44][SCENARIO] Start : Scenario lance manuellement.
[2019-10-27 17:59:44][SCENARIO] Exécution du sous-élément de type [action] : action
[2019-10-27 17:59:44][SCENARIO] Exécution d'un bloc élément : 112
[2019-10-27 17:59:44][SCENARIO] Exécution de la commande [Salon][GatewaySalon][Parle] avec comme option(s) : {"background":"0","title":"","message":" Fermeture des volets dans 5 minutes"}
[2019-10-27 17:59:51][SCENARIO] Exécution de la commande [Chambre parent][GatewayParents][Parle] avec comme option(s) : {"background":"0","title":"","message":" Fermeture des volets dans 5 minutes"}
[2019-10-27 17:59:55][SCENARIO] Fin correcte du scénario
------------------------------------

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » 27 oct. 2019, 18:20

Comme signalé, tu as probablement le problème...


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » 17 nov. 2019, 20:01

Bonjour,
Je viens de mettre à jour vers jeedom v4. Mon plugin ne fonctionne plus et mes dépendances sont nok. Je réinstalle et c'est la même chose.

Voici le log



--0%
--10%
Lancement de l'installation/mise à jour des dépendances xiaomiTalk
--20%
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:3 https://deb.nodesource.com/node_8.x buster InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ffmpeg
E: Package 'libav-tools' has no installation candidate
Reading package lists...
Building dependency tree...
Reading state information...
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dpkg: error: cannot access archive 'libttspico-data_1.0+git20130326-3_all.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico0_1.0+git20130326-3_armhf.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico-utils_1.0+git20130326-3_armhf.deb': No such file or directory
--30%
Version actuelle : v10.15.2
Ok, version suffisante
--50%
--60%
Installation de MIIO...
npm ERR! code 128
npm ERR! Command failed: git clone --depth=1 -q -b master git://github.com/NebzHB/miio.git /root/.npm/_cacache/tmp/git-clone-7b57126a
npm ERR! fatal: could not create leading directories of '/root/.npm/_cacache/tmp/git-clone-7b57126a': Permission denied
npm ERR!
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-11-17T18_55_45_198Z-debug.log
--95%
--100%
Installation des dépendances xiaomiTalk terminée, vérifiez qu'il n'y a pas d'erreur.


Une idée ?

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » 17 nov. 2019, 20:04

Oui le plug-in ne fonctionne pas sur debian buster.

Je mettrai peut être à jour prochainement


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » 17 nov. 2019, 20:45

Merci pour cette réponse rapide

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » 18 nov. 2019, 09:47

Hello,

j'ai sorti une nouvelle version, tu peux tenter ?
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » 18 nov. 2019, 23:45

Ça ne fonctionne pas encore. Voici le log


--0%
--10%
Lancement de l'installation/mise à jour des dépendances xiaomiTalk
--20%
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:3 https://deb.nodesource.com/node_8.x buster InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
apt-utils is already the newest version (1.8.2).
dialog is already the newest version (1.3-20190211-1).
lsb-release is already the newest version (10.2019051400+rpi1).
libavcodec-extra is already the newest version (7:4.1.4-1+rpt1~deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ffmpeg
E: Package 'libav-tools' has no installation candidate
Installation de ffmpeg à la place de libav-tools
Reading package lists...
Building dependency tree...
Reading state information...
ffmpeg is already the newest version (7:4.1.4-1+rpt1~deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
dpkg: error: cannot access archive 'libttspico-data_1.0+git20130326-3_all.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico0_1.0+git20130326-3_armhf.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico-utils_1.0+git20130326-3_armhf.deb': No such file or directory
--30%
Version actuelle : v10.15.2
Ok, version suffisante
--50%
--60%
Installation de MIIO...
npm ERR! code 128
npm ERR! Command failed: git clone --depth=1 -q -b master git://github.com/NebzHB/miio.git /root/.npm/_cacache/tmp/git-clone-afc88755
npm ERR! fatal: could not create leading directories of '/root/.npm/_cacache/tmp/git-clone-afc88755': Permission denied
npm ERR!
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-11-18T22_43_36_161Z-debug.log
--95%
--100%
Installation des dépendances xiaomiTalk terminée, vérifiez qu'il n'y a pas d'erreur

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » 18 nov. 2019, 23:51

Là je peux pas faire plus... tu es en i386 32 bits et c'est pas supporté par nodejs...


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » 18 nov. 2019, 23:51

Et en plus tu as un problème de droits sur ton systeme


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » 18 nov. 2019, 23:53

Un autre log après réparation de nodejs


--0%
--10%
Lancement de l'installation/mise à jour des dépendances xiaomiTalk
--20%
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://deb.nodesource.com/node_8.x buster InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
apt-utils is already the newest version (1.8.2).
dialog is already the newest version (1.3-20190211-1).
lsb-release is already the newest version (10.2019051400+rpi1).
libavcodec-extra is already the newest version (7:4.1.4-1+rpt1~deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ffmpeg
E: Package 'libav-tools' has no installation candidate
Installation de ffmpeg à la place de libav-tools
Reading package lists...
Building dependency tree...
Reading state information...
ffmpeg is already the newest version (7:4.1.4-1+rpt1~deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
dpkg: error: cannot access archive 'libttspico-data_1.0+git20130326-3_all.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico0_1.0+git20130326-3_armhf.deb': No such file or directory
dpkg: error: cannot access archive 'libttspico-utils_1.0+git20130326-3_armhf.deb': No such file or directory
--30%
Version actuelle :
--40%
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
/usr/bin/env: 'node': No such file or directory
/usr/bin/env: 'node': No such file or directory
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Package 'nodejs' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
--45%
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://deb.nodesource.com/node_8.x buster InRelease
Reading package lists...
## Confirming "buster" is supported...
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_8.x/dis ... er/Release'
## Adding the NodeSource signing key to your keyring...
+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
## Creating apt sources list file for the NodeSource Node.js 8.x LTS Carbon repo...
+ echo 'deb https://deb.nodesource.com/node_8.x buster main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src https://deb.nodesource.com/node_8.x buster main' >> /etc/apt/sources.list.d/nodesource.list
## Running `apt-get update` for you...
+ apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://deb.nodesource.com/node_8.x buster InRelease
Reading package lists...
## Run `sudo apt-get install -y nodejs` to install Node.js 8.x LTS Carbon and npm
## You may also need development tools to build native addons:
sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt-get update && sudo apt-get install yarn
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
libc-ares2 libnode64 libuv1 nodejs-doc
Suggested packages:
npm
The following NEW packages will be installed:
libc-ares2 libnode64 libuv1 nodejs nodejs-doc
0 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/5986 kB of archives.
After this operation, 27.1 MB of additional disk space will be used.
Selecting previously unselected package libc-ares2:armhf.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 67881 files and directories currently installed.)
Preparing to unpack .../libc-ares2_1.14.0-1_armhf.deb ...
Unpacking libc-ares2:armhf (1.14.0-1) ...
Selecting previously unselected package libuv1:armhf.
Preparing to unpack .../libuv1_1.24.1-1_armhf.deb ...
Unpacking libuv1:armhf (1.24.1-1) ...
Selecting previously unselected package libnode64:armhf.
Preparing to unpack .../libnode64_10.15.2~dfsg-2+rpi1_armhf.deb ...
Unpacking libnode64:armhf (10.15.2~dfsg-2+rpi1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_10.15.2~dfsg-2+rpi1_armhf.deb ...
Unpacking nodejs (10.15.2~dfsg-2+rpi1) ...
Selecting previously unselected package nodejs-doc.
Preparing to unpack .../nodejs-doc_10.15.2~dfsg-2+rpi1_all.deb ...
Unpacking nodejs-doc (10.15.2~dfsg-2+rpi1) ...
Setting up libc-ares2:armhf (1.14.0-1) ...
Setting up libuv1:armhf (1.24.1-1) ...
Setting up libnode64:armhf (10.15.2~dfsg-2+rpi1) ...
Setting up nodejs-doc (10.15.2~dfsg-2+rpi1) ...
Setting up nodejs (10.15.2~dfsg-2+rpi1) ...
update-alternatives: using /usr/bin/nodejs to provide /usr/bin/js (js) in auto mode
Processing triggers for libc-bin (2.28-10+rpi1) ...
Processing triggers for man-db (2.8.5-2) ...
Version actuelle : v10.15.2
--50%
--60%
Installation de MIIO...
npm ERR! code 128
npm ERR! Command failed: git clone --depth=1 -q -b master git://github.com/NebzHB/miio.git /root/.npm/_cacache/tmp/git-clone-fcb9622d
npm ERR! fatal: could not create leading directories of '/root/.npm/_cacache/tmp/git-clone-fcb9622d': Permission denied
npm ERR!
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-11-18T22_50_10_678Z-debug.log
--95%
--100%
Installation des dépendances xiaomiTalk terminée, vérifiez qu'il n'y a pas d'erreur

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » 18 nov. 2019, 23:57

Je fait comment pour régler le problème de droits ?
i386 32 bits, c'est quoi exactement ?
Ça fonctionnait avant le passage à buster.
Je pense que je vais repasser à la version précédente.
Dommage

Merci pour le temps passé

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » Hier, 16:37

Bonjour Nebz,

Mon Jeedom tourne sur un raspberry pi 3 B et ce n'est donc pas un i386 32 bits.
Si j'ai bien compris, i386 correspond à l'architecture d'un vieux processeur intel.

Le fait est que cela fonctionnait avec la version strech et je n'ai pas changé le matériel.
J'ai juste fait une mise à jour vers buster et je suis passé à la V4 de jeedom.

Bien à toi

Tannis

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » Hier, 16:55

Plusieurs utilisateurs fonctionnent sur buster v4 sur un raspberry... étrange...

@akenad c'est ta config non ?


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » Hier, 20:27

Nebz,
Tu me disais que j'avais un problème de droit.
Comment faire pour régler ce problème?
Ensuite je referai un log pour voir ce qui se passe.

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6494
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Nebz » Hier, 20:38

fais la mise à jour
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Tannis
Timide
Messages : 27
Inscription : 18 sept. 2015, 17:28

Re: [Plugin Tiers][Sujet Principal] XiaomiTalk - Faites parler votre passerelle Xiaomi !

Message par Tannis » Hier, 23:48

Mise à jour effectuée et rpi relancé. Ça fonctionne parfaitement.

Un grand merci pour ton suivi et pour la solution.

Tannis

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités