Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Pour échanger sur les plugins classés en catégorie "Nature"
Avatar de l’utilisateur
Kalimasta7075
Timide
Messages : 63
Inscription : 11 oct. 2014, 09:01
Contact :

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Kalimasta7075 » 22 sept. 2018, 20:07

drobert.68 a écrit :
20 sept. 2018, 11:12
Bonjour René,

Installation tournant sous PI3 avec stretch avec le core en v3.2.11

J'ai tous les boutons mais lancer le scan ne me donne rien, la page reste vide
J'ai NOK en rouge dans les dépendances ....
J'ai dans la partie Configuration du Plugin:
  • la version 2018-07-01 14:07:41
  • la version de Jeedom en 2.4
  • la frequence de recuperation des données à 1h
  • le niveau de sécurité Bluetooth (high) à low
  • l'adaptateur Bluetooth (hci0) sur hci0
Je n'ai pas de dongle BT, je souhaite utiliser le module integré

Tout semble Ok, mais ....

le log en mode debug sur

Code : Tout sélectionner

Launch install of MiFlora dependancy
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:3 http://archive.raspbian.org/raspbian stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0f-3+deb9u2).
python-dev is already the newest version (2.7.13-2).
python-requests is already the newest version (2.12.4-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libglib2.0-dev is already the newest version (2.50.3-2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pyudev in /usr/local/lib/python2.7/dist-packages (0.21.0)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pyudev) (1.10.0)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pyserial in /usr/local/lib/python2.7/dist-packages (3.4)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: requests in /usr/local/lib/python2.7/dist-packages (2.18.4)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests) (1.22)
Requirement already satisfied: idna<2.7,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests) (2.6)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages (from requests) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests) (2017.7.27.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages (1.7.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pycrypto in /usr/lib/python2.7/dist-packages (2.6.1)
Everything is successfully installed!
Bonsoir,

J'ai la même config que toi , le log est identique et... Le même problème.
J'ai tenté moult fois de relancer l'installation des dépendances sans succès.
So...
Bonne soirée
RPI 3 Jeedom V3.1.7
RPI 3 B+

rene.jullien
Timide
Messages : 250
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 22 sept. 2018, 20:38

Bonsoir,

Il faut regarder le log en mode debug du plugin (et ne pas le laisser en debug, ca récupère les données toutes les 15 minutes)
tu peux aussi tester directement la commande qui est dans la doc (prerequis)
s’assurer que

Code : Tout sélectionner

gatttool --device=hci0 -b _macAddMiFlora_ --char-read -a 0x35 --sec-level=low 
fonctionne sur l’appareil cible (selon le choix local ou déporté).
Ca permet de s'assurer que le RPI peut se connecter au MiFlora

Désolé de ne pas avoir repondu plus tot, je n'ai pas vu le pop up du precedent post

Je l utilise avec jeedom 3.11, pas en 2.4 mais logiquement ca devrait marcher. A voir ce qu'il y a dans les log.

René.

Avatar de l’utilisateur
Kalimasta7075
Timide
Messages : 63
Inscription : 11 oct. 2014, 09:01
Contact :

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Kalimasta7075 » 22 sept. 2018, 20:54

Pour être plus complet, mes mifloras sont bien connectés via Blea.
Je testais juste ce plugin qui indique un NOC de dépendances...
Donc, j'ai bien la remontée de mes équipements.
RPI 3 Jeedom V3.1.7
RPI 3 B+

rene.jullien
Timide
Messages : 250
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 22 sept. 2018, 21:05

Kalimasta7075 a écrit :Pour être plus complet, mes mifloras sont bien connectés via Blea.
Je testais juste ce plugin qui indique un NOC de dépendances...
Donc, j'ai bien la remontée de mes équipements.
Attention BLEA utilise le Bluetooth de manière plus ou moins exclusive, il faut un autre dongle pour avoir les 2 en même temps sinon il y a des conflits d acces au Bluetooth assez fréquent.
Les dépendances ne sont pas indispensables, en général tout est déjà installé. Je vais regarder, c est effectivement pas normal d avoir un NOK si ça fonctionne bien.


Envoyé de mon iPhone en utilisant Tapatalk

drobert.68
Timide
Messages : 6
Inscription : 07 mars 2017, 21:16

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par drobert.68 » 24 sept. 2018, 11:55

Bonjour,

juste pour précisé, ma jeedom est en V3.11 mais l'indication sur le panel du plugin me donne v2.4.

Pour la commande gatttool --device=hci0 -b _macAddMiFlora_ --char-read -a 0x35 --sec-level=low
j'ai : connect error: Too many levels of symbolic links (40)

Merci
Netatmo, Ecocompteur, Gateway Xiaomi, JEEDOM v3 (Pi3 Stretch), EEDOMUS v1
  • 1xFGBS321; 4xFGK101;2xFGMS001;2xFGWP01;5xLC13;1xZMNHBA2,1xRFXUSB(Chacon)
  • Usages : Relevé Conso &Temp, Surv. IP, Gestion Piscine & Store & Allumage ....

Avatar de l’utilisateur
Kalimasta7075
Timide
Messages : 63
Inscription : 11 oct. 2014, 09:01
Contact :

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Kalimasta7075 » 25 sept. 2018, 10:54

drobert.68 a écrit :
24 sept. 2018, 11:55
Bonjour,

juste pour précisé, ma jeedom est en V3.11 mais l'indication sur le panel du plugin me donne v2.4.

Pour la commande gatttool --device=hci0 -b _macAddMiFlora_ --char-read -a 0x35 --sec-level=low
j'ai : connect error: Too many levels of symbolic links (40)

Merci
Oui, moi aussi.
J'ai une clef bluetooth pour les mifloras et le bluetooth interne du RPI 3 pur Blea.
RPI 3 Jeedom V3.1.7
RPI 3 B+

Répondre

Revenir vers « [Catégorie] Nature »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité