Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers] Plugin Téléinfo

Pour échanger sur les plugins classés en catégorie "Energie"
Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 13:26

Salut
@cadavor, merci j'ajoute les dépendances manquantes.
@vince_007, pour que le plugin gère les données il faut qu'elles lui soient envoyées. Donc il faut utiliser l'API.
@palouf34, les logs sont là pour aider en cas de problème pas pour être beaux ;) Je regarde pour ton problème de %20.
@kemar, peux-tu ré-essayer avec la version 4.1.2.
@fwehrle, le dossier est créé par Jeedom lors de l'installation. C'est possible que tu ai une installation assez ancienne qui la créait différemment. C'est la bonne chose que le dossier /tmp/jeedom ai le même owner que jeedom.
Présence / SonyBravia / Téléinfo

zaz
Timide
Messages : 317
Inscription : 06 nov. 2015, 13:33
Localisation : Proche d'Amiens

Re: [Plugin Tiers] Plugin Téléinfo

Message par zaz » 06 mars 2019, 14:34

Bonjour,
avec la version 4.1.2 j'ai pu remettre le deamon et marche et tout semble reparti comme avant.
Merci
(Mini + V 3.2.8) Jeedom smart 3.2.8
Fib fgsd 002 6
Fib FGMS 001 sur thermostat et scenario lumière
Fib FGFS 101 3, 1 en test
fib FGWPE 102 1 porte
Dio 54755 3 chauffage salon et 1 ch 1 Sdb
3 camera ip
Xiaomi detecteur ouveture, temperature enceinte

kemar
Timide
Messages : 74
Inscription : 22 août 2017, 23:22

Re: [Plugin Tiers] Plugin Téléinfo

Message par kemar » 06 mars 2019, 14:44

Pas mieux chez moi malgré l'installation manuelle de pyudev. Testé également en 4.1.2.

Quand je fais un pip list, j'ai bien :
pyudev 0.21.0
requests 2.12.4

Mais le log persiste avec :
Error: importing module from jeedom folder
No module named pyudev
Je ne suis pas assez familier avec Python, mais est-ce possible que ce soit lié à une histoire de version ? Je vois qu'il y a 2 versions de Python sur ma machine : Python 2.7.13 et Python 3.5.3.

Par contre que je lance pip ou pip3, j'ai le même retour. Aucune mention du 2.7:

# pip --version
pip 19.0.3 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5)

# pip3 --version
pip 19.0.3 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5)

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 14:47

Salut @kemar, c'est le 2.7 qui est utilisé par le plugin.
Essai en lançant les dépendances.
Présence / SonyBravia / Téléinfo

kemar
Timide
Messages : 74
Inscription : 22 août 2017, 23:22

Re: [Plugin Tiers] Plugin Téléinfo

Message par kemar » 06 mars 2019, 14:52

Installation relancée, et voila le log. On dirait qu'il utilise python 3 vu ce qu'il écrit non ?

Ce qui est bizarre, c'est que tout était OK ce matin avant que je passe l'update 4.1.1.

Lancement de l'installation/mise à jour des dépendances Téléinfo
Raffraichissement du système
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.proxad.net/debian stretch InRelease
Hit:4 http://ftp.proxad.net/debian stretch-updates InRelease
Hit:5 http://ftp.proxad.net/debian stretch Release
Hit:6 https://repo.mosquitto.org/debian stretch InRelease
Hit:7 https://deb.nodesource.com/node_8.x stretch InRelease
Ign:3 https://packages.mapcrafter.org/debian stretch InRelease
Hit:8 https://packages.mapcrafter.org/debian stretch Release
Reading package lists...
Installation de la librairie ftdi pour modem 2 compteurs
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package python-ftdi
Reading package lists...
Building dependency tree...
Reading state information...
python-ftdi1 is already the newest version (1.3-2+b2).
The following packages were automatically installed and are no longer required:
cakephp cakephp-scripts javascript-common libappconfig-perl
libclass-inspector-perl libclass-load-perl libclass-std-fast-perl
libclass-std-perl libcommon-sense-perl libconvert-binhex-perl
libdata-optlist-perl libdate-manip-perl libdevice-serialport-perl
libemail-date-format-perl libexpect-perl libgnutls-openssl27
libio-interface-perl libio-sessiondata-perl libio-socket-multicast-perl
libio-stringy-perl libio-stty-perl libjs-mootools libjson-any-perl
libjson-xs-perl libmime-lite-perl libmime-tools-perl libmime-types-perl
libmodule-implementation-perl libmodule-runtime-perl
libnet-sftp-foreign-perl libossp-uuid-perl libossp-uuid16
libpackage-stash-perl libpackage-stash-xs-perl libparams-classify-perl
libparams-util-perl libphp-serialization-perl libproxy-tools
libsoap-lite-perl libsoap-wsdl-perl libsub-install-perl libsys-cpu-perl
libsys-meminfo-perl libsys-mmap-perl libtask-weaken-perl libtemplate-perl
libtry-tiny-perl libtypes-serialiser-perl liburi-encode-perl libvlc-bin
libvlc5 libvlccore8 libxml-parser-perl libxmlrpc-lite-perl php-apcu
php-apcu-bc php-cgi php-mysql
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Requirement already satisfied: pylibftdi in /usr/local/lib/python3.5/dist-packages (0.17.0)
Installation de la librairie serial
Skipping serial as it is not installed.
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages (3.4)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (2.12.4)
Requirement already satisfied: pyudev in /usr/local/lib/python3.5/dist-packages (0.21.0)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pyudev) (1.10.0)
Mise à jour de cmdline ou inittab suivant système
Everything is successfully installed!

snaille
Timide
Messages : 134
Inscription : 25 févr. 2016, 13:07
Localisation : 74

Re: [Plugin Tiers] Plugin Téléinfo

Message par snaille » 06 mars 2019, 15:04

Salut,
avec la 4.1.2, j'ai enfin retrouvé mon deuxième usbtic (cartelectronic) -production solaire-qui ne fonctionnais plus avec les maj 4.*.* précedentes.
Redemarrage Jeedom+dépendances
Thanks... :D
Raspberry PI3B+SSD-32Go - Jeedom 3.3.32 - USB AeonGen5- FibaroWallPlug- ZMNHJD1-FGSD-002 + FGS-223-2xTeleinfo usb Tic-FGBS001+4 sondes, 7x Fgr222, Save Samba sur Bbox-F@st5330b

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 15:07

@kemar, ton python3 a l'air d'être mis en principal.
Essai de voir la version en exécutant python --version
Si tu as la 2.7 il faut alors que tu puisses installer la librairie avec pip et non pip3 qui doit également être en principal.
Présence / SonyBravia / Téléinfo

kemar
Timide
Messages : 74
Inscription : 22 août 2017, 23:22

Re: [Plugin Tiers] Plugin Téléinfo

Message par kemar » 06 mars 2019, 15:58

Trouvé !! Merci !

Python me remonte bien la version 2.7 :
$ python --version
Python 2.7.13

MAIS ! Le loup était caché dans pip. En effet, "pip --version" remontait la version 3.5, alors qu'il aurait du pointer sur la 2.7 (et pip3 lui doit pointer sur python 3.5).

Du coup j'ai passé les commandes suivantes pour réinstaller pip:
# python3 -m pip install -U --force-reinstall pip
# python -m pip install -U --force-reinstall pip
Puis relancé une installation des dépendances, et la tout roule ! Mes compteurs conso et prod remontent. Merci pour ton aide.

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 16:54

Sera-t-il possible aux personnes qui ont un compteur linky en mode standard et/ou un second de production de me faire un retour sur la version 4.2.0 en beta concernant le calcul des statistiques et l'affichage du panel.
Merci
Présence / SonyBravia / Téléinfo

6co
Timide
Messages : 65
Inscription : 26 mars 2016, 18:42
Localisation : Sarthe

Re: [Plugin Tiers] Plugin Téléinfo

Message par 6co » 06 mars 2019, 16:59

Bonjour à tous,

Personnellement plus rien ne fonctionne de mon côté :?

J'ai mis le plugin à jour vers 14h, j'ai tenté une reinstall des dépendances, etc mais mon plug n'interprète plus les données de la téléinfo.

Je suis en 2.7.13 pour python, j'ai tenté : python -m pip install -U --force-reinstall pip comme indiqué par kemar mais rien à faire, sniffff

Voici le log teleinfo_update :

Lancement de l'installation/mise à jour des dépendances Téléinfo
Raffraichissement du système
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Installation de la librairie ftdi pour modem 2 compteurs
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package python-ftdi
Reading package lists...
Building dependency tree...
Reading state information...
python-ftdi1 is already the newest version (1.3-2).
The following package was automatically installed and is no longer required:
libpng12-0
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Requirement already satisfied: pylibftdi in /usr/local/lib/python2.7/dist-packages
Installation de la librairie serial
Cannot uninstall requirement serial, not installed
Requirement already satisfied: pyserial in /usr/lib/python2.7/dist-packages
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pyudev in /usr/lib/python2.7/dist-packages
Mise à jour de cmdline ou inittab suivant système
Désactivation de la sortie serie vers la console
Everything is successfully installed!


et un extrait du log Teleinfo :

[2019-03-06 16:55:08][DEBUG] : Commande HC N°654
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HC MAX : 55693036.00
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HC MIN : 55683926.00
[2019-03-06 16:55:08][DEBUG] : Total HC --> 9110
[2019-03-06 16:55:08][DEBUG] : Commande HP N°655
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HP MAX : 62592828.00
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HP MIN : 62589930.00
[2019-03-06 16:55:08][DEBUG] : Total HP --> 2898
[2019-03-06 16:55:08][DEBUG] : Commande HP N°661
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HP MAX :
[2019-03-06 16:55:08][DEBUG] : ==> Valeur HP MIN :
[2019-03-06 16:55:08][DEBUG] : Total HP --> 2898
[2019-03-06 16:55:08][INFO] : Mise à jour de la statistique journalière (HC) ==> 9110
[2019-03-06 16:55:08][INFO] : Mise à jour de la statistique journalière (HP) ==> 2898
[2019-03-06 16:55:08][INFO] : Mise à jour de la statistique journalière ==> 12008
[2019-03-06 16:55:14][DEBUG] : Pas de calcul
[2019-03-06 16:56:14][DEBUG] : Pas de calcul
[2019-03-06 16:57:14][DEBUG] : Pas de calcul
[2019-03-06 16:58:16][DEBUG] : Pas de calcul
"Ne vis pas pour que ta présence se remarque mais pour que ton absence se ressente" [Bob Marley]

Raspberry Pi 3 sur SSD, Wemos en pagaille, RFLink, Shelly 1 et Plug S, Gateway XIaomi et modules aqara

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 17:03

Svp faite attention quand vous trouvez des commandes sur le sujet, elles ne sont pas destinés à tous les environnement et peuvent tout casser !
@6co je ne vois pas de problème quand aux dépendances.
L'extrait log téléinfo ne montre pas le démarrage du démon. Ce serait nécessaire pour savoir ce qu'il se passe.
Présence / SonyBravia / Téléinfo

Avatar de l’utilisateur
marmoul
Actif
Messages : 891
Inscription : 01 sept. 2015, 15:50
Localisation : Haute-Saône (70)

Re: [Plugin Tiers] Plugin Téléinfo

Message par marmoul » 06 mars 2019, 17:09

Bonjour à tous,
J’ai vu dans la maj des nouveautés concernant la Conso des jours précédents.
Ces infos sont elles disponibles dans les cmd statistiques m (je suis peut-être passé à côté, si c’est le cas désolé :) )
Merc :D

6co
Timide
Messages : 65
Inscription : 26 mars 2016, 18:42
Localisation : Sarthe

Re: [Plugin Tiers] Plugin Téléinfo

Message par 6co » 06 mars 2019, 17:12

Désolé ticed, dans la panique j'ai un peu testé tout ce que je trouvais :$
"Ne vis pas pour que ta présence se remarque mais pour que ton absence se ressente" [Bob Marley]

Raspberry Pi 3 sur SSD, Wemos en pagaille, RFLink, Shelly 1 et Plug S, Gateway XIaomi et modules aqara

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 17:22

@6co Pas de trouble, peux tu afficher les logs lorsque tu lance le démon ?
@marmoul, la stat consommation du jour ou d'hier était déjà disponible, tu peux les afficher.
Présence / SonyBravia / Téléinfo

Avatar de l’utilisateur
fwehrle
Actif
Messages : 2828
Inscription : 01 juil. 2015, 11:03
Localisation : Strasbourg

Re: [Plugin Tiers] Plugin Téléinfo

Message par fwehrle » 06 mars 2019, 17:28


ticed35 a écrit :.
@fwehrle, le dossier est créé par Jeedom lors de l'installation. C'est possible que tu ai une installation assez ancienne qui la créait différemment. C'est la bonne chose que le dossier /tmp/jeedom ai le même owner que jeedom.
Oui, mon installation a effectivement quelques années. Je trouvais juste étrange que l'erreur arrive juste maintenant, alors que le plugin téléinfo (et d'autres plugins) utilisent ce dossier depuis le début sans problème. Mais j'ai modifié les droits.
Jeedom 3 sur Debian 9 en VM Proxmox 5 sur NUC Intel.
(Anciennement sur Docker sur Syno DS-415+ / MariaDB / DSM 6)
Teleinfo / RFXCom / Stick ZWave / IPX / Serveur Traccar / Blea

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 17:30

@fwehrle, j'ai modifié l'emplacement. À l'origine j'écrivais directement dans /tmp/jeedom maintenant le plugin a son propre dossier pour coller au fonctionnement officiel de jeedom.
Présence / SonyBravia / Téléinfo

Avatar de l’utilisateur
fwehrle
Actif
Messages : 2828
Inscription : 01 juil. 2015, 11:03
Localisation : Strasbourg

Re: [Plugin Tiers] Plugin Téléinfo

Message par fwehrle » 06 mars 2019, 17:32

Ah ok. Mais le plus étonnant, c'est que le sous répertoire a bien été créé avec les droits www-data.
Pourquoi le plugin n'aurait pas les droits d'écrire dedans alors qu'il écrivait bien avant dans le dossier jeedom qui appartenait a root?
Jeedom 3 sur Debian 9 en VM Proxmox 5 sur NUC Intel.
(Anciennement sur Docker sur Syno DS-415+ / MariaDB / DSM 6)
Teleinfo / RFXCom / Stick ZWave / IPX / Serveur Traccar / Blea

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 17:34

@fwehrle, étonnant en effet. tant que le pid peu être écrit avec le user jeedom normalement il n'y a pas de soucis.
Présence / SonyBravia / Téléinfo

6co
Timide
Messages : 65
Inscription : 26 mars 2016, 18:42
Localisation : Sarthe

Re: [Plugin Tiers] Plugin Téléinfo

Message par 6co » 06 mars 2019, 17:38

@ticed : jusqu'à maintenant je n'utilisais pas le démon puisque c'est mon remora qui me remonte les données de téléinfo. Peut-être que je n'aurais pas dû faire la mise à jour :oops:

J'obtiens ceci quand je tente de le lancer :

[2019-03-06 17:37:16][INFO] : Pas d'informations sur le port USB (Modem série ?)
"Ne vis pas pour que ta présence se remarque mais pour que ton absence se ressente" [Bob Marley]

Raspberry Pi 3 sur SSD, Wemos en pagaille, RFLink, Shelly 1 et Plug S, Gateway XIaomi et modules aqara

Avatar de l’utilisateur
ticed35
Actif
Messages : 1339
Inscription : 22 juil. 2014, 21:44
Localisation : Montréal

Re: [Plugin Tiers] Plugin Téléinfo

Message par ticed35 » 06 mars 2019, 17:44

@6co, ahh je comprend mieux. Je suppose que ton remora appelait l'api du plugin.
Depuis la version 4 celle-ci à changé (cf doc du plugin).
Dorénavant il faut également utiliser la clé api dédié au plugin et non la générale.
Présence / SonyBravia / Téléinfo

Répondre

Revenir vers « [Catégorie] Energie »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités