Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Raspberry pi 3 + Bluetooth

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Raspberry pi 3 + Bluetooth

Message par Naboleo » 23 oct. 2019, 19:52

Fabrice a écrit :
23 oct. 2019, 18:49
ARF,..

Non, c'est inexacte !

C'est bien l'installation des dépendances du plugin OpenZwave qui désactive le Bluetooth interne du PI3, PI3B, PI3B+ (depuis pas longtemps pour le PI3B+).

Bien que cela ne soit nécessaire QUE pour les cartes ZWave câblées sur le GPIO (comme les RAZBERRY), l'installation des dépendances du plugin OpenZwave de Jeedom détecte la présence des PI3x. Et quand l'une de ces cartes est détectées, il coupe directement HCIUART (qui à pour effet de désactiver le BT interne).

Tout cela est visible ligne 139 / 142 ici :
https://github.com/jeedom/plugin-openzw ... all_apt.sh
Tout à fait.*
C'est même à partir de la ligne 130 que ça commence avec la reconfiguration des ports serie
Personnellement je patche pour éviter les surprises...

Code : Tout sélectionner

--- /var/www/html/plugins/openzwave/resources/install_apt.sh	2019-09-20 19:36:16.923773844 +0200
+++ /var/www/html/plugins/openzwave/resources/install_apt.sh	2019-09-20 19:36:37.643404225 +0200
@@ -128,18 +128,18 @@
 fi
 
 if [ -e /dev/ttymxc0 ];  then 
-  sudo systemctl mask serial-getty@ttymxc0.service
-  sudo systemctl stop serial-getty@ttymxc0.service
+  //sudo systemctl mask serial-getty@ttymxc0.service
+  //sudo systemctl stop serial-getty@ttymxc0.service
 fi
 if [ -e /dev/ttyAMA0 ];  then 
-  sudo systemctl mask serial-getty@ttyAMA0.service
-  sudo systemctl stop serial-getty@ttyAMA0.service
+  //sudo systemctl mask serial-getty@ttyAMA0.service
+  //sudo systemctl stop serial-getty@ttyAMA0.service
 fi
 
 RPI_BOARD_REVISION=`grep Revision /proc/cpuinfo | cut -d: -f2 | tr -d " "`
 if [[ $RPI_BOARD_REVISION ==  "a02082" || $RPI_BOARD_REVISION == "a22082" || $RPI_BOARD_REVISION == "a020d3" ]]
 then
-   systemctl disable hciuart
+   //systemctl disable hciuart
    if [[ ! `grep "dtoverlay=pi3-miniuart-bt" /boot/config.txt` ]]
    then
       echo "Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth"
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

Flat
Timide
Messages : 13
Inscription : 17 mai 2017, 11:56

Re: Raspberry pi 3 + Bluetooth

Message par Flat » 25 oct. 2019, 14:24

Fabrice a écrit :
22 oct. 2019, 17:14
Bonjour,

Vous n'avez pas forcément besoin de le faire.

Sinon, en SSH, il faut ajouter la ligne :
dtoverlay=pi3-disable-bt
A la fin du fichier :
/boot/config.txt

- Redémarrez ensuite le Raspberry PI.
Bonjour Fabrice,
Je l'avais fait pour le wifi à l'époque mais pas pour le BT. Je viens de le faire.
Merci.
@+
Flat

Swr
Actif
Messages : 702
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Raspberry pi 3 + Bluetooth

Message par Swr » 25 oct. 2019, 23:15

Fabrice a écrit :ARF,..

Non, c'est inexacte !

C'est bien l'installation des dépendances du plugin OpenZwave qui désactive le Bluetooth interne du PI3, PI3B, PI3B+ (depuis pas longtemps pour le PI3B+).

Bien que cela ne soit nécessaire QUE pour les cartes ZWave câblées sur le GPIO (comme les RAZBERRY), l'installation des dépendances du plugin OpenZwave de Jeedom détecte la présence des PI3x. Et quand l'une de ces cartes est détectées, il coupe directement HCIUART (qui à pour effet de désactiver le BT interne).

Tout cela est visible ligne 139 / 142 ici :
https://github.com/jeedom/plugin-openzw ... all_apt.sh
Quid du pi4, faut il également couper le BT ?

Envoyé de mon Redmi Note 4 en utilisant Tapatalk


Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Raspberry pi 3 + Bluetooth

Message par Mips2648 » 26 oct. 2019, 09:30

Ok, mais il doit y avoir autre chose alors...
je n'ai jamais du faire de manip particulière et j'ai toujours eu zwave et bluetooth activé et le bluetooth n'a jamais été désactivé via quoi que ce soit.

et donc non il ne FAUT pas, apparemment, dans certain cas, le plugin le fait mais ce n'est pas nécessaire avec un dongle zwave.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3422
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Raspberry pi 3 + Bluetooth

Message par Fabrice » 26 oct. 2019, 23:37

C'est cela le problème, le plugin le fait systématiquement à la détection d'un PI de génération 3.
- Même pour ceux, qui comme nous, n'ont pas de module Z-Wave de branché sur le port GPIO.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Répondre

Revenir vers « Raspberry Pi »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité