Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Tuto] OpenMediaVault + Docker + Jeedom

qtb
Timide
Messages : 26
Inscription : 26 nov. 2018, 23:58

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par qtb » 27 nov. 2018, 03:54

Bonjour à tous,

Merci d'abord pour ce tuto qui m'a été très utile :)

L'installation est opérationnelle chez moi mais je suis moi aussi confronté à un soucis avec ma clé bluetooth.

j'arrive a me connecter en SSH a docker et à mon nas OMV via Putty

cependant, sur Jeedom, lorsque je tape le commande lsusb j'ai le message "Command not found"

En tout cas dans mon nas omv ma clé est bien reconnue

Merci

qtb
Timide
Messages : 26
Inscription : 26 nov. 2018, 23:58

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par qtb » 27 nov. 2018, 16:04

petit up !

Lorsque je me connecte à mon nas via Putty en SSH sur mon nas omv (<Mon IP> port 22)
je lance un lsusb et j'obtiens ceci :

Bus 002 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Lorsque je me connecte a mon docker Jeedom via Putty en SSH (<meme IP> port 9022)
lsusb ne se lance pas (bash: lsusb: command not found)

je tape donc dmesg :

[ 3.705595] usb 2-8: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 3.705596] usb 2-8: Product: CSR8510 A10

ma clé bluetooth est elle correctement reconnue ?

merci

bart70
Timide
Messages : 21
Inscription : 09 août 2015, 07:49

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par bart70 » 28 nov. 2018, 10:43

un grand merci pour ce tuto, quelques embuches (que je détaillerai après pour t'aider à améliorer encore éventuellement le tuto .. ou m'expliquer que je suis nul ;p ) j'ai un jeedom presque fonctionnel, j'ai restauré mon backup et là, le zwave m'embête :

Je n'arrive pas à installer la dépendance pour openzwave voici le log du plugin :

Lancement de l'installation/mise à jour des dépendances openzwave
Ign http://http.us.debian.org jessie InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://deb.debian.org jessie InRelease
Hit http://deb.debian.org jessie-updates InRelease
Hit http://http.us.debian.org jessie Release.gpg
Hit http://http.us.debian.org jessie Release
Hit http://deb.debian.org jessie Release.gpg
Hit http://deb.debian.org jessie Release
Get:1 http://security.debian.org jessie/updates/main amd64 Packages [781 kB]
Get:2 http://http.us.debian.org jessie/non-free amd64 Packages [101 kB]
Get:3 http://deb.debian.org jessie-updates/main amd64 Packages [23.0 kB]
Get:4 http://deb.debian.org jessie/main amd64 Packages [9098 kB]
Fetched 10.0 MB in 38s (257 kB/s)
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
gcc is already the newest version.
libjpeg-dev is already the newest version.
python-louie is already the newest version.
python-lxml is already the newest version.
make is already the newest version.
python-serial is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
python-setuptools is already the newest version.
python-pyudev is already the newest version.
python-requests is already the newest version.
libudev-dev is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
udev : Depends: libudev1 (= 215-17+deb8u5) but 215-17+deb8u8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
could not install git - abort

bart70
Timide
Messages : 21
Inscription : 09 août 2015, 07:49

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par bart70 » 28 nov. 2018, 20:57

laissez tomber (au cas où quelque un passe encore sur ce topic, visiblement, beaucoup de questions sont sans réponses, j'aurais du regarder avant) au reboot, le docker a perdu la conf ... je tente de passer sur un rasp 3

qtb
Timide
Messages : 26
Inscription : 26 nov. 2018, 23:58

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par qtb » 29 nov. 2018, 12:52

Salut bart70

Effectivement, le topic semble devenu peu actif...

je viens moi même d'installer Jeedom sur mon NAS OMV 4.1.13-1

pour ceux qui passerais par la :

j'ai eu quelques soucis à l'installation moi aussi notamment pour me connecter en "root" a MySQL (apparemment on ne peut plus facilement se connecter à MySQL en root depuis certaines M.A.J, le fait d'être sous OMV 4 pose soucis aussi)

Pour ceux qui tenterais l'opération aujourd'hui, il faut créer l'utilisateur "Jeedom" non pas en se connectant en "root" (ça ne marche pas même en modifiant le MDP via une commande SSH) mais en se connectant en 'omvadmin"

bart70 : Je suis Débutant en la matière mais tu semble avoir un soucis similaire au mien avec ta clé Zwave

Dans mon cas c'est ma clé bluetooth que je n'arrive pas à faire reconnaître par Jeedom...

Si tu regarde dans le topic, plusieurs utilisateurs ont eu des soucis similaires (p 2-3; p6; p9; p11)

j'ai créé un topic ailleurs pour essayer de régler mon soucis :

viewtopic.php?f=157&t=41048

Si jamais j'arrive à régler mon soucis, peut-être que les conseille qu'on me donne et qu'on me donneras te serons aussi utiles...

Si quelqu'un passe pas là et voudrais nous aider, ce serais sympa aussi d'y jeter un oeil :)

Merci

qtb
Timide
Messages : 26
Inscription : 26 nov. 2018, 23:58

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par qtb » 30 nov. 2018, 00:40

Petit up ici !

Je n'ai toujours pas trouvé de solution à mon problème...

Darknesse
Timide
Messages : 3
Inscription : 23 déc. 2018, 18:00

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par Darknesse » 28 déc. 2018, 20:55

Bonjour,

Pour moi tout c'est bien déroulé jusqu' a l'étape du mot de passe admin/admin dans Jeedom cela ne fonctionne pas.

https://screenshots.firefox.com/bvKp7OL ... 2.168.0.22

Savez-vous pourquoi ?

Darknesse
Timide
Messages : 3
Inscription : 23 déc. 2018, 18:00

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par Darknesse » 30 déc. 2018, 10:01

C'est bon problème résolut , il faillait juste mettre ADMIN en majuscule.

dax08drummer
Timide
Messages : 5
Inscription : 23 déc. 2018, 16:57

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par dax08drummer » 10 janv. 2019, 20:08

Bonjour Nibb31,

D'abord merci pour ton tuto sur l'installation de Jeedom via Docker sur OMV.

J'ai un problème le plugin Xiaomi Home, en effet, la Gateway Xiaomi fonctionne en broadcast, et l'installation en mode Bridge dans docker fait que le serveur Jeedom ne reçoit pas les requêtes de broadcast.
Peux tu m'aider pour faire en sorte que Jeedom soit dans le même sous-reseau que la Gateway.

PS : j'ai essayer de passer en mode "Host" en changeant le port d'ecoute d'Apache, mais ça ne fonctionne pas.

Avatar de l’utilisateur
nicoxygen
Timide
Messages : 81
Inscription : 10 juil. 2014, 18:19

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par nicoxygen » 16 janv. 2019, 23:33

salut dès que j'ai un peut de temps je vais faire un tuto complet sur l'install en host parceque ce tuto n'est plus à jour
1 Cubietruck | 1 Jeedom Mini + RFXcom | Clé Z-wave Aeotech gen 5 | 6 prises Intertechno | 1 sonde oregon | 1 station Netatmo | contacteur qubino | controleur snips |

dax08drummer
Timide
Messages : 5
Inscription : 23 déc. 2018, 16:57

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par dax08drummer » 17 janv. 2019, 23:14

Cool ! hâte de voir ça! en attendant tu n'a pas des indications a me donner

jeje66
Timide
Messages : 44
Inscription : 22 févr. 2019, 11:39

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par jeje66 » 22 févr. 2019, 19:18

Bonsoir à tous,

merci pour le tuto
j'ai Omv 4.1.19-1 (Arrakis)

ça fonctionne en local, installation de plugins, je vais chercher un actionneur sur ma eedomus ça fonctionne.
seul hic en https, impossble a y acceder, j'ai renseigné l'ip fixe de mon fai+ ouvert un port pour le https, rien à faire impossble à acceder à jeedom de l'extérieur

que faut il renseigner en ayant jeedom installé sur docker via omv?
Eedomus+/Rfplayer1000/Oregon/Chacon/Zwave/serveur G7 Hp 54L Omv 4 VirtualBox/Jeedom DIY

Amiddaru
Timide
Messages : 3
Inscription : 04 mars 2019, 10:05

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par Amiddaru » 04 mars 2019, 10:15

Alors j'ai bien suivi le tuto, j'ai bien lutté pour la partie Mysql :? mais j'ai finalement réussi.

Par contre, sous le plugin Docker, quand j'essaye de Pull l'image, il télécharge tout et à la fin l'image ne se retrouve pas dans la liste.

En invite de commande quand j'essaye manuellement avec docker pull jeedom/jeedom, je me retrouve avec un message d'erreur en fin de téléchargement :
Docker failed to register layer : Symlink [...] Operation Not permitted

J'ai bien regardé, le dossier root docker est bien celui créé avant. :?:

Omv version 4 en tout cas

neeqkowlah
Timide
Messages : 4
Inscription : 31 mai 2018, 22:05

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par neeqkowlah » 02 avr. 2019, 17:18

moi j'ai le probleme du demon qui ne se lance pas, mais pour une raison que je ne trouve nullepart ailleurs

Code : Tout sélectionner

2019-04-02 17:01:00][INFO] : Début d'activation du plugin
[2019-04-02 17:01:01][INFO] : Info sur le démon : Array (     [state] => nok     [launchable] => nok     [launchable_message] => Gestion automatique désactivée     [log] =>      [auto] => 0     [last_launch] => Inconnue )
[2019-04-02 17:01:01][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php  plugin_id=openzwave function=install callInstallFunction=1
[2019-04-02 17:10:08][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device /dev/ttyACM0 --loglevel debug --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback http://127.0.0.1:80/plugins/openzwave/core/php/jeeZwave.php --apikey glwVa5JP3YYePjmVWQtkXYeyp1BsPmSd --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
('The dependency of openzwave plugin are not installed. Please check the plugin openzwave configuration page for instructions', 'error')
('Error: invalid syntax (web.py, line 205)', 'error')
[2019-04-02 17:10:40][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log
les indicateurs sont tous au vert, les dependances semblent etre installées, seul le demon ne veut pas se lancer. j'ai bien choisi /dev/ttyACM0, j'ai meme ajouté un mapping dans la conf docker de /dev/ttyACM0 vers /dev/ttyACM0 comme certains semblent avoir fait, mais rien n'y fait. Ce serait super si quelqu'un pouvait m'aider.
Merci

OMV3 + docker + jeedom + zwave

didav81
Timide
Messages : 1
Inscription : 10 avr. 2019, 23:24

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par didav81 » 10 avr. 2019, 23:53

nicoxygen a écrit :salut dès que j'ai un peut de temps je vais faire un tuto complet sur l'install en host parceque ce tuto n'est plus à jour
Salut, si tu te motives pour faire le tuto en Host, je suis preneur. Je galère à essayer d'installer les dépendances de mon plugin Xiaomi.

Envoyé de mon BLN-AL10 en utilisant Tapatalk


Keisarr
Timide
Messages : 9
Inscription : 16 sept. 2019, 18:51

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par Keisarr » 16 sept. 2019, 19:23

Bonjour,

J'ai suivit le tutoriel à la lettre en revanche j'ai une vilaine erreur :
standard_init_linux.go:211: exec user process caused "exec format error"
D'après ce que je comprends sur les différents forum on a ce genre d'erreur quand les architecture ne sont pas compatible. Mais ici je fais tourner ça sur un rock 64 et l'archi de Jeedom est amd64 donc ça doit marcher...

J'ai d'autres conteneurs qui fonctionnent sans problèmes.

Une idée du problème ?

Keisarr
Timide
Messages : 9
Inscription : 16 sept. 2019, 18:51

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par Keisarr » 17 sept. 2019, 16:03

J'ai trouvé la réponse, en fait le rock64 n'a pas la bonne architecture - pas possible alors.

MrVince
Timide
Messages : 173
Inscription : 11 sept. 2017, 15:22

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par MrVince » 15 oct. 2019, 14:56

Bonjour,

J'ai suivi ce tuto sympathique il y a de cela plusieurs mois, et tout se passait bien !

J'ai recommencé cette fois ci apres avoir mis a jour mon systeme sous Stretch Debian 9 et maintenant j'ai un soucis avec le plugin Homebridge que je n'avais pas jusqu'ici.

Lorsque je lance le daemon, j'ai l'erreur suivante :

Code : Tout sélectionner

sh: 1: /var/www/html/plugins/homebridge/core/class/../../resources/node_modules/homebridge/bin/homebridge: Permission denied
Je precise que j'ai lancé mon Jeedom en mode Host avec les droits privilégiés.

Ma demande fait suite à ce post dans le plugin Homebridge :
viewtopic.php?f=188&t=48022

Je suis coincé uniquement avec ce plugin depuis plusieurs jours, et je ne sais plus quoi faire. Merci à ceux qui auront pris le temps de me lire
NAS HP Proliant - OpenMediaVault - Jeedom Docker
Raspberry Pi 3 - MagicMirror
Prusa i3

Capteurs MySensors / Xiaomi / Éclairage Ikea Tradfri
SmarterCoffee / Chromecast & Google Home / Thermostat Netatmo

neeqkowlah
Timide
Messages : 4
Inscription : 31 mai 2018, 22:05

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par neeqkowlah » 07 nov. 2019, 17:17

Bonjour,
quelqu'un a t'il essayé d'installé jeedom sur openmediavault 4 (debian 9) sans passer par docker ?
Qu'elle peuvent être les conséquences ?
si me souvenirs sont bons, j'avais essayé de le faire via docker mais il m’était impossible de détecter ma clé zwave :o(
Un grand merci

MrVince
Timide
Messages : 173
Inscription : 11 sept. 2017, 15:22

Re: [Tuto] OpenMediaVault + Docker + Jeedom

Message par MrVince » 13 nov. 2019, 23:11

Bonjour,

Il y a plusieurs messages sur le forum concernant l'ajout de clé zwave avec docker. C'est possible sans trop de soucis

Je pense qu'il peut y avoir un soucis avec l'interface web de omv4 et de jeedom au niveau du apache/nginx si install sans docker
NAS HP Proliant - OpenMediaVault - Jeedom Docker
Raspberry Pi 3 - MagicMirror
Prusa i3

Capteurs MySensors / Xiaomi / Éclairage Ikea Tradfri
SmarterCoffee / Chromecast & Google Home / Thermostat Netatmo

Répondre

Revenir vers « Docker »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité