Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[RESOLU] OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Répondre
seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

[RESOLU] OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 14 août 2017, 20:35

Bonjour,

Tout nouveau sur JEEDOM, je posséde déjà depuis quelques mois un serveur à la maison sur lequel j'ai installé Openmediavault (solution opensource pour NAS).

Cela remplit pleinement mes besoins de stockage mais je voulais rajouter des fonctionnalités et me suis tourné vers le monde de la domotique.

Après un rapide passage sous Domoticz je me suis tourné vers Jeedom que j'apprécie tout particulièrement.

Sur OMV j'ai installé Jeedom dans un container Docker et ce matin aprés redémarrage de mon serveur j'ai perdu l'accès à Jeedom.

J'ai redémarré le container Docker mais rien n'y fait, le container est "running" mais plus de Jeedom :( .

Si une ame charitable peut m'aider ?
Dernière édition par seda38200 le 02 déc. 2017, 08:59, édité 1 fois.

Avatar de l’utilisateur
magicgg91
Actif
Messages : 10023
Inscription : 09 août 2014, 12:15
Localisation : Région Parisienne
Contact :

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par magicgg91 » 14 août 2017, 20:37

Bonjour

J'ai déplacé dans la bonne section
DomoPi - Mon site dédié au Raspberry Pi et à la domotique

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 14 août 2017, 20:41

Merci

Avatar de l’utilisateur
slobberbone
Actif
Messages : 2692
Inscription : 25 juin 2014, 12:34
Localisation : Caen

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par slobberbone » 14 août 2017, 21:20

Sur ton conteneur, nginx ou apache est bien démarré ? Les portes ne sont ils pas déjà pris part un autre process ou conteneur ?
Docker est il bien démarré ?

Envoyé de mon D6503 en utilisant Tapatalk

Présentation, Rénovation, JeedomBox : https://www.jeedom.fr/forum/viewtopic.php?f=50&t=11339
Mes plugins/widgets : viewtopic.php?f=50&t=11339#p214011

Avatar de l’utilisateur
Nibb31
Actif
Messages : 2137
Inscription : 17 févr. 2015, 15:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par Nibb31 » 14 août 2017, 22:23

Que dit le log du container?
Jeedom: VM ProxMox sur HP Microserver N54L
Z-wave: Z-stick Aeonlabs S2
433MHz: RFXCom433E
Hue

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 11:02

Nibb31 a écrit :
14 août 2017, 22:23
Que dit le log du container?
Aucune idée, comment accéde-t-on aux logs ? (je suis complétement newbie sur docker :-( )

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 11:07

slobberbone a écrit :
14 août 2017, 21:20
Sur ton conteneur, nginx ou apache est bien démarré ? Les portes ne sont ils pas déjà pris part un autre process ou conteneur ?
Docker est il bien démarré ?

Envoyé de mon D6503 en utilisant Tapatalk
A priori le container tourne, voici ce que me retourne la commande docker ps :

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
287af40860a1 jeedom/jeedom:latest "/root/init.sh" 14 hours ago Up 13 hours 0.0.0.0:9022->22/tcp, 0.0.0.0:9080->80/tcp jeedom

Pour NGINX ou Apache je ne sais pas comment vérifier sur docker :-(.

Pour les ports, dans le doute, je vais les changer mais à priori rien ne tourne sur ces ports.

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 11:14

Bon finalement le changement de port m'a permis de réaccéder temprairement à Jeedom, car après redémarrage du serveur même combat je n'y ai plus accés.
Dernière édition par seda38200 le 15 août 2017, 11:41, édité 1 fois.

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 11:25

Finalement pour les logs du container voila ce que me donne la commande docker logs jeedom :

Start init
Jeedom is already install
All init complete
/usr/lib/python2.7/dist-packages/supervisor/options.py:296: UserWarning: Supervisord is running as root and it is searching for its configuration file in default locations (including its current working directory); you probably want to specify a "-c" argument specifying an absolute path to a configuration file for improved security.
'Supervisord is running as root and it is searching '
2017-08-15 11:16:18,068 CRIT Supervisor running as root (no user in config file)
2017-08-15 11:16:18,068 WARN Included extra file "/etc/supervisor/conf.d/supervisord.conf" during parsing
2017-08-15 11:16:18,078 INFO RPC interface 'supervisor' initialized
2017-08-15 11:16:18,079 CRIT Server 'unix_http_server' running without any HTTP authentication checking
2017-08-15 11:16:18,079 INFO supervisord started with pid 13
2017-08-15 11:16:19,081 INFO spawned: 'cron' with pid 16
2017-08-15 11:16:19,082 INFO spawned: 'sshd' with pid 17
2017-08-15 11:16:19,083 INFO spawned: 'apache2' with pid 18
2017-08-15 11:16:20,270 INFO success: cron entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-15 11:16:20,270 INFO success: sshd entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-15 11:16:20,270 INFO success: apache2 entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
Start init
Jeedom is already install
All init complete
/usr/lib/python2.7/dist-packages/supervisor/options.py:296: UserWarning: Supervisord is running as root and it is searching for its configuration file in default locations (including its current working directory); you probably want to specify a "-c" argument specifying an absolute path to a configuration file for improved security.
'Supervisord is running as root and it is searching '
2017-08-15 11:20:42,345 CRIT Supervisor running as root (no user in config file)
2017-08-15 11:20:42,360 WARN Included extra file "/etc/supervisor/conf.d/supervisord.conf" during parsing
Unlinking stale socket /var/run/supervisor.sock
2017-08-15 11:20:42,931 INFO RPC interface 'supervisor' initialized
2017-08-15 11:20:42,931 CRIT Server 'unix_http_server' running without any HTTP authentication checking
2017-08-15 11:20:42,931 INFO supervisord started with pid 14
2017-08-15 11:20:43,933 INFO spawned: 'cron' with pid 17
2017-08-15 11:20:43,934 INFO spawned: 'sshd' with pid 18
2017-08-15 11:20:43,935 INFO spawned: 'apache2' with pid 19
2017-08-15 11:20:44,936 INFO success: cron entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-15 11:20:44,936 INFO success: sshd entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-15 11:20:44,936 INFO success: apache2 entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-15 11:20:46,326 INFO exited: apache2 (exit status 0; expected)

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 18:45

Bon je pense avoir solutionné le souci :

J'ai modifié le container à partir de l'interface du plugin Docker et dans la partie "Volumes& bind mounts" et sur la ligne Host path/container path j'ai activé l'option R/O.

Aprés redémarrage l'accés est toujours là mais je ne sais pas quelle est cette option R/O.

Si quelqu'un sait ?

J'aime bien comprendre les choses :-)

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 18:50

Fausse joie, j'ai bien accés à Jeedom par contre il reste bloqué sur "JEEDOM est en cours de démarrage veuillez patienter ...." et j'ai des erreurs à chaque action du type :

Error on shell exec, return value : 1. Details : Array ( [0] => )

Je file de ce peu désactiver cette option R/O :-(

Avatar de l’utilisateur
magicgg91
Actif
Messages : 10023
Inscription : 09 août 2014, 12:15
Localisation : Région Parisienne
Contact :

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par magicgg91 » 15 août 2017, 19:06

ah bah oui ....
Si Jeedom ne peut rien écrire, ça ne fonctionnera pas !
DomoPi - Mon site dédié au Raspberry Pi et à la domotique

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 15 août 2017, 19:13

J'ai bien vu oui :-)

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 17 août 2017, 18:56

SOS, nobody to help me ? :-(

Avatar de l’utilisateur
slobberbone
Actif
Messages : 2692
Inscription : 25 juin 2014, 12:34
Localisation : Caen

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par slobberbone » 13 sept. 2017, 15:11

seda38200 a écrit :
17 août 2017, 18:56
SOS, nobody to help me ? :-(
Bah R/O ca veut dire Read Only ... alors effectivement ...
Présentation, Rénovation, JeedomBox : https://www.jeedom.fr/forum/viewtopic.php?f=50&t=11339
Mes plugins/widgets : viewtopic.php?f=50&t=11339#p214011

seda38200
Timide
Messages : 19
Inscription : 14 août 2017, 20:29

Re: OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par seda38200 » 02 déc. 2017, 08:58

Je me suis débrouillé et tout est Ok aujourd'hui

Avatar de l’utilisateur
Nibb31
Actif
Messages : 2137
Inscription : 17 févr. 2015, 15:29

Re: [RESOLU] OMV + JEEDOM : plus d'accés aprés redémarrage openmediavault

Message par Nibb31 » 02 déc. 2017, 09:46

On est ravis de l'apprendre 4 mois plus tard ;)
Jeedom: VM ProxMox sur HP Microserver N54L
Z-wave: Z-stick Aeonlabs S2
433MHz: RFXCom433E
Hue

Répondre

Revenir vers « Docker »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité