Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Plugin blea

Swr
Timide
Messages : 242
Inscription : 08 nov. 2016, 20:56

Re: Plugin blea

Message par Swr » 07 sept. 2017, 18:46

raphael_malin a écrit :
04 sept. 2017, 21:59
Swr a écrit :
03 sept. 2017, 19:22
J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide
Hello, j'ai ouvert un ticket pour ce problème:
Réponse de l'équipe:
Bonjour, Il vous manque probablement des paquets.
pourriez vous lancer un sudo pip install requests
merci
Cordialement,​


Et depuis cela fonctionne!! 8-)
Un grand merci, c'est parfait...le «coeur bat » à nouveau

raphael_malin
Timide
Messages : 302
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: Plugin blea

Message par raphael_malin » 07 sept. 2017, 23:13

J'ai parfois des déconnexions.
Comment puis-je surveiller que le démon est bien actif?
Comment puis-je attaquer par un scénario le bouton "Lancer"?
L'idée c'est si cela se désactive, que je puisse le relancer de manière automatique après X min par exemple.

J'ai eu aussi le problème de l'état présent/absent qui bascule toutes les 3 minutes, exclusion/inclusion résout le problème.
Je voudrais savoir ou se trouve l'automatisme qui dit que si y'a du signal, présent passe sur présent ? je ne le trouve pas.

Merci

Swr
Timide
Messages : 242
Inscription : 08 nov. 2016, 20:56

Re: Plugin blea

Message par Swr » 08 sept. 2017, 22:36

Je viens de découvrir le module ESP32 qui intègre un BT LE et interface wifi, est il possible de l'utiliser en antenne?

Avatar de l’utilisateur
Theduck38
Actif
Messages : 1396
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 09 sept. 2017, 01:08

Peu de chances qu'il ait un linux embarqué...
-- TD38 --
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom - Rfxcom Rfxtrx433 - Clef Sigma UZB 'Z-wave plus'
Mon matériel en détails

DenisPac
Actif
Messages : 1165
Inscription : 14 août 2014, 13:25
Localisation : Près d'Orléans (45)

Re: Plugin blea

Message par DenisPac » 09 sept. 2017, 20:37

Swr a écrit :
07 sept. 2017, 18:46
raphael_malin a écrit :
04 sept. 2017, 21:59
Swr a écrit :
03 sept. 2017, 19:22
J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide
Hello, j'ai ouvert un ticket pour ce problème:
Réponse de l'équipe:
Bonjour, Il vous manque probablement des paquets.
pourriez vous lancer un sudo pip install requests
merci
Cordialement,​


Et depuis cela fonctionne!! 8-)
Un grand merci, c'est parfait...le «coeur bat » à nouveau
Bonsoir,
J'ai eu la même erreur sur une nouvelle antenne (Rasbian Stretch) avec SqeezeLite.
Et la commande

Code : Tout sélectionner

sudo pip install requests
a également résolu le problème.
Merci !
Jeedom Maître sur VM Debian sur ESXi (N54L) + Z-Stick 2 (non fonctionnel) + RFXCOM
Jeedom déporté Z-Wave sur Jeedom mini avec JeeLink
Antenne RPI3 BLEA, Netatmo, Philips Hue, Xiaomi Home, Yeelight, Dash Button, ...

thouve
Timide
Messages : 118
Inscription : 21 oct. 2016, 19:30

Re: Plugin blea

Message par thouve » 10 sept. 2017, 01:15

thouve a écrit :
04 sept. 2017, 17:34
Salut a tous, j'ai un petit soucis avec BLEA.
Depuis mon retour de vacance,le demon ne veut plus ce lancer.
La configuration est bien sur ok mais le statuts reste NOK.
Dans la configuration mon dongle BT est toujours présent et sélectionné mais rien n'y fait.
Voici une copi des logs debug en essayant d'activer manuellement le demon :

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0
Je suis sous RPi 3 si jamais.

Merci d'avance pour votre aide
Personne? :(

yves273
Timide
Messages : 230
Inscription : 18 janv. 2016, 11:13

Re: Plugin blea

Message par yves273 » 10 sept. 2017, 08:47

Bonjour,

J'ai des boutons ticatag avec smart v3 (Je les ai mis côte à côte) marqué comme non présent dans le widget.
L'onglet santé donne une dernière communication soit récente (moins de 15mn), ils sont marqués comme non présent dans l'onglet santé.
Est-ce qu'il y a une explication?

vincecoco
Actif
Messages : 939
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 11 sept. 2017, 14:07

Hello,
Quelqu'un a-t-il tester l'installation d'Antenne sur un PiCorePlayer ?

Merci

Avatar de l’utilisateur
Theduck38
Actif
Messages : 1396
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 11 sept. 2017, 21:23

Hello,

On en a parlé un peu plus haut... à priori ce n'est pas possible car on ne peut pas installer de manière simple un package sur PiCore.
-- TD38 --
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom - Rfxcom Rfxtrx433 - Clef Sigma UZB 'Z-wave plus'
Mon matériel en détails

vincecoco
Actif
Messages : 939
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 11 sept. 2017, 23:37

J'ai regardé bon peut installer via tcz-load -wi ou depuis l'interface web.
Il reste à trouver tous les paquets nécessaire.
J'ai déjà mis bluetooth et bluez hcidump mais il manque des trucs

vincecoco
Actif
Messages : 939
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 12 sept. 2017, 15:30

*Hello,
J'ai tenté d'installé une antenne sur mon PI2 OSMC
- Envoie des fichiers : OK
- Installation des dépendances : OK
- Lancement du démon KO

Code : Tout sélectionner

Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Auriez vous une idée, je n'ai rien trouvé lors de ma recherche :)


[Edit] J'ai voulu redémarrer osmc mais à présent plus moyen de monter le BT

Code : Tout sélectionner

 sudo hciconfig hci0 up
Can't init device hci0: Operation not possible due to RF-kill (132)
Il faut installer rfkill d'après ce que j'ai compris ? (Si quelqu'un peut me confirmer merci)

[Edit 2] Pour ne pas avoir ce message je dois mettre la clef, apres démarrage du PI....

Merci bcp

Avatar de l’utilisateur
cadavor
Actif
Messages : 992
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Plugin blea

Message par cadavor » 13 sept. 2017, 16:18

vincecoco a écrit :
12 sept. 2017, 15:30
*Hello,
J'ai tenté d'installé une antenne sur mon PI2 OSMC
- Envoie des fichiers : OK
- Installation des dépendances : OK
- Lancement du démon KO

Code : Tout sélectionner

Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Auriez vous une idée, je n'ai rien trouvé lors de ma recherche :)


[Edit] J'ai voulu redémarrer osmc mais à présent plus moyen de monter le BT

Code : Tout sélectionner

 sudo hciconfig hci0 up
Can't init device hci0: Operation not possible due to RF-kill (132)
Il faut installer rfkill d'après ce que j'ai compris ? (Si quelqu'un peut me confirmer merci)

[Edit 2] Pour ne pas avoir ce message je dois mettre la clef, apres démarrage du PI....

Merci bcp
Le probleme de RF-kill a déja été evoqué il me semble, sinon une petite recherche google...
https://www.google.fr/search?q=raspberr ... e&ie=UTF-8
:arrow: https://raspberrypi.stackexchange.com/q ... oesnt-work
Jeedom Stable 3.0.11
Rpi3 + SSD 120Go + Aeotec Z-Stick Gen5 + Inateck dongle BLE
Zwave FGMS-001 + FGDS-002 + FGFS-101 + FGK-101 + FGWPE-101
Orvibo AllOne + Playbulb + Miband2 + Mini-enceinte Jack (TTS)

vincecoco
Actif
Messages : 939
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 13 sept. 2017, 16:46

Yep ca confirme bien ce que l'avais vu merci :)

Sinon en checkant les logs directement depuis osmc, je constate que les dépendances ne ce sont pas correctement installées, malgré le all is sucessfull :)

Il faudrait que j'active le root, mais impossible d'activer le root sur osmc malgré l'ajout d'un mot de passe et la modification du fichier sshf_config

++

Avatar de l’utilisateur
cadavor
Actif
Messages : 992
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Plugin blea

Message par cadavor » 13 sept. 2017, 21:07

vincecoco a écrit :
13 sept. 2017, 16:46
Yep ca confirme bien ce que l'avais vu merci :)

Sinon en checkant les logs directement depuis osmc, je constate que les dépendances ne ce sont pas correctement installées, malgré le all is sucessfull :)

Il faudrait que j'active le root, mais impossible d'activer le root sur osmc malgré l'ajout d'un mot de passe et la modification du fichier sshf_config

++
Pour OSMC, la réponse est aussi dans le fil...Il faut lancer le script d'install manuellement par SSH.
Jeedom Stable 3.0.11
Rpi3 + SSD 120Go + Aeotec Z-Stick Gen5 + Inateck dongle BLE
Zwave FGMS-001 + FGDS-002 + FGFS-101 + FGK-101 + FGWPE-101
Orvibo AllOne + Playbulb + Miband2 + Mini-enceinte Jack (TTS)

Avatar de l’utilisateur
Theduck38
Actif
Messages : 1396
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 13 sept. 2017, 21:15

vincecoco a écrit :
11 sept. 2017, 23:37
J'ai regardé bon peut installer via tcz-load -wi ou depuis l'interface web.
Il reste à trouver tous les paquets nécessaire.
J'ai déjà mis bluetooth et bluez hcidump mais il manque des trucs
Hello,

Si tu y arrives, ça m'intéresse d'avoir quelques explications ! Je n'ai pas une connaissance suffisante de tinycore pour trouver comment faire, du coup j'étais passé sur M2Play pour pouvoir avancer dans le multiroom...
-- TD38 --
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom - Rfxcom Rfxtrx433 - Clef Sigma UZB 'Z-wave plus'
Mon matériel en détails

vincecoco
Actif
Messages : 939
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 13 sept. 2017, 21:44

cadavor a écrit :
13 sept. 2017, 21:07
vincecoco a écrit :
13 sept. 2017, 16:46
Yep ca confirme bien ce que l'avais vu merci :)

Sinon en checkant les logs directement depuis osmc, je constate que les dépendances ne ce sont pas correctement installées, malgré le all is sucessfull :)

Il faudrait que j'active le root, mais impossible d'activer le root sur osmc malgré l'ajout d'un mot de passe et la modification du fichier sshf_config

++
Pour OSMC, la réponse est aussi dans le fil...Il faut lancer le script d'install manuellement par SSH.
Merci je vais tester, j'ai pourtant chercher.
J'ai compris pourquoi ma recherche n'a pas fonctionné, (Double recherche...)

chrislam86
Timide
Messages : 187
Inscription : 19 janv. 2016, 23:16

Re: Plugin blea

Message par chrislam86 » 14 sept. 2017, 23:18

Bonjour,
le Qilive Tracker for key est il supporté?

http://www.qilive.com/sites/default/fil ... or_key.pdf
Cordialement
DIY Asus N3150I-C, Kingston 4Go DDR3, SSD Sandisk 64Go,Antec ISK 110,Debian Jessie 64 bits, Zwave Sigma + RFXCom USB 433E.

Thyer
Timide
Messages : 95
Inscription : 30 mai 2017, 09:51
Localisation : Lorraine

Re: Plugin blea

Message par Thyer » 14 sept. 2017, 23:26

Salut,
j'ai aussi un Qlive, il faut Autoriser l'inclusion de devices inconnus pour l'inclure dans BLEA.
Il fonctionne parfaitement, c'est pas le meilleur des trackers (qualité du plastique) mais sinon dans un sac ou autre, il fait le boulot ;)

chrislam86
Timide
Messages : 187
Inscription : 19 janv. 2016, 23:16

Re: Plugin blea

Message par chrislam86 » 14 sept. 2017, 23:50

merci ca marche!!!
DIY Asus N3150I-C, Kingston 4Go DDR3, SSD Sandisk 64Go,Antec ISK 110,Debian Jessie 64 bits, Zwave Sigma + RFXCom USB 433E.

thouve
Timide
Messages : 118
Inscription : 21 oct. 2016, 19:30

Re: Plugin blea

Message par thouve » 17 sept. 2017, 22:41

thouve a écrit :
10 sept. 2017, 01:15
thouve a écrit :
04 sept. 2017, 17:34
Salut a tous, j'ai un petit soucis avec BLEA.
Depuis mon retour de vacance,le demon ne veut plus ce lancer.
La configuration est bien sur ok mais le statuts reste NOK.
Dans la configuration mon dongle BT est toujours présent et sélectionné mais rien n'y fait.
Voici une copi des logs debug en essayant d'activer manuellement le demon :

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0
Je suis sous RPi 3 si jamais.

Merci d'avance pour votre aide
Personne? :(
????

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité