Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

Plugin blea

Mips2648
Actif
Messages : 861
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 31 juil. 2019, 16:09

DuplO a écrit :
31 juil. 2019, 15:53
Il n'y a pas de changement.

Mes configurations sont les suivantes :
Equipement Miflora :
Salut,
J'en ai plusieurs et exceptionnellement (genre 1 tous les 6 mois max) cela arrive qu'un déconne et n’envoie plus rien.
Jusqu'à présent, je me connecte avec l'app "flower care" (smartphone) et ca les "débloque";

juste une info... mais je n'explique pas :)
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Mips2648
Actif
Messages : 861
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 31 juil. 2019, 16:13

stanthewizzard a écrit :
31 juil. 2019, 15:54
MIPS je veux bien de ton aide là

j'ai fais tout ce que tu suggérais de reboot du RASP etc

et voilà ce que j'ai au bout d'un moment :(

MERCI pour ton aide
Le log remonte pas mal d'erreur encore effectivement mais globalement cela à l'air plus stable non? tu parlais de chaque minute et là ca tient 30min
es-tu sur que l'installation des dépendances était finie? as-tu le log?
tu peux faire aussi un update (sudo apt-get update / sudo apt-get upgrade) de ton pi antenne si tu ne l'as pas fait depuis longtemps, tourne-t-il sous jessie ou stretch?
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

stanthewizzard
Timide
Messages : 451
Inscription : 26 oct. 2015, 13:46

Re: Plugin blea

Message par stanthewizzard » 31 juil. 2019, 16:51

Merci MIPS

oui j'ai fait l'install de dependances en ligne de commande.
elle tourne sous stretch
et deja fait

:(

Mips2648
Actif
Messages : 861
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 31 juil. 2019, 17:31

Mais donc ca crash encore souvent ?
En tout cas tes devices bluetooth sont captés.

En l'état je ne sais pas expliquer ces entrées, faudrait vérifier avec le code; mais ce sont des logs "info"; je ne sais meme pas dire si je ce meme comportement (3 antennes sur pi) car j'ai le log level en warning chez moi
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

stanthewizzard
Timide
Messages : 451
Inscription : 26 oct. 2015, 13:46

Re: Plugin blea

Message par stanthewizzard » 31 juil. 2019, 17:46

oui assez je trouve
oui ils sont vu puis plus vu

Merci :)

Avatar de l’utilisateur
iPapy
Timide
Messages : 253
Inscription : 12 mars 2017, 16:58
Localisation : Bobigny

Re: Plugin blea

Message par iPapy » 31 juil. 2019, 18:36

Bonsoir à tous,

Depuis 2 mis à jour j'ai mon MiFlora qui ne me remonte plus ni son niveau de pile, ni sa version de firmware sur mon Jeedom de prod à base d'un Pi 3B+ alors que sur mon Pi 3B de test ces informations remonte bien comme sur les copies ci-dessous.

Pi 3B+
Capture.PNG
Capture.PNG (4.9 Kio) Consulté 377 fois
Pi 3B
Capture1.PNG
Capture1.PNG (39.04 Kio) Consulté 377 fois
J'ai la même version de stretch sur les deux Pi, update de stretch à jour sur les deux et même version de Jeedom (3.3.29).

Auriez vous un idée d’où cela peu provenir?

Merci d'avance pour vos réponses.

Avatar de l’utilisateur
Poumi
Actif
Messages : 578
Inscription : 21 mars 2019, 22:41

Re: Plugin blea

Message par Poumi » 31 juil. 2019, 18:38

Avec l’advertizing, le miflora ne remonte le niveau de batterie que lorsqu’elle change. Aucune idée de quand le firmware est remonté par contre...

Avatar de l’utilisateur
iPapy
Timide
Messages : 253
Inscription : 12 mars 2017, 16:58
Localisation : Bobigny

Re: Plugin blea

Message par iPapy » 31 juil. 2019, 21:02

Poumi a écrit :
31 juil. 2019, 18:38
Avec l’advertizing, le miflora ne remonte le niveau de batterie que lorsqu’elle change. Aucune idée de quand le firmware est remonté par contre...
D'accord Poumi mais cela n'explique pas pourquoi sur le Pi3b+ il est à 0% alors que sur le Pi3b à 99% les valeurs devraient être identique entre les deux normalement et que les autres valeurs sont bien identiques sur les 2 Pi, surtout qu'il y a encore 2 mise à jour si mes souvenirs sont bon j'avais et la valeur de la pile et la version du Firmware sur le Pi3B+

J'ai même testé par curiosité le plugin MiFlora en supprimant mon MiFlora de Blea, sur le Pi3 il marchouille car parfois l'actualisation toutes les heures ne se fait pas alors que sur le Pi3b+ il ne s'actualise pas du tout avec pour message "Firmware MiFlora inconnue: [Entrée][Ficus]"

La différence que j'ai vu par rapport à un Miflora d'un ami, le siens est blanc alors que le miens est vert pâle et la MAC du miens est la suivante C4:7C:8D:6B:01:09.

Avatar de l’utilisateur
Poumi
Actif
Messages : 578
Inscription : 21 mars 2019, 22:41

Re: Plugin blea

Message par Poumi » 31 juil. 2019, 21:13

Les mien sont vert pale et ont le même firmware que le tien, donc le problème n’est pas là.

Tu utilise uniquement l’advertizing ou tu as mis le refresh forcé?

Pour la batterie, un seul de mes 22 miflora m’a envoyé une mise à jour depuis que j’ai fait l’update il y a 2 semaines. Mais j’avais eu l’explication de celui qui a mis en place l’advertizing que c’etait envoyé sur mise à jour.

Peut-être que c’est lié au fait que tu as 2 jeedom qui écoutent le même miflora. (Pas sûr que l’advertizing marche bien dans ce cas, je n’ai pas testé)

benj29
Actif
Messages : 3864
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 31 juil. 2019, 21:59

La mise à jour de ce soir pour le dotti ne semble pas incrémenter le démon en 2.6.3.
Sauf erreur ?

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3314
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 31 juil. 2019, 22:02

Non c'est vrais.
- Le deamon ne doit pas voir de lien avec la configuration des modules.
Helper Officiel Jeedom
- Jeedom : 3.3.31
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

benj29
Actif
Messages : 3864
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 31 juil. 2019, 23:06

OK, je voulais juste être sûr. Chose faite. Merci. N'ayant plus de dotti.... Intérêt limité pour moi.

Envoyé de mon JSN-L21 en utilisant Tapatalk


Avatar de l’utilisateur
DuplO
Actif
Messages : 714
Inscription : 17 sept. 2015, 14:04

Re: Plugin blea

Message par DuplO » 01 août 2019, 07:57

Mips2648 a écrit :
31 juil. 2019, 16:09
DuplO a écrit :
31 juil. 2019, 15:53
Il n'y a pas de changement.

Mes configurations sont les suivantes :
Equipement Miflora :
Salut,
J'en ai plusieurs et exceptionnellement (genre 1 tous les 6 mois max) cela arrive qu'un déconne et n’envoie plus rien.
Jusqu'à présent, je me connecte avec l'app "flower care" (smartphone) et ca les "débloque";

juste une info... mais je n'explique pas :)
Hello,

Mon miflora n est connecté à aucune appli.
Je ne l ai connecté qu a jeedom.

stanthewizzard
Timide
Messages : 451
Inscription : 26 oct. 2015, 13:46

Re: Plugin blea

Message par stanthewizzard » 01 août 2019, 08:26

@mips

Tellement eu ras le bol
J’ai fait sur un rasp plus recent en stretch un jeedom
Blea et link

Ca a l’air de fonctionner nickel

Mips2648
Actif
Messages : 861
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 01 août 2019, 09:17

stanthewizzard a écrit :
01 août 2019, 08:26
@mips

Tellement eu ras le bol
J’ai fait sur un rasp plus recent en stretch un jeedom
Blea et link

Ca a l’air de fonctionner nickel
ok, mais je pensais que ton antenne etait déjà en stretch ... :roll:
le principal c'est que cela fonctionne
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Mips2648
Actif
Messages : 861
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 01 août 2019, 09:18

DuplO a écrit :
01 août 2019, 07:57
Hello,

Mon miflora n est connecté à aucune appli.
Je ne l ai connecté qu a jeedom.
en soit ils ne sont jamais "connectés", mais avec l'appli tu peux lire les memes données

je ne l'utilise pas réellement par contre, lancer l'appli et lire la sonde me la déjà "débloquée" sous jeedom (quand elle a l'air de ne plus rien envoyer)
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
DuplO
Actif
Messages : 714
Inscription : 17 sept. 2015, 14:04

Re: Plugin blea

Message par DuplO » 01 août 2019, 10:24

Mips2648 a écrit :
01 août 2019, 09:18

en soit ils ne sont jamais "connectés", mais avec l'appli tu peux lire les memes données

je ne l'utilise pas réellement par contre, lancer l'appli et lire la sonde me la déjà "débloquée" sous jeedom (quand elle a l'air de ne plus rien envoyer)
Merci, je vais essayer ça.

Avatar de l’utilisateur
Kiminou
Timide
Messages : 12
Inscription : 30 mars 2019, 19:07

Re: Plugin blea

Message par Kiminou » 01 août 2019, 13:09

syl62 a écrit :
30 juil. 2019, 21:27
Bonsoir,

Toujours le même problème avec Dotti avec la version d'aujourd'hui (2019-07-30 01:03:08).

DOTTI------Sending Display
DOTTI------Failed to finish : 'dict' object has no attribute 'iteritems'

Cdlt.
Bonjour,

Le problème du Dotti avec l'envoi des messages est maintenant réglé grâce à la dernière mise à jour de Blea datée du 2019-07-31 11:20:37. (Merci à l'équipe).
Il faut remettre son fichier collection_dotti.json à l'emplacement initial pour avoir ses images.
Hystou i3, Raspberry Pi 2, Contrôleur Z-Wave Plus Z-Stick GEN5, ASUS USB-BT400, Zigate, Sena UD100-G03, Huawei e169, Dotti, Divoom Tivoo V5.0, Jeedom 3.3.31.

Avatar de l’utilisateur
iPapy
Timide
Messages : 253
Inscription : 12 mars 2017, 16:58
Localisation : Bobigny

Re: Plugin blea

Message par iPapy » 01 août 2019, 13:09

Poumi a écrit :
31 juil. 2019, 21:13
Les mien sont vert pale et ont le même firmware que le tien, donc le problème n’est pas là.

Tu utilise uniquement l’advertizing ou tu as mis le refresh forcé?

Pour la batterie, un seul de mes 22 miflora m’a envoyé une mise à jour depuis que j’ai fait l’update il y a 2 semaines. Mais j’avais eu l’explication de celui qui a mis en place l’advertizing que c’etait envoyé sur mise à jour.

Peut-être que c’est lié au fait que tu as 2 jeedom qui écoutent le même miflora. (Pas sûr que l’advertizing marche bien dans ce cas, je n’ai pas testé)

Hello Poumi,

Qu'entends tu par"l’advertizing ou refresh forcé" Je l'utilise avec les paramètres par défaut sans avoir rien modifié.
A la base je ne l'avais pas mis sur mon Jeedom de test, uniquement sur mon serveur en prod et c'est en voyant que je n'avais plus les remontées de firmware et de batterie depuis 2/3 mise à jour que je l'ai inclus dans mon serveur de test, toujours avec les paramètre par défaut pour voir si j'avais le même souci.

Au début même j ne l'avais même pas mis sur BLEA mais juste sur le plugin MiFlora et cela fonctionnait moyennement jusqu'au jour ou je n'ai plus jamais eu d'actualisation avec le message de firmware inconnu, du coup j'avais supprimé le plugin MiFlora que j'aimais bien pour le basculer dans BLEA. La seul différence que je vois c'est que vu que j'utilise le Bluetooth du Pi et que ce dernier est légèrement différent entre le Pi3B et le Pi3B+.

Edit à 13h25:

Je viens de redémarrer mon serveur de prod et bizarrement les info sont revenu.
Capture.PNG
Capture.PNG (5.04 Kio) Consulté 191 fois

Avatar de l’utilisateur
Zeilloc
Timide
Messages : 31
Inscription : 28 sept. 2016, 13:38

Re: Plugin blea

Message par Zeilloc » 01 août 2019, 17:30

Bonjour,
Depuis la mise à jour que j'ai faite hier midi, le démon BLEA ne démarre plus.
Plus de NUT ou de MiFlower du coup.
La Santé de Jeedom est tout vert sauf le démon du plugin BLEA.
Que puis-je faire pour y remédier ?

Log BLEA

Code : Tout sélectionner

[2019-08-01 15:45:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 15:45:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 15:50:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 15:50:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 15:55:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 15:55:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:00:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:00:37][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:05:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:05:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:10:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:10:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:15:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:15:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:20:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:20:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:25:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:25:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:30:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:30:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:35:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:35:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:40:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:40:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:45:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:45:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:50:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:50:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 16:55:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 16:55:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:00:06][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:00:38][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:05:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:05:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:10:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:10:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:15:38][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:16:04][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-08-01 17:15:38
[2019-08-01 17:16:19][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-08-01 17:15:38
[2019-08-01 17:16:29][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:17:01][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:19:35][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:20:04][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-08-01 17:19:35
[2019-08-01 17:20:06][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-01 17:25:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-08-01 17:25:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
Log BLEA_LOCAL

Code : Tout sélectionner

Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
BLEA_UPDATE

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Fetched 15.0 kB in 0s (15.9 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0j-1~deb9u1).
python-dev is already the newest version (2.7.13-2).
python-requests is already the newest version (2.12.4-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 73 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 73 not upgraded.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pyudev in /usr/lib/python2.7/dist-packages (0.21.0)
You are using pip version 19.0.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pyserial in /usr/lib/python2.7/dist-packages (3.2.1)
You are using pip version 19.0.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages (2.12.4)
You are using pip version 19.0.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting pip
Downloading https://files.pythonhosted.org/packages/d8/f3/413bab4ff08e1fc4828dfc59996d721917df8e8583ea85385d51125dceff/pip-19.0.3-py2.py3-none-any.whl (1.4MB)
Collecting setuptools
Downloading https://files.pythonhosted.org/packages/d1/6a/4b2fcefd2ea0868810e92d519dacac1ddc64a2e53ba9e3422c3b62b378a6/setuptools-40.8.0-py2.py3-none-any.whl (575kB)
Installing collected packages: pip, setuptools
Found existing installation: pip 19.0.1
Uninstalling pip-19.0.1:
Successfully uninstalled pip-19.0.1
Found existing installation: setuptools 40.6.3
Uninstalling setuptools-40.6.3:
Successfully uninstalled setuptools-40.6.3
Successfully installed pip-19.0.3 setuptools-40.8.0
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 1659k  100 1659k    0     0  2927k      0 --:--:-- --:--:-- --:--:-- 2926k
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting pip
Using cached https://files.pythonhosted.org/packages/d8/f3/413bab4ff08e1fc4828dfc59996d721917df8e8583ea85385d51125dceff/pip-19.0.3-py2.py3-none-any.whl
Installing collected packages: pip
Found existing installation: pip 19.0.3
Uninstalling pip-19.0.3:
Successfully uninstalled pip-19.0.3
Successfully installed pip-19.0.3
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/bluepy
copying bluepy/blescan.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/sensortag.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/thingy52.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scanner.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/btle.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/__init__.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/get_services.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/uuids.json -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluez-src.tgz -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluepy-helper.c -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/Makefile -> build/lib.linux-armv7l-2.7/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib.linux-armv7l-2.7/bluepy
running install_lib
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/blescan.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/sensortag.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/thingy52.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper.c -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/scanner.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/Makefile -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/btle.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/__init__.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluez-src.tgz -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/uuids.json -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/get_services.py -> /usr/local/lib/python2.7/dist-packages/bluepy
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/blescan.py to blescan.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/sensortag.py to sensortag.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/thingy52.py to thingy52.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/scanner.py to scanner.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/btle.py to btle.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/get_services.py to get_services.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing top-level names to bluepy.egg-info/top_level.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python2.7/dist-packages/bluepy-1.1.2-py2.7.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python2.7/dist-packages/bluepy-1.1.2-py2.7.egg-info
running install_scripts
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages (1.7.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pycrypto in /usr/lib/python2.7/dist-packages (2.6.1)
********************************************************
*             Installation terminée                    *
********************************************************

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités