Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3389
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 05 août 2019, 09:37

Bonjour,

Que cela soit avec des NUT ou avec un Mi Band 3, je n'ai pas ce problème.
- Tout avec les paramétrages par défaut des équipements tel que BLEA les a créés.

Pour "tester" déconnectez votre montre de votre smartphone pour voir si vous avez encore ce problème.
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 05 août 2019, 10:07

Une telle différence de comportement est étrange quand même.

pas de changement d'habitude autre? (tu places toujours ta montre au même endroit la nuit? distance avec une antenne équivalente à avant l'update?
combien as-tu d'antenne? sont-elles toutes fonctionnelles si tu en as plusieurs?
est-ce que le paramètre "antenne de réception" sur le device et sur la config général est bien configuré?

Sinon il y a le mode "forcé" aussi mais je n'ai pas encore bien creusé les changements là.
Il est possible qu'avant le plugin interrogeait ton device régulièrement et qu'à présent il attende juste que ta montre se signale, d'où le changement.
Si j'ai bien compris, le mode "forcé" permet que le plugin prenne l'initiative mais cela pourrait réduire ta batterie si refresh trop fréquent.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: Plugin blea

Message par m.georgein » 05 août 2019, 13:11

Bonjour à tous,
J'essaye sans succès depuis deux jours de faire fonctionner BLEA sans succès.
J'ai créé une nouvelle VM en stretch, dépendance lancé sur l'antenne OK, daemon lancé OK mais pas de scan.
Au bout d'une heure le daemon est KO et impossible de le relancer :

Code : Tout sélectionner

[sudo] Mot de passe de debian9 : [2019-08-05 12:59:07.622][INFO] : GLOBAL------Start blead
[2019-08-05 12:59:07.622][INFO] : GLOBAL------Log level : info
[2019-08-05 12:59:07.622][INFO] : GLOBAL------Socket port : 55008
[2019-08-05 12:59:07.622][INFO] : GLOBAL------Socket host :
[2019-08-05 12:59:07.622][INFO] : GLOBAL------Device : hci0
[2019-08-05 12:59:07.622][INFO] : GLOBAL------PID file : /tmp/blead.pid
[2019-08-05 12:59:07.622][INFO] : GLOBAL------Apikey : Ynx6qgnHsW95I3rXwH6wOrMLHASJ3mHX
[2019-08-05 12:59:07.623][INFO] : GLOBAL------Callback : http://10.187.70.106:80/plugins/blea/core/php/jeeBlea.php
[2019-08-05 12:59:07.623][INFO] : GLOBAL------Cycle : 0.3
[2019-08-05 12:59:07.623][INFO] : GLOBAL------Scan interval  : 29
[2019-08-05 12:59:07.623][INFO] : GLOBAL------Number for no seen : 4
[2019-08-05 12:59:07.623][INFO] : GLOBAL------Scan Mode : passive
[2019-08-05 12:59:07.636][INFO] : LOADER------Import de la configuration devices.awoxmesh
[2019-08-05 12:59:07.638][INFO] : LOADER------Import de la configuration devices.beagle
[2019-08-05 12:59:07.639][INFO] : LOADER------Import de la configuration devices.beewismartdoor
[2019-08-05 12:59:07.639][INFO] : LOADER------Import de la configuration devices.blpnr
[2019-08-05 12:59:07.640][INFO] : LOADER------Import de la configuration devices.divoomtimeboxmini
Traceback (most recent call last):
File "/home/debian9/blead/resources/blead/blead.py", line 572, in <module>
import devices
File "/home/debian9/blead/resources/blead/devices/__init__.py", line 6, in <module>
__import__(modname)
File "/home/debian9/blead/resources/blead/devices/divoomtimeboxmini.py", line 5, in <module>
from devices.timebox import timebox
File "/home/debian9/blead/resources/blead/devices/timebox/timebox.py", line 5, in <module>
from bluetooth import BluetoothSocket, RFCOMM
ImportError: No module named 'bluetooth'
pourtant le lod des dépendances est OK :

Code : Tout sélectionner

[sudo] Mot de passe de debian9 : ********************************************************
*			 Installation des dépendances			 *
********************************************************
Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:2 http://security.debian.org/debian-security stretch/updates InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:4 http://ftp.fr.debian.org/debian stretch-backports InRelease
Atteint:5 http://ftp.fr.debian.org/debian stretch Release
Lecture des listes de paquets…
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
bluetooth is already the newest version (5.43-2+deb9u1).
libbluetooth-dev is already the newest version (5.43-2+deb9u1).
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
python3-serial is already the newest version (3.2.1-1).
python3-setuptools is already the newest version (33.1.1-1).
python3-dev is already the newest version (3.5.3-1).
python3-pyudev is already the newest version (0.21.0-1).
python3-requests is already the newest version (2.12.4-1).
rfkill is already the newest version (0.5-1+b1).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin :
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 0 o/142 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 56973 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-pip_9.0.1-2+deb9u1_all.deb ...
Dépaquetage de python3-pip (9.0.1-2+deb9u1) sur (9.0.1-2+deb9u1) ...
Paramétrage de python3-pip (9.0.1-2+deb9u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python3/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Clonage dans 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing entry points to bluepy.egg-info/entry_points.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing bluepy.egg-info/PKG-INFO
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Installing blescan script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************
Dernier point, je viens de voir que le daemon est arrété juste après son lancement ...

Code : Tout sélectionner

2019-08-05 13:19:02][INFO] : Lancement du démon distant
[2019-08-05 13:19:02][INFO] : Arret du démon distant
[2019-08-05 13:19:02][INFO] : Commande par SSH fuser -k 55008/tcp >> /dev/null 2>&1 & sur 10.187.70.121
[2019-08-05 13:19:08][INFO] : Lancement du démon distant /usr/bin/python3 /home/debian9/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://10.187.70.106:80/plugins/blea/core/php/jeeBlea.php --apikey Ynx6qgnHsW95I3rXwH6wOrMLHASJ3mHX --daemonname "Antenne-BLEA" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 &
[2019-08-05 13:19:08][INFO] : Commande par SSH /usr/bin/python3 /home/debian9/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://10.187.70.106:80/plugins/blea/core/php/jeeBlea.php --apikey Ynx6qgnHsW95I3rXwH6wOrMLHASJ3mHX --daemonname "Antenne-BLEA" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 & sur 10.187.70.121
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1


MrVince
Timide
Messages : 168
Inscription : 11 sept. 2017, 15:22

Re: Plugin blea

Message par MrVince » 05 août 2019, 15:05

Bonjour,

De mon coté je n'arrive pas à finir l'installation des dependaces en local, il bloque depuis plus de 30 min à 60%

Voici les logs

Code : Tout sélectionner

********************************************************
*			 Installation des dépendances			 *
********************************************************
sudo: unable to resolve host NAS
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://deb.debian.org/debian stretch Release
Hit:5 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
sudo: unable to resolve host NAS
Reading package lists...
Building dependency tree...
Reading state information...
bluetooth is already the newest version (5.43-2+deb9u1).
libbluetooth-dev is already the newest version (5.43-2+deb9u1).
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
python3-serial is already the newest version (3.2.1-1).
python3-setuptools is already the newest version (33.1.1-1).
python3-dev is already the newest version (3.5.3-1).
python3-pyudev is already the newest version (0.21.0-1).
python3-requests is already the newest version (2.12.4-1).
rfkill is already the newest version (0.5-1+b1).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
sudo: unable to resolve host NAS
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 9 not upgraded.
Need to get 142 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://deb.debian.org/debian stretch/main amd64 python3-pip all 9.0.1-2+deb9u1 [142 kB]
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
Fetched 142 kB in 0s (880 kB/s)
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 55224 files and directories currently installed.)
Preparing to unpack .../python3-pip_9.0.1-2+deb9u1_all.deb ...
Unpacking python3-pip (9.0.1-2+deb9u1) over (9.0.1-2+deb9u1) ...
Setting up python3-pip (9.0.1-2+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
sudo: unable to resolve host NAS
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
sudo: unable to resolve host NAS
Reading package lists...

Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
sudo: unable to resolve host NAS
Requirement already satisfied: pyudev in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pyudev)
sudo: unable to resolve host NAS
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages
sudo: unable to resolve host NAS
Requirement already satisfied: requests in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.5/dist-packages (from requests)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.5/dist-packages (from requests)
sudo: unable to resolve host NAS
Cloning into 'bluepy'...
sudo: unable to resolve host NAS
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
sudo: unable to resolve host NAS
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing entry points to bluepy.egg-info/entry_points.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing blescan script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Si quelqu'un a une idée de pourquoi je bloque sur 'Installing sensortag script to /usr/local/bin'

Merci
NAS HP Proliant - OpenMediaVault - Jeedom Docker
Raspberry Pi 3 - MagicMirror
Prusa i3

Capteurs MySensors / Xiaomi / Éclairage Ikea Tradfri
SmarterCoffee / Chromecast & Google Home / Thermostat Netatmo

Avatar de l’utilisateur
Titi007
Timide
Messages : 104
Inscription : 23 févr. 2017, 16:31

Re: Plugin blea

Message par Titi007 » 05 août 2019, 15:44

Bonjour,
Moi aussi, j'ai un soucis avec une de mes antennes depuis la mise à jour .. sur rpi 3 (il y a octoprint dessus), strech
Impossible de lancer le démon, j'ai même tout réinstallé mais en y regardant de plus prés, j'ai quelques erreurs au moment de l'installation des dépendances..
je désespère, j'ai presque tout tenté (sauf la bonne solution visiblement!) alors si quelqu'un peut m'aider, ça serait sympa
voici mon log :

Code : Tout sélectionner

********************************************************
[sudo] password for pi: ********************************************************
*			 Installation des dépendances			 *
********************************************************
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
python3-dev is already the newest version (3.5.3-1).
python3-pyudev is already the newest version (0.21.0-1).
python3-requests is already the newest version (2.12.4-1).
python3-serial is already the newest version (3.2.1-1).
python3-setuptools is already the newest version (33.1.1-1).
rfkill is already the newest version (0.5-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
libbluetooth-dev is already the newest version (5.43-2+rpt2+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded.
Need to get 0 B/142 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 46121 files and directories currently installed.)
Preparing to unpack .../python3-pip_9.0.1-2+rpt2_all.deb ...
Unpacking python3-pip (9.0.1-2+rpt2) over (9.0.1-2+rpt2) ...
Setting up python3-pip (9.0.1-2+rpt2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python3/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Please do not run git as root, your regular user account is enough :)

If you need to run git with root rights for some other application than
what comes preinstalled on this image you can remove this sanity check:

    sudo rm /root/bin/git

You might have to restart your login session after doing that.
/home/pi/blead/resources/install_apt.sh: line 25: cd: /tmp/bluepy: No such file or directory
python3: can't open file 'setup.py': [Errno 2] No such file or directory
python3: can't open file 'setup.py': [Errno 2] No such file or directory
rm: cannot remove '/tmp/bluepy': No such file or directory
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************
j'ai l'impression qu'il bute sur ça :
You might have to restart your login session after doing that.
/home/pi/blead/resources/install_apt.sh: line 25: cd: /tmp/bluepy: No such file or directory
python3: can't open file 'setup.py': [Errno 2] No such file or directory
python3: can't open file 'setup.py': [Errno 2] No such file or directory

mais je ne vois pas comment y remedier ?

par avance, merci

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: Plugin blea

Message par m.georgein » 05 août 2019, 16:12

benj29 a écrit :
05 août 2019, 13:41
Les api....

Envoyé de mon JSN-L21 en utilisant Tapatalk
J'ai du louper quelque chose, je ne vois pas de quelle API tu parles ;(
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 05 août 2019, 16:15

@Titi007, as-tu autre chose que l'antenne BLEA qui tourne sur ce pi?
si pas, connecte toi en ssh dessus et fait ce qui est proposé:

Code : Tout sélectionner

sudo rm /root/bin/git
le script d'install des dépendances a été bloqué lors du git clone à cause du fait qu'il est exécuté en tant que sudo, ce n'est effectivement pas nécessaire pour git mais ca l'était pour les étapes précédentes.
Par contre je n'explique pas pourquoi ton raspbian fait ce check, jamais vu cela avant; d'ou vient ton image?
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 05 août 2019, 16:19

MrVince a écrit :
05 août 2019, 15:05
Bonjour,

De mon coté je n'arrive pas à finir l'installation des dependaces en local, il bloque depuis plus de 30 min à 60%

Si quelqu'un a une idée de pourquoi je bloque sur 'Installing sensortag script to /usr/local/bin'

Merci
Sans autre info, j'attendrais et je ne couperais pas (ou tu vas devoir relancer), un raspberry n'est pas toujours rapide...
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

MrVince
Timide
Messages : 168
Inscription : 11 sept. 2017, 15:22

Re: Plugin blea

Message par MrVince » 05 août 2019, 16:59

Je reviens vers vous pour vous donner plus de détail.

J'ai laissé tourner le script sans évolution. Une fois signalé par jeedom comme installé, j'ai tenté de lancer le démon sans succès. J'ai ensuite relancé l'installation, et j'ai bloqué une étape après. Je me rends compte en me connectant via ssh que mon hci0 est déjà up et que ma commande freeze si je souhaite le down.

JE précise, comme indiqué dans ma signature, que je ne suis pas sur un rpi, que mes antennes fonctionnent, et qu'il ne s'agit que de mon antenne local qui pose problème

EDIT: Problème résolu, j'ai retiré mon dongle bluetooth, reboot, installé les dépendances, et remis le dongle. Tout marche à merveille
NAS HP Proliant - OpenMediaVault - Jeedom Docker
Raspberry Pi 3 - MagicMirror
Prusa i3

Capteurs MySensors / Xiaomi / Éclairage Ikea Tradfri
SmarterCoffee / Chromecast & Google Home / Thermostat Netatmo

milou161185
Timide
Messages : 11
Inscription : 14 mars 2018, 19:45

Re: Plugin blea

Message par milou161185 » 05 août 2019, 18:28

Bonjour, je rencontre un problème avec le daemon blea sur une antenne déportée. L'antenne est un pi 3B, et depuis que je l'ai mis à jour la semaine dernière, le bluetooth n’arrête pas de planter avec cette erreur : "Bluetooth: hci0: Frame reassembly failed (-84)". En stoppant le daemon, plus d'erreur. J'ai tenté le rebot, la réinstallation des dépendances, mais rien n'y fait !!
Je suis en version du plugin blea 2.6.3 et mon pi est en version 4.19.58-v7+.
Quelqu'un as-t'il déjà rencontré ce problème? Merci pour vos lumières.

Avatar de l’utilisateur
raqpub
Timide
Messages : 272
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: Plugin blea

Message par raqpub » 06 août 2019, 08:01

Mips2648 a écrit :
05 août 2019, 10:07
Une telle différence de comportement est étrange quand même.

pas de changement d'habitude autre? (tu places toujours ta montre au même endroit la nuit? distance avec une antenne équivalente à avant l'update?
combien as-tu d'antenne? sont-elles toutes fonctionnelles si tu en as plusieurs?
est-ce que le paramètre "antenne de réception" sur le device et sur la config général est bien configuré?

Sinon il y a le mode "forcé" aussi mais je n'ai pas encore bien creusé les changements là.
Il est possible qu'avant le plugin interrogeait ton device régulièrement et qu'à présent il attende juste que ta montre se signale, d'où le changement.
Si j'ai bien compris, le mode "forcé" permet que le plugin prenne l'initiative mais cela pourrait réduire ta batterie si refresh trop fréquent.
Bonjour,

Plusieurs tentatives, sans succès (Refresh forcé ou pas, augmentation du refresh des infos sur la montre à 49...) je perds toujours mon appareil (NOT SEEEEN) et pas vu de logique au niveau timing hormis la récup qui est toujours quelques secondes après (RE SEEEEN) et quelque soit le temps entre le présécent RE SEEEN et le dernier NOT SEEEN ?!
Rien n'a donc changé depuis la toute dernière version et malgré mon passage à stretch pour être compliant.

Merci à Mips2648 pour tes pistes avec ton expérience. Non je n'ai rien changé et c'est pour ça que c'est flagrant.
@Fabrice : Montre non connecté au smartphone (que lorsque je synchronise mes séances de sport).

EDIT : Comme je l'avais indiqué antenne locale sur PI3 (le BLE intégré) --> Comme avant.

EDIT 2 : Je retente une totale
-Suppression du plugin,
-Reboot
-Réinstallation
-Résintallation dépendances
-Reboot
-Rescan --> Perte d'un MIfrlora sur 3 au passage (mais j'insisterai)
-Récup de ma montre

Ajout des écrans après cette installation et en l'état post installation (tout par défaut) pour répondre à Mips2648
Config plugin 1.png
Config plugin 1.png (170.42 Kio) Consulté 361 fois
Config plugin 2.png
Config plugin 2.png (160.31 Kio) Consulté 361 fois
Config montre.png
Config montre.png (159.91 Kio) Consulté 361 fois
Log installation dépendances au cas où j'aurais loupé quelque chose :

Code : Tout sélectionner

********************************************************
*			 Installation des dépendances			 *
********************************************************
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 https://deb.nodesource.com/node_10.x stretch InRelease
Fetched 25.4 kB in 2s (10.7 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
python3-dev is already the newest version (3.5.3-1).
python3-pyudev is already the newest version (0.21.0-1).
python3-requests is already the newest version (2.12.4-1).
python3-serial is already the newest version (3.2.1-1).
python3-setuptools is already the newest version (33.1.1-1).
rfkill is already the newest version (0.5-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
libbluetooth-dev is already the newest version (5.43-2+rpt2+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/142 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 65220 files and directories currently installed.)
Preparing to unpack .../python3-pip_9.0.1-2+rpt2_all.deb ...
Unpacking python3-pip (9.0.1-2+rpt2) over (9.0.1-2+rpt2) ...
Setting up python3-pip (9.0.1-2+rpt2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python3/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing bluepy.egg-info/PKG-INFO
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing blescan script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************
En l'état je désactive l'utilisation de BLEA pour la gestion de la présence/absence.

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 06 août 2019, 09:46

Désolé, pas d'autres idées de pistes.
Tu peux toujours soumettre un ticket au support, c'est un plugin officiel.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3389
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 06 août 2019, 10:14

Votre montre n'a pas eu de mise à jour entre temps ?
- Il est possible qu'elle ne soit tout simplement pas compatible (par économie d’énergie) avec l'advertissment en continue.
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
raqpub
Timide
Messages : 272
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: Plugin blea

Message par raqpub » 06 août 2019, 10:19

Mips2648 a écrit :
06 août 2019, 09:46
Désolé, pas d'autres idées de pistes.
Tu peux toujours soumettre un ticket au support, c'est un plugin officiel.
Merci tout de même.
Vu que c'est un appareil "inconnu" pas certain que le support prenne en compte (et je comprendrais vu la complexité).
Là je l'ai posée à 2m et pareil 3 pertes en moins de 15'.

@Fabrice : Pas souvenir d'une mise à jour qui correspond à ce comportement (mais bonne idée).
Pour la batterie elle tient plus de 3 semaines voire plus suivant activité.

Avatar de l’utilisateur
Laco
Actif
Messages : 822
Inscription : 06 oct. 2014, 19:25

Re: Plugin blea

Message par Laco » 06 août 2019, 20:43

Kiminou a écrit :
27 juil. 2019, 15:52
syl62 a écrit :
27 juil. 2019, 15:12
Hello Kiminou,

J'ai les memes problèmes que vous . Jeedom est aussi sous VM chez moi.
Pour info, les icônes crées se trouvent dans /html/plugin/blea/data /collection-dotti.json.
Peut-être qu'un ancien backup peut permettre de restaurer votre fichier.
de mon coté, je l'ai restauré, mais pas d'image affiché pourtant la bibliothèque est bien la.
Batterie/Heure/OFF/couleur fonctionnent seulement.
Cdlt
Ouf j'ai su remettre mes images (j'ai sauvegardé la collection) en allant dans "Configuration" - "OS/>_DB" - "Editeur de fichiers" - "Lancer" puis dans le dossier plugins/blea/data/collection_dotti.json
J'ai bien mes images dans la bibliothèque qui sont revenus mais toujours les mêmes problèmes 1 et 2.
Salut à tous

Depuis la mise à jour du plugin Blea ou du Linux, je n'ai plus mes icônes au niveau des DOTTI. :shock:

Est il possible en restaurant une sauvegarde sur un Raspberry par exemple de copier/coller le contenu du fichier "collection_dotti.json" de la sauvegarde vers ma Smart ?
Ça pourrait fonctionner ?

Voyez vous une autre méthode ?

Merci par avance ;)

A+ :)
MERCI A TOUTE L'ÉQUIPE POUR LE TAF

Avatar de l’utilisateur
Laco
Actif
Messages : 822
Inscription : 06 oct. 2014, 19:25

Re: Plugin blea

Message par Laco » 07 août 2019, 08:43

Salut à tous :)

Je confirme, la méthode du copier/coller à fonctionner dans le fichier /html/plugin/blea/data /collection-dotti.json

Bonne journée à tous ;)
MERCI A TOUTE L'ÉQUIPE POUR LE TAF

julien35
Timide
Messages : 103
Inscription : 26 déc. 2015, 23:56

Re: Plugin blea

Message par julien35 » 07 août 2019, 09:28

Bonjour, depuis la dernière mise à jour du plugin, avec mes 5 hygrothermometre xiaomi, j'ai ma charge système qui est passée de 0.5 à 2 sur 15 minutes... Suis je le seul à avoir eu une augmentation considérable de charge cpu ?

Avatar de l’utilisateur
raqpub
Timide
Messages : 272
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: Plugin blea

Message par raqpub » 07 août 2019, 09:39

Bonjour,

Je reviens vous saouler avec mes "Not SEEEEEEEEEN"/"RE SEEEEEEEEEN"...

En élargissant le filtre de recherche à la chaine SEEEEEEEEEN et pas seulement à la mac de ma montre Amazfit Bip, j'ai vu que "souvent" tous mes clients BLE disparaissaient (Ma montre qui n'a pas bougée au point d'être hors de portée et 2 MIFLORA qui ne bougent pas ;-) )

Du coup en relisant la changelog du plugin BLEA je vois :
3) 20/07/2019
...
-Si une antenne n’a pas communiqué depuis plus d’une minute alors les présences de cette antenne sont mises à 0
...
Ne serais-ce pas cette nouveauté qui serait la root cause de mes pbs ?

Illustration par une surveillance de la log il y a quelques minutes ( tail -f blea_local|grep SEEEEEEEEEN).
On voit disparaitre les 3 en même temps puis revenir...

Code : Tout sélectionner

[2019-08-07 08:51:19.238][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6B:04:E8
[2019-08-07 08:51:20.240][INFO] : Not SEEEEEEEEEN------ since 116s E9:06:C5:77:8D:A6
[2019-08-07 08:51:25.248][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6A:48:52
[2019-08-07 08:52:12.489][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6B:04:E8 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 0, 'lastseen': 1565160568}, 'E9:06:C5:77:8D:A6': {'present': 0, 'lastseen': 1565160563}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565160732}}
[2019-08-07 08:52:13.194][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6A:48:52 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565160733}, 'E9:06:C5:77:8D:A6': {'present': 0, 'lastseen': 1565160563}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565160732}}
[2019-08-07 08:52:23.099][INFO] : RE SEEEEEEEEEN------E9:06:C5:77:8D:A6 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565160738}, 'E9:06:C5:77:8D:A6': {'present': 1, 'lastseen': 1565160743}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565160732}}
[2019-08-07 08:55:45.604][INFO] : Not SEEEEEEEEEN------ since 116s E9:06:C5:77:8D:A6
[2019-08-07 08:55:53.071][INFO] : RE SEEEEEEEEEN------E9:06:C5:77:8D:A6 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565160950}, 'E9:06:C5:77:8D:A6': {'present': 1, 'lastseen': 1565160953}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565160952}}
[2019-08-07 08:57:47.772][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6A:48:52
[2019-08-07 08:57:49.775][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6B:04:E8
[2019-08-07 08:57:50.778][INFO] : Not SEEEEEEEEEN------ since 116s E9:06:C5:77:8D:A6
[2019-08-07 08:58:00.169][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6A:48:52 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565161080}, 'E9:06:C5:77:8D:A6': {'present': 0, 'lastseen': 1565160953}, 'C4:7C:8D:6B:04:E8': {'present': 0, 'lastseen': 1565160952}}
[2019-08-07 08:58:00.826][INFO] : RE SEEEEEEEEEN------E9:06:C5:77:8D:A6 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565161080}, 'E9:06:C5:77:8D:A6': {'present': 1, 'lastseen': 1565161080}, 'C4:7C:8D:6B:04:E8': {'present': 0, 'lastseen': 1565160952}}
[2019-08-07 08:58:01.492][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6B:04:E8 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565161080}, 'E9:06:C5:77:8D:A6': {'present': 1, 'lastseen': 1565161080}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565161081}}
[2019-08-07 09:02:44.159][INFO] : Not SEEEEEEEEEN------ since 116s E9:06:C5:77:8D:A6
[2019-08-07 09:02:46.164][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6A:48:52
[2019-08-07 09:02:49.169][INFO] : Not SEEEEEEEEEN------ since 116s C4:7C:8D:6B:04:E8
[2019-08-07 09:03:40.525][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6B:04:E8 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 0, 'lastseen': 1565161249}, 'E9:06:C5:77:8D:A6': {'present': 0, 'lastseen': 1565161247}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565161420}}
[2019-08-07 09:03:41.199][INFO] : RE SEEEEEEEEEN------C4:7C:8D:6A:48:52 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565161421}, 'E9:06:C5:77:8D:A6': {'present': 0, 'lastseen': 1565161247}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565161420}}
[2019-08-07 09:03:46.220][INFO] : RE SEEEEEEEEEN------E9:06:C5:77:8D:A6 || {'C0:39:F8:F5:20:CB': {'present': 0}, 'C4:7C:8D:6A:48:52': {'present': 1, 'lastseen': 1565161421}, 'E9:06:C5:77:8D:A6': {'present': 1, 'lastseen': 1565161426}, 'C4:7C:8D:6B:04:E8': {'present': 1, 'lastseen': 1565161424}}


Avatar de l’utilisateur
raqpub
Timide
Messages : 272
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: Plugin blea

Message par raqpub » 07 août 2019, 10:07

Suite...
En fouillant si mon ble local était défaillant, j'ai sondé le dmesg sur hci0 et j'ai bcp de messages de ce type :

Code : Tout sélectionner

pi@raspberrypi:~ $ dmesg|grep hci0
[   87.697060] Bluetooth: hci0: Frame reassembly failed (-84)
[   89.751968] Bluetooth: hci0: command 0x200c tx timeout
[  128.537388] Bluetooth: hci0: Frame reassembly failed (-84)
[  130.552013] Bluetooth: hci0: command 0x200c tx timeout
[  145.616303] Bluetooth: hci0: Frame reassembly failed (-84)
[  145.616350] Bluetooth: hci0: Frame reassembly failed (-84)
[  145.616615] Bluetooth: hci0: Frame reassembly failed (-84)
[  297.165401] Bluetooth: hci0: advertising data len corrected
[  349.237087] Bluetooth: hci0: Frame reassembly failed (-84)
[  349.237201] Bluetooth: hci0: Frame reassembly failed (-84)
[  349.237227] Bluetooth: hci0: Frame reassembly failed (-84)
[  349.237399] Bluetooth: hci0: Frame reassembly failed (-84)
[  359.205755] Bluetooth: hci0: Frame reassembly failed (-84)
[  359.205872] Bluetooth: hci0: Frame reassembly failed (-84)
[  359.206114] Bluetooth: hci0: Frame reassembly failed (-84)
[  361.352109] Bluetooth: hci0: command 0x200c tx timeout
[  371.432113] Bluetooth: hci0: command 0x200c tx timeout
[  381.432062] Bluetooth: hci0: command 0x200b tx timeout
[  383.512068] Bluetooth: hci0: command 0x200c tx timeout
[  391.832027] Bluetooth: hci0: command 0x200c tx timeout
[  401.832088] Bluetooth: hci0: command 0x200b tx timeout
[  410.086999] Bluetooth: hci0: Frame reassembly failed (-84)
[  412.152057] Bluetooth: hci0: command 0x200c tx timeout
[  421.113498] Bluetooth: hci0: Frame reassembly failed (-90)
[  421.113557] Bluetooth: hci0: Frame reassembly failed (-84)
[  421.113646] Bluetooth: hci0: Frame reassembly failed (-84)
[  421.113735] Bluetooth: hci0: Frame reassembly failed (-84)
[  421.113820] Bluetooth: hci0: Frame reassembly failed (-84)
[  421.113862] Bluetooth: hci0: Frame reassembly failed (-84)
[  456.489762] Bluetooth: hci0: Frame reassembly failed (-84)
[  458.552211] Bluetooth: hci0: command 0x200c tx timeout
Ce site : https://github.com/raspberrypi/firmware/issues/1150 semble indiquer des pbs de firmware sur hci0.
...
A suivre

EDIT : Ne voulant pas retenter une mise à jour firmware j'ai appliqué le pansement proposé sur ce site :

Sauvegarde du script /usr/bin/btuart
et modif comme suit :
#$HCIATTACH /dev/serial1 bcm43xx 921600 noflow - $BDADDR
$HCIATTACH /dev/serial1 bcm43xx 115200 noflow - $BDADDR

Code : Tout sélectionner

pi@raspberrypi:~ $ cat /usr/bin/btuart 
#!/bin/sh

HCIATTACH=/usr/bin/hciattach
SERIAL=`cat /proc/device-tree/serial-number | cut -c9-`
B1=`echo $SERIAL | cut -c3-4`
B2=`echo $SERIAL | cut -c5-6`
B3=`echo $SERIAL | cut -c7-8`
BDADDR=`printf b8:27:eb:%02x:%02x:%02x $((0x$B1 ^ 0xaa)) $((0x$B2 ^ 0xaa)) $((0x$B3 ^ 0xaa))`

uart0="`cat /proc/device-tree/aliases/uart0`"
serial1="`cat /proc/device-tree/aliases/serial1`"

if [ "$uart0" = "$serial1" ] ; then
	uart0_pins="`wc -c /proc/device-tree/soc/gpio@7e200000/uart0_pins/brcm\,pins | cut -f 1 -d ' '`"
	if [ "$uart0_pins" = "16" ] ; then
		$HCIATTACH /dev/serial1 bcm43xx 3000000 flow - $BDADDR
	else
		#$HCIATTACH /dev/serial1 bcm43xx 921600 noflow - $BDADDR
		$HCIATTACH /dev/serial1 bcm43xx 115200 noflow - $BDADDR
	fi
else
	$HCIATTACH /dev/serial1 bcm43xx 460800 noflow - $BDADDR
fi

Pour l'instant plus de messages dans dmesg :

Code : Tout sélectionner

pi@raspberrypi:~ $ dmesg|grep hci
[    0.829783] sdhci: Secure Digital Host Controller Interface driver
[    0.832214] sdhci: Copyright(c) Pierre Ossman
[    0.840584] sdhci-pltfm: SDHCI platform and OF driver helper
--> Je scrute mes SEEEEEEEEEN et je vous dis.


....

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités