Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

benj29
Actif
Messages : 3971
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 03 sept. 2017, 15:58

snorlax a écrit :
29 août 2017, 19:26
benj29 a écrit :
28 août 2017, 21:56
J'ai par personne, 3 infos : présent, nut présent, clé laissé.
Si clé laissée = 1 alors présent est à faux (absent) quelque soit l'état du nut.
Si clé laissé = 0 alors présent est à vrai en fonction de l'état du nut.
Petite question : "clé laissée" c'est une info manuelle ou automatique ?
Non c'est un info manuelle (désolé je n'avais pas vu ton post). D'où le NUT validé/dévalidé. En gros, je laisse les clés à la maison ou non (déplacement sur plusieurs jours, fréquent pour moi).

benj29
Actif
Messages : 3971
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 03 sept. 2017, 16:09

A tout hasard, mes nuts décrochent... en regardant, je vois dans les logs de BLEA local ceci :

Code : Tout sélectionner

[2017-08-28 19:12:49][ERROR] : 'type' is an invalid keyword argument for this function
[2017-09-03 05:03:17][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:13:57][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:17:57][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:24:37][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:28:38][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:32:59][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
A quoi cela correspond-il ? Est-ce lié à ma clé Bluetooth ? (j'attends une Sena, mais là où sont mes nuts actuellement le signal n'est pas trop mauvais -79/-80 dBm).

Du coup, pour ceux qui utilisent les nuts, comment faites vous pour "filtrer" la perte/récupération d'un nut "rapide" (sous entendu < 2 min par exemple) ?

Pour l'instant j'ai ajouté un lastchangeduration sur condition à 1 (plus personne =1 dans la maison quand tous les nuts présents sont à 0) à 5 min pour être de plus voir ces variations.

Image

Code : Tout sélectionner

- Nom du scénario : Gestion Alarme Maison
- Objet parent : Maison
- Mode du scénario : provoke
    - Evènement : #[Maison][Présence Maison][Personne ?]#

Gestion de l'alarme de la maison

    
    comment
    
    SI #[Maison][Présence Maison][Personne ?]# == 0 AND #[Maison][Etat Alarme][Actif]# == 1  
    ALORS
     #[NAS - Box][JPI][SMS Benjamin]# - Options : Array
    (
        [enable] => 0
        [title] => 
        [message] => Désactivation automatique de l'alarme
    )
    
     #[NAS - Box][Google][Alerte Benjamin]# - Options : Array
    (
        [enable] => 1
        [title] => [Jeedom-Présence] Désactivation de l'alarme
        [message] => Désactivation automatique de l'alarme
    )
    
     #[Maison][Gestion Alarme][Bonjour !]# - Options : Array
    (
        [enable] => 1
    )
    
    SINON
    
    SI #[Maison][Présence Maison][Personne ?]# == 1 AND #[Maison][Etat Alarme][Actif]# == 0 
    ALORS
     wait - Options : Array
    (
        [enable] => 1
        [condition] => (lastChangeStateDuration(#[Maison][Présence Maison][Personne ?]#,1) > 300)
        [timeout] => 315
    )
    
         
        SI #[Maison][Présence Maison][Personne ?]# == 1 AND #[Maison][Etat Alarme][Actif]# == 0 AND (lastChangeStateDuration(#[Maison][Présence Maison][Personne ?]#,1) > 300)
        ALORS
         #[NAS - Box][JPI][SMS Benjamin]# - Options : Array
        (
            [enable] => 1
            [title] => 
            [message] => Activation automatique de l'alarme
        )
        
         #[NAS - Box][Google][Alerte Benjamin]# - Options : Array
        (
            [enable] => 1
            [title] => [Jeedom-Présence] Activation de l'alarme
            [message] => Activation automatique de l'alarme
        )
        
             
            SI #[Maison][Saison Alarme ?][Alarme]# == 1  
            ALORS
             #[Maison][Gestion Alarme][Out Hiver]# - Options : Array
            (
                [enable] => 1
            )
            
            SINON
             #[Maison][Gestion Alarme][Out Eté]# - Options : Array
            (
                [enable] => 1
            )
        SINON
    SINON

Swr
Actif
Messages : 689
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Plugin blea

Message par Swr » 03 sept. 2017, 19:22

J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2677
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 03 sept. 2017, 20:48

Hello,

Ce ne serait pas Stretch le problème ? Si j'ai bien suivi, il n'est pas encore supporté... ça se répercute peut-être sur les antennes..
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

raphael_malin
Timide
Messages : 481
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: Plugin blea

Message par raphael_malin » 03 sept. 2017, 22:19

Perso j'ai installé Raspbian Lite, et j'ai le même problème.
Jeedom smart avec en général toutes les mises à jour faites (système et plugin)

Dgigio
Timide
Messages : 1
Inscription : 03 sept. 2017, 14:04

Re: Plugin blea

Message par Dgigio » 03 sept. 2017, 23:16

Même problème sur BLEA et aussi Broadlink pour ma part.
Par contre je suis sur Stretch aussi

Edit : le problème a disparu sur Broadlink (de lui même ?) par contre il est toujours présent sur BLEA

thouve
Timide
Messages : 215
Inscription : 21 oct. 2016, 19:30

Re: Plugin blea

Message par thouve » 04 sept. 2017, 17:34

Salut a tous, j'ai un petit soucis avec BLEA.
Depuis mon retour de vacance,le demon ne veut plus ce lancer.
La configuration est bien sur ok mais le statuts reste NOK.
Dans la configuration mon dongle BT est toujours présent et sélectionné mais rien n'y fait.
Voici une copi des logs debug en essayant d'activer manuellement le demon :

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0
Je suis sous RPi 3 si jamais.

Merci d'avance pour votre aide

benj29
Actif
Messages : 3971
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 04 sept. 2017, 17:46

benj29 a écrit :
03 sept. 2017, 16:09
A tout hasard, mes nuts décrochent... en regardant, je vois dans les logs de BLEA local ceci :

Code : Tout sélectionner

[2017-08-28 19:12:49][ERROR] : 'type' is an invalid keyword argument for this function
[2017-09-03 05:03:17][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:13:57][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:17:57][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:24:37][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:28:38][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
[2017-09-03 05:32:59][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Read timed out. (read timeout=120) retry : 0/3
A quoi cela correspond-il ? Est-ce lié à ma clé Bluetooth ? (j'attends une Sena, mais là où sont mes nuts actuellement le signal n'est pas trop mauvais -79/-80 dBm).

Du coup, pour ceux qui utilisent les nuts, comment faites vous pour "filtrer" la perte/récupération d'un nut "rapide" (sous entendu < 2 min par exemple) ?

Pour l'instant j'ai ajouté un lastchangeduration sur condition à 1 (plus personne =1 dans la maison quand tous les nuts présents sont à 0) à 5 min pour être de plus voir ces variations.

Image

Code : Tout sélectionner

- Nom du scénario : Gestion Alarme Maison
- Objet parent : Maison
- Mode du scénario : provoke
    - Evènement : #[Maison][Présence Maison][Personne ?]#

Gestion de l'alarme de la maison

    
    comment
    
    SI #[Maison][Présence Maison][Personne ?]# == 0 AND #[Maison][Etat Alarme][Actif]# == 1  
    ALORS
     #[NAS - Box][JPI][SMS Benjamin]# - Options : Array
    (
        [enable] => 0
        [title] => 
        [message] => Désactivation automatique de l'alarme
    )
    
     #[NAS - Box][Google][Alerte Benjamin]# - Options : Array
    (
        [enable] => 1
        [title] => [Jeedom-Présence] Désactivation de l'alarme
        [message] => Désactivation automatique de l'alarme
    )
    
     #[Maison][Gestion Alarme][Bonjour !]# - Options : Array
    (
        [enable] => 1
    )
    
    SINON
    
    SI #[Maison][Présence Maison][Personne ?]# == 1 AND #[Maison][Etat Alarme][Actif]# == 0 
    ALORS
     wait - Options : Array
    (
        [enable] => 1
        [condition] => (lastChangeStateDuration(#[Maison][Présence Maison][Personne ?]#,1) > 300)
        [timeout] => 315
    )
    
         
        SI #[Maison][Présence Maison][Personne ?]# == 1 AND #[Maison][Etat Alarme][Actif]# == 0 AND (lastChangeStateDuration(#[Maison][Présence Maison][Personne ?]#,1) > 300)
        ALORS
         #[NAS - Box][JPI][SMS Benjamin]# - Options : Array
        (
            [enable] => 1
            [title] => 
            [message] => Activation automatique de l'alarme
        )
        
         #[NAS - Box][Google][Alerte Benjamin]# - Options : Array
        (
            [enable] => 1
            [title] => [Jeedom-Présence] Activation de l'alarme
            [message] => Activation automatique de l'alarme
        )
        
             
            SI #[Maison][Saison Alarme ?][Alarme]# == 1  
            ALORS
             #[Maison][Gestion Alarme][Out Hiver]# - Options : Array
            (
                [enable] => 1
            )
            
            SINON
             #[Maison][Gestion Alarme][Out Eté]# - Options : Array
            (
                [enable] => 1
            )
        SINON
    SINON
Une idée pour mon souci dans le log ?

J'ai vérifié, je n'ai pas eu de nouveau cas aujourd'hui.

Merci !

raphael_malin
Timide
Messages : 481
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: Plugin blea

Message par raphael_malin » 04 sept. 2017, 21:59

Swr a écrit :
03 sept. 2017, 19:22
J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide
Hello, j'ai ouvert un ticket pour ce problème:
Réponse de l'équipe:
Bonjour, Il vous manque probablement des paquets.
pourriez vous lancer un sudo pip install requests
merci
Cordialement,​


Et depuis cela fonctionne!! 8-)
Jeedom smart avec en général toutes les mises à jour faites (système et plugin)

Swr
Actif
Messages : 689
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Plugin blea

Message par Swr » 07 sept. 2017, 18:46

raphael_malin a écrit :
04 sept. 2017, 21:59
Swr a écrit :
03 sept. 2017, 19:22
J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide
Hello, j'ai ouvert un ticket pour ce problème:
Réponse de l'équipe:
Bonjour, Il vous manque probablement des paquets.
pourriez vous lancer un sudo pip install requests
merci
Cordialement,​


Et depuis cela fonctionne!! 8-)
Un grand merci, c'est parfait...le «coeur bat » à nouveau

raphael_malin
Timide
Messages : 481
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: Plugin blea

Message par raphael_malin » 07 sept. 2017, 23:13

J'ai parfois des déconnexions.
Comment puis-je surveiller que le démon est bien actif?
Comment puis-je attaquer par un scénario le bouton "Lancer"?
L'idée c'est si cela se désactive, que je puisse le relancer de manière automatique après X min par exemple.

J'ai eu aussi le problème de l'état présent/absent qui bascule toutes les 3 minutes, exclusion/inclusion résout le problème.
Je voudrais savoir ou se trouve l'automatisme qui dit que si y'a du signal, présent passe sur présent ? je ne le trouve pas.

Merci
Jeedom smart avec en général toutes les mises à jour faites (système et plugin)

Swr
Actif
Messages : 689
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Plugin blea

Message par Swr » 08 sept. 2017, 22:36

Je viens de découvrir le module ESP32 qui intègre un BT LE et interface wifi, est il possible de l'utiliser en antenne?

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2677
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 09 sept. 2017, 01:08

Peu de chances qu'il ait un linux embarqué...
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

DenisPac
Actif
Messages : 629
Inscription : 14 août 2014, 13:25
Localisation : Près d'Orléans (45)

Re: Plugin blea

Message par DenisPac » 09 sept. 2017, 20:37

Swr a écrit :
07 sept. 2017, 18:46
raphael_malin a écrit :
04 sept. 2017, 21:59
Swr a écrit :
03 sept. 2017, 19:22
J'ai installé blea de nombreuses fois avec le tuto de Sarakha et sans erreur, mais aujourd'hui, j'ai cette erreur.
Error: importing module from jeedom folder


En regardant le forum, je vois qu'elle est abordée plusieurs fois.

J'ai donc installé
sudo apt-get install python-dev

Activé le BT
sudo systemctl enable hciuart
et
sudo systemctl start hciuart

A savoir, le BT est sur un PI3 avec Stretch

Merci d'avance de votre aide
Hello, j'ai ouvert un ticket pour ce problème:
Réponse de l'équipe:
Bonjour, Il vous manque probablement des paquets.
pourriez vous lancer un sudo pip install requests
merci
Cordialement,​


Et depuis cela fonctionne!! 8-)
Un grand merci, c'est parfait...le «coeur bat » à nouveau
Bonsoir,
J'ai eu la même erreur sur une nouvelle antenne (Rasbian Stretch) avec SqeezeLite.
Et la commande

Code : Tout sélectionner

sudo pip install requests
a également résolu le problème.
Merci !
Jeedom Maître sur VM Debian sur ESXi (N54L) + Z-Stick 2 (non fonctionnel) + RFXCOM
Jeedom déporté Z-Wave sur Jeedom mini avec JeeLink
Antenne RPI3 BLEA, Netatmo, Philips Hue, Xiaomi Home, Yeelight, Dash Button, ...

thouve
Timide
Messages : 215
Inscription : 21 oct. 2016, 19:30

Re: Plugin blea

Message par thouve » 10 sept. 2017, 01:15

thouve a écrit :
04 sept. 2017, 17:34
Salut a tous, j'ai un petit soucis avec BLEA.
Depuis mon retour de vacance,le demon ne veut plus ce lancer.
La configuration est bien sur ok mais le statuts reste NOK.
Dans la configuration mon dongle BT est toujours présent et sélectionné mais rien n'y fait.
Voici une copi des logs debug en essayant d'activer manuellement le demon :

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0

Code : Tout sélectionner

[2017-09-04 17:31:09][INFO] : Start blead
[2017-09-04 17:31:09][INFO] : Log level : debug
[2017-09-04 17:31:09][INFO] : Socket port : 55008
[2017-09-04 17:31:09][INFO] : Socket host : 127.0.0.1
[2017-09-04 17:31:09][INFO] : Device : hci0
[2017-09-04 17:31:09][INFO] : PID file : /tmp/blead.pid
[2017-09-04 17:31:09][INFO] : Apikey : yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj
[2017-09-04 17:31:09][INFO] : Callback : http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php
[2017-09-04 17:31:09][INFO] : Cycle : 0.3
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.dotti
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.fitbit
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.gigaset
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.hector
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.itag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.jinlin
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.logiswitch
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miband2
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miflora
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.miscale
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.myfox
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.niu
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.noke
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.nut
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.playbulb
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.smartplug
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.tb05
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.ticatag
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.wistiki
[2017-09-04 17:31:09][INFO] : Import de la configuration devices.yeelight
[2017-09-04 17:31:09][DEBUG] : Writing PID 903 to /tmp/blead.pid
[2017-09-04 17:31:09][DEBUG] : Init request module v2.4.3
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : Socket interface started
[2017-09-04 17:31:09][DEBUG] : LoopNetServer Thread started
[2017-09-04 17:31:09][INFO] : Start listening...
[2017-09-04 17:31:09][DEBUG] : Listening on: [127.0.0.1:55008]
[2017-09-04 17:31:09][INFO] : Preparing Scanner...
[2017-09-04 17:31:09][DEBUG] : Read Socket Thread Launched
[2017-09-04 17:31:09][DEBUG] : Read Device Thread Launched
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:09][DEBUG] : Heartbeat Thread Launched
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'local'}
[2017-09-04 17:31:09][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:09][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 7): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][WARNING] : Exception on scanner (trying to resolve by myself 8): Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'
[2017-09-04 17:31:10][INFO] : Shutting down due to errors
[2017-09-04 17:31:10][DEBUG] : Send to jeedom :  {'source': 'local', 'learn_mode': 0}
[2017-09-04 17:31:10][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2017-09-04 17:31:10][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=yAmV0XAv5Bt7uh6NIyXGGLS4AEel02Mj HTTP/1.1" 200 0
[2017-09-04 17:31:12][DEBUG] : Shutdown
[2017-09-04 17:31:12][DEBUG] : Removing PID file /tmp/blead.pid
[2017-09-04 17:31:12][DEBUG] : Closing all potential bluetooth connection
[2017-09-04 17:31:12][DEBUG] : LoopNetServer Thread stopped
[2017-09-04 17:31:12][DEBUG] : Exit 0
Je suis sous RPi 3 si jamais.

Merci d'avance pour votre aide
Personne? :(

yves273
Timide
Messages : 321
Inscription : 18 janv. 2016, 11:13

Re: Plugin blea

Message par yves273 » 10 sept. 2017, 08:47

Bonjour,

J'ai des boutons ticatag avec smart v3 (Je les ai mis côte à côte) marqué comme non présent dans le widget.
L'onglet santé donne une dernière communication soit récente (moins de 15mn), ils sont marqués comme non présent dans l'onglet santé.
Est-ce qu'il y a une explication?

vincecoco
Actif
Messages : 1173
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 11 sept. 2017, 14:07

Hello,
Quelqu'un a-t-il tester l'installation d'Antenne sur un PiCorePlayer ?

Merci

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2677
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 11 sept. 2017, 21:23

Hello,

On en a parlé un peu plus haut... à priori ce n'est pas possible car on ne peut pas installer de manière simple un package sur PiCore.
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

vincecoco
Actif
Messages : 1173
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 11 sept. 2017, 23:37

J'ai regardé bon peut installer via tcz-load -wi ou depuis l'interface web.
Il reste à trouver tous les paquets nécessaire.
J'ai déjà mis bluetooth et bluez hcidump mais il manque des trucs

vincecoco
Actif
Messages : 1173
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 12 sept. 2017, 15:30

*Hello,
J'ai tenté d'installé une antenne sur mon PI2 OSMC
- Envoie des fichiers : OK
- Installation des dépendances : OK
- Lancement du démon KO

Code : Tout sélectionner

Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Auriez vous une idée, je n'ai rien trouvé lors de ma recherche :)


[Edit] J'ai voulu redémarrer osmc mais à présent plus moyen de monter le BT

Code : Tout sélectionner

 sudo hciconfig hci0 up
Can't init device hci0: Operation not possible due to RF-kill (132)
Il faut installer rfkill d'après ce que j'ai compris ? (Si quelqu'un peut me confirmer merci)

[Edit 2] Pour ne pas avoir ce message je dois mettre la clef, apres démarrage du PI....

Merci bcp

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : arnog23 et 1 invité