Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Bosquetia
Actif
Messages : 6777
Inscription : 10 mai 2016, 07:54

Re: Plugin blea

Message par Bosquetia » 04 oct. 2017, 15:04

Quelle est ta version de jeedom et du plugin ?

Blum95
Timide
Messages : 313
Inscription : 10 oct. 2014, 18:16

Re: Plugin blea

Message par Blum95 » 04 oct. 2017, 16:43

Voilà:
Capture.JPG
Capture.JPG (25.06 Kio) Consulté 616 fois
Jeedom sur ESXi SSD Debian 9.
ZWAVE, RFXCOM, BT, TéléInfo, WifiLight, Alexa
9 Sondes, 4 Detecteurs 6 Ouvertures en 433.
9 Modules Zwave
5 Cams IP

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3380
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 04 oct. 2017, 17:09

Bonjour,

La configuration et la version semble bonne (le service est démarré).

Quel est le problème exactement ?
- avez vous tenté d'y inclure des périphériques à la norme BT4 qui fonctionne en "Advertissement" ?

Exemple :
OK pour un iTag, NUT, et divers objet dit "Connecté"
NOK pour une enceinte, un smartphone... qui eux ne répondent pas à cette norme.
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2677
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 04 oct. 2017, 19:26

Hello à tous,

Perso, mes nuts fonctionnent toujours sur la dernière version de BLEA... ils sont câblés sur un virtuel, avec la répétition de la commande de présence du Nut sur 'Auto'. En revanche sur le virtuel (c'est donc lui qui récupère les infos des 3 nuts et déclenche les scénarios) les commandes de présence sont réglées sur 'Jamais répéter'.
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Blum95
Timide
Messages : 313
Inscription : 10 oct. 2014, 18:16

Re: Plugin blea

Message par Blum95 » 05 oct. 2017, 08:32

j'ai relancer les dépendances ça fonctionne


Me reste à trouvé où commander des NUT mini pour mes clés à petits prix
Jeedom sur ESXi SSD Debian 9.
ZWAVE, RFXCOM, BT, TéléInfo, WifiLight, Alexa
9 Sondes, 4 Detecteurs 6 Ouvertures en 433.
9 Modules Zwave
5 Cams IP

Blum95
Timide
Messages : 313
Inscription : 10 oct. 2014, 18:16

Re: Plugin blea

Message par Blum95 » 05 oct. 2017, 09:11

Par contre j'ai un équipement qui a été détecté mais impossible de savoir ce que c'est
Capture.JPG
Capture.JPG (124.29 Kio) Consulté 567 fois
:?: :?:
Jeedom sur ESXi SSD Debian 9.
ZWAVE, RFXCOM, BT, TéléInfo, WifiLight, Alexa
9 Sondes, 4 Detecteurs 6 Ouvertures en 433.
9 Modules Zwave
5 Cams IP

benj29
Actif
Messages : 3934
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 05 oct. 2017, 09:59

Blum95 a écrit :
05 oct. 2017, 08:32
j'ai relancer les dépendances ça fonctionne


Me reste à trouvé où commander des NUT mini pour mes clés à petits prix
Amazon rapide, entre 6 et 9€ maxi suivant la couleur.

Blum95
Timide
Messages : 313
Inscription : 10 oct. 2014, 18:16

Re: Plugin blea

Message par Blum95 » 05 oct. 2017, 10:49

Jeedom sur ESXi SSD Debian 9.
ZWAVE, RFXCOM, BT, TéléInfo, WifiLight, Alexa
9 Sondes, 4 Detecteurs 6 Ouvertures en 433.
9 Modules Zwave
5 Cams IP

benj29
Actif
Messages : 3934
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 05 oct. 2017, 11:13

Je sais pas, j'ai les nuts officiels...
Franchement vu le prix et la durée de vie des batteries, je m'embête pas à gagner 3€...

Maxime62110
Timide
Messages : 8
Inscription : 04 nov. 2016, 15:54

Re: Plugin blea

Message par Maxime62110 » 05 oct. 2017, 15:30

Salut a tous j'ai un soucis ...
mes depandances blea :
Installation en cours - 0 % - 3425 min
Dans mes logs ca install en boucle une solution ?
Je suis sur pi 3 avec le bluetooth du pi .
Logs :

Code : Tout sélectionner

[code]Launch install of blea dependancy
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit https://deb.nodesource.com jessie InRelease
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Hit https://deb.nodesource.com jessie/main Sources
Hit https://deb.nodesource.com jessie/main armhf Packages
Get:1 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:2 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:3 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:4 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:5 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 85 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
libelfg0 libglib2.0-bin
Suggested packages:
git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
gitweb git-arch git-cvs git-mediawiki git-svn libglib2.0-doc
The following NEW packages will be installed:
libelfg0 libglib2.0-bin libglib2.0-dev
The following packages will be upgraded:
git
Reading changelogs...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
1 upgraded, 3 newly installed, 0 to remove and 84 not upgraded.
Need to get 0 B/6550 kB of archives.
After this operation, 9599 kB of additional disk space will be used.
/usr/bin/dpkg-split: 1: /usr/bin/dpkg-split: Syntax error: word unexpected (expecting ")")
E: Sub-process /usr/bin/dpkg exited unexpectedly
Requirement already satisfied: pyudev in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python2.7/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/bluepy
copying bluepy/thingy52.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/sensortag.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scanner.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/get_services.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/btle.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/blescan.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/__init__.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/uuids.json -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluez-src.tgz -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluepy-helper.c -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/Makefile -> build/lib.linux-armv7l-2.7/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
Failed to compile bluepy-helper. Exiting install.
Command was 'make -C bluepy -j1' in /tmp/bluepy
Return code was 2
Output was:
make: Entering directory '/tmp/bluepy/bluepy'
tar xzf bluez-src.tgz
touch ./bluez-5.29/lib/bluetooth.c ./bluez-5.29/lib/hci.c ./bluez-5.29/lib/sdp.c ./bluez-5.29/lib/uuid.c ./bluez-5.29/attrib/att.c ./bluez-5.29/attrib/gatt.c ./bluez-5.29/attrib/gattrib.c ./bluez-5.29/attrib/utils.c ./bluez-5.29/btio/btio.c ./bluez-5.29/src/log.c ./bluez-5.29/src/shared/mgmt.c ./bluez-5.29/src/shared/crypto.c ./bluez-5.29/src/shared/att.c ./bluez-5.29/src/shared/queue.c ./bluez-5.29/src/shared/util.c ./bluez-5.29/src/shared/io-glib.c ./bluez-5.29/src/shared/timeout-glib.c
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
gcc -L. -Os -g -Wall  -DHAVE_CONFIG_H -I./bluez-5.29/attrib -I./bluez-5.29 -I./bluez-5.29/lib -I./bluez-5.29/src -I./bluez-5.29/gdbus -I./bluez-5.29/btio  -o bluepy-helper bluepy-helper.c ./bluez-5.29/lib/bluetooth.c ./bluez-5.29/lib/hci.c ./bluez-5.29/lib/sdp.c ./bluez-5.29/lib/uuid.c ./bluez-5.29/attrib/att.c ./bluez-5.29/attrib/gatt.c ./bluez-5.29/attrib/gattrib.c ./bluez-5.29/attrib/utils.c ./bluez-5.29/btio/btio.c ./bluez-5.29/src/log.c ./bluez-5.29/src/shared/mgmt.c ./bluez-5.29/src/shared/crypto.c ./bluez-5.29/src/shared/att.c ./bluez-5.29/src/shared/queue.c ./bluez-5.29/src/shared/util.c ./bluez-5.29/src/shared/io-glib.c ./bluez-5.29/src/shared/timeout-glib.c
bluepy-helper.c:33:18: fatal error: glib.h: No such file or directory
#include <glib.h>
^
compilation terminated.
(null):0: confused by earlier errors, bailing out
Makefile:28: recipe for target 'bluepy-helper' failed
make: *** [bluepy-helper] Error 4
make: Leaving directory '/tmp/bluepy/bluepy'
Everything is successfully installed!
[/code]
Dernière édition par Maxime62110 le 05 oct. 2017, 15:51, édité 1 fois.


Maxime62110
Timide
Messages : 8
Inscription : 04 nov. 2016, 15:54

Re: Plugin blea

Message par Maxime62110 » 05 oct. 2017, 15:51

Voila :p

squwal
Timide
Messages : 60
Inscription : 25 mai 2017, 17:15

Re: Plugin blea

Message par squwal » 05 oct. 2017, 16:14

Je rajoute quelques logs au problème de déconnections :

Code : Tout sélectionner


*** Error in `/usr/bin/python': double free or corruption (out): 0x75005510 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x72400e08 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75902f28 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75902ea0 ***
*** Error in `/usr/bin/python': free(): invalid pointer: 0x759026d0 ***
*** Error in `/usr/bin/python': free(): invalid pointer: 0x75903bf8 ***
*** Error in `/usr/bin/python': free(): invalid pointer: 0x750060a0 ***
*** Error in `/usr/bin/python': free(): invalid pointer: 0x75001290 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75001000 ***
*** Error in `/usr/bin/python': free(): invalid pointer: 0x75005570 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75901740 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75903608 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x759046f8 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75904d40 ***
*** Error in `/usr/bin/python': double free or corruption (out): 0x75906088 ***

Envoyé de mon ONE A2003 en utilisant Tapatalk


benj29
Actif
Messages : 3934
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 06 oct. 2017, 08:16

Au passage, hier en faisant un peu de ménage sur mon Jeedom, j'ai eu la désagréable surprise de voir que mes scénarios de présence / gestion de nut tournaient "souvent" alors que les clés étaient dans la maison depuis des heures...

Du coup, j'ai modifié "Jamais répéter" dans les paramètres de Présent...

Ca doit soulager maintenant !

Rabieau
Timide
Messages : 115
Inscription : 24 déc. 2016, 10:15

Re: Plugin blea

Message par Rabieau » 06 oct. 2017, 09:49

Bonjour,
Quelqu’un aurait-il réussi à inclure des Playbulb Garden dont le firmware est en 2.3 ? Je viens d’en recevoir et n’arrive pas à les inclure.
Je sais qu’il y a beaucoup de firmware apparemment (2 versions disponibles lors de l’ajout) et de fait pas évident qu’ils soient tous présents dans le plugin.
Y’a-t-il un moyen de récupérer les infos de ce firmware et demander à ce qu’elles soient ajoutées au plugin ?

scotty92fr
Timide
Messages : 261
Inscription : 07 mars 2017, 20:31

Re: Plugin blea

Message par scotty92fr » 06 oct. 2017, 17:22

Bonjour,

Je viens de recevoir un un XIAOMI Mi Flore. la communication se passe bien avec l'application "Flower Care".

Par contre je n'arrive pas à le faire reconnaitre sur JEEDOM

par le plugin BLEA J'ai bien eu des détections d’équipements "inconnu" dont la seul information est un nom de type MAC adresse
j'ai beau essayer de passer l’équipement en "Miflora" mais une fois modifié les commandes ne répondent pas comme attendue.

Est ce que quelqu'un pourrait m'expliquer comment connaitre la MAC d'un équipement en Bluetooth ?
Comment faire pour intégrer le XIAOMI Mi Flore sur Jeedom ?

Le log Blea ne donne pas grand chose :

Code : Tout sélectionner

[2017-10-06 17:16:13][DEBUG] : This is a message from antenna local
[2017-10-06 17:16:14][DEBUG] : This is a message from antenna local
[2017-10-06 17:16:19][DEBUG] : This is a message from antenna local
[2017-10-06 17:16:20][DEBUG] : This is a message from antenna local
[2017-10-06 17:16:20][INFO] : This is a learn from antenna local
[2017-10-06 17:16:26][DEBUG] : This is a message from antenna local
[2017-10-06 17:16:26][INFO] : This is a heartbeat from antenna local
[2017-10-06 17:17:20][DEBUG] : This is a message from antenna local
[2017-10-06 17:17:21][DEBUG] : This is a message from antenna local
[2017-10-06 17:17:22][DEBUG] : This is a message from antenna local
[2017-10-06 17:17:22][INFO] : This is a heartbeat from antenna local
la commande rawdata sur un équipement que je pense être le bon me donne :
Capture d’écran 2017-10-06 à 17.16.57.png
Capture d’écran 2017-10-06 à 17.16.57.png (23.84 Kio) Consulté 896 fois
Jeedom 4.0.19 DIY RPI3/SSD , Zwave - Rfxcom - ...

Djal94
Actif
Messages : 1224
Inscription : 09 août 2016, 09:21

Re: Plugin blea

Message par Djal94 » 06 oct. 2017, 18:38

Juste pour t'éviter de chercher, tu as bien déconnecté ton miflora de ton bluetooth de téléphone avant de lancer la detection?
Jeedom 3.2.11 sur NUC Intel (Debian 8)
Zwave - BLEA - Wifi
Trucs et Astuces

scotty92fr
Timide
Messages : 261
Inscription : 07 mars 2017, 20:31

Re: Plugin blea

Message par scotty92fr » 06 oct. 2017, 20:09

Merci Djal94,

Oui, comme beaucoup d'éléments bluetooth, le Flower Care ne doit pas aimer une double connexion :)
Jeedom 4.0.19 DIY RPI3/SSD , Zwave - Rfxcom - ...

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: Plugin blea

Message par BaaTuuC » 07 oct. 2017, 18:40

Bonjour tous, le plugin est il ok avec le bluettoth natif sur rpi3 ou faut il une clé bluetooth supplémentaire ?
je ne trouve aucune doc sur ce plugin ..
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

benj29
Actif
Messages : 3934
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 07 oct. 2017, 18:42

BaaTuuC a écrit :Bonjour tous, le plugin est il ok avec le bluettoth natif sur rpi3 ou faut il une clé bluetooth supplémentaire ?
je ne trouve aucune doc sur ce plugin ..
Perso j'utilise une antenne avec le Bluetooth sur la pi3 ras.

Envoyé de mon Moto G (4) en utilisant Tapatalk


Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité