Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 06 déc. 2017, 14:12

J'aime les bugs tapatalk

Envoyé de mon Moto G (4) en utilisant Tapatalk

Damien

olivier42
Timide
Messages : 142
Inscription : 26 janv. 2016, 07:47
Localisation : Montpellier
Contact :

Re: Plugin blea

Message par olivier42 » 06 déc. 2017, 14:13

cadavor a écrit :
06 déc. 2017, 12:25
sheep300 a écrit :
03 déc. 2017, 00:27
bonjour
je posse un flower care (miflora) en version 2.7.0 situé a la base dune plante dehors.
depuis que les temperatures arrive dans le négatif je constate que la temperature affiche : 655x.x (ex : 6550.3°c) des que ca descend en dessous de 0.
est ce normal ?
y'a t'il une méthode de calcul a faire ?
dans les logs pas d'erreurs.
merci ^^
Comme ça, a brûle-pourpoint, je dirais :
Si valeur > 3276.7 alors valeur = valeur - 6553.4
Exemple : 6550.3 => -3.1
Ca me semble tout à fait probable :)

Avatar de l’utilisateur
cadavor
Actif
Messages : 1262
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Plugin blea

Message par cadavor » 06 déc. 2017, 15:33

sheep300 a écrit :
06 déc. 2017, 13:14
J'essaierai ça vient d'où la valeur 6553,4 ?

Envoyé de mon Moto G (4) en utilisant Tapatalk
Oui désolé réponse rapide pour donner une solution probable sans explication.
Merci @Nibb31 pour le complément d'infos
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 06 déc. 2017, 15:34

cadavor a écrit :
sheep300 a écrit :
06 déc. 2017, 13:14
J'essaierai ça vient d'où la valeur 6553,4 ?

Envoyé de mon Moto G (4) en utilisant Tapatalk
Oui désolé réponse rapide pour donner une solution probable sans explication.
Merci @Nibb31 pour le complément d'infos
Pas de problème c'est déjà gentil d y réfléchir même rapidement

Envoyé de mon Moto G (4) en utilisant Tapatalk

Damien

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 06 déc. 2017, 16:32

J ai mis dans formule
If #value#>3276.7 then #value#=#value#-6553.4
C'est bon ?

Envoyé de mon Moto G (4) en utilisant Tapatalk

Damien

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 10 déc. 2017, 11:30

bon alors deja merci j'ai fait des essais avec la formule If #value#>3276.7 then #value#=#value#-6553.4 j'ai 0 tout le temps.
je pense que c'est juste qu'il ne comprend pas la formule.
j'ai essayer : #value#>3276.7?#value#-6553.4
formule volée dans un autre article sur les conditions dans les formules.
j'ai les valeurs positives qui sont revenues.
vous validez cette formules ?
a voir au prochains froid !
Damien

pawnies
Timide
Messages : 142
Inscription : 08 août 2016, 21:22

Re: Plugin blea

Message par pawnies » 11 déc. 2017, 15:27

Salut a tous.
Une lampe comme celle la deviendrait compatible BLEA?
https://www.tomtop.com/p-s1558w.html?ai ... &cr=blogbp

Avatar de l’utilisateur
domoggvad
Actif
Messages : 1876
Inscription : 29 avr. 2015, 16:02
Localisation : Seine-Saint-Denis (Villepinte)

Re: Plugin blea

Message par domoggvad » 16 déc. 2017, 10:55

Bonjour @sharaka63
j'ai une association de la serrure The-key qui remonte dans blea, penses tu a une possibilité d’intégration?
merci
3 Odroid C2 (Prod - secours - test) Z83 tests: rfxcom + Z-wave- Clims DAIKIN - espeasy - thekey - Xiaomi - Telinfo - broadlink... widget V3 :viewtopic.php?f=29&t=44183&p=717810#p717810

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3412
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 16 déc. 2017, 11:12

Bonjour voisin,

Pourquoi ne pas voir cela sur le sujet dédié à cette serrure ?
viewtopic.php?f=134&t=32267
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
domoggvad
Actif
Messages : 1876
Inscription : 29 avr. 2015, 16:02
Localisation : Seine-Saint-Denis (Villepinte)

Re: Plugin blea

Message par domoggvad » 16 déc. 2017, 14:58

Salut voisin,
Comme je voulais alerter l'auteur du plugin BLEA, et non the key qui fonctionne dejà avec une gateway.
Dernière édition par domoggvad le 16 déc. 2017, 14:58, édité 1 fois.
3 Odroid C2 (Prod - secours - test) Z83 tests: rfxcom + Z-wave- Clims DAIKIN - espeasy - thekey - Xiaomi - Telinfo - broadlink... widget V3 :viewtopic.php?f=29&t=44183&p=717810#p717810

ioull
Timide
Messages : 135
Inscription : 11 juin 2015, 16:46

Re: Plugin blea

Message par ioull » 17 déc. 2017, 07:13

Tout d'abord merci pour ce super boulot !
Ensuite je me demandais si c'était possible d'utiliser le plugin juste avec une antenne ? En effet mon serveur faisant tourner jeedom se trouvant dans les combles et vu la portée du bt, le dongle du serveur ne me sert à rien ;-)

Merci !!!

Envoyé de mon Nexus 6P en utilisant Tapatalk

Jeedom sous proxmox sur HP54NL
Rfxcom : CM180i / UVN800 / 11 temperature / 2 VR Somfy
Z-Stick: 6 VR / 5 Fil Pilote / 1 Zipato / 1 sirene / 2 Smoke sensor
GW Xiaomi: 12 détecteurs ouvertures / 4 motions / 2 cubes
BLEA: Miflora / MiBand

Avatar de l’utilisateur
Giome
Timide
Messages : 191
Inscription : 03 oct. 2015, 06:18

Re: Plugin blea

Message par Giome » 17 déc. 2017, 08:08

Tu peux sans problème, je l'ai fais car mon RPI3 n'a jamais été très coopératif que ce soit avec le BT interne ou un dongle du coup j'ai branché le dongle sur mon NAS et le nécessaire pour l'antenne tournait dans un conteneur Docker.

ioull
Timide
Messages : 135
Inscription : 11 juin 2015, 16:46

Re: Plugin blea

Message par ioull » 17 déc. 2017, 08:26

Pourtant j’ai l’impression que le plugin ne démarre pas si il n’as pas de périphérique bt ... du coup il remonte pas les infos des antennes :-(


Envoyé de mon iPad en utilisant Tapatalk Pro
Jeedom sous proxmox sur HP54NL
Rfxcom : CM180i / UVN800 / 11 temperature / 2 VR Somfy
Z-Stick: 6 VR / 5 Fil Pilote / 1 Zipato / 1 sirene / 2 Smoke sensor
GW Xiaomi: 12 détecteurs ouvertures / 4 motions / 2 cubes
BLEA: Miflora / MiBand

Avatar de l’utilisateur
Giome
Timide
Messages : 191
Inscription : 03 oct. 2015, 06:18

Re: Plugin blea

Message par Giome » 17 déc. 2017, 18:54

Le démon du plugin ne démarrera pas c'est sur car il n'a pas de port pour le bluetooth mais les infos de l'antenne remonte sans problème. Tu peux vérifier le statut de l'antenne avec son "cœur" si c'est vert c'est tout bon sinon problème. Aussi pense a autoriser chaque équipement sur TOUTES les antennes et non pas seulement "local".

Hopper
Helper
Messages : 26
Inscription : 17 févr. 2016, 00:12

Re: Plugin blea

Message par Hopper » 18 déc. 2017, 00:32

cyrilphoenix a écrit :
24 janv. 2017, 15:51
@Sarakha63, depuis ce matin 11h je ne plus d'info ni présence de mon miFlower.
J'ai regardé dans le log, j'ai ca :
[2017-01-24 11:03:15][ERROR] : 'str' object has no attribute 'disconnect'

Que dois-je faire ?

Ps : a propos du probable conflit avec pulse voici les erreurs que j'avais ce matin avant de desactiver pulse :
[2017-01-24 09:18:09][ERROR] : Critical error on send_changes_async local variable 'r' referenced before assignment
[2017-01-24 09:18:14][ERROR] : Error on send request to jeedom ('Connection aborted.', error(111, 'Connection refused')) retry : 0/3
[2017-01-24 09:18:14][ERROR] : Error on send request to jeedom ('Connection aborted.', error(111, 'Connection refused')) retry : 1/3
[2017-01-24 09:18:14][ERROR] : Error on send request to jeedom ('Connection aborted.', error(111, 'Connection refused')) retry : 2/3

Une idée ?

Si le problème est toujours d'actualité, ou pour ceux qui viennent de le rencontrer et qui n'aurait pas la solution, alors rendez-vous ici « viewtopic.php?f=146&t=22870&p=560404#p560404 »

ioull
Timide
Messages : 135
Inscription : 11 juin 2015, 16:46

Re: Plugin blea

Message par ioull » 18 déc. 2017, 10:10

Giome a écrit :Le démon du plugin ne démarrera pas c'est sur car il n'a pas de port pour le bluetooth mais les infos de l'antenne remonte sans problème. Tu peux vérifier le statut de l'antenne avec son "cœur" si c'est vert c'est tout bon sinon problème. Aussi pense a autoriser chaque équipement sur TOUTES les antennes et non pas seulement "local".
Du coup ce serait top d'avoir le local géré comme les antennes ;-) ça éviterait une erreur sur le plugin !!!

Je vais tester ça ;-) merci !

Envoyé de mon Nexus 6P en utilisant Tapatalk

Jeedom sous proxmox sur HP54NL
Rfxcom : CM180i / UVN800 / 11 temperature / 2 VR Somfy
Z-Stick: 6 VR / 5 Fil Pilote / 1 Zipato / 1 sirene / 2 Smoke sensor
GW Xiaomi: 12 détecteurs ouvertures / 4 motions / 2 cubes
BLEA: Miflora / MiBand

mibis
Timide
Messages : 217
Inscription : 17 déc. 2015, 00:36

Re: Plugin blea

Message par mibis » 19 déc. 2017, 15:16

meneomic a écrit :
12 nov. 2017, 10:32
Pour les SmartLED d'Awox (http://www.awox.com/awox_product/smartled/), j'en suis là:

En mode console sur le Rpi (XX:XX:XX:XX:XX:XX = MAC adress de la lampe):

Code : Tout sélectionner

Eteindre : sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x002a -n 00
Allumer: sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x002a -n 01

Lumière Froide: sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x003f -n 00
Lumière Chaude: sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x003f -n 7f

Lumière minimum: sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x0044 -n 01
Lumière maximale: sudo gatttool -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x0044 -n 7f

0x002a: 00 (OFF) - 01 (ON)
0x0044: Intensité de 00 à 7f (01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f 10 11 12 ...)
0x003f: Couleur de 00 à 7f
Ensuite, j'ai voulu intégrer cela dans le plugin BLEA. J'ai ajouté en local les fichiers smartled.json et smartled.py. Je m'inspire des commandes envoyées au playbulb. (je mets ces deux fichiers en annexe).
Awox.zip
Ces 2 fichiers ne sont pas optimaux mais fonctionnels, je ne les destine pas à être intégrer tel quel sur le plug-in. C'est juste ma base de travail.

Pour l'instant j'ai changé les commandes directement dans Jeedom comme ceci:
screenshot.1.jpg


Ça fonctionne relativement bien. J'aurai aimé trouver une méthode pour faire un "dimmer" (0% = 00 et 100% = 7f, avec toutes les valeurs intermédiaires). Et aussi, que le plugin retrouve l'état de la lampe.
Mais là,... je sèche un peu...
Merci meneomic pour toutes ces informations, mais ça ne fonctionne pas chez moi.
Je n'ai pas les mêmes ampoules, moi c'est un panneau Led awox eglo en bluetooth mesh technologie.
https://www.leroymerlin.fr/v3/p/produit ... 1500366049
J'ai essayé de retrouver les commandes avec wireshark, mais je n'ai pas réussi :(

Quelqu'un a t'il réussi a trouver les commandes pour l'éclairage eglo en mesh technologie?
Jeedom sur Rpi3 / ssd avec passerelle Zibasedom / zibase

Avatar de l’utilisateur
czara
Timide
Messages : 76
Inscription : 03 juil. 2016, 13:39

Re: Plugin blea

Message par czara » 20 déc. 2017, 22:34

Bonjour,

Désolé si le sujet a déjà été traité, mais il y a beaucoup de page sur ce plugin, mais pour plusieurs éléments Bluetooth, C'est donc difficile de retrouver les informations voulues, bref ...
J'ai acheté des Mi Band 1S, je souhaitais les ajouter à Jeedom via BLEA mais je n'ai aucun des bracelets de détecté.
Celui que j'utilise fonctionne parfaitement avec l'application, j'ai bien modifié la présence dans l'application afin que le bracelet puisse être modifié.

La version du firmware de mon bracelet est 4.16.11.15

Je n'ai pas d'autre objet bluetooth pour faire des tests.

Pouvez vous m'indiquer quel logiciel je dois regarder, j'ai activé le mode debug, mais je ne vois aucune détection :

[2017-12-20 22:24:49][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:25:45][DEBUG] : This is a message from antenna local
[2017-12-20 22:25:45][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:26:41][DEBUG] : This is a message from antenna local
[2017-12-20 22:26:41][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:27:37][DEBUG] : This is a message from antenna local
[2017-12-20 22:27:37][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:28:33][DEBUG] : This is a message from antenna local
[2017-12-20 22:28:33][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:29:29][DEBUG] : This is a message from antenna local
[2017-12-20 22:29:29][INFO] : This is a heartbeat from antenna local
[2017-12-20 22:30:25][DEBUG] : This is a message from antenna local
[2017-12-20 22:30:25][INFO] : This is a heartbeat from antenna local

[2017-12-20 22:31:21][DEBUG] : Send to jeedom : {'heartbeat': 1, 'source': 'local'}
[2017-12-20 22:31:21][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2017-12-20 22:31:21][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=XXXXX HTTP/1.1" 200 0
[2017-12-20 22:32:17][DEBUG] : Send to jeedom : {'heartbeat': 1, 'source': 'local'}
[2017-12-20 22:32:17][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2017-12-20 22:32:17][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=XXXXX HTTP/1.1" 200 0

Désolé encore si le sujet a été traité ...

Christophe

Avatar de l’utilisateur
rombautsdidier
Helper
Messages : 446
Inscription : 01 juin 2016, 07:56
Localisation : Grabels, France
Contact :

Re: Plugin blea

Message par rombautsdidier » 29 déc. 2017, 11:59

sarakha63 a écrit :
19 janv. 2017, 17:47
vosmont a écrit :Hello,

je ne sais pas si ça a été vu mais mon MiPlant m'annonce 6653.4°C pour la température.
:)
Il est dehors et il fait pas mal froid...
Oui soucis de valeur négative je corrige dans la prochaine version

Envoyé de mon SM-G930F en utilisant Tapatalk
J'ai la version du 2017-09-26 et j'ai toujours le problème... J'ai regardé le gitHub et le problème semble toujours ouvert.
Une idée de la date de la prochaine version qui contiendra la correction?
Didier Rombauts
Helper Officiel Jeedom
Jeedom SMART
https://didier.rombauts.fr

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 29 déc. 2017, 12:24

rombautsdidier a écrit :
sarakha63 a écrit :
19 janv. 2017, 17:47
vosmont a écrit :Hello,

je ne sais pas si ça a été vu mais mon MiPlant m'annonce 6653.4°C pour la température.
:)
Il est dehors et il fait pas mal froid...
Oui soucis de valeur négative je corrige dans la prochaine version

Envoyé de mon SM-G930F en utilisant Tapatalk
J'ai la version du 2017-09-26 et j'ai toujours le problème... J'ai regardé le gitHub et le problème semble toujours ouvert.
Une idée de la date de la prochaine version qui contiendra la correction?
Regarde un peu plus haut j'ai mis la méthode de calcul qui va bien à mettre dans la formule

Envoyé de mon Moto G (4) en utilisant Tapatalk

Damien

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités