Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

AlainM
Actif
Messages : 1036
Inscription : 20 mars 2016, 14:21
Localisation : Hérault

Re: Plugin blea

Message par AlainM » 18 juil. 2019, 14:06

Petit message pour dire que j'étais content de gérer mes plantes vertes avec les MiFlora mais j'ai abandonné au bout d'un an. L'un après l'autre, ils racontaient n'importe quoi rien qu'au niveau du taux d'humidité. Puis j'ai dû désactiver certains qui ne fonctionnaient plus après un changement de pile.
Au final j'ai coupé BLEA et j'économise en charge sur mon PI3B+.
Pour savoir quand je dois arroser, je mets mon doigt en guise de sonde :)

defmy
Timide
Messages : 250
Inscription : 14 sept. 2015, 08:52

Re: Plugin blea

Message par defmy » 19 juil. 2019, 16:03

Même souci que vous, depuis un certain temps tous mes mi flora ne se mettent plus à jour automatiquement.

Pour avoir des valeurs à jour, je suis obligé de faire un refresh. Pourtant tout fonctionne, dans la page santé, l'ensemble des équipements communique très bien. Je n'utilise aucune autre application tierce pouvant perturber les capteurs. Même mes NUT sont opérationnels...
En attendant de trouver une solution, j'ai créer un scénario pour refresh chaque capteur tous les X heures. Je trouve ça nul mais je n'ai pas d'autres solutions pour l'instant...

Et un autre problème quand je coche "pas de local", je n'ai plus de graphes, tout est superposé.

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin blea

Message par Idaho947 » 20 juil. 2019, 09:47

Bonjour,

Je viens d'installer la maj beta de ce matin. Depuis, mon antenne ne se relance pas. J'ai déporté mon antenne sur une vm en debian pour éviter les problèmes d'instabilité.

J'ai essayé de la redémarrer, de relancer les dépendance mais rien n'y fait.

Dans le log j'ai ce message :
[sudo] Mot de passe de pi : Traceback (most recent call last):
File "/home/pi/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'

J'ai reinstallé le install.sh en ssh root et ça n'a pas fonctionne non plus.

EDIT : Il fallait en plus installer le install_apt.sh.

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin blea

Message par Idaho947 » 20 juil. 2019, 12:04

J'ai un autre soucis suite a cette mise a jour Beta.
La commande présence de mes nut change d'ID constamment. Elle est recréée toutes les 15min. Elle alimente la valeur d'un virtuel par personne et ces virtuels déclanches des scénarios.
Ce qui fait que j'ai des commandes orphelines mais surtout que ma détection de présence ne fonctionne pas puisqu'elle cherche à lire des commandes qui n'existe pas.

Le problème survient toute les 15min a chaque fois que jeedom synchronise l'antenne.

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 20 juil. 2019, 12:51

Oui je confirme il y a un truc avec cette version beta :
-Obligé de lancer le script install_apt.sh à la main sinon, le démon ne fonctionne pas bien
- La présence de mon mi band 3 ne fonctionne plus, malgré rescan et recréation des commandes
- J'ai l'impression que la présence dans le widget se (re)masque toute seule dans le widget

Code : Tout sélectionner

[Sat Jul 20 12:48:38.444472 2019] [:error] [pid 26593] [client 127.0.0.1:39378] PHP Notice:  Undefined index: present in /var/www/html/plugins/blea/core/php/jeeBlea.php on line 197
[Sat Jul 20 12:49:07.208038 2019] [:error] [pid 8207] [client 127.0.0.1:39388] PHP Notice:  Undefined index: present in /var/www/html/plugins/blea/core/php/jeeBlea.php on line 197
Dernière édition par Naboleo le 20 juil. 2019, 18:51, édité 1 fois.
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

6ko
Timide
Messages : 2
Inscription : 20 juil. 2019, 18:10

Re: Plugin blea

Message par 6ko » 20 juil. 2019, 18:36

Bonjour à tous,

je vous écris pour remonter un problème.

J'ai installé BLEA sur un conteneur arm32v7/debian:9.8-slim, l'installation des dépendances se déroule bien mais lorsque je lance le daemon, j'ai une erreur de définition de variable global (enfin je crois). Je trouve personne ayant ce problème avec BLEA.
Je connais pas le Python mais j'ai l'impression qu'il manque quelque dans le code.
J'ai déjà une antenne sur cette image de conteneur, et elle fonctionne.

Quelqu'un peut-il m'aider ? Merci d'avance.

Code : Tout sélectionner

tail -f /tmp/blea
[2019-07-20 15:22:06][ERROR] : GLOBAL------Exception on scanner (didn't resolve there is an issue with bluetooth) : global name 'TimeoutExpired' is not defined

Code : Tout sélectionner

cat /tmp/blea_dependancy
Launch install of blea dependancy
Ign:1 http://deb.debian.org/debian stretch InRelease
Get:2 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Get:3 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
Hit:4 http://deb.debian.org/debian stretch Release
Get:5 http://security.debian.org/debian-security stretch/updates/main armhf Packages [485 kB]
Fetched 670 kB in 2s (326 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
bluetooth is already the newest version (5.43-2+deb9u1).
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2+deb9u1).
python-requests is already the newest version (2.12.4-1).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Requirement already satisfied: pyudev in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pyudev)
Requirement already satisfied: pyserial in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages
Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python2.7/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/bluepy
copying bluepy/__init__.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/thingy52.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scan_fuzz.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/btle.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/blescan.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/get_services.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scanner.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/sensortag.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/uuids.json -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluez-src.tgz -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluepy-helper.c -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/Makefile -> build/lib.linux-armv7l-2.7/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib.linux-armv7l-2.7/bluepy
running install_lib
creating /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/__init__.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/thingy52.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/uuids.json -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/scan_fuzz.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/btle.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/blescan.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/get_services.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/scanner.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluez-src.tgz -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/sensortag.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper.c -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/Makefile -> /usr/local/lib/python2.7/dist-packages/bluepy
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/thingy52.py to thingy52.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/btle.py to btle.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/blescan.py to blescan.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/get_services.py to get_services.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/scanner.py to scanner.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/sensortag.py to sensortag.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing top-level names to bluepy.egg-info/top_level.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
Copying bluepy.egg-info to /usr/local/lib/python2.7/dist-packages/bluepy-1.1.3.egg-info
running install_scripts
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Everything is successfully installed!

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin blea

Message par Idaho947 » 20 juil. 2019, 22:25

Naboleo a écrit :
20 juil. 2019, 12:51
Oui je confirme il y a un truc avec cette version beta :
-Obligé de lancer le script install_apt.sh à la main sinon, le démon ne fonctionne pas bien
- La présence de mon mi band 3 ne fonctionne plus, malgré rescan et recréation des commandes
- J'ai l'impression que la présence dans le widget se (re)masque toute seule dans le widget

Code : Tout sélectionner

[Sat Jul 20 12:48:38.444472 2019] [:error] [pid 26593] [client 127.0.0.1:39378] PHP Notice:  Undefined index: present in /var/www/html/plugins/blea/core/php/jeeBlea.php on line 197
[Sat Jul 20 12:49:07.208038 2019] [:error] [pid 8207] [client 127.0.0.1:39388] PHP Notice:  Undefined index: present in /var/www/html/plugins/blea/core/php/jeeBlea.php on line 197
Salut Naboleo,

As tu regarde l id de ta commande présence. Est ce que comme moi il changer régulièrement ?

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 20 juil. 2019, 22:31

Idaho947 a écrit :
20 juil. 2019, 22:25
Salut Naboleo,

As tu regarde l id de ta commande présence. Est ce que comme moi il changer régulièrement ?
Changer régulièrement je ne sais pas, mais j'ai bien des commandes associées (dont la présence) qui sont orphelines .... Donc ça y ressemble
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin blea

Message par Idaho947 » 21 juil. 2019, 06:17

Donc on a le même soucis... Si tu es comme moi et que tu as une antenne ru peux utilisé les commandes présence des antenne qui elle ne sont pas recréé de façon régulière. Fe qui est un palliatifs pour l'instant.

EDIT : la maj ne se matin règle le problème de l'installation mais pas celui des commande présence qui sont recréée a chaque cycle sur la beta

REEDIT : la maj de cette aprem corrige le problème de récréation des commandes. C'est tout bon.

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 22 juil. 2019, 08:43

Et celle d’aujourd’hui corrige le problème des présences
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

Dautrip
Timide
Messages : 48
Inscription : 26 sept. 2017, 06:56

Re: Plugin blea

Message par Dautrip » 23 juil. 2019, 19:20

Je tente la mise à jour suite à la notification mais je reste bloqué sur une roue crantée. J’utilise une antenne déportée (promox). Un conseil ?

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 23 juil. 2019, 19:46

Dautrip a écrit :
23 juil. 2019, 19:20
Je tente la mise à jour suite à la notification mais je reste bloqué sur une roue crantée. J’utilise une antenne déportée (promox). Un conseil ?
Salut

Tu peux commencer par faire un tour dans les logs...
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

Dautrip
Timide
Messages : 48
Inscription : 26 sept. 2017, 06:56

Re: Plugin blea

Message par Dautrip » 23 juil. 2019, 20:05

Oui pardon je suis désolé,


le seul log ayant changé est le update.log :

si je peux faire autre chose pour aider, je suis à votre disposition.

2019-07-23 20:01:25 (2.63 MB/s) - '/tmp/jeedom/market/blea.zip' saved [9203134]
[2019-07-23 20:01:25][ALERT] : OK
[2019-07-23 20:01:25][ALERT] : Décompression du zip...
[2019-07-23 20:01:25][ALERT] : OK
[2019-07-23 20:01:25][ALERT] : Post-installation de blea...

je reste coincé à cette étape là.

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 23 juil. 2019, 20:13

Dautrip a écrit :
23 juil. 2019, 20:05
je reste coincé à cette étape là.
Rien dans ceux -là ?
  • blea
  • blea_local
  • blea_update
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

chris777c
Timide
Messages : 152
Inscription : 01 mai 2017, 16:56

Re: Plugin blea

Message par chris777c » 23 juil. 2019, 20:38

Bonjour,

J'ai installé la dernière version du plugin, le démon était KO, j'ai donc décidé de réinstaller les dépendances par contre je suis coincés sur cette log d'installation de dépendance :
Running setup.py (path:/tmp/pip-build-6l846ajd/cryptography/setup.py) egg_info for package cryptography
Traceback (most recent call last):
File "<string>", line 17, in <module>
File "/tmp/pip-build-6l846ajd/cryptography/setup.py", line 26, in <module>
"cryptography requires setuptools 18.5 or newer, please upgrade to a "
RuntimeError: cryptography requires setuptools 18.5 or newer, please upgrade to a newer version of setuptools
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 17, in <module>
File "/tmp/pip-build-6l846ajd/cryptography/setup.py", line 26, in <module>
"cryptography requires setuptools 18.5 or newer, please upgrade to a "
RuntimeError: cryptography requires setuptools 18.5 or newer, please upgrade to a newer version of setuptools
J'ai déjà essayé ça (en tapant sur google) :

- pip install -U pip
- pip install virtualenv --upgrade
- pip install -U setuptools

Non concluant, je suis sous Debain Jessie

Mad Ein
Timide
Messages : 62
Inscription : 09 août 2016, 21:00

Re: Plugin blea

Message par Mad Ein » 23 juil. 2019, 20:51

bonjour,
après mise à jour du plugin j'ai eu une erreur de BLEA: Bluepy not up to date : expected 1.1.4
dépendance KO j'ai voulu relancer et même soucis que chris777c et moi aussi en debian jessie 8.9 :

Code : Tout sélectionner

Downloading/unpacking cryptography
  Running setup.py (path:/tmp/pip-build-wzjlmw4x/cryptography/setup.py) egg_info for package cryptography
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/tmp/pip-build-wzjlmw4x/cryptography/setup.py", line 26, in <module>
        "cryptography requires setuptools 18.5 or newer, please upgrade to a "
    RuntimeError: cryptography requires setuptools 18.5 or newer, please upgrade to a newer version of setuptools
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/tmp/pip-build-wzjlmw4x/cryptography/setup.py", line 26, in <module>

    "cryptography requires setuptools 18.5 or newer, please upgrade to a "

RuntimeError: cryptography requires setuptools 18.5 or newer, please upgrade to a newer version of setuptools

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-wzjlmw4x/cryptography
Storing debug log for failure in /root/.pip/pip.log
Requirement already satisfied (use --upgrade to upgrade): pycrypto in /usr/local/lib/python3.4/dist-packages
Cleaning up...
********************************************************
*			 Installation terminée					*
********************************************************

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Plugin blea

Message par Naboleo » 23 juil. 2019, 21:01

@chris777c et @Mad Ein pourquoi rester en jessie ? Z'êtes sur des box smart ?
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

chris777c
Timide
Messages : 152
Inscription : 01 mai 2017, 16:56

Re: Plugin blea

Message par chris777c » 23 juil. 2019, 21:04

Non pas sur smart pour moi

Mad Ein
Timide
Messages : 62
Inscription : 09 août 2016, 21:00

Re: Plugin blea

Message par Mad Ein » 23 juil. 2019, 21:06

mini+ et ssd... pas possible en stretch.
sinon retour en sd pas cool.

Avatar de l’utilisateur
snorlax
Timide
Messages : 202
Inscription : 01 févr. 2016, 15:16

Re: Plugin blea

Message par snorlax » 23 juil. 2019, 21:13

La dernière mise à jour est...comment dire... pas vraiment parfaite quoi :o :o :o

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités