Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Avatar de l’utilisateur
nickasimir
Actif
Messages : 693
Inscription : 06 août 2014, 19:35
Localisation : Montreuil, Idf

Re: Plugin blea

Message par nickasimir » 04 févr. 2017, 17:10

Je viens de vérifier la version c'est du 4.1 déjà. Je ferai le test plus tard.

Envoyé de mon Nexus 4
Jeedom en DIY sur NUCI3| Mon Matos : Ici

Ikari
Timide
Messages : 101
Inscription : 29 mars 2016, 08:21

Re: Plugin blea

Message par Ikari » 05 févr. 2017, 12:42

Bonjour,
j'essaye de mettre mon RPI3 en antenne pour Blea.

J'y suis presque sauf que j'ai un problème au niveau des dépendances voici le log :

Code : Tout sélectionner

Cloning into 'bluepy'...
Traceback (most recent call last):
  File "setup.py", line 3, in <module>
    from setuptools.command.install import install
  File "/usr/local/lib/python2.7/dist-packages/setuptools/__init__.py", line 12, in <module>
    import setuptools.version
  File "/usr/local/lib/python2.7/dist-packages/setuptools/version.py", line 1, in <module>
    import pkg_resources
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 70, in <module>
    import packaging.version
ImportError: No module named packaging.version
Traceback (most recent call last):
  File "setup.py", line 3, in <module>
    from setuptools.command.install import install
  File "/usr/local/lib/python2.7/dist-packages/setuptools/__init__.py", line 12, in <module>
    import setuptools.version
  File "/usr/local/lib/python2.7/dist-packages/setuptools/version.py", line 1, in <module>
    import pkg_resources
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 70, in <module>
    import packaging.version
ImportError: No module named packaging.version
Everything is successfully installed!
je pense que le pb vient de l'installation de bluepy pour qui il manque les dépendances packaging.version

Qqun a-til rencontré ce pb ?

Avatar de l’utilisateur
jolyp
Timide
Messages : 180
Inscription : 10 mars 2015, 20:50
Localisation : Région Parisienne

Re: Plugin blea

Message par jolyp » 05 févr. 2017, 12:59

Bonjour

je viens juste de la faire et je n'ai pas eu ce problème sur mon raspi3 (basé sur la dernière image dispo)
le seul problème que j'ai rencontré est de devoir cliquer plusieurs fois sur "envoyer les fichiers" avant de pouvoir lancer les dépendances.
Jeedom Raspi3 (Zwave/RFCOM/RFLINK/BLEA)
Jeedom Raspi3 (Teleinfo,BLEA)
Antenne BLEA Raspi0
GW Xiaomi + capteurs divers (température, portes, présence ...)
Qubino Fil Pilote radiateur, Sondes RFXcom low cost
plugins : Thermostat, Agenda, ICS,

Avatar de l’utilisateur
jolyp
Timide
Messages : 180
Inscription : 10 mars 2015, 20:50
Localisation : Région Parisienne

Re: Plugin blea

Message par jolyp » 05 févr. 2017, 13:46

Par contre j'ai des soucis avec le capteur xiaomi flower plant

la présence est bien là mais pas les données (j'ai réussi à en récupérer de temps en temps avec le plugin MiPlant)

Code : Tout sélectionner

2017-02-05 13:30:08][DEBUG] : This is a miflora device c4:7c:8d:62:4f:a8
[2017-02-05 13:30:09][DEBUG] : Send to jeedom : {u'devices': {u'C4:7C:8D:62:4F:A8': {'name': u'Flower care', 'source': 'edf', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'95fe'), (22, '16b Service Data', u'95fe310298001ca84f628d7cc40d'), (9, 'Complete Local Name', u'Flower care')]", 'rssi': -94, 'type': 'miflora', 'id': u'C4:7C:8D:62:4F:A8', 'present': 1}}}
j'ai essayé de poser le detecteur près du raspi3 mais pas mieux
Jeedom Raspi3 (Zwave/RFCOM/RFLINK/BLEA)
Jeedom Raspi3 (Teleinfo,BLEA)
Antenne BLEA Raspi0
GW Xiaomi + capteurs divers (température, portes, présence ...)
Qubino Fil Pilote radiateur, Sondes RFXcom low cost
plugins : Thermostat, Agenda, ICS,

rigmath
Timide
Messages : 16
Inscription : 06 juil. 2014, 18:31

Re: Plugin blea

Message par rigmath » 05 févr. 2017, 15:32

Fabrice a écrit :Bonjour,

J'aurais bien besoin d'information sur l'option : Refresh des infos (en s)

Voilà, j'ai acheté des Nut Find 3. Je les ai activés via l'application Android avant, pour avoir la détection en continue (merci le forum pour l'astuce).
- puis suppression de l'application de mon smartphone.

Je les aient inclus dans Jeedom avec BLEA. Tout va bien, cela fonctionne comme je le souhaitais. Mais un truc me chagrine, c'est l'option "Refresh des infos (en s)".
Par défaut elle est à 18000 secondes, ce qui correspond à 5h00. Et toutes les 5 heures, j'ai mes scénarios liés à la présence des Nut Find 3 qui se déclenches. Quand je lis l'info bull sur le ? de cette option, il est indiqué que "Si les valeurs sont identiques aux précédentes il n'y aura pas de mise à jour". Ce qui ne semble pas correspondre à ce que je constate.
- Cette nuit, le plugin TTSPlay, m'a très gentillement annoncé "Bienvenu à la maison Fabrice"... et ainsi de suite les pour les autres membres de la famille ;-)

L'état des Nut étaient bien à 1, au terme du délais de refresh, ils sont tous passés à 0 puis, 3 minutes plus tard, ils sont repassés à 1. Les 3 ensembles, puisqu'ils étaient passés précédemment à 1 tous ensemble aussi.

Comment faites vous, pour ne pas avoir de problème avec vos scénarios avec ce délais ? (hormis placer un délais de 31536000 secondes (1 an) pour être tranquille).
Bonjour,

J'ai exactement le phénomène d'écrit par Fabrice (Phénomène très bien décrit, je n'aurais pas fait aussi bien)

@Fabrice As-tu changer la valeur par défaut et le délais avant coupure a-t-il été modifié ?

@sarakha63 A quoi sert ce temps ? et est-ce un fonctionnement normal ?
MERCI AUX DEVELOPPEURS
Odroid C2 eMMC 8Go
Matériels Zwave : AEON Labs - Qubino - Eurotronic - Nodon
Matériels Xiaomi
Matériels Nut
Matériel SENA

Pignonduclan
Timide
Messages : 132
Inscription : 02 sept. 2015, 22:32

Re: Plugin blea

Message par Pignonduclan » 05 févr. 2017, 16:49

De fait, excellent que ça tourne sur Orange pi Zero! Et de fait, si tu trouves quelques minutes pour faire un petit tuto, je suis preneur :)! Merci d'avance!

Cedric

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3415
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 05 févr. 2017, 19:48

Bonsoir.

J'ai placé le délai à 1 an en minutes. Cela fonctionne bien comme cela. Je ne connais pas le rôle de ce délai.

Voici comment je gère la présence :
viewtopic.php?f=23&t=24679#p435548

Voir mes deux réponses avec les captures.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Chewbacca44
Timide
Messages : 114
Inscription : 08 janv. 2015, 10:31

Re: Plugin blea

Message par Chewbacca44 » 06 févr. 2017, 11:30

Theduck38 a écrit :Pour ceux qui galèrent à installer une antenne distante, je fais partager un mode opératoire qui a fonctionné deux fois pour moi (sur le Raspbian de Max2Play) :
- Installer le bluetooth sur le RPi distant : sudo apt-get install bluetooth
- Redémarrer le Rpi
- hciconfig => doit donner UP RUNNING
- Sur Blea, créer une nouvelle antenne, entrer son IP, port 22, user, MdP (en général "pi" et "raspberry")
- Envoyer les fichiers => ça doit répondre réussi
- Lancer les dépendances => je pense que c'est là où ça coince pour certains : il faut vraiment être patient. Pour moi ça a pris presque 15 minutes.
On peut récupérer périodiquement les logs de dépendances (sur l'équipement antenne de Blea) et les ouvrir via 'logs'. Tant que ce n'est pas écrit 'Everything is succesfully installed' c'est que c'est encore en cours.
- Une fois les dépendances Ok, on reboot encore le Rpi
- Sur le Rpi (en ssh) : sudo hcitool lescan => doit montrer un scanning (si vous n'avez pas d'équipement BT, rien n'apparaît en dessous, sinon ça défile)
- Il faut ensuite lancer le démon.
- On ressort de l'équipement, on y retourne et la petite icône à côté du nom devrait être en vert.
Big merci !!!! ca marche au poil :) Pour ceux qui ont un souci avec les antennes suivez cette procédure :) (dongle bluetooth CSR 4 dans ma config)

chboc85
Timide
Messages : 55
Inscription : 16 déc. 2015, 11:18

Re: Plugin blea

Message par chboc85 » 06 févr. 2017, 11:55

Bonjour à tous,

Je voudrais me lancer dans ce plugin qui à l'air vraiment pas mal pour gérer des équipements Bluetooth. Pour commencé, je me suis commandé des nut mini pour être notifié lorsque mes enfants rentre de l'école. (commande en attente de livraison)

Je me posais surtout une autre question. Voila, je me suis fait un système d'éclairage pour mon escalier comme celui ci => https://www.youtube.com/watch?v=oBf7ip8xa68 à l'aide d'un Arduino + ruban de LED RGB. En plus de ça, pour pouvoir changer la couleur comme je veux, j'ai ajouté un module Bluetooth sur mon Arduino et à l'aide d'une petite application android je viens modifier la couleur.

Ma question: Le plugin BLEA serait il capable de détecter le module Bluetooth de mon Arduino? si oui, je pourrais donc lui envoyer des commandes pour changer la couleur de mon escalier à l'aide de Jeedom?

J'avais fait mon ouverture de portail avec une carte Arduino + 2 relais + Bluetooth aussi. Serait il possible d'envoyer les commandes d'ouverture avec BLEA si le module Bluetooth est reconnu?

Je m'excuse d'avance si cette question avait déja été posé auparavant, je n'ai pas eu le courage de relire toutes les pages du post...

Merci d'avance pour votre réponse ;)

yoguiti
Timide
Messages : 69
Inscription : 30 sept. 2015, 10:09

Re: Plugin blea

Message par yoguiti » 06 févr. 2017, 12:11

rol-rider a écrit :
Bonjour
J'ai un souci avec les mi plant sur l'information de la luminosité.
Toutes les autres informations sont correctes en comparant avec Flower Care sauf la luminosité qui par exemple est de 224 lux sur BLEA et 27 sur Flower Care.
J'ai le soucis sur tous les capteurs, une idée ?
oui, j'ai exactement le même problème sur mon mi plant, toutes les données sont cohérentes sauf la luminosité...plus de 100lux dans le noir !
Même problème pour moi. La luminosité est incohérente. Toujours autour de 60 Lux, jour comme nuit.

Un bug juste pour nous ou pour tout le monde?

Merci pour votre aide !

yoguiti

rol-rider
Actif
Messages : 5086
Inscription : 10 août 2014, 23:50

Re: Plugin blea

Message par rol-rider » 06 févr. 2017, 15:48

Oui, pas très fiable ce mi plant, avec blea !
l'humidité à baissé, mais malgré un arrosage important, je suis à 21% d'humidité ! et il fait jamais nuit chez moi !
mon firmware est le 2.6.2
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Plugin blea

Message par DimitraBelder » 06 févr. 2017, 16:56

DimitraBelder a écrit :Bonjour,

Super plugin !
Tout fonctionne très bien depuis mon RPI3 + clé bluetooth.
J'ai un problème sur une antenne déportée sur RPI0 + clé bluetooth (identique que celui du RPI3).
Quand je lance le démon, il voit bien les périphériques autour de lui, mais après il ne vois plus aucun élément, le démon est OK, pas d'erreur dans les logs même en mode debug...

Voici les logs :

Code : Tout sélectionner

[2017-01-30 13:53:11][INFO] : Start blead
[2017-01-30 13:53:11][INFO] : Log level : debug
[2017-01-30 13:53:11][INFO] : Socket port : 55008
[2017-01-30 13:53:11][INFO] : Socket host : 
[2017-01-30 13:53:11][INFO] : Device : hci0
[2017-01-30 13:53:11][INFO] : PID file : /tmp/blead.pid
[2017-01-30 13:53:11][INFO] : Apikey : <API_KEY>
[2017-01-30 13:53:11][INFO] : Callback : http://192.168.0.2:80/plugins/blea/core/php/jeeBlea.php
[2017-01-30 13:53:11][INFO] : Cycle : 0.3
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.dotti
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.fitbit
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.gigaset
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.hector
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.itag
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.jinlin
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.logiswitch
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.miband
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.miband2
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.miflora
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.miscale
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.myfox
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.niu
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.noke
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.nut
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.playbulb
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.smartplug
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.tb05
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.ticatag
[2017-01-30 13:53:11][INFO] : Import de la configuration devices.wistiki
[2017-01-30 13:53:11][DEBUG] : Writing PID 24349 to /tmp/blead.pid
[2017-01-30 13:53:11][DEBUG] : Init request module v2.4.3
[2017-01-30 13:53:11][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:11][DEBUG] : "GET /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:11][DEBUG] : Socket interface started
[2017-01-30 13:53:11][INFO] : Start listening...
[2017-01-30 13:53:11][INFO] : Preparing Scanner...
[2017-01-30 13:53:11][DEBUG] : Read Socket Thread Launched
[2017-01-30 13:53:11][DEBUG] : LoopNetServer Thread started
[2017-01-30 13:53:11][DEBUG] : Listening on: [:55008]
[2017-01-30 13:53:11][DEBUG] : Send to jeedom :  {'source': 'Chambre', 'learn_mode': 0}
[2017-01-30 13:53:11][DEBUG] : Read Device Thread Launched
[2017-01-30 13:53:11][DEBUG] : Heartbeat Thread Launched
[2017-01-30 13:53:11][DEBUG] : Send to jeedom :  {'started': 1, 'source': 'Chambre'}
[2017-01-30 13:53:11][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:11][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:11][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:11][DEBUG] : Client connected to [192.168.0.2:44694]
[2017-01-30 13:53:11][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"add","device":{"id":"D6:E5:38:C7:6D:8A","delay":"18000","needsrefresh":0,"name":"miband2","refreshlist":[],"islocked":0,"emitterallowed":"all","refresherallowed":"all"}}
[2017-01-30 13:53:11][DEBUG] : Client disconnected from [192.168.0.2:44694]
[2017-01-30 13:53:11][DEBUG] : Client connected to [192.168.0.2:44698]
[2017-01-30 13:53:11][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"add","device":{"id":"88:0F:10:9E:1D:F2","delay":0,"needsrefresh":0,"name":"0","refreshlist":[],"islocked":0,"emitterallowed":"local","refresherallowed":"all"}}
[2017-01-30 13:53:11][DEBUG] : Client disconnected from [192.168.0.2:44698]
[2017-01-30 13:53:11][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:11][DEBUG] : Client connected to [192.168.0.2:44702]
[2017-01-30 13:53:11][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"add","device":{"id":"90:03:B7:CA:13:3F","delay":0,"needsrefresh":0,"name":"0","refreshlist":[],"islocked":0,"emitterallowed":"local","refresherallowed":"local"}}
[2017-01-30 13:53:11][DEBUG] : Client disconnected from [192.168.0.2:44702]
[2017-01-30 13:53:11][DEBUG] : Client connected to [192.168.0.2:44706]
[2017-01-30 13:53:11][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"add","device":{"id":"A0:14:3D:0C:93:18","delay":0,"needsrefresh":0,"name":"0","refreshlist":[],"islocked":0,"emitterallowed":"local","refresherallowed":"local"}}
[2017-01-30 13:53:11][DEBUG] : Client disconnected from [192.168.0.2:44706]
[2017-01-30 13:53:12][DEBUG] : Client connected to [192.168.0.2:44710]
[2017-01-30 13:53:12][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:12][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"add","device":{"id":"00:15:83:40:84:0D","delay":0,"needsrefresh":0,"name":"tb05","refreshlist":[],"islocked":0,"emitterallowed":"local","refresherallowed":"local"}}
[2017-01-30 13:53:12][DEBUG] : Client disconnected from [192.168.0.2:44710]
[2017-01-30 13:53:12][DEBUG] : Received command from jeedom : add
[2017-01-30 13:53:12][DEBUG] : Add device : {u'needsrefresh': 0, u'name': u'miband2', u'emitterallowed': u'all', u'delay': u'18000', u'refresherallowed': u'all', u'islocked': 0, u'refreshlist': [], u'id': u'D6:E5:38:C7:6D:8A'}
[2017-01-30 13:53:12][WARNING] : Exception on scanner (trying to resolve by myself 6): Failed to execute mgmt cmd 'scanend'
[2017-01-30 13:53:12][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:12][DEBUG] : Received command from jeedom : add
[2017-01-30 13:53:12][DEBUG] : Add device : {u'needsrefresh': 0, u'name': u'0', u'emitterallowed': u'local', u'delay': 0, u'refresherallowed': u'all', u'islocked': 0, u'refreshlist': [], u'id': u'88:0F:10:9E:1D:F2'}
[2017-01-30 13:53:12][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:12][DEBUG] : Received command from jeedom : add
[2017-01-30 13:53:12][DEBUG] : Add device : {u'needsrefresh': 0, u'name': u'0', u'emitterallowed': u'local', u'delay': 0, u'refresherallowed': u'local', u'islocked': 0, u'refreshlist': [], u'id': u'90:03:B7:CA:13:3F'}
[2017-01-30 13:53:12][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:12][DEBUG] : Received command from jeedom : add
[2017-01-30 13:53:12][DEBUG] : Add device : {u'needsrefresh': 0, u'name': u'0', u'emitterallowed': u'local', u'delay': 0, u'refresherallowed': u'local', u'islocked': 0, u'refreshlist': [], u'id': u'A0:14:3D:0C:93:18'}
[2017-01-30 13:53:13][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:13][DEBUG] : Received command from jeedom : add
[2017-01-30 13:53:13][DEBUG] : Add device : {u'needsrefresh': 0, u'name': u'tb05', u'emitterallowed': u'local', u'delay': 0, u'refresherallowed': u'local', u'islocked': 0, u'refreshlist': [], u'id': u'00:15:83:40:84:0D'}
[2017-01-30 13:53:14][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')] True public 00:15:83:40:84:0d
[2017-01-30 13:53:14][DEBUG] : This is a tb05 device 00:15:83:40:84:0d
[2017-01-30 13:53:14][DEBUG] : Send to jeedom : {u'devices': {u'00:15:83:40:84:0D': {'name': u'TB05', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')]", 'rssi': -83, 'type': 'tb05', 'id': u'00:15:83:40:84:0D', 'present': 1}}}
[2017-01-30 13:53:14][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:14][INFO] : Attempt to recover successful, reseting counter
[2017-01-30 13:53:14][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:15][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')] True public 88:0f:10:9e:1d:f2
[2017-01-30 13:53:15][DEBUG] : This is a miscale device 88:0f:10:9e:1d:f2
[2017-01-30 13:53:15][DEBUG] : Miscale this is a dummy measure
[2017-01-30 13:53:15][DEBUG] : Send to jeedom : {u'devices': {u'88:0F:10:9E:1D:F2': {'name': u'MI_SCALE', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')]", 'rssi': -76, 'type': 'miscale', 'id': u'88:0F:10:9E:1D:F2', 'present': 1}}}
[2017-01-30 13:53:15][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:15][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:23][DEBUG] : Client connected to [192.168.0.2:44742]
[2017-01-30 13:53:23][DEBUG] : Message read from socket: {"apikey":"<API_KEY>","cmd":"logdebug"}
[2017-01-30 13:53:23][DEBUG] : Client disconnected from [192.168.0.2:44742]
[2017-01-30 13:53:23][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2017-01-30 13:53:23][DEBUG] : Received command from jeedom : logdebug
[2017-01-30 13:53:23][INFO] : Passage du demon en mode debug force
[2017-01-30 13:53:23][DEBUG] : <----- La preuve ;)
[2017-01-30 13:53:24][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')] True public 00:15:83:40:84:0d
[2017-01-30 13:53:24][DEBUG] : This is a tb05 device 00:15:83:40:84:0d
[2017-01-30 13:53:24][DEBUG] : Send to jeedom : {u'devices': {u'00:15:83:40:84:0D': {'name': u'TB05', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')]", 'rssi': -84, 'type': 'tb05', 'id': u'00:15:83:40:84:0D', 'present': 1}}}
[2017-01-30 13:53:24][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:24][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:25][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')] True public 88:0f:10:9e:1d:f2
[2017-01-30 13:53:25][DEBUG] : This is a miscale device 88:0f:10:9e:1d:f2
[2017-01-30 13:53:25][DEBUG] : Miscale this is a dummy measure
[2017-01-30 13:53:25][DEBUG] : Send to jeedom : {u'devices': {u'88:0F:10:9E:1D:F2': {'name': u'MI_SCALE', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')]", 'rssi': -77, 'type': 'miscale', 'id': u'88:0F:10:9E:1D:F2', 'present': 1}}}
[2017-01-30 13:53:25][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:25][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:29][DEBUG] : [(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')] True public a0:14:3d:0c:93:18
[2017-01-30 13:53:29][DEBUG] : It's a unknown packet and I known this device so I send a0:14:3d:0c:93:18
[2017-01-30 13:53:29][DEBUG] : {'name': '', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')]", 'rssi': -91, 'type': 'default', 'id': u'A0:14:3D:0C:93:18'}
[2017-01-30 13:53:29][DEBUG] : Send to jeedom : {u'devices': {u'A0:14:3D:0C:93:18': {'name': '', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')]", 'rssi': -91, 'type': 'default', 'id': u'A0:14:3D:0C:93:18'}}}
[2017-01-30 13:53:29][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:29][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:39][DEBUG] : [(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')] True public a0:14:3d:0c:93:18
[2017-01-30 13:53:39][DEBUG] : It's a unknown packet and I known this device so I send a0:14:3d:0c:93:18
[2017-01-30 13:53:39][DEBUG] : {'name': '', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')]", 'rssi': -92, 'type': 'default', 'id': u'A0:14:3D:0C:93:18'}
[2017-01-30 13:53:39][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')] True public 00:15:83:40:84:0d
[2017-01-30 13:53:39][DEBUG] : This is a tb05 device 00:15:83:40:84:0d
[2017-01-30 13:53:39][DEBUG] : Send to jeedom : {u'devices': {u'00:15:83:40:84:0D': {'name': u'TB05', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'e0ff'), (9, 'Complete Local Name', u'TB05')]", 'rssi': -81, 'type': 'tb05', 'id': u'00:15:83:40:84:0D', 'present': 1}, u'A0:14:3D:0C:93:18': {'name': '', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (6, 'Incomplete 128b Services', u'1bc5d5a50200baafe211a88400fae139'), (255, 'Manufacturer', u'4300016102')]", 'rssi': -92, 'type': 'default', 'id': u'A0:14:3D:0C:93:18'}}}
[2017-01-30 13:53:39][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:39][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')] True public 88:0f:10:9e:1d:f2
[2017-01-30 13:53:39][DEBUG] : This is a miscale device 88:0f:10:9e:1d:f2
[2017-01-30 13:53:39][DEBUG] : Miscale this is a dummy measure
[2017-01-30 13:53:40][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:53:40][DEBUG] : Send to jeedom : {u'devices': {u'88:0F:10:9E:1D:F2': {'name': u'MI_SCALE', 'source': 'Chambre', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18a27837e107010d042035'), (255, 'Manufacturer', u'5701880f109e1df2')]", 'rssi': -76, 'type': 'miscale', 'id': u'88:0F:10:9E:1D:F2', 'present': 1}}}
[2017-01-30 13:53:40][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:53:40][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:54:05][DEBUG] : Send to jeedom :  {'heartbeat': 1, 'source': 'Chambre'}
[2017-01-30 13:54:05][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:54:05][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:55:01][DEBUG] : Send to jeedom :  {'heartbeat': 1, 'source': 'Chambre'}
[2017-01-30 13:55:01][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:55:02][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:55:57][DEBUG] : Send to jeedom :  {'heartbeat': 1, 'source': 'Chambre'}
[2017-01-30 13:55:57][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:55:58][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
[2017-01-30 13:56:53][DEBUG] : Send to jeedom :  {'heartbeat': 1, 'source': 'Chambre'}
[2017-01-30 13:56:53][INFO] : Starting new HTTP connection (1): 192.168.0.2
[2017-01-30 13:56:53][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=<API_KEY> HTTP/1.1" 200 None
Bonjour,

j'ai toujours mon problème sur RPI 0.
En ajoutant des traces dans blead.py, je me rend compte que la boucle infini dans "def listen():" s’arrête au bout d'un moment.
Je ne vois pas d'où peut venir l'erreur qui fait planter la boucle.

sarakha63 si tu as une version en mode débug++ je suis preneur ;)

UnMaster
Timide
Messages : 182
Inscription : 17 juil. 2014, 21:12
Localisation : Anjou

Re: Plugin blea

Message par UnMaster » 07 févr. 2017, 01:10

Bon petit retour sur mon cas.

J'ai supprimé d'abord tous mes playbulb et ma balance MiScale.
Après 2 jours tout est OK, plus de monté en charge et de process qui ce multiplie.
J'ai donc remis en service ma MiScale et du coup j'ai détecté mon MiBand2, donc ajouté sur le plugin.
Pour le moment, environ 3 jours tout est OK.
Donc il semblerait qu'il y ai un soucis avec le playbulb.
Sarakha, si cela peut te servir pour recentrer les débats ;)

Mik
HP Microserver G7 WHS2011 - VM Jeedom 3.1.6 - ZWave 20 nodes - RFXcom + 11 sondes - Bluetooth - IPX800 +X880 -Téléinfo - Xiaomi Home - 20 nodes
Multimédia - 2 Kodi + 3 Squeezebox + Orvibo AllOne + Broadlink RM3 Mini - MP1

Avatar de l’utilisateur
bravan
Timide
Messages : 202
Inscription : 30 janv. 2015, 21:25
Localisation : Dijon

Re: Plugin blea

Message par bravan » 07 févr. 2017, 21:06

caplam a écrit :
caplam a écrit :
magicgg91 a écrit :Pas possible sur openelec ou librelec. Passez à OSMC, beaucoup plus ouvert ;)
J'ai tenté sur un rpi2 avec libreelec, ça n'a evidemment pas marché. Puis j'ai lu ce topic plus en détail. Du coup j'ai installé un rpi3 avec osmc.
Ca ne marche pas non plus. J'ai un problème avec l'installation des dépendances:

Voici un extrait du fichier /tmp/blea_dependancy du rpi3:

Code : Tout sélectionner

debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/arm-linux-gnueabihf/perl5/5.20 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 18.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
1 upgraded, 17 newly installed, 0 to remove and 43 not upgraded.
Need to get 0 B/22.8 MB of archives.
After this operation, 74.9 MB of additional disk space will be used.
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: git: command not found
/home/osmc/blead/resources/install.sh: line 20: cd: /tmp/bluepy: No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
rm: cannot remove '/tmp/bluepy': No such file or directory
Everything is successfully installed!
Je vais chercher un peu quoi faire mais j'arrive à mes limites de compétences.
Bon j'ai eu un peu de temps pour voir ce problème. Alors pour ceux qui galèrent pour installer une antenne (avec le même genre de log que moi) sur osmc c'est tout con.
Créez votre antenne dans le plugin
Cliquez sur envoyer les fichiers
connectez vous en ssh sur osmc
allez dans le répertoire /home/"nom du compte utilisé"/blead/resources/
lancez l'installation avec ./install.sh
Normalement à la fin de l'install ça sera bon.

Il me reste un problème que je n'identifie pas pour l'instant. Dans la page santé j'ai une erreur d'indiquée pour le plugin mais tout me semble fonctionner correctement.
Est-ce que ça peut venir du faible niveau de réception d'une antenne ?
merci pour tes infos qui m'ont bien servi, j'atouterai que j'ai du faire la commande :
sudo sh ./install.sh

pour lancer l'install sous osmc avec la clef BT asus sur un pi2
Jeedom 3.2.9 sur Pi3
RFXcom - GCE Téléinformation USB - Jeedouino - Xiaomi - BLEA

papabert
Timide
Messages : 160
Inscription : 29 mai 2016, 08:30

Re: Plugin blea

Message par papabert » 08 févr. 2017, 22:01

Bonjour à tous,

Est-il prévu que ce plugin puisse prendre en charge les boutons Beewi ?

Merci !!
RPI3 - RFLink pour prises Dio et sonde température DIY - Legrand inOne pour volets, chauffage et alarme - EnOcean pour détecteurs d'ouverture...

byackee
Timide
Messages : 263
Inscription : 03 mai 2015, 21:03
Contact :

Re: Plugin blea

Message par byackee » 08 févr. 2017, 22:12

Bonjour pour info sur une debian 8 fresh le plugin ne fonctionne pas.

J'ai du installer le pacquet bluez car non installer de base, a jouter dans les dépendances je pense

Bisous a tous :D

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: Plugin blea

Message par Anonyme » 08 févr. 2017, 22:33

Contenu supprimé à la demande de son auteur

gpga
Actif
Messages : 754
Inscription : 03 mars 2015, 10:29
Localisation : 67 proche de Strasbourg

Re: Plugin blea

Message par gpga » 08 févr. 2017, 22:52

J'ai vu que le plugin etait compatible avec les fitbit, j'ai un fitbit blaze, il n'est jamais vu par le plugin lors de la recherche,

y a t'il quelque chose à faire pour le rendre visible
1x Nuc I3 cible / Stick Aeon Gen5 / +- 30 modules Zwave / 7 cameras (Surveillance station)
1 x RPi2 source / Teleinfo USB
1 x Odroid C2 / Stick Aeon Gen 5 / 10 modules Zwave

Chewbacca44
Timide
Messages : 114
Inscription : 08 janv. 2015, 10:31

Re: Plugin blea

Message par Chewbacca44 » 09 févr. 2017, 14:39

Le mode antenne est vraiment top pour couvrir toute la maison.

serait t'il possible de prévoir les améliorations suivantes sur le plugin :
- bouton activer/désactiver pour les antennes (permet de désactiver sa prise en charge le temps de maintenance ou autre)
- une liste d'exclusion d'adresse mac : a chaque scan il me trouve des adresse mac (systematiquement les mêmes, netatmo je pense) que je ne souhaites pas prendre en compte avec blea et je dois les supprimer à chaque fois, une liste d'exclusion permettrait d'éviter cela

mais le nombre de périphérique compatible c'est top :) et avec le BT5 qui arrive c'est prometteur :)

Avatar de l’utilisateur
DuplO
Actif
Messages : 714
Inscription : 17 sept. 2015, 14:04

Re: Plugin blea

Message par DuplO » 09 févr. 2017, 16:44

Hello Magic !!!

Attendant patiemment début Noël dernier ou j'ai eu mon Miband 2, saurais tu nous dire il sera pris en compte par le plugin?

Merci

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités