Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Demon ne demarre pas

ericg
Timide
Messages : 68
Inscription : 31 déc. 2017, 15:14

Demon ne demarre pas

Message par ericg » 09 déc. 2018, 10:56

Bonjour,

SUr un PI3B+, plugin installé, dependances installées et port clef bluetooth correctement selectionné, impossible de démarrer le demon.
J'ai dans les logs BLEA local se retour systematique:

Code : Tout sélectionner

Traceback (most recent call last):
  File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
    from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Dans le log BLEA:

Code : Tout sélectionner

[2018-12-07 20:34:14][INFO] : Début d'activation du plugin
[2018-12-07 20:34:15][INFO] : Info sur le démon : Array (     [log] => blea     [state] => nok     [launchable] => ok     [launchable_message] => Gestion automatique désactivée     [auto] => 0     [last_launch] => Inconnue ) 
[2018-12-07 20:34:16][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php  plugin_id=blea function=install callInstallFunction=1
[2018-12-07 20:34:44][INFO] : Lancement démon blea : sudo /usr/bin/python /var/www/html/plugins/blea/resources/blead/blead.py --loglevel debug --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey CKSKLSUmfUMygjQXXXXXXXXXXXXXXXXXXXXXXXXXXX --daemonname local --pid /tmp/jeedom/blea/deamon.pid
[2018-12-07 20:35:04][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2018-12-07 20:34:43
[2018-12-07 20:35:14][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-12-07 20:40:01][INFO] : Lancement démon blea : sudo /usr/bin/python /var/www/html/plugins/blea/resources/blead/blead.py --loglevel debug --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey CKSKLSUmfUMXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX --daemonname local --pid /tmp/jeedom/blea/deamon.pid
[2018-12-07 20:40:05][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2018-12-07 20:40:00
[2018-12-07 20:40:31][ERROR] : Impossible de lancer le démon blea, vérifiez la log
et les messages info et error se repetent tpoutes les 5 minutes...

J'ai essayé l'astuce donnée sur un autre sujet:
: viewtopic.php?t=27797 mais sans succès...
Le Pi a été redemarré sans plus de succès...
je suis aux limites (qui arrivent vite!) de ma compétence sur le sujet...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3387
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon ne demarre pas

Message par Fabrice » 10 déc. 2018, 09:00

Bonjour.

Mettez à jour le Raspberry pi avec cette commande :

Code : Tout sélectionner

sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y && sudo rpi-update
Redémarrez
Puis réinstallez les dépendances du plugin

Si cela ne fonctionne toujours pas, montrez nous la log de l'installation des dépendances
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

ericg
Timide
Messages : 68
Inscription : 31 déc. 2017, 15:14

Re: Demon ne demarre pas

Message par ericg » 10 déc. 2018, 17:23

Ok, je relance celà ce soir.

ericg
Timide
Messages : 68
Inscription : 31 déc. 2017, 15:14

Re: Demon ne demarre pas

Message par ericg » 10 déc. 2018, 22:52

lors des mises à jours, j'ai eu une erreur réglée en suivant les instructions de réparation donnée par raspbian. Après la finalisation du process et la re-installation des dependances, le demon a démarré!
Merci pour le coup de main!

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : tornlouses et 1 invité