Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

impossible d'installer les dépendance HELP

Répondre
tontonel
Timide
Messages : 79
Inscription : 24 janv. 2017, 17:48

impossible d'installer les dépendance HELP

Message par tontonel » 22 sept. 2019, 21:38

Bonjour,

Depuis la dernière mise à jour de blea, il m'est impossible d'utiliser le plugin.
j'ai les statut et la configuration en statut NOK et lorsque je veux démarrer cela me relance l'installation des dépendances.

J'ai supprimé le plugin puis réinstallé mais le problème persiste.

je met le log si quelqu'un a le temps de jeter un coup d'oeil :

merci à vous

Code : Tout sélectionner

********************************************************
*			 Installation des dépendances			 *
********************************************************
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Hit:3 https://deb.nodesource.com/node_12.x stretch InRelease
Hit:4 https://raspbian.snips.ai/stretch stable InRelease
Get:5 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Fetched 11.7 MB in 14s (835 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libtiff5 is already the newest version (4.0.8-2+deb9u4).
libtiff5 set to manually installed.
python3-dev is already the newest version (3.5.3-1).
python3-requests is already the newest version (2.12.4-1).
python3-requests set to manually installed.
python3-setuptools is already the newest version (33.1.1-1).
rfkill is already the newest version (0.5-1).
rfkill set to manually installed.
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libatlas-base-dev : Depends: libatlas3-base (= 3.10.3-1+rpi1) but 3.10.3-1-snips is to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 173 not upgraded.
Need to get 0 B/142 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 114048 files and directories currently installed.)
Preparing to unpack .../python3-pip_9.0.1-2+rpt2_all.deb ...
Unpacking python3-pip (9.0.1-2+rpt2) over (9.0.1-2+rpt2) ...
Setting up python3-pip (9.0.1-2+rpt2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 173 not upgraded.
Requirement already satisfied: pyudev in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pyudev)
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Collecting pybluez
Using cached https://files.pythonhosted.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip
Building wheels for collected packages: pybluez
Running setup.py bdist_wheel for pybluez: started
Running setup.py bdist_wheel for pybluez: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-txbr_872/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpsyag3xytpip-wheel- --python-tag cp35:
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-armv7l-3.5
creating build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/ble.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/btcommon.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/widcomm.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/osx.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/bluez.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/msbt.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/__init__.py -> build/lib.linux-armv7l-3.5/bluetooth
running build_ext
building 'bluetooth._bluetooth' extension
creating build/temp.linux-armv7l-3.5
creating build/temp.linux-armv7l-3.5/bluez
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-6waWnr/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.5m -c bluez/btmodule.c -o build/temp.linux-armv7l-3.5/bluez/btmodule.o
In file included from bluez/btmodule.c:20:0:
bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: No such file or directory
#include <bluetooth/bluetooth.h>
^
compilation terminated.
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
----------------------------------------
Failed building wheel for pybluez
Running setup.py clean for pybluez
Failed to build pybluez
Installing collected packages: pybluez
Running setup.py install for pybluez: started
Running setup.py install for pybluez: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-txbr_872/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-a_44_inz-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-armv7l-3.5
creating build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/ble.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/btcommon.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/widcomm.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/osx.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/bluez.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/msbt.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/__init__.py -> build/lib.linux-armv7l-3.5/bluetooth
running build_ext
building 'bluetooth._bluetooth' extension
creating build/temp.linux-armv7l-3.5
creating build/temp.linux-armv7l-3.5/bluez
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-6waWnr/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.5m -c bluez/btmodule.c -o build/temp.linux-armv7l-3.5/bluez/btmodule.o
In file included from bluez/btmodule.c:20:0:
bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: No such file or directory
#include <bluetooth/bluetooth.h>
^
compilation terminated.
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-txbr_872/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-a_44_inz-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-txbr_872/pybluez/
Requirement already satisfied: pillow in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: numpy in /usr/local/lib/python3.5/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing entry points to bluepy.egg-info/entry_points.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing sensortag script to /usr/local/bin
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************

Avatar de l’utilisateur
Patdec
Actif
Messages : 771
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: impossible d'installer les dépendance HELP

Message par Patdec » 22 sept. 2019, 23:32

Ton log indique
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libatlas-base-dev : Depends: libatlas3-base (= 3.10.3-1+rpi1) but 3.10.3-1-snips is to be installed
......
Si tu donnais ta distrib, ton matos, ta version Jeedom ça pourrait aider les connaisseurs.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.36 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3415
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: impossible d'installer les dépendance HELP

Message par Fabrice » 23 sept. 2019, 07:31

Bonjour,

Votre log indique aussi qu'il y a 173 packages qui ne sont pas à jour,
En SSH, faites ces deux commandes :
sudo apt-get update
sudo apt-get upgrade
- que vous validez pas y

Laissez faire l'installation de TOUTES les mises à jour, puis redémarrez votre Jeedom
- Après le redémarrage, tentez une nouvelle fois l'installation des dépendances du plugin BLEA.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
zeftp
Timide
Messages : 441
Inscription : 19 avr. 2015, 11:46
Localisation : Lyon

Re: impossible d'installer les dépendance HELP

Message par zeftp » 23 sept. 2019, 10:51

Pareil ici.

Je suis sous Smart. J'ai fait toutes les updates mais je ne me suis pas connecté en ssh parce que j'ai une smart et donc c'est pas autorisé si on ne veut pas perdre la garantie.

Code : Tout sélectionner

Hit http://ftp.debian.org jessie-updates InRelease
Ign http://ftp.debian.org jessie-backports InRelease
Ign http://ftp.debian.org jessie-proposed-updates InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie-backports Release.gpg
Hit http://repo.jeedom.com stable/main arm64 Packages
Ign http://ftp.debian.org jessie-proposed-updates Release.gpg
Hit http://ftp.debian.org jessie Release
Ign http://ftp.debian.org jessie-backports Release
Hit http://ftp.debian.org jessie-updates/main Sources
Hit http://ftp.debian.org jessie-updates/contrib Sources
Ign http://repo.jeedom.com stable/main Translation-en_US
Ign http://repo.jeedom.com stable/main Translation-en
Hit http://ftp.debian.org jessie-updates/non-free Sources
Ign http://ftp.debian.org jessie-proposed-updates Release
Ign http://ftp.debian.org jessie-backports/main Sources/DiffIndex
Get:1 http://security.debian.org jessie/updates/main Sources [336 kB]
Ign http://ftp.debian.org jessie-backports/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex
Get:2 http://security.debian.org jessie/updates/non-free Sources [1,629 B]
Hit http://security.debian.org jessie/updates/contrib Sources
Ign http://ftp.debian.org jessie-proposed-updates/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main arm64 Packages/DiffIndex
Hit http://ftp.debian.org jessie/main Sources
Hit http://ftp.debian.org jessie/contrib Sources
Hit http://ftp.debian.org jessie/non-free Sources
Ign http://ftp.debian.org jessie-backports/contrib Translation-en_US
Ign http://ftp.debian.org jessie-backports/contrib Translation-en
Ign http://ftp.debian.org jessie-backports/main Translation-en_US
Ign http://ftp.debian.org jessie-backports/main Translation-en
Ign http://ftp.debian.org jessie-backports/non-free Translation-en_US
Ign http://ftp.debian.org jessie-backports/non-free Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/contrib Translation-en_US
Ign http://ftp.debian.org jessie-proposed-updates/contrib Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/main Translation-en_US
Ign http://ftp.debian.org jessie-proposed-updates/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/non-free Translation-en_US
Ign http://ftp.debian.org jessie-proposed-updates/non-free Translation-en
Err http://ftp.debian.org jessie-backports/main Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/main arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/main Sources
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/main arm64 Packages
  404  Not Found [IP: 130.89.148.12 80]
Hit http://oph.mdrjr.net all InRelease
Hit http://oph.mdrjr.net jessie InRelease
Get:3 http://oph.mdrjr.net all/c2 arm64 Packages
Get:4 http://oph.mdrjr.net all/main arm64 Packages
Hit http://oph.mdrjr.net all/c2 arm64 Packages
Get:5 http://oph.mdrjr.net all/testing arm64 Packages
Hit http://oph.mdrjr.net all/main arm64 Packages
Get:6 http://oph.mdrjr.net all/c2 Translation-en_US [324 B]
Get:7 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Hit http://oph.mdrjr.net all/testing arm64 Packages
Get:8 http://oph.mdrjr.net all/main Translation-en_US [326 B]
Get:9 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:10 http://oph.mdrjr.net all/testing Translation-en_US [329 B]
Get:11 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:12 http://oph.mdrjr.net jessie/backports arm64 Packages
Get:13 http://oph.mdrjr.net jessie/main arm64 Packages
Get:14 http://oph.mdrjr.net jessie/backports Translation-en_US [334 B]
Get:15 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:16 http://oph.mdrjr.net jessie/main Translation-en_US [329 B]
Hit http://oph.mdrjr.net jessie/backports arm64 Packages
Get:17 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Hit http://oph.mdrjr.net jessie/main arm64 Packages
Get:18 http://oph.mdrjr.net all/c2 Translation-en_US [324 B]
Get:19 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:20 http://oph.mdrjr.net all/main Translation-en_US [326 B]
Get:21 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:22 http://oph.mdrjr.net all/testing Translation-en_US [329 B]
Get:23 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:24 http://oph.mdrjr.net jessie/backports Translation-en_US [334 B]
Get:25 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:26 http://oph.mdrjr.net jessie/main Translation-en_US [329 B]
Get:27 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:28 http://oph.mdrjr.net all/c2 Translation-en_US [324 B]
Get:29 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:30 http://oph.mdrjr.net all/main Translation-en_US [326 B]
Get:31 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:32 http://oph.mdrjr.net all/testing Translation-en_US [329 B]
Get:33 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:34 http://oph.mdrjr.net jessie/backports Translation-en_US [334 B]
Get:35 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:36 http://oph.mdrjr.net jessie/main Translation-en_US [329 B]
Get:37 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:38 http://oph.mdrjr.net all/c2 Translation-en_US [324 B]
Get:39 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:40 http://oph.mdrjr.net all/main Translation-en_US [326 B]
Get:41 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:42 http://oph.mdrjr.net all/testing Translation-en_US [329 B]
Get:43 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:44 http://oph.mdrjr.net jessie/backports Translation-en_US [334 B]
Get:45 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:46 http://oph.mdrjr.net jessie/main Translation-en_US [329 B]
Get:47 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:48 http://oph.mdrjr.net all/c2 Translation-en_US [324 B]
Ign http://oph.mdrjr.net all/c2 Translation-en_US
Get:49 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Ign http://oph.mdrjr.net all/c2 Translation-en
Get:50 http://oph.mdrjr.net all/main Translation-en_US [326 B]
Ign http://oph.mdrjr.net all/main Translation-en_US
Get:51 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://oph.mdrjr.net all/main Translation-en
Get:52 http://oph.mdrjr.net all/testing Translation-en_US [329 B]
Ign http://oph.mdrjr.net all/testing Translation-en_US
Get:53 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://oph.mdrjr.net all/testing Translation-en
Get:54 http://oph.mdrjr.net jessie/backports Translation-en_US [334 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en_US
Get:55 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en
Get:56 http://oph.mdrjr.net jessie/main Translation-en_US [329 B]
Ign http://oph.mdrjr.net jessie/main Translation-en_US
Get:57 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://oph.mdrjr.net jessie/main Translation-en
W: There is no public key available for the following key IDs:
AA8E81B4331F7F50
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/Release  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
bluetooth is already the newest version.
build-essential is already the newest version.
libffi-dev is already the newest version.
python3-dev is already the newest version.
The following extra packages will be installed:
  cpp-4.9 g++-4.9 gcc-4.9 gcc-4.9-base gfortran gfortran-4.9 libatlas-dev
  libatlas3-base libatomic1 libblas-common libblas-dev libblas3 libbluetooth3
  libgcc-4.9-dev libgcc1 libgfortran-4.9-dev libgfortran3 libgomp1 libitm1
  libssl1.0.0 libstdc++-4.9-dev libstdc++6 python3-pkg-resources
  python3-urllib3
Suggested packages:
  gcc-4.9-locales gcc-4.9-doc libstdc++6-4.9-dbg libgcc1-dbg libgomp1-dbg
  libitm1-dbg libatomic1-dbg libasan1-dbg liblsan0-dbg libtsan0-dbg
  libubsan0-dbg libcilkrts5-dbg libquadmath-dbg gfortran-doc gfortran-4.9-doc
  libgfortran3-dbg libblas-doc liblapack-doc liblapack-dev liblapack-doc-man
  libstdc++-4.9-doc python3-ndg-httpsclient python3-openssl python3-pyasn1
  python3-socks python3-wxgtk3.0 python3-wxgtk python-setuptools-doc
Recommended packages:
  libssl-doc
The following NEW packages will be installed:
  gfortran gfortran-4.9 libatlas-base-dev libatlas-dev libatlas3-base
  libblas-common libblas-dev libblas3 libbluetooth-dev libbluetooth3
  libgfortran-4.9-dev libgfortran3 libopenjp2-7 python3-pyudev python3-serial
  rfkill
The following packages will be upgraded:
  cpp-4.9 g++-4.9 gcc-4.9 gcc-4.9-base libatomic1 libgcc-4.9-dev libgcc1
  libgomp1 libitm1 libssl-dev libssl1.0.0 libstdc++-4.9-dev libstdc++6
  libtiff5 python3-pkg-resources python3-requests python3-setuptools
  python3-urllib3
18 upgraded, 16 newly installed, 0 to remove and 189 not upgraded.
Need to get 32.9 MB of archives.
After this operation, 51.6 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libssl-dev libssl1.0.0 libblas-common libatlas3-base libblas3 libblas-dev
  libatlas-dev libatlas-base-dev python3-setuptools python3-pkg-resources
  python3-pyudev python3-urllib3 python3-requests python3-serial
E: There are problems and -y was used without --force-yes
Reading package lists...
Building dependency tree...
Reading state information...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 207 not upgraded.
Need to get 0 B/97.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 52844 files and directories currently installed.)
Preparing to unpack .../python3-pip_1.5.6-5_all.deb ...
Unpacking python3-pip (1.5.6-5) over (1.5.6-5) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up python3-pip (1.5.6-5) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.4/dist-packages
Cleaning up...
Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
  libelfg0
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  git-man libelf1 libglib2.0-0 libglib2.0-bin
Suggested packages:
  gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
  git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn libglib2.0-doc
The following NEW packages will be installed:
  libelf1
The following packages will be upgraded:
  git git-man libglib2.0-0 libglib2.0-bin libglib2.0-dev
5 upgraded, 1 newly installed, 0 to remove and 202 not upgraded.
Need to get 12.2 MB of archives.
After this operation, 7,645 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  git git-man libglib2.0-dev libglib2.0-bin libglib2.0-0
E: There are problems and -y was used without --force-yes
Requirement already satisfied (use --upgrade to upgrade): pyudev in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python3.4/dist-packages (from pyudev)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): pyserial in /usr/local/lib/python3.4/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): requests in /usr/lib/python3/dist-packages
Cleaning up...
Downloading/unpacking pybluez
  Running setup.py (path:/tmp/pip-build-mpx4z242/pybluez/setup.py) egg_info for package pybluez
    /tmp/pip-build-mpx4z242/pybluez/setup.py:12: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
      os.getenv('ProgramFiles(x86)'))
    warning: no files found matching '*.h' under directory 'osx'
    warning: no previously-included files matching '*.pyc' found under directory '*'
    warning: no previously-included files matching '*.o' found under directory '*'
    warning: no previously-included files matching '*.opp' found under directory '*'
Installing collected packages: pybluez
  Running setup.py install for pybluez
    building 'bluetooth._bluetooth' extension
    aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.4m -c bluez/btmodule.c -o build/temp.linux-aarch64-3.4/bluez/btmodule.o
    In file included from bluez/btmodule.c:20:0:
    bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: No such file or directory
     #include <bluetooth/bluetooth.h>
                                     ^
    compilation terminated.
    error: command 'aarch64-linux-gnu-gcc' failed with exit status 1
    Complete output from command /usr/bin/python3 -c "import setuptools, tokenize;__file__='/tmp/pip-build-mpx4z242/pybluez/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('
', '
'), __file__, 'exec'))" install --record /tmp/pip-v97hen6r-record/install-record.txt --single-version-externally-managed --compile:
    running install

running build

running build_py

creating build

creating build/lib.linux-aarch64-3.4

creating build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/__init__.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/widcomm.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/osx.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/msbt.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/btcommon.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/bluez.py -> build/lib.linux-aarch64-3.4/bluetooth

copying bluetooth/ble.py -> build/lib.linux-aarch64-3.4/bluetooth

running build_ext

building 'bluetooth._bluetooth' extension

creating build/temp.linux-aarch64-3.4

creating build/temp.linux-aarch64-3.4/bluez

aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.4m -c bluez/btmodule.c -o build/temp.linux-aarch64-3.4/bluez/btmodule.o

In file included from bluez/btmodule.c:20:0:

bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: No such file or directory

 #include <bluetooth/bluetooth.h>

                                 ^

compilation terminated.

error: command 'aarch64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
Cleaning up...
Command /usr/bin/python3 -c "import setuptools, tokenize;__file__='/tmp/pip-build-mpx4z242/pybluez/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('
', '
'), __file__, 'exec'))" install --record /tmp/pip-v97hen6r-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip-build-mpx4z242/pybluez
Storing debug log for failure in /root/.pip/pip.log
Downloading/unpacking pillow
  Running setup.py (path:/tmp/pip-build-w5t6p5ln/pillow/setup.py) egg_info for package pillow
    /tmp/pip-build-w5t6p5ln/pillow/setup.py:12: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
      import os
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/tmp/pip-build-w5t6p5ln/pillow/setup.py", line 873, in <module>
        zip_safe=not (debug_build() or PLATFORM_MINGW),
      File "/usr/local/lib/python3.4/dist-packages/setuptools/__init__.py", line 145, in setup
        return distutils.core.setup(**attrs)
      File "/usr/lib/python3.4/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/usr/lib/python3.4/distutils/dist.py", line 955, in run_commands
        self.run_command(cmd)
      File "/usr/lib/python3.4/distutils/dist.py", line 974, in run_command
        cmd_obj.run()
      File "<string>", line 15, in replacement_run
      File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 303, in find_sources
        mm.run()
      File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 534, in run
        self.add_defaults()
      File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 570, in add_defaults
        sdist.add_defaults(self)
      File "/usr/local/lib/python3.4/dist-packages/setuptools/command/py36compat.py", line 36, in add_defaults
        self._add_defaults_ext()
      File "/usr/local/lib/python3.4/dist-packages/setuptools/command/py36compat.py", line 119, in _add_defaults_ext
        build_ext = self.get_finalized_command('build_ext')
      File "/usr/lib/python3.4/distutils/cmd.py", line 299, in get_finalized_command
        cmd_obj.ensure_finalized()
      File "/usr/lib/python3.4/distutils/cmd.py", line 107, in ensure_finalized
        self.finalize_options()
      File "/tmp/pip-build-w5t6p5ln/pillow/setup.py", line 324, in finalize_options
        if sys.version_info.major >= 3 and not self.parallel:
      File "/usr/lib/python3.4/distutils/cmd.py", line 103, in __getattr__
        raise AttributeError(attr)
    AttributeError: parallel
    Complete output from command python setup.py egg_info:
    running egg_info

creating pip-egg-info/Pillow.egg-info

writing dependency_links to pip-egg-info/Pillow.egg-info/dependency_links.txt

writing top-level names to pip-egg-info/Pillow.egg-info/top_level.txt

writing pip-egg-info/Pillow.egg-info/PKG-INFO

writing manifest file 'pip-egg-info/Pillow.egg-info/SOURCES.txt'

/tmp/pip-build-w5t6p5ln/pillow/setup.py:12: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.

  import os

Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/tmp/pip-build-w5t6p5ln/pillow/setup.py", line 873, in <module>

    zip_safe=not (debug_build() or PLATFORM_MINGW),

  File "/usr/local/lib/python3.4/dist-packages/setuptools/__init__.py", line 145, in setup

    return distutils.core.setup(**attrs)

  File "/usr/lib/python3.4/distutils/core.py", line 148, in setup

    dist.run_commands()

  File "/usr/lib/python3.4/distutils/dist.py", line 955, in run_commands

    self.run_command(cmd)

  File "/usr/lib/python3.4/distutils/dist.py", line 974, in run_command

    cmd_obj.run()

  File "<string>", line 15, in replacement_run

  File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 303, in find_sources

    mm.run()

  File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 534, in run

    self.add_defaults()

  File "/usr/local/lib/python3.4/dist-packages/setuptools/command/egg_info.py", line 570, in add_defaults

    sdist.add_defaults(self)

  File "/usr/local/lib/python3.4/dist-packages/setuptools/command/py36compat.py", line 36, in add_defaults

    self._add_defaults_ext()

  File "/usr/local/lib/python3.4/dist-packages/setuptools/command/py36compat.py", line 119, in _add_defaults_ext

    build_ext = self.get_finalized_command('build_ext')

  File "/usr/lib/python3.4/distutils/cmd.py", line 299, in get_finalized_command

    cmd_obj.ensure_finalized()

  File "/usr/lib/python3.4/distutils/cmd.py", line 107, in ensure_finalized

    self.finalize_options()

  File "/tmp/pip-build-w5t6p5ln/pillow/setup.py", line 324, in finalize_options

    if sys.version_info.major >= 3 and not self.parallel:

  File "/usr/lib/python3.4/distutils/cmd.py", line 103, in __getattr__

    raise AttributeError(attr)

AttributeError: parallel

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-w5t6p5ln/pillow
Storing debug log for failure in /root/.pip/pip.log
Downloading/unpacking numpy
  Running setup.py (path:/tmp/pip-build-n0ixrs8g/numpy/setup.py) egg_info for package numpy
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/tmp/pip-build-n0ixrs8g/numpy/setup.py", line 31, in <module>
        raise RuntimeError("Python version >= 3.5 required.")
    RuntimeError: Python version >= 3.5 required.
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/tmp/pip-build-n0ixrs8g/numpy/setup.py", line 31, in <module>

    raise RuntimeError("Python version >= 3.5 required.")

RuntimeError: Python version >= 3.5 required.

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-n0ixrs8g/numpy
Storing debug log for failure in /root/.pip/pip.log
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.4/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/__init__.py to __init__.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/blescan.py to blescan.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/btle.py to btle.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/get_services.py to get_services.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/scanner.py to scanner.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/sensortag.py to sensortag.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/thingy52.py to thingy52.cpython-34.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing bluepy.egg-info/PKG-INFO
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.4/dist-packages/bluepy-1.1.4-py3.4.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.4/dist-packages/bluepy-1.1.4-py3.4.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Installing blescan script to /usr/local/bin
Requirement already satisfied (use --upgrade to upgrade): cryptography in /usr/local/lib/python3.4/dist-packages
Requirement already satisfied (use --upgrade to upgrade): asn1crypto>=0.21.0 in /usr/local/lib/python3.4/dist-packages (from cryptography)
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.1 in /usr/local/lib/python3.4/dist-packages (from cryptography)
Requirement already satisfied (use --upgrade to upgrade): cffi!=1.11.3,>=1.8 in /usr/local/lib/python3.4/dist-packages (from cryptography)
Requirement already satisfied (use --upgrade to upgrade): pycparser in /usr/local/lib/python3.4/dist-packages (from cffi!=1.11.3,>=1.8->cryptography)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): pycrypto in /usr/local/lib/python3.4/dist-packages
Cleaning up...
********************************************************
*			 Installation terminée					*
********************************************************
Jeedom Smart, Mini+ + RFXCom + Clé 3g, onduleur, qqs trucs z wave, Keycode RFID Zipato + Flower Power + Téléc RFX chinoises x 4 + Caméra vidéo Foscam FI9821P + Détecteur ouverture de garage ZG8101 + Xiaomi & magic cube + SoundTab

madcow
Timide
Messages : 298
Inscription : 06 févr. 2019, 21:41

Re: impossible d'installer les dépendance HELP

Message par madcow » 23 sept. 2019, 12:49

Bonjour,

@zeftp
Il faut passer sur Debian Stretch pour BLEA. Or tu es encore sur Debian Jessie.


DIY Proxmox sur HP Proliant
Débutant sur Jeedom

Avatar de l’utilisateur
zeftp
Timide
Messages : 441
Inscription : 19 avr. 2015, 11:46
Localisation : Lyon

Re: impossible d'installer les dépendance HELP

Message par zeftp » 24 sept. 2019, 11:23

Bonjour,

je n'ai rien changé depuis que j'ai acheté ma Smart. J'ai fait les mises à jour du core et des plugins régulièrement.

S'il faut faire une opération spéciale pour que sa smart fonctionne, est-ce qu'une communication type email a été faite?
Est ce qu'on a du recul sur cette migration ? C'est stable?

Merci
Jeedom Smart, Mini+ + RFXCom + Clé 3g, onduleur, qqs trucs z wave, Keycode RFID Zipato + Flower Power + Téléc RFX chinoises x 4 + Caméra vidéo Foscam FI9821P + Détecteur ouverture de garage ZG8101 + Xiaomi & magic cube + SoundTab

madcow
Timide
Messages : 298
Inscription : 06 févr. 2019, 21:41

Re: impossible d'installer les dépendance HELP

Message par madcow » 24 sept. 2019, 12:53

zeftp a écrit :Bonjour,

je n'ai rien changé depuis que j'ai acheté ma Smart. J'ai fait les mises à jour du core et des plugins régulièrement.

S'il faut faire une opération spéciale pour que sa smart fonctionne, est-ce qu'une communication type email a été faite?
Est ce qu'on a du recul sur cette migration ? C'est stable?

Merci
Bonjour,

Le passage en Stretch est une mise à jour majeure qui doit être réalisée selon une procédure spécifique.

Voir ici tous les détails (ne pas avoir peur des bugs rencontrés par les 1ères personnes ayant migré ils ont été corrigés depuis) : viewtopic.php?t=44870
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

Avatar de l’utilisateur
zeftp
Timide
Messages : 441
Inscription : 19 avr. 2015, 11:46
Localisation : Lyon

Re: impossible d'installer les dépendance HELP

Message par zeftp » 24 sept. 2019, 20:40

Ouais c'est vrai qu'ils ont l'air corrigés...
Capture.PNG
Capture.PNG (788.18 Kio) Consulté 379 fois
C'est parti pour la galère... je change de thread
Jeedom Smart, Mini+ + RFXCom + Clé 3g, onduleur, qqs trucs z wave, Keycode RFID Zipato + Flower Power + Téléc RFX chinoises x 4 + Caméra vidéo Foscam FI9821P + Détecteur ouverture de garage ZG8101 + Xiaomi & magic cube + SoundTab

tontonel
Timide
Messages : 79
Inscription : 24 janv. 2017, 17:48

Re: impossible d'installer les dépendance HELP

Message par tontonel » 04 oct. 2019, 23:14

Salut la team

Fabrice :
bonjour j'ai suivie votre manip puis réinstallé les dépendances mais j'ai toujours le même résultat.

Patdec :
Je suis en strech, sur raspberry et avec la dernière maj de jeedom.

Une idée d'où ça peux venir ? Les dépendances s'installent a chaque fois que jeu mettre en route le plugins ?

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3415
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: impossible d'installer les dépendance HELP

Message par Fabrice » 05 oct. 2019, 09:19

Bonjour,

Il faut placer de nouveau le journal des dépendances.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

tontonel
Timide
Messages : 79
Inscription : 24 janv. 2017, 17:48

Re: impossible d'installer les dépendance HELP

Message par tontonel » 07 oct. 2019, 21:54

bonjour,

désolé mais je ne comprend pas.
peux tu m'expliquer la manip ?

merci

tontonel
Timide
Messages : 79
Inscription : 24 janv. 2017, 17:48

Re: impossible d'installer les dépendance HELP

Message par tontonel » 07 oct. 2019, 21:56

voici le log de l'installation :

il y a pas mal d'erreur apparement.

Code : Tout sélectionner

touch: impossible de faire un touch '/tmp/jeedom/blea/dependance': Aucun fichier ou dossier de ce type
/var/www/html/plugins/blea/core/class/../../resources/install_apt.sh: ligne 6: /tmp/jeedom/blea/dependance: Aucun fichier ou dossier de ce type
********************************************************
*			 Installation des dépendances			 *
********************************************************
Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Réception de:2 http://archive.raspberrypi.org/debian stretch InRelease [25,4 kB]
Atteint:3 https://deb.nodesource.com/node_12.x stretch InRelease
Atteint:4 https://raspbian.snips.ai/stretch stable InRelease
25,4 ko réceptionnés en 2s (11,4 ko/s)
Lecture des listes de paquets…
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libopenjp2-7 is already the newest version (2.1.2-1.1+deb9u3).
libopenjp2-7 passé en « installé manuellement ».
libtiff5 is already the newest version (4.0.8-2+deb9u4).
libtiff5 passé en « installé manuellement ».
python3-dev is already the newest version (3.5.3-1).
python3-requests is already the newest version (2.12.4-1).
python3-requests passé en « installé manuellement ».
python3-setuptools is already the newest version (33.1.1-1).
rfkill is already the newest version (0.5-1).
rfkill passé en « installé manuellement ».
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
libatlas-base-dev : Dépend: libatlas3-base (= 3.10.3-1+rpi1) mais 3.10.3-1-snips devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
libpng12-0
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin :
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 24 non mis à jour.
Il est nécessaire de prendre 0 o/142 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 115406 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-pip_9.0.1-2+rpt2_all.deb ...
Dépaquetage de python3-pip (9.0.1-2+rpt2) sur (9.0.1-2+rpt2) ...
Paramétrage de python3-pip (9.0.1-2+rpt2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.5/dist-packages
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2+deb9u1).
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
libpng12-0
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 24 non mis à jour.
Requirement already satisfied: pyudev in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pyudev)
Requirement already satisfied: pyserial in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Collecting pybluez
Using cached https://files.pythonhosted.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip
Building wheels for collected packages: pybluez
Running setup.py bdist_wheel for pybluez: started
Running setup.py bdist_wheel for pybluez: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-cwzcc84s/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmphmx3z8nbpip-wheel- --python-tag cp35:
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-armv7l-3.5
creating build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/ble.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/btcommon.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/widcomm.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/osx.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/bluez.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/msbt.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/__init__.py -> build/lib.linux-armv7l-3.5/bluetooth
running build_ext
building 'bluetooth._bluetooth' extension
creating build/temp.linux-armv7l-3.5
creating build/temp.linux-armv7l-3.5/bluez
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-6waWnr/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.5m -c bluez/btmodule.c -o build/temp.linux-armv7l-3.5/bluez/btmodule.o
In file included from bluez/btmodule.c:20:0:
bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: Aucun fichier ou dossier de ce type
#include <bluetooth/bluetooth.h>
^
compilation terminated.
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
----------------------------------------
Failed building wheel for pybluez
Running setup.py clean for pybluez
Failed to build pybluez
Installing collected packages: pybluez
Running setup.py install for pybluez: started
Running setup.py install for pybluez: finished with status 'error'
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-cwzcc84s/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ncx5c9gs-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-armv7l-3.5
creating build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/ble.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/btcommon.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/widcomm.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/osx.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/bluez.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/msbt.py -> build/lib.linux-armv7l-3.5/bluetooth
copying bluetooth/__init__.py -> build/lib.linux-armv7l-3.5/bluetooth
running build_ext
building 'bluetooth._bluetooth' extension
creating build/temp.linux-armv7l-3.5
creating build/temp.linux-armv7l-3.5/bluez
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fdebug-prefix-map=/build/python3.5-6waWnr/python3.5-3.5.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -I./port3 -I/usr/include/python3.5m -c bluez/btmodule.c -o build/temp.linux-armv7l-3.5/bluez/btmodule.o
In file included from bluez/btmodule.c:20:0:
bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: Aucun fichier ou dossier de ce type
#include <bluetooth/bluetooth.h>
^
compilation terminated.
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1
----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-cwzcc84s/pybluez/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('
', '
');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ncx5c9gs-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-cwzcc84s/pybluez/
Requirement already satisfied: pillow in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: numpy in /usr/local/lib/python3.5/dist-packages
Clonage dans 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing entry points to bluepy.egg-info/entry_points.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Installing blescan script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************

tontonel
Timide
Messages : 79
Inscription : 24 janv. 2017, 17:48

Re: impossible d'installer les dépendance HELP

Message par tontonel » 07 oct. 2019, 22:02

grrrrrrrr rien y fait. les dépendances passent leur temps à ce réinstaller mais le plugin démarre pas...
c'est rageant ça marche plus au moment ou j'en ai le plus besoin ( monitoring via nut des enfants qui rentrent seul maintenant de l'école )

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: impossible d'installer les dépendance HELP

Message par bronche » 07 oct. 2019, 23:53

Bonsoir,
Un beau bordel ...

peut être un problème sur les bibliothèques et les dépendances
Tente en SSh :
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
Puis pour python

Code : Tout sélectionner

for x in $(pip list -o --format=columns | sed -n '3,$p' | cut -d' ' -f1); do pip install $x --upgrade; done
puis

Code : Tout sélectionner

sudo easy_install -U cryptography

pip install pyopenssl 
relance tes dépendances et poste le log

Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

winhex
Actif
Messages : 3781
Inscription : 23 janv. 2015, 01:41

Re: impossible d'installer les dépendance HELP

Message par winhex » 27 oct. 2019, 17:14

ta cmd python demande un certain temps de mise à jour mais elle a résolut mon soucis (avec ajout sudo au bon endroit) pour un rasp avec vielle version blea et jeedom
merci bronche

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités