Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin SMS

broukmout
Timide
Messages : 8
Inscription : 26 avr. 2018, 16:46

Re: Plugin SMS

Message par broukmout » 27 avr. 2018, 12:24

Bonjour les gens !

ça fait 2 jours que j’épluche les docs et le forum pour faire fonctionner cette fameuse Clé 3G et le plugin SMS. Je pense que là j'ai besoin d'aide avant de péter un câble :D

Matos : rPi 3b+ sous Stretch
La clé 3G du tuto de rosty, branchée sur un hub alimenté.
puce orange, pas de code PIN
évidemment, tout à jour.

La clé est bien en mode modem, elle est vu dans lsusb et apparait aussi en ttyUSB0, ttyUSB1 et ttyUSB2 (à priori le 0 et le 2 ont l'air d'aller plus loin que le USB1 qui lui plante à la commande ATZ lors du lancement du demon) :

Image

Image

la config :

Image

et le log :

Code : Tout sélectionner

[2018-04-27 12:17:32][INFO] : Lancement démon sms : /usr/bin/python /var/www/html/plugins/sms/resources/smsd/smsd.py --device /dev/ttyUSB2 --loglevel debug --socketport 55002 --serialrate 9600 --pin None --textmode no --smsc +33689004000 --cycle 30 --callback http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php --apikey D1lwJB5PARiT64cZUTBIgCa0gDB4qixK --pid /tmp/jeedom/sms/deamon.pid
[2018-04-27 12:17:34][INFO] : Start smsd
[2018-04-27 12:17:34][INFO] : Log level : debug
[2018-04-27 12:17:34][INFO] : Socket port : 55002
[2018-04-27 12:17:34][INFO] : Socket host : 127.0.0.1
[2018-04-27 12:17:34][INFO] : PID file : /tmp/jeedom/sms/deamon.pid
[2018-04-27 12:17:34][INFO] : Device : /dev/ttyUSB2
[2018-04-27 12:17:34][INFO] : Apikey : xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[2018-04-27 12:17:34][INFO] : Callback : http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php
[2018-04-27 12:17:34][INFO] : Cycle : 30.0
[2018-04-27 12:17:34][INFO] : Serial rate : 9600
[2018-04-27 12:17:34][INFO] : Pin : None
[2018-04-27 12:17:34][INFO] : Text mode : no
[2018-04-27 12:17:34][INFO] : SMSC : +33689004000
[2018-04-27 12:17:34][DEBUG] : Writing PID 7876 to /tmp/jeedom/sms/deamon.pid
[2018-04-27 12:17:34][DEBUG] : Init request module v2.12.4
[2018-04-27 12:17:34][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-04-27 12:17:34][DEBUG] : http://127.0.0.1:80 "GET /plugins/sms/core/php/jeeSMS.php?apikey=xxxxxxxxxxxxxxxxxxxxxxxxxxHTTP/1.1" 200 0
[2018-04-27 12:17:34][DEBUG] : Socket interface started
[2018-04-27 12:17:34][DEBUG] : LoopNetServer Thread started
[2018-04-27 12:17:34][DEBUG] : Start listening...
[2018-04-27 12:17:34][DEBUG] : Listening on: [127.0.0.1:55002]
[2018-04-27 12:17:34][DEBUG] : Connecting to GSM Modem...
[2018-04-27 12:17:34][DEBUG] : Text mode false
[2018-04-27 12:17:34][INFO] : Connecting to modem on port /dev/ttyUSB2 at 9600bps
[2018-04-27 12:17:34][DEBUG] : write: ATZ
[2018-04-27 12:17:34][DEBUG] : response: ['OK']
[2018-04-27 12:17:34][DEBUG] : write: ATE0
[2018-04-27 12:17:34][DEBUG] : response: ['OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+CFUN?
[2018-04-27 12:17:34][DEBUG] : response: ['+CFUN: 1', 'OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+CMEE=1
[2018-04-27 12:17:34][DEBUG] : response: ['OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+CPIN?
[2018-04-27 12:17:34][DEBUG] : response: ['+CPIN:READY', 'OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+CLAC
[2018-04-27 12:17:34][DEBUG] : response: ['&C', '&D', '&E', '&F', '&S', '&V', '&W', 'E', 'I', 'L', 'M', 'Q', 'V', 'X', 'Z', 'T', 'P', '\Q', '\S', '\V', '%V', 'D', 'A', 'H', 'O', 'S0', 'S3', 'S4', 'S5', 'S6', 'S7', 'S8', 'S9', 'S10', 'S11', 'S30', 'S103', 'S104', '+FCLASS', '+ICF', '+IFC', '+IPR', '+GMI', '+GMM', '+GMR', '+GCAP', '+GSN', '+DR', '+DS', '+WS46', '+WRIMEI', '+WRIMEI2', '+WRSN', '+CBST', '+CRLP', '+CV120', '+CHSN', '+CSSN', '+CREG', '+CGREG', '+CFUN', '+GCAP', '+CSCS', '+CSTA', '+CR', '+CEER', '+CRC', '+CMEE', '+CGDCONT', '+CGDSCONT', '+CGTFT', '+CGEQREQ', '+CGEQMIN', '+CGQREQ', '+CGQMIN', '+CGEREP', '+CGPADDR', '+CGDATA', '+CGCLASS', '+CGSMS', '+CSMS', '+CMGF', '+CSAS', '+CRES', '+CSCA', '+CSMP', '+CSDH', '+CSCB', '+FDD', '+FAR', '+FCL', '+FIT', '+ES', '+ESA', '+CMOD', '+CVHU', '+HSDPA', '+TTYMODE', '+EONS', '+pref_UARFCN', '+ATAmaskW1', '+QEXTONE', '+ATAAGPS', '+CUS_SBM', '+CUS_EM', '+2GNCELL', '+Q2GNCELL', '+3GNCELL', '+Q3GNCELL', '+MEMFULL', '+OPTUS', '+CMEMFULL', '+SKTSRVMOD', '+NETMODE', '+CSQ', '+CBC', '+CPAS', '+CPIN', '+CMEC', '+CKPD', '+CIND', '+CMER', '+CGATT', '+CGACT', '+CGCMOD', '+CPBS', '+CPBR', '+CPBF', '+CPBW', '+CPMS', '+CNMI', '+CMGL', '+CMGR', '+CMGS', '+CMSS', '+CMGW', '+CMGD', '+CMGC', '+CNMA', '+CMMS', '+CHUP', '+CCFC', '+CCUG', '+COPS', '+ATA_PPLMN', '+CGAATT', '+BANDSET', '+COPSLAC', '+ALS', '+ODEN', '+ATAPDPIDLE', '+FWDB', '+MTCFW', '+CLCK', '+CNAP', '+CPWD', '+CUSD', '+CAOC', '+SKT_ECC', '+A5X', '+CACM', '+CAMM', '+CPUC', '+CCWA', '+CHLD', '+CIMI', '+SKTEMBandSet', '+UCID', '+CHZ', '+CPPP', '+CALLREJECT', '+RXD', '+EQ', '+MAXPWR', '+L1OPT', '+ENCSQ', '+ATACNIV', '+QBANDCAP', '+CGMI', '+CGMM', '+CGMR', '+CGSN', '+CNUM', '+CSIM', '+CRSM', '+CCLK', '+CLVL', '+CMUT', '+CLCC', '+COPN', '+CPOL', '+CPLS', '+CTZR', '+ATACTZR', '+CTZU', '+CLAC', '+CLIP', '+COLP', '+CDIP', '+CTFR', '+CLIR', '+SIMTYPE', '+CPBC', '+CCSQ', '+DMODE', '+SKTEMPrefUARFCN', '+VTS', '+PHPREF', '^CVOICE', '^SNDDEVICE', '+DELAYREG', '^SDEN', '^CALLPROTECT', '^OTPPROGCMD', '^OTPINF', '^OTPGET', '^OTPSET', '^POSTPROGCMD', '+TIME', '+FLASHID', '^SRAND', '^FSREGION', '^ISOVERSION', '^CONAME', '^PROJECTNAME', '^VERSIONNAME', '^INTFACENAME', '+TESTINFO', '+DATACARD', '^SCID', '^LOCKDOWN', '^SWAUTHOR', '^DATADIS', '^EMLIST', '^NETNAME', '^REVSHOW', '^HWVER', '^MACCH', '^OTPMAC', '^ATAOTPEXT', '^ATAEXTFUNC', '^ATAEXTBKISO', '^ISOLANG', '^OEMID', '^HS', '^CARDLOCK', '^CARDMODE', '^SYSINFO', '^SPN', '^CPIN', '^IPAD', '^ATADEFAULTRF', '^DIAGEN', '^LINKRATESET', '$QCSIMSTAT', '$QCCNMI', '$QCCLR', '$QCDMG', '$QCDMR', '$QCDNSP', '$QCDNSS', '$QCTER', '$QCSLOT', '$QCPINSTAT', '$QCPDPP', '$QCPDPLT', '$QCPWRDN', '$QCDGEN', '$BREW', '$QCSYSMODE', '$CPINS', 'OK']
[2018-04-27 12:17:34][DEBUG] : write: AT^CVOICE=0
[2018-04-27 12:17:34][DEBUG] : response: ['^CVOICE:0,8000Hz,16,20', 'OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+CGMI
[2018-04-27 12:17:34][DEBUG] : response: ['QUALCOMM INCORPORATED', 'OK']
[2018-04-27 12:17:34][DEBUG] : write: AT+ZPAS?
[2018-04-27 12:17:35][DEBUG] : response: ['ERROR']
[2018-04-27 12:17:35][INFO] : Unknown/generic modem type - will use polling for call state updates
[2018-04-27 12:17:35][DEBUG] : write: AT+COPS=3,0
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CMGF=0
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CSCA?
[2018-04-27 12:17:35][DEBUG] : response: ['+CSCA: "+33689004000",145', 'OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CSMP=49,167,0,0
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CSCA?
[2018-04-27 12:17:35][DEBUG] : response: ['+CSCA: "+33689004000",145', 'OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CPMS=?
[2018-04-27 12:17:35][DEBUG] : response: ['+CPMS: ("ME","MT","SM","SR"),("ME","MT","SM","SR"),("ME","MT","SM","SR")', 'OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CPMS="ME","ME","ME"
[2018-04-27 12:17:35][DEBUG] : response: ['+CPMS: 0,255,0,255,0,255', 'OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CNMI=2,1,0,2
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CLIP=1
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CRC=1
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : write: AT+CVHU=0
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : Configure smsc : +33689004000
[2018-04-27 12:17:35][DEBUG] : write: AT+CSCA="+33689004000"
[2018-04-27 12:17:35][DEBUG] : response: ['OK']
[2018-04-27 12:17:35][DEBUG] : Waiting for network...
[2018-04-27 12:17:35][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:35][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:36][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:36][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:37][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:37][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:38][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:38][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:39][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:39][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:40][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:40][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:41][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:41][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:42][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:42][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:43][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:43][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:44][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:44][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:45][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:45][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:46][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:46][DEBUG] : response: ['+CREG: 0,2', 'OK']
[2018-04-27 12:17:47][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:47][DEBUG] : response: ['+CREG: 0,2', 'OK']

Problème :

1° : je capte pas le réseau :

Image

2° : évidemment aucun texto ne part ^^ mais je vois passer ça dans le log :

Code : Tout sélectionner

[2018-04-27 12:45:40][DEBUG] : Client connected to [127.0.0.1:55818]
[2018-04-27 12:45:40][DEBUG] : Message read from socket: {"apikey":"xxxxxxxxxxxxxxxxxxxxxxxxxx","number":"+336********","message":"test"}
[2018-04-27 12:45:40][DEBUG] : Client disconnected from [127.0.0.1:55818]
Le Log boucle à l'infini sur ça :

Code : Tout sélectionner

[2018-04-27 12:17:47][DEBUG] : write: AT+CREG?
[2018-04-27 12:17:47][DEBUG] : response: ['+CREG: 0,2', 'OK']
ça peut avoir un lien?

on trouve ça aussi en erreur dans le log (une seule fois au lancement du demon) :

Code : Tout sélectionner

[2018-04-27 12:17:34][DEBUG] : write: AT+ZPAS?
[2018-04-27 12:17:35][DEBUG] : response: ['ERROR']
voila le code executé lors de cette etape :

Image

J'ai collé une Femtocell Orange à coté de la clé pour tester si ça venait du réseau (parce que à la base mon LackRack dans lequel se trouve toute l'install est au fin fond de mon garage, et ça capte pas top) à priori ça change rien.

Edit : la femto semble être en rade. Matos Orange quoi...

Problème hardware avec la clé?

si quelqu'un a une idée je prend ! merci d'avance !

esso1
Actif
Messages : 856
Inscription : 03 oct. 2017, 12:26

Re: Plugin SMS

Message par esso1 » 27 avr. 2018, 14:31

il me semble que la clé de rosty ne fonctionne pas top sous sms, mais sous gamu.
changer de clé et prendre une clé huawei E220, .
soit neuve sur aliexpress, env 14€
soit ebay en fouillant on peut a 3/4 €

et ca fonctionnera beaucoup mieux

esso1
Actif
Messages : 856
Inscription : 03 oct. 2017, 12:26

Re: Plugin SMS

Message par esso1 » 27 avr. 2018, 14:35

loic a écrit :
24 avr. 2018, 15:24
Alors c'est peut etre free qui a vu que la carte sim se connecte toujours a la meme antenne et a bloqué l'accès dans ce cas il faut l'emener en voyage dans un téléphone pendant 24h
bon avec du retard, free bug beaucoup en ce moment sur les SMS....
chez moi 2 abonnement, ma femme envoi , moi impossible. ca revient sur un envoi puis plus rien et parfois sur 1 jour ...

Ekinox
Timide
Messages : 407
Inscription : 07 mars 2015, 13:17
Localisation : Toulouse

Re: Plugin SMS

Message par Ekinox » 27 avr. 2018, 15:03

Perso, la clef achetee sur le lien de Rosty n'a pas fonctionne (test sous Windows avant de passe sous Linux). Je suis en train de me faire rembourser...
J'ai recup une Huawei E180, nickel sous plugin SMS ou Gammu.
Note: J'avais auparavant une E220 qui m'a laché; donc attention ou tu l'achétes.
NUC i5+ESXi 6.0 (Jeedom sur Debian 8 avec zWave+RFXCom+MySensors+HuaweiG200)+IPX800v4+RaspPi (Multiroom SqueezeBox, Arrosage). 35 zWave/10 RFXCom/4 MySensors/Alarme filaire sur IPX (ouv, mvt, sirène ext), 4 Cameras

broukmout
Timide
Messages : 8
Inscription : 26 avr. 2018, 16:46

Re: Plugin SMS

Message par broukmout » 27 avr. 2018, 15:04

J'ai trouvé une E 180 à 8€ sur Ebay, on verra bien quand je vais la recevoir ;)

Ekinox
Timide
Messages : 407
Inscription : 07 mars 2015, 13:17
Localisation : Toulouse

Re: Plugin SMS

Message par Ekinox » 27 avr. 2018, 15:07

broukmout a écrit :J'ai trouvé une E 180 à 8€ sur Ebay, on verra bien quand je vais la recevoir ;)
T'as essayé ta clef sous Windows ? (pas de config, drivers et logiciel intégrés a la clef). Pr moi, c'est une bonne maniére de tester la partie matérielle (avant de passer sous Jeedom qd tu es sur que ta clef peut communiquer)
NUC i5+ESXi 6.0 (Jeedom sur Debian 8 avec zWave+RFXCom+MySensors+HuaweiG200)+IPX800v4+RaspPi (Multiroom SqueezeBox, Arrosage). 35 zWave/10 RFXCom/4 MySensors/Alarme filaire sur IPX (ouv, mvt, sirène ext), 4 Cameras

broukmout
Timide
Messages : 8
Inscription : 26 avr. 2018, 16:46

Re: Plugin SMS

Message par broukmout » 27 avr. 2018, 15:18

Pas contre non, j'aurai du commencer par là t'as raison.

Là je test la clé sur Jeedom, mais avec une puce B&You cette fois.

esso1
Actif
Messages : 856
Inscription : 03 oct. 2017, 12:26

Re: Plugin SMS

Message par esso1 » 27 avr. 2018, 16:31

broukmout a écrit :
27 avr. 2018, 15:18
Pas contre non, j'aurai du commencer par là t'as raison.

Là je test la clé sur Jeedom, mais avec une puce B&You cette fois.
a mon avis tu perds ton temps

gammu ou tu change de clé ...

broukmout
Timide
Messages : 8
Inscription : 26 avr. 2018, 16:46

Re: Plugin SMS

Message par broukmout » 27 avr. 2018, 17:04

Alors déjà, j'ai dit que j'étais con ? :D

nan parce que 2 jours de config, et pas foutu de m'apercevoir que c'est une SIM qu'il faut mettre dans la clé 3G, et pas une micro-sim...

bref :D

j'ai testé sur le PC, ça dit que ça se connecte dans le soft, mais en fait nan, aucun in/out, la carte reseau de windows qui reste en disconnected, bref ça pue.

j'ai voulu tester avec Gammu, mais au moment de lancer le premier texto de test, le systeme a perdu la clé sans raison, elle était là dans lsusb, et pouf, disparue...

bref, je desactive les plugin et je m'y remet quand je reçois la nouvelle clé :D

esso1
Actif
Messages : 856
Inscription : 03 oct. 2017, 12:26

Re: Plugin SMS

Message par esso1 » 28 avr. 2018, 07:43

broukmout a écrit :
27 avr. 2018, 17:04
Alors déjà, j'ai dit que j'étais con ? :D

nan parce que 2 jours de config, et pas foutu de m'apercevoir que c'est une SIM qu'il faut mettre dans la clé 3G, et pas une micro-sim...

bref :D

j'ai testé sur le PC, ça dit que ça se connecte dans le soft, mais en fait nan, aucun in/out, la carte reseau de windows qui reste en disconnected, bref ça pue.

j'ai voulu tester avec Gammu, mais au moment de lancer le premier texto de test, le systeme a perdu la clé sans raison, elle était là dans lsusb, et pouf, disparue...

bref, je desactive les plugin et je m'y remet quand je reçois la nouvelle clé :D
sage idée. beaucoup plus simple

broukmout
Timide
Messages : 8
Inscription : 26 avr. 2018, 16:46

Re: Plugin SMS

Message par broukmout » 02 mai 2018, 12:26

J'ai reçu la nouvelle clé ce matin, j'ai réactivé le plugin, branché la clé, choisi le port et remis le code PIN, et zou, les textos fonctionnent.

C'était bien la clé du tuto de rosty qui fonctionnait pas ;)

esso1
Actif
Messages : 856
Inscription : 03 oct. 2017, 12:26

Re: Plugin SMS

Message par esso1 » 04 mai 2018, 09:41

broukmout a écrit :
02 mai 2018, 12:26
J'ai reçu la nouvelle clé ce matin, j'ai réactivé le plugin, branché la clé, choisi le port et remis le code PIN, et zou, les textos fonctionnent.

C'était bien la clé du tuto de rosty qui fonctionnait pas ;)
oui c bien plus simple avec une bonne clé.
c'est dommage ce tuto, car tout le monde prend la clé de rosty, et a 95% elle ne fonctionne pas...
cela serait bien a Rosty de mettre a jour . car c'est pas magique, et ce nest pas un bon plan . !!!
pour 2 € de plus on a une clé Huawei. qui elle fonctionne.

jeremy02
Timide
Messages : 18
Inscription : 16 févr. 2018, 14:01

Re: Plugin SMS

Message par jeremy02 » 04 mai 2018, 10:48

c'est dommage ce tuto, car tout le monde prend la clé de rosty, et a 95% elle ne fonctionne pas...
cela serait bien a Rosty de mettre a jour . car c'est pas magique, et ce nest pas un bon plan . !!!
pour 2 € de plus on a une clé Huawei. qui elle fonctionne.
Je confirme, c'est plus simple avec la Huawei. ;)

squwal
Timide
Messages : 60
Inscription : 25 mai 2017, 17:15

Re: Plugin SMS

Message par squwal » 04 mai 2018, 11:26

ah ben on y arrive, parfois. Mais c'est pas stable...
Je galère avec la mienne, j'ai réussi à la remettre en fonction, mais elle fini par bugguer au bout de quelques jours, et pas d'autres moyen pour la récupérer que la débrancher, rebrancher. Pas du tout pratique...

xav_38
Timide
Messages : 462
Inscription : 13 avr. 2016, 20:45
Localisation : Grenoble

Re: Plugin SMS

Message par xav_38 » 12 mai 2018, 10:08

Bonjour

j'ai migré d'un RPI3 à un NUC.

Mon dongle E220 marche nickel sur le RPI3, je viens de refaire un test. En revanche, quand je le connecte au NUC, je vois bien deux ports USB du Huawei (j'utilise le 1er sur le RPI3) mais l'initialisation du démon du plugin SMS se passe mal et je n'arrive pas à le faire fonctionner.

Est-ce qu'une réception de 11/30 peut causer de tels problèmes (avec le RPI3 qui est localisé ailleurs, j'ai 15/30) ?
Dernière édition par xav_38 le 12 mai 2018, 11:21, édité 2 fois.

drs
Actif
Messages : 1526
Inscription : 04 nov. 2016, 10:44

Re: Plugin SMS

Message par drs » 12 mai 2018, 10:10

xav_38 a écrit :
12 mai 2018, 10:08
Bonjour

j'ai migré d'un RPI3 à un NUC.

Moon dongle E220 marche nickel sur le RPI3, je viens de refaire un test. En revanche, quand je le connecte au NUC, je vois bien deux ports USB du Huawei (j'utilise le 1er sur le RPI3) mais l'initialisation du démon du plugin SMS se passe mal et je n'arrive pas à le faire fonctionner.

Est-ce qu'une réception de 11/30 peut causer de tels problème (avec le RPI3 qui est localisé ailleurs, j'ai 15/30) ?
Bonjour,

Sur le pi je suis déjà descendu à 8/30 sans problème.
Donc à priori ton souci ne viens pas de là.

xav_38
Timide
Messages : 462
Inscription : 13 avr. 2016, 20:45
Localisation : Grenoble

Re: Plugin SMS

Message par xav_38 » 12 mai 2018, 11:30

Bon, j'ai enlevé la rallonge (qui pourtant marchait sur RPI3) et changé de port USB et ça fonctionne, je ne vais pas me prendre la tête, le fonctionnement a l'air assez capricieux.

xav_38
Timide
Messages : 462
Inscription : 13 avr. 2016, 20:45
Localisation : Grenoble

Re: Plugin SMS

Message par xav_38 » 16 mai 2018, 22:24

de retour, pour des raisons inconnues, cela ne marche plus

j'ai le log suivant si quelqu'un saurait m'aiguiller dans le diagnotic

Code : Tout sélectionner

[2018-05-16 22:20:04][INFO] : Connecting to modem on port /dev/ttyUSB2 at 115200bps
[2018-05-16 22:20:04][DEBUG] : write: ATZ
[2018-05-16 22:20:04][DEBUG] : response: ['OK']
[2018-05-16 22:20:04][DEBUG] : write: ATE0
[2018-05-16 22:20:04][DEBUG] : response: ['ATE0', 'OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CFUN?
[2018-05-16 22:20:04][DEBUG] : response: ['+CFUN: 1', 'OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CMEE=1
[2018-05-16 22:20:04][DEBUG] : response: ['OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CPIN?
[2018-05-16 22:20:04][DEBUG] : response: ['+CPIN: READY', 'OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CLAC
[2018-05-16 22:20:04][DEBUG] : response: ['COMMAND NOT SUPPORT']
[2018-05-16 22:20:04][DEBUG] : write: AT+WIND?
[2018-05-16 22:20:04][DEBUG] : response: ['COMMAND NOT SUPPORT']
[2018-05-16 22:20:04][DEBUG] : write: AT+CGMI
[2018-05-16 22:20:04][DEBUG] : response: ['huawei', 'OK']
[2018-05-16 22:20:04][INFO] : Loading Huawei call state update table
[2018-05-16 22:20:04][DEBUG] : write: AT+COPS=3,0
[2018-05-16 22:20:04][DEBUG] : response: ['OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CMGF=0
[2018-05-16 22:20:04][DEBUG] : response: ['OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CSCA?
[2018-05-16 22:20:04][DEBUG] : response: ['+CSCA: "002B00330033003600390035003000300030003600390035",145', 'OK']
[2018-05-16 22:20:04][DEBUG] : write: AT+CSMP=49,167,0,0
[2018-05-16 22:20:09][ERROR] : Exception: None
[2018-05-16 22:20:09][ERROR] : Exit 1 because this exeption is fatal
[2018-05-16 22:20:09][DEBUG] : Send to jeedom :  {'message': 'None', 'number': 'none'}
[2018-05-16 22:20:09][DEBUG] : Shutdown
[2018-05-16 22:20:09][DEBUG] : Removing PID file /tmp/jeedom/sms/deamon.pid
[2018-05-16 22:20:09][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-05-16 22:20:09][DEBUG] : http://127.0.0.1:80 "POST /plugins/sms/core/php/jeeSMS.php?apikey=XXX(censurée)HTTP/1.1" 200 0
[2018-05-16 22:20:09][DEBUG] : LoopNetServer Thread stopped
[2018-05-16 22:20:09][DEBUG] : Exit 0

leon-99
Timide
Messages : 233
Inscription : 09 févr. 2016, 18:34
Localisation : Limoges (ou presque)

Re: Plugin SMS

Message par leon-99 » 18 mai 2018, 15:58

Bonjour a tous
Juste un retour d'expérience sur le plugin SMS. Depuis bientôt 2 ans que je l'utilise avec des hauts et des bas comme beaucoup de monde au vu du forum.
Depuis 2 mois il ne fonctionnait plus qu'à mi-temps et j'ai eu l'idée de rajouter +33 devant mon 06. ...et miracle. .plus aucun problème. .pourvu que ça dure.
Bonne journée

Envoyé de mon SM-G903F en utilisant Tapatalk


xav_38
Timide
Messages : 462
Inscription : 13 avr. 2016, 20:45
Localisation : Grenoble

Re: Plugin SMS

Message par xav_38 » 18 mai 2018, 19:20

merci, c'est déjà le cas chez moi

Répondre

Revenir vers « [Plugin Officiel] SMS »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité