Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

Plugin SMS

Avatar de l’utilisateur
loic
Administrateur
Messages : 14365
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 13 août 2019, 08:42

Tu es sur sur le port est le bon ? C'est bien le 1?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Titof2375
Helper
Messages : 645
Inscription : 22 août 2017, 18:59

Re: Plugin SMS

Message par Titof2375 » 13 août 2019, 11:35

Moi ca venait de mon installation debian que j avais installé, j ai refait une installation toute neuve et ca a fonctionne de nouveau
Rpi 3 avec jeedom
Plugins zwave, Plugins volets, Plugins rflinq, Plugins blea,Plugin

wasah84
Timide
Messages : 16
Inscription : 19 juil. 2017, 22:38

Re: Plugin SMS

Message par wasah84 » 13 août 2019, 17:42

@loic : port SMS sur le USB 1 (les autres me mettent bien une erreur que ce n'est pas le bon port). Pour le port Web Socket c'est le 55002.

toineduke
Timide
Messages : 1
Inscription : 21 août 2019, 22:49

Re: Plugin SMS

Message par toineduke » 21 août 2019, 22:55

Bonjour a tous ,
j'ai un petit soucis avec le plugin il ne reçoit pas les SMS que je lui envoie, par contre j'arrive a en envoyer du plugin

dans le log de debug il y a une erreur qui revient en permanence mais je n'ai pas trouver d'ou ça vient :/

pour info j'ai une clef huawei 3531

[2019-08-21 22:49:43][DEBUG] : write: AT+CSQ
[2019-08-21 22:49:43][DEBUG] : response: ['+CSQ: 20,99', 'OK']
[2019-08-21 22:50:13][DEBUG] : write: AT+CREG?
[2019-08-21 22:50:13][DEBUG] : response: ['+CREG: 2,1,"051A","00DB1352"', 'OK']
[2019-08-21 22:50:13][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-08-21 22:50:14][DEBUG] : write: AT+CSQ
[2019-08-21 22:50:14][DEBUG] : response: ['+CSQ: 20,99', 'OK']
[2019-08-21 22:50:14][DEBUG] : write: AT+CMGL=0
[2019-08-21 22:50:14][DEBUG] : response: ['OK']
[2019-08-21 22:50:14][DEBUG] : write: AT+CSQ
[2019-08-21 22:50:14][DEBUG] : response: ['+CSQ: 20,99', 'OK']
[2019-08-21 22:50:44][DEBUG] : write: AT+CREG?
[2019-08-21 22:50:44][DEBUG] : response: ['+CREG: 2,1,"051A","00DB1352"', 'OK']
[2019-08-21 22:50:44][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-08-21 22:50:45][DEBUG] : write: AT+CSQ
[2019-08-21 22:50:45][DEBUG] : response: ['+CSQ: 20,99', 'OK']


si jamais quelqu'un a une idee :D

Merci d' avance :D

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1337
Inscription : 20 oct. 2015, 17:32

Re: Plugin SMS

Message par Jeandhom » 22 août 2019, 10:08

https://m2msupport.net/m2msupport/atcre ... istration/

La réponse "2" : 2 not registered, but MT is currently searching a new operator to register to
La réponse "1" : 1 GSM Compact

Tartanpion
Timide
Messages : 88
Inscription : 09 nov. 2014, 16:54

Re: Plugin SMS

Message par Tartanpion » 23 août 2019, 01:22

Bonsoir,

J'avais un signal très stable et donc un plugin avec peu de logs d'erreur auparavant.
Par contre, depuis les dernières mises à jour (faites depuis le 15 août environ) le signal a chuté drastiquement et je me retrouve avec des tas d'erreurs, de redémarrages etc...
Je regrette d'avoir fait la mise à jour du coup :(

znation
Actif
Messages : 1931
Inscription : 12 nov. 2014, 15:48

Re: Plugin SMS

Message par znation » 23 août 2019, 08:00

L'histoire du signal ça doit être un effet placebo le plugin ne peut en aucun cas agit sur la qualité de réception du signal.

Perso tout est ok.

Envoyé de mon Mi A2 en utilisant Tapatalk

JEEDOM v3.3.31 - NUC Z83 II

znation
Actif
Messages : 1931
Inscription : 12 nov. 2014, 15:48

Re: Plugin SMS

Message par znation » 23 août 2019, 08:00

L'histoire du signal ça doit être un effet placebo le plugin ne peut en aucun cas agit sur la qualité de réception du signal.

Perso tout est ok.

Envoyé de mon Mi A2 en utilisant Tapatalk

JEEDOM v3.3.31 - NUC Z83 II

Tartanpion
Timide
Messages : 88
Inscription : 09 nov. 2014, 16:54

Re: Plugin SMS

Message par Tartanpion » 23 août 2019, 23:18

N'empêche, au niveau des dates, ça concorde...
Avant mise à jour, signal stable, depuis des tas de combinaisons de ces 3 lignes toute la journée :
[2019-08-23 22:13:38][ERROR] : Exception on GSM :
[2019-08-23 22:25:16][ERROR] : Exception on GSM : Device not searching for network operator
[2019-08-23 22:25:16][ERROR] : Exit 1 because this exeption is fatal

znation
Actif
Messages : 1931
Inscription : 12 nov. 2014, 15:48

Re: Plugin SMS

Message par znation » 24 août 2019, 03:07

Déconnecte ta clé 5 min.

Envoyé de mon Mi A2 en utilisant Tapatalk

JEEDOM v3.3.31 - NUC Z83 II

Avatar de l’utilisateur
loic
Administrateur
Messages : 14365
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 24 août 2019, 08:41

Tartanpion a écrit :
23 août 2019, 23:18
N'empêche, au niveau des dates, ça concorde...
Avant mise à jour, signal stable, depuis des tas de combinaisons de ces 3 lignes toute la journée :
[2019-08-23 22:13:38][ERROR] : Exception on GSM :
[2019-08-23 22:25:16][ERROR] : Exception on GSM : Device not searching for network operator
[2019-08-23 22:25:16][ERROR] : Exit 1 because this exeption is fatal
La mise a jour du plugin change juste un object en jeeObject sur la page d'équipement pour etre compatible 7.3. Tu penses que c'est la maj car elle redemarre le demon et donc reconnecte la clef sur le réseaux opérateur. Qu'as tu comme forfait ? A mon avis il faut que tu mette la carte sim dans un téléphone, la fasse se deplacer pour qu'elle change d'antenne relais puis la remette dans le téléphone (beaucoup d'opérateur bloque la carte sim a la reconnexion si elle ne change pas d'antenne relais)
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

znation
Actif
Messages : 1931
Inscription : 12 nov. 2014, 15:48

Re: Plugin SMS

Message par znation » 24 août 2019, 09:00

Ou juste déconnecter la clé 3g lol

Envoyé de mon Mi A2 en utilisant Tapatalk

JEEDOM v3.3.31 - NUC Z83 II

Tartanpion
Timide
Messages : 88
Inscription : 09 nov. 2014, 16:54

Re: Plugin SMS

Message par Tartanpion » 25 août 2019, 13:43

Merci pour vos retours.
J'ai tenté une déconnexion de 15min de la clé. Si ça ne change pas, j'irai "promener" la carte SIM dans un portable comme conseillé.
Je vous tiendrai au courant du résultat.

Tartanpion
Timide
Messages : 88
Inscription : 09 nov. 2014, 16:54

Re: Plugin SMS

Message par Tartanpion » 26 août 2019, 20:09

Bon j'ai promené ma carte SIM dans un téléphone aujourd'hui.
J'ai même envoyé un SMS, avec une super qualité de réception.

De retour chez moi, je la remets et hop rebelote... mauvaise qualité.

Je regarde le site d'Orange pour vérifier l'état du réseau mobile, je tape mon adresse et :
2G : Une intervention de nos techniciens est en cours. Le rétablissement du service est prévu le 31/08/2019 matin
3G : Une intervention de nos techniciens est en cours. Le rétablissement du service est prévu le 28/08/2019 matin
4G : Une intervention de nos techniciens est en cours. Le rétablissement du service est prévu le 28/08/2019 matin

Bref; désolé de vous avoir dérangés pour rien... :(

Tartanpion
Timide
Messages : 88
Inscription : 09 nov. 2014, 16:54

Re: Plugin SMS

Message par Tartanpion » 26 août 2019, 20:48

-101dbm 6asu sur mon smartphone, l'antenne qui me couvrait auparavant doit être morte...

Yoyo1111
Timide
Messages : 1
Inscription : 27 nov. 2018, 21:58

Re: Plugin SMS

Message par Yoyo1111 » 29 août 2019, 19:26

Bonjour,
ci dessous mes logs en mode "debug" ...

"[2019-08-29 17:19:36][INFO] : Start smsd
[2019-08-29 17:19:36][INFO] : Log level : debug
[2019-08-29 17:19:36][INFO] : Socket port : 55002
[2019-08-29 17:19:36][INFO] : Socket host : 127.0.0.1
[2019-08-29 17:19:36][INFO] : PID file : /tmp/jeedom/sms/deamon.pid
[2019-08-29 17:19:36][INFO] : Device : /dev/ttyUSB1
[2019-08-29 17:19:36][INFO] : Apikey : xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[2019-08-29 17:19:36][INFO] : Callback : http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php
[2019-08-29 17:19:36][INFO] : Cycle : 30.0
[2019-08-29 17:19:36][INFO] : Serial rate : 9600
[2019-08-29 17:19:36][INFO] : Pin : xxxx
[2019-08-29 17:19:36][INFO] : Text mode : yes
[2019-08-29 17:19:36][INFO] : SMSC : None
[2019-08-29 17:19:36][DEBUG] : Writing PID 25906 to /tmp/jeedom/sms/deamon.pid
[2019-08-29 17:19:36][DEBUG] : Init request module v2.21.0
[2019-08-29 17:19:36][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2019-08-29 17:19:36][DEBUG] : http://127.0.0.1:80 "GET /plugins/sms/core/php/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[2019-08-29 17:19:36][DEBUG] : Socket interface started
[2019-08-29 17:19:36][DEBUG] : LoopNetServer Thread started
[2019-08-29 17:19:36][DEBUG] : Start listening...
[2019-08-29 17:19:36][DEBUG] : Listening on: [127.0.0.1:55002]
[2019-08-29 17:19:36][DEBUG] : Connecting to GSM Modem...
[2019-08-29 17:19:36][DEBUG] : Text mode true
[2019-08-29 17:19:36][DEBUG] : Enter pin code : xxxx
[2019-08-29 17:19:36][INFO] : Connecting to modem on port /dev/ttyUSB1 at 9600bps
[2019-08-29 17:19:36][DEBUG] : write: ATZ
[2019-08-29 17:19:41][ERROR] : Exception: None
[2019-08-29 17:19:41][ERROR] : Exit 1 because this exeption is fatal
[2019-08-29 17:19:41][DEBUG] : Shutdown
[2019-08-29 17:19:41][DEBUG] : Removing PID file /tmp/jeedom/sms/deamon.pid
[2019-08-29 17:19:41][DEBUG] : Send to jeedom : {'message': 'None', 'number': 'none'}
[2019-08-29 17:19:41][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2019-08-29 17:19:41][DEBUG] : http://127.0.0.1:80 "POST /plugins/sms/core/php/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
HTTP/1.1" 200 0
[2019-08-29 17:19:41][DEBUG] : LoopNetServer Thread stopped
[2019-08-29 17:19:41][DEBUG] : Exit 0
[2019-08-29 19:20:03][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-08-29 19:19:34"

Le demon ne tient pas et fonction sms NOK. Cela a marché environ 1Mois et il ne me semble pas avoir modifié quoi que ce soit...??
J'ai lu que ce n'était pas bon d'avoir localhost à 127.0.0.1 mais je n'arrive pas a modifier cela dans les configuration réseau, comme c'est demandé dans le l'"help" du plugin.
merci pour votre retour d'expérience.

Okimi
Timide
Messages : 93
Inscription : 09 févr. 2015, 13:20

Re: Plugin SMS

Message par Okimi » 31 août 2019, 08:19

Okimi a écrit :
09 août 2019, 21:07
Bonjour

J'ai installé Jeedom v3.3.29 stable sur une TV Box S905 (Tanix TX3 mini) flashée en Linux et je rencontre un problème de réception des SMS avec une clé Huawei E220.
L'envoi de SMS avec le plugin SMS fonctionne bien mais je ne réceptionne aucun SMS.
Pour le coup les interactions ne fonctionnent pas.
J'ai essayé cette clé sur ma VM Jeedom et aucun souci en émission et réception.

Il doit y avoir une restriction quelconque au niveau de ma TV box mais je ne vois pas quoi.
J'ai donné les droits 777 aux 3 ports ttyUSB affectés à la clé.

Y a-t-il des droits spécifiques à donner à un dossier ou à un script pour la réception des SMS ?

Merci pour votre aide

Bonjour

J'ai refait des tests (réinstallation des dépendances du plugin SMS, vérification de la bonne réception des SMS quand la carte SIM est placée dans un Smartphone, mise à jour d'Armbian et de Jeedom+Plugins) mais j'en suis toujours au même point.

Je peux envoyer des SMS mais pas en recevoir.
Pour le coup je ne peux toujours pas utiliser les interactions.

Help :cry:
Jeedom v3.3.29 stable sur VM Debian 9 avec interfaçage Veralite (v1.5.622 fr), IPX800v4 (v4.00.35), IPX800v3 (v3.05.62), Teracom TCW180b, Serveur WES (v0.75G), Karotz.

Overcrash
Timide
Messages : 56
Inscription : 03 févr. 2015, 12:11

Re: Plugin SMS

Message par Overcrash » 03 sept. 2019, 13:08

Bonjour,

Eernièrement le plugin ne fonctionnait plus chez moi.
An cherchant un peu, il semblerait qu'il n'utilise pas l'adresse interne du paramétrage pour attaquer son API mais 127.0.0.1.
Dans certains cas, comme le mien où j'ai des vhosts avec des entrées DNS distinguées en fonction du besoin, dont l'URL interne, ça ne fonctionne plus.

Dans le fichier "sms.class.php" il est bien fait mention du 127.0.0.1 :

Ligne 85 :
$cmd .= ' --callback ' . network::getNetworkAccess('internal', 'proto:127.0.0.1:port:comp') . '/plugins/sms/core/php/jeeSMS.php';

Ligne 238 :
socket_connect($socket, '127.0.0.1', config::byKey('socketport', 'sms'));

En remplaçant 127.0.0.1 par mon entrée DNS interne le démon redémarre correctement, mais ce n'est pas une solution durable.
Est-ce possible de remédier à ce détail directement dans le plugin ?

Avatar de l’utilisateur
loic
Administrateur
Messages : 14365
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 03 sept. 2019, 14:07

Bonjour,
Non ce n'est pas prévu désolé, le plugin est fait pour communiquer avec jeedom sur l'adresse 127.0.0.1 (pour info c'est le cas de quasiment tous les plugins avec un demon)
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

bertrandF
Timide
Messages : 63
Inscription : 23 déc. 2015, 14:50

Re: Plugin SMS

Message par bertrandF » 12 sept. 2019, 09:13

Bonjour,

J'utilise le plugin SMS depuis déjà quelques années et tout était globalement stable.
J'utilise une clé HUAWEI E220.

Je suis sur Smart et je suis passé de Jessie à Stretch la semaine dernière.

Depuis, le plugin SMS ne fonctionne plus :(
J'ai réinstallé les dépendances, réinstallé le plugin, débranché la clé, changé de port USB, joué avec les paramètres, ... rien n'y fait.

Voici les erreurs que j'obtiens dans les logs (je n'avais jamais eu ce genre de logs auparavant) :
(et vu la tête de l'erreur, difficile de faire des recherche Google)

Code : Tout sélectionner

[2019-09-12 07:04:13][ERROR] : Exception on GSM : ['> ']
[2019-09-12 07:04:48][ERROR] : Exception on GSM : ['> ']
[2019-09-12 07:05:23][ERROR] : Exception on GSM : ['> ']
[2019-09-12 07:05:58][ERROR] : Exception on GSM : ['> ']
[2019-09-12 07:07:08][ERROR] : Exception: None
[2019-09-12 07:07:08][ERROR] : Exit 1 because this exeption is fatal
[2019-09-12 07:10:10][ERROR] : Exception: None
[2019-09-12 07:10:10][ERROR] : Exit 1 because this exeption is fatal
Une idée d'où pourrait venir le problème ?
Merci d'avance.

EDIT : A force de débrancher/rebrancher la clé, le démon a fini par se lancer.
J'avais ensuite l'erreur : "[ERROR] : unicode strings are not supported, please encode to bytes"
En désactivant le "Texte mode" (cf. viewtopic.php?t=126&start=1980#p531307) ca refonctionne ! (à voir pour combien de temps)
Jeedom Smart (ZWave+ / RFXCOM / Teleinfo / BLEA / Zigate) / NAS Synology

Répondre

Revenir vers « [Plugin Officiel] SMS »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité