Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Sujet officiel] Plugin sonos

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 11 oct. 2019, 08:57

A ben mince en faite il le donne pas... Dans ce cas faut installer le plugin, faire une decouverte en debug et me fournir la log
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

scossf
Timide
Messages : 7
Inscription : 27 sept. 2018, 01:00

Re: [Sujet officiel] Plugin sonos

Message par scossf » 11 oct. 2019, 09:22

Hello
J'ai retiré le screen shot qui prenait de la place :)
Et voici la log si je ne me suis pas trompé dans la manip
Du coup pour rappel, le Port est sur le .71 en ip fixe
et je ne le trouve pas dans les logs
Pièces jointes
sonos3(1).log
(359.19 Kio) Téléchargé 9 fois

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 11 oct. 2019, 10:06

Ya toujours pas les infos que je veux, autre methode aller sur :
http://IP_SONOS:1400/xml/device_description.xml

Et m'envoyer le resultat.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

scossf
Timide
Messages : 7
Inscription : 27 sept. 2018, 01:00

Re: [Sujet officiel] Plugin sonos

Message par scossf » 11 oct. 2019, 10:51

Super,
apparemment j'ai l'info, c'est le S23
Pièces jointes
WhatsApp Image 2019-10-11 at 10.48.45.jpeg
WhatsApp Image 2019-10-11 at 10.48.45.jpeg (383.52 Kio) Consulté 266 fois

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 11 oct. 2019, 10:59

Merci je viens de faire l'ajout dans la beta du plugin
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

scossf
Timide
Messages : 7
Inscription : 27 sept. 2018, 01:00

Re: [Sujet officiel] Plugin sonos

Message par scossf » 11 oct. 2019, 11:07

super, merci

victonic
Timide
Messages : 12
Inscription : 21 sept. 2019, 22:01

Re: [Sujet officiel] Plugin sonos

Message par victonic » 18 oct. 2019, 19:05

loic a écrit :
05 oct. 2019, 09:43
Bonjour,
C'est qu'il doit manquait picotts sur ta machine. Si tu l'installer tout devrait rentrer dans l'ordre
Bonjour Loic

Je confirme que j’ai bien pico TTS (sous debian 9) car j’ai fait un test depuis le terminal de Debian en utilisant la commande pico2wave et j’ai bien généré un fichier son qui fonctionne.
(Par contre je n’ai pas pu le faire en mp3 je ne connais pas la commande).
Donc je ne pense pas que ca vienne de ca...
Tu as une autre idée pourquoi le fichier xxxxx.mp3 fait 0ko ?
Merci de ton aide
Machine : Jeedom sous Virtual Machin / Debian 9 / NUC
Dongles : RFXcom / Z-WAVE / Tahoma
Modules : Fibaro, Blyss (du temps de la blyssbox...pfff), RTS, io

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 18 oct. 2019, 19:06

Non désolé la pas d'autre idée
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Atlas
Timide
Messages : 5
Inscription : 02 sept. 2019, 15:09
Localisation : 92

Re: [Sujet officiel] Plugin sonos

Message par Atlas » 18 oct. 2019, 23:07

kgaudin a écrit :
16 sept. 2019, 11:57
Pour ceux qui sont embêtés par les textes blanc sur blanc sur le widget depuis que des modifications ont été réalisées en vue de Jeedom v4, voilà de quoi rendre les choses lisibles dans la "Personnalisation avancée / CSS" :

Code : Tout sélectionner

span.playFavourite, span.playPlaylist, .speakersList span.cursor {
  color: grey;
}
(au moins ce n'est pas écrasé par les updates du plugin)
Top comme solution par contre il me manque les radios peux tu nous faire un update avec ?

mortyre
Actif
Messages : 1241
Inscription : 17 mai 2016, 16:51

Re: [Sujet officiel] Plugin sonos

Message par mortyre » 19 oct. 2019, 10:49

Bonjour, la question a surement déjà été abordé mais je n'ai pas réussi à trouver la réponse (dans la doc et par recherche), alors je me permet de la poser ici pour une âme charitable me réponde.

Est ce que avec le plugin Sonos, si une musique est en cours de lecture (lancé avec l'app sonos ou avec le plugin) et qu'on lance un TTS, est ce que la musique reprendra après l'annonce TTS ? Merci d'avance
PROD: NAS1815+ VMM Buster 10.1 / Jeedom 4.0.23 / MariaDB 10.3.17 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: [Sujet officiel] Plugin sonos

Message par i-magin » 19 oct. 2019, 13:02

Bonjour @mortyre

Voir sur le nouveau forum https://community.jeedom.com/t/plugin-s ... 754/3188/7

La version beta corrige le problème de reprise de lecture après TTS .... j’espère qu’une stable sortira prochainement car je ne peux plus ouvrir de ticket avec un plugin en bêta ;)
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

mortyre
Actif
Messages : 1241
Inscription : 17 mai 2016, 16:51

Re: [Sujet officiel] Plugin sonos

Message par mortyre » 20 oct. 2019, 12:03

MErci pour ton retour, je t'ai répondu sur le nouveau forum
PROD: NAS1815+ VMM Buster 10.1 / Jeedom 4.0.23 / MariaDB 10.3.17 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

victonic
Timide
Messages : 12
Inscription : 21 sept. 2019, 22:01

Re: [Sujet officiel] Plugin sonos

Message par victonic » 18 nov. 2019, 20:39

victonic a écrit :
18 oct. 2019, 19:05
loic a écrit :
05 oct. 2019, 09:43
Bonjour,
C'est qu'il doit manquait picotts sur ta machine. Si tu l'installer tout devrait rentrer dans l'ordre
Bonjour Loic

Je confirme que j’ai bien pico TTS (sous debian 9) car j’ai fait un test depuis le terminal de Debian en utilisant la commande pico2wave et j’ai bien généré un fichier son qui fonctionne.
(Par contre je n’ai pas pu le faire en mp3 je ne connais pas la commande).
Donc je ne pense pas que ca vienne de ca...
Tu as une autre idée pourquoi le fichier xxxxx.mp3 fait 0ko ?
Merci de ton aide
Problème résolu ! Merci à l'équipe Jeedom pour l'aide. Cela venait de ma configuration réseaux, j'avais mis en local du https sur une ip sans un certificat valide (d'ailleurs il n'est pas possible d'avoir un certificat valide sur une ip).
Depuis tout est ok et je peux faire dire des phrases à ma sonos.
Si ca peut aider quelqu'un ;)
Machine : Jeedom sous Virtual Machin / Debian 9 / NUC
Dongles : RFXcom / Z-WAVE / Tahoma
Modules : Fibaro, Blyss (du temps de la blyssbox...pfff), RTS, io

Répondre

Revenir vers « [Plugin Officiel] Sonos controller »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 9 invités