Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Résolu] Problème lancement daemon

Répondre
b00bs42
Timide
Messages : 2
Inscription : 10 sept. 2017, 11:58

[Résolu] Problème lancement daemon

Message par b00bs42 » 10 sept. 2017, 12:03

Bonjour à tous,

Je rencontre un petit soucis :

J'ai réinstallé un jeedom tout neuf sous raspbian Jessie (RPi 2), et restauré ma sauvegarde. Tout marche sauf le plugin Broadlink dont le daemon ne veut pas démarrer.

J'ai on dirai une erreur de clé API :

Code : Tout sélectionner

[2017-09-10 16:34:02][INFO] : Lancement démon broadlink : sudo /usr/bin/python /var/www/html/plugins/broadlink/resources/broadlinkd/broadlinkd.py --loglevel debug --socketport 55013 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/broadlink/core/php/jeeBroadlink.php --apikey AQ5VjgiCe9iBdt5qyd7pqNdhtPe7O54u --cycle 0.3 --pid /tmp/jeedom/broadlink/deamon.pid
Error: importing module from jeedom folder
Quand j'accède à la page "http://127.0.0.1:80/plugins/broadlink/c ... adlink.php" j'ai ce message qui s'affiche :
Clef API non valide, vous n'etes pas autorisé à effectuer cette action
Quelqu'un aurait-il la solution à mon problème.

Merci d'avance :)
Dernière édition par b00bs42 le 10 sept. 2017, 13:13, édité 1 fois.

b00bs42
Timide
Messages : 2
Inscription : 10 sept. 2017, 11:58

Re: Problème lancement daemon

Message par b00bs42 » 10 sept. 2017, 13:12

Je me réponds à moi même.

Problème réglé en installant le plugin Zwave.

snoopy10800
Timide
Messages : 127
Inscription : 25 mai 2016, 20:57
Localisation : entre Troyes et Quimper...

Re: [Résolu] Problème lancement daemon

Message par snoopy10800 » 10 sept. 2017, 13:50

Bonjour

Tu viens de m'enlever une belle épine du pied.
Ça fait plusieurs jours que je galerais avec exactement le même problème sans en comprendre l'origine.

J'ai essayé pas mal de choses, sans succès

Je viens de réinstaller mon plugin zwave, et effectivement le demon du broadlink se lance sans problème.
Je ne comprends pas trop le pourquoi du comment, mais ça marche !

MERCI !!!!

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 14 janv. 2018, 00:06

bonjour.

a tu activer ton plugin zwave?
je n'ai pas de clef zwave et je ne conte pas en acheter. si quelqu'un a une autre solution je suis preneur.

merci

snoopy10800
Timide
Messages : 127
Inscription : 25 mai 2016, 20:57
Localisation : entre Troyes et Quimper...

Re: [Résolu] Problème lancement daemon

Message par snoopy10800 » 14 janv. 2018, 10:54

Chez moi, le plugin est installé mais désactivé. Ca a suffit pour que le daemon de Broadlink se lance...

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 14 janv. 2018, 10:59

Mince ça n'a pas résolu mon problème.
Quelqu'un a une autre idée?

Bosquetia
Actif
Messages : 5951
Inscription : 10 mai 2016, 07:54

Re: [Résolu] Problème lancement daemon

Message par Bosquetia » 14 janv. 2018, 11:02

jemreyctr a écrit :
14 janv. 2018, 10:59
Mince ça n'a pas résolu mon problème.
Quelqu'un a une autre idée?
As-tu essayé de ré installer le plugin en mode forcé avec la dernière version ?

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 14 janv. 2018, 11:36


jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 15 janv. 2018, 07:59

Est ce la bonne version? Et ou la bonne manière de faire?

yala37
Timide
Messages : 25
Inscription : 15 juil. 2016, 10:32

Re: [Résolu] Problème lancement daemon

Message par yala37 » 15 janv. 2018, 12:19

Bonjour,

Quelqu'un a t'il une solution plus viable que l'installation d'un autre plugin (Zwave en l’occurrence) pour faire démarrer ce plugin Broadlink?

(peut être une autre dépendance manquante que celles installées par défaut avec le plugin?)

merci d'avance,

Yann

Avatar de l’utilisateur
magicgg91
Actif
Messages : 10085
Inscription : 09 août 2014, 12:15
Localisation : Région Parisienne
Contact :

Re: [Résolu] Problème lancement daemon

Message par magicgg91 » 15 janv. 2018, 12:25

Les dépendances ont été corrigées et ajoutées au plugin.

N’as-tu pas une maj du plugin proposée ? Tente de la faire quand même.
Et relance les dépendances ensuite.

Et il faut la log en debug pour qu’on puisse t’aider.
DomoPi - Mon site dédié au Raspberry Pi et à la domotique

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 15 janv. 2018, 16:29

voila ce que j'ai. Je n'ai pas de maj a faire et quand je fait reinstaller ca fait rien de plus.
je ne vois pas de maj pour les depandances


http://zupimages.net/viewer.php?id=18/03/amce.png
http://zupimages.net/viewer.php?id=18/03/ahnn.png
http://zupimages.net/viewer.php?id=18/03/de3x.png

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 15 janv. 2018, 19:52

désoler double post mais c'est pour signaler que j'ai trouver le log débug...

Image


Error: importing module from jeedom folder
[2018-01-27 00:25:34][ERROR] : Impossible de lancer le démon broadlink, vérifiez la log
[2018-01-27 00:30:04][INFO] : Lancement démon broadlink : sudo /usr/bin/python /var/www/html/plugins/broadlink/resources/broadlinkd/broadlinkd.py --loglevel debug --socketport 55013 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/broadlink/c ... adlink.php --apikey vLvKvAsynjG2O4fuHnbUAAhQBuxnjnCx --cycle 0.3 --pid /tmp/jeedom/broadlink/deamon.pid
Error: importing module from jeedom folder
Dernière édition par jemreyctr le 27 janv. 2018, 14:22, édité 1 fois.

jemreyctr
Timide
Messages : 24
Inscription : 09 janv. 2018, 21:21
Localisation : lezignan corbieres
Contact :

Re: [Résolu] Problème lancement daemon

Message par jemreyctr » 17 janv. 2018, 20:46

bonsoir,
comme on m'a appris : quand tu a un doute formate ;) ;) jai suivi ce tuto pour l'installation du raspberry j'ai suivi ce tuto http://sarakha63-domotique.fr/jeedom-in ... rettyPhoto
J'ai eue un message d'erreur a cette étape : apt-get install python-requests

pi@raspberrypi:~ $ apt-get install python-requests
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

je ne sait pas comment faire. car le demon ne demare toujours pas.

Répondre

Revenir vers « [Plugin Officiel] Broadlink »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité