Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin XIAOMI Daemon NOK

Jez
Timide
Messages : 95
Inscription : 03 mai 2016, 13:12
Localisation : Nancy

Re: Plugin XIAOMI Daemon NOK

Message par Jez » 30 janv. 2019, 18:03

Merci pour cette astuce qui a fonctionné pour moi aussi. Cependant, le plugin me recréé tous les devices et ils ne sont plus identifiés par pièce. J'en ai une vingtaine sur 2 gateway. Comment puis je les identifier à nouveau ?

Jez
Timide
Messages : 95
Inscription : 03 mai 2016, 13:12
Localisation : Nancy

Re: Plugin XIAOMI Daemon NOK

Message par Jez » 31 janv. 2019, 12:31

Je cherchais une solution pratique. J'ai finalement recréé tous mes équipements, ce qui m'a obligé à recréer également toutes les commandes où ils étaient associés. Un peu galère mais bon, ça fonctionne.

Avatar de l’utilisateur
manuc0
Timide
Messages : 88
Inscription : 08 mars 2017, 09:36
Localisation : Belgique

Re: Plugin XIAOMI Daemon NOK

Message par manuc0 » 31 janv. 2019, 22:39

Associe des virtuels dans tes commandes cela évitera de devoir les recréer en cas de problèmes
;)

Jez
Timide
Messages : 95
Inscription : 03 mai 2016, 13:12
Localisation : Nancy

Re: Plugin XIAOMI Daemon NOK

Message par Jez » 02 févr. 2019, 09:34

Merci pour cette astuce.

OliV IeR
Timide
Messages : 2
Inscription : 28 févr. 2019, 21:03

Re: Plugin XIAOMI Daemon NOK

Message par OliV IeR » 28 févr. 2019, 21:14

Bonjour a tous,

Je rencontre le même problème avec le pluging Xiaomi.
Les dépendances sont installées correctement, cependant le demon ne démarre pas correctement.

Ci dessous le log lors d'une tentative de démarrage:

[2019-02-28 21:05:05][INFO] : Lancement démon xiaomihome : /usr/bin/python /var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py --loglevel debug --socketport 55019 --callback https://127.0.0.1:443/plugins/xiaomihom ... miHome.php --apikey xxxxxxxxxxxxxxxxxxxxx--cycle 0.05 --pid /tmp/jeedom/xiaomihome/deamon.pid
Traceback (most recent call last):
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 26, in <module>
import globals
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/globals.py", line 3, in <module>
from devices.yeelight.flow import *
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/__init__.py", line 5, in <module>
from .main import Bulb, BulbType, BulbException, discover_bulbs
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/main.py", line 9, in <module>
from future.utils import raise_from
ImportError: No module named future.utils
[2019-02-28 21:05:35][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.


J'ai tenté de désinstallé complètement le plugin, de faire les mise à jour et de le reinstaller. J'ai toujours le même problème, :oops:

Je suis preneur de toutes vos idée. :(

Avatar de l’utilisateur
manuc0
Timide
Messages : 88
Inscription : 08 mars 2017, 09:36
Localisation : Belgique

Re: Plugin XIAOMI Daemon NOK

Message par manuc0 » 28 févr. 2019, 23:27

OliV IeR a écrit :
28 févr. 2019, 21:14
Bonjour a tous,

Je rencontre le même problème avec le pluging Xiaomi.
Les dépendances sont installées correctement, cependant le demon ne démarre pas correctement.

Ci dessous le log lors d'une tentative de démarrage:

[2019-02-28 21:05:05][INFO] : Lancement démon xiaomihome : /usr/bin/python /var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py --loglevel debug --socketport 55019 --callback https://127.0.0.1:443/plugins/xiaomihom ... miHome.php --apikey xxxxxxxxxxxxxxxxxxxxx--cycle 0.05 --pid /tmp/jeedom/xiaomihome/deamon.pid
Traceback (most recent call last):
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 26, in <module>
import globals
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/globals.py", line 3, in <module>
from devices.yeelight.flow import *
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/__init__.py", line 5, in <module>
from .main import Bulb, BulbType, BulbException, discover_bulbs
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/main.py", line 9, in <module>
from future.utils import raise_from
ImportError: No module named future.utils
[2019-02-28 21:05:35][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.


J'ai tenté de désinstallé complètement le plugin, de faire les mise à jour et de le reinstaller. J'ai toujours le même problème, :oops:

Je suis preneur de toutes vos idée. :(
As tu appliqué viewtopic.php?p=702965&sid=ab3ea90f0809 ... ec#p677936 et autres dans ce post ? ?

OliV IeR
Timide
Messages : 2
Inscription : 28 févr. 2019, 21:03

Re: Plugin XIAOMI Daemon NOK

Message par OliV IeR » 01 mars 2019, 19:56

manuc0 a écrit :
28 févr. 2019, 23:27
OliV IeR a écrit :
28 févr. 2019, 21:14
Bonjour a tous,

Je rencontre le même problème avec le pluging Xiaomi.
Les dépendances sont installées correctement, cependant le demon ne démarre pas correctement.

Ci dessous le log lors d'une tentative de démarrage:

[2019-02-28 21:05:05][INFO] : Lancement démon xiaomihome : /usr/bin/python /var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py --loglevel debug --socketport 55019 --callback https://127.0.0.1:443/plugins/xiaomihom ... miHome.php --apikey xxxxxxxxxxxxxxxxxxxxx--cycle 0.05 --pid /tmp/jeedom/xiaomihome/deamon.pid
Traceback (most recent call last):
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 26, in <module>
import globals
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/globals.py", line 3, in <module>
from devices.yeelight.flow import *
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/__init__.py", line 5, in <module>
from .main import Bulb, BulbType, BulbException, discover_bulbs
File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/main.py", line 9, in <module>
from future.utils import raise_from
ImportError: No module named future.utils
[2019-02-28 21:05:35][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.


J'ai tenté de désinstallé complètement le plugin, de faire les mise à jour et de le reinstaller. J'ai toujours le même problème, :oops:

Je suis preneur de toutes vos idée. :(
As tu appliqué viewtopic.php?p=702965&sid=ab3ea90f0809 ... ec#p677936 et autres dans ce post ? ?

Hello,

Oui j'ai bien lu le topic au complet, j'ai bien vérifié la partie réseau et remis à jour mon certificat pour la partie SSL.
J'ai réactiver l’accès local en http, redémarré mon rapsberry et force les mises à jour.

Et toujours le même soucis .... De quoi devenir fou ... :oops: :roll:

cyber_co
Timide
Messages : 10
Inscription : 25 nov. 2018, 10:25

Re: Plugin XIAOMI Daemon NOK

Message par cyber_co » 14 mars 2019, 19:52

Même problème que olivier
Dernière édition par cyber_co le 17 mars 2019, 17:03, édité 1 fois.

cyber_co
Timide
Messages : 10
Inscription : 25 nov. 2018, 10:25

Re: Plugin XIAOMI Daemon NOK

Message par cyber_co » 16 mars 2019, 17:47

problème résolu avec la commande (raspberry pi, ssh) :
sudo easy_install future

Gaël M
Timide
Messages : 16
Inscription : 16 janv. 2018, 17:21

Re: Plugin XIAOMI Daemon NOK

Message par Gaël M » 24 mars 2019, 14:00

Bonjour.
J'ai une jeedom smart.
Un PC sous window 10.
Une freebox revolution.
J'ai essayé les méthodes si dessus en ayant activé le mode développeur.
Les lignes en SSH avec le unbuntu on windows executer en mode administrateur.
et pour les logs jai ça :

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Hit http://repo.jeedom.com stable InRelease
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://ftp.debian.org jessie-backports InRelease
Hit http://security.debian.org jessie/updates InRelease
Hit http://ftp.debian.org jessie-proposed-updates InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://ftp.debian.org jessie Release
Hit http://repo.jeedom.com stable/main arm64 Packages
Ign http://repo.jeedom.com stable/main Translation-en
Hit http://ftp.debian.org jessie-updates/contrib Sources
Get:1 http://ftp.debian.org jessie-updates/main arm64 Packages/DiffIndex [11.8 kB]
Hit http://ftp.debian.org jessie-updates/contrib arm64 Packages
Get:2 http://ftp.debian.org jessie-updates/non-free arm64 Packages/DiffIndex [736 B]
Get:3 http://security.debian.org jessie/updates/main Sources [297 kB]
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Get:4 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Get:5 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Hit http://oph.mdrjr.net all InRelease
Hit http://ftp.debian.org jessie-updates/main Sources
Get:6 http://security.debian.org jessie/updates/non-free Sources [1627 B]
Get:7 http://ftp.debian.org jessie-backports/main Sources/DiffIndex [736 B]
Hit http://security.debian.org jessie/updates/contrib Sources
Hit http://oph.mdrjr.net jessie InRelease
Get:8 http://ftp.debian.org jessie-backports/contrib Sources/DiffIndex [736 B]
Get:9 http://ftp.debian.org jessie-backports/non-free Sources/DiffIndex [736 B]
Get:10 http://oph.mdrjr.net all/c2 arm64 Packages
Get:11 http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex [736 B]
Get:12 http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex [736 B]
Get:13 http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex [736 B]
Get:14 http://oph.mdrjr.net all/main arm64 Packages
Get:15 http://ftp.debian.org jessie-backports/contrib Translation-en/DiffIndex [736 B]
Get:16 http://ftp.debian.org jessie-backports/main Translation-en/DiffIndex [736 B]
Hit http://oph.mdrjr.net all/c2 arm64 Packages
Get:17 http://ftp.debian.org jessie-backports/non-free Translation-en/DiffIndex [736 B]
Hit http://ftp.debian.org jessie-updates/non-free Sources
Get:18 http://oph.mdrjr.net all/testing arm64 Packages
Get:19 http://ftp.debian.org jessie-proposed-updates/contrib Sources/DiffIndex [7762 B]
Get:20 http://ftp.debian.org jessie-proposed-updates/non-free Sources/DiffIndex [18.0 kB]
Get:21 http://ftp.debian.org jessie-proposed-updates/main Sources/DiffIndex [27.8 kB]
Get:22 http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages/DiffIndex [4948 B]
Get:23 http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages/DiffIndex [8254 B]
Hit http://oph.mdrjr.net all/main arm64 Packages
Get:24 http://ftp.debian.org jessie-proposed-updates/main arm64 Packages/DiffIndex [27.8 kB]
Get:25 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:26 http://ftp.debian.org jessie-proposed-updates/contrib Translation-en/DiffIndex [8392 B]
Get:27 http://ftp.debian.org jessie-proposed-updates/main Translation-en/DiffIndex [27.8 kB]
Get:28 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:29 http://ftp.debian.org jessie-proposed-updates/non-free Translation-en/DiffIndex [18.0 kB]
Get:30 http://oph.mdrjr.net all/testing Translation-en [326 B]
Hit http://oph.mdrjr.net all/testing arm64 Packages
Get:31 http://oph.mdrjr.net jessie/backports arm64 Packages
Get:32 http://oph.mdrjr.net jessie/main arm64 Packages
Get:33 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Hit http://ftp.debian.org jessie/main Sources
Hit http://ftp.debian.org jessie/contrib Sources
Get:34 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Hit http://ftp.debian.org jessie/non-free Sources
Hit http://ftp.debian.org jessie/main arm64 Packages
Hit http://ftp.debian.org jessie/contrib arm64 Packages
Get:35 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Hit http://ftp.debian.org jessie/non-free arm64 Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Get:36 http://oph.mdrjr.net all/main Translation-en [323 B]
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Hit http://oph.mdrjr.net jessie/backports arm64 Packages
Get:37 http://oph.mdrjr.net all/testing Translation-en [326 B]
Hit http://oph.mdrjr.net jessie/main arm64 Packages
Get:38 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:39 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:40 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:41 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:42 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:43 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:44 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:45 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:46 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:47 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:48 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:49 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:50 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Ign http://oph.mdrjr.net all/c2 Translation-en
Get:51 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://oph.mdrjr.net all/main Translation-en
Get:52 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://oph.mdrjr.net all/testing Translation-en
Get:53 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en
Get:54 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://oph.mdrjr.net jessie/main Translation-en
Fetched 172 kB in 7s (24.1 kB/s)
W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
python-dev is already the newest version.
python-pip is already the newest version.
The following package was automatically installed and is no longer required:
  linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  libffi6 libssl1.0.0 python-cffi python-ply python-pycparser
Suggested packages:
  python-cryptography-doc python-cryptography-vectors python-ply-doc
Recommended packages:
  libssl-doc
The following NEW packages will be installed:
  libffi-dev python-cffi python-cryptography python-ply python-pycparser
The following packages will be upgraded:
  libffi6 libssl-dev libssl1.0.0
3 upgraded, 5 newly installed, 0 to remove and 131 not upgraded.
Need to get 19.1 kB/2499 kB of archives.
After this operation, 2361 kB of additional disk space will be used.
Err http://ftp.debian.org/debian/ jessie/main libffi6 arm64 3.1-2+deb8u1
  404  Not Found [IP: 2001:67c:2564:a119::148:12 80]
E: Failed to fetch http://ftp.debian.org/debian/pool/main/libf/libffi/libffi6_3.1-2+deb8u1_arm64.deb  404  Not Found [IP: 2001:67c:2564:a119::148:12 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Downloading/unpacking construct
  Running setup.py (path:/tmp/pip-build-A4O6xm/construct/setup.py) egg_info for package construct
    
Installing collected packages: construct
  Running setup.py install for construct
    
Successfully installed construct
Cleaning up...
Downloading/unpacking pyudev
  Running setup.py (path:/tmp/pip-build-G0KKO2/pyudev/setup.py) egg_info for package pyudev
    
    warning: no previously-included files matching '*.py' found under directory 'tests/.hypothesis'
    warning: no files found matching '*.c' under directory 'reproducers'
    warning: no files found matching '*.py' under directory 'reproducers'
Downloading/unpacking six (from pyudev)
  Downloading six-1.12.0-py2.py3-none-any.whl
Installing collected packages: pyudev, six
  Running setup.py install for pyudev
    
    warning: no previously-included files matching '*.py' found under directory 'tests/.hypothesis'
    warning: no files found matching '*.c' under directory 'reproducers'
    warning: no files found matching '*.py' under directory 'reproducers'
Successfully installed pyudev six
Cleaning up...
Downloading/unpacking requests
Downloading/unpacking idna>=2.5,<2.9 (from requests)
Downloading/unpacking urllib3>=1.21.1,<1.25 (from requests)
Downloading/unpacking certifi>=2017.4.17 (from requests)
Downloading/unpacking chardet>=3.0.2,<3.1.0 (from requests)
Installing collected packages: requests, idna, urllib3, certifi, chardet
Successfully installed requests idna urllib3 certifi chardet
Cleaning up...
Downloading/unpacking pyserial
Installing collected packages: pyserial
Successfully installed pyserial
Cleaning up...
Downloading/unpacking future
  Running setup.py (path:/tmp/pip-build-gtizzM/future/setup.py) egg_info for package future
    /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
      warnings.warn(msg)
    
    warning: no files found matching '*.au' under directory 'tests'
    warning: no files found matching '*.gif' under directory 'tests'
    warning: no files found matching '*.txt' under directory 'tests'
Installing collected packages: future
  Running setup.py install for future
    /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
      warnings.warn(msg)
    
    warning: no files found matching '*.au' under directory 'tests'
    warning: no files found matching '*.gif' under directory 'tests'
    warning: no files found matching '*.txt' under directory 'tests'
    Installing pasteurize script to /usr/local/bin
    Installing futurize script to /usr/local/bin
Successfully installed future
Cleaning up...
Downloading/unpacking pycrypto
  Running setup.py (path:/tmp/pip-build-iPefNE/pycrypto/setup.py) egg_info for package pycrypto
    
Installing collected packages: pycrypto
  Running setup.py install for pycrypto
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for __gmpz_init in -lgmp... no
    checking for __gmpz_init in -lmpir... no
    checking whether mpz_powm is declared... no
    checking whether mpz_powm_sec is declared... no
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking for inttypes.h... (cached) yes
    checking limits.h usability... yes
    checking limits.h presence... yes
    checking for limits.h... yes
    checking stddef.h usability... yes
    checking stddef.h presence... yes
    checking for stddef.h... yes
    checking for stdint.h... (cached) yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking wchar.h usability... yes
    checking wchar.h presence... yes
    checking for wchar.h... yes
    checking for inline... inline
    checking for int16_t... yes
    checking for int32_t... yes
    checking for int64_t... yes
    checking for int8_t... yes
    checking for size_t... yes
    checking for uint16_t... yes
    checking for uint32_t... yes
    checking for uint64_t... yes
    checking for uint8_t... yes
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible malloc... yes
    checking for memmove... yes
    checking for memset... yes
    configure: creating ./config.status
    config.status: creating src/config.h
    warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.
    building 'Crypto.Hash._MD2' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/MD2.c -o build/temp.linux-aarch64-2.7/src/MD2.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/MD2.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_MD2.so
    building 'Crypto.Hash._MD4' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/MD4.c -o build/temp.linux-aarch64-2.7/src/MD4.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/MD4.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_MD4.so
    building 'Crypto.Hash._SHA256' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/SHA256.c -o build/temp.linux-aarch64-2.7/src/SHA256.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/SHA256.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_SHA256.so
    building 'Crypto.Hash._SHA224' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/SHA224.c -o build/temp.linux-aarch64-2.7/src/SHA224.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/SHA224.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_SHA224.so
    building 'Crypto.Hash._SHA384' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/SHA384.c -o build/temp.linux-aarch64-2.7/src/SHA384.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/SHA384.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_SHA384.so
    building 'Crypto.Hash._SHA512' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/SHA512.c -o build/temp.linux-aarch64-2.7/src/SHA512.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/SHA512.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_SHA512.so
    building 'Crypto.Hash._RIPEMD160' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -DPCT_LITTLE_ENDIAN=1 -Isrc/ -I/usr/include/python2.7 -c src/RIPEMD160.c -o build/temp.linux-aarch64-2.7/src/RIPEMD160.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/RIPEMD160.o -o build/lib.linux-aarch64-2.7/Crypto/Hash/_RIPEMD160.so
    building 'Crypto.Cipher._AES' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/AES.c -o build/temp.linux-aarch64-2.7/src/AES.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/AES.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_AES.so
    building 'Crypto.Cipher._ARC2' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/ARC2.c -o build/temp.linux-aarch64-2.7/src/ARC2.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/ARC2.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_ARC2.so
    building 'Crypto.Cipher._Blowfish' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/Blowfish.c -o build/temp.linux-aarch64-2.7/src/Blowfish.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/Blowfish.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_Blowfish.so
    building 'Crypto.Cipher._CAST' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/CAST.c -o build/temp.linux-aarch64-2.7/src/CAST.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/CAST.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_CAST.so
    building 'Crypto.Cipher._DES' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -Isrc/libtom/ -I/usr/include/python2.7 -c src/DES.c -o build/temp.linux-aarch64-2.7/src/DES.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/DES.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_DES.so
    building 'Crypto.Cipher._DES3' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -Isrc/libtom/ -I/usr/include/python2.7 -c src/DES3.c -o build/temp.linux-aarch64-2.7/src/DES3.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/DES3.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_DES3.so
    building 'Crypto.Cipher._ARC4' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/ARC4.c -o build/temp.linux-aarch64-2.7/src/ARC4.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/ARC4.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_ARC4.so
    building 'Crypto.Cipher._XOR' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/XOR.c -o build/temp.linux-aarch64-2.7/src/XOR.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/XOR.o -o build/lib.linux-aarch64-2.7/Crypto/Cipher/_XOR.so
    building 'Crypto.Util.strxor' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/strxor.c -o build/temp.linux-aarch64-2.7/src/strxor.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/strxor.o -o build/lib.linux-aarch64-2.7/Crypto/Util/strxor.so
    building 'Crypto.Util._counter' extension
    aarch64-linux-gnu-gcc -pthread -fwrapv -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/_counter.c -o build/temp.linux-aarch64-2.7/src/_counter.o
    aarch64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-aarch64-2.7/src/_counter.o -o build/lib.linux-aarch64-2.7/Crypto/Util/_counter.so
    
Successfully installed pycrypto
Cleaning up...
Downloading/unpacking enum34
  Downloading enum34-1.1.6-py2-none-any.whl
Installing collected packages: enum34
Successfully installed enum34
Cleaning up...
Downloading/unpacking enum-compat
  Downloading enum-compat-0.0.2.tar.gz
  Running setup.py (path:/tmp/pip-build-PLPc3t/enum-compat/setup.py) egg_info for package enum-compat
    
Downloading/unpacking enum34 (from enum-compat)
  Downloading enum34-1.1.6-py2-none-any.whl
Installing collected packages: enum-compat, enum34
  Running setup.py install for enum-compat
    
Successfully installed enum-compat enum34
Cleaning up...
********************************************************
*             Installation terminée                    *
********************************************************

et ça :

Code : Tout sélectionner

Traceback (most recent call last):
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 28, in <module>
    from devices.yeehome import *
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeehome.py", line 13, in <module>
    import utils
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/utils.py", line 4, in <module>
    from cryptography.hazmat.primitives.ciphers import Cipher, algorithms, modes
ImportError: No module named cryptography.hazmat.primitives.ciphers
[2019-03-24 13:48:12][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.
Traceback (most recent call last):
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 28, in <module>
    from devices.yeehome import *
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeehome.py", line 13, in <module>
    import utils
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/utils.py", line 4, in <module>
    from cryptography.hazmat.primitives.ciphers import Cipher, algorithms, modes
ImportError: No module named cryptography.hazmat.primitives.ciphers
[2019-03-24 13:50:02][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-03-24 13:49:44
[2019-03-24 13:50:15][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.
Je sais plus trop quoi faire et même j'ai peur de faire des bétises :
le ssh c'est direct sur le pc ou il faut passer par interface de jeedom ?
Pouvez vous m'aidez ?
Merci par avance.
Jeedom Smart
Module Fibaro :
FDG 212
FGS 213
FGS 222

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 10 juin 2019, 01:36

Bonjour, petit déterrage, j'ai acheté le plugin xiaomi aujourd’hui en prévision de la réception de mon aspirateur roborock et le demon ne demarre pas avec le log :

ImportError: No module named future.utils

j'ai déjà tenté la méthode:

1) Reboot
2) Desinstaller le plugin Xiaomi
3) En ligne de commande via SSH
sudo apt-get update
sudo apt-get upgrade
4) reboot
5) Reinstalle le plugin
6) metter les log en debug
7) demarer les dépendances
8) verifier les logs des dépandances
7) demarrer le daemon
8) verifie les log
9) Si tout ok remettre les logs en Default

ca ne fonctionne pas et aussi l'installation de future en ssh via "sudo pip2 install future" qui me retourne:

Code : Tout sélectionner

Collecting future
  Using cached https://files.pythonhosted.org/packages/90/52/e20466b85000a181e1e144fd8305caf2cf475e2f9674e797b222f8105f5f/future-0.17.1.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-umjXb8/future/setup.py", line 181, in <module>
        **setup_kwds
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-umjXb8/future/
Voila je sèche un peu. J ai lu aussi une histoire d'accès local HTTPS au lieu de HTTP (je suis en HTTP).
Merci d 'avance

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 24 juin 2019, 22:22

ValueError: Entry points must be listed in groups

Apparemment ça serait un problème avec python? ... des connaisseurs..?

Avatar de l’utilisateur
akenad
Actif
Messages : 695
Inscription : 27 oct. 2017, 11:39

Re: Plugin XIAOMI Daemon NOK

Message par akenad » 25 juin 2019, 07:54

Substi57 a écrit :
10 juin 2019, 01:36
... j'ai acheté le plugin xiaomi ... et le demon ne demarre pas ...

Bonjour @Substi57,

pour t'aider ce serait plus facile si tu renseignais dans ton profil la rubrique Matériel, genre "JeedomSmart en Stretch" (ou autre ...).
Et d'autres part fournir la log complet de l'installation des dépendances du plugin Xiaomi Home.

akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 27 juin 2019, 19:31

Bonjour @akenad
Première chose, je m'excuse du retard, je n’étais pas trop disponible.
Je viens de mettre à jours mon profil, en gros c'est un RPi3B+ qui héberge JEEDOM ainsi que SNIPS (les 2 sur le même RPI). Pour communiquer avec mes équipements j'utilise un RFXcom XL pour 433mhz et une clé AEOTEC gen 5 pour le zwave.

Voila pour le hard. En ce qui concerne les logs d'installation des dépendances, les voici:

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Hit:3 https://deb.nodesource.com/node_10.x stretch InRelease
Hit:4 https://raspbian.snips.ai/stretch stable InRelease
Fetched 40.3 kB in 1s (20.5 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libssl-dev is already the newest version (1.1.0j-1~deb9u1).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2+rpt2).
Suggested packages:
  python-cryptography-doc python-cryptography-vectors
The following NEW packages will be installed:
  libffi-dev
The following packages will be upgraded:
  python-cryptography
apt-listchanges: Reading changelogs...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
1 upgraded, 1 newly installed, 0 to remove and 128 not upgraded.
Need to get 0 B/332 kB of archives.
After this operation, 327 kB of additional disk space will be used.
Selecting previously unselected package libffi-dev:armhf.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'python-pygments' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
Collecting construct
  Using cached https://files.pythonhosted.org/packages/19/c0/f054941fa33d14378de66d2c0477d31f7ad97aa2e298a5771a7b20bc2039/construct-2.9.45.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-i9OR75/construct/setup.py", line 63, in <module>
        "Programming Language :: Python :: Implementation :: PyPy",
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-i9OR75/construct/
Collecting pyudev
  Using cached https://files.pythonhosted.org/packages/bc/a2/31a07829acea8e70a28c247f43fa5d981229ae0f9edfeddedf52de00709b/pyudev-0.21.0.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-VyT5I6/pyudev/setup.py", line 62, in <module>
        packages=setuptools.find_packages("src"),
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-VyT5I6/pyudev/
Collecting requests
  Using cached https://files.pythonhosted.org/packages/51/bd/23c926cd341ea6b7dd0b2a00aba99ae0f828be89d72b2190f27c11d4b7fb/requests-2.22.0-py2.py3-none-any.whl
Collecting idna<2.9,>=2.5 (from requests)
  Using cached https://files.pythonhosted.org/packages/14/2c/cd551d81dbe15200be1cf41cd03869a46fe7226e7450af7a6545bfc474c9/idna-2.8-py2.py3-none-any.whl
Collecting chardet<3.1.0,>=3.0.2 (from requests)
  Using cached https://files.pythonhosted.org/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting certifi>=2017.4.17 (from requests)
  Using cached https://files.pythonhosted.org/packages/69/1b/b853c7a9d4f6a6d00749e94eb6f3a041e342a885b87340b79c1ef73e3a78/certifi-2019.6.16-py2.py3-none-any.whl
Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 (from requests)
  Using cached https://files.pythonhosted.org/packages/e6/60/247f23a7121ae632d62811ba7f273d0e58972d75e58a94d329d51550a47d/urllib3-1.25.3-py2.py3-none-any.whl
Installing collected packages: idna, chardet, certifi, urllib3, requests
Successfully installed certifi-2019.6.16 chardet-3.0.4 idna-2.8 requests-2.22.0 urllib3-1.25.3
Collecting pyserial
  Using cached https://files.pythonhosted.org/packages/0d/e4/2a744dd9e3be04a0c0907414e2a01a7c88bb3915cbe3c8cc06e209f59c30/pyserial-3.4-py2.py3-none-any.whl
Installing collected packages: pyserial
Successfully installed pyserial-3.4
Collecting future
  Using cached https://files.pythonhosted.org/packages/90/52/e20466b85000a181e1e144fd8305caf2cf475e2f9674e797b222f8105f5f/future-0.17.1.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-5Ez6cA/future/setup.py", line 181, in <module>
        **setup_kwds
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-5Ez6cA/future/
Collecting pycrypto
  Using cached https://files.pythonhosted.org/packages/60/db/645aa9af249f059cc3a368b118de33889219e0362141e75d4eaf6f80f163/pycrypto-2.6.1.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-W2Ud1w/pycrypto/setup.py", line 456, in <module>
        core.setup(**kw)
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-W2Ud1w/pycrypto/
Collecting enum34
  Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Installing collected packages: enum34
Successfully installed enum34-1.1.6
Collecting enum-compat
  Using cached https://files.pythonhosted.org/packages/95/6e/26bdcba28b66126f66cf3e4cd03bcd63f7ae330d29ee68b1f6b623550bfa/enum-compat-0.0.2.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-NQrSAE/enum-compat/setup.py", line 45, in <module>
        install_requires=[] if has_enum else ['enum34'],
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-NQrSAE/enum-compat/
********************************************************
*             Installation terminée                    *
********************************************************
Pour le log de démarrage du plugin j'ai ca:

Code : Tout sélectionner

[2019-06-27 19:27:35][INFO] : Lancement démon xiaomihome : /usr/bin/python /var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py --loglevel debug --socketport 55019 --callback http://192.168.1.33:80/plugins/xiaomihome/core/php/jeeXiaomiHome.php --apikey CKMiir3jVSTe64Z7I4UfCMHdhkPMknjO --cycle 0.05 --pid /tmp/jeedom/xiaomihome/deamon.pid
Traceback (most recent call last):
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/xiaomihomed.py", line 26, in <module>
    import globals
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/globals.py", line 3, in <module>
    from devices.yeelight.flow import *
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/__init__.py", line 5, in <module>
    from .main import Bulb, BulbType, BulbException, discover_bulbs
  File "/var/www/html/plugins/xiaomihome/resources/xiaomihomed/devices/yeelight/main.py", line 9, in <module>
    from future.utils import raise_from
ImportError: No module named future.utils
[2019-06-27 19:28:06][ERROR] : Impossible de lancer le démon xiaomihomed. Vérifiez le log.
Quand je tente le "sudo pip2 install future" ça me retourne:

Code : Tout sélectionner

Collecting future
  Using cached https://files.pythonhosted.org/packages/90/52/e20466b85000a181e1e144fd8305caf2cf475e2f9674e797b222f8105f5f/future-0.17.1.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "", line 1, in 
      File "/tmp/pip-build-AnaI70/future/setup.py", line 181, in 
        **setup_kwds
      File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 318, in __init__
        for ep in pkg_resources.iter_entry_points('distutils.setup_keywords'):
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 726, in iter_entry_points
        entries = dist.get_entry_map(group)
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2639, in get_entry_map
        self._get_metadata('entry_points.txt'), self
      File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2373, in parse_map
        raise ValueError("Entry points must be listed in groups")
    ValueError: Entry points must be listed in groups

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-AnaI70/future/
Voila, j'ai vu que tu as repondu aussi sur un autre sujet qui parle du même problème, on va tout centraliser ici si tu veux bien.
Merci d'avance pour ton aide :)

Avatar de l’utilisateur
akenad
Actif
Messages : 695
Inscription : 27 oct. 2017, 11:39

Re: Plugin XIAOMI Daemon NOK

Message par akenad » 27 juin 2019, 22:15

Que retourne ? :

Code : Tout sélectionner

$ pip list
akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 27 juin 2019, 22:30

Code : Tout sélectionner

DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
Adafruit-BMP (1.5.4)
Adafruit-DHT (1.4.0)
Adafruit-GPIO (1.0.4)
Adafruit-PureIO (0.2.3)
astroid (1.6.5)
backports-abc (0.5)
backports.functools-lru-cache (1.5)
beautifulsoup4 (4.5.3)
blessings (1.7)
blinker (1.3)
certifi (2019.6.16)
chardet (3.0.4)
configparser (3.5.0)
coverage (4.5.2)
cryptography (1.7.1)
Cython (0.25.2)
docutils (0.13.1)
duplicity (0.7.11)
enum34 (1.1.6)
futures (3.2.0)
html5lib (0.999999999)
idna (2.8)
ipaddress (1.0.17)
isort (4.3.4)
keyring (10.1)
keyrings.alt (1.3)
lazy-object-proxy (1.3.1)
libopenzwave (0.3.1)
lockfile (0.12.2)
Louie (1.1)
lxml (3.7.1)
mccabe (0.6.1)
nose (1.3.7)
nose-html (1.1)
nose-progressive (1.5.2)
oauthlib (2.0.1)
openzwave (0.3.1)
paramiko (2.0.0)
Pillow (4.0.0)
pip (9.0.1)
pyasn1 (0.1.9)
pycrypto (2.6.1)
Pygments (2.2.0)
pygobject (3.22.0)
PyJWT (1.4.2)
pylint (1.9.4)
pyOpenSSL (16.2.0)
pyserial (3.4)
pyudev (0.21.0)
pyxdg (0.25)
requests (2.22.0)
roman (2.0.0)
RPi.GPIO (0.6.5)
SecretStorage (2.3.1)
setuptools (33.1.1)
singledispatch (3.4.0.3)
six (1.10.0)
speedtest-cli (1.0.0)
spidev (3.4)
tornado (5.1.1)
urllib3 (1.25.3)
urwid (2.0.1)
virtualenv (16.4.3)
webencodings (0.5)
wheel (0.29.0)

Avatar de l’utilisateur
akenad
Actif
Messages : 695
Inscription : 27 oct. 2017, 11:39

Re: Plugin XIAOMI Daemon NOK

Message par akenad » 28 juin 2019, 00:34

Je te suggère d'installer le paquet python-future :

Code : Tout sélectionner

$ sudo apt-get install python-future
akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 28 juin 2019, 06:05

Ok, je fais ca en rentrant ce soir et je te tiens informé.
Merci

Substi57
Timide
Messages : 70
Inscription : 24 déc. 2018, 17:30

Re: Plugin XIAOMI Daemon NOK

Message par Substi57 » 28 juin 2019, 17:45

Voila c'est fait, ca me retourne ca:

Code : Tout sélectionner

sudo apt-get install python-future
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libjs-sphinxdoc libjs-underscore python-configparser
Suggested packages:
  python-future-doc
The following NEW packages will be installed:
  libjs-sphinxdoc libjs-underscore python-configparser python-future
0 upgraded, 4 newly installed, 0 to remove and 129 not upgraded.
Need to get 543 kB of archives.
After this operation, 2550 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://raspbian.42.fr/raspbian stretch/main armhf libjs-underscore all 1.8                                                                                                                                                           .3~dfsg-1 [63.8 kB]
Get:2 http://raspbian.42.fr/raspbian stretch/main armhf libjs-sphinxdoc all 1.4.                                                                                                                                                           9-2 [69.5 kB]
Get:3 http://raspbian.42.fr/raspbian stretch/main armhf python-configparser all                                                                                                                                                            3.3.0r2-2 [62.1 kB]
Get:4 http://raspbian.42.fr/raspbian stretch/main armhf python-future all 0.15.2                                                                                                                                                           -4 [347 kB]
Fetched 543 kB in 0s (620 kB/s)
Selecting previously unselected package libjs-underscore.
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'python-pygments' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

Avatar de l’utilisateur
akenad
Actif
Messages : 695
Inscription : 27 oct. 2017, 11:39

Re: Plugin XIAOMI Daemon NOK

Message par akenad » 28 juin 2019, 18:20

J’ai l’impression que tu n’as pas installé ton RPi3 avec l’image raspbian officielle.

Je te suggère de réinstaller le paquet python-pygments:

Code : Tout sélectionner

$ sudo apt-get --reinstall install python-pygments
$ sudo apt-get install python-future
akenad :)
Dernière édition par akenad le 28 juin 2019, 22:55, édité 3 fois.
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

Répondre

Revenir vers « [Plugin Tiers] Xiaomi Home »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités