Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[PROBLEME] Intégration gateway Xiaomi

Avatar de l’utilisateur
lunarok
Actif
Messages : 6692
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [PROBLEME] Intégration gateway Xiaomi

Message par lunarok » 01 janv. 2019, 20:42

Non je confirme pas, le firmware on est en 1.4 quelque chose. Alors la version 2.67 faudrait dire déjà d'où elle sort.
Le dernier qui a utilisé le subjonctif pour la même chose, au final c'était bien une fausse piste.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

smoreau59
Timide
Messages : 4
Inscription : 27 déc. 2018, 11:21

Re: [PROBLEME] Intégration gateway Xiaomi

Message par smoreau59 » 02 janv. 2019, 07:55

jibai69,

oui j'ai la même config, j'ai également un certificat LetsEncrypt pour la redirection en HTTPS.

jibai69
Timide
Messages : 9
Inscription : 29 déc. 2017, 12:52

Re: [PROBLEME] Intégration gateway Xiaomi

Message par jibai69 » 02 janv. 2019, 10:28

Merci pour vos réponses.

Lunarok, comme je l'ai précisé dans mon message :
--> Coté Mihome
- Mihome version : 5.4.43
- Serveur Mainland China
- Plug-in version 2.67.12
- Firmware 1.4.4_461.0143
- Version gateway : DGNWG02LM (pas homekit)
- Version développeur activé et visible sur l'application
C'est le plug-in (page about de la gateway sur l'application) qui est en 2.67.

Je ne comprends vraiment pas d'où peut venir le problème....

Coco69530
Timide
Messages : 28
Inscription : 09 janv. 2018, 09:56

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Coco69530 » 02 janv. 2019, 11:11

J'ai exactement le problème ::

Code : Tout sélectionner

Starting Nmap 6.47 ( http://nmap.org ) at 2019-01-02 11:08 CET
Nmap scan report for XX.XX.XX.XX
Host is up (0.098s latency).
PORT     STATE  SERVICE
4321/udp closed rwhois
9898/udp closed unknown
MAC Address: xx:xx:xx:xx:xx:xx (Unknown)
Gateway V3
v 1.4.1_161.0143

jibai69
Timide
Messages : 9
Inscription : 29 déc. 2017, 12:52

Re: [PROBLEME] Intégration gateway Xiaomi

Message par jibai69 » 02 janv. 2019, 12:39

J'ai vraiment l'impression qu'il y a un problème avec la gateway. On est de plus en plus à remonter ce problème....

Avatar de l’utilisateur
lunarok
Actif
Messages : 6692
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [PROBLEME] Intégration gateway Xiaomi

Message par lunarok » 02 janv. 2019, 12:46

Vous êtes 2 ici (en squattant le fil d'un autre problème résolu qui plus est)
C'est pas logique, il y aurait un nombre plus important.
Les dernières gateway marchent très bien. Derniere fois qu'on en a parler sur le fil principal, il y a eu des retours ok avec la nouvelle gateway chez des utilisateurs qui étendaient leur réseau.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

jibai69
Timide
Messages : 9
Inscription : 29 déc. 2017, 12:52

Re: [PROBLEME] Intégration gateway Xiaomi

Message par jibai69 » 02 janv. 2019, 14:08

Alors non.

De un, le problème de l'initiateur du post n'a pas été réglé (crysis).
De deux il y a au moins 4 post récent sur la même thématique, avec exactement le même problème.
De trois c'était pour ne pas surcharger le forum et regrouper des problématiques d'apparences similaires.

Lunarok permet moi un commentaire sur ta réponse. J'ai lu à plusieurs reprises sur le forum des utilisateurs de ton Plugin se plaignant du coté condescendant de tes réponses. Je viens de comprendre pourquoi...

Alors oui, nous ne sommes pas expert. Oui, il y a une probabilité non négligeable que le problème vienne de notre part. Je ne faisais que constater que nous sommes quelques un à rencontrer exactement le même problème, et grouper les informations pouvant nous aider.

Lunarok, je me permets de te rappeler que nous avons acheté ton plugin, un strict minimum de courtoisie avec tes "clients" serai le bienvenue....

Avatar de l’utilisateur
lunarok
Actif
Messages : 6692
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [PROBLEME] Intégration gateway Xiaomi

Message par lunarok » 02 janv. 2019, 14:47

Ici c'est un forum comunautaire, il n'y a pas de clients, c'est pas le support officiel.

Je suis intervenu pour 2 raisons :
- ca squat un fil avec UN problème d'origine pour partir dans tous les sens à grand coup de "moi pareil" mais quand on a les infos, non c'est pas pareil (pas de port ouvert sur la gateway != pas de traffic broadcast != mauvaise conf IP https)
- 2 personnes ont à nouveau incriminer un pb de firmware en s'appuyant sur du vent (et c'est pas la première fois)

Le pb de firmware est arrivé effectivement 1 fois et 1 seule sauf à réellement prouver l'inverse. Et quand ca c'est produit, c'était ni 2 ni 4 personnes avec le problème.
Le fait de le prendre pour argent comptant cache les réels problèmes et c'est nuisible. Si on tombe sur ce fil, on voit toute sorte de problèmes et la conclusion serait un firmware répendu sur des milliers de gateway ??? Au pire ca donne une mauvaise information, au mieux ca fait sourire.

Des gateway j'en ai assez chez moi pour mon besoin perso. Et vu qu'à chaque fois c'est une fausse alerte, j'arrête d'en commander juste pour confirmer, car après faut que je les refile aux connaissances qui ne sont pas toutes acquises à la domotique.
Il y a peu, après que cette paranoia au firmware buggé (qu'on a tous soit dit en passant cette version, tous ceux à jour, pareil pour la version de plugin)
Ca peut paraitre "beaucoup" le nombre de problèmes qui vous semble être "pareil" sauf qu'ils sont pas tous pareil et je vous garantis que ca ferait plus de bruit si c'était bien le cas.

Le but est que les utilisateurs, ne mélangent pas tout. Si c'est lié au broadcast, qu'on vienne pas lui mettre dans la tête que c'est son firmware.
Et si il n'y a pas de pb de firmware, ca peut être lié à la gateway elle même.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Coco69530
Timide
Messages : 28
Inscription : 09 janv. 2018, 09:56

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Coco69530 » 02 janv. 2019, 15:21

J'ai trouvé quelques sujets (où les ports n'étaient pas open malgré le passage en mode développeur) où les gateway semblaient être en défaut.

J'en ai recommandé une pour en avoir le cœur net.

Je vous ferais un retour dès réception.

jibai69
Timide
Messages : 9
Inscription : 29 déc. 2017, 12:52

Re: [PROBLEME] Intégration gateway Xiaomi

Message par jibai69 » 08 janv. 2019, 19:02

Mise à jour du firmware aujourd'hui, et toujours pas de remontée...

J'ai fait comme toi, j'ai racheté une gateway pour tester...

A voir...

Sinon il existe une façon de savoir si le broadcast passe sur le réseau d'une manière générale ?

dax08drummer
Timide
Messages : 5
Inscription : 23 déc. 2018, 16:57

Re: [PROBLEME] Intégration gateway Xiaomi

Message par dax08drummer » 10 janv. 2019, 20:34

Bonjour a tous,

J'ai suivi [Tuto] OpenMediaVault + Docker + Jeedom pour l'install de jeedom, et en effet le plugin Xiaomi fonctionne mais ne voit pas la Gateway.

En effet vu que la Gateway envoie des requêtes de broadcast et l'installation de Jeedom via Docker et en mode "Bridge". Jeedom a sa propre ip@ et utilise l’ip de son hôte mais dans un sous-reseau différent donc les requete de broadcast ne passent pas.

Quelqu'un sais comment faire en sorte que Jeedom soit dans le même sous-reseau que la Gateway.

PS : j'ai essayer de passer en mode "Host" en changeant le port d'ecoute d'Apache, mais ça ne fonctionne pas.

mf4n4ck
Timide
Messages : 7
Inscription : 09 nov. 2018, 20:15

Re: [PROBLEME] Intégration gateway Xiaomi

Message par mf4n4ck » 16 janv. 2019, 10:39

Bonjour à tous,

Un petit message d'espoir si il en faut : J'ai reçu il y a peu un pack gateway + motion sensor + wireless switch + smart plug + window/door sensor

Version Gateway : 1.4.1_164.0158
Version matérielle Gateway: DGNWG02LM
Version MiHome : 5.4.43

Installé sans souci (ou presque car j'avais mal recopié le mot de passe du mode "Wireless communication protocol" -> une recherche sur le forum a pu m'aider) avec une Livebox 4.

En cours de déploiement de mon installation, je ne suis pas encore un expert mais ce forum m'aide tous les jours à comprendre et apprendre. Les réponses (qu'importe leurs tons, du moment qu'elles sont constructives et font avancer la problématique) m'on toutes été utiles à un moment ou un autre.

De manière générale, et comme un peu partout, nous avons tendance à critiquer lorsque ça ne marche pas en oubliant de rendre hommage au travail et à la disponibilité de ceux qui aide (ou essaie d'aider). Nous ne sommes pas dans un rapport client/fournisseur, la solution Jeedom étant majoritairement communautaire ce qui implique beaucoup d'avantages et quelques inconvénients.

Dans tous les cas si je peux vous aider à y voir plus clair n'hésitez pas.
Raspberry Pi 3+ - Razberry2 (ZME*RAZ2)
Gateway Xiaomi - Interface filaire universelle Bubendorff
Fibaro FGMS-01- FGS222 - FGS212 + bypass - FGSD-002
Qnap TS251+ - Livebox 4 - Harmony Hub
Netatmo Weather Station - Welcome - Thermostat

jibai69
Timide
Messages : 9
Inscription : 29 déc. 2017, 12:52

Re: [PROBLEME] Intégration gateway Xiaomi

Message par jibai69 » 27 janv. 2019, 21:18

Suite et fin.

Je viens de recevoir ce soir une nouvelle gateway (Même numéro de version) qui fonctionne de manière impeccable !

Je n'ai par contre pas fait la mise à jour de firmware.

Soit le problème venait de ma première gateway, soit le problème vient de firmware.

Comme la dit Lunarok, un problème de firmware serai plus bruyant que çà au niveau du nombre de cas, j'en déduis donc que la bonne réponse est la première proposition.

Par superstition je ne vais pas faire quand même la mise à jour ;).

Merci à ceux qui m'ont proposé leur aide.

Rejo007
Timide
Messages : 33
Inscription : 02 oct. 2018, 16:12

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Rejo007 » 28 janv. 2019, 16:15

Bonjour,

J'ai le même problème depuis le jour ou j'ai changé de routeur.
Les autres plugins dans jeedom n'ont pas de probleme et dans mi home, tout est parfait.

Toujours pas de piste?

Merci

Avatar de l’utilisateur
fensoft
Actif
Messages : 1314
Inscription : 07 mai 2015, 11:26

Re: [PROBLEME] Intégration gateway Xiaomi

Message par fensoft » 28 janv. 2019, 16:25

C'est un autre problème : ton Routeur bloque le broadcast udp. Regarde si tu as une option type igmp snooping dans les options de ton Routeur.
Coin!
Thermostat lowcost MaxCube DataTransfert (upload vers cloud)
Développeur embarqué (rtos/drivers linux/c/xilinx/atmel/pic/arm/mips), système (linux,docker,qnx), scientifique (c++/python/mongodb), web (php/mysql), webservices (java/nodejs)

Rejo007
Timide
Messages : 33
Inscription : 02 oct. 2018, 16:12

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Rejo007 » 28 janv. 2019, 17:07

Jeedom est branché en rj45 sur ma box.
les devices xiaomi sont en wifi via les relais "google wifi" ce sont ces "google wifi" qui sont nouveaux.
Mais depuis vu que ca n'allait pas j'ai réinstaller les gateway en enlevant et en remettant le mode dev (avec les nouveaux firmwares installés.
je ne vois rien d'igmp dans les google wifi.
Dois je essayer d'ouvrir des ports?
Dois je changer qqchose dans jeedom suite au changement de "google wifi" (je ne pense pas car les autres plugin marche a la perfection)

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Bosquetia » 28 janv. 2019, 18:10

Les devices xiaomi ne fonctionnent pas en wifi, seule la gateway fonctionne en wifi
et les modules xiaomi causent en zigbee avec la gateway.
Donc jeedom cause à la gateway via le plugin dont il est question dans ce thread

Si le broadcast ne passe pas sur le réseau entre jeedom et la gateway c'est source de souci

Rejo007
Timide
Messages : 33
Inscription : 02 oct. 2018, 16:12

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Rejo007 » 28 janv. 2019, 18:30

Oui pardon, le gateway est en wifi mais je ne vois pas ce que je peux modifier dans mes parametres "google wifi" pour laisser passer le "broadcast"...
une idée?

Rejo007
Timide
Messages : 33
Inscription : 02 oct. 2018, 16:12

Re: [PROBLEME] Intégration gateway Xiaomi

Message par Rejo007 » 28 janv. 2019, 18:43

Voici les réglages possibles...
Pièces jointes
Screenshot_20190128-184238.png
Screenshot_20190128-184238.png (119.89 Kio) Consulté 1105 fois

Avatar de l’utilisateur
lunarok
Actif
Messages : 6692
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [PROBLEME] Intégration gateway Xiaomi

Message par lunarok » 28 janv. 2019, 18:58

Ca serait sympa de créer un post avec ton modèle de routeur en titre, les suivants retrouveront plus facilement et ce post ne finira pas en poubelles à "+1" sans liens les uns avec les autres.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Répondre

Revenir vers « [Plugin Tiers] Xiaomi Home »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités