Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

SONOFF POW

BenouLM
Timide
Messages : 229
Inscription : 15 déc. 2015, 09:27

Re: SONOFF POW

Message par BenouLM » 26 janv. 2018, 12:34

Bonjour a tous,

Bon j'ai lut pas mal de choses et à moins d’être passé a coté, j'ai une question et un problème.

J'ai pow que j'ai voulu passer en ESPEasy_v2.0-20180126 la toute dernière mouture .

J'avoue que j'aime bien la progression mais voila je n'ai plus AC en "energie" mais que DC malgré mais flash différents ( j'ai cru comprendre que je m'était peu étre trompé de version de espeasy) .

Ne trouvant pas la solution j'ai voulu revenir en REV12 Mais il garde la même interface graphique et ne me remet pas le AC .

A chaque flash j'ai fais un "erase" avec la méthode de Rol-rider ( fichier remplit de 0 ).

Auriez vous une idée, soit pour revenir a la REV12 normal ou pour avoir AV dans la dernière version ESPEasy_v2.0-20180126 .

En espérant avoir été assez claire

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 26 janv. 2018, 13:36

Si tu veux utiliser la mesure du courant avec le sonoff Pow il te faut sélectionner le device HLW8012.
Mais il n'est pas dans la liste du fichier " normal"
Si tu récupères le fichier que j'ai donné, le HLW8012 est dispo.
Sinon, ba c'est à toi de faire ta compil.

Envoyé de mon Nexus 7 en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

BenouLM
Timide
Messages : 229
Inscription : 15 déc. 2015, 09:27

Re: SONOFF POW

Message par BenouLM » 26 janv. 2018, 14:26

rol-rider a écrit :
26 janv. 2018, 13:36
Si tu veux utiliser la mesure du courant avec le sonoff Pow il te faut sélectionner le device HLW8012.
Mais il n'est pas dans la liste du fichier " normal"
Si tu récupères le fichier que j'ai donné, le HLW8012 est dispo.
Sinon, ba c'est à toi de faire ta compil.

Envoyé de mon Nexus 7 en utilisant Tapatalk
C'est ce que j'avais lu mais j'avais apparemment pas bien compris l'infos ... compiler je veux bien mais je n'ai pas les connaissances malheureusement .

Je me risque a une dernière question , ton fichier est basé sur quel version ?

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 26 janv. 2018, 15:47

C'est une v2.0.0 (custom)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

BenouLM
Timide
Messages : 229
Inscription : 15 déc. 2015, 09:27

Re: SONOFF POW

Message par BenouLM » 26 janv. 2018, 17:38

Merci Rol-rider,

Ce n'est pas tout a fait ce que je demandé, plus la version par rapport a ce qui'ils publient en ce moment mais c'est pas très important .

Merci a toi pour ton aide et tout ce que tu fais pour ce forum

Avatar de l’utilisateur
stalex
Timide
Messages : 374
Inscription : 16 janv. 2015, 08:59
Localisation : Bordeaux

Re: SONOFF POW

Message par stalex » 28 janv. 2018, 16:42

Bonjour à tous,

j'ai essayé de flasher mon sonoff Pow comme évoqué par @rol-rider, mais impossible de le faire fonctionner....
J'ai un modèle récent, puisqu'il s'agit d'un Sonoff pow 2.0
Je suis passé par la procédure sur Computek, c'est a dire le flash en mode DOUT:

Je lancer l'outil ESP8266 DOWNLOAD TOOL, et je positionne ces réglages:
Esp8266DownloadTool.png
Esp8266DownloadTool.png (25.56 Kio) Consulté 464 fois
Comme conseillé sur le site. Je lance, et là impossible d'en tirer quoique ce soit, dans la console j'ai toujours ce message:
baud: 115200
root baud: 115200
-------------
===============
BAUD : 115200
===============
Connecting...
*********************
pic path: ./RESOURCE/SYNC_S.bmp
***********************
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
Je ne sais plus quoi faire du tout. Quelqu'un aurait il deja reussi avec un Sonoff 2.0 ?


Edit: Je précise que la procédure avec FlashESP8266.exe ne fonctionne pas non plus.
Merci pour l'aide.
Rpi 3
Rfxcom:
  • Chacon: 6 DIO first - 4 mod 1000W + 300W dimmer - 6 détecteurs: 1 obscur + 5 ouv
  • Coco: 1 PIR
  • Flamingo: 2 DF
  • Oregon: 4 thermo hygro
  • 10 VR + Portail Smfy
  • Orvb
  • Owl CM160
MySensors: Noeud Dist + temp, hum, pluie +lum

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 28 janv. 2018, 18:07

si tu utilises esp tool, il faut que tu coches la petite case à gauche de ton fichier sélectionné.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 28 janv. 2018, 18:09

et je crois que le sonoff pow, c'est 32Mb à sélectionner, mais tu le seras dans Detected info
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

BenouLM
Timide
Messages : 229
Inscription : 15 déc. 2015, 09:27

Re: SONOFF POW

Message par BenouLM » 28 janv. 2018, 18:16

As tu inversé le tx et rx ?
As tu essayé une autre methode ?

Avatar de l’utilisateur
stalex
Timide
Messages : 374
Inscription : 16 janv. 2015, 08:59
Localisation : Bordeaux

Re: SONOFF POW

Message par stalex » 04 févr. 2018, 15:17

Hello, je viens de ressayer avec vos conseils.
Toujours la meme chose:

serial port opened
-----------
baud: 115200
root baud: 115200
-------------
===============
BAUD : 115200
===============
Connecting...
*********************
pic path: ./RESOURCE/SYNC_S.bmp
***********************
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
raise in device connect
chip sync error.
baudrate sync fail ... retry...
Connecting...
set STOP FLG: True
*********************

J'ai inversé le Tx et le Rx mais dans les deux cas le messages est le meme...
Je pense que mon Sonoff est deffectueux..... y a t il un moyen de le tester ? Merci

Note: je viens de tester la tension entre le VCC et le GND directement sur le SONOFF est, branché au PC via mon FTDI, j'ai bien 3.39v.... donc tout est correct. Pour autant je n'ai jms de connexion...
Rpi 3
Rfxcom:
  • Chacon: 6 DIO first - 4 mod 1000W + 300W dimmer - 6 détecteurs: 1 obscur + 5 ouv
  • Coco: 1 PIR
  • Flamingo: 2 DF
  • Oregon: 4 thermo hygro
  • 10 VR + Portail Smfy
  • Orvb
  • Owl CM160
MySensors: Noeud Dist + temp, hum, pluie +lum

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 04 févr. 2018, 15:40

donc, tu n'as jamais réussi à le flasher?
logiquement il doit donc toujours être avec le firmware original.
tu peux donc vérifier si la procédure officiel du sonoff fonctionne. (pour vérifier s'il est défectueux)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 04 févr. 2018, 15:43

sinon ? ton convertisseur ftdi ? c'est quoi la référence de la puce?
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
stalex
Timide
Messages : 374
Inscription : 16 janv. 2015, 08:59
Localisation : Bordeaux

Re: SONOFF POW

Message par stalex » 04 févr. 2018, 18:52

Merci pour ton aide.
C'est un FTDI 232 RL:
https://fr.aliexpress.com/item/Free-Shi ... 0.0.DVlDbk

Oui je n'ai jamais réussi à le flasher.
Pour vérifier si le firmware officiel fonctionne, il faut obligatoirement le connecter au 220v ?
Rpi 3
Rfxcom:
  • Chacon: 6 DIO first - 4 mod 1000W + 300W dimmer - 6 détecteurs: 1 obscur + 5 ouv
  • Coco: 1 PIR
  • Flamingo: 2 DF
  • Oregon: 4 thermo hygro
  • 10 VR + Portail Smfy
  • Orvb
  • Owl CM160
MySensors: Noeud Dist + temp, hum, pluie +lum

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 04 févr. 2018, 18:58

je te demandais si c'était bien un ftdi232, parce qu'avec le CH340 il ne fournit pas assez de jus pour flasher.

pour vérifier le firmware officiel, tu retires le ftdi et oui, il faut le raccorder sur le secteur 230.

tu es sur de bien réaliser la procédure?
gpio 0 (bp enfoncé) sur gnd avant la mise sous tension ? pour qu'il soit en mode programmation.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
stalex
Timide
Messages : 374
Inscription : 16 janv. 2015, 08:59
Localisation : Bordeaux

Re: SONOFF POW

Message par stalex » 05 févr. 2018, 09:02

Oui oui je suis bien sur de ca.
BenouLM m'a aussi dit que le pluguer au PC via le FTDI faisait que les leds s'allumaient si le Sonoff fonctionne. Tu confirmes ?

Car Lorsque je le branche (sans appuyer sur le BP) rien ne se passe: pas de led.
Lorsque j'appuie sur le BP, rien ne se passe non plus..... donc :)

Je vais essayer avec le 220v mais bon, faudrait deja que je trouve des fils qui se baladent en 220v dans ma maison pour essayer de le brancher dessus !
Initialement je voulais deja reussir à le flasher avant d'ouvrir le mur où se trouvent les fils....
Rpi 3
Rfxcom:
  • Chacon: 6 DIO first - 4 mod 1000W + 300W dimmer - 6 détecteurs: 1 obscur + 5 ouv
  • Coco: 1 PIR
  • Flamingo: 2 DF
  • Oregon: 4 thermo hygro
  • 10 VR + Portail Smfy
  • Orvb
  • Owl CM160
MySensors: Noeud Dist + temp, hum, pluie +lum

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 05 févr. 2018, 09:27

Les led? Du sonoff ? Je sais plus, mais je crois pas!
Et c'est la le problème, on ne sait pas si on est en mode programmation ou pas!
La seule chose pour voir, serait de vérifier le wifi, Si tu trouves le module en point d'accès, c'est qu'il n'est pas passer en mode programmation, et tu as le temps pour vérifier, parceque une fois en mode programmation, il y reste jusqu'au moment où tu coupes l'alimentation.
Tu as les led du FTDI qui doivent clignoter lors du flash, ça c'est sur.
Ça peut aussi être ton câble USB, ou le port USB du PC.
Ton FTDI, est bien reconnu par le PC, tu dois le voir dans les port COM.


Envoyé de mon Nexus 7 en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
stalex
Timide
Messages : 374
Inscription : 16 janv. 2015, 08:59
Localisation : Bordeaux

Re: SONOFF POW

Message par stalex » 08 févr. 2018, 09:16

Hello,

sur vos conseils j'ai essayé de brancher mon sonoff pow sur du 220v:
IMG_20180207_215501.jpg
IMG_20180207_215501.jpg (71.16 Kio) Consulté 360 fois
Et là, il fonctionne très bien. C'est donc le firmware d'origine qui est encore dessus. J'ai téléchargé l'app qui va avec (eWeLink) et il est tout de suite reconnu et ajouté au réseau en wifi. Je peux m'en servir pour au moins piloter le relais.

Donc, du coup, mon Sonoff n'est pas mort ! Je ne comprends toujours pas comment ca se fait que je n'arrive pas à le flasher.... Je suis totalement perdu....
Rpi 3
Rfxcom:
  • Chacon: 6 DIO first - 4 mod 1000W + 300W dimmer - 6 détecteurs: 1 obscur + 5 ouv
  • Coco: 1 PIR
  • Flamingo: 2 DF
  • Oregon: 4 thermo hygro
  • 10 VR + Portail Smfy
  • Orvb
  • Owl CM160
MySensors: Noeud Dist + temp, hum, pluie +lum

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 08 févr. 2018, 09:50

Ba....que veux tu que l'on te dise !
Comme il n'y a même pas eu de flash !
Soit tu t'y prends mal !
Soit tu t'y prends mal !

Refais ton montage, calmement, fait une photo, décris ce que tu fais et post tout ça.
On peut pas grand chose à distance !

Envoyé de mon Nexus 7 en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

RobertDuval
Timide
Messages : 16
Inscription : 17 févr. 2018, 04:50
Localisation : Haut de France

Re: SONOFF POW

Message par RobertDuval » 17 févr. 2018, 05:35

Bonjour à tous,

Je suis nouveau sur le forum ainsi qu'en domotique, avant de poser ma question je me suis fait un plaisir de lire tous les posts de ce topic :roll: ainsi que d'autres traitant du sujet

J'ai procédé au flash de mon SonOff Pow comme indiqué par Rol-rider, tout s'est bien passé, même si j'ai du m'y reprendre à 3 fois (c'est toujours mieux la 3eme fois :D ) à cause d'un problème de soudure et de mauvais paramétrages. Bref, ca marche.

J'ai 3 petites questions :

- Je ne sais pas si je suis le seul, au moment de paramétrer le module, dans la section "device", à la ligne "Sensor" /1st GPIO", je n'arrive pas à sélectionner GPIO5(D1), l'option est grisée, apparement il est selectionné pour un autre parametre (I2C interface), quel est votre avis ?
Image
Image


- Comment récupérer la led bleu du wifi ? Le wifi fonctionne parfaitement, mais la led reste éteinte, y-a-t'il un paramétrage ? comme vous le voyez sur l'image en haut, le paramètre Pin_Led est sur GPIO-13

- La led rouge est allumée au démarrage et tout fonctionne bien, j'appuie sur le bouton du SonOff et le relais s’éteint, par contre, si j'appuie pour le rallumer, la led reste éteinte et le module régalement, plus moyen de le remettre en marche, heureusement avec Jeedom, j'arrive à le mettre en marche, mais la led rouge reste éteinte.

Je vous remercie d'avance pour votre aide. :)

rol-rider
Actif
Messages : 4031
Inscription : 10 août 2014, 23:50

Re: SONOFF POW

Message par rol-rider » 17 févr. 2018, 10:31

- Je ne sais pas si je suis le seul, au moment de paramétrer le module, dans la section "device", à la ligne "Sensor" /1st GPIO", je n'arrive pas à sélectionner GPIO5(D1), l'option est grisée, apparement il est selectionné pour un autre parametre (I2C interface), quel est votre avis ?
tu as zappé une ligne
il y a juste dans "Hardware" de supprimer les gpio pour I2C (on a besoin d'un des gpio pour le hlw8012).
quand tu es dans le menu Hardware, dans la zone I2C tu sélectionnes "None" pour les deux gpio, et ensuite ils ne seront plus grisés.
- Comment récupérer la led bleu du wifi ? Le wifi fonctionne parfaitement, mais la led reste éteinte, y-a-t'il un paramétrage ? comme vous le voyez sur l'image en haut, le paramètre Pin_Led est sur GPIO-13
Sur le schéma de ITEAD la led semble être sur le gpio 15.
- La led rouge est allumée au démarrage et tout fonctionne bien, j'appuie sur le bouton du SonOff et le relais s’éteint, par contre, si j'appuie pour le rallumer, la led reste éteinte et le module régalement, plus moyen de le remettre en marche, heureusement avec Jeedom, j'arrive à le mettre en marche, mais la led rouge reste éteinte.
La led et le relais sont sur le gpio12, mais la gestion BP--relais+led se fait par les rules (règles), donc il faudrait que tu nous donnes la configuration des devices et rules pour voir d’où vient l'erreur.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Répondre

Revenir vers « [Plugin Tiers] ESPEasy »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité