Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

nouveau SonOff 11/2017 flash compliqué ?

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 16:58

Bonjour, j'ai recu la semaine derniere une nouvelle flotte de sonOff 10A (relais bleu) et ils se comportent étrangement:


1er flash en suivant le tuto:
http://www.compu-tek.fr/blog/1325-2/ ( qui soit dit nous met le doute en permanence entre les baud annoncés et ceux sur les images ainsi que pour 0x00000)
bref le flashage se passe super bien pour tous les sonoff ( le wifi esp_o) est la et tout est OK.

je me sers de 2 des sonoff dans jeedom et j'en range 4 pour plus tard.... lorsque je reprends les 3 restant 1 fonctionne parfaitement.
mais pour les 3 autres soit ils perdent la conf soit il sont...... ( briqué ?) :
Capture.PNG
Capture.PNG (17.71 Kio) Consulté 1056 fois
Capture1.PNG
Capture1.PNG (31.62 Kio) Consulté 1056 fois
En fait plus possible de les flasher, je n'ai que des erreur de baudrate sync fail ( j'ai essayer toutes les vitesses )
en changeant rx tx :idem
en prenant la nouvelle version du esp8266 download tool de chez espressif: idem
Capture2.PNG
Capture2.PNG (5.99 Kio) Consulté 1056 fois
en chargeant un autre version du firmawe de espeasy genre la 120 : idem
sur un j'ai essayer cette methode https://tech.scargill.net/more-sonoff/ pour tenter un gpio 0 reset mais cela n'a rien fait.
remplacement du ftdi usb: idem

arff je suis un peu deg de jetter 3 sonoff qui fonctionnaient..

avez vous un autre moyen de reset le GPIO 0 ?

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 17:01

voici la photo du nouveau en haut :
capture3.jpg
capture3.jpg (101.88 Kio) Consulté 1055 fois
je me dit briqué en lisant le message d'erreur "esp sync.....blocking"

christlep
Actif
Messages : 530
Inscription : 13 janv. 2015, 23:17
Localisation : France - 38 - Nord Isére

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par christlep » 16 déc. 2017, 19:01

Salut,

tu es sur de ton port com ?

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 19:10

oui il es en detection auto , mais j'ai verifié aussi . dailleurs le changement de port USB ne fait rien non plus.

latwingo
Timide
Messages : 451
Inscription : 24 nov. 2014, 10:58
Localisation : Cagnes Sur Mer

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par latwingo » 16 déc. 2017, 19:19

Salut est tu sur de pas les avoir cabler en 5v

Sinon essai un clear eepron par defaut sur arduino ide

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 16 déc. 2017, 19:24

ton ftdi est bien sur 3.3v ?

et les ref sur les relais ? tu as cherché sur le net?
sinon, tu effaces (si tu arrive à le mettre en mode programmation)
comme ici viewtopic.php?f=185&t=29859&start=60 message du 26 nov
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 19:38

re, sur mon ftdi c'est un jumper et il es ok sur le 3.3v

ensuite j'ai lock les settings depuis que j'ai flashé tous les sonoff. j'en suis a mon 11 eme.....
la on dirais que sur les nouveaux on a droit a un flash apres il sont plus exploitable....
on dirais que j'arrive pas a le mettre en mode flash, enfin que il veut plus s'y mettre une seconde fois.
pareil pour IDE pas de sync, je me demande vraiement si le bouton est bien le GPIO 0 sur ces nouveau sonoff.....

je viens de tester le fichier blank du lien que tu as mentionner mais le problmeme c'est que le ftdi n'arrive pas a se synchroniser au sonoff
pfff sa fait genre 10 fois que je change rx tx... ce qui me tue c'est que ils se sont dejas flasher une fois pour certains puis que maintenant ils sont amnésiques....en plus 4 sur 6.....

et mes 2 ftdi fonctionnent parfaitement sur un nodemcu , weemos ou un autre sonoff... erff je suis perdu la...

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 16 déc. 2017, 20:59

Tu peux peut être essayer en branchant le sonoff sur le 230vac et en ne raccordant que TX/RX/GND du FTDI.

Envoyé de mon Nexus 7 en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 22:30

Bonne idée , je teste.....


grrr idem même message d'erreur....

quelle est la methode (je vois pas le gpio0 ) pour essayer de le reseter ? peut etre....
Meme si j'y crois pas trop je vais refaire les soudures....

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 16 déc. 2017, 22:50

bon j'ai remplacer les duponts et j'ai refais les soudures idem.
une question avec le logiciel de chez espressif vous avez cela ?:
Capture.PNG
Capture.PNG (6.46 Kio) Consulté 1013 fois
je vois "test running FALSE"
et plus bas:
"is open:FALSE

et je ne comprends pas "raise in device"....

sous IDE toujours le message de synchro

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 17 déc. 2017, 01:47

ça semble comme chez moi (flash wemos)
CaptureTestCom.PNG
CaptureTestCom.PNG (19.34 Kio) Consulté 1005 fois
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 17 déc. 2017, 01:59

une autre piste, diminuer la vitesse (BAUD)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
dcjona
Actif
Messages : 1239
Inscription : 16 juil. 2017, 11:06

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par dcjona » 17 déc. 2017, 08:33

J'ai eu le meme soucis avec mon pow ( pu le mettre une seule fois en mode prog) et puis le faiot de flasher , plus possible de le mettre en prog, il apparait peut etre que en réalisant une flash, la procédure ( appui sur le bouton) pour le mettre ne mode prog est modifiée par le flash...

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 17 déc. 2017, 11:12

Bon après une bonne nuit de sommeil, je décide ce matin de refaire un test en reprenant tout.
et là la synchronisation parfaite tout OK avec les option normale de sur le logiciel, je débranche rebranche pour avoir le wifi esp_o .....
pas de wifi , je le branche sur le 220V pareil pas de wifi

je tente de le reflasher et je me reprends les memes erreurs que y hier.
bon je vais pas me torturer pour 3 sonOff dernier test demain sur un PC au travail et après poubelle.

personne n'a de procédure pour reseter le sonOff via le GPIO 0 to gnd ? j'ai rien trouvé pour ce modele sur le net

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 17 déc. 2017, 12:11

tu n'as pas donné la REF qui est sur le relais !
ça peu éventuellement de donner des pistes sur le net.

c'est peut être plus un 8266 mais un 8285 !
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 17 déc. 2017, 14:52

re,
j'ai tester le flash en 8285 meme resultat hier.

Voici les refs:
sur les bleus c'est churod A1-s-105haf
sur les noirs: golden GI-1a-5dh
les etiquettes sur les relais:
ITA-GZ1-GL
100019cd31
sur les bleu
ITA-GZ1-GL
10001ae376

difficile de tordre plus le condo contre relais pour les noirs par sur de"GI"
20171217_144203.jpg
20171217_144203.jpg (32.9 Kio) Consulté 969 fois
20171217_144153.jpg
20171217_144153.jpg (42.93 Kio) Consulté 969 fois

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 17 déc. 2017, 14:56

t’embête pas pour les relais, c'est la ref sur l'étiquette qui est importante, c'est que tu as donné juste au dessus.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
sweaatchou
Timide
Messages : 78
Inscription : 06 août 2016, 00:19
Localisation : Montpellier

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par sweaatchou » 19 déc. 2017, 18:23

Bon apres vraiment avoir tout essayer nouveau pc etc... je reussi a flasher les bleus mais apres il n'affichent que des erreurs , les noirs eux sont en erreur permanente.
résultat poubelle.
je pense effectivement que on droit juste a un one shot, j'en ai recommandé 2 autres que je testerais.

rol-rider
Actif
Messages : 4260
Inscription : 10 août 2014, 23:50

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par rol-rider » 20 déc. 2017, 10:39

ba, plutôt que la poubelle ! si tu as un moment, tu me l’envoies, je te rembourse le port et je regarde ce que je peux en faire.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

GiDom
Timide
Messages : 449
Inscription : 26 oct. 2016, 18:52
Localisation : Haute Saône (70)

Re: nouveau SonOff 11/2017 flash compliqué ?

Message par GiDom » 20 déc. 2017, 18:15

C'est quoi la date de fabrication ? Essaie la méthode avec esptool.py
https://github.com/espressif/esptool

J'ai longtemps galéré aussi et je m'en suis sorti avec ça.

Ensuite :
1flash.png
1flash.png (1.77 Kio) Consulté 910 fois
Puis :
2 flash.png
2 flash.png (3.01 Kio) Consulté 910 fois
Si tu veux les binaires donne moi ton mail en MP je te les envoie.

Tu as essayé d'inverser le Rx/ tx ? Tu arrives à lire les ref sur la puce ?
NUC sous EXSI et Jeedom 3.2.11 sur VM Debian9 / Zwave / MySensors / Remora / RFXCOM433E / Xiaomi Home / Volets sous ESPEASY / Squeezebox / ZoneMinder

Répondre

Revenir vers « [Plugin Tiers] ESPEasy »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités