Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Installation dépendances impossible

TheFFF
Timide
Messages : 33
Inscription : 08 mai 2017, 11:50

Installation dépendances impossible

Message par TheFFF » 08 juil. 2018, 15:12

Bonjour,

Je tente sans succès depuis hier d'installer ce plugin sur mon Jeedom (RP1 - Raspbian GNU/Linux 9 (stretch) 32bits (armv6l)

Je vous joint le LOG, mise à part que je n'aurais pas la bonne architecture, je ne vois pas. Il faut un Raspi plus récent (3 ? )



Début de l'installation
--2018-07-08 13:05:22-- https://raw.githubusercontent.com/lunar ... /nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K . 100% 4.67M=0s
2018-07-08 13:05:25 (4.67 MB/s) - 'dependencies.sh' saved [1458/1458]
Version actuelle : 4
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
0 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
libuv1* nodejs*
0 upgraded, 0 newly installed, 2 to remove and 25 not upgraded.
After this operation, 12.8 MB disk space will be freed.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 56937 files and directories currently installed.)
Removing nodejs (4.8.2~dfsg-1) ...
Removing libuv1:armhf (1.18.0-3~bpo9+1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
dependencies.sh: 32: [: armv6l: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## You appear to be running on ARMv6 hardware. Unfortunately this is not currently supported by the NodeSource Linux distributions. Please use the 'linux-armv6l' binary tarballs available directly from nodejs.org for Node.js 4 and later.
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
libuv1
The following NEW packages will be installed:
libuv1 nodejs
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 2 newly installed, 0 to remove and 25 not upgraded.
Need to get 0 B/3097 kB of archives.
After this operation, 12.8 MB of additional disk space will be used.
Selecting previously unselected package libuv1:armhf.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 56870 files and directories currently installed.)
Preparing to unpack .../libuv1_1.18.0-3~bpo9+1_armhf.deb ...
Unpacking libuv1:armhf (1.18.0-3~bpo9+1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_4.8.2~dfsg-1_armhf.deb ...
Unpacking nodejs (4.8.2~dfsg-1) ...
Setting up libuv1:armhf (1.18.0-3~bpo9+1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up nodejs (4.8.2~dfsg-1) ...
update-alternatives: using /usr/bin/nodejs to provide /usr/bin/js (js) in auto mode
Version actuelle : v4.8.2
dependencies.sh: 54: dependencies.sh: npm: not found
chown: cannot access 'node_modules': No such file or directory
Fin de l'installation

vincenzi1
Timide
Messages : 235
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Installation dépendances impossible

Message par vincenzi1 » 08 juil. 2018, 17:37

Bonjour,

visiblement le script n'a pas l'air de prendre les bon fichier d’install
je pense qui faut récupéré ici la version pour ARM6 et l'installer a la main

https://nodejs.org/en/download/

TheFFF
Timide
Messages : 33
Inscription : 08 mai 2017, 11:50

Re: Installation dépendances impossible

Message par TheFFF » 08 juil. 2018, 19:42

Nickel, ca marche, j'ai pu installer les dépendances après avoir fait l'installation à la main de la version ARMV6

Merci !

Si ca peut aider un jour, voilà ce que j'ai fait :

cd ~
wget https://nodejs.org/dist/v6.2.1/node-v6. ... v6l.tar.gz
tar -xzf node-v6.2.1-linux-armv6l.tar.gz
node-v6.2.1-linux-armv6l/bin/node -v

vincenzi1
Timide
Messages : 235
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Installation dépendances impossible

Message par vincenzi1 » 09 juil. 2018, 17:25

super :D

de rien en même temps c'est mon métier 8-)

MaximeDu74
Timide
Messages : 116
Inscription : 29 nov. 2017, 13:18

Installation dépendances impossible

Message par MaximeDu74 » 17 juil. 2018, 21:45

TheFFF a écrit :Nickel, ca marche, j'ai pu installer les dépendances après avoir fait l'installation à la main de la version ARMV6

Merci !

Si ca peut aider un jour, voilà ce que j'ai fait :

cd ~
wget https://nodejs.org/dist/v6.2.1/node-v6. ... v6l.tar.gz
tar -xzf node-v6.2.1-linux-armv6l.tar.gz
node-v6.2.1-linux-armv6l/bin/node -v
Peux tu remettre en forme ces lignes de commandes pour que je puisse bien les taper dans le terminal. Merci. Ça devrait donc enlever le problème de node modules?



Envoyé de mon iPhone en utilisant Tapatalk

TheFFF
Timide
Messages : 33
Inscription : 08 mai 2017, 11:50

Re: Installation dépendances impossible

Message par TheFFF » 24 juil. 2018, 15:55

Pardon de mon délais de réponse, je n'avais pas vu..

Que veux tu dire par remettre en forme ?
Un copier coller dans le terminal passe chez moi.

MaximeDu74
Timide
Messages : 116
Inscription : 29 nov. 2017, 13:18

Re: Installation dépendances impossible

Message par MaximeDu74 » 25 juil. 2018, 11:14

C’est bon j’ai résolu mon problème en réinstallant totalement Jeedom

TheFFF
Timide
Messages : 33
Inscription : 08 mai 2017, 11:50

Re: Installation dépendances impossible

Message par TheFFF » 25 juil. 2018, 11:36

Parfait.

De mon coté, après une mise à jour du plugin, à nouveau erreur d'installation. J'ai laissé traîner, hier mon Jeedom me demande une nouvelle MAJ du plugin. Je m’exécute, et là, l'installation des dépendances est passée parfaitement.

Répondre

Revenir vers « [Plugin Tiers] ESPEasy »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités