Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Zibase : ZiBASEDOM

jeanmy
Timide
Messages : 41
Inscription : 30 mai 2015, 20:18

Re: Zibase : ZiBASEDOM

Message par jeanmy » 01 sept. 2018, 16:52

Bonjour,
Suite à un problème de carte SD, je refait toute ma configuration.
J'ai réinstalle ZibaseDOM.
Mes paramètres sont bon car j'ai récupéré bien "les actionneurs"
Mais je ne récupéré "les sondes"

Avez-vous une idée des mon problème ?
Mon matériel : Jeedom 3.0.9 installé sur raspberry / Zibasedom pour échangé avec ma Zibase

enguerrand
Timide
Messages : 11
Inscription : 24 août 2018, 19:40

Re: Zibase : ZiBASEDOM

Message par enguerrand » 10 sept. 2018, 13:15

Bonjour,
Plus de nouvelle concernant ce plugin, l'auteur a t'il abandonné son développement?
Comment ça se passe dans se cas?

Avatar de l’utilisateur
scanab
Actif
Messages : 778
Inscription : 30 juil. 2014, 15:15

Re: Zibase : ZiBASEDOM

Message par scanab » 10 sept. 2018, 13:56

Bonjour
Ma situation personnelle ne me permet effectivement plus de me consacrer à la domotique comme je l'ai fait auparavant et j'en suis désolé...
Actuellement, je suis incapable de dire quand et si je pourrais y reconsacrer un temps suffisant.
Si quelqu'un peut me donner les modifications à apporter au plugin pour les problème d'installation, je les intégrerais.

Envoyé de mon SM-A520F en utilisant Tapatalk

Développeur des plugins :

enguerrand
Timide
Messages : 11
Inscription : 24 août 2018, 19:40

Re: Zibase : ZiBASEDOM

Message par enguerrand » 10 sept. 2018, 18:43

Merci de votre réponse,
Il faudrait rendre votre plugin compatible avec la version 8 (au minimum) de nodeJS

neololo_2000
Timide
Messages : 43
Inscription : 06 oct. 2016, 21:01

Re: Zibase : ZiBASEDOM

Message par neololo_2000 » 17 sept. 2018, 08:19

Merci Scanab juste de modifier cette compatibilité qui pénalise actuellement quelques personnes depuis quelques mois. Après test de la version 3.3.3 de Jeedom, des équipements ne répondent plus. Pour ma part, cela marche encore en 3.2.11 mais sans installation des dépendances et en nok.
Si tu n'as plus le temps, il faudrait peut-être une dernière fois rendre le plugin opérationnel puis peut-être passer le flambeau à une âme charitable (je n'ai hélas ni le temps ni assez de connaissances dans ce domaine pour prendre le relais).
Merci pour ton soutiens!
Laurent

matthieu51
Timide
Messages : 16
Inscription : 10 déc. 2017, 09:21
Contact :

Re: Zibase : ZiBASEDOM

Message par matthieu51 » 21 sept. 2018, 21:42

Même problème que cité au dessus : installations des dépendances en KO : récupération néanmoins des actionneurs (impossible à actionner) mais aucune sonde (oregon) de vu. Plugin zibasedom HS !
Je vais finalement acheter un Rfplayer avec lequel je serais autonome et pas dépendant d'un plugin plus mis à jour, quel dommage.
Merci Scanab pour ton boulo et bon courage pour la suite.
Pour ceux bloqués comme moi, je vous conseil de passer par le plugin : JEEBASE (gratuit)

Code : Tout sélectionner

Début de l'installation
Version actuelle : v8.11.1
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
libc-ares2* libhttp-parser2.8* libuv1* nodejs* nodejs-doc*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 22.2 MB disk space will be freed.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 64706 files and directories currently installed.)
Removing nodejs (8.11.1~dfsg-2~bpo9+1) ...
Removing libc-ares2:armhf (1.14.0-1~bpo9+1) ...
Removing libhttp-parser2.8:armhf (2.8.1-1~bpo9+1) ...
Removing libuv1:armhf (1.18.0-3~bpo9+1) ...
Removing nodejs-doc (8.11.1~dfsg-2~bpo9+1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Utilisation du dépot officiel
================================================================================
================================================================================
DEPRECATION WARNING
Node.js 5.x is no longer actively supported!
You will not receive security or critical stability updates for this version.
You should migrate to a supported version of Node.js as soon as possible.
Use the installation script that corresponds to the version of Node.js you
wish to install. e.g.
* https://deb.nodesource.com/setup_8.x — Node.js 8 LTS "Carbon" (recommended)
* https://deb.nodesource.com/setup_10.x — Node.js 10 Current
Please see https://github.com/nodejs/Release for details about which
version may be appropriate for you.
The NodeSource Node.js distributions repository contains
information both about supported versions of Node.js and supported Linux
distributions. To learn more about usage, see the repository:
https://github.com/nodesource/distributions
================================================================================
================================================================================
Continuing in 20 seconds ...
## Installing the NodeSource Node.js 5.x repo...
## Populating apt-get cache...
+ apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Hit:3 https://deb.nodesource.com/node_6.x stretch InRelease
Reading package lists...
## Confirming "stretch" is supported...
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_5.x/dists/stretch/Release'
## Your distribution, identified as "stretch", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
libc-ares2 libhttp-parser2.8 libuv1 nodejs-doc
The following NEW packages will be installed:
libc-ares2 libhttp-parser2.8 libuv1 nodejs nodejs-doc
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/5087 kB of archives.
After this operation, 22.2 MB of additional disk space will be used.
Selecting previously unselected package libc-ares2:armhf.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 64558 files and directories currently installed.)
Preparing to unpack .../libc-ares2_1.14.0-1~bpo9+1_armhf.deb ...
Unpacking libc-ares2:armhf (1.14.0-1~bpo9+1) ...
Selecting previously unselected package libhttp-parser2.8:armhf.
Preparing to unpack .../libhttp-parser2.8_2.8.1-1~bpo9+1_armhf.deb ...
Unpacking libhttp-parser2.8:armhf (2.8.1-1~bpo9+1) ...
Selecting previously unselected package libuv1:armhf.
Preparing to unpack .../libuv1_1.18.0-3~bpo9+1_armhf.deb ...
Unpacking libuv1:armhf (1.18.0-3~bpo9+1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_8.11.1~dfsg-2~bpo9+1_armhf.deb ...
Unpacking nodejs (8.11.1~dfsg-2~bpo9+1) ...
Selecting previously unselected package nodejs-doc.
Preparing to unpack .../nodejs-doc_8.11.1~dfsg-2~bpo9+1_all.deb ...
Unpacking nodejs-doc (8.11.1~dfsg-2~bpo9+1) ...
Setting up nodejs-doc (8.11.1~dfsg-2~bpo9+1) ...
Setting up libuv1:armhf (1.18.0-3~bpo9+1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up libc-ares2:armhf (1.14.0-1~bpo9+1) ...
Setting up libhttp-parser2.8:armhf (2.8.1-1~bpo9+1) ...
Setting up nodejs (8.11.1~dfsg-2~bpo9+1) ...
update-alternatives: using /usr/bin/nodejs to provide /usr/bin/js (js) in auto mode
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Version actuelle : v8.11.1
/var/www/html/plugins/Zibasedom/resources/nodejs.sh: line 59: npm: command not found
sudo: npm: command not found
sudo: npm: command not found
chmod: cannot access 'bridge': No such file or directory
sudo: npm: command not found
sudo: npm: command not found
sudo: npm: command not found
Fin de l'installation

enguerrand
Timide
Messages : 11
Inscription : 24 août 2018, 19:40

Re: Zibase : ZiBASEDOM

Message par enguerrand » 07 oct. 2018, 09:41

Bonjour,
Toujours pas de solution?
Est-ce que le plugin jeebase peut remplacer zibasedom ?

djiwhy
Timide
Messages : 45
Inscription : 28 sept. 2017, 17:58

Re: Zibase : ZiBASEDOM

Message par djiwhy » 09 oct. 2018, 20:25

bonjour
à la lecture de ces posts, j'ai switché sur jeebase qui fait le job à part la remontée des scénarios.
Par contre faut tout reparaméter ce qui n'est pas rien selon l'install.

matthieu51
Timide
Messages : 16
Inscription : 10 déc. 2017, 09:21
Contact :

Re: Zibase : ZiBASEDOM

Message par matthieu51 » 09 oct. 2018, 21:32

La clef Rfplayer fait le job à la perfection, voir plus, parrot et anti-brouilleur. Passez le cap des 129 euro max pour la tranquilité.
clef zwave couplé aux rfplayer remplace largement la malheureuse zibase lite

Viald
Timide
Messages : 401
Inscription : 21 juil. 2014, 00:09

Re: Zibase : ZiBASEDOM

Message par Viald » 22 oct. 2018, 10:28

scanab a écrit :
10 sept. 2018, 13:56
Bonjour
Ma situation personnelle ne me permet effectivement plus de me consacrer à la domotique comme je l'ai fait auparavant et j'en suis désolé...
Actuellement, je suis incapable de dire quand et si je pourrais y reconsacrer un temps suffisant.
Si quelqu'un peut me donner les modifications à apporter au plugin pour les problème d'installation, je les intégrerais.

Envoyé de mon SM-A520F en utilisant Tapatalk
Hello, c'est un peu raide comme réponse pour un plugin qui était payant. Ce serait légitime d'apporter une dernière fois les corrections nécessaires pour les personnes qui t'ont fait confiances, qu'elles aient le temps de se retourner vers une autre solution.

Les logs des dépendances.

Code : Tout sélectionner

Début de l'installation
Version actuelle : v8.12.0
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Le paquet « npm » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  nodejs*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 60,6 Mo d'espace disque seront libérés.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 64695 fichiers et répertoires déjà installés.)
Suppression de nodejs (8.12.0-1nodesource1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Utilisation du dépot officiel

================================================================================
================================================================================

                              DEPRECATION WARNING                            

  Node.js 5.x is no longer actively supported!

  You will not receive security or critical stability updates for this version.

  You should migrate to a supported version of Node.js as soon as possible.
  Use the installation script that corresponds to the version of Node.js you
  wish to install. e.g.

   * https://deb.nodesource.com/setup_8.x — Node.js 8 LTS "Carbon" (recommended)
   * https://deb.nodesource.com/setup_10.x — Node.js 10 Current

  Please see https://github.com/nodejs/Release for details about which
  version may be appropriate for you.

  The NodeSource Node.js distributions repository contains
  information both about supported versions of Node.js and supported Linux
  distributions. To learn more about usage, see the repository:
    https://github.com/nodesource/distributions

================================================================================
================================================================================

Continuing in 20 seconds ...

## Installing the NodeSource Node.js 5.x repo...


## Populating apt-get cache...

+ apt-get update
Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Atteint:2 http://archive.raspberrypi.org/debian stretch InRelease
Atteint:3 https://deb.nodesource.com/node_8.x stretch InRelease
Lecture des listes de paquets…

## Confirming "stretch" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_5.x/dists/stretch/Release'

## Your distribution, identified as "stretch", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support

Lecture des listes de paquets…
Construction de l'arbre des dépendances…

Lecture des informations d'état…
Les NOUVEAUX paquets suivants seront installés :
  nodejs
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin : 
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/12,3 Mo dans les archives.
Après cette opération, 60,6 Mo d'espace disque supplémentaires seront utilisés.
Sélection du paquet nodejs précédemment désélectionné.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 61210 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nodejs_8.12.0-1nodesource1_armhf.deb ...
Dépaquetage de nodejs (8.12.0-1nodesource1) ...
Paramétrage de nodejs (8.12.0-1nodesource1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Version actuelle : v8.12.0
npm ERR! As of npm@5, the npm cache self-heals from corruption issues and data extracted from the cache is guaranteed to be valid. If you want to make sure everything is consistent, use 'npm cache verify' instead. On the other hand, if you're debugging an issue with the installer, you can use `npm install --cache /tmp/empty-cache` to use a temporary cache instead of nuking the actual one.
npm ERR! 
npm ERR! If you're sure you want to delete the entire cache, rerun this command with --force.

npm ERR! A complete log of this run can be found in:
npm ERR!     /var/www/.npm/_logs/2018-10-22T08_20_58_448Z-debug.log
npm ERR! As of npm@5, the npm cache self-heals from corruption issues and data extracted from the cache is guaranteed to be valid. If you want to make sure everything is consistent, use 'npm cache verify' instead. On the other hand, if you're debugging an issue with the installer, you can use `npm install --cache /tmp/empty-cache` to use a temporary cache instead of nuking the actual one.
npm ERR! 
npm ERR! If you're sure you want to delete the entire cache, rerun this command with --force.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2018-10-22T08_21_00_640Z-debug.log
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.
up to date in 3.678s
found 0 vulnerabilities

chmod: impossible d'accéder à 'bridge': Aucun fichier ou dossier de ce type
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ string@3.3.3
added 1 package from 1 contributor and audited 1 package in 2.458s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ request@2.88.0
added 47 packages from 58 contributors and audited 63 packages in 9.524s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ xml2js@0.4.19
added 3 packages from 48 contributors and audited 188 packages in 5.561s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
Fin de l'installation
Jeedom 3.2.x / RPI 3 [Alcatel OneTouch X220L + Zibase + Milight + Aeotec Z-Stick S5 + Bluetooth + RFXCom]

matthieu51
Timide
Messages : 16
Inscription : 10 déc. 2017, 09:21
Contact :

Re: Zibase : ZiBASEDOM

Message par matthieu51 » 22 oct. 2018, 12:57

C'est bien le problème des plugins non officiels : pas d'assurance d'être maintenus, c'est bien dommage pour la communauté. On peut comprendre les devs mais aussi ceux qui ont payés. Le plugin aurait dû resté gratuit...

Avatar de l’utilisateur
mbuffat69
Timide
Messages : 384
Inscription : 02 févr. 2016, 21:25
Localisation : Lyon

Re: Zibase : ZiBASEDOM

Message par mbuffat69 » 22 oct. 2018, 15:44

Attention !!

la solution jeedom est une solution ouverte, qui évolue sans arrêt. Cela a ses avantages et ses inconvénients !!

Un développeur de pluggin fait un développement à un instant donné, pour un système et une configuration donnée.
et Il corrige les bugs sur cette config.

Et Je tiens à remercier scanab pour son travail en particulier sur le plugin ZIbase, qui m'a permis de passer à Jeedom, tout en conservant ma vénérable Zibase.

Par contre , on ne peut pas demander à un développeur d'assurer at vitam le portage de son travail sur les nouvelles versions, même si le plugin était payant.

J'utiilse chez moi une Zibase, qui fonctionne très bien depuis 4 ans, n'a jamais eu de mise ajour (et n'évolue donc pas). Une ancienne version de jeedom avec le plugin Zibasedom fonctionnerait de même sans problème mais sans évolution possible!!!!

Si on fait évoluer sa configuration jeedom, il faut accepter que dans certains cas cela puisse entraîner des problèmes.

C'est d’ailleurs ce qui m'est arrivé, puisque j'ai du passer sous stretch (raspbian 9), et la effectivement la compilation de Zibasedom plante.
Ayant accès aux sources (vive l'open source même si le pluggin est payant), on peut comprendre que c'est encore du au problème de version de nodejs ( :evil: ): le plugin n'accepte pas la dernière version de nodejs 8_x ou 10_x.

Ma solution: forcer l'installation sous stretch de node_js 6_x (6.14) et cela fonctionne très bien :D !!

Je peut donc continuer à utiliser ma vénérable Zibase (pour mes volets) avec la dernière version de jeedom , (mais aussi homeassistant)

Encore merci aux devs (et en particulier dans ce cas a scanab)
Système DIY PI + Orange Plus (voir mon profil pour le détail)

mecano91
Actif
Messages : 752
Inscription : 30 sept. 2014, 20:41
Localisation : Paris, France

Re: Zibase : ZiBASEDOM

Message par mecano91 » 22 oct. 2018, 16:31

Viald a écrit :
scanab a écrit :
10 sept. 2018, 13:56
Bonjour
Ma situation personnelle ne me permet effectivement plus de me consacrer à la domotique comme je l'ai fait auparavant et j'en suis désolé...
Actuellement, je suis incapable de dire quand et si je pourrais y reconsacrer un temps suffisant.
Si quelqu'un peut me donner les modifications à apporter au plugin pour les problème d'installation, je les intégrerais.

Envoyé de mon SM-A520F en utilisant Tapatalk
Hello, c'est un peu raide comme réponse pour un plugin qui était payant. Ce serait légitime d'apporter une dernière fois les corrections nécessaires pour les personnes qui t'ont fait confiances, qu'elles aient le temps de se retourner vers une autre solution.

Les logs des dépendances.

Code : Tout sélectionner

Début de l'installation
Version actuelle : v8.12.0
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Le paquet « npm » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  nodejs*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 60,6 Mo d'espace disque seront libérés.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 64695 fichiers et répertoires déjà installés.)
Suppression de nodejs (8.12.0-1nodesource1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Utilisation du dépot officiel

================================================================================
================================================================================

                              DEPRECATION WARNING                            

  Node.js 5.x is no longer actively supported!

  You will not receive security or critical stability updates for this version.

  You should migrate to a supported version of Node.js as soon as possible.
  Use the installation script that corresponds to the version of Node.js you
  wish to install. e.g.

   * https://deb.nodesource.com/setup_8.x — Node.js 8 LTS "Carbon" (recommended)
   * https://deb.nodesource.com/setup_10.x — Node.js 10 Current

  Please see https://github.com/nodejs/Release for details about which
  version may be appropriate for you.

  The NodeSource Node.js distributions repository contains
  information both about supported versions of Node.js and supported Linux
  distributions. To learn more about usage, see the repository:
    https://github.com/nodesource/distributions

================================================================================
================================================================================

Continuing in 20 seconds ...

## Installing the NodeSource Node.js 5.x repo...


## Populating apt-get cache...

+ apt-get update
Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Atteint:2 http://archive.raspberrypi.org/debian stretch InRelease
Atteint:3 https://deb.nodesource.com/node_8.x stretch InRelease
Lecture des listes de paquets…

## Confirming "stretch" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_5.x/dists/stretch/Release'

## Your distribution, identified as "stretch", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support

Lecture des listes de paquets…
Construction de l'arbre des dépendances…

Lecture des informations d'état…
Les NOUVEAUX paquets suivants seront installés :
  nodejs
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin : 
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/12,3 Mo dans les archives.
Après cette opération, 60,6 Mo d'espace disque supplémentaires seront utilisés.
Sélection du paquet nodejs précédemment désélectionné.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 61210 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nodejs_8.12.0-1nodesource1_armhf.deb ...
Dépaquetage de nodejs (8.12.0-1nodesource1) ...
Paramétrage de nodejs (8.12.0-1nodesource1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Version actuelle : v8.12.0
npm ERR! As of npm@5, the npm cache self-heals from corruption issues and data extracted from the cache is guaranteed to be valid. If you want to make sure everything is consistent, use 'npm cache verify' instead. On the other hand, if you're debugging an issue with the installer, you can use `npm install --cache /tmp/empty-cache` to use a temporary cache instead of nuking the actual one.
npm ERR! 
npm ERR! If you're sure you want to delete the entire cache, rerun this command with --force.

npm ERR! A complete log of this run can be found in:
npm ERR!     /var/www/.npm/_logs/2018-10-22T08_20_58_448Z-debug.log
npm ERR! As of npm@5, the npm cache self-heals from corruption issues and data extracted from the cache is guaranteed to be valid. If you want to make sure everything is consistent, use 'npm cache verify' instead. On the other hand, if you're debugging an issue with the installer, you can use `npm install --cache /tmp/empty-cache` to use a temporary cache instead of nuking the actual one.
npm ERR! 
npm ERR! If you're sure you want to delete the entire cache, rerun this command with --force.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2018-10-22T08_21_00_640Z-debug.log
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.
up to date in 3.678s
found 0 vulnerabilities

chmod: impossible d'accéder à 'bridge': Aucun fichier ou dossier de ce type
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ string@3.3.3
added 1 package from 1 contributor and audited 1 package in 2.458s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ request@2.88.0
added 47 packages from 58 contributors and audited 63 packages in 9.524s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
npm WARN saveError ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/var/www/html/plugins/Zibasedom/node/package.json'
npm WARN node No description
npm WARN node No repository field.
npm WARN node No README data
npm WARN node No license field.

+ xml2js@0.4.19
added 3 packages from 48 contributors and audited 188 packages in 5.561s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
Fin de l'installation
Un peu raide comme réponse.
Les développeurs sont bénévole et doivent déjà maintenir un fragile équilibre entre vie privée et professionnels en plus ils sacrifient leurs temps libre pour crée ses plugin qui ne leurs rapportent quasiment rien au vu du temps passé surtout que le cout du plugin et le prix d'achat et et non pas le prix du sav qui plus est comme indiqué ci-dessus est dépendant non seulement des évolutions du produits qu'il permets de connecter mais aussi de celle de jeedom
Une team de développeur c'est créé pour palier à se genre de souci mais suite à des incidents elles a été banni de jeedom qui a alors créé un statut spécifique pour prendre en charge se genre de cas mais vu le faible nombre d'employé il ne peuvent pas à la fois améliorer et maintenir jeedom et les plugin officiel et les autre en même temps

Envoyé de mon ASUS_Z016D en utilisant Tapatalk


Viald
Timide
Messages : 401
Inscription : 21 juil. 2014, 00:09

Re: Zibase : ZiBASEDOM

Message par Viald » 22 oct. 2018, 17:42

Le bénévolat n'exclue pas les responsabilités. Un bénévole rentre dans l'équation de la stabilité d'un écosystème qu'il soit celui du développement ou de tout autre système. Je suis sapeur pompier bénévole, je ne peux pas m'exclure du groupe du jour au lendemain sans crier gare. Et c'est justement ce que je reproche içi. Si Scanab n'a effectivement plus la possibilité d'accorder du temps au groupe ou à ses propres développements, il aurait fallu prévenir la communauté pour que nous puissions anticiper ce genre de problème. Là une fois de plus, celui qui est dos au mur c'est l'utilisateur, qu'il est financièrement contribué ou pas au projet.
Jeedom 3.2.x / RPI 3 [Alcatel OneTouch X220L + Zibase + Milight + Aeotec Z-Stick S5 + Bluetooth + RFXCom]

Avatar de l’utilisateur
mbuffat69
Timide
Messages : 384
Inscription : 02 févr. 2016, 21:25
Localisation : Lyon

Re: Zibase : ZiBASEDOM

Message par mbuffat69 » 23 oct. 2018, 00:08

attention c'est encore une incompréhension du système de développement logiciel open-source !!!
nous ne sommes pas das ce cas dans une situation vendeur / utilisateur !!
Nous disposons des sources, donc en cherchant on peut trouver des solutions et nous ne sommes pas dos au mur !!!
Dans ton cas , je t'ai fournis une solution:

installe la version nodejs 6.14
avec par exemple

Code : Tout sélectionner

apt-get install nodejs=6.14.4-1nodesource1
Système DIY PI + Orange Plus (voir mon profil pour le détail)

Avatar de l’utilisateur
Nebz
Actif
Messages : 3866
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: Zibase : ZiBASEDOM

Message par Nebz » 23 oct. 2018, 07:46

Bonjour,

La situation est en discussion dans le portail développeurs. Merci de ne pas faire de plan sur la comète !

Attention aussi aux manipulation "à la main" qui risquent de poser problèmes à d'autres plugins qui utilisent nodejs également !

(La "norme" définie entre dev est la v8. car c'est la LTS donc la plus stable et supportée actuellement. Donc les autres plugins vont "upgrader" en V8 s'ils en ont besoin, ce qui rendra ce plugin instable et créera une sorte de yoyo s'il réinstalle nodejs en v5 après. Ce n'est donc pas une situation viable)
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
lionelb
Timide
Messages : 138
Inscription : 12 févr. 2018, 22:38
Contact :

Re: Zibase : ZiBASEDOM

Message par lionelb » 05 nov. 2018, 16:14

Comme beaucoup de monde ici j'ai utilisé un plugin pour passer de la ZiBase à Jeedom en douceur.
La ZiBase n'étant plus maintenue, notamment du coté des serveurs indispensables à sa configuration, il m'est rapidement apparu que par soucis de fiabilité il était évident qu'il ne fallait pas continuer à l'utiliser, même via un plugin. J'ai donc basculé sur Jeedom avec un RFPLayer (dont le couple qu'il forme avec son plugin est discutable) afin de parvenir à une solution a peu près stable.

Que faire de la ZiBase ensuite ?

La ZiBase avait pour elle une fonctionnalité très intéressante : ses voyants. Ces 5 leds pouvaient s’activer par scénario et ainsi apporter une information visuelle instantanée. Sous Jeedom il n’y a pas de voyants et j’avoue que ça manque. Alors j’ai cherché des afficheurs, il y a bien sur des choses toutes faites comme Lametric qui vaut un bras ou des solutions DIY qui imposent le fer à souder, ce dont je n’ai pas envie. Et puis en réfléchissant je me suis dit qu’il devait être possible de recycler la ZiBase désormais éteinte, puisqu’on peut la commander via une url… Et que de toute façon il était inutile de la coller sur le boncoin !

J'ai fait un petit tuto ici https://www.canaletto.fr/post/jeedom-recycler-sa-zibase
www.canaletto.fr
Pi3 / RFPlayer / Zigate / Visonic / Oregon / Chacon / Tuya / X2D / Xiaomi / Unifi / VMWare ESXi / Kodi / Emby / HD HomeRun & more...

franck69570
Timide
Messages : 18
Inscription : 02 mars 2016, 10:47

Re: Zibase : ZiBASEDOM

Message par franck69570 » 18 nov. 2018, 13:09

Bonjour,

Avez-vous trouvé une solution ? Je viens de réinstaller mon jeedom et j'ai du coup le même problème : nodejs en v8 et les dépendances qui ne veulent pas s'installer ...

Répondre

Revenir vers « [Plugin Tiers] Zibasedom »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité