Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

problème restauration

Répondre
domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

problème restauration

Message par domoluc » 20 mars 2018, 23:03

bonsoir,
j'espère que quelqu'un va me lire et me répondre ...
je galère dans la restauration car mon SDD m'a planté. Je l'ai remplacé par une SD.
Jeedom a démarré mais ensuite, impossible de faire la restauration.
j'ai réappliqué les droits, corrigé l'erreur sur le fichier temp (selon le tuto)
et j'ai toujours ce message d'erreur quand je veux faire la restauration :
[START RESTORE]
***************Start of Jeedom restoration 2018-03-20 22:59:14***************
Send begin restoration event...OK
Check rights...
OK
File use for restoration : /var/www/html/core/class/../../backup/backup-J1-3.1.7-2018-03-20-02h49.tar.gz
Backup databse acces configuration...Can not copy /var/www/html/install/../core/config/common.config.php
OK
Disable all task OK
Disable all scenario OK
Decompression of backup...
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
OK
Error during restoration : Cannot find backup database file : DB_backup.sqlDetails : Array
(
)
[END RESTORE ERROR]
Enable scenario : OK
Enable task : OK
PHP Fatal error: Uncaught exception 'Exception' with message 'Cannot find backup database file : DB_backup.sql' in /var/www/html/install/restore.php:134
Stack trace:
#0 {main}
thrown in /var/www/html/install/restore.php on line 134

Je suis crevé et ma famille dort sans chauffage ce soir.
Merci, Luc.

Swatmorpheus
Actif
Messages : 779
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: problème restauration

Message par Swatmorpheus » 20 mars 2018, 23:13

hmmm ça sent le backup corrompu, y'a eu un sujet il y a pas mal de temps de mémoire je sais pas s'ils ont pu récupérer leurs backups t'as essayé avec des anciens ?? car là il te manque le fichier DB_backup.sql
ici viewtopic.php?f=189&t=33498&p=581373&hi ... 27#p581373
Prod: jeedom V3.1.7 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
Test: VM virtualbox Debian 9

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 20 mars 2018, 23:31

à chaque fois que je veux envoyer une sauvegarde (j'en ai du début d'année), ça me met : impossible de déplacer le fichier temporaire.
et j'ai toujours la sauvegarde d'hier soir que j'ai essayé de restaurer au début qui ne veut pas se supprimer.

Swatmorpheus
Actif
Messages : 779
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: problème restauration

Message par Swatmorpheus » 20 mars 2018, 23:33

tu as bien les droits ?
Prod: jeedom V3.1.7 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
Test: VM virtualbox Debian 9

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 20 mars 2018, 23:43

oui, il me semble mais j'ai lu pas mal de posts et j'ai peur de mal m'y prendre en fait.
quand je suis sur Putty, je fais ce que Bosquettia a mis sur le tuto :

pour Apache2
chmod 775 -R /var/www/html
chown -R www-data:www-data /var/www/html

et j'i fiat le reste :
Erreur sur le dossier tmp
chmod 775 -R /tmp/jeedom/
chown -R www-data:www-data /tmp/jeedom/

Autre erreur
The stream or file "/var/www/html/core/class/../../log/update" could not be opened: failed to open stream: Permission denied
Aller sur la page de configuration de jeedom puis OS/DB et faites juste : chown www-data:www-data -R /var/www/html/*

puis je redémarre et je réessaie ma restauration mais toujours le problème "impossible de déplacer le fichier temporaire"

Swatmorpheus
Actif
Messages : 779
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: problème restauration

Message par Swatmorpheus » 20 mars 2018, 23:49

tu es bien connecté en root ?
Prod: jeedom V3.1.7 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
Test: VM virtualbox Debian 9

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 20 mars 2018, 23:52

quand je suis sur Putty j'ai ça :
Capture.PNG
Capture.PNG (12.67 Kio) Consulté 659 fois

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 21 mars 2018, 00:28

HELP !!!
est-ce que toutes mes sauvegardes sont corrompues ?
pourquoi ? j'utilise le plugin cloud sync pro pour les transférer sur dropbox.

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 21 mars 2018, 02:37

mes sauvegardes ne sont pas corrompues. J'ai remis celle du 15 et ça marche.
Je me suis finalement rendu compte que je n'étais pas root.
j'ai remis les droits puis redémarré. je n'arrivais pas à installer les dépendances : Jeedom n'était pas redémarré au bout de 30 minutes. J'ai remis les droits : MIRACLE ! les dépendances se sont installées et c'est reparti.
c'est bien le DIY mais à 2h du mat' c'est moyen.
Je comprendrais peut-être demain ...

Swatmorpheus
Actif
Messages : 779
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: problème restauration

Message par Swatmorpheus » 21 mars 2018, 10:42

Ah bah cool , dsl me suis endormi cette nuit ^^
tu n'avais pas mis les droits au début ?? bizarre qu'ils aient sautés
Prod: jeedom V3.1.7 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
Test: VM virtualbox Debian 9

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 21 mars 2018, 12:55

Je te remercie swatmorpheus pour tes indications qui m'ont mises sur la voie.
Je pense que mon erreur vient de la mauvaise application des droits.
D'après ce que je comprends il faut être " root" pour le faire. Ce que je n'ai pas fait au début. Et je paniquais car pas de chauffage pour les enfants. Mais à 2h30 tout est revenu.
Encore merci, luc.

Bosquetia
Actif
Messages : 6004
Inscription : 10 mai 2016, 07:54

Re: problème restauration

Message par Bosquetia » 21 mars 2018, 13:00

Le tuto sur les droits est explicite en ce qui concerne root ou sudo

esso1
Actif
Messages : 820
Inscription : 03 oct. 2017, 12:26

Re: problème restauration

Message par esso1 » 21 mars 2018, 13:34

comme tu la indiqué bosquetia

faut savoir :
pi => compte user
pi / Sudo => connexion avec droit admin
root => compte administrateur

tu te connecte en pi, et tu as à ajouter sudo devant les lignes de commande .. pour pouvoir installer ou modifier des droits.
ex
sudo chmod 775 -R /var/www/html
sudo chown -R www-data:www-data /var/www/html

c'est pas du jeedom ...
car on n'est pas tous en compte utilisateur , moi , j suis en compte root sur le miens ( Opi+2).

Swatmorpheus
Actif
Messages : 779
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: problème restauration

Message par Swatmorpheus » 21 mars 2018, 13:58

une manière de savoir si t'es en root après par ex pi@raspberry~# si t'es avec un simple user y'a pi@raspberry~$ on voit la différence avec les signe # et $
Prod: jeedom V3.1.7 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
Test: VM virtualbox Debian 9

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 21 mars 2018, 15:34

ok, merci pour vos réponses,
ce que je me rend compte c'est que pi ou pi / sudo ou root, cela ne me parle pas trop et me porte à confusion.
Je vais me pencher sur la question pour mieux comprendre tout cela quand j'aurai du temps pour mieux utiliser Jeedom.
ce que j'ai fait hier soir avant que ça marche c'est ça : j'ai tapé sudo - i pour être en root. j'ai trouvé ça sur Internet. c'est peut-être pas le pus académique mais ça marche !
Capture2.PNG
Capture2.PNG (5.96 Kio) Consulté 573 fois
l'essentiel c'est que Jeedom soit reparti et que j'ai du chauffage.
Merci, Luc.

domoluc
Timide
Messages : 189
Inscription : 14 janv. 2017, 18:19
Localisation : Saint- Étienne- du-Rouvray
Contact :

Re: problème restauration

Message par domoluc » 08 avr. 2018, 14:00

bonjour,
j'ai été obligé de faire une réinstallation de mon Jeedom principal.
je suis bien root, j'ai réappliqué les droits
j'ai envoyé ma sauvegarde dans Jeedom. Elle apparaît bien dans les sauvegardes.
quand je lance la restauration, j'ai les erreurs suivantes :

- sur le market, j'ai le DNS inactif.

- ensuite le log de la retaurtion est le suivant :

[START RESTORE]
***************Start of Jeedom restoration 2018-04-08 13:55:52***************
Send begin restoration event...OK
Check rights...OK
File use for restoration : /var/www/html/core/class/../../backup/backup-J1-3.1.7-2018-04-08-10h48 (1).tar.gz
Backup databse acces configuration...Can not copy /var/www/html/install/../core/config/common.config.php
OK
Disable all task
OK
Disable all scenario OK
Decompression of backup...
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
OK
Error during restoration : Cannot find backup database file : DB_backup.sqlDetails : Array
(
)
[END RESTORE ERROR]
Enable scenario : OK
Enable task : OK
PHP Fatal error: Uncaught Exception: Cannot find backup database file : DB_backup.sql in /var/www/html/install/restore.php:134
Stack trace:
#0 {main}
thrown in /var/www/html/install/restore.php on line 134

Qu'est-ce que j'ai (encore) raté pour que ça ne fonctionne pas.
Merci, luc.

Répondre

Revenir vers « Backup/Restauration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités