Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

résolu : Mise en place HTTPS -> plus d'accès Web - SSH->OK

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
faber
Timide
Messages : 49
Inscription : 28 sept. 2015, 17:15

résolu : Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par faber » 15 févr. 2018, 23:18

Bonsoir,

J'ai installé le HTTPS sur ma jeedom sur raspberry en suivant le tuto suivant :
https://jeedom.github.io/documentation/ ... place.html

Tout a semlbé bien fonctionné, y compris Telegram !
Sauf qu'après un redemarrage du Raspberry, je n'ai plus la main en web même sur l'IP local a ma Jeedom.
J'ai toujours le main en SSH !
J'ai cherché pas mal de chose, mais je n'arrive toujours pas à me connecter en Web !

Quelqu'un a une idée ?
Merci

Faber
Dernière édition par faber le 19 févr. 2018, 15:15, édité 1 fois.

Bosquetia
Actif
Messages : 6004
Inscription : 10 mai 2016, 07:54

Re: Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par Bosquetia » 15 févr. 2018, 23:48

Hello,

En ssh vérifier qu'apache est démarré, si pas le démarrer, si souci donner le log

faber
Timide
Messages : 49
Inscription : 28 sept. 2015, 17:15

Re: Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par faber » 16 févr. 2018, 09:40

Bonjour,

OK, merci je pensais bien que ça venait de mon apache qui était planté.

Mon erreur semble venir d'une erreur lorsque j'ai modifié le fichier suivant :
/etc/apache2/sites-available/000-default-le-ssl.conf

dans la procédure il est dit :
Note

Si vous utilisez la méthode de renouvellement automatique ci-dessous, vous pouvez désactiver le virtualHost default-ssl.conf avec la commande a2dissite default-ssl.conf Pensez à reporter le code par défaut ci-dessous dans le virtualHost créé par le script de renouvellement : /etc/apache2/sites-available/000-default-le-ssl.conf`

<FilesMatch "\.(cgi|shtml|phtml|php)$">
SSLOptions +StdEnvVars
</FilesMatch>
<Directory /usr/lib/cgi-bin>
SSLOptions +StdEnvVars
</Directory>
</VirtualHost>
j'ai donc ajouté ça au fichier telle qu'elle, est ce bien ça ?
ça donne ça au finale dans le fichier:


<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error

ServerName mondomaine.com
SSLCertificateFile /etc/letsencrypt/live/mondomaine.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mondomaine.com/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
</IfModule>

<FilesMatch "\.(cgi|shtml|phtml|php)$">
SSLOptions +StdEnvVars
</FilesMatch>
<Directory /usr/lib/cgi-bin>
SSLOptions +StdEnvVars
</Directory>
</VirtualHost>
Est ce que j'ai bon ?

Avatar de l’utilisateur
tomdom
Actif
Messages : 687
Inscription : 14 nov. 2016, 05:46

Re: Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par tomdom » 16 févr. 2018, 13:53

Bonjour,

Ton fichier doit ressemblé à ça :

Code : Tout sélectionner

<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error

ServerName mondomaine.com
SSLCertificateFile /etc/letsencrypt/live/mondomaine.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mondomaine.com/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
<FilesMatch "\.(cgi|shtml|phtml|php)$">
SSLOptions +StdEnvVars
</FilesMatch>
<Directory /usr/lib/cgi-bin>
SSLOptions +StdEnvVars
</Directory>
</VirtualHost>
</IfModule>
Il y a 10 catégories de personnes, celles qui connaissent le binaire et les autres
.

faber
Timide
Messages : 49
Inscription : 28 sept. 2015, 17:15

Re: Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par faber » 19 févr. 2018, 15:15

Merci, c'est nickel !
j'ai réadapté le fichier et ça marche.

Avatar de l’utilisateur
stapsien
Timide
Messages : 121
Inscription : 27 févr. 2015, 12:35
Localisation : Groslay

Re: résolu : Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par stapsien » 09 nov. 2018, 03:13

Bonjour a tous

Suite a une tentative de mise en place HTTPS j'ai mis le bazard et je n'arrive plus a accéder a ma page jeedom via le navigateur .
Ma connexion en SSH est fonctionnelle. JE pense que cela vient du server apache que je n'arrive pas a demarrer .

Voici le log a la commande sudo /etc/init.d/apache2 restart

------------------------------
[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
failed!
------------------------------

si je fais sudo systemctl status apache2.service j'obtient

-------------------------------
● apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset:
Drop-In: /etc/systemd/system/apache2.service.d
└─privatetmp.conf
Active: failed (Result: exit-code) since Fri 2018-11-09 02:07:17 UTC; 1min 33
Process: 15013 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAIL

Nov 09 02:07:17 raspberrypi systemd[1]: Starting The Apache HTTP Server...
Nov 09 02:07:17 raspberrypi apachectl[15013]: AH00526: Syntax error on line 9 of
Nov 09 02:07:17 raspberrypi apachectl[15013]: SSLCertificateFile: file '/etc/let
Nov 09 02:07:17 raspberrypi apachectl[15013]: Action 'start' failed.
Nov 09 02:07:17 raspberrypi apachectl[15013]: The Apache error log may have more
Nov 09 02:07:17 raspberrypi systemd[1]: apache2.service: Control process exited,
Nov 09 02:07:17 raspberrypi systemd[1]: Failed to start The Apache HTTP Server.
Nov 09 02:07:17 raspberrypi systemd[1]: apache2.service: Unit entered failed sta
Nov 09 02:07:17 raspberrypi systemd[1]: apache2.service: Failed with result 'exi
lines 1-16/16 (END)
-----------------------------------
Quelqu'un a t il une idée qui me permettrait de rétablir mon accès a jeedom ?

Merci d'avance pour votre aide

stapsien
Jeedom 2.3 sur Raspi 3
Protocoles|Zwave|Rfxcom
Aeotec Z-Stick S2 | RFXtrx433E | Multiprise Greenwave *3 | Fibaro Motion sensor * 6 | Fibaro Wall Plug | Zipato RGBW | 8 détecteurs de fumée Fibaro FGSD-002

Mific91
Timide
Messages : 47
Inscription : 18 sept. 2017, 21:15

Re: résolu : Mise en place HTTPS -> plus d'accès Web - SSH->OK

Message par Mific91 » 11 nov. 2018, 07:39

Quel est le résultat de la commande suivante :

Code : Tout sélectionner

sudo apachectl configtest

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités