Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Modbus RTU

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
poupoune1974
Timide
Messages : 130
Inscription : 27 juil. 2015, 18:28

Re: Modbus RTU

Message par poupoune1974 » 17 juin 2019, 11:33

Rebonjour,
J'ai un gros doute sur mon plugin que j'utilise : j'ai en fait un boitier USR qui est relié à ma chaudière d'un côté, et de l'autre à mon réseau en RJ45.
Quel plugin dois-je utiliser ? Celui intitulé Modbus, ou celui intitulé modbus RTU.
Je n'y comprends plus rien ....
Car ni l'un ni la'autre ne me permettent de communiquer avec ma DDietrich.
Merci pour vos conseils.
Jeedom sur Rpi2
Noeuds Mysensors:
- Citerne eau de pluie
- Relais lumières
- Pollution, température, humidité
- Arrosage extérieur
- Consommation électrique
H801 : Leds RGBW

looping
Timide
Messages : 142
Inscription : 30 avr. 2017, 11:31
Localisation : Lot (46)

Re: Modbus RTU

Message par looping » 17 juin 2019, 11:56

Ici on est sur le fil du plugin modbus rtu. C'est celui que j'utilise sur ma chaudière (sans réseau) et qui fonctionne parfaitement

poupoune1974
Timide
Messages : 130
Inscription : 27 juil. 2015, 18:28

Re: Modbus RTU

Message par poupoune1974 » 22 juin 2019, 16:38

Ok merci,
J'ai tenté d'ouvrir un ticket pour qu'on me réactive l'autre plugin (non rtu). Sans succès.
On m'a désactivé l'autre plugin pour que je puisse tester celui-ci.
Du coup je suis coincé.
Jeedom sur Rpi2
Noeuds Mysensors:
- Citerne eau de pluie
- Relais lumières
- Pollution, température, humidité
- Arrosage extérieur
- Consommation électrique
H801 : Leds RGBW

Avatar de l’utilisateur
philmo
Timide
Messages : 67
Inscription : 24 janv. 2018, 02:07

Re: Modbus RTU

Message par philmo » 04 juil. 2019, 17:57

Bonjour,
je suis en réflexion sur les possibilités de pilotage de climatiseurs Mitsubishi. Est-ce que vous auriez d'éventuels retours d'expérience de pilotage de climatisations en modbus ? C'est généralement standard ou c'est plein de particularités constructeurs ?
philmo

reimsois
Timide
Messages : 34
Inscription : 23 avr. 2017, 14:49

Re: Modbus RTU

Message par reimsois » 04 juil. 2019, 21:02

No Lan a écrit :
16 juin 2019, 13:01
Super affichage.
Je suis vraiment un novice sur jeedom comment fais tu pour régler la consigne? tu ne passes pas par une action ?
As tu des conseils où un petit tuto.


Envoyé de mon SM-J600FN en utilisant Tapatalk
Salut,

perso, j'ai demarre par un virtuel par source de chauffe (radiateur et plancher). Pour chaque virtuel, il est possible de configurer des temperatures Jour et Nuit.
Lors d'une modification, j'ai un scenario qui lance une commande "action" du plugins Modbus RTU avec la consigne de temperature modifiée en paramètre (cmd : recherche équipement). Cela fonctionne sans probleme.

NOTA : j'ai la table complete fournie par le support De Dietrich. Par contre si quelqu'un à la valeur pour modifier la temperature de consigne du plancher en mode rafraichissant, je suis preneur. Tout comme reussir à recuperer les index de fonctionnement (cycle et heures).

NOTA 2 : La MAJ du 03/06 ne fonctionne pas.

Christophe

No Lan
Timide
Messages : 5
Inscription : 09 juin 2019, 09:07

Re: Modbus RTU

Message par No Lan » 07 juil. 2019, 10:54

Bonjour et merci Reimsois,
Je pense que la version MOBDUS RTU 03/06 ne fonctionne pas, seul la lecture des registres fonctionne.
,[img]C:\capture.jpg[/img]
dans "parametres" il n'y a aucun emplacement ou je peux mettre une consigne avec un type ACTION COIL .Est ce que vous confirmer ?

question : comment obtenir l'ancienne version du plugin.
Pièces jointes
Capture.JPG
Capture.JPG (63.88 Kio) Consulté 353 fois

reimsois
Timide
Messages : 34
Inscription : 23 avr. 2017, 14:49

Re: Modbus RTU

Message par reimsois » 07 juil. 2019, 11:57

Bonjour,

dsl, je ne sais repondre à aucune de tes questions !

Christophe

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 18 août 2019, 00:55

Bonjour @Loic,

Est-ce que Jeedom a prévu de s'occuper des plugins Modbus RTU et Modbus RTC?
Modbus RTU, pour que les dépendances s'installent, il faut lancer je ne sais pas quelles commandes manuellement.
Modbus TCP, c'est abandonné depuis un paquet de temps. Certains l'utilise en mode RTU (en modifiant un fichier de conf) car ils n'arrivent à rien avec celui-ci (Modbus RTU).

La communication en Modbus est tout de même bien sympa. Cela offre pas mal de possibilités.
C'est dommage de laisser mourir ces plugins.

Pour ma part (et plusieurs sont dans la même situation), j'arrive à récupérer des valeurs via une interface en PHP mais rien avec ces modules.

Et si besoin de personnes pour faire des essais, ce n'est pas un problème ;)

joviel
Timide
Messages : 1
Inscription : 20 août 2019, 22:27

Re: Modbus RTU

Message par joviel » 20 août 2019, 22:48

Bonjour,
Je pense comme Kyoshi que c'est indispensable que Jeedom possède les plugin Modbus RTU et TCP. Je commence juste à utiliser Jeedom et je ne pensais même pas rencontrer une difficulté pour échanger en Modbus. Je suis donc preneur pour toute solution qui me permettra de communiquer avec des entrées/sorties filaires raccordés à des modules communiquant en Modbus. Mon problème immédiat est de superviser au moins 60 capteurs ILS installés sur des ouvrants et des volets. D'autre part si cela peut encore intéresser quelqu'un, j'ai des informations techniques et le programme du pseudo Modbus écrit (et éprouvé) en langage automate pour communiquer avec une chaudière De Dietrich avec la signification des data lues.

reimsois
Timide
Messages : 34
Inscription : 23 avr. 2017, 14:49

Re: Modbus RTU

Message par reimsois » 21 août 2019, 06:14

Bonjour,

J utilise actuellement le plugins ModBus RTU en bêta avec une Pac De Dietrich et suis donc vraiment en attente d une solution pérenne.
@joviel: je suis preneur des infos à ta dispo.

Christophe

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 21 août 2019, 07:49

Si seulement, on avait un retour de quelqu'un de Jeedom... @marie ? Peut-être une réponse de ta part vu que @loic ne semble vouloir faire aucun retour (sauf si je me trompe et que le fait de taguer un pseudo avec "@" n'affiche pas de notifications).

Pour ma part, j'ai déjà les tableaux de correspondance de ma chaudière. Mais merci @joviel ;)

Avatar de l’utilisateur
Dams
Helper
Messages : 877
Inscription : 16 sept. 2014, 08:06
Localisation : Annecy

Re: Modbus RTU

Message par Dams » 22 août 2019, 08:08

J'ai posé la question aux principaux intéressés.
Je vous tiens au courant dès que j'ai la réponse
Helper Officiel Jeedom
Merci à l'équipe pour le job !!
Trucs & Astuces I Documentation Jeedom

looping
Timide
Messages : 142
Inscription : 30 avr. 2017, 11:31
Localisation : Lot (46)

Re: Modbus RTU

Message par looping » 22 août 2019, 08:35

Il me semble que ca a déjà été fait.. sans succès. perso le plugin fonctionne bien chez moi apres de grosses galères pour l'installer (il manquait des choses dans mon linux, je ne sais plus quoi.... et comme je n'y connais rien.... )

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 22 août 2019, 09:06

Dams a écrit :
22 août 2019, 08:08
J'ai posé la question aux principaux intéressés.
Je vous tiens au courant dès que j'ai la réponse
Merci! ;)

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 22 août 2019, 13:31

Hello,

Je rebascule (le plugin Modbus TCP s'installe et dialogue avec mon convertisseur mais aucun retour probant) sur ce plugin pour tenter de le faire fonctionner mais j'ai un souci avec les dépendances.
Pas d'erreur lors de l'installation (ou je loupe un truc) par contre, il me dit qu'ils ne sont pas installés et retente en boucle de les installer :

Code : Tout sélectionner

********************************************************
*             Installation des dépendances             *
********************************************************

Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libffi-dev is already the newest version (3.2.1-6).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-serial is already the newest version (3.2.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
libudev-dev is already the newest version (232-25+deb9u11).
0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Package 'python-cffi' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: cffi in /usr/local/lib/python2.7/dist-packages (1.12.3)
Requirement already satisfied, skipping upgrade: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi) (2.19)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: cryptography in /usr/local/lib/python2.7/dist-packages (2.7)
Requirement already satisfied, skipping upgrade: enum34; python_version < "3" in /usr/lib/python2.7/dist-packages (from cryptography) (1.1.6)
Requirement already satisfied, skipping upgrade: asn1crypto>=0.21.0 in /usr/local/lib/python2.7/dist-packages (from cryptography) (0.24.0)
Requirement already satisfied, skipping upgrade: six>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from cryptography) (1.12.0)
Requirement already satisfied, skipping upgrade: cffi!=1.11.3,>=1.8 in /usr/local/lib/python2.7/dist-packages (from cryptography) (1.12.3)
Requirement already satisfied, skipping upgrade: ipaddress; python_version < "3" in /usr/local/lib/python2.7/dist-packages (from cryptography) (1.0.22)
Requirement already satisfied, skipping upgrade: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi!=1.11.3,>=1.8->cryptography) (2.19)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: minimalmodbus in /usr/local/lib/python2.7/dist-packages (1.0.2)
Requirement already satisfied, skipping upgrade: pyserial>=3.0 in /usr/local/lib/python2.7/dist-packages (from minimalmodbus) (3.4)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: paramiko in /usr/local/lib/python2.7/dist-packages (2.6.0)
Requirement already satisfied, skipping upgrade: pynacl>=1.0.1 in /usr/local/lib/python2.7/dist-packages (from paramiko) (1.3.0)
Requirement already satisfied, skipping upgrade: cryptography>=2.5 in /usr/local/lib/python2.7/dist-packages (from paramiko) (2.7)
Requirement already satisfied, skipping upgrade: bcrypt>=3.1.3 in /usr/local/lib/python2.7/dist-packages (from paramiko) (3.1.7)
Requirement already satisfied, skipping upgrade: six in /usr/local/lib/python2.7/dist-packages (from pynacl>=1.0.1->paramiko) (1.12.0)
Requirement already satisfied, skipping upgrade: cffi>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from pynacl>=1.0.1->paramiko) (1.12.3)
Requirement already satisfied, skipping upgrade: enum34; python_version < "3" in /usr/lib/python2.7/dist-packages (from cryptography>=2.5->paramiko) (1.1.6)
Requirement already satisfied, skipping upgrade: asn1crypto>=0.21.0 in /usr/local/lib/python2.7/dist-packages (from cryptography>=2.5->paramiko) (0.24.0)
Requirement already satisfied, skipping upgrade: ipaddress; python_version < "3" in /usr/local/lib/python2.7/dist-packages (from cryptography>=2.5->paramiko) (1.0.22)
Requirement already satisfied, skipping upgrade: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.4.1->pynacl>=1.0.1->paramiko) (2.19)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: utils in /usr/local/lib/python2.7/dist-packages (0.9.0)
********************************************************
*             Installation terminée                    *
********************************************************

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 22 août 2019, 14:33

Je précise également qu'il n'est pas possible de lancer le démon... D'ailleurs le bouton de démarrage ne s'affiche pas.
Si on lance l'installation des dépendances en ligne de commande cela ne change rien du tout.

Donc bon, quand il n'y a pas d'erreurs affichés... Trouver le problème est compliqué...

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 25 août 2019, 13:40

Dams a écrit :
22 août 2019, 08:08
J'ai posé la question aux principaux intéressés.
Je vous tiens au courant dès que j'ai la réponse
Hello,

Des news des principaux intéressés ?
J’ai de mon côté réussi à faire récupérer des valeurs avec l’auutre Plugin (viewtopic.php?f=133&t=1560&start=700#p758189).
Le problème, c’est qu’il est aussi abandonné.

Pour résumer les soucis sur ces modules :

Modbus TCP :
- Abandonné
- Certains checks empêchent de récupérer des valeurs dans certains cas

Modbus RTU :
- Abandonné
- Ne s’installe pas dans beaucoup de cas. Et il faut jouer avec les lignes de commandes. Pour ma part, je n’ai aucune erreur (cf mes logs précédemment affichés) mais il ne fonctionne pas.
- Pas de possibilité de l’utiliser avec un convertisseur RS vers Ethernet.

Je précise une chose : un convertisseur RS vers Ethernet ne fait pas forcément du Modbus TCP. La plupart ne font que du Modbus RTU over TCP et non du Modbus TCP. Et dans ce cas là, il faut utiliser un plugin qui fait du Modbus RTU avec possibilité d’indiquer une adresse IP au lieu du périphérique USB.

Donc pour ceux qui sont dans ce cas, il faut actuellement utiliser le plugin Modbus TCP et modifier un fichier pour qu’il fasse du RTU et non du TCP (c’est expliqué dans mon post).

Le must serait une fusion des deux plugins.

Si Jeedom SAS se décide à faire cela, je peux faire des tests et des retours sur ce que j’ai compris de mes différents tests. Tu peux passer le mot 😉

Aldarande
Timide
Messages : 14
Inscription : 01 mai 2018, 10:32

Re: Modbus RTU

Message par Aldarande » 05 sept. 2019, 12:00

Bonjour,

J'ai bien galéré pour arriver à installer les dependances mais j'y suis arrivé.
Je me fait une note ici qui servira, je l’espère à tous.

En ligne de commande , dans le répertoire :
/var/www/html/plugins/modbusrtu/core/class

Il y a le fichier : modbusrtu.class.php

>>> Je vous invite à le copier *.BCK au cas où... ( à faire toujours avant un changement dans les codes, d'ailleurs)
Vous trouverez la fonction suivante :

public static function dependancy_info() {
$return = array();
$return['progress_file'] = jeedom::getTmpFolder('modbusrtu') . '/dependance';
$return['state'] = 'ok';
if (exec(system::getCmdSudo() . system::get('cmd_check') . '-E "python\-serial|python\-request|python\-pyudev" | wc -l') < 3) {
$return['state'] = 'nok';
}
if (exec(system::getCmdSudo() . 'pip list | grep -E "MinimalModbus|paramiko" | wc -l') < 2) {
$return['state'] = 'nok';
}
return $return;
Je vous invite à tester la commande suivante en SSH :
pip list | grep -E "MinimalModbus|paramiko" | wc -l

Le résultat sera 1 car "MinimalModbus" n'existe pas mais "minimalmodbus", oui !

Il vous reste plus qu'à changer la chaine de caractére dans modbusrtu.class.php et "HOP" !

Kyoshi
Timide
Messages : 405
Inscription : 04 mai 2018, 14:05

Re: Modbus RTU

Message par Kyoshi » 06 sept. 2019, 14:26

Aldarande a écrit :
05 sept. 2019, 12:00
Bonjour,

J'ai bien galéré pour arriver à installer les dependances mais j'y suis arrivé.
Je me fait une note ici qui servira, je l’espère à tous.
Hello,

Bien joué!
Je reste toujours sur l'autre plugin pour ma part (que j'ai passé en mode RTU) car celui-ci ne gère que les convertisseurs USB.
Dommage qu'il ne gère pas le Modbus RTU over Ethernet (qui n'est pas du Modbus TCP).

Aldarande
Timide
Messages : 14
Inscription : 01 mai 2018, 10:32

Re: Modbus RTU

Message par Aldarande » 19 sept. 2019, 23:48

looping a écrit :
16 juin 2019, 12:50
Voila un exemple avec une valeur lue; la T° extèrieure vue par la chaudière et le réglage de la consigne de chauffage

Capture d’écran 2019-06-16 à 12.49.58.png

Et l'affichage sur mon dashboard

Capture d’écran 2019-06-16 à 12.39.53.png
Bonjour Looping,

Pourrais tu partager les captures d'écrans qui t'on permis de modifier la température de consigne, s'il te plait ?

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités