Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

Nouveau plantage Jeedom, Ras le bol

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
racouet
Timide
Messages : 195
Inscription : 01 sept. 2014, 20:16
Localisation : Mios, Gironde

Nouveau plantage Jeedom, Ras le bol

Message par racouet » 03 déc. 2018, 09:41

Bonjour à tous,

Ce matin, après une semaine de bons et loyaux services, mon jeedom, que j'ai refait de A à Z, sur un RPI3 B+ avec ssd externe est déconnecté. La semaine avant, le jeedom monté sur un RPI3 avait grillé, RPI HS, plus de connexion réseau, charge système supérieure à 4, température proche de 80 °C.. Bref, le garçon a rendu l'âme après un an et demi de bons et loyaux services.

J'ai donc entrepris de remonter un système Jeedom le 25/11 et aujourd'hui il est down. Je l'ai redémarré et il reste fonctionnel, pour le moment. Je n'ai pas d'erreur de log!!
Par contre, de ce que j'ai pu constater, hier, j'ai installé le plugin openvpn et immédiatement j'ai vu la charge system 1mn, 5mn passer à une valeur comprise entre 1 et 1.7... La charge 15mn est semble-t-il stable autour de 0.8.

Je ne fait que constater, pas de jugement et ce constat est strictement subjectif et n'appel pas à de nombreux commentaires. Le jeedm que j'ai reconstruit en partant de 0 possède les plugins zwave, xiaomi, espeasy + divers autres (moden telegram, thermostat, virtuel, widget, ...) j'ai 8 scénarios qui tournent sur évènements et non sur cron, bref un jeedom avec une config mini comparé au 39 scénarios qui toiurnaient sur mon RPI3 précédant.

Je ne suis pas un expert, mais un simple individu et ne comprends pas ces plantages.

Le ras le bol du titre ne conserne que mon état d'esprit actuel, et non le développement ou l'équipe de développement de Jeedom.

Avatar de l’utilisateur
breizh22
Actif
Messages : 1311
Inscription : 10 oct. 2015, 17:35

Re: Nouveau plantage Jeedom, Ras le bol

Message par breizh22 » 03 déc. 2018, 10:02

Peut-être qu'il te faudrait passer sur un matériel plus puisant à l'avenir. On installe de plus en plus, donc à un moment, il faut obligatoirement se poser la question et laisser tomber le RPI qui est trop light. (NUC ou NAS) avec Jeedom en VM par exemple.

Je dis cela par rapport à ton ras le bol. Perso, j'avais atteint les limites du RPI, j'ai fait le choix d'un Gen8 à l'époque, je ne le regrette pas. Mais c'est vrai que ça demande quel que soit la machine un certain investissement financier, et bien sur, là, c'est décisif aussi dans la réflexion.
HP Gen 8 / OMV4 sur SSD / Jeedom 3.3.24 VM Debian 9
RFLink - Sondes Oregon THN 132 N / THGR 122 NX / THGR 810 / THC238 - Prises DIO/Dedra/IDK.
Orvibo AllOne et S20 - Onduleur APC Back-UPS ES 700VA
Écosystème xiaomi - Dash buttons - GHome et mini.

racouet
Timide
Messages : 195
Inscription : 01 sept. 2014, 20:16
Localisation : Mios, Gironde

Re: Nouveau plantage Jeedom, Ras le bol

Message par racouet » 03 déc. 2018, 10:49

J'y pense, j'ai un Nas, mais je préfère le garder pour mes données et ne pas le polluer avec Jeedom. J'envisage l'achat d'une carte mère mini itx avec un processeur J19200 et 4 Go de ram. Cela devrait suffire. Pour le moment j'attends un orange pi, le win plus, histoire de comparer.

Je suis néanmoins surpris, je n'ai rien qui tourne sur le RPI, juste mes thermostats avec un calendrier. J'&ai viré openvpn et curieusement la charge est descendue à 0.75 pour 1mn, 0.54 pour 5mn et 0.47 poutr 15mn. Je pense effectivement qu'open vpn peut poser un problème, mais pas de log d'erreur.

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 799
Inscription : 19 oct. 2015, 19:48

Re: Nouveau plantage Jeedom, Ras le bol

Message par BaaTuuC » 03 déc. 2018, 11:36

openvpn semble être la cause. As des tentatives de connexion entrantes importantesi ? Si oui si tu subis des scans de port à répétition cela génère de la charge.
Regarde du côté du fail2ban ce que tu peux mettre en place pour le soulager.
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

racouet
Timide
Messages : 195
Inscription : 01 sept. 2014, 20:16
Localisation : Mios, Gironde

Re: Nouveau plantage Jeedom, Ras le bol

Message par racouet » 03 déc. 2018, 13:04

Je vais effectivement mettre fail2ban. Lorsque j'avais mon site web sur OVH, hébergé sur mon Nas, c'était régulier, j'avais des scans en provenance de partout, mais maintenant, que j'ai tout redirigé sur OVH, je n'en ai plus Je pense que je vais utiliser la double authentificatio et blinder le mot de passe du root et de PI

J'arrête OPENVPN, et me dirige vers une redirection via OVH et un port à la con + une redirection du port vers le Jeedom via mon router

Avatar de l’utilisateur
cadavor
Actif
Messages : 1216
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Nouveau plantage Jeedom, Ras le bol

Message par cadavor » 03 déc. 2018, 13:57

Je ne pense pas que OpenVPN soit la cause.

As-tu vérifié l'alimentation?
C'est souvent la point faible des installations Raspberry Pi.
Prendre une alimentation de qualité délivrant au moins 2 à 2.5A. Le SSD externe a-t-il une alimentation propre ou est-il alimenté par le Raspberry?

Il faudrait aussi vérifier que la température interne ne monte pas trop. Le RPI3 B+ est optimisé sur ce point contrairement à la première version.

Le RPi3 est quadcore donc ta charge système peut monter à 4 sans impact sur les performances.
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

racouet
Timide
Messages : 195
Inscription : 01 sept. 2014, 20:16
Localisation : Mios, Gironde

Re: Nouveau plantage Jeedom, Ras le bol

Message par racouet » 04 déc. 2018, 10:12

Mon alim, 5V 3A, la température ne dépasse pas 45 ° C, j'ai un dissipateur surdimensionné de 35 mm avec un ventilateur de 50 mm dessus avec alim externe. Il est possible que la charge puisse dépasser 4, mais alors pourquoi ai-je dû jeter mon RPI 3 qui avait cramé, et pourquoi le nouveau RPI 3 B+ s'arrête tout seul avec un raspbian à jour, un rpi neuf refroidit, 7 scénarios (chauffage, chauffeau et vmc)???? Et surtout avec aucune erreur dans les logs. Moi je ne sais pas et penche pour repartir sur une zibase qui elle était moche, peu aisée à appréhender mais qui fonctionnait bien sauf quand zodianet a déposé le bilan. Je me demande même si la box de Leroy... ne me dépannerai pas mieux... , mais là je rigole, je garde mon Jeedom s'il fonctionne bien.

J'aimerai juste comprendre, simplement comprendre. Un an et demi de bons et loyaux services avec un pi-drive puis plus rien et une semaine avec un nouveau rpi + ssd,... c'est just strange. J'ai fait un scan du hdd à la recherche d'erreur, ou de secteurs défectueux, rien. C'est juste le RPI qui d'un coup déconne.

Avatar de l’utilisateur
cadavor
Actif
Messages : 1216
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Nouveau plantage Jeedom, Ras le bol

Message par cadavor » 04 déc. 2018, 12:55

Le système est-il sur un onduleur?
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

pjeanne
Timide
Messages : 9
Inscription : 24 mars 2015, 14:12

Re: Nouveau plantage Jeedom, Ras le bol

Message par pjeanne » 07 déc. 2018, 11:42

Le problème peut venir du ssd qui consomme trop sur le port USB du R-Pi. As-tu une alimentation externe pour le SSD?
Perso j'ai abandonné le RPI à cause de ça.

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : jax24fr et 1 invité